Subject: Re: [Netatalk-devel] Re: Netatalk, Macos X and other issues

From: [email-masked]
Date: Fri, 13 Jul 2001 08:45:04 +0100

I'm quite happy with CVS. It's just that elusive confidence factor. Why can't
they commit? was the comment I got when my boss saw the list pre-releases on the
website.

In objective quality terms there might be no difference btn a pre and a beta,
but we're talking irrational feel-goodness here:-)

At 13/07/2001 03:33:07, Joe Clarke <[email-masked]> wrote:
#  The instructions for getting CVS to work are quite clear on the CVS page.
#
#  http://sourceforge.net/cvs/?group_id=8642
#
#  Once you download the source, you run ./autogen.sh from the source
#  directory, then configure as normal.  Perhaps a nightly CVS snapshot build
#  wouldn't be a bad idea.  I'd be happy to set this up unless there are any
#  objections.
#
#  Joe Clarke
#
#  On Thu, 12 Jul 2001, Troy R. Baldwin wrote:
#
#  > What if one does not know how to use CVS? It sure would be nice if there
were a
#  regular
#  > beta release or something we can easily compile and use.
#  >
#  > Thanks,
#  > --TRBo
#  >
#  > Joe Clarke wrote:
#  >
#  > > I submitted a patch to netatalk that "fixes" the AFP problem with opening
#  > > and copying files in OS X.  The reason I say "fixes" is that it relies on
#  > > the old DID algorithm.  I have not tried the mtab stuff yet, so I don't
#  > > know if that will work.
#  > >
#  > > Anyway, if you want OS X support with netatalk, download the CVS version
#  > > from http://sourceforge.net/cvs/?group_id=8642, and configure with the
#  > > added option --with-did=last.  You should be able to use netatalk with OS
#  > > X after that.
#  > >
#  > > The big goal I think is to find the right way to do DID calculations so
#  > > that collisions do not exist and DIDs are persistent.  If Apple wants to
#  > > contribute, that would be great.  I'm not sure if anyone else is
currently
#  > > working on the DID "Rossetta Stone."
#  > >
#  > > I'm currently working on porting AFP 3.0 to netatalk.  I have most of the
#  > > volume and directory code done.  I'm not sure how well this will work,
but
#  > > it should provide for longer filename support.
#  > >
#  > > Joe Clarke
#  > >
#  > > On Wed, 11 Jul 2001 [email-masked] wrote:
#  > >
#  > > > We tried the 1.5pre6, which is why I was trying that wacky version
there.
#  > > >
#  > > > The problem with pre6 was that it caused NFS to stop working -
authentication
#  > > > stopped working. Reverting to a previous release fixed this.
#  > > >
#  > > > I have a proper description of the problem:-
#  > > >
#  > > > <GMT17-May-2001 23:49:56GMT> B.S.:
#  > > > Problem is that netatlk is not making their fileIDs unique and the
AppleShare
#  > > > client uses those ids for its hash entries. Thats why we are hitting
the
#  assert.
#  > > > I will file a bug against netatalk and also change the AppleShare
client so
#  that
#  > > > it will not assert any more. Although anytime someone tries to do a
ResolveID
#  > > > (not too common, I think), it will get back some indeterminate file and
that
#  > > > will be bad.
#  > > >
#  > > > <GMT23-May-2001 21:31:24GMT> B.S.:
#  > > > Fix is too catch this case and not assert, but to fail the create call
with
#  some
#  > > > error. Real fix is to get an updated netatalk installed on the server.
I am
#  > > > working on getting a fixed netatalk submitted.
#  > > >
#  > > > >from here
#  > > >
#  > > >
#
http://www.publicsource.apple.com/bugs/X%20Server/AppleShare%20X%20Client/2666595.h

#  tml
#  > > >
#  > > > I can't see any bug filed anywhere on the netatalk site - that's the
first
#  place
#  > > >  I looked.
#  > > >
#  > > > Would this be fixed in pre7?
#  > > >
#  > > > Another question: why so many pre's?
#  > > >
#  > > >
#  > > >
#  > > > At 11/07/2001 16:31:48, Jeff <[email-masked]> wrote:
#  > > > #  [email-masked] wrote:
#  > > > #  > #  Which version of netatalk are you using?
#  > > > #  >
#  > > > #  > The tar file is called pre-asun2.1.4-37b.tar
#  > > > #  >
#  > > > #  > it decompresses into a directory called
#  > > > #  >
#  > > > #  > netatalk-1.4b2+asun2.1.4
#  > > > #  >
#  > > > #  > Is there a deterministic way of finding the version?
#  > > > #
#  > > > #  That's version 1.4b2+asun2.1.4. The series on sourceforge is
currently
#  > > > #  at 1.5pre6.
#  > > > #
#  > > > #  > #  > This is quite important to us as we're relying on this to try
and
#  get
#  > > > a
#  > > > #  > product
#  > > > #  > #  > out shortly.
#  > > > #  > #  >
#  > > > #  > #  > We would also like to know -who- is supporting netatalk these
days.
#  > > > I've
#  > > > #  > heard a
#  > > > #  > #  > rumour that Apple are looking for a netatalk developer.
#  > > > #  > #
#  > > > #  > #  Interesting. Currently most support seems to be via the admin
and
#  > > > #  > #  developer lists.
#  > > > #  >
#  > > > #  > This was from someone on the darwin-developers list.
#  > > > #  >
#  > > > #  > Also the lack of archive here
#  > > > http://netatalk.sourceforge.net/mailing_lists.php
#  > > > #  > for 2000/2001 does give an appearance of cobwebness to the page.
#  > > > #
#  > > > #  Sorry about that. The netatalk development is in full swing. Check
out
#  > > > #  http://sourceforge.net/projects/netatalk/ for a little more
information
#  > > > #  on that.
#  > > > #
#  > > > #  I'd suggest trying 1.5pre6 or the upcoming 1.5pre7, as it probably
#  > > > #  resolves that issue.
#  > > > #
#  > > > #  Jeff
#  > > > #
#  > > > Roger
#  > > >
#  > > >
#  > > >
#  > > > _______________________________________________
#  > > > Netatalk-devel mailing list
#  > > > [email-masked]
#  > > > http://lists.sourceforge.net/lists/listinfo/netatalk-devel
#  > > >
#  > > >
#  >
#  >
#  >
#
Roger

---

From: Jeff <[email-masked]>
Date: Fri, 13 Jul 2001 08:41:16 -0400

> but we're talking irrational feel-goodness here:-)

The 1.5 series is meant to be a solidification of Adrian's upcoming
1.4b2+asun2.1.4 version, with community patches and new build system.

The pre-releases are until 1.5 builds across all of its supported
platforms properly.

Jeff