Subject: Probably OT: netatalk + printing

From: Carsten Neumann <[email-masked]>
Date: Wed, 10 Jan 2001 03:49:58 +0100

Hi all,

I'm using netatalk (papd) to print from my Mac to a lpd printer on my linux box.
When I print from my Mac lpq shows:
	Warning: queue is not active (no server present).
When I print locally everything is fine.

If anyone can help please let me know.

Thanks

	Carsten

---

From: Michael Schmitz <[email-masked]>
Date: Wed, 10 Jan 2001 22:10:31 +0100 (CET)

> If anyone can help please let me know.

Need more details - what version of Linux is running the netatalk
package, is there anything in the syslog on that box either by papd or
lpd?

I had to adjust a few permissions on the lpd spool and the printer socket
with RedHat 6.2. I still have the disks around to look it up - we just
upgraded to RedHat 7.0 and papd stopped working altogether due to lpd
being replaced by lprng ...

	Michael

---

From: Carsten Neumann <[email-masked]>
Date: Thu, 11 Jan 2001 04:53:16 +0100

> being replaced by lprng ...

I'm running SuSE 6.3, kernel: 2.2.13, netatalk: 1.4b2+asun2.1.3-30, plp: 4.1.2-77.

There are some strange messages in /var/log/messages:
Jan 11 03:23:19 athlet papd[5733]: lp_conn_unix connect /dev/printer: Connection refused
Jan 11 03:23:19 athlet papd[5733]: lp_print: lp_conn_unix: Connection refused

None of my printers is configured with an entry containing "/dev/printer".
There is no config file with this string.

Seems to be a problem in papd: guesses it has to print to a /dev/printer device!?

Could this lead to the problem that the daemon is not started?

Seems that replacing lpd by LPRng will not solve my problem. (Thought of this try.) :-(

	Carsten

---

From: andrew morgan <[email-masked]>
Date: Wed, 10 Jan 2001 23:09:45 -0800 (PST)

> Seems that replacing lpd by LPRng will not solve my problem. (Thought of this try.) :-(

Change your papd.conf file so that it doesn't try to place the job in the
spool directory itself.  You can pipe the print job from papd to your
print software with (lpd in this example):

my_printer:\
	:pr=|/usr/bin/lpr -Plp1:

	Andy