Subject: compilation of 1.5-pre7 on redhat?

From: Harald Wagener <[email-masked]>
Date: Thu, 30 Aug 2001 13:53:55 +0200

Hello all,

I succeeded compiling netatalk-1.5-pre7 on a stock SuSE 7.2 System.
But compilation fails with varying errors on RedHat 7.x using gcc or kgcc.

Did anybody succeed in doing so, and if yes, which versions of
compiler/autotools/libtool were involved?

TIA,
	Harald

-- 
Harald Wagener      |                                Systemadministrator 
FCB/Wilkens GmbH    |                              Tel.:+49-40-2881-1252 
An der Alster 42    |                              Fax.:+49-40-2881-1263 
20099 Hamburg       |                         http://www.fcb-wilkens.com

---

From: Axel Rose <[email-masked]>
Date: Thu, 30 Aug 2001 18:47:57 +0200

>But compilation fails with varying errors on RedHat 7.x using gcc or kgcc.

No luck here too.

I spotted this when running
  $ ./configure --enable-redhat
  [cut]
  enabling redhat-style sysv support
  ./configure: acconfig.h: command not found

The doc/INSTALL file points to the main INSTALL file
which is not included in pre7.tar.gz.

What's the best way to contact developers I wonder.

Axel

---

From: "Stuart Haas" <[email-masked]>
Date: Thu, 30 Aug 2001 12:52:05 -0400

Try the developers list [email-masked]

---

From: Harald Wagener <[email-masked]>
Date: Fri, 31 Aug 2001 10:02:19 +0200

>   ./configure: acconfig.h: command not found

This particular one is due to misconfiguration of the source or because You
grabbed the initial 
archive that was put on the sf.net page for download. I get the following errors
while compiling:

# make
make  all-recursive
make[1]: Entering directory `/tmp/netatalk-1.5pre7'
Making all in libatalk
make[2]: Entering directory `/tmp/netatalk-1.5pre7/libatalk'
Making all in adouble
make[3]: Entering directory `/tmp/netatalk-1.5pre7/libatalk/adouble'
/bin/sh ../../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../..     -g
-O2 -I/usr/include -I../../include -I../../sys -I/usr/include
-I/usr/include/openssl -c ad_open.c
rm -f .libs/ad_open.lo
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -g -O2 -I/usr/include -I../../include
-I../../sys -I/usr/include -I/usr/include/openssl -c ad_open.c  -fPIC -DPIC -o
ad_open.o
In file included from ad_open.c:48:
/usr/include/atalk/adouble.h:123:7: warning: extra tokens at end of #else
directive
ad_open.c: In function `ad_open':
ad_open.c:609: structure has no member named `ad_refcount'
make[3]: *** [ad_open.lo] Error 1
make[3]: Leaving directory `/tmp/netatalk-1.5pre7/libatalk/adouble'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/netatalk-1.5pre7/libatalk'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/netatalk-1.5pre7'
make: *** [all-recursive-am] Error 2

Actually, You can compile using SuSE 7.2  (prof. edition, fresh install) using the
following options

 --enable-redhat --enable-cnid-db --with-tcp-wrappers --with-pkgconfdir=/etc/atalk

and use it on RedHat 7.1  (works on my test machine, haven't put it on our
production server).
 --with-afs does not work, because venus.h and another .h file are missing from
the 
source tree (they're not in CVS either).

Be sure to back up Your configuration files, they _will_ get overwritten by a
'make install'
 
> which is not included in pre7.tar.gz.

the generic INSTALL is part auf the automake environment and would not help You
much, except get
started on configure. What I miss is an updated doc/INSTALL that explains the
current configure
options added by the netatalk developers...

H.