Subject: Re: Unidentified subject!

From: Mika Vuokko <[email-masked]>
Date: Thu, 18 Oct 2001 23:19:44 +0300 (EEST)

Hi. 

I asked about the Freehand problem earlier ( links to different files inside 
freehand document breaks ) but now it seems that also other software makes same 
kind of reprodusable actions.

I managed to compile the 1.5pre8 nicely now ( thanks Sebastian! :) ) but still 
have this problem. It makes the netatalk server unusable since it seems to 
break links to other files.

The really amusing part now is that the server works (all the links in the 
pictures inside Freehand document will work) when I
- open share with my username / password
- open *all the folders where the pictures are first*
and *then* open the freehand document - voila! All works fine.

Is this somekind of bug in the afpd? Since it seems that when afpd "knows" the 
folder where I have been when the share is open (the same afpd process with my 
user-id running) everything works, but when I close the share and the afpd-
process with my user-id dies - all links break.

Can anyone comment on this one? Please? :)

// Mika
 
---
 
Mika Vuokko
Programmer 
Scandinavia Online
Finland
 
Tel: +358-20-1234518
Mobile: +358-40-8334884
Email:   [email-masked]
Web:    http://www.suomi24.fi

---

From: [email-masked]
Date: Thu, 18 Oct 2001 23:55:23 +0200

Aliases will not work when compiled with --did=last,
only untill you restart the afpd.
Else aliases work but files are id'd by the inode which can result in data 
loss.
So far I have used *without* --did=last for 3 weeks and no data loss or
DID conflicts so far, I think you are alot more likely to have problems 
when users
are sharing dirs (accessing dirs simultaniously).

/Mikko

---

From: Mika Vuokko <[email-masked]>
Date: Fri, 19 Oct 2001 01:07:00 +0300 (EEST)

I compiled by netatalk like this:
./configure \
        --prefix=/usr/local/netatalk \
        --enable-lastdid \
        --enable-redhat \
        --with-did=mtab \
        --with-cracklib \
        --with-pam \
        --with-shadow \
        --with-tcp-wrappers \
        --with-ssl \
        --enable-pgp-uam \
        --enable-fhs

Is this OK? If I understood the docs correctly, the --with-did=mtab would help 
me with this broken link problem - but no. Could explain to me briefly what the 
did actually does, since I am not that good with mac's and their filesystems...

// Mika

Lainaus [email-masked]:
> >freehand document breaks ) but now it seems that also other software
> makes 
> >same
> >I managed to compile the 1.5pre8 nicely now ( thanks Sebastian! :) )
> but 
> >still
> >Is this somekind of bug in the afpd? Since it seems that when afpd
> "knows" 
> >the

---
 
Mika Vuokko
Programmer 
Scandinavia Online
Finland
 
Tel: +358-20-1234518
Mobile: +358-40-8334884