Subject: permissions

From: Luk Vermeylen <[email-masked]>
Date: Mon, 16 Jul 2001 13:59:50 -0400

Can someone give me a good example for file sharing with netatalk?
I want to share a directory (/data/design/) between samba and netatalk
the group graphics has total acces to the dir, the group staf only read 
permissions.
How do i have to set the line in my applevolumes file?
And how do i have to set the rights under linux for the directory?

Thanks

Now i'm having problems to copy directories with subdirs to the server. He 
copies only the basic dir, when you try again, he makes the sub dirs, but 
doen't copies the files.

-- 
Luk Vermeylen
Putsebaan 84
2040 Antwerpen 4
[email-masked]
+32(0)32950012

---

From: Michelle Murrain <[email-masked]>
Date: Mon, 16 Jul 2001 08:30:59 -0400

>copies only the basic dir, when you try again, he makes the sub dirs, but

My understanding is that as long as the permissions are set properly 
for the directory and files, you don't need to do anything special 
for samba or netatalk. The caviat is that you do need to make sure 
that the default way that files are written works properly (like if 
you want to have the files group-writeable). That functionality is in 
the samba configs - I don't know about how to work that in netatalk.

Make the directory owned by whoever, group graphics, and make the 
files group-writeable/readable, and only world-readable. That means 
that everyone can read, but only graphics can write.

For Linux, the commands chown (to change ownership) chgrp (to change 
groups) and chmod (to change permissions) are the ones you need. Just 
look at the man pages for info on those.

Michelle
-- 
---------------------------------------
Michelle Murrain, Ph.D.
[email-masked]

---

From: Henry Gripp Zeringue <[email-masked]>
Date: Mon, 16 Jul 2001 08:03:50 -0500 (CDT)

> And how do i have to set the rights under linux for the directory?

AppleVolumes.default:
/data/design	allow:@group1		share_name

sippit from "ls -l /"
drwxrwxr-x  21 root    group1	4096 Apr 26 22:26 data

It seems you have to make the parent directory of the directory you want
to share owned by the group you want to share it to (I know it sounds
confusing). So you should make sure everyone you want to be able to access
a certain share is part of the same group...

-gripp

-- 
---------------------------------------------
Henry 'Gripp' Zeringue	Home:	(608)260-8098
Biomedical Engineering	Office:	(608)262-8212
1410 Engineering Dr.	Lab:	(608)262-3013
Madison, WI 53706-1608	Fax:	(608)265-9239
[email-masked]
---------------------------------------------

---

From: Mac Conin <[email-masked]>
Date: Mon, 16 Jul 2001 15:33:30 +0200

hmm

for netatalk you should do the following:
afpd.conf
"<server>" -port 12000 -uampath /etc/atalk/uams/ -nlspath
/etc/atalk/nls/ 

AppleVolumes.default
/data2/transfer/ "dosenwelt" codepage:maccode.iso8859-1 [allow:group1,
user1 deny:@group2,user2]

you should set the shared directory to
chown -R nobody <directory>
chgrp -R <users> <directory>
chmod -R 2775 *

for Samba you shoud set the <directory> like this

[dosenweltt]
   comment = Heimatverzeichnis
   browseable = yes
   read only = no
   force create mode =0777
   force directory mode = 0777
   inherit permissions = yes
   directory security mask = 0777
   path = <directory>
   character set = ISO8859-1

..
the second question depends on the netatalk versio you are using :)

-- 
--schnippe-di-schnipp-- 

mit freundlichen grüssen

-----------------------------------------------------------
Mac Conin                        EUC Online Service GmbH
Geschäftsführer                  Taubengasse 9
[email-masked]                    D 50676 Koeln
http://www.euc.de                HRB Köln 32038
tel : +49-221-923 27 33          fax : +49-221-239 651
-----------------------------------------------------------