Subject: [Fwd: [Fwd: Solaris 8 and DDP]]

From: Xiaping Lin <[email-masked]>
Date: Mon, 19 Nov 2001 15:54:41 +1000

Xiaping Lin wrote:

> Hi, Thomas
>
> Thanks so much for your reply. I think the precomiled binary(solaris8-TCP.tar.gz)  I
> installed on my SUN E420 Solaris 8 machine
> by Tim Carlson (ftp://ftp.santafe.edu/pub/unix/netatalk/) is 2.1.4asun-pre39
> according to his reply below:
>
> http://www.umich.edu/~rsug/netatalk/archive/admins/2000/2999.html
>
> So, there is no need for me to recompile it again. Also, I did not have SUN cc
> compiler.
>
> One thing I am not very clear is that is the default  kernel of Solaris 8 64-bit ?
> if so, Is there any chance to get ddp working under
> Solaris? Has any one got it working ? I prefer not to change kernel to 32-bit if I
> can.
>
> Looking forward to hearing from you.
>
> Thanks again for your help!
>
> Thomas Kaiser wrote:
>
> > On Thu, 15 Nov 2001 10:21:31 +1000, Xiaping Lin wrote:
> >
> > > I think my current problem with Netatalk not broadcasting may be to do the ddp
> > > not working under sparc64 solaris8.
> >
> > There are know issues with some network hardware originally manufactured by
> > sun. Quad-FastEthernet-cards for example were known to not support multicast
> > correctly. This affected other afp-/appletalk-stacks (like helios'
> > ethershare) also. (the differences between broadcasting and multicasting are
> > explained here for example: <http://www.pmg.com/otw_nwsl/96_sm_apple.htm>)
> >
> > > Can anyone tell me where I can get 2.1.4asun-pre39 source ?
> >
> > Take a look at: <ftp://ftp.cobaltnet.com/pub/users/asun/testing/>
> >
> > > What is "pre39" means here?
> >
> > It's a pre-release, not for production purposes. Search google for "asun
> > pre" (and mix it with "cobalt" and "netatalk" too) and read this article
> > <http://www.umich.edu/~rsug/netatalk/archive/admins/2000/0297.html> to find
> > out what you will get ;-)
> >
> > Be careful when using pre39. There the "persistent DID kludge" was invoked
> > to create fixed directory ids instead of incrementing them on a per-client
> > base. But this hack is known to produce data-loss under some circumstances
> > (duplicate DIDs).
> >
> > <http://www.umich.edu/~rsug/netatalk/archive/admins/2000/3251.html>
> > <http://www.umich.edu/~rsug/netatalk/archive/admins/2000/3325.html>
> >
> > Best regards,
> >
> > Thomas
>
> --
> Xiaping Lin

--
Xiaping Lin
Information Technology
Queensland Institute of Medical Research
E-mail: [email-masked]
Ph:    61-7-33620231
fax:   61-7-33620111

---

From: Thomas Kaiser <[email-masked]>
Date: Mon, 19 Nov 2001 08:05:44 +0100

On Mon, 19 Nov 2001 15:54:41 +1000, Xiaping Lin wrote:

> I think the precomiled binary(solaris8-TCP.tar.gz) I installed on my SUN E420
> Solaris 8 machine by Tim Carlson (ftp://ftp.santafe.edu/pub/unix/netatalk/) is
> 2.1.4asun-pre39 according to his reply below:
> 
> So, there is no need for me to recompile it again.

If you can trust him? ;-) Have you found out which DID scheme he used for
his compile?

> One thing I am not very clear is that is the default kernel of Solaris 8

I think so, but am not an solaris expert (no os-expert at all)

> if so, Is there any chance to get ddp working under Solaris? Has any
> one got it working ? I prefer not to change kernel to 32-bit if I can.

As Steve wrote before ("1.5 release candidate needs volunteers") The
netatalk developer community wants to provide us all within the next weeks
with a final 1.5 version of netatalk that will compile on a variety of
platforms. Solaris is one of the target platforms, so maybe you just wait
for a week or so...

Regards,

Thomas

---

From: Jamie Flournoy <[email-masked]>
Date: Mon, 19 Nov 2001 15:31:11 -0800

During installation of Solaris 8 for SPARC, you are given a choice of a 64-bit or 32-bit
kernel, and 64-bit is the default selection. I don't remember what happens on older
machines that aren't 64-bit capable... I think the installer actually notices this and
says something about it.

---

From: Timo Schoeler <[email-masked]>
Date: Tue, 20 Nov 2001 01:05:23 +0100

on machines not 64bit capable as far as i can remember the installer 
doesn't give you the opportunity of choosing a 64bit kernel ;)

regards, timo