Subject: Bug in build 1.5pre6 on 4.2 BSDI

From: Daniel V Klein <[email-masked]>
Date: Tue, 24 Apr 2001 19:06:21 -0400

I tried to build on BSDI 4.2, and it never made it past the first Makefile.
Here's what I got, the error is at the very end.  Any clues?  The relevant
makefile is attached.

netatalk-1.5pre6 % ./configure
loading cache ./config.cache
checking host system type... i386-pc-bsdi4.2
checking target system type... i386-pc-bsdi4.2
checking for a BSD compatible install... (cached) /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... (cached) yes
checking for working aclocal... missing
checking for working autoconf... missing
checking for working automake... missing
checking for working autoheader... missing
checking for working makeinfo... found
checking for ranlib... (cached) ranlib
checking for gcc... (cached) gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for ld used by GCC... (cached) /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... (cached) yes
checking for BSD-compatible nm... (cached) /usr/bin/nm -p
checking whether ln -s works... (cached) yes
updating cache ./config.cache
checking for object suffix... o
checking for executable suffix... no
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.lo... yes
checking if gcc supports -fno-rtti -fno-exceptions ... yes
checking if gcc static flag -static works... -static
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking whether the linker (/usr/bin/ld) supports shared libraries... yes
checking command to parse /usr/bin/nm -p output... ok
checking how to hardcode library paths into programs... immediate
checking for /usr/bin/ld option to reload object files... -r
checking dynamic linker characteristics... bsdi4.2 ld.so
checking if libtool supports shared libraries... yes

*** Warning: the command libtool uses to detect shared libraries,
*** /usr/bin/file, produces output that libtool cannot recognize.
*** The result is that libtool may fail to recognize shared libraries
*** as such.  This will affect the creation of libtool libraries that
*** depend on shared libraries, but programs linked with such libtool
*** libraries will work regardless of this problem.  Nevertheless, you
*** may want to report the problem to your system manager and/or to
*** [email-masked]

checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking for objdir... .libs
creating libtool
loading cache ./config.cache
checking for gawk... (cached) gawk
checking for gcc... (cached) gcc
checking whether the C compiler (gcc -g -O2 ) works... yes
checking whether the C compiler (gcc -g -O2 ) is a cross-compiler... no
checking whether we are using GNU C... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for a BSD compatible install... /usr/bin/install -c
checking whether ln -s works... (cached) yes
checking whether make sets ${MAKE}... (cached) yes
checking for object suffix... o
checking for executable suffix... no
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.lo... yes
checking if gcc supports -fno-rtti -fno-exceptions ... yes
checking if gcc static flag -static works... -static
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking whether the linker (/usr/bin/ld) supports shared libraries... yes
checking command to parse /usr/bin/nm -p output... ok
checking how to hardcode library paths into programs... immediate
checking for /usr/bin/ld option to reload object files... -r
checking dynamic linker characteristics... bsdi4.2 ld.so
checking if libtool supports shared libraries... yes

*** Warning: the command libtool uses to detect shared libraries,
*** /usr/bin/file, produces output that libtool cannot recognize.
*** The result is that libtool may fail to recognize shared libraries
*** as such.  This will affect the creation of libtool libraries that
*** depend on shared libraries, but programs linked with such libtool
*** libraries will work regardless of this problem.  Nevertheless, you
*** may want to report the problem to your system manager and/or to
*** [email-masked]

checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking for objdir... .libs
creating libtool
loading cache ./config.cache
checking for main in -labs... (cached) no
checking for main in -laudit... (cached) no
checking for main in -lauth... (cached) no
checking for main in -lcmd... (cached) no
checking for main in -lcom_err... (cached) no
checking for main in -lcrypt... (cached) no
checking for main in -ld... (cached) no
checking for main in -ldb... (cached) no
checking for main in -ldl... (cached) yes
checking for main in -lkauth... (cached) no
checking for main in -lkrb... (cached) yes
checking for main in -llwp... (cached) no
checking for main in -ln... (cached) no
checking for main in -lnsl... (cached) no
checking for main in -lprot... (cached) no
checking for main in -lresolv... (cached) no
checking for main in -lrpcsvc... (cached) yes
checking for main in -lrx... (cached) no
checking for main in -lrxkad... (cached) no
checking for main in -lsocket... (cached) no
checking for main in -lsys... (cached) no
checking for main in -lubik... (cached) no
checking for access... (cached) yes
checking for dirent.h that defines DIR... (cached) yes
checking for opendir in -ldir... (cached) no
checking how to run the C preprocessor... (cached) gcc -E
checking for ANSI C header files... (cached) yes
checking for sys/wait.h that is POSIX.1 compatible... (cached) yes
checking for fcntl.h... (cached) yes
checking for limits.h... (cached) yes
checking for stdint.h... (cached) no
checking for strings.h... (cached) yes
checking for sys/fcntl.h... (cached) yes
checking for sys/file.h... (cached) yes
checking for sys/ioctl.h... (cached) yes
checking for sys/time.h... (cached) yes
checking for syslog.h... (cached) yes
checking for unistd.h... (cached) yes
checking for termios.h... (cached) yes
checking for sys/termios.h... (cached) yes
checking for netdb.h... (cached) yes
checking for sgtty.h... (cached) yes
checking for sys/cdefs.h... (cached) yes
checking for working const... (cached) yes
checking for uid_t in sys/types.h... (cached) yes
checking for inline... (cached) inline
checking for mode_t... (cached) yes
checking for off_t... (cached) yes
checking for pid_t... (cached) yes
checking for size_t... (cached) yes
checking for st_rdev in struct stat... (cached) yes
checking whether time.h and sys/time.h may both be included... (cached) yes
checking whether struct tm is in sys/time.h or time.h... (cached) time.h
checking type of array argument to getgroups... (cached) gid_t
checking whether gcc needs -traditional... (cached) no
checking for 8-bit clean memcmp... (cached) yes
checking whether sys/types.h defines makedev... (cached) yes
checking for unistd.h... (cached) yes
checking for getpagesize... (cached) yes
checking for working mmap... (cached) yes
checking return type of signal handlers... (cached) void
checking whether utime accepts a null argument... (cached) yes
checking for wait3 that fills in rusage... (cached) yes
checking for getcwd... (cached) yes
checking for gethostname... (cached) yes
checking for gettimeofday... (cached) yes
checking for getusershell... (cached) yes
checking for mkdir... (cached) yes
checking for rmdir... (cached) yes
checking for select... (cached) yes
checking for socket... (cached) yes
checking for strdup... (cached) yes
checking for strstr... (cached) yes
checking for strtoul... (cached) yes
checking for setpgrp... (cached) yes
checking whether setpgrp takes no argument... (cached) no
checking for pam_start in -lpam... (cached) no
setting configuration files location to NONE/etc
./configure: AUTHORS: permission denied
creating ./config.status
creating Makefile
creating bin/Makefile
creating bin/adv1tov2/Makefile
creating bin/aecho/Makefile
creating bin/afile/Makefile
creating bin/afppasswd/Makefile
creating bin/getzones/Makefile
creating bin/megatron/Makefile
creating bin/nbp/Makefile
creating bin/pap/Makefile
creating bin/psorder/Makefile
creating config/Makefile
creating contrib/Makefile
creating contrib/nu/Makefile
creating contrib/printing/Makefile
creating contrib/shell_utils/Makefile
creating contrib/timelord/Makefile
creating distrib/Makefile
creating distrib/config/Makefile
creating distrib/config/netatalk-config
creating distrib/initscripts/Makefile
creating distrib/m4/Makefile
creating doc/Makefile
creating etc/Makefile
creating etc/afpd/Makefile
creating etc/afpd/nls/Makefile
creating etc/atalkd/Makefile
creating etc/uams/Makefile
creating etc/uams/uams_krb4/Makefile
creating etc/papd/Makefile
creating etc/psf/Makefile
creating include/Makefile
creating include/atalk/Makefile
creating libatalk/Makefile
creating libatalk/adouble/Makefile
creating libatalk/asp/Makefile
creating libatalk/atp/Makefile
creating libatalk/compat/Makefile
creating libatalk/dsi/Makefile
creating libatalk/nbp/Makefile
creating libatalk/netddp/Makefile
creating libatalk/util/Makefile
creating man/Makefile
creating man/man1/Makefile
creating man/man3/Makefile
creating man/man4/Makefile
creating man/man5/Makefile
creating man/man8/Makefile
creating sys/Makefile
creating sys/netatalk/Makefile
creating config.h
config.h is unchanged
netatalk-1.5pre6 % make
make  all-recursive
Making all in libatalk
"Makefile", line 317: Need an operator
Fatal errors encountered -- cannot continue
*** Error code 1

Stop.
*** Error code 1

Stop.

---

From: Carsten Neumann <[email-masked]>
Date: Wed, 25 Apr 2001 05:42:00 +0200

> Here's what I got, the error is at the very end.  Any clues?  The relevant

Where was it attached? :-)

<snip>
> Fatal errors encountered -- cannot continue

What "make" do you use?
What I heard is that netatalk definitely needs GNU Make!
Try to get a recent version!

You probably want to update your libtool, too!?

Kind regards

	Carsten

---

From: Jason Quigley <[email-masked]>
Date: Wed, 25 Apr 2001 12:37:34 +0200

Hi!

You *definitely* need to use gmake on FreeBSD 4.2.

I have:

libtool-1.3.4_2     Generic shared library support script
gcc-2.8.1           Latest and greatest version of the GNU compiler suite
autoconf-2.13       Automatically configure source code on many Un*x 
platforms
automake-1.4        GNU Standards-compliant Makefile generator
gmake-3.79.1        GNU version of 'make' utility

and any dependencies as my build environment. These are all in 
/usr/ports.

Cheers,
Jason.

---

From: Bob Rogers <[email-masked]>
Date: Wed, 25 Apr 2001 14:09:15 -0400

From: Jason Quigley <[email-masked]>
   Date: Wed, 25 Apr 2001 12:37:34 +0200

   Hi!

   I have:

   Cheers,
   Jason.

I seem to recall that the only absolute requirement to install netatalk
is GNU make (and maybe gcc).  The others (plus m4) should only be needed
for development.  True?

					-- Bob Rogers