Subject: Solaris 8 ddp driver problem

From: Bruce <[email-masked]>
Date: Mon, 03 Sep 2001 17:50:31 -0700

I've seen this question posed before, but have not seen an answer.
It applies to all these verions:

netatalk-1.4.99-0.20001108.tar
netatalk-1.5pre6.tar
netatalk-971027.tar
netatalk-1.4b2+asun2.1.3.tar
pre-asun2.1.4-38b_test.tar

in ./sys/solaris directory,
trying to run "make kinstall" on Solaris 8 (UltraSPARC-1),
produces the following error message (same in both 32-bit and 64-bit):

   ...
   /usr/ucb/install -c ddp.conf /usr/kernel/drv/ddp.conf
   add_drv -m '* 0666 root sys' ddp
   devfsadm: driver failed to attach: ddp
   Warning: Driver (ddp) successfully added to system but failed to
attach
   sync;sync;sync
   ...

After setting atalkd.conf with hme0,
when atalkd is started, it produces the error message:

   can't establish STREAMS plumbing, exiting.

/var/adm/messages says this about ioctl(fd,  I_PUSH, "ddp") in
./etc/atalkd/config.c:

   Sep  3 16:31:48 mail atalkd[12708]: [ID 174707 user.error] I_PUSH:
Invalid argument

I had to guess at a device (is this documented? ), using:

   mknod /devices/psuedo/ddp@0:ddp c 92 1
   ln -s /devices/psuedo/ddp@0:ddp   /dev/ddp

Any hints?

-bruce
Bruce Kropp
[email-masked]

---

From: Rory Campbell-Lange <[email-masked]>
Date: Tue, 4 Sep 2001 12:12:58 +0100

Hi

Trying to connect to the server from my mac I get the following error
(or something like it) "An AppleShare system error occurred".

The server log shows:

    Sep  4 11:47:04 hopnet2 afpd[7346]: 
                    ASIP session:548(2) from 194.159.148.247:49367(0)
    Sep  4 11:47:04 hopnet2 afpd[7346]: 
                    dsi_getsess: too many connections

However I have specified 300 connection is netatalk.conf, whereas we
have less than a 100 users in the office (although some connect to more
than 1 volume on the server each morning):

    # Appletalk configuration
    # Change this to increase the maximum number of clients that \
    can connect:
    AFPD_MAX_CLIENTS=300
    
Any insight much appreciated.

Rory

---

From: Harald Wagener <[email-masked]>
Date: Tue, 04 Sep 2001 14:05:05 +0200

> Any insight much appreciated.

Depending on the version of netatalk or distribution installed, this variable
does not get read for afpd startup. With 'nu', You can check who is logged on
to the server (and how many people are - wc is Your friend). If it maxes out 
at 20 connections, the default number is set. 

You can either upgrade to 1.5 pre 6 or edit Your startup script to use the 
-c option for afpd.

H.

-- 
Harald Wagener      |                                Systemadministrator 
FCB/Wilkens GmbH    |                              Tel.:+49-40-2881-1252 
An der Alster 42    |                              Fax.:+49-40-2881-1263 
20099 Hamburg       |                         http://www.fcb-wilkens.com

---

From: Javan Slaney <[email-masked]>
Date: Tue, 04 Sep 1973 12:05:36 +0100

Acording to the Netatalk-FAQ-O-MATIC:

This happens when you didn't specify the "ddp" protocol in /etc/netconfig;
see the README.SOLARIS document from the ~/INSTALL directory.

(based on netatalk-1.4b2+asun-2.1.3, Sun Solaris 2.6 on UltraSparc 10)