Subject: Install path problem on Debian

From: Rory Campbell-Lange <[email-masked]>
Date: Thu, 19 Apr 2001 13:42:03 +0100

Hi 

I'm trying to build 1.5pre6. I've never installed something from source
before.

I have done the ./configure and make steps, but it is clear that I've
installed things to the wrong directories. (See extracts in the daemon
log when I try to startup). The binaries are installed to
/usr/local/sbin. However all the config files are installed within the
source directory itself.

Reading the INSTALL and README files suggest that I should state a
destination directory for the install in the Makefile. However configure
also takes directory paths for the install - I tried 
    
    ./configure --prefix=/usr --with-config-dir=/etc \
                --with-uams-path=/etc/uams

but it didn't work.

Thanks for ANY help!
Rory

atalkd[16646]: NONE/etc/atalkd.tmp: No such file or directory
atalkd[16646]: ready 0/0/0
afpd[16650]: hopnet2:AFPServer@* started on 6.42:128 (1.5pre6)
afpd[16650]: ASIP started on x.x.x.x:548(1) (1.5pre6)
afpd[16650]: uam : Loading (NONE/etc/uams/uams_guest.so)
afpd[16650]: uam: uam not found (status=-1)
afpd[16650]: uam : Loading (NONE/etc/uams/uams_clrtxt.so)
afpd[16650]: uam: uam not found (status=-1)
afpd[16650]: uam : Loading (NONE/etc/uams/uams_dhx.so)
afpd[16650]: uam: uam not found (status=-1)

-----

---

From: Jason Quigley <[email-masked]>
Date: Thu, 19 Apr 2001 14:58:15 +0200

Hi Rory!

I too had the same or a very similar problem under FreeBSD. It appears 
that the default configuration directory (--with-config-dir=path  path 
to config files [default=/usr/local/etc]) is being ignored:

...
setting configuration files location to NONE/etc <---- Here
AUTHORS: not found
  * FreeBSD specific configuration
checking for main in -lcrypto... (cached) yes
...

I just configured with --with-config-dir=/usr/local/etc/atalk and 
everything was fine.

Cheers,
Jason.

---

From: Rory Campbell-Lange <[email-masked]>
Date: Thu, 19 Apr 2001 14:50:12 +0100

> I just configured with --with-config-dir=/usr/local/etc/atalk and 

Jason

Thanks a ton for your useful info. I've done what you have suggested but
it still doesn't work.

I wonder if this is because I've got netatalk installed already. The
make programme doesn't seem to be deleting this.

Thanks again!
Rory

---------------------

.configure setup:

My Makefile includes the following as a result:

---------------------

    SHELL = /bin/sh

    srcdir = .
    top_srcdir = .
    prefix = /usr
    exec_prefix = ${prefix}

    bindir = ${exec_prefix}/bin
    sbindir = ${exec_prefix}/sbin
    libexecdir = ${exec_prefix}/libexec
    datadir = ${prefix}/share
    sysconfdir = ${prefix}/etc
    sharedstatedir = ${prefix}/com
    localstatedir = ${prefix}/var
    libdir = ${exec_prefix}/lib
    infodir = ${prefix}/info
    mandir = ${prefix}/man
    includedir = ${prefix}/include
    oldincludedir = /usr/include

    DESTDIR =

    pkgdatadir = $(datadir)/netatalk
    pkglibdir = $(libdir)/netatalk
    pkgincludedir = $(includedir)/netatalk

---------------------

    make check
    
reports stuff like

    make[1]: Entering directory         
`/home/rory/netatalk_source/netatalk-1.5pre6/config'
        sed -e s@:UAMS_PATH:@/etc@ \
            -e s@:NLS_PATH:@/etc/nls@ \
            -e s@:ETCDIR:@/etc@ \
 
 and
 
     sed -e s@:SBINDIR:@/usr/sbin@ \
        -e s@:BINDIR:@/usr/bin@ \
        -e s@:ETCDIR:@/etc@ \
        -e s@:LIBDIR:@/usr/lib@ \
        <AppleVolumes.default.5.tmpl >AppleVolumes.default.5
    sed -e s@:SBINDIR:@/usr/sbin@ \
        -e s@:BINDIR:@/usr/bin@ \
        -e s@:ETCDIR:@/etc@ \
        -e s@:LIBDIR:@/usr/lib@ \
        <afpd.conf.5.tmpl >afpd.conf.5
    sed -e s@:SBINDIR:@/usr/sbin@ \
        -e s@:BINDIR:@/usr/bin@ \
        -e s@:ETCDIR:@/etc@ \
        -e s@:LIBDIR:@/usr/lib@ \
        <atalkd.conf.5.tmpl >atalkd.conf.5
    sed -e s@:SBINDIR:@/usr/sbin@ \
        -e s@:BINDIR:@/usr/bin@ \
        -e s@:ETCDIR:@/etc@ \
        -e s@:LIBDIR:@/usr/lib@ \
        <netatalk.conf.5.tmpl >netatalk.conf.5
    sed -e s@:SBINDIR:@/usr/sbin@ \
        -e s@:BINDIR:@/usr/bin@ \
        -e s@:ETCDIR:@/etc@ \
        -e s@:LIBDIR:@/usr/lib@ \
        <papd.conf.5.tmpl >papd.conf.5

---

From: Mike Johnson <[email-masked]>
Date: Thu, 19 Apr 2001 09:19:33 -0700

It sounds like you need to run the configure again. Just cd into the 
directory and run ./configure, then run "make clean" and "make uninstall".

I think you still have stuff on your system that needs to be removed. Then 
you can run configure and make again (your configure line looks good, but you 
might want --with-shadow if you're using shadow passwords).

-
mike johnson

---

From: Bob Rogers <[email-masked]>
Date: Thu, 19 Apr 2001 14:24:17 -0400

From: Mike Johnson <[email-masked]>
   Date: Thu, 19 Apr 2001 09:19:33 -0700

I usually do "make distclean" before redoing ./configure -- "distclean"
is supposed to flush everything created by ./configure, in addition to
what "clean" does, so it should be as if you had reloaded the
distribution tarball.  That way, you can be sure that the new
./configure isn't using any of the old state.

					-- Bob Rogers

---

From: Karen A Swanberg <[email-masked]>
Date: Wed, 3 Oct 2001 17:04:30 -0500 (CDT)

...

using gmake will help, too. Netatalk has been 'gnuified', but I'm not sure
that's made it into the documentation yet (and I did the exact same thing
when I first built from source, just a few months ago)

> atalkd[16646]: ready 0/0/0

If I recall correctly, this NONE was a bug in Pre6. It is fixed in Pre7,
which is available on Sourceforge or vi CVS. The Pre7 on sourgeforge is
still beta, but is in pretty good shape. There is talk on the develers
list of making a Pre8 in the next few days, too, which will fix some of
the more insidious and hard to spot bugs in Pre7.

If you do decide to go the CVS route, also become familiar with the
archives of netatalk-admins, available at: 

ftp ftp://terminator.rs.itd.umich.edu/unix/netatalk/netatalk-admins.mail

as many of the questions you'll most likely ask first I (and others) have
gone through recently. Or you're welcome to ask me. The first is that the
CVS doesn't have a configure file, you must run ./autogen.sh first.

-Karen

-                                                                  -
    Karen Swanberg | Sys Admin | Dept. of Geology and Geophysics    
206 Pillsbury Hall | 310 Pillsbury Ave. SE | University of Minnesota
     Minneapolis, MN 55455  (612) 624-6541  (612) 625-3819 (f)

              * <---- Tribble   . <--- Tribble.tgz