Subject: Re: Files not visible with over 31 characters

From: [email-masked] (Lee Blevins)
Date: Fri, 15 Jun 2001 07:00:34 -0400

What can be done to move this up on the priority list?

> This has been characteristic of Netatalk for some time.   It's very
> interesting in a shared file area (Samba and Netatalk) when the Samba
> users changes protocols and naming conventions and the new files
> "disappear" for the Mac users.   I'm sure this could be found in the 
> afpd source.
> 
>                                               mht
> 
> -----Original Message-----
> From: [email-masked]
> To: [email-masked]
> Sent: 6/14/01 6:11 PM
> Subject: Files not visible with over 31 characters
> 
> I have users ftp files to our ftp site.
> 
> If they send from a pc and the filename is over 31 characters, it's
> invisible the the mac when opening the ftp folder that is being
> published by netatalk.
> 
> Why does name truncation not seem to be happening here?

---

From: [email-masked]
Date: Fri, 15 Jun 2001 11:37:46 -0700

My trick is build a symbolic link to the file with a "~" in it. I'm always
gonna write a Perl Script to automate the process, since I can't seem to
train the Win32 folks not to make these files.  It's also a royal pain,
since I archive to HSFS CD's and the same thing happens.

Celeste Suliin Burris
Systems Administrator
Tacoma Economic Development Department
email: [email-masked]

> ----------
> From: 	David Nelson
> Sent: 	Friday, June 15, 2001 4:20 AM
> Subject: 	Re: Files not visible with over 31 characters
> 
> On Thursday 14 June 2001 10:50 pm, Carsten Neumann wrote:
> > What name truncation do you expect?
> > Please tell detailed rules!
> 
> Okay. This is how I would like to see file name truncation handled:
> 
> If the name is over 31 chars and there is no extension just lop chars off
> the 
> end of the name to get it down to 31.
> 
> If the file name has an extension or layers of extensions e.g. 
> complete_collection_of_scanned_john_denver_album_covers.tar.gz, then start
> 
> lopping just to the left of the first extension. The file name from my 
> previous example would become:
> complete_collection_of_scanned_john_denver_albu.tar.gz
> 
> Of course sometime removing characters from a file name will result in the
> 
> file having the same name as another file in the same directory. For
> example 
> consider what would happen if the following files were both 1 character 
> over the Macintosh limit of 31.
> my_really_important_files1.tgz
> my-really_important_files2.tgz
> 
> Both files would end up with the name my-really_important_files.tgz, if
> that 
> were allowed. The best way to handle this situation may not be immediately
> 
> agreed upon by all. 
> 
> A number could be added to the end of the file name between the root and
> the 
> extension. The example file names would become:
> my_really_important_files.tgz
> my-really_important_file1.tgz
> 
> The characters could be removed from the beginning or the middle of the
> file 
> name. Which would result in something like this:
> y_really_important_files1.tgz
> y-really_important_files2.tgz
> 
> OR
> 
> my_really_impotant_files1.tgz
> my-really_impotant_files2.tgz
> 
> 
> The best solution might be a combination of these approaches. 
> 
> First try removing chars from between the root of the name and the file 
> extension. 
> 
> If that results in a conflict try removing chars from the middle of the
> name.
> 
> If that results in a conflict try removing chars from the beginning of the
> 
> name.
> 
> As a last resort add a number to the file name.
> 
> 
> I look forward to hearing other peoples' thoughts on this.
> 
> Have a great day.
> David Nelson
> 
>

---

From: "Bryn Hughes" <[email-masked]>
Date: Fri, 15 Jun 2001 11:42:03 -0700

Apple's solution usually has been to add a number on the end... (Try creating a few new folders and see what happens).  It would seem to make sense to duplicate Apple's behaviour, wouldn't it?

Bryn

>>> David Nelson <[email-masked]> 06/15/01 09:27 AM >>>

If the name is over 31 chars and there is no extension just lop chars off the 
end of the name to get it down to 31.

file having the same name as another file in the same directory. For example 

Both files would end up with the name my-really_important_files.tgz, if that 
were allowed. The best way to handle this situation may not be immediately 
agreed upon by all. 

A number could be added to the end of the file name between the root and the 
extension. The example file names would become:
my_really_important_files.tgz
my-really_important_file1.tgz

The characters could be removed from the beginning or the middle of the file 
name. Which would result in something like this:
y_really_important_files1.tgz
y-really_important_fils2.tgz

OR

If that results in a conflict try removing chars from the middle of the name.

Have a great day.
David Nelson