Subject: papd 'connection refused'

From: [email-masked] (Eric van Oorschot (mail))
Date: 17 Feb 2001 19:51:32 +0100

I'm using netatalk 1.4.99-0.20001108 and I'm able to use my Linux
server as a fileserver for my iMac. But I can't get papd to
work. Whatever I change to the papd.conf file I keep getting the
follwing messages in my syslog.

Feb 17 19:37:31 gildewg papd[19303]: read_ppd .ppd: No such file or directory
Feb 17 19:38:00 gildewg papd[19305]: read_ppd .ppd: No such file or directory
Feb 17 19:38:04 gildewg papd[19305]: lp_conn_unix connect /dev/printer: Connection refused
Feb 17 19:38:04 gildewg papd[19305]: lp_print: lp_conn_unix: Connection refused
r

I don't have a /dev/printer. The user in papd :op=oorschot, and that's
a user that normally can printer from the Linux server. One more
thing, I'm using LPRng.

Who knows what's going wrong ?

Eric van Oorschot

---

From: Carsten Neumann <[email-masked]>
Date: Sat, 17 Feb 2001 20:18:22 +0100

> Who knows what's going wrong ?

You missed to include your complete papd.conf entry, so I can only guess.
But I had the the same "Connection refused" errors.
One of my papd.conf entries is:

Lasie2:\
        :pr=|/usr/bin/lpr -Plasie:\
        :op=deltaman:\
        :pd=/etc/atalk/LC890.ppd:

where "deltaman" is a mortal user, lasie a printer in printcap, and "/etc/atalk/LC890.ppd" the path
to my PPD file.

I.e. I piped the data through lpr instead of giving just the name of my printcap printer.
Don't know what goes wrong with your PPD file.

Regards

	Carsten

---

From: Benjamin Lee <[email-masked]>
Date: Sun, 18 Feb 2001 11:56:24 +1100

I think this is a lpd / LPRng or kernel related error.

1. Maybe lpd isn't running. Or permissions aren't set properly.

2. Or parport_pc, lp, parport kernel modules were not loaded.

-- 
B.      http://makelinux.org/    "Always real."    http://realthought.net/
__________________________________________________________________________
It destroys one's nerves to be amiable every day to the same human being.
		-- Benjamin Disraeli

---

From: Carsten Neumann <[email-masked]>
Date: Sun, 18 Feb 2001 03:04:56 +0100

On Sat, 17 Feb 2001, Carsten Neumann wrote:
[snip]
> Don't know what goes wrong with your PPD file.

Forgot to mention that this piping through lpr fixed my problem. ;-)

Regards

	Carsten

---

From: [email-masked] (Eric van Oorschot (mail))
Date: 18 Feb 2001 16:00:54 +0100

> Forgot to mention that this piping through lpr fixed my problem. ;-)
Thanks to everybody for their advices. Changing my papd.conf and
adding the "|/usr/bin/lpr -Plp:" part solved the problem. Now I can
print from my iMac on the printer connected to the Linux server.

---

From: Christian Schmidt <[email-masked]>
Date: Sun, 18 Feb 2001 16:03:58 +0100

>  Feb 17 19:37:31 gildewg papd[19303]: read_ppd .ppd: No such file or directory

Have a look at your ppd entry in papd.conf....
Does the ppd file specified there exist? Have you typed the name 
and/or path correctly?

hth,
Christian
-- 
Made with a Macintosh...
[email-masked]
http://home.t-online.de/home/chrischmi/