Subject: Anyone recognize this?

From: Lance Levsen <[email-masked]>
Date: Tue, 27 Nov 2001 20:18:56 -0600

Solaris 7 32-bit, gcc:

On running /usr/local/sbin/afpd:

sparkie afpd[16232]: main: atp_open: Protocol not supported
sparkie afpf[16232]: uam_load(uams_dhx.so): failed to load: 
ld.so.1: /usr/local/sbin/afpd: fatal: relocation error : file 
/usr/local/etc/netatalk/uams/uams_dhx.so: symbol uams_afpserver_o
ption: referenced symbol not found

This happens if I use uams_clrtxt, or if I change the symlink to 
uams_dhx_passwd.so

Cheers,
-- 
Lance Levsen,
Systems Administrator,
PWGroup - Saskatoon

---

From: Simon Bazley <[email-masked]>
Date: Wed, 28 Nov 2001 03:39:25 +0000

Its similar to the pam problems I was having on RedHat 7.0 (assuming you're accessing it all via pam).

If you have any pam problems check if you're using /etc/pam.conf or /etc/pam.d/  If the later, then the uams file called netatalk must exist in the directory, if the former then the contents of the file netatalk should be in the pam.conf file but each line
should have the word 'netatalk ' at the begging of it.

Alternatively, I notices you said you had a symlink to uams_dhx_passwd: I believe someons said aeons ago that uams contains symbols that match the filename, so symlinks to it (or renaming it) will break it.

I had a look for the symbol uams_afpserver_option and I found uam_afpserver_option.  I guess its a typo somewhere.   I've got a script for you to try finding it if you like; http://sibaz.ncuk.net/uams_afpserver_option.sh

Not sure about the protocol bit.

Simon