Subject: Netatalk not showing in Chooser

From: Geoffrey Hughes <[email-masked]>
Date: Thu, 22 Mar 2001 09:23:05 +1200

This is probably quite a simple fix but it's got me stumped at the moment.

I have just installed Mandrake 7.1 on a machine with a 3com 3c905C nic and 
when starting netatalk I get the messages below...

Mar 22 09:15:35 LTServer atalkd: eth0: multicast may not work correctly.
Mar 22 09:15:36 LTServer atalkd[641]: zip_getnetinfo for eth0
Mar 22 09:15:45 LTServer atalkd[641]: zip_getnetinfo for eth0
Mar 22 09:15:55 LTServer atalkd[641]: zip_getnetinfo for eth0
Mar 22 09:16:05 LTServer atalkd[641]: config for no router
Mar 22 09:16:06 LTServer atalkd[641]: ready 0/0/0
Mar 22 09:16:06 LTServer atalk: atalkd startup succeeded
Mar 22 09:16:19 LTServer atalk: timelord startup succeeded
Mar 22 09:16:19 LTServer atalk: afpd startup succeeded
Mar 22 09:16:25 LTServer afpd[673]: Can't register LTServer:AFPServer@ITS 
Services DN
Mar 22 09:16:25 LTServer timelord[665]: LTServer:TimeLord started
Mar 22 09:16:25 LTServer afpd[673]: ASIP started on 139.80.105.33:548(1) (1.5)
Mar 22 09:16:25 LTServer afpd[673]: uam: uams_clrtxt.so loaded
Mar 22 09:16:25 LTServer afpd[673]: uam: "Cleartxt Passwrd" available

I have loaded the module and if I click the server ip button in the choose, 
I can connect fine.  The server just isn't showing in the chooser at 
all.  The same configuration files work fine on a machine with an intel 
etherexpress pro card.

Any ideas?

____________________________________________________________________
Geoffrey Hughes				Information Technology Services,
Technical Support Assistant			University of Otago,
Phone: +64 3 479 7333			PO Box 56,
Cellphone: 021 376 032			Dunedin, New Zealand
EMail: [email-masked]
____________________________________________________________________

---

From: Cathelijne Hornstra <[email-masked]>
Date: Tue, 27 Mar 2001 05:10:13 +0200 (CEST)

> all.  The same configuration files work fine on a machine with an intel 

appletalk module loaded in the kernel?

gr.
Cathelijne
-- 

****.~.********************************************************
*___ V ___              Is it a bird? - No                    *
*   /S\                Is it Superman? - No                   *
*  (\ /)      It's Flying SuperPenguin with the big feet!     *
**^^^-^^^******************************************************

---

From: Karen A Swanberg <[email-masked]>
Date: Tue, 27 Mar 2001 09:32:49 -0600 (CST)

> Mar 22 09:15:35 LTServer atalkd: eth0: multicast may not work correctly.
<snip>
> all.  The same configuration files work fine on a machine with an intel 

Have you edited your atalkd.conf file? When mine was empty, I was getting
the exact same error, but when I added the line

fxp0

which is my NIC, netatalk then populated it with all of the info I needed,
specifically:

fxp0 -phase 2 -net 51321 -addr 51321.229 -zone "Geology"

so I think if you were to just put in

eth0

it might just work.

I'm on OpenBSD/1.5pre5, and know very little about linux...

*                                                     *
Karen Swanberg              |                         
Network Admin.              | Error: Sector not found-- 
Dept. of Geology/Geophysics |search behind couch? (Y/N)
206 Pillsbury Hall          |                         
310 Pillsbury Ave. SE       |                         
University of Mn            |  Enter any 11-digit prime
Minneapolis, MN 55455       |     number to continue...
(612) 624-6541              |                         
*                                                     *