Subject: "Locked File" problems and solution?

From: Ryan McBeth <[email-masked]>
Date: Wed, 14 Mar 2001 11:42:33 -0500

Like most of the group knows, a few of us have been talking 
about the errors (well, that's too harsh, anomalies) with locked 
files and permissions.

	My company's new server is a Dell running Red Hat Linux 
version 7.0 (with liberally applied patches).  When I installed the 
RPM for Netatalk 1.5pre5, I kept getting an error whenever I dropped 
a file onto a netatalk directory.  The error would say that I didn't 
have the proper permissions.  But then the file would be created on 
the server with a size of 0 bytes.  Another error was "Cannot create 
because this file is locked" and the same thing would happen.

	So I removed 1.5pre5 and installed 1.5pre4
	Same problem.
	Then I removed 1.5pre4 and installed 1.5pre3
	Same problem.

	So I installed the RPM for 1.4.99-0.20001108.  Everything 
looks like it's working so far.  So this might solve the problem, or 
at least fix it temporarily until we can figure out what is wrong 
with 1.5pre5 .

	What happened between 1.4.99-0.20001108 and 1.5pre3 that did 
this?  Is it only happening on machines running Red Hat Linux 7.0?

	Ryan
__________________________________
Ryan McBeth
Systems Administrator, Mobius New Media
Voice: (302) 475-9880 x11
FAX: (302) 475-9894
www.mobiusnm.com
__________________________________
The secret to not getting burned out is to play at
working hard, and not taking things too seriously.
- Linus Torvalds

---

From: "Chad Leigh, Objectwerks, Inc." <[email-masked]>
Date: Wed, 14 Mar 2001 11:46:36 -0500

--On Wednesday, March 14, 2001 11:42 AM -0500 Ryan McBeth 
<[email-masked]> wrote:

>	 What happened between 1.4.99-0.20001108 and 1.5pre3 that did this?  Is
>	 it only happening on machines running Red Hat Linux 7.0?

No, it happens on FreeBSD 4.2 as well...

Chad

---

From: Matthew Keller <[email-masked]>
Date: Wed, 14 Mar 2001 12:04:33 -0500

Ryan McBeth wrote:
> Is it only happening on machines running Red Hat Linux 7.0?

	Nope... All sorts of BSDs and Linuxes. :)
-- 

 Matthew Keller
 Enterprise Systems Analyst
 Computing & Technology Services
 Information Services Division
 State University of New York at Potsdam
 
 Website: http://mattwork.potsdam.edu/
 PGP: http://mattwork.potsdam.edu/crypto/

---

From: "Mohammad A. Haque" <[email-masked]>
Date: Wed, 14 Mar 2001 13:30:31 -0500 (EST)

Same problem under rh 6.2. However I've done a lot of updates and maybe
I kicked something to the version that 7.0 has.

-- 

=====================================================================
Mohammad A. Haque                              http://www.haque.net/
                                               [email-masked]

  "Alcohol and calculus don't mix.             Project Lead
   Don't drink and derive." --Unknown          http://wm.themes.org/
                                               [email-masked]
=====================================================================