Subject: Can't start netatalk on Debian

From: Rory Campbell-Lange <[email-masked]>
Date: Mon, 2 Apr 2001 15:57:56 +0100

Hi

I'm trying to get netatalk running on a VALinux box running Debian.

When I run /etc/init.d/netatalk start I get the following errors:

socket: Invalid argument
atalkd: can't get interfaces, exiting
    atalkd afpd papd
    
I seem to remember using a gui tool to write the line in atalkd.conf that
provided the following on a LinuxPPC box I am using elsewhere:

eth0 -phase 2 -net 6 -addr 6.21 -zone "MHP Main Office"

However the netatalk docs suggest that this line will be created
automatically: "If there is no configuration file, atalkd will attempt to
configure all available interfaces and will create a configuration file".
However I DO have a config file - it just doesn't have any uncommented
lines in it. Is this wrong?

A simple "eth0" in atalkd.conf doesn't work.

I guess these problems may have something to do with my routing table. I
don't have a route for localhost, and I'm not sure if the first entry in
the table is sensible.

route:
Destination     GW              Mask
194.159.148.140 194.159.148.1   255.255.255.255
194.159.148.0   0.0.0.0         255.255.255.0
0.0.0.0         194.159.148.1   0.0.0.0

I'd be grateful for help.

Rory

---

From: Mac Conin <[email-masked]>
Date: Mon, 02 Apr 2001 17:07:23 +0200

Try writing

-seed

into your atalkd.conf

you can start atalkd and afpd manually

give atalkd some time to lookup the appletalk net. this can take up to 2 minutes.

if your connections are only via tcp forget about atalkd

just call afpd from the command line

-- 
--schnipp-- 

mit freundlichen grüssen

-----------------------------------------------------------
Mac Conin                        EUC Online Service GmbH
Geschäftsführer                  Taubengasse 9
[email-masked]                    D 50676 Koeln
http://www.euc.de                HRB Köln 32038
tel : +49-221-923 27 33          fax : +49-221-239 651
-----------------------------------------------------------
EUC sponsort Clean up Cologne - eine Iniative der IHK Köln,
der Abfallwirtschaftsbetriebe Köln (AWB) und dem
Grünflächenamt der Stadt Köln. http://www.clean-up-cologne.de

---

From: Bob Rogers <[email-masked]>
Date: Mon, 2 Apr 2001 21:19:13 -0400

From: Mac Conin <[email-masked]>
   Date: Mon, 02 Apr 2001 17:07:23 +0200

I made this same mistake on this list less than a month ago . . .

					-- Bob Rogers

------------------------------------------------------------------------
From: Bob Rogers <[email-masked]>
To: Cliff Crawford <[email-masked]>, [email-masked]
Subject: Re: very [newbie]
Date: Wed, 7 Mar 2001 11:31:34 -0500

   From: Cliff Crawford <[email-masked]>
   Date: Wed, 7 Mar 2001 08:49:34 -0500

   Carsten is correct.  afpd implements the file server for both appletalk
   and tcp, while atalkd implements the AppleTalk networking protocols and
   has nothing to do with file serving itself.  So both need to be running
   to do AppleShare over appletalk.

Oops; sorry, guys.

					-- Bob