Subject: Re: .AppleDouble tests on OpenBSD (long...)

From: Karen A Swanberg <[email-masked]>
Date: Wed, 25 Apr 2001 10:19:41 -0500 (CDT)

> From: andrew morgan <[email-masked]>
> Subject: Re: .AppleDouble tests on OpenBSD (long...)

> >
> > -----Forwarded Message-----
> > From: Karen A Swanberg <[email-masked]>
> > To: [email-masked]
> > Subject: .AppleDouble tests on OpenBSD (long...)
> 
> [chop, chop]
> 
> > Apr 23 16:30:20 epidote afpd[25250]: setdirowner: chown 16777216/-1
> > .: Operation not permitted
> > Apr 23 16:30:20 epidote afpd[25250]: setdirowner: chown -1/0
> > .AppleDouble/.Parent: Operation not permitted
> 
> >From my investigations tonight (whew!), these are not really errors.
> 
> Just to clarify what is happening above:
> 
> These are all being triggered by calls to FPSetDirParms from the mac.  It
> passes a big structure full of permission bits, user and group ids, etc.

[regretfully chopped lots of good stuff]
 
> In the current code, when the chown fails, we call syslog at LOG_ERR
> level.  In the asun2.1.4 code, it called syslog at LOG_DEBUG level.  In
> both cases, no error was passed to the mac client because really, afpd
> should deal with this operation properly or just ignore it.  At the
> LOG_DEBUG level, most users never saw the "error".
> 
> Somewhere around revision 1.6 of etc/afpd/unix.c, someone changed the
> LOG_ERR to LOG_DEBUG, apparently in the throes of adding dropkludge
> support.  If there was a valid reason for the change, please speak up.
> Otherwise, we should change those back to LOG_DEBUG so we don't scare our
> users.
> 
> 	Andy

So to clarify for the newbies, this breaks down to "This isn't a
problem?" We just need to tell our sysloggers to ignore it? Are the errors
catagorized as something like afpd.error or something similar that we can
configure our syslogs to ignore? I don't want to miss other errors, or
have my console window so full of this information that I miss others. If
and when the change is made in the CVS, will someone post here, so I can
test that new version?

Great to hear that this isn't a problem. I've been drooling to let my
users at this fileserver for awhile, and this was the last stumbling
block. Don't worry, I'll tell them it's still in testing.

Thanks,

-Karen

*                                                     *
Karen Swanberg              |                         
Network Admin.              | Error: Sector not found-- 
Dept. of Geology/Geophysics |search behind couch? (Y/N)
206 Pillsbury Hall          |                         
310 Pillsbury Ave. SE       |     Old geeks never die,                    
University of Mn            |         They just revert
Minneapolis, MN 55455       |            to cleartext.
(612) 624-6541              |                         
*                                                     *

---

From: andrew morgan <[email-masked]>
Date: Wed, 25 Apr 2001 09:07:01 -0700 (PDT)

> block. Don't worry, I'll tell them it's still in testing.

I've made the change in CVS since nobody squawked about it.  Give it a
whirl.

	Andy