Subject: Re: Samba and Netatalk

From: "Bryn Hughes" <[email-masked]>
Date: Wed, 07 Mar 2001 11:55:02 -0800

Ah, I wasn't aware of that limitation...

How does the Mac itself deal with this?  MacOS has no trouble assigning user/group/everyone permissions...

Bryn

>>> Seanano <[email-masked]> - 3/7/01 11:07 AM >>>

> Here's a question... is this issue resolved if using an HFS volume to
> do the file sharing?  As HFS doesn't allow filenames longer than 32
> chars, users just plain wouldn't be able to create them in the first
> place, correct?  This also helps with some issues with Mac aliases
> getting confused, etc. AFAIK.  I know there are limitations to HFS
> with regards to volume and file size and how efficiently the disk is
> used with larger volumes, but for smaller shares this could be a
> solution.

  IMHO, I would think the lack of file permissions with HFS wouldn't make
this very useful for anything other than read only (which wouldn't have
the problem anyway since nothing could be changed) or single user shares.

Sean

---

From: Matthew Keller <[email-masked]>
Date: Wed, 07 Mar 2001 15:11:44 -0500

> How does the Mac itself deal with this?  MacOS has no trouble assigning user/group/everyone permissions...

	The permissions are kept in a separate DB, and looked at whenever
files/folders are accessed over filesharing.

-- 

 Matthew Keller
 Enterprise Systems Analyst
 Computing & Technology Services
 Information Services Division
 State University of New York at Potsdam
 
 Website: http://mattwork.potsdam.edu/
 PGP: http://mattwork.potsdam.edu/crypto/