Subject: net range problems.

From: Peter Risdon <[email-masked]>
Date: Mon, 09 Apr 2001 20:02:08 +0100

I get the following when I try to 

/usr/local/etc/rc.d/netatalk.sh start

on FreeBSD 4.2:

netatalkNet (0) not in net-range (65280-65534).
bind: Can't assign requested address
bind: Can't assign requested address

And I can't figure out why. Any help would be greatly appreciated.

-- 
Peter Risdon
circle squared
9 The Maltings,
Millfield, 
Cottenham,
Cambridge,
CB4 8RE
UK
tel +44 1954 251097
fax +44 1954 252209

While every effort is made to ensure this mail and its attachments are
free of viruses and other malicious software, recipients should take
their own precautions.

This mail is intended for the addressees only. Should you receive it
inappropriately, please delete it and inform us by return mail to
[email-masked]

Unless otherwise stated, the opinions expressed in this mail are those
of its author, and not statements made on behalf of the circle squared.

---

From: Walt Reed <[email-masked]>
Date: Mon, 09 Apr 2001 12:22:08 -0700

what do you have in your atalkd.conf file?  it should just have the name
of the interface you want netatalk to bind to, i.e. "eth0" on linux, not
sure what on bsd.  once the interface is in there, netatalk should add the
rest when started.

w

---

From: Mac Conin <[email-masked]>
Date: Mon, 09 Apr 2001 21:14:30 +0200

hmmm.

do you have 2 ethernet cards in your system?

if so try running atalkd directly from the console.
make sure afpd and atalkd are not running

look into the /etc/atalk/atalkd.conf file and add '-seed' to it.
e.g.
eth0 -seed -phase 2 -net 300-500 -addr 352.96 -zone "others" -zone "admin"

wait for atalkd coming up - it could take some time.

after atalkd running take a look into the atalkd.conf file and
see what addresses atalkd as assinged to itself.

-- 
--schnipp-- 

mit freundlichen grüssen

-----------------------------------------------------------
Mac Conin                        EUC Online Service GmbH
Geschäftsführer                  Taubengasse 9
[email-masked]                    D 50676 Koeln
http://www.euc.de                HRB Köln 32038
tel : +49-221-923 27 33          fax : +49-221-239 651
-----------------------------------------------------------
EUC sponsort Clean up Cologne - eine Iniative der IHK Köln,
der Abfallwirtschaftsbetriebe Köln (AWB) und dem
Grünflächenamt der Stadt Köln. http://www.clean-up-cologne.de

---

From: Peter Risdon <[email-masked]>
Date: Mon, 09 Apr 2001 20:42:53 +0100

Thanks very much indeed. Every interface (there are three cards plus an
IP4-IP6 tunnel) was in the atalkd.conf file. I commented out the ones I
didn't need and it worked.

Peter.

-- 
Peter Risdon
circle squared
9 The Maltings,
Millfield,
Cottenham,
Cambridge,
CB4 8RE
UK
tel +44 1954 251097
fax +44 1954 252209