Subject: Problem in configuring netatalk

From: Stefano Guerrini <[email-masked]>
Date: Fri, 9 Feb 2001 13:02:22 +0100

Hello,

I have dowloaded the netatalk rpm (t1.5pre3 for Mandrake, I am running 
Mandrake 7.2).

But, I have the following problem when I try to start the daemon

	Starting AppleTalk services: socket: Invalid argument
	socket: Invalid argument
	atalkd: can't get interfaces, exiting.
 
I just tried adding

	eth0
 
to atalk.conf. But it does not work.

I would be very happy if you can give me some help.

Best wishes

-- 
Stefano Guerrini      -      Dipartimento di Scienze dell'Informazione
                             Via Salaria, 113  -  00198 Roma  -  Italy
phone:   +39 06.4991.8434                       fax:   +39 06.854.1842
mailto:[email-masked]   http://www.dsi.uniroma1.it/~guerrini

---

From: [email-masked]
Date: Fri, 9 Feb 2001 07:56:49 -0500

> 	atalkd: can't get interfaces, exiting.

You either don't have appletalk compiled into your kernel
or the appletalk module is not loaded.  Try 

  dmesg | grep -i appletalk

to see if it's compiled into your kernel.  Then try

  modprobe appletalk

to load the module.  Also make sure you have

  alias net-pf-5 appletalk

in /etc/conf.modules 

Stephen

---

From: Chris Murley <[email-masked]>
Date: Fri, 9 Feb 2001 08:25:48 -0600 (CST)

Ahh see i just had this problem yesterday , you have to modprobe iddp

-Chris

-----------------------
Christopher Murley
Application Index
http://www.appindex.net
http://www.appindex.org
-----------------------

---

From: Stefano Guerrini <[email-masked]>
Date: Fri, 9 Feb 2001 16:48:37 +0100

Great. It worked. 
Adding 
   alias net-pf-5 appletalk
the appletalk module is loaded and everything works fine.
Thank you everybody.
Cheers
--s

---

From: Carsten Neumann <[email-masked]>
Date: Fri, 9 Feb 2001 20:12:13 +0100

On Fri, 09 Feb 2001, [email-masked] wrote:
[snip]
> to load the module.  Also make sure you have

You have to look if conf.modules isn't a symlink to modules.conf.
The symlink is due to historical reasons.
some editors might remove it and replace it by a regular file if you edit the symlink,
so the module loader will just see the old modules.conf file.
I once had such an encounter.

Regards

	Carsten