Subject: file permissions

From: "Mike Egglestone" <[email-masked]>
Date: Fri, 05 Jan 2001 16:24:49 -0800

Hi.... 
I'm having some trouble with file permissions after the user 
logs into the appleshare....(through the chooser) 
I have a share from netatalk called "web" 
its real location is here 
/var/www/ 
I have given rwx permissions to the group of the folder "www" -R 
so basically I did this...... 
cd /var 
chgrp web www -R 
chmod g+rwx www -R 
when the user mounts the share "web"... all is good... 
However they can't write to (the root) of the share.... 
if they go into the share.... a directory or more... then the permissions
work fine... 
basically from the mac computer... they can write to here 
/var/www/library/ 
but not here /var/www/ 
however.. if they log into the linux server directly (telnet in or
something) and access the /var/www folder... 
they have their permissions with out problems.... 
Am I making sense? 
I wondering if netatalk is somehow blocking the permissions on the root of
the mounted share.... 
Has anyone had this before? 
Any help would be great!!! 
thanks 
Mike

---

From: Marc Miller <[email-masked]>
Date: Fri, 5 Jan 2001 16:41:10 -0800 (PST)

Are you using a netatalk 1.5 prerelease or is this 1.4b2+asun2.1.4 ?

> Any help would be great!!! 

============================================================
	/\/\arc ._|. /\/\iller ([email-masked])
	Computer Room Consultant
	Information Technology/Lab Management
============================================================
I can be contacted through the Communication Center link from
http://www.mother.com/~mjmiller/

---

From: Christian Schmidt <[email-masked]>
Date: Sat, 6 Jan 2001 11:50:01 +0100

>  basically from the mac computer... they can write to here

On my Linux server there is a directory shared by netatalk. I set the 
permissions as follows:
drwsrwsr--  10 root     users

And everything works fine. Every user can login via the chooser and 
create directories and files.

hth,
Christian
-- 
Made with a Macintosh...
[email-masked]
http://home.t-online.de/home/chrischmi/