Subject: Pre5 and RH 7

From: "Daniel E. Lautenschleger" <[email-masked]>
Date: Thu, 8 Mar 2001 15:27:18 -0600 (CST)

I just installed the RPM Pre5 on my RH 7 box and specifying only DHX in
the netatalk.conf file does not allow me to copy files properly. It claims
there is a permission problem. I believe this bug was present in Pre 4 as
well.

Logs:

Mar  8 15:24:17 itchy afpd[2591]: ASIP session:548(1) from 144.92.19.76:49272(2)
Mar  8 15:24:17 itchy afpd[2591]: dhx login: usrdel
Mar  8 15:24:17 itchy afpd[2591]: uams_dhx_pam.c :PAM: PAM Success -- Function not implemented
Mar  8 15:24:17 itchy PAM_pwdb[2591]: (netatalk) session opened for user usrdel by (uid=0)
Mar  8 15:24:17 itchy afpd[2591]: uams_dhx_pam.c :PAM: PAM Auth OK!: (null) -- Inappropriate ioctl for device
Mar  8 15:24:17 itchy afpd[2591]: login usrdel (uid 500, gid 500)
Mar  8 15:24:19 itchy afpd[2591]: setdirowner: chown -1/0 .AppleDouble/.Parent: Operation not permitted

What's line 5 all about!? ioctl...

Anyone else experiencing this?

-Dan

---

From: Marc Miller <[email-masked]>
Date: Thu, 8 Mar 2001 14:39:24 -0800 (PST)

I've been helping a fellow developer with adding better logging to the
PAMs and it looks like this is a case of "overlogging."  I suggested that
he put a %m in his syslog statements.  That puts the last system message
in the log.  I think it was simply unnecessary this time.  Clearly that
login was a success.  PAM usually goes through a series of things to
determine if someone is authorized to log in.  Perhaps one authentication
method failed and that's what the ioctl message is all about.

As for your permissions problem,... I'm not sure.  If you have write and
execute permission set on both the directory and its .AppleDouble
subdirectory, it should have no trouble with moving the file.  .Parent
usually contains resource information for the directory itself (can't
remember if the directory icon is part of that or not).

> Anyone else experiencing this?

============================================================
	/\/\arc ._|. /\/\iller ([email-masked])
	Computer Room Consultant
	Information Technology/Lab Management
============================================================
I can be contacted through the Communication Center link from
http://www.mother.com/~mjmiller/