Subject: RE: passwords longer than 8 characters

From: "Miller.Jonathan" <[email-masked]>
Date: Tue, 31 Jul 2001 06:43:27 -0400

Thanks for the help.  I do believe I've got it working the way I need
it to now.  But another, related question:  what are uams_dhx_pam.so
and uams_dhx_passwd.so for?  I'm just using -uamlist uams_dhx.so in my
afpd.conf and it's working just fine...

Thanks again,
Jon

Jonathan Miller
Bioinformatics System Administrator
NIEHS MicroArray Center (ITSS) 

> -----Original Message-----
> From: Thomas Kaiser [mailto:[email-masked]]
> Sent: Thursday, July 26, 2001 3:49 PM
> To: Miller.Jonathan; [email-masked]'
> Subject: Re: passwords longer than 8 characters
> 
> 
> am 26.07.2001 20:25 Uhr schrieb Miller.Jonathan:
> 
> > there's a problem when people have passwords longer than 8 
> characters.
> 
> Support for more than 8 chars in passwords came with DHX 
> authentication.
> 
> > Is there some way, maybe through a UAM, to have it accept 
> longer passwords?
> 
> If you have a recent AppleShare Client (Apple recommends 
> 3.8.8 if you want
> to change you passwords through chooser: 
> <http://til.info.apple.com/techinfo
> .nsf/artnum/n60792>) and compiled a recent Netatalk version with DHX
> Authentication, things will work as expected. :-)
> 
> Regards,
> 
> Thomas
>

---

From: Sebastian Rittau <[email-masked]>
Date: Tue, 31 Jul 2001 12:59:09 +0200

> afpd.conf and it's working just fine...

If you do an "ls -l" on your uams directory, you will notice that
some uams are just symlinks to other uams, depending on whether you
turned on pam, dhx, etc. uams_dhx.so is such an uam. It's linked to
uams_dhx_pam.so on my PAM-enabled Debian GNU/Linux box.

 - Sebastian