Subject: netatalk and MAC OS X

From: Christophe Raffalli <[email-masked]>
Date: Mon, 17 Sep 2001 12:30:12 +0200

I have seen some message that netatalk and MAC OS X are not working together ! 
I have the same problem and I have seen no answer. Can somone help me ?

Netatalk + Mac OS X: fails to mount the volume
Netatalk + Mac 0S 9: OK
Netatalk + Mac OS X + OS9 Chooser: OK

Here is the log:

Sep 17 12:20:47 www afpd[16325]: ASIP session:548(1) from
193.48.123.140:49175(2)
Sep 17 12:20:47 www afpd[16325]: dhx login: fmang
Sep 17 12:20:47 www afpd[16325]: uams_dhx_pam.c :PAM: PAM Success -- Appel
système interrompu
Sep 17 12:20:47 www PAM_pwdb[16325]: (netatalk) session opened for user fmang
by (uid=0)
Sep 17 12:20:47 www afpd[16325]: uams_dhx_pam.c :PAM: PAM Auth OK!: (null) --
Ioctl() inappropré pour un périphérique
Sep 17 12:20:47 www afpd[16325]: login fmang (uid 1079, gid 200)
Sep 17 12:20:52 www afpd[16325]: dsi_stream_read(0): Aucun fichier ou
répertoire de ce type
Sep 17 12:20:52 www PAM_pwdb[16325]: (netatalk) session closed for user fmang
Sep 17 12:20:52 www afpd[16325]: 0.96KB read, 9.03KB written
Sep 17 12:20:52 www afpd[16325]: Connection terminated
Sep 17 12:20:52 www afpd[16251]: server_child[1] 16325 exited 1

-- 
Christophe Raffalli
Université de Savoie
Batiment Le Chablais, bureau 21
73376 Le Bourget-du-Lac Cedex

tél: (33) 4 79 75 81 03
fax: (33) 4 79 75 87 42
mail: [email-masked]
www: http://www.lama.univ-savoie.fr/~RAFFALLI

---

From: "Chad Leigh, ObjectWerks, Inc." <[email-masked]>
Date: Mon, 17 Sep 2001 07:04:14 -0400

I have not done a lot of testing but my Mac OS X boxes have had no problem 
mounting volumes on my netatalk server and reading and writing to and from 
them (using the Mac OS X mounter in the menu).  I have 1.5pre7 on FreeBSD 
4.4-RC4.  Mac OS X 10.0.4.

Chad

--On Monday, September 17, 2001 12:30 PM +0200 Christophe Raffalli 
<[email-masked]> wrote:

>
> I have seen some message that netatalk and MAC OS X are not working
> together !  I have the same problem and I have seen no answer. Can somone
> help me ?
>
> Sep 17 12:20:47 www PAM_pwdb[16325]: (netatalk) session opened for user
> fmang by (uid=0)
> Sep 17 12:20:47 www afpd[16325]: uams_dhx_pam.c :PAM: PAM Auth OK!:
> (null) -- Ioctl() inappropré pour un périphérique
> Sep 17 12:20:52 www PAM_pwdb[16325]: (netatalk) session closed for user
> fmang Sep 17 12:20:52 www afpd[16325]: 0.96KB read, 9.03KB written

---

From: Christophe Raffalli <[email-masked]>
Date: Mon, 17 Sep 2001 13:36:32 +0200

> 4.4-RC4.  Mac OS X 10.0.4.

I have the 1.5pre6 undir Linux Mandrake 7.1 and Mac OS X 10.0.4.

Could you send your configuration file please, it may be a problem with the 
config files bundled with the mandrake distribution ?

tél: (33) 4 79 75 81 03
fax: (33) 4 79 75 87 42

---

From: Chad Cunningham <[email-masked]>
Date: Mon, 17 Sep 2001 10:09:46 -0400 (EDT)

> config files bundled with the mandrake distribution ?

Update to pre7, it fixes this problem, at least on all of my machines.

-- 

Chad Cunningham
[email-masked]

"Well, once again my friend, we find that science is a two-headed beast. One
head is nice, it gives us aspirin and other modern conveniences,...but the
other head of science is bad! Oh beware the other head of science, Arthur, it
bites!"

---

From: "Chris Garrigues" <[email-masked]>
Date: Mon, 17 Sep 2001 09:14:31 -0500

> From:  "Chad Leigh, ObjectWerks, Inc." <[email-masked]>
> Date:  Mon, 17 Sep 2001 07:04:14 -0400
>

I don't see an RPM for 1.5pre7 on sourceforge.  Does anyone have one yet?

Chris

-- 
Chris Garrigues                 http://www.DeepEddy.Com/~cwg/
virCIO                          http://www.virCIO.Com
4314 Avenue C                   
Austin, TX  78751-3709		+1 512 374 0500

  My email address is an experiment in SPAM elimination.  For an
  explanation of what we're doing, see http://www.DeepEddy.Com/tms.html 

    Nobody ever got fired for buying Microsoft,
      but they could get fired for relying on Microsoft.