Subject: alias losing it's link

From: [email-masked] (Lee Blevins)
Date: Wed, 16 May 2001 08:54:41 -0400

I make an alias of a directory (folder) on a netatalk vol. and after
some time I double click it and it opens another folder. 

Any ideas what's happening here?

thanks

---

From: Christoph Sold <[email-masked]>
Date: Thu, 17 May 2001 12:26:08 +0200

> Any ideas what's happening here?

Since netatalk saves folder IDs only for a session, afert logout your 
alias is stale. That's a known problem, it's not easily fixed.

HTH
-Christoph Sold

---

From: Lorenzo Perone <[email-masked]>
Date: Fri, 18 May 2001 14:58:46 +0200

>Any ideas what's happening here?

Directories are identified differently in MacOS and Unix filesystems... so netatalk creates 'fake-on-the-fly' MacOS-Directory-IDs at each session for each user (though I didn't track the way this really happens, nor am I an ext2-expert - but the problem will rise sooner or later, if you add/remove dirs).

A Mac-alias is a file that stores an alis record, which contains this among other info:

- directory ID
- absolute directory path
- relative directory path (I think I've seen that when aliasing on the same volume)
- server [dns] name, and login user name.
- kind of original, and info about what You can drop on it.

when the mac does not find the directory ID, it uses the path.
Unfortunately, netatalk mostly has a folder with the ID specified in the alias, but after a logout/login it can be bound to a new directory... and the mac doesn't use the path stored in the alias because it actually finds a directory with that ID.

Anyway, there's no solution to it until some disk-database solution is developed into netatalk, where these ids are storedand available thruout sessions (unlikely to happen annytime soon?) .

I've been wondering, sometimes, what would happen if netatalk didn't reply with DIDs at all (after all)... but I guess the MacOS (classic) would explode, or so, while OSX might find something new to be terribly afraid of ;-).

If you think that's a viable workaround for Your environment, You can use the applescript I posted lately  (in case you just subscribed to the list)
http://lorenzo.yellowspace.net/scriptfarm/download/NetAliasApplet.sit

:-)

Lorenzo