Subject: Netatalk to Samba Prob...

From: "Wayne Dozier" <[email-masked]>
Date: Sat, 12 Jan 2002 19:02:26 -0500

I am having a problem getting my macs in a computer lab to
see all my shares on my Samba server.  When the user chooses
my server and logs in, it maps their home directory but not
the share directory.  Is there something in one of the
config files that I need to add.  I am new to netatalk so I
am sure there is something simple I am missing.  Keep in
mind that the PC's map just fine so I am confused as to what
may be happening.  Any ideas?

---

From: Steve Freitas <[email-masked]>
Date: Sat, 12 Jan 2002 21:32:22 -0800

You need to look in the config file "AppleVolumes.default". Depending on
your installation, it may be under /etc/netatalk, or /etc/atalk. Or maybe
it's elsewhere. To find it, do:

[user@localhost]$ find / -name AppleVolumes.default

You'll find, at the end of that file, a tilde (~). That automatically gives
each user access to his/her home directory. If you want to map them to other
shares, the syntax is like this:

<path> <name>

So if you had an MP3 directory you wanted to share to your users that
resided in /home, and you wanted to name it "Music", you'd add a line like
this to AppleVolumes.default:

/home/mp3s Music

The user must log out of the netatalk server before any changes to
AppleVolumes.default take effect. Hope this helps.

Steve

> From: "Wayne Dozier" <[email-masked]>
> Date: Sat, 12 Jan 2002 19:02:26 -0500
> To: <[email-masked]>
> Subject: Netatalk to Samba Prob...
> Resent-From: [email-masked]
> Resent-Date: Sat, 12 Jan 2002 19:15:10 -0500 (EST)
>