Subject: RE: Permissions?

From: "Black, Nathan" <[email-masked]>
Date: Thu, 17 Jan 2002 08:43:22 -0600

I almost added configs to my initial post.  the shares are normal /xxxx
"name"  and I don't share the ~ home dir's.  Nothing special in the other
two, and I let afpd detect etho and insmod the appletalk module.  That works
and I can telnet to 548.  

I noticed RedHat didn't ship with Netatalk, so I compiled it. ( I despise
the way RedHat sticks everything in /usr instead of /usr/local/ )  

But I think that is my problem, I compiled with pam.d, shadow and RedHat
support, but it prompts, so I think the auth is incorrect (probably no
PAM)?.  I will re-do it with the RedHat rpm and see what happens.  Do you
know what flags they used to build the RPM?

Thanks for the tips.
Nathan

> -----Original Message-----
> From: Damien MATTEI [mailto:[email-masked]]
> Sent: Thursday, January 17, 2002 3:36 AM
> To: Black, Nathan
> Cc: [email-masked]
> Subject: Re: Permissions?
> 
> 
> "Black, Nathan" wrote:
> > 
> > Hello,
> > 
> > Configured Netatalk on Redhat 7.2
> > The Macs see the box but complain about permissions
> > the user is macuser with no password in /etc/passwd
> > the shares are full drwxrwxrwx
> > 
> > How do I get Netatalk to log something so that I can see 
> what is preventing
> > the connection?
> > What account or permissions is it looking for?
> > If I compile it with PAM support, does that require that I 
> use PAMs for
> > authentication?
> > 
> > Nathan
> i just installed netatalk on redhat 7.2 this month netatalk isn't
> shipped with 7.2 so i use gnorpm connect to redhat and download latest
> available which is the one for redhat 7.1 i use standard file
> configuration, my user have password i didn't try without,and it works
> well.
> 
> give us more info :your /etc/atalk/afpd.conf ,redhat use
> /etc/atalk/config 
> and /etc/atalk/AppleVolumes.default for more help
> but default files of redhat works at leat for users that share only
> their home directory.
> 
> for the permission you don't need to put rwx on others 
> sometimes putting
> rws on the group help to share with other users in the 
> group,do not try
> to access
> with root login as afpd refuse to go in superuser mode.
> 
> hope it helps!
> -- 
> MATTEI Damien					Phone: +33 (0)4 
> 93 37 76 66
> C.N.R.S / U.N.S.A				Fax:   +33 (0)4 
> 93 53 30 71
> UMR 6549 Instabilite & Alterations des Genomes	E-mail: 
> [email-masked]
> Faculte de Medecine - Avenue de Valombrose - 06107 NICE Cedex 
> 2 - France
>

---

From: Thomas Kaiser <[email-masked]>
Date: Thu, 17 Jan 2002 16:01:44 +0100

On Thu, 17 Jan 2002 08:43:22 -0600, Black, Nathan wrote:

> I will re-do it with the RedHat rpm and see what happens.  Do you

Take a look at 2 sites with recent netatalk RPMs for RedHat 7.2:

<http://kraftwerk.adsl.dk/netatalk/> (the specs are available directly from
there)

<ftp://ftp.falsehope.net/home/tengel/netatalk/> (to know how they build it,
you have to download the src-RPM and extract the netatalk.spec file)

I would strongly recommend using RPMs based on the final 1.5.0 version
instead of using so called 'official' ones from RedHat (the last based on
1.5pre2 -- many things have changed in the meantime)

Regards,

Thomas