Subject: Multiple NICS under netatalk

From: "Bryn Hughes" <[email-masked]>
Date: Wed, 19 Sep 2001 10:48:56 -0700

I have a machine running netatalk with 2 ethernet cards.  Each of them is connected to a different subnet on our system, but both of them are really the same number of hops away from most of the computers that use the server.  I've noticed that connections over TCP/IP seem to go to either NIC.  This IS what I want, but I was wondering how netatalk decides which NIC to use.  Only one of them has Appletalk enabled on it, and it seems that half the time I'm connecting to that one and half the time I'm connecting to the other one.  Is there some sort of load balancing going on?

Bryn

---

From: Thomas Schierle <[email-masked]>
Date: Wed, 19 Sep 2001 22:53:33 +0200

I believe it's a bug -- the card which catches a connection first
is used. For a single connection from a Mac, incoming packets
may be handled by ether0, outgoing by ether1.

That may cause trouble, for me connections to my Netatalk box
(Netatalk not configured to use a single NIC, no AppleTalk routing)
have been unstable, especially with multiple simultaneous copies,
until I physically separated both subnets.

NICs in use: SMC EtherPower II, and on old Realtec 8019 (NE2000 mode).
Each NIC running perfectly stable.

-Thomas

On 2001-09-19 19:48 +0200, "Bryn Hughes"<[email-masked]> wrote:

> I have a machine running netatalk with 2 ethernet cards.  Each of them is
> connected to a different subnet on our system, but both of them are really the
> same number of hops away from most of the computers that use the server.  I've
> noticed that connections over TCP/IP seem to go to either NIC.  This IS what I
> want, but I was wondering how netatalk decides which NIC to use.  Only one of
> them has Appletalk enabled on it, and it seems that half the time I'm
> connecting to that one and half the time I'm connecting to the other one.  Is
> there some sort of load balancing going on?

-- 
Thomas Schierle, Munich, Germany

PGP key [DSS/DH] 0xA23CDA1D available at various public key servers