Subject: Pre 4 and 5

From: "Daniel E. Lautenschleger" <[email-masked]>
Date: Tue, 13 Mar 2001 07:18:04 -0600 (CST)

Okay, since Pre 4 and Pre 5 have issues relating to file perms and
copy/delete problems on RH 7, what happened after 3 to cause these
problems?

Thanks.
-Dan

---

From: Axel Bringenberg <[email-masked]>
Date: Tue, 13 Mar 2001 14:29:00 +0100

> copy/delete problems on RH 7, what happened after 3 to cause these

imho the problems are caused by a change in ./libatalk/adouble/ad_open.c
from 
	admode = ad_mode( ad_p, mode );
to
	admode = ad_mode( ad_p, O_RDWR );
Changing back to the original line solves the problem - at least for me.

Regards.
- Axel

---

From: "Nikolas Hagelstein" <[email-masked]>
Date: Tue, 13 Mar 2001 15:07:30 +0100

> > copy/delete problems on RH 7, what happened after 3 to cause these
MDK7.2 also has the same problems 

> admode = ad_mode( ad_p, O_RDWR );
May be this depends on the definiton of  O_RDWR in 
/usr/include/bits/fcntl.h (which belongs to glibc-devel)
on RH7 and MDK7.2 systems it is defined as 02...
it seems as if O_RDWR is "ANDED" with the original mode 
which is a very bad thing if O_RWDR is set to 02...
could someone who has no problems with pre4 and pre5 please
tell me what O_RDWR is set to on his system ?
thxn4ward,
                Nikolas

---

From: jeff <[email-masked]>
Date: Wed, 14 Mar 2001 05:38:42 -0500

> Changing back to the original line solves the problem - at least for me.

Enough people have pointed this one out that I've moved it back to
"mode" in the CVS tree.

Thanks,
jeff