Subject: newbie netatalk printing questions..

From: Lorenzo Perone <[email-masked]>
Date: Mon, 28 May 2001 21:51:03 +0200

Hi all,

while I've become accustomed somehow (thanks to you, mostly :) to afpd and atalkd configuration and admin, but I have _just_ finished reading the papd manual and some basic linux printing docs;

I am evaluating the possibility to get some epson stylus color usb ink jet printers to work over the net with macos and windows boxes accessing them over the print dialog.

My (_very_) newbie questions are:

- Is papd needed, or is it just the 'printing atalkd', i.e. a daemon to get the jobs transferred over the AppleTalk protocol? Or is it usable over TCP/IP too?

- Any good links/hints/manpages on how to set up a standard 'lpr protocol' print server over TCP/IP, so that creating a printer symbol via LPR protocol with the appropriate ppd would be enough on the mac, as well as (similarly) on windows2k?

Thanks very much,

:-)

Lorenzo

---

From: Axel Rose <[email-masked]>
Date: Tue, 29 May 2001 00:35:02 +0200

Hi Lorenzo,

you could use the "lpr" protocol for Macs too. I wouldn't recommend
so because it's really hard to setup (AppleScript and Desktop Printer
Monitor). I doesn't give you any speed advance.

pap is the protocol of choice for printing from Macs and even
for Unix if it comes to high end printing devices.

A possible setup could look like this:

setup "papd.conf" + "/etc/printcap"
Macs communicate in the usual chooser/LaserWriter way with
a printing queue provided by netatalk. netatalk then uses
the Unix provided lpr service.

I can't help much though how to setup the latter.

There is another problem still.
Macs usually produce PostScript output.
In order to convert this PostScript to a format understandable
by your Epson Stylus you will need GhostScript installed on the
server, probably.

If you understood the process and have a running papd/lpd
configuration ask again for hints how to connect lpd with
GhostScript. I have suche a thing running to produce PDF
from the PS generated by Macs.

Best wishes

Axel
-- 
----------------------------------------------------------------------
Axel Rose, Springer & Jacoby Digital GmbH & Co. KG, mailto:[email-masked]
  pub PGP key 1024/A21CB825 E0E4 BC69 E001 96E9  2EFD 86CA 9CA1 AAC5
  "... denn alles, was entsteht, ist wert, daß es zugrunde geht ..."