Subject: help needed

From: Jeroen Baten <[email-masked]>
Date: Wed, 16 Jan 2002 13:40:06 +0100

Hello.

Since a couple of days my appletalk connection doesn't work any more and I 
have no clue as to why. I open the chooser. Select the server (SuSE Linux 
7.3) and it then opens the window where you can select a share (sorry for use 
of MS term). Unfortunately the window never fills with information until the 
moment that I kill the afpd child. But offcourse selecting a share gives the 
message that the server has died.

I did put a -d in afpd and it gaves the following information:

command: 18
12 06 41 46 50 32 2E 32 09 44 48 43 41 53 54 31
..AFP2.2.DHCAST1
32 38 06 6A 65 72 6F 65 6E 00 83 A9 66 2F 39 0B
28.jeroen...f/9.
DD E1 8D FA C9 61 3D CB 1E 7B                           .....a=..{
(end)
reply: -5001, 2
5F C7 1B 01 7F B4 66 E8 40 6B 7F C4 07 02 86 45
_.....f.@k.....E
E4 CE 92 B1 0C 1E 6D 48 C2 2A 46 F2 20 57 79 19         ......mH.*F.
Wy.
9C 74 74 CA F2 3A 16 DA 60 DE FB 4C 67 A6 59 D4
.tt..:..`..Lg.Y.
7A F3                                                   z.
(end)
command: 19
13 00 5F C7 C1 19 94 58 72 A1 23 94 65 55 96 B5
.._....Xr.#.eU..
4F 3B B2 C4 B0 25 58 56 BD 38 EA A4 B1 00 AD C6
O;...%XV.8......
23 16 65 94 82 EC CD B9 2D 55 10 99 7C 84 67 91
#.e.....-U..|.g.
A6 7A C3 09 5E 63 98 B9 C7 1F 7A 90 E0 A4 C4 E3
.z..^c....z.....
D3 D6 10 59 10 70 F2 C3 69 2F EB C9 35 71 89 ED
...Y.p..i/..5q..
AE 0F 57 03                                             ..W.
(end)
reply: 0, 3
(end)
command: 16
10                                                      .
(end)
reply: 0, 4
03 D8 2F C0 02 00 0E 69 32 72 73 20 62 65 73 74         ../....i2rs
best
61 6E 64 65 6E 00 06 6A 65 72 6F 65 6E                  anden..jeroen
(end)
command: 24
18 00 00 20 0E 69 32 72 73 20 62 65 73 74 61 6E         ... .i2rs
bestan
64 65 6E                                                den
(end)
reply: 0, 5
00 20 01 00                                             . ..
(end)
command: 34
22 00 01 00 00 00 00 02 00 00 10 00 02 00               ".............
(end)
reply: 0, 6
00 00 10 00 80 00 87 03 07 07                           ..........
(end)
command: 2
02 00 01 00                                             ....
(end)
reply: 0, 7
(end)
command: 24
18 00 00 20 06 6A 65 72 6F 65 6E                        ... .jeroen
(end)

Can somebody please help?

kind regards,

-- 

  Jeroen Baten            | EMAIL :  [email-masked]
 ____  _  __              | web   :  www.i2rs.nl
  |  )|_)(_               | tel   :  +31 (0)30 221 00 11
 _|_/_| \__)              | fax   :  +31 (0)30 220 31 91
           Kometenlaan 26, 3721 JT, Bilthoven

---

From: Olaf Hering <[email-masked]>
Date: Wed, 16 Jan 2002 14:07:16 +0100

> message that the server has died.

Possible a bug in the older version 1.5pre8. Try the 1.5.0 version:

ftp.suse.com/pub/people/olh/netatalk/

Gruss Olaf

-- 
 $ man clone

BUGS
       Main feature not yet implemented...

---

From: Damien MATTEI <[email-masked]>
Date: Wed, 16 Jan 2002 15:28:32 +0000

> ftp.suse.com/pub/people/olh/netatalk/

i can't believe things go wrong without reasons, i had had some troubles
with true appleshareIP on MacOS 9.x, but restarting reset the problems.
Check if you changed something in your config.
How long does your server run without problems?
look in /var/log/messages for some entries about afp.

-- 
MATTEI Damien					Phone: +33 (0)4 93 37 76 66
C.N.R.S / U.N.S.A				Fax:   +33 (0)4 93 53 30 71
UMR 6549 Instabilite & Alterations des Genomes	E-mail: [email-masked]
Faculte de Medecine - Avenue de Valombrose - 06107 NICE Cedex 2 - France