Subject: Is it a Zone problem ?

From: Deepak Gupta <[email-masked]>
Date: Wed, 17 Jan 2001 15:21:16 +0100 (CET)

I have ibook (blue) with MacOS and Apple Personal Laser NTR.
But I'm love of Linux, so I have SuSe Linux on ibook with 
netetalk running. ibook do not have any apple/parellel/serial port so to
use the printer I have Farallon EtherMac Printer adapter, which connect
to Ethernet port on ibook, and Appletalk port on Printer. 
Everything works fine with ibook running MacOS, and I use printer
without any problem.

But my favourite linux has problem. After setting Netatalk, by 
following the various hints from Web etc. 
Running nbplkup gives
[root@linux /root]# nbplkup             
                         linux:AFPServer   65280.200:128
                         linux:netatalk    65280.200:4
                         linux:Workstation 65280.200:4

But do not shows any Printer entry.

And getzone gives
[root@linux /root]# getzones
atp_rresp: Connection timed out

Many people seems to get this getzone response on Single Zone
network, but some are not (As I get to know by browsing mailing list).
I will also don't bother about it, if my printer works. 

I am Guessing following problems (but don't know solutions).

1) Printer is on a zone differnet from that of default, and hence
nbplkup do not shows it. As getzones fails, I can't even find out
that if there exist a zone other than default (and what's its name).
But if this is the problem, why things work with MacOS ? And how 
to confirm it and correct it, finaly, on linux?

2) Do I need to do something `special' to see the printer across
Farallon Adapter ? (But as I remember I never did anything special
to make it run under MacOS. It just worked!) If yes, What ?

3) Rare possibility, but I need to define the printer's Name/Zone
somewhere. But where and how ?

4) Something else ......

Please HELP. Your help will prevent me to reboot the machine in MacOS to
just take the printouts.

=>dpk
-- 
Deepak K Gupta
C.P.A.T.			  Emails: [email-masked]
Université Paul Sabatier		  [email-masked]
118 rte de Narbonne		  Fax:  (33) 561 556 332
31062 Toulouse, Cedex 4, FRANCE		
Phones: [Office] (33) 561 556 864, [Residence] (33) 561 251 095

---

From: andrew morgan <[email-masked]>
Date: Wed, 17 Jan 2001 08:13:40 -0800 (PST)

> to confirm it and correct it, finaly, on linux?

You could confirm this by booting up MacOS and seeing what it tells you in
the chooser with respect to the zone and the printer's name.

	Andy

---

From: Carsten Neumann <[email-masked]>
Date: Wed, 17 Jan 2001 21:34:22 +0100

> Please HELP. Your help will prevent me to reboot the machine in MacOS to

Seems I had exactly the same problem.
Bringing the Ethernet interface of my linux box into promiscous mode solved my problem.

Typing
/sbin/ifconfig eth0 promisc
will do this.

Regards

	Carsten