Subject: for help

From: ming zhang <[email-masked]>
Date: Thu, 7 Jun 2001 13:18:58 -0700 (PDT)

Dear Netatalk-admins:
    > I am installing netatalk-1.5pre6 on a unix
server
> running SUN OS 5.8 for mac client. The 'make'
command
> generated the following error message which confused
> me.
> Please help me out.
> Thanks a lot.
> 
> Yours,
> ming zhang
> U of Arizona
> 
> # pwd
> /zhangm/netatalk-1.5pre6
> # make all
> make  all-recursive
> Making all in libatalk
> mksh: Fatal error in reader: = missing from
> replacement macro reference
> Current working directory
> /zhangm/netatalk-1.5pre6/libatalk
> *** Error code 1
> make: Fatal error: Command failed for target
> `all-recursive'
> Current working directory /zhangm/netatalk-1.5pre6
> *** Error code 1
> make: Fatal error: Command failed for target
> `all-recursive-am'
> 
> ***following is from ./configure output:
> # ./configure
> creating cache ./config.cache
> checking host system type... sparc-sun-solaris2.8
> checking target system type... sparc-sun-solaris2.8
> checking build system type... sparc-sun-solaris2.8
> checking for a BSD compatible install...
./install-sh
> -c
> checking whether build environment is sane... yes
> checking whether make sets ${MAKE}... yes
> checking for working aclocal... found
> checking for working autoconf... found
> checking for working automake... found
> checking for working autoheader... found
> checking for working makeinfo... missing
> checking for ranlib... ranlib
> checking for gcc... gcc
> checking whether the C compiler (gcc  ) works... yes
> checking whether the C compiler (gcc  ) is a
> cross-compiler... no
> checking whether we are using GNU C... yes
> checking whether gcc accepts -g... yes
> checking for ld used by GCC... /usr/ccs/bin/ld
> checking if the linker (/usr/ccs/bin/ld) is GNU
ld...
> no
> checking for BSD-compatible nm... /usr/ccs/bin/nm -p
> checking whether ln -s works... yes
> updating cache ./config.cache
> checking for object suffix... o
> checking for executable suffix... no
> checking for gcc option to produce PIC... -fPIC
> checking if gcc PIC flag -fPIC works... yes
> checking if gcc supports -c -o file.o... yes
> checking if gcc supports -c -o file.lo... yes
> checking if gcc supports -fno-rtti -fno-exceptions
...
> yes
> checking if gcc static flag -static works... -static
> checking if the linker (/usr/ccs/bin/ld) is GNU
ld...
> no
> checking whether the linker (/usr/ccs/bin/ld)
supports
> shared libraries... yes
> checking command to parse /usr/ccs/bin/nm -p
output...
> ok
> checking how to hardcode library paths into
> programs... immediate
> checking for /usr/ccs/bin/ld option to reload object
> files... -r
> checking dynamic linker characteristics...
solaris2.8
> ld.so
> checking if libtool supports shared libraries... yes
> checking whether to build shared libraries... yes
> checking whether to build static libraries... yes
> checking for objdir... .libs
> creating libtool
> loading cache ./config.cache
> checking for gawk... no
> checking for mawk... no
> checking for nawk... nawk
> checking for gcc... (cached) gcc
> checking whether the C compiler (gcc -g -O2 )
works...
> yes
> checking whether the C compiler (gcc -g -O2 ) is a
> cross-compiler... no
> checking whether we are using GNU C... (cached) yes
> checking whether gcc accepts -g... (cached) yes
> checking for aBSD compatible install... ./install-sh
> -c
> checking whether ln -s works... (cached) yes
> checking whether make sets ${MAKE}... (cached) yes
> updating cache ./config.cache
> checking for object suffix... o
> checking for executable suffix... no
> checking for gcc option to produce PIC... -fPIC
> checking if gcc PIC flag -fPIC works... yes
> checking if gcc supports -c -o file.o... yes
> checking if gcc supports -c -o file.lo... yes
> checking if gcc supports -fno-rtti -fno-exceptions
...
> yes
> checking if gcc static flag -static works... -static
> checking if the linker (/usr/ccs/bin/ld) is GNU
ld...
> no
> checking whether the linker (/usr/ccs/bin/ld)
supports
> shared libraries... yes
> checking command to parse /usr/ccs/bin/nm -p
output...
> ok
> checking how to hardcode library paths into
> programs... immediate
> checking for /usr/ccs/bin/ld option to reload object
> files... -r
> checking dynamic linker characteristics...
solaris2.8
> ld.so
> checking if libtool supports shared libraries... yes
> checking whether to build shared libraries... yes
> checking whether to build static libraries... yes
> checking for objdir... .libs
> creating libtool
> loading cache ./config.cache
> checking for main in -labs... no
> checking for main in -laudit... no
> checking for main in -lauth... no
> checking for main in -lcmd... yes
> checking for main in -lcom_err... no
> checking for main in -lcrypt... yes
> checking for main in -ld... no
> checking for main in -ldb... no
> checking for main in -ldl... yes
> checking for main in -lkauth... no
> checking for main in -lkrb... no
> checking for main in -llwp... no
> checking for main in -ln... no
> checking for main in -lnsl... yes
> checking for main in -lprot... no
> checking for main in -lresolv... yes
> checking for main in -lrpcsvc... yes
> checking for main in -lrx... no
> checking for main in -lrxkad... no
> checking for main in -lsocket... yes
> checking for main in -lsys... yes
> checking for main in -lubik... no
> checking for access... yes
> checking for dirent.h that defines DIR... yes
> checking for opendir in -ldir... no
> checking how to run the C preprocessor... gcc -E
> checking for ANSI C header files... yes
> checking for sys/wait.h that is POSIX.1
compatible...
> yes
> checking for fcntl.h... yes
> checking for limits.h... yes
> checking for stdint.h... no
> checking for strings.h... yes
> checking for sys/fcntl.h... yes
> checking for sys/file.h... yes
> checking for sys/ioctl.h... yes
> checking for sys/time.h... yes
> checking for syslog.h... yes
> checking for unistd.h... yes
> checking for termios.h... yes
> checking for sys/termios.h... yes
> checking for netdb.h... yes
> checking for sgtty.h... yes
> checking for sys/cdefs.h... no
> enabling generic cdefs.h from tree
> checking for working const... yes
> checking for uid_t in sys/types.h... yes
> checking for inline... inline
> checking for mode_t... yes
> checking for off_t... yes
> checking for pid_t... yes
> checking for size_t... yes
> checking for st_rdev in struct stat... yes
> checking whether time.h and sys/time.h may both be
> included... yes
> checking whether struct tm is in sys/time.h or
> time.h... time.h
> checking type of array argument to getgroups...
gid_t
> checking whether gcc needs -traditional... no
> checking for 8-bit clean memcmp... yes
> checking whether sys/types.h defines makedev... no
> checking for sys/mkdev.h... yes
> checking for unistd.h... (cached) yes
> checking for getpagesize... yes
> checking for working mmap... yes
> checking return type of signal handlers... void
> checking whether utime accepts a null argument...
yes
> checking for wait3 that fills in rusage... no
> checking for getcwd... yes
> checking for gethostname... yes
> checking for gettimeofday... yes
> checking for getusershell... yes
> checking for mkdir... yes
> checking for rmdir... yes
> checking for select... yes
> checking for socket... yes
> checking for strdup... yes
> checking for strstr... yes
> checking for strtoul... yes
> checking for setpgrp... yes
> checking whether setpgrp takes no argument... yes
> checking for pam_start in -lpam... yes
> setting configuration files location to NONE/etc
> ./configure: AUTHORS: execute permission denied
> * Solaris specific configuration
> enabling Solaris kernel module build
> updating cache ./config.cache
> creating ./config.status
> creating Makefile
> creating bin/Makefile
> creating bin/adv1tov2/Makefile
> creating bin/aecho/Makefile
> creating bin/afile/Makefile
> creating bin/afppasswd/Makefile
> creating bin/getzones/Makefile
> creating bin/megatron/Makefile
> creating bin/nbp/Makefile
> creating bin/pap/Makefile
> creating bin/psorder/Makefile
> creating config/Makefile
> creating contrib/Makefile
> creating contrib/nu/Makefile
> creating contrib/printing/Makefile
> creating contrib/shell_utils/Makefile
> creating contrib/timelord/Makefile
> creating distrib/Makefile
> creating distrib/config/Makefile
> creating distrib/config/netatalk-config
> creating distrib/initscripts/Makefile
> creating distrib/m4/Makefile
> creating doc/Makefile
> creating etc/Makefile
> creating etc/afpd/Makefile
> creating etc/afpd/nls/Makefile
> creating etc/atalkd/Makefile
> creating etc/uams/Makefile
> creating etc/uams/uams_krb4/Makefile
> creating etc/papd/Makefile
> creating etc/psf/Makefile
> creating include/Makefile
> creating include/atalk/Makefile
> creating libatalk/Makefile
> creating libatalk/adouble/Makefile
> creating libatalk/asp/Makefile
> creating libatalk/atp/Makefile
> creating libatalk/compat/Makefile
> creating libatalk/dsi/Makefile
> creating libatalk/nbp/Makefile
> creating libatalk/netddp/Makefile
> creating libatalk/util/Makefile
> creating man/Makefile
> creating man/man1/Makefile
> creating man/man3/Makefile
> creating man/man4/Makefile
> creating man/man5/Makefile
> creating man/man8/Makefile
> creating sys/Makefile
> creating sys/netatalk/Makefile
> creating config.h
> 
> __________________________________________________
> Do You Yahoo!?
> Get personalized email addresses from Yahoo! Mail -
only $35 
> a year!  http://personal.mail.yahoo.com/
        Next | Inbox   - Choose Folder -[New Folder]  

    as attachmentinline text  Download Attachments  

Yahoo! Messenger - Send instant messages to friends!  
Address Book · Alerts · Auctions · Bill Pay ·
Bookmarks · Briefcase · Broadcast · Calendar · Chat ·
Classifieds · Clubs · Companion · Domains · Experts
·Games · Greetings · Home Pages · Invites · Mail ·
Maps · Member Directory · Messenger · My Yahoo! · News
· PayDirect · People Search · Personals · Photos ·
Shopping · Sports · Stock Quotes · TV · Travel ·
Weather · Yahooligans · Yellow Pages · more...  

Privacy Policy- Terms of Service - Guidelines 
Copyright © 1994-2001 Yahoo! Inc. All rights reserved.

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail - only $35 
a year!  http://personal.mail.yahoo.com/

---

From: Carsten Neumann <[email-masked]>
Date: Fri, 8 Jun 2001 02:36:59 +0200

On Thu, 07 Jun 2001, ming zhang wrote:
[Lots of garbage and spam removed]

Use GNU make!

Best regards

	Carsten