Subject: Having printers other than an Apple Laserwrtiter IINT

From: James Hammett <[email-masked]>
Date: Mon, 12 Mar 2001 15:23:41 -0600

I have a weird setup.  Our Netatalk box is also running Samba and 
shares the local appletalk printers to the 95/98/Me/NT boxes. 
Unfortunately the only way to get the PC's to print correctly is to 
tell them to use the "Apple Laserwriter IINT" print driver. (Even if 
its a brand new lexmark with all sorts of bells and whistles).  Is 
there any way to tell papd that these are a different type of printer?

thanks,
james

---

From: Carsten Neumann <[email-masked]>
Date: Tue, 13 Mar 2001 02:54:05 +0100

> there any way to tell papd that these are a different type of printer?

It looks to me that your problem is not netatalk and papd but Windoze (and probably apsfilter)
related.

I see it this way:

1. You spool your Doze printer files to a spool directory on your Samba server.
2. The data is then sent via pap (not papd!) to your AppleTalk Postscript printer.

I don't know what languages your Lexmark supports, but if you need to switch to another
emulation than Postscript to enable the features you desire, and your Doze-PCs have printer drivers
supporting this, you have use a "raw" device. I.e. a printer spooler which ships the data as-is to
your printer. Usually (for the standard spoolers) apsfilter will always try to convert any data to
Postscript.
To accomplish this you will probably need to install a recent version of apsfilter:

http://www.apsfilter.org/

The newest version is something like 6.0.x.
Older versions have problems when sending Non-Postscript data via pap.

Also make sure you have a new version of Ghostscript installed.
The latest of Aladdin Ghostscript is 6.50.

See:
http://www.cs.wisc.edu/~ghost/

BTW: since my over 10 years old NEC LC890 doesn't support Postscript Level 2, I use its laserjet
emulation and apsfilter, ghostscript, and pap to print my data.
Works great! :-)

HTH,
Regards

	Carsten