Subject: Slackware 8 + netatalk 1.5x problems

From: Mark Guertin <[email-masked]>
Date: Fri, 21 Sep 2001 16:43:46 -0400

Anyone out there tried this combination?

No matter what I do it seems I can't get any kind of authentication
happening, not even cleartext works...

have setup afppasswd via the admin tool, etc...

Any slackware users out there can offer help/tips/suggestions?

Mark
======================================
Mark Guertin, IT Manager
Artshouse Communications Inc.
345 Adelaide Street West, Main Floor
Toronto, ON, Canada   M5V 1R5
Phone (416) 340-6284 x222
Fax - (416) 581-1252

---

From: xris <[email-masked]>
Date: Fri, 21 Sep 2001 14:08:15 -0700

> Any slackware users out there can offer help/tips/suggestions?

Several of us have tried 1.5pre7 with no luck.  The best solution we've
found is to go back to 1.5pre6 and use something like the following (my
config)

./configure --with-shadow --without-pam --with-tcp-wrappers \
--enable-lastdid --disable-ddp \
--with-ssl-dir=/usr/local/ssl --with-config-dir=/etc/atalk

Also, make sure that you grab the latest version of openssl, as the one that
comes with slackware doesn't seem to work (this seems to be the main reason
the passwords fail).   If you have any luck with pre7, please let us know..

-Chris

---

From: Mark Guertin <[email-masked]>
Date: Mon, 24 Sep 2001 13:29:28 -0400

Thanks muchly

Finally got it going, used the latest CVS (pre7), it compiled cleanly.

The problems for me were as follows:

replaced both the openssl and openssh pkgs from slackware 8.0 with latest
versions, also my system somehow had a -lpam (PAM) on it...removed that.

It now works fine, about to do some extensive testing w/ Quark, etc.

Thanks for the help.

Mark

> From: xris <[email-masked]>
> Date: Fri, 21 Sep 2001 14:08:15 -0700
> To: Mark Guertin <[email-masked]>, <[email-masked]>
> Subject: Re: Slackware 8 + netatalk 1.5x problems
> Resent-From: [email-masked]
> Resent-Date: Fri, 21 Sep 2001 17:11:21 -0400 (EDT)
>

---

From: Thomas Baumann <[email-masked]>
Date: Mon, 24 Sep 2001 19:49:31 +0200

I´m sorry; How can I do that ?
What have I tell my admin to fix this.

Sorry, dear list, I\'ll be in the office,
and try to fix this problem.

- tom

Please fix your out of office replies to not reply to 
lists ;)

I\'m sure you will here this from others as well

Mark

> From: Thomas Baumann <[email-masked]>
> Date: Mon, 24 Sep 2001 18:25:25 +0100
> To: Mark Guertin <[email-masked]>
> Subject: Out of Office AutoReply: Slackware 8 + 
netatalk 1.5x problems
> 
> I´m not in the office today. You can reach me via my 
normal extention number
> -773.

-----------------------------------------------------
This mail sent through IMP: http://web.horde.org/imp/

---

From: [email-masked]
Date: Wed, 26 Sep 2001 05:07:36 +0200

How does one remove "-lpam (PAM)" that you describe?

All the best /Mikko