Subject: RE: Hidden Files Not Being Copied

From: "Vaughn, George" <[email-masked]>
Date: Thu, 18 Jan 2001 11:29:21 -0800

You're both right. Ignore my earlier post as erroneous and full of many bad
things. Apparently, my brain decided to shut off, but my hands kept talking.
Feel free to ignore my posts from now on, as obviously undernourished by
brainpower ;-) 

I'm going to bed.

G 

-----Original Message-----
From: David R Bosso [mailto:[email-masked]]
Sent: Thursday, January 18, 2001 11:19 AM
To: [email-masked]
Subject: RE: Hidden Files Not Being Copied

--On Thursday, January 18, 2001 10:47 AM -0800 "Vaughn, George" 
<[email-masked]> wrote:

> Macs don't create files without resource forks. If a file exists on a
> MacOS filesystem (FS), it has a resource fork. If a file is copied to a
> MacOS FS without a resource fork, one is created as soon as MacOS looks
> in the directory (this is why MacOS takes a while for DOS-formatted disk
> contents to appear, it's creating resource forks for the contents of the
> viewed directory).

Woah, I think you're confusing resource forks with Finder information. 
Resource forks are _not_ ubiquitous.  Maybe you've never tried opening a 
file with Resedit that does not have a resouce fork and recieved the 
following dialog:

"The file 'filename' has no resource fork.  Opening it will add one. Do you 
wish to open it?

-David

---

From: Jason Quigley <[email-masked]>
Date: Fri, 19 Jan 2001 14:38:06 +0100

I think that one thing has been proven by this thread: the documentation is inadequate.
I know that the config files and source have some documentation in them but it's a long way to go to try and get things running smoothly. I'd offer to do the docs myself, but I'm already working 28 hours a day!

Cheers,
Jason.

On Friday, January 19, 2001, at 01:32 PM, Michalowski Thierry wrote:

> OK folks, let's clarify something on the U*X side. 
>  
> A file beginning with a . is definitely NOT MEANT to be "invisible". 
> It is only that the default "ls" command behaviour is to filter out these 
> files, for readability purposes. 
> And the default shell wildcard, "*", too. 
>  
> Any other thingy (command, API) in the U*X world "sees" everything in a 
> directory. 
>

---

From: Jason Quigley <[email-masked]>
Date: Sat, 20 Jan 2001 02:06:08 +0100

Ah yes, I know about "options:usedots". I was leaning more towards the idea of having a separate configuration file which would contain filenames or globs so that exactly which files are seen can be tightly controlled, much the way files can be marked as hidden in Samba.

Cheers,
Jason.

On Saturday, January 20, 2001, at 12:58 AM, Bill Moran wrote:

> Jason Quigley wrote: 
> >  
> > Are there some configuration parameters that I'm unaware of? 
>  
> Yes, there are two config options in the config file that control the 
> way dotfiles are treated by Netatalk. It's possible to have them show up 
> simply as regular files. 
>  
> -Bill 
>  
>  
>