Subject: Re: logging in

From: "Rolf Schoepfer" <[email-masked]>
Date: Thu, 14 Feb 2002 14:57:28 +0100

Hello Ken

I have the same problem posted a few days ago. Unfortunately I didn't solve the problem so far. If you get any good advice, I'll be very interested. Here is what I have posted:

I compiled netatalk 1.5.1.1 under Linux ( no distribution: www.linuxfromscratch.com ). Compiling was done as follow: 

./configure --with-shadow --sysconfdir=/etc/config --with-flock-locks --mandir=/usr/share/man/ --infodir=/usr/share/info/ --with-ssl-dir=/usr/lib/openssl/ 

It all succeeded. Starting atalkd and aftp, looks like: 

Feb  9 17:09:05 www afpd[18859]: TestDrive:AFPServer@* started on 65280.34:128 (1.5.1.1) 
Feb  9 17:09:05 www afpd[18859]: ASIP started on 10.10.10.197:548(2) (1.5.1.1) 
Feb  9 17:09:05 www afpd[18859]: uam: loading (/etc/config/netatalk/uams/uams_guest.so) 
Feb  9 17:09:05 www afpd[18859]: uam: uams_guest.so loaded 
Feb  9 17:09:05 www afpd[18859]: uam: loading (/etc/config/netatalk/uams/uams_dhx.so) 
Feb  9 17:09:05 www afpd[18859]: uam: uams_dhx.so loaded 
Feb  9 17:09:05 www afpd[18859]: uam: "DHCAST128" available 
Feb  9 17:09:05 www afpd[18859]: uam: "No User Authent" available 

Seems to be correct. Afpd was configured like: 

"TestDrive" -loginmesg "Welcome" -transall -uamlist uams_guest.so,uams_dhx.so -nosavepassword 

Login with Mac 9.2 
================== 

OK 
- TestDrive in Chooser is visible 
- Guest login successfully 

NOK 
- Login with Linuxuser returns "wrong password" on mac 
- under /var/log/sys.log is no error or warning message 

I was reading all doc-files in netatalk-tarball and searched the internet, but didn't get out the solution. How can I solve this problem? 
Netatalk has many ways of authentication, but it's not easy to understand which part is involved. For example shadow password: do all uams ( except guest ) use it? 

Any help is appreciated 

Regards, Rolf Schoepfer

---------- Original Message ----------------------------------
From: Ken Gillett <[email-masked]>
Date:  Wed, 13 Feb 2002 20:31:39 +0000

>I've just replaced my previous (mandrake) 1.5.1.1 rpm with my own 
>compiled version as I wanted to incorporate SLP registration. But...
>
>I can no longer log in as anything other than guest. Everything I try 
>says the password is incorrect.
>
>I specified '--with-pam=/etc/pam.d' and '--with-shadow' when I ran 
>configure and I have the guest, cleartxt (linked to pam) and also a 
>new passwd uam. They are listed in netatalk.conf and nowhere else 
>(not changed from before).
>
>I also specified '--disable-ddp', but I can't see that as the problem.
>
>My guess is it's something to do with differences to the uams for my 
>compile from the mandrake rpm, but can someone give me a clue as to 
>what the problem is? I'd really appreciate it.
>
>Thanks.
>
>BTW, the auto SLP registration works fine:-)
>-- 
>
>
>
>Ken  G i l l e t t
>
>_/_/_/_/_/_/_/_/_/
>
>

---

From: Ken Gillett <[email-masked]>
Date: Thu, 14 Feb 2002 16:08:06 +0000

I'm not running atalkd, just afp over tcp, but I seem to have the 
same problem. I think it's an authentication problem and independent 
of whether using tcp or ddp.

I agree it is difficult to figure what's going on with 
authentication. I've only just been told that shadow password auth 
requires the dhx uam. Where's that mentioned in the docs?

I saw your last post and tried to search for it, but there's no 
archive:-( I hoped you'd fixed it.

My guess is that it's down to our incorrect command line options for 
configure but there's little documentation for that.

Any result that I do achieve I'll definitely post to the list, if you 
do as well hopefully we'll crack it:-)

At 2:57 pm +0100 14/2/02, Rolf Schoepfer wrote:
>Hello Ken
>
>I have the same problem posted a few days ago. Unfortunately I 
>didn't solve the problem so far. If you get any good advice, I'll be 
>very interested. Here is what I have posted:
>
>I compiled netatalk 1.5.1.1 under Linux ( no distribution: 
>www.linuxfromscratch.com ). Compiling was done as follow:
>
>./configure --with-shadow --sysconfdir=/etc/config 
>--with-flock-locks --mandir=/usr/share/man/ 
>--infodir=/usr/share/info/ --with-ssl-dir=/usr/lib/openssl/
>
>Feb  9 17:09:05 www afpd[18859]: uam: loading 
>(/etc/config/netatalk/uams/uams_guest.so)
>"TestDrive" -loginmesg "Welcome" -transall -uamlist 
>uams_guest.so,uams_dhx.so -nosavepassword
>
>Login with Mac 9.2
>==================
>
>OK
>I was reading all doc-files in netatalk-tarball and searched the 
>internet, but didn't get out the solution. How can I solve this 
>problem?
>Netatalk has many ways of authentication, but it's not easy to 
>understand which part is involved. For example shadow password: do 
>all uams ( except guest ) use it?
>
>Any help is appreciated
>
>Regards, Rolf Schoepfer
>

-- 

Ken  G i l l e t t

_/_/_/_/_/_/_/_/_/