Subject: PAPD with HP drivers (PTAL-...)

From: "pyx pyx" <[email-masked]>
Date: Fri, 24 Aug 2001 08:56:30

Hi Everyone,

I succesfully installed an HP officejet G85 USB on my linux redhat 7.1 with 
ghostscript-hpijs-5.50-5.rh7.i386.rpm and hpijs-0.97-1.rh7.i386.rpm and i 
used the footmatic driver made with www.linuxprinting.org LPD engine.

I'm using netatalk-1.5pre6-1rh7.i386.rpm for enabling printing from a Mac 
G3.

I created the printer on the mac and spooling seems to start but on my log i 
find:
papd[27648]: No such printer: lp
apd[27648]: printcap problem: lp

I tried many papd.conf types with no success, some examples:
HP-G85:\
:pr=|/usr/bin/lpr -Plp:\
:pd=/etc/atalk/color.ppd:

HP-G85:\
:pr=|/usr/bin/lpr -Phpg85:\
:pd=/etc/atalk/color.ppd:

HP-G85:\
:pr=hpg85:\
:pd=/etc/atalk/color.ppd:

Can someone please tell me who is invoking this damned lp?

Thaks in advance
Paul

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp

---

From: Pete Kuczynski <[email-masked]>
Date: Fri, 24 Aug 2001 07:43:52 -0500

In my limited experience, the 1st printer installed on Linux, must be
called lp, that is why the job is looking for it, and can't find it,
cause you don't have one.

My theory, I had this same error, and renamed my printer from hplaser to
lp, worked after that.

Pete

-- 
_______________________________________
Pete Kuczynski
Sr. Field Engineer
DHL Airways Inc.
Infrastructure Technology & Services
(773)-462-9758
24/7 Helpdesk 1-800-434-5767

---

From: Carsten Neumann <[email-masked]>
Date: Fri, 24 Aug 2001 14:50:16 +0200

> Can someone please tell me who is invoking this damned lp?

In your first example you did it yourself.
The second example should work if you have a printer called "hpg85" in your printcap.

Did you change the correct papd.conf? There may a copy from an older installation having a
different path to the netatalk config files than the one you are using now.

I hope you restarted papd after changing papd.conf, e.g. by restarting netatalk that your changes
can take effect!

Kind regards

	Carsten