Subject: natalk and Mac OS X

From: Peter Duchateau <[email-masked]>
Date: Thu, 28 Jun 2001 18:25:55 +0200

We have a server running linux Mandrake 8 with natalk configured.
(version 1.5pre6-1mdk-i586)
Connecting to the server and using the files works fine from Mac OS 9.

When we connect from Mac OS X, we see the different shares, but when we try
to mount one of them, we get the following error message:

-------------------------------------
Disconnected

The file server "xxxxxx" connection
has unexpectedly closed down.
[date and time]
-------------------------------------

Can someone help me with this problem ?

---

From: Vic Landi <[email-masked]>
Date: Thu, 28 Jun 2001 12:35:01 -0400

Which version of OSX are you using?  Have you upgraded to 10.0.4 yet?

> From: Peter Duchateau <[email-masked]>
> Date: Thu, 28 Jun 2001 18:25:55 +0200
> To: netatalk mailing list <[email-masked]>
> Subject: natalk and Mac OS X
> Resent-From: [email-masked]
> Resent-Date: Thu, 28 Jun 2001 12:30:48 -0400 (EDT)
>

---

From: Stanton Schell <[email-masked]>
Date: Thu, 28 Jun 2001 13:11:13 -0400

Hello,
I am having the same problem; I am working with netatalk-1.5pre2-6 on Redhat
7.1.  This is the version distributed by RH in the Powertools.  I am also
running OS X v10.0.4 on the client machine...

-stanton schell
-- 
Stanton.Schell | [email-masked] | 703.989.6591
Livsform | [email-masked] | 202.328.1967

> From: Vic Landi <[email-masked]>
> Date: Thu, 28 Jun 2001 12:35:01 -0400
> Subject: Re: natalk and Mac OS X
> Resent-Date: Thu, 28 Jun 2001 12:38:25 -0400 (EDT)
>

---

From: Lorenzo Perone <[email-masked]>
Date: Sat, 7 Jul 2001 20:55:42 +0200

I've tried almost all versions of netatalk with OSX
(and all the tricks like loginmessage, et al)
and I tell u, the only one which is working reliably both on 9 and X is netatalk1.4b2+asun2.1.4pre37_test + client OSX 10.0.4.

As for server platform, it is working thruout SuSE 6.3, 6.4, 7.0 on Intel and PPC, as well as on LinuxPPC 2000 Q4 on a G3. Haven't tried with kernel 2.4 yet...

u find it here: ftp://ftp.cobaltnet.com/pub/users/asun/testing/
(to be compiled from source. note: pre39 has the same problems as sourceforge-versions)

The sourceforge versions don't work with OSX (-43 errors all over the place, when u finally manage to log in), and they will continue to do so until there will be enough enthusiasm to solve this problem @ the netatalk project maintainers and developers....

;-(

Lorenzo

ps. if You really find a way to make any sourceforge version work with osx, please tell us how..

---

From: Steven Karel <[email-masked]>
Date: Sat, 07 Jul 2001 16:54:26 -0400

Lorenzo Perone wrote:

> The sourceforge versions don't work with OSX (-43 errors all over the place, when u finally manage to log in), and they will continue to do so until there will be enough enthusiasm to solve this problem @ the netatalk project maintainers and developers...

>From my experience:

2.14pre37 works fine with kernel 2.4.x (compiled on background of Redhat 7.0).

2.14pre37 does have some problems with OS X, especially if you copy large numbers of files (1000+) from a server, or on copying smaller number of files to a server. It's far from bulletproof.

The sourceforge 1.5pre7 CVS version does seem to work at least as well as 2.1.4pre37, IF you compile it with:

--with-did=last.

It would probably help the developers for more users to the test the current CVS version of the code. You can get it from:

http://sourceforge.net/cvs/?group_id=8642

Here is my message to the netatalk-devel list describing test with the CVS version at sourceforge as of about 2 weeks ago.

>
>
>
>
> On Sun, 24 Jun 2001, Joe Clarke wrote:
>
> > Did you compile with --with-did=last?  You need to compile with that
> > option to enable the Mac OS X compatibility code.  Sorry for not being
> > clearer.
>
> OK:
>
> testing
>
>         netatalk-cvs/RH 7.0/guest with OS X 10.0.4
>
> configured with:
>
>          ./configure  --prefix=/usr/local/atalk --enable-redhat
> --with-tcp-wrappers --with-flock-locks --with-pam --with-did=last
>
>
> the immediate "error -43" is gone.
>
> Still get some errors: on moving a large number of files to the netatalk
> server, I get either a spurious "file already exists, cannot copy" error,
> or I get "error code -37". On further examination, this seems to happen
> only when the files originated from OS X. If I move files from the
> netatalk server, then copy them all back to the netatalk server, or if I
> move files from the OS 9.1 partition to the netatalk server, it doesn't
> seem to happen.
>
> I _can_ move large numbers (>1000) files to and from the server.
>
>

---

From: Carsten Neumann <[email-masked]>
Date: Sat, 7 Jul 2001 23:36:07 +0200

> The sourceforge 1.5pre7 CVS version does seem to work at least as well as 2.1.4pre37, IF you compile it with:

Hey, what did I miss?

Is/was/will this message falling out of the future?
The latest netatalk version I know is 1.5pre6.
Never heard of "2.14.x" or "2.1.4.x"!

It seems we are talking about two completely different things!

Regards

	Carsten

---

From: Lorenzo Perone <[email-masked]>
Date: Sun, 8 Jul 2001 03:54:10 +0200

>Never heard of "2.14.x" or "2.1.4.x"!

there are in fact two netatalk packages (which shouldn't be mixed normally):

- one based on netatalk 1.4b2 and mantained by Adrian Sun (the '+asun2.1.x' versions)
(_usually_ defaults to /usr/local/atalk - comes with most linux distribs)
- one which is the 'official' new 1.5 release, mantained by the people at SourceForge.
(_usually_ spreads itself into /etc/atalk, /usr/sbin, /usr/bin and other dirs)

>It seems we are talking about two completely different things!

in fact.... :-)
but configuration files have been compatible, up to yet, among the two.

Lorenzo

---

From: Carsten Neumann <[email-masked]>
Date: Sun, 8 Jul 2001 14:03:24 +0200

> (_usually_ spreads itself into /etc/atalk, /usr/sbin, /usr/bin and other dirs)

Ah, so you're talking about the version of just the asun patches.
The netatalk version was still 1.4.x.
There was never a netatalk version 2.1.x or - even higher - 2.14.x until now!

Regards

	Carsten

---

From: John Seifarth <[email-masked]>
Date: Sun, 8 Jul 2001 23:26:00 +0200

I've never used CVS before, but I'd really like to get netatalk working with mac OS X.

I followed the instructions at the URL below:

>http://sourceforge.net/cvs/?group_id=8642

I installed cvs (I'm running Debian potato), downloaded the module netatalk, but I don't find the ./configure script in the directory created by CVS. I'm stuck.

I note that configure, Makefile and other compilation essentials are listed in the .cvsignore file. So if they're ignored, and not downloaded, how am I supposed to compile the beast?

Any suggestions?

-- 
__________________________________________________________________
John Seifarth                               http://www.waw.be/waw/
Words & Wires SPRL                                     [email-masked]         
Computer Consulting & Language Services   Voice: (+) 32-2-660-3943
1160 Brussels, Belgium                      Fax: (+) 32-2-675-3922

---

From: Steven Karel <[email-masked]>
Date: Sun, 08 Jul 2001 20:23:33 -0400

> I note that configure, Makefile and other compilation essentials are listed in the .cvsignore file. So if they're ignored, and not downloaded, how am I supposed to compile the beast?

I believe all you should need to do is to run the included autogen.sh
script to invoke automake and autoconf. At least that worked for me.