Subject: atalkd under solaris 8

From: Andreas Westendörpf <[email-masked]>
Date: Fri, 15 Feb 2002 15:32:32 +0100

hello folks!
i'm currently having some difficulties configuring an appletalk fileserver 
under solaris8. i tried to get netatalk v1.5.1.1 working. what a pain in 
the a**. finally it compiled without errors, but then, when i start atalkd 
it says:
"atalkd: zero interfaces, exiting."

yes, i did create a file in /usr/local/atalkd/etc/ called atalkd.conf with 
the name of my ethernet-device in it (hme0).
but still it doesn't work. same effect when i remove the atalkd.conf file.

yes, i read it and configured it the right way. means:
- added "ddp tpi_clts - appletalk ddp /dev/ddp -" to /etc/netconfig
- tried "make -f Makefile.kernel kinstall" but it didn't work in the root 
of the source directory. i went in sys/solaris and there it worked out.
- in /usr/local/atalk/atalk/etc/atalkd.conf i added hme0 (my ethernet device)

but atalkd still starts up saying "zero interfaces, exiting.".
no change, even if i remove atalkd.conf

anybody got a clue?

are there any other appletalk-servers for servering basic apple macintosh 
file and print services?

tia

andreas

please help. it's urgent
tia
andreas

---

From: Andreas Westendörpf <[email-masked]>
Date: Fri, 15 Feb 2002 16:01:26 +0100

hi again!
the solaris box has only one nic.

cya

andreas

At 15:38 15.02.2002 +0100, you wrote:
>Hallo,
>
>kaann es sein, dass es mehrere Netzwerkkarten / Interfaces auf der sun gibt?
>
>versuche folgendes, schreib in die atalkd.conf folgende zeile:
>
>Bsp.:
>eth0 -zone admin seed eth1 -zone admin
>
>also hme0 -zone admin seed hme1 -zone admin
>
>dann starte atalkd. normalerweise (jedenfalls unter linux) stoppelt sich
>die kiste dann die zeile zurecht und weiss wo sie hingehört.
>
>Andreas Westendörpf wrote:
> >
> > hello folks!
>--
>mit freundlichen grüssen
>........................................................
>
>Mac Conin                        Taubengasse 9
>                                  D 50676 Koeln
>Neue Telefonnummern!....................................
>CONIN - Agentur                  tel : +49-221-58 007-10
>EUC Online Service GmbH          tel : +49-221-58 007-20
>punktum postscript-Service       tel : +49-221-58 007-70
>Fax Zentrale                     tel : +49-221-58 007-58
>........................................................

---

From: Sebastian Rittau <[email-masked]>
Date: Fri, 15 Feb 2002 23:17:14 +0100

On Fri, Feb 15, 2002 at 03:32:32PM +0100, Andreas Westendörpf wrote:

> the a**. finally it compiled without errors,

*Please* tell us about the errors if you can. We would really like to
fix them.

> but then, when i start atalkd 
> it says:

Are you sure that atalkd looks in /usr/local/atalkd/etc? If in doubt,
please use a utility like strace to find out.

 - Sebastian