Subject: Problem with more then one netatalk server

From: Scodeller Marco <[email-masked]>
Date: Thu, 29 Mar 2001 18:25:15 +0200

> Hello,
> we have problem in using netatalk in the moment that there is more then
> one netatalk server on the same network.
> What happens is that in the chooser of the macintosh you can see and
> connect only one of them.
> How is it possible to solve this problem?
> Regards.
> 
> Scodeller Marco
> HYPHEN- GROUP
> HYPHEN- ITALIA * GRAPH-OS * ANY.COM * KEY ACCESS
> Via A. de Gasperi, 17
> 37013 Caprino Vr.se Verona - Italy
> Phone +39 045 7242446
> Fax +39 045 7242629
> http://www.hyphen-italia.com
> E-mail: [email-masked]
> 
>

---

From: Lorenzo Perone <[email-masked]>
Date: Thu, 29 Mar 2001 23:14:44 +0200

>> E-mail: [email-masked]

- do the servers have the same hostnames(!)?
- or do you have the same share name in all afpd.confs (maybe while copying the files across the servers)?
- or do some servers (especially those with more than one NIC) miss the ethX line in atalkd.conf?
- is atalkd started on those other machines....?

we have 3 netatalks on the same network and i can see all of them. All of them have the eth information stored in atalkd.conf - didn't show up otherwise.

....

if you can't get some servers to show up, either because they're on different physical networks or for any other reason, remember you can always 'advertise' those servers from the one that is visible, by adding -ipaddr servers in afpd.conf
(it is described clearly in the conf comments)

:-)

Lorenzo