Subject: HELP: Request for Information!

From: Steve Freitas <[email-masked]>
Date: Tue, 18 Sep 2001 01:27:04 -0700

Hi folks,

I'm trying to do a non-programmer's job of tracking down the culprit behind
the sometimes difficult relationship between Quark and Netatalk.

We've got a complicated set of datapoints. Could those with non-working and
working Quark installations supply the mailing list with a few points of
information?

I know a few of you have done this, but I'd like to generate a fresh report.
Information is needed such as...

1. Netatalk version (+ any patches), plus compile-time options if you
compiled it (specifically locking-related options). If you didn't compile
it, note the specific binary package used so the package generator can tell
us about it.

2. Server operating system, with kernel version and filesystem type. If you
know of any strange issues with these, let us know. (E.g., I believe Linux
2.2's locking code was flaky, don't know if that's fixed on 2.4. TcX cited
this as a reason for not supporting row-level locking on MySQL, I believe.)

3. Client operating system and version

4. Quark version

5. Quark save method (with/without previews, any other options)

6. Whether it works, doesn't work, or partially works. If it doesn't work,
what does it report?

Hopefully we can build a little matrix and find a clue or three.

Thanks!

Steve

---

From: Nicky Haan <[email-masked]>
Date: Tue, 18 Sep 2001 10:46:59 +0200

Hi,

from what i think happens with quark is really a problem with filenames, i
noticed that DTP ppl really like using / $ % * : and so on in filenames, these
obviously get screwed if u put them on an appeltalk unix machine.
For your information the awnsers to the questions:
1) netatalk-1.5pre6-1mdk und mandrake 8.0,  had the same problems on a self
compiled version under rh 6.1 (cant remember what version atalk was but the
newest there was about august 2000

2) rh was 2.2 kernel and ext 2 and mandrake is 2.4 kernel with riserfs

3) mac os 9.01 and 9.04

4) quark passport 4.1

5) with preview and single language files

6) the redhat system didnt work at all, the mandrake one does better but still
not satisfiing, dont know the error messages (but as i said above i think
atleast 95 % of the problem is the filenames)

hope this helps

--
----------------------------------------
Nicky Haan
Unix/Linux Sysadmin / Systems Engineer
NetCASE Interactive Solutions
Dr. Nolenslaan 140
6136 GV Sittard
Netherlands
Tel: +31(0)46 420 1880
Fax: +31(0)46 420 1881
E-Mail: [email-masked]
Web: www.netcase.nl
----------------------------------------

---

From: Marcus Radich <[email-masked]>
Date: Tue, 18 Sep 2001 21:34:22 +1200

Greetings.

My company supplies IBM x200 servers preconfigured to netatalk and 
samba for Mac and PC publishing environments.

Our netatalk drama:
- We were using asun2.13 for a long time, but then with the intro of 
the G4 - we had a problem with disconnects. I emailed adrian and he 
told me to use 2.14 - he had just solved the disconnect issue with 
2.14.
- We installed 2.14 on our problem servers, and it solved the 
disconnect issue! Great......but.....then some operators were 
complaining that their files were "already open by another user" etc 
etc.
- Read through adrian's notes in the ReadMe and found this line:
"    byte locks should now work. if you want to enable the old way
         of doing things, add -DUSE_FLOCK_LOCKS."
I added this to our compile options - and the Quark 'open' problems went away.
This was all back in late 1999, and we have used asun2.14-37b since.

We have over 30 servers running with this config, and all works well. 
We used to have the occasional problem with folders ending up in the 
trash - but since switching to ReiserFS - no problems have shown up 
(Fingers crossed).

Here is our latest config:
Hardware: IBM x200 e-series, Promise Ultra-100 ide card, IBM Disks.
OS: Mandrake 8.0 with all updates. Software-RAID with ReiserFS.
netatalk version: asun2.14 pre37b
compile options: DEFS= -DUSE_FLOCK_LOCKS

Macs:
OS 8.1 through to 9.2.1
Appleshare client 3.8.3 minimum
QuarkXPress 3.32r5 and 4.11

Quark files saved with previews on.

Any tests anyone wants me to run, let me know.

Marcus

-- 
========================================================

"Always ask the question, never assume the answer."
		Marcus Radich 1999

========================================================

---

From: Simon Bazley <[email-masked]>
Date: Tue, 18 Sep 2001 11:44:08 +0100

wasn't there an old post about this showing a site that had tracked the problem down to quark creating temporary files.  

It was something like, if you click on a quark document that is on a mounted share, then quark will create the temporary file at that location (on the server), wheras if you go file open, then find the same file in the open dialog, the temprary file is
created on a local file system.  

The issue was down to quarks use of its temporary file (which is basically a dump of the quark file in a dodgy order).  Quark uses a naughty bit of code that was in early macs file system, that was to do with opening a file, but not closing it, so you
still stored data, but didn't create a file (or something like that).  Anyway, Apple say its not something people should use, and most afpd's don't support it (and rightly so), but quark insists on keeping it, as it works locally, and on mac servers.  

Or are you talking about soemthing completely different.  

Simon

---

From: Magnus Stenman <[email-masked]>
Date: Tue, 18 Sep 2001 17:42:53 +0200

Simon Bazley wrote:
> still stored data, but didn't create a file (or something like that).  Anyway, Apple say its not something people 

Could it be the old (also used on *nix) trick:
create/open file, delete (unlink) it, but don't close it.
Read/write from file, and when closed, file magically goes away?

That might work strangely in a network environment I imagine.

/Magnus

should use, and most afpd's don't support it (and rightly so), but quark
insists on keeping it, as it works locally, and on mac servers.