Subject: Speed Tests

From: "Lawrence Farr" <[email-masked]>
Date: Thu, 17 Jan 2002 17:05:42 -0000

I have done some Helios Lantesting of Appleshare servers,
and come up with some good results. These are all done 
from the same test mac (A G4 400, 100Mbit connection), 
and connected to the same switches (Extreme Networks 
Summit 48 and 1). All readings are 10 pass averages, and 
the mac is the only client.

Machine 1 FreeBSD 4.4-STABLE 

Celeron 400, 256Mb 66Mhz RAM, 4xUDMA33 Disks Striped in
software. (Vinum).
3com 3C985 SX in a 32 bit/33Mhz slot @ 1000Mbit FDX.

Average Read 	9857.686 Kb/Sec
Average Write 	9580.123 Kb/Sec

Machine 2 Windows 2000 Service Pack 2

Quad Xeon 700/2Mb, 4096Mb 133Mhz RAM, 5x10kRPM U160 drives,
Striped on a Dell PERC2 With 128Mb cache.
3com 3C985 SX in a 64 bit/66Mhz slot @ 1000Mbit FDX.

Average Read	9211.537 Kb/Sec
Average Write	8948.165 Kb/Sec

Lawrence Farr
EPC Direct Limited

---

From: Russell Kerrison <[email-masked]>
Date: Fri, 18 Jan 2002 22:03:20 +1100

What was the test size on these? In my testing of both Win 2000 and Netatalk
machines, I found that when I went to a 300Mb file size my write speed began
to decline after the first test. I'm looking to move to gigabit, but I am
concerned as to where the bottleneck lies, and whether with gigabit I'll be
getting the kind of throughput that the server disks can handle.

Russell.

---

From: "Lawrence Farr" <[email-masked]>
Date: Fri, 18 Jan 2002 11:15:04 -0000

This is with the 30Mb test file. It's the release version
of Netatalk, and Jumbo Frames are enabled on the Win2k box
and the switch, but not on the FreeBSD test one.

Lawrence Farr
EPC Direct Limited 

> -----Original Message-----
> From: Russell Kerrison [mailto:[email-masked]] 
> Sent: 18 January 2002 11:03
> To: Lawrence Farr
> Cc: [email-masked]
> Subject: Re: Speed Tests
> 
> 
> 
>

---

From: "Eric J. Feldhusen" <[email-masked]>
Date: Fri, 18 Jan 2002 08:16:51 -0500

So far, I've seen better performance using multiple 10/100 cards. Usually, 3
10/100 cards will have better performance than one gigabit ethernet card.
Of course, the problem is with having enough ports in your switches and open
slots in the computer.

Eric Feldhusen

On 1/18/02 6:03 AM, "Russell Kerrison" <[email-masked]> wrote:

> I'm looking to move to gigabit, but I am

---

From: "Lawrence Farr" <[email-masked]>
Date: Fri, 18 Jan 2002 13:53:18 -0000

Ok, Here's some tests with 300Mb files. My poor celeron
started to show it's limits, so I built a quick replacement,
still nowhere near as powerful as the Win2k box though!

Here's the original two machines at 300Mb testsize:

Machine 1 FreeBSD 4.4-STABLE Netatalk 1.5R

Average Read 	6896.241 Kb/Sec
Average Write 	4638.899 Kb/Sec

Average Read	9732.36  Kb/Sec
Average Write	9623.616 Kb/Sec

And the new test machine at 300Mb Testsize:

Machine 3 FreeBSD 4.4-STABLE Netatalk 1.5R

P3 800, 1Gb 100Mhz RAM, 2x10kRPM LVD drives,
Striped on an Adaptec SCSI controller.
Intel EtherExpress 10/100Mb Card @ 100Mb FDX

Average Read	10103.846 Kb/Sec
Average Write	10004.49  Kb/Sec

Lawrence Farr
EPC Direct Limited

---

From: "Daniel E. Lautenschleger" <[email-masked]>
Date: Fri, 18 Jan 2002 08:15:40 -0600 (CST)

Have you tested with all three machines at once? I think you'll see the
results drop off dramatically.

-Dan

---------------------------------
Daniel E. Lautenschleger
Computer Guy
R.M. Bock Labs
University of Wisconsin - Madison

On Fri, 18 Jan 2002, Lawrence Farr wrote:

> _______________________________________________
> Netatalk-devel mailing list
> [email-masked]
> https://lists.sourceforge.net/lists/listinfo/netatalk-devel
>

---

From: "Lawrence Farr" <[email-masked]>
Date: Fri, 18 Jan 2002 14:27:45 -0000

Errr, how do you mean?

Lawrence Farr
EPC Direct Limited 

> From: Daniel E. Lautenschleger [mailto:[email-masked]] 
> Sent: 18 January 2002 14:16
> To: Lawrence Farr
> Cc: 'Russell Kerrison'; [email-masked]; 
> [email-masked]
> Subject: Re: [Netatalk-devel] RE: Speed Tests
> 
>

---

From: "Daniel E. Lautenschleger" <[email-masked]>
Date: Fri, 18 Jan 2002 08:33:10 -0600 (CST)

I mean I've tested up to 7 machines running LanTest against a Netatalk box
and I found the first machine that connects to the Netatalk box has pretty
decent performance but after adding several other LanTest machines,
performance drops off on all of them.

-Dan

---

From: "Lawrence Farr" <[email-masked]>
Date: Fri, 18 Jan 2002 14:38:36 -0000

What spec server? Switches/Hubs? Linux? *BSD? 

Have you tried the same tests against Win2k or Helios?

Lawrence Farr
EPC Direct Limited 

> Sent: 18 January 2002 14:33
> To: Lawrence Farr
> Subject: RE: [Netatalk-devel] RE: Speed Tests
> 
>

---

From: Thomas Kaiser <[email-masked]>
Date: Fri, 18 Jan 2002 15:46:31 +0100

> performance drops off on all of them.

If your server is connected via fast ethernet, then the results are
obviously correct. The LanTest clients have to share the bandwidth.

But even if you put in a gigabit ethernet NIC and have high performance
switches, you won't be able to test the performance of "netatalk itself"
with such limited testing. You will only be able to test for bottlenecks
(IO, networking, quality of drivers) on a specific machine/architecture.

Regards,

Thomas