Subject: Cannot print any longer

From: Carsten Neumann <[email-masked]>
Date: Thu, 12 Apr 2001 03:53:50 +0200

Hi all,

I just installed netatalk 1.5pre5.
Afpd and papd seem to work well for me, but I cannot print any more
to my AppleTalk printer.
I was using 1.4b2+asun2.1.3 before and printing worked fine.
Now I have a serious PAP problem.
An interactive pap dialog showed the following:

<dialog>
athlet:~ # pap -p Lasie
Trying 65280.226:202 ...
status: waiting; source: AppleTalk
...
status: waiting; source: AppleTalk
status: busy; source: AppleTalk
...
status: busy; source: AppleTalk
status: idle
Connected to Lasie:LaserWriter@*.
Bad status response!
athlet:~ #
</dialog>

Downgrading to 1.4b2+asun2.1.3 verified that I still can
print with the old netatalk software.
But I need the new one because of the afpd death when AppleSharing
HFS CDs.

Thanks in advance, regards

	Carsten

---

From: Jonathan Paisley <[email-masked]>
Date: Thu, 12 Apr 2001 10:27:36 +0100 (BST)

You might be able to use the old papd binary in conjunction with the new
afpd. That would solve the problem in the interim.

I'm not sure how papd interacts with atalkd, and how stable that interface
has been over the recent versions. If it's ok, then things should still
run. If you're not interested in AFP over DDP, then you could always use
the atalkd for the old distribution too (then afpd will only use TCP/IP)
if there is such a problem.

-- 
Jonathan Paisley
[email-masked]

---

From: Carsten Neumann <[email-masked]>
Date: Thu, 12 Apr 2001 19:13:25 +0200

> afpd. That would solve the problem in the interim.

No, not really. ;-)
I (mostly) don't want to print onto a spooler of my linux box,
but via the famous program "pap" from my linux box to an AppleTalk printer.
And the new papd seems to work, data from my Mac arrived on my linux box.
It's just the other way ... :-(

> if there is such a problem.

I do use DDP exclusively, running MacOS 7.6.1 on my IIfx (no AppleTalk via IP!).
7.6.1 is the latest - and last - for that machine.
So, no way!

> > Thanks in advance, regards

Thank you for your reply

	Carsten

---

From: Jonathan Paisley <[email-masked]>
Date: Thu, 12 Apr 2001 21:07:24 +0100 (BST)

> It's just the other way ... :-(

Duh! Silly me. I should have read your original message more thoroughly.
Sorry.

Would it be foolish of me to ask if you've tried the pap from the old
distro with the new one?

-- 
Jonathan Paisley
[email-masked]

---

From: Carsten Neumann <[email-masked]>
Date: Thu, 12 Apr 2001 22:27:31 +0200

> Would it be foolish of me to ask if you've tried the pap from the old

No, it wouldn't. ;-)
But I tried this, of course.

It cannot even lookup the NBP name, and since there is no way to circumvent this lookup
it fails before reading the status from the printer.

Regards

	Carsten