Subject: papd trouble

From: Martin McWhorter <[email-masked]>
Date: Mon, 16 Apr 2001 16:13:16 -0500

Hello,

I am having a problem with papd. I can see the printer in MacOS chooser,
but can not print to it.

Of course this is because when I start papd on RH 6.2 linux it stops
shorly after with this message in the /var/log/messages
Apr 16 15:50:28 m_mcwhorter papd[7460]: restart (1.4b2+asun2.1.3)
Apr 16 15:50:36 m_mcwhorter papd[7460]: can't register lp:LaserWriter@*

My /etc/atalk/papd.conf looks like this
lp:ps=lp:op=m_mcwhorter:pd=/etc/atalk/9955_65.ppd:

and my /etc/printcap looks like this:
##PRINTTOOL3## SMB ljet4 600x600 letter {} LaserJet4 Default {}
lp:\
        :sd=/var/spool/lpd/lp:\
        :mx#0:\
        :sh:\
        :if=/var/spool/lpd/lp/filter:\
        :af=/var/spool/lpd/lp/acct:\
        :lp=/dev/null:

I have read all the available Documentation and scoured the mail
archive... to no avail.

Thanks much,
Martin

-- 
Martin McWhorter
Network Administrator
Prairie
708 563 5832

---

From: Jonathan Paisley <[email-masked]>
Date: Tue, 17 Apr 2001 12:13:09 +0100 (BST)

> Apr 16 15:50:36 m_mcwhorter papd[7460]: can't register lp:LaserWriter@*

That looks a bit like it can't register the name because it's already
registered (i.e. there's already a LaserWriter called lp on the network,
or some previous instance of papd died without unregistering).

try

$ nbpunrgstr lp:Laserwriter

I'm not entirely sure what the syntax of that command is (I've not tried
this recently), but you should get the idea.

-- 
Jonathan Paisley
[email-masked]

---

From: Martin McWhorter <[email-masked]>
Date: Tue, 17 Apr 2001 08:42:59 -0500

Thanks Jonathan,

nbpunrgsr lp:LaserWriter
	or
nbpunrgsr lp:LaserWriter@*

Returns:
Can't unregister lp:LaserWriter@

Obviosly this is part of my problem. I changed the name of the printer
in the papd.conf to misptr. Same results.

Apr 17 08:35:24 m_mcwhorter papd[29587]: restart (1.4b2+asun2.1.3)
Apr 17 08:35:32 m_mcwhorter papd[29587]: can't register
misptr:LaserWriter@*

[root@m_mcwhorter m_mcwhorter]# nbpunrgstr misptr:LaserWriter  
Can't unregister misptr:LaserWriter@*

Thanks In Advance,
Martin

-- 
Martin McWhorter
Network Administrator
Prairie
708 563 5832

---

From: Carsten Neumann <[email-masked]>
Date: Tue, 17 Apr 2001 18:32:01 +0200

> Can't unregister misptr:LaserWriter@*

What does nbplkup tell?
Is there another "<printername>:LaserWriter" registered?
If yes, has it the same net.node like the server?

Can you see other nodes (Macs) at all?
If not this is a good hint that netatalk does not properly start up.

E.g.: I have to put my interface into promiscuous mode.
But then I have to start netatalk TWICE at boot.
After the first start I can't see other nodes on my net.

BTW: Has somebody encountered the same problem?
Does he/she know what goes wrong and how I can solve this more
elegant than starting netatalk twice?

Best wishes

	Carsten

---

From: Martin McWhorter <[email-masked]>
Date: Tue, 17 Apr 2001 12:28:58 -0500

> What does nbplkup tell?

It shows all the appletalk devices on the network. 

> Is there another "<printername>:LaserWriter" registered?
No, There is no lp:LaserWriter or misptr:LaserWriser in the list.

> Can you see other nodes (Macs) at all?
Yes. Macs can connect to my Atalk shares fine. From a Mac I can drag and
drop files back and forth the my linux server.

> If not this is a good hint that netatalk does not properly start up.
Atalk starts fine 

[m_mcwhorter@m_mcwhorter temp]$ ps -ax | grep atalk
 1330 ?        S      0:06 atalkd
11725 pts/2    R      0:00 grep atalk

Just not papd.

Any ideas? Im stuck.
 
Thanks,
Martin

---

From: Carsten Neumann <[email-masked]>
Date: Tue, 17 Apr 2001 20:35:27 +0200

> lp:ps=lp:op=m_mcwhorter:pd=/etc/atalk/9955_65.ppd:

Hrrrglllmppphhff!  (Some sort of curse! ;-) )
Stupid me!
I saw this in your first message, but forgot to verify this.
You made a typo in your papd.conf!
There is no "ps" attribute.
You probably mean "pr=lp:".

BTW: If your lpd isn't started when data arrive in your spooler queue you can pipe the data to lpr:
"pr=|/usr/bin/lpr -Plp:". The daemon is then started by lpr.

HTH

	Carsten