Subject: quark file locking

From: Jeff Masud <[email-masked]>
Date: Wed, 1 Aug 2001 05:43:03 -0700 (PDT)

Another question, I've been having an issue that users with Quark and
Adobe Indesign have been experiencing "File is locked" when they try to
save a file that they opened from the server, modified and hit save.

I went through and changed some permissions around and half the users are
working and the other half are still getting this file locked
scenario.  Any suggestions?

thanks
Jeff

---

From: Rob deMallac <[email-masked]>
Date: Wed, 1 Aug 2001 12:01:27 -0700 (PDT)

This is a known issue with Quark XPress, although it's the first I've read
of it for InDesign.

http://www.macwindows.com/quark.html

"A number of readers have reported problems of Quark Xpress file
corruption when saving files to an AFP server. The problem was first
reported with PC MacLAN, but has since been reported occurring with all
AFP servers, including Windows NT SFM, AppleShare IP 6, MacServerIP, and
Linux running Netatalk. The problem seems to be cause by the unusual way
Quark Xpress saves files.

...

Because of the way Quark handles its temp files, it is a bad idea to open
a Quark file from any AFP Server. The best thing to do is to copy the
Quark file to the local machine, open it, edit it, and close it; then copy
it back to the AFP Server."

Pain in the butt, but Quark doesn't play nice with AppleShare networks.

On Wed, 1 Aug 2001, Jeff Masud wrote:

> Date: Wed, 1 Aug 2001 05:43:03 -0700 (PDT)
> From: Jeff Masud <[email-masked]>
> To: [email-masked]
> Subject: quark file locking
> Resent-Date: Wed, 1 Aug 2001 09:52:25 -0400 (EDT)
> Resent-From: [email-masked]
> 

*********************************
Rob deMallac
Network Manager
SFSU Journalism Department
http://www.journalism.sfsu.edu/
*********************************

---

From: seiji <[email-masked]>
Date: Thu, 02 Aug 2001 09:41:13 +0900

HI

I am using pre-asun2.1.4-37b.tar.gz on Redhat 7.1
So far there is not a problem even MacOSX even Quark.

I change this part of "Makefile" like the lower part.

Before a change
--------------------------------------------------------
# for system-level binaries
SBINDIR=$(DESTDIR)/sbin
# for user-level binaries
BINDIR=$(DESTDIR)/bin
# for program libraries (*.a)
LIBDIR=$(DESTDIR)/lib
# for machine-independent resources (pagecount.ps, etc.)
RESDIR=$(DESTDIR)/etc
# for configuration files (AppleVolumes.system, etc.)
ETCDIR=$(DESTDIR)/etc
# for include files
INCDIR=$(DESTDIR)/include
# Root of man pages. Subdirectories will be
# ${MANDIR}/man1, ${MANDIR}/man4, and ${MANDIR}/man8.
MANDIR=$(DESTDIR)/man
　　　　　　　　　　　
#INSTALL_PREFIX=
#SBINDIR=${INSTALL_PREFIX}/usr/sbin
#BINDIR=${INSTALL_PREFIX}/usr/bin
#LIBDIR=${INSTALL_PREFIX}/usr/lib
#RESDIR=${INSTALL_PREFIX}/usr/lib/atalk
#ETCDIR=${INSTALL_PREFIX}/etc/atalk
#INCDIR=${INSTALL_PREFIX}/usr/include
#MANDIR=${INSTALL_PREFIX}/usr/man

---------------------------------------------------------

After a change
---------------------------------------------------------
# for system-level binaries
#SBINDIR=$(DESTDIR)/sbin
# for user-level binaries
#BINDIR=$(DESTDIR)/bin
# for program libraries (*.a)
#LIBDIR=$(DESTDIR)/lib
# for machine-independent resources (pagecount.ps, etc.)
#RESDIR=$(DESTDIR)/etc
# for configuration files (AppleVolumes.system, etc.)
#ETCDIR=$(DESTDIR)/etc
# for include files
#INCDIR=$(DESTDIR)/include
# Root of man pages. Subdirectories will be
# ${MANDIR}/man1, ${MANDIR}/man4, and ${MANDIR}/man8.
#MANDIR=$(DESTDIR)/man

INSTALL_PREFIX=
SBINDIR=${INSTALL_PREFIX}/usr/sbin
BINDIR=${INSTALL_PREFIX}/usr/bin
LIBDIR=${INSTALL_PREFIX}/usr/lib
RESDIR=${INSTALL_PREFIX}/usr/lib/atalk
ETCDIR=${INSTALL_PREFIX}/etc/atalk
INCDIR=${INSTALL_PREFIX}/usr/include
MANDIR=${INSTALL_PREFIX}/usr/man
--------------------------------------------------

And I change this part of "Makefile" like the lower part.

Before a change
CRYPTODIR=/usr/local/ssl

After a change
#CRYPTODIR=/usr/local/ssl

And I change this part of "Makefile" like the lower part.

Before a change
#DESDIR=/usr/local

After a change
DESDIR=/usr/local

And I change this part of "etc/afpd/Makefile" like the lower part.

Before a change
CFLAGS=****

After a change
CFLAGS=**** -DSHADOWPW

And I change this part of "sys/linux/Makefile" like the lower part.
(In case of me, there was not a problem of a lock of Quark when I took out
this option.)

Before a change
DEFS=$$OSDEFS $$MACHINEDEFS $$QUOTADEF

After a change
DEFS=$$OSDEFS $$MACHINEDEFS $$QUOTADEF -DUSE_FLOCK_LOCKS

# make
# make install
# cd config
# cp AppleVolumes.default /etc/atalk
# cp AppleVolumes.system /etc/atalk
# cp atalkd.conf /etc/atalk
# cp papd.conf /etc/atalk
# cd /etc/atalk

/usr/bin/afppasswd -acf
(Then a file named "afppasswd" comes "/usr/lib/atalk/".)

/usr/bin/afppasswd username
(Input a password twice.)

In "/etc/atalk/afpd.conf" file, add "-passwdfile /usr/lib/atalk/afppasswd"

Good Luck!!

====
naka
====

---

From: Axel Rose <[email-masked]>
Date: Thu, 2 Aug 2001 10:20:03 +0200

Rob cited:
>... Because of the way Quark handles its temp files, it is a bad idea to open

This is rubbish.

Commercial workflow solutions always open Quark files from
the server. This causes problems only if you have a
corrupted desktop file (with Helios EtherShare this might
happen if you are playing in the Unix file system) or you
have no way to store alias information on the server volume
(that's what's missing in netatalk).

Best regards

Axel