Subject: OS9-iMAC and netatalk

From: Renato BARRIOS <[email-masked]>
Date: Thu, 10 Jan 2002 08:24:28 +0100

Hi all,
I have a pc with a debian 2.2 with netatalk(1.4 version). I can see the pc
with the imac selector(an ethernet connection) but I have been never able to
print. I can see my printer with the iMAC OS9 printer utilities (as  Apple
printer utility PPC) and I have a message obout  a spooler attached. I tried
it with and without papd.conf
I tried to use a Hewlett Packard Deskjet 540 but also a Cannon BJ 4200 that
run well with aps2filter in my debian and I can print with Ghostview,
mozilla and simple lpr command.
My printcap file is :
Hi,
I have a pc with a debian 2.2 and netatalk installed. I can see the pc with
the imac selector(an ethernet connection) but I have been never able to
print. I can see my printer with the iMAC OS9 printer utilities (as an
appletalk printer) and I have a message obout  a spooler attached. I tried
it with and without papd.conf
I tried to use a Hewlett Packard Deskjet 540 but also a Cannon BJ 4200 that
run well with aps2filter and I can print with Ghostview, mozilla and simple
lpr command. 
Please help me to resolve it.
Thanks,
Renato
## /etc/printcap: printer capability database. See printcap(5).
## You can use the filter entries df, tf, cf, gf etc. for
## your own filters. See /etc/filter.ps, /etc/filter.pcl and
## the printcap(5) manual page for further details.
#
#lp|Generic dot-matrix printer entry:\
#        :lp=/dev/lp0:\
#        :sd=/var/spool/lpd/lp:\
#        :af=/var/log/lp-acct:\
#        :lf=/var/log/lp-errs:\
#        :pl#66:\
#        :pw#80:\
#        :pc#150:\
#        :mx#0:\
#        :sh:
#
## rlp|Remote printer entry:\
##         :lp=:\
##         :rm=remotehost:\
##         :rp=remoteprinter:\
##         :sd=/var/spool/lpd/remote:\
##         :mx#0:\
##         :sh:
# LABEL apsfilter
# apsfilter setup Sun Dec  9 20:28:09 CET 2001
#
#
ascii|lp1|cdjmono-letter-ascii-mono|cdjmono ascii mono:\
    :lp=/dev/lp0:\
    :sd=/var/spool/lpd/cdjmono-letter-ascii-mono:\
    :lf=/var/spool/lpd/cdjmono-letter-ascii-mono/log:\
    :af=/var/spool/lpd/cdjmono-letter-ascii-mono/acct:\
    :if=/var/lib/apsfilter/filter/aps-cdjmono-letter-ascii-mono:\
    :mx#0:\
    :sh:
#
lp|lp2|cdjmono-letter-auto-mono|cdjmono auto mono:\
    :lp=/dev/lp0:\
    :sd=/var/spool/lpd/cdjmono-letter-auto-mono:\
    :lf=/var/spool/lpd/cdjmono-letter-auto-mono/log:\
    :af=/var/spool/lpd/cdjmono-letter-auto-mono/acct:\
    :if=/var/lib/apsfilter/filter/aps-cdjmono-letter-auto-mono:\
    :mx#0:\
    :sh:
#
raw|lp3|cdjmono-letter-raw|cdjmono auto raw:\
    :lp=/dev/lp0:\
    :sd=/var/spool/lpd/cdjmono-raw:\
    :lf=/var/spool/lpd/cdjmono-raw/log:\
    :af=/var/spool/lpd/cdjmono-raw/acct:\
    :if=/var/lib/apsfilter/filter/aps-cdjmono-letter-raw:\
    :mx#0:\
    :sh:

Please help me to resolve it.
Thanks,
Renato

---

From: Thomas Kaiser <[email-masked]>
Date: Thu, 10 Jan 2002 08:52:56 +0100

On Thu, 10 Jan 2002 08:24:28 +0100, Renato BARRIOS wrote:

Have you read the "PPD's Q..." thread?

> I tried it with and without papd.conf

You better do it with papd.conf...

> mozilla and simple lpr command.

That's good.

> Please help me to resolve it.

What error messages appear in /var/log/messages when you try to print?

Try this in your papd.conf

Deskjet 540:\
    :pr=lp:op=lp\
    :pd=[path to a correct PPD for this printer]:

As your DeskJet is not a native PS printer, there won't be PPDs on the Adobe
site for it. So you should give the PPDs from the CUPS project a chance. For
example this one (the basic features will be comparable):
<http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/lpr/ppds/hp/Attic/HP_DeskJet
_600C_Series.ppd>

Please note: If you use LPRng, then you should replace ":pr=lp:" with
":pr=|/usr/bin/lpr -Plp:".

It seems that the format of papd.conf is a bit difficult. You must indent
the following lines of each entry.

For both problems see http://www.rodsbooks.com/network/network-netatalk.html

Regards,

Thomas