Subject: Appletalk connection ONLY?

From: Ian Hitchman <[email-masked]>
Date: Wed, 18 Jul 2001 11:22:03 +0100 (BST)

Dear Netatalk Users,

I appear to only be able to connect by AppleTalk. Any attempt to connect
by TCP/IP gives the error "No response from the server". Could someone
help me with this. I believe my TCP wrappers are OK as they work no an
rpm-netatalk installed machine. atalk/afpd.conf is default.
/etc/rc.d/init.d/atalk was copied from distrib/initscripts/atalk.

All the best,

Ian.

netatalk-1.5pre6.tar.gz
RedHat 7.1 kernel 2.4.2-2

cat /etc/services | grep 548
afpovertcp      548/tcp                         # AFP over TCP
afpovertcp      548/udp                         # AFP over TCP

./configure
--prefix=/usr/local/netatalk \
--sysconfdir=/etc/atalk \
--with-config-dir=/etc/atalk \
--with-tcp-wrappers \
--mandir=/usr/local/man \
--with-ssl-dir=/usr/include/openssl \
--disable-admin-group \
--with-shadow \
--with-pam \
--enable-lastdid \
--with-flock-locks \
--enable-redhat

Jul 18 10:56:49 dellboy2 atalkd[723]: restart (1.5pre6)
Jul 18 10:56:50 dellboy2 atalkd[723]: zip_getnetinfo for eth0
Jul 18 10:56:51 dellboy2 atalkd[723]: zip_packet configured eth0 from
100.227
Jul 18 10:56:58 dellboy2 atalkd[723]: rtmp_packet gateway 100.227 up
Jul 18 10:57:19 dellboy2 atalkd[723]: ready 0/0/0
Jul 18 10:57:19 dellboy2 atalk: atalkd startup succeeded
Jul 18 10:57:31 dellboy2 papd[733]: restart (1.5pre6)
Jul 18 10:57:31 dellboy2 atalk: papd startup succeeded
Jul 18 10:57:31 dellboy2 atalk: afpd startup succeeded
Jul 18 10:57:37 dellboy2 afpd[738]: Zing:AFPServer@* started on 109.14:128
(1.5pre6)
Jul 18 10:57:37 dellboy2 afpd[738]: ASIP started on 131.111.147.52:548(1)
(1.5pre6)
Jul 18 10:57:37 dellboy2 afpd[738]: uam: uams_guest.so loaded
Jul 18 10:57:37 dellboy2 afpd[738]: uam: uams_clrtxt.so loaded
Jul 18 10:57:37 dellboy2 afpd[738]: uam: uams_dhx.so loaded
Jul 18 10:57:37 dellboy2 afpd[738]: uam: "DHCAST128" available
Jul 18 10:57:37 dellboy2 afpd[738]: uam: "Cleartxt Passwrd" available
Jul 18 10:57:37 dellboy2 afpd[738]: uam: "No User Authent" available

Jul 18 11:19:26 dellboy2 afpd[904]: session from 106.215:249 on 109.14:129
Jul 18 11:19:26 dellboy2 afpd[904]: dhx login: ian
Jul 18 11:19:26 dellboy2 afpd[904]: uams_dhx_pam.c :PAM: PAM Success -- No
such file or directory
Jul 18 11:19:26 dellboy2 PAM_pwdb[904]: (netatalk) session opened for user
ian by (uid=0)
Jul 18 11:19:26 dellboy2 afpd[904]: uams_dhx_pam.c :PAM: PAM Auth OK!:
(null) -- Inappropriate ioctl for device
Jul 18 11:19:26 dellboy2 afpd[904]: login ian (uid 500, gid 500

---

From: Carsten Neumann <[email-masked]>
Date: Wed, 18 Jul 2001 16:41:13 +0200

> /etc/rc.d/init.d/atalk was copied from distrib/initscripts/atalk.

It seems you haven't enabled TCP connections in your /etc/atalk/afpd.conf.
It is explained in this file.

HTH

Best regards

	Carsten

---

From: Ian Hitchman <[email-masked]>
Date: Thu, 19 Jul 2001 09:23:57 +0100 (BST)

Thanks for the response,

My afpd.conf is
 default:
 - -transall -uamlist uams_guest.so,uams_clrtxt.so,uams_dhx.so
-nosavepassword

-transall should start AFPD over TCP & AppleTalk. ASIP appears to start in
the logs and I get no error on a failed ip connection. Is there something
the redhat rpm install does that I have omitted? Could someone send me a
1.5pre6 configuration that they have working on a 7.1 system so as I can
check it against mine. I suspect my problem may not be with netatalk.

All the best

Ian.

./configure \