Subject: atalkd: can't get interfaces, exitin

From: Chris Stone <[email-masked]>
Date: Fri, 26 Jan 2001 11:18:53 -0500

Hello,

I, like a few others on the list, have gotten the following error when invoking netatalk.
--snip
root>./atalkd
socket: Invalid argument
socket: Invalid argument
atalkd: can't get interfaces, exiting.
--end snip

I have checked the list and found comments regarding the /etc/conf.modules file. I believe I have the proper entry. Here is a snippet from my file.
--snip
alias net-pf-5 appletalk
# alias net-pf-5            off
--end snip

My interface does multicasting.
root>ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:50:E4:B0:55:3A  
          inet addr:128.244.xxx.yy  Bcast:128.244.xxx.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5540 errors:0 dropped:0 overruns:0 frame:0
          TX packets:351 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          Interrupt:42 Base address:0xf000 

The only entry in my /etc/atalk/atalkd.conf file is.
--snip
eth0
--end snip

I am running suse linux v6.4 for PPC on a blue and white g3. Can any one point me in the right direction?

Thank You,

Chris

---

From: Jason Powell <[email-masked]>
Date: Fri, 26 Jan 2001 15:18:15 -0500

> point me in the right direction?

Last I heard it would only work properly on a red or green G3.

Sorry, somebody had to say it :)
Jason

ps. Do you have the appletalk module installed? (modprobe appletalk)?  I
seem to recall getting that error when the module got unloaded.