Subject: Netatalk FrameMaker Problems

From: "Dave (Grizz) Glaser" <[email-masked]>
Date: Thu, 26 Apr 2001 15:23:19 -0400 (EDT)

I have been running netatalk on a Solaris 6 Ultra 5 box. (version netatalk-1.4b2+asun2.1.3) It was running fine, but we were having the standard Error -50 problems. We upgraded our NFS server and have been having some problems:

Now Netatalk is on a Solaris 8 Ultra 60 box. The version is netatalk-1.4b2+asun2.1.4. Since I have installed it, we have been having problems with Frame Maker. If you open a document and try to save it, an error saying that "Some document specific settings could not be saved. All changes were saved. US English Interface." Also, if you close the program and it tries to save you get the same message as well as one saying the someone else may be modifying the file (no one is). It then will not let you log off unless you click 'Don't save'. Frame seems to be the only program causing problems. 

I believe it has something to do with locking files. (the <filename>.lck is made, but I don't beieve it is working correctly). 

Has anyone seen this problem?

Dave

 David S. Glaser  AKA Grizz	|        
 M&M Systems Administrator      | Forget virus scanning. Its all about "re-
 U201 M&ME Building 	  	| education". Preferably in a parking lot with
 Houghton, MI 49931	 	| a tire iron.   - BOFH
 [email-masked] 		|

---

From: Matthew Keller <[email-masked]>
Date: 26 Apr 2001 15:43:30 -0400

If these files reside accross an NFS boundry from the Netatalk
    server, you may have to disable NFS locking.

-- 

Matthew Keller
Enterprise System Analyst
Computing & Technology Services
Information Services Division
State University of NY at Potsdam
Potsdam, NY USA

http://mattwork.potsdam.edu/

---

From: "Dave (Grizz) Glaser" <[email-masked]>
Date: Thu, 26 Apr 2001 15:44:05 -0400 (EDT)

Nope, these files are on the same machine.

Dave

---

From: Thorsten Biel <[email-masked]>
Date: Fri, 27 Apr 2001 00:42:39 +0200

yes, here! :) Same version of netatalk, Solaris 8 (64bit), local disk.
The clients are running MacOS 9.0.4 or 9.1. The error is sporadic, I can
save several documents without any problems. But once I get the error,
the only thing that helps is saving the document to the Mac's disk,
quitting Frame and using the Finder to copy the document over to the
Sun.
I haven't been able to correlate any netatalk error messages to the
problem. Seeing that I can copy the document over the net via Finder,
it must be something Frame-specific. It does seem as if it has something
to do with the lock files; sometimes they keep piling up instead of
getting deleted by Frame on exit.
I'm no netatalk expert, but I'd be willing to help any way I can.

-Thorsten

--On Thursday, April 26, 2001 15:23 -0400 "Dave (Grizz) Glaser" 
<[email-masked]> wrote:
> Now Netatalk is on a Solaris 8 Ultra 60 box. The version is
> netatalk-1.4b2+asun2.1.4. Since I have installed it, we have been having
> problems with Frame Maker. If you open a document and try to save it, an
> error saying that "Some document specific settings could not be saved.
> All changes were saved. US English Interface." Also, if you close the
> program and it tries to save you get the same message as well as one
> saying the someone else may be modifying the file (no one is). It then
> will not let you log off unless you click 'Don't save'. Frame seems to be
> the only program causing problems.
>
> I believe it has something to do with locking files. (the <filename>.lck
> is made, but I don't beieve it is working correctly).
>

--
Thorsten Biel                                         [email-masked]
www.ITadmin.com                                  - keep IT under control
ITadmin GmbH       Waldeckstr. 6         D-74372 Sersheim        Germany
mobile: +49 171 9516717    Tel. +49 7042 960640      Fax +49 7042 960641