Subject: Re: Newbie Install Help

From: "Nathaniel Pendleton" <[email-masked]>
Date: Tue, 3 Apr 2001 12:38:47 -0400

Still no luck. Netatalk is NOT working.
I installed webmin module 0.9 beta to try and solve the config issues.
I repointed the files to "/etc/atalk" instead of "/usr/local/atalkd/etc"
The hand written share was somehow deleted and every effort to create
a new share in webmin fails.  Edit interface says "Error - file not found".

"Start Apple File Sharing" says /usr/sbin/atalkd failed

What is going wrong?

-Nathaniel
-----Original Message-----
From: Nathaniel Pendleton <[email-masked]>
To: [email-masked] <[email-masked]>
Date: Monday, April 02, 2001 4:31 AM
Subject: Newbie Install Help

>I am trying to install netatalk on Linux on VA linux 6.2.3 distro
>and the VA linux powertools rpm for netatalk.
>http://www.valinux.com/software/vaload/archive/6.2.3/
>http://ftp.valinux.com/pub/software/VALinux/released/6.2.3/extras/Powertool
s
>/i386/netatalk-1.4b2+asun2.1.3-7.i386.rpm
>
>I read this page and was stumped and as VA Linux who RTFM'd me back here.
>http://www.anders.com/projects/netatalk/
>
>0) Honestly is netatalk reliable for file serving Mac files for a business?
>1.4b2+asun2.1.3-7.i386.rpm?
>1.5pre5?
>netatalk webmin module 0.9?
>
>1) What file system do I use on the netatalk server?  ext2 or what?
>
>2) How do I get netatalk started?
>using VA linux 6.2.3 (redhat 6.2 derivative)
>dmesg has no "AppleTalk" so I insmod appletalk.o
>/etc/services has all the correct stuff
>
>kpackage installed the valinux 1.4b2 package which has:
>/usr/doc/netatalk-1.4b2+asun2.1.3/
>/etc/atalk/
>
>webmin>system>bootupshutdown lists "atalk" being started, and started at
>boot
>
>made macosdata folder in a folder that samba also uses.
>chmod smbuser, chgrp smbusers, my default samba file controls.
>I added to Apple Volumes.default
>/home/data/macosdata "VACell400 MacOS"
>restarted atalk in webmin.
>
>no luck, now what?
>
>-Nathaniel
>
>

---

From: Chad Cunningham <[email-masked]>
Date: Tue, 3 Apr 2001 15:19:25 -0400 (EDT)

> >netatalk webmin module 0.9?

Probably? In my experience 1.4b2+asun is very solid. I've had some
problems with the 1.5pre series, the clients tend to get "Server
unexpectedly quit" messages. Of course, we have some "experimental"
setups... The advantage of the 1.5 series is that they do encrypted
password transport, which you probably want depending on your network.

> >1) What file system do I use on the netatalk server?  ext2 or what?

The file system, in terms of performance, should be the last thing your
worry about. I'd say whatever you have is fine. We run ours off of UFS,
EXT2, and ReiserFs and I can't say it really makes much difference.

> >/etc/services has all the correct stuff

Depending on what RPM you installed, you should have an
/etc/rc.d/init.d/atalk. To start it, run

/etc/rc.d/init.d/atalk start

To start at bootup, run

chkconfig --level 345 atalk on

You may also need an entry in /etc/modules.conf to load the appletalk
module, but I *think* the rpm should set that up, depends on where you got
the rpm though...

> >no luck, now what?

What do you mean by no luck?

-- 

Chad Cunningham
[email-masked]

"Well, once again my friend, we find that science is a two-headed beast. One
head is nice, it gives us aspirin and other modern conveniences,...but the
other head of science is bad! Oh beware the other head of science, Arthur, it
bites!"