Subject: Chooser Problems...

From: Bean Visger <[email-masked]>
Date: Fri, 2 Feb 2001 16:10:03 -0800

howdy, trying to get the server name to show up in Chooser, 
webmonkeys are lazy and don't like typing in IP address...

here are the specs:

FreeBSD 4.1-RELEASE
netatalk-1.4b2+asun2.1.3_1

content of atalkd.conf:
	fxp0 -phase 2 -net 0-65534 -addr 65280.103
content of afpd.conf:
	servo "Tom Servo" -transall

when I try & restart netatalk, I get these syslog messages:

Feb  2 15:51:14 servo papd[30656]: restart (1.4b2+asun2.1.3)
Feb  2 15:51:14 servo papd[30656]: atp_open: Protocol not supported
Feb  2 15:51:14 servo afpd[30658]: main: atp_open: Protocol not supported

any ideas? it almost sounds like netatalk isn't shutting down / 
starting up properly... I'd really rather not reboot the box, I'm an 
uptime whore :)

	thanks,
	 -Rebecca 'Bean' Visger
	 System Administrator / Smith & Jones

---

From: Bill Moran <[email-masked]>
Date: Fri, 02 Feb 2001 19:16:44 -0500

I could be wrong, but it seems like you don't have appletalk support in
your kernel. Are you sure Netatalk is running at all? Can you connect at
all (with an IP addy?)
A default kernel won't have appletalk support. You'll have to add:
options		NETATALK
and recompile your kernel, then (sorry) reboot.

-Bill

---

From: Bean Visger <[email-masked]>
Date: Fri, 2 Feb 2001 16:25:22 -0800

ah yes, sorry I didn't include that as well, it is running, and I am 
able to connect via IP address from the chooser, it just won't show 
in the list. thx :)

	-Bean

---

From: Carsten Neumann <[email-masked]>
Date: Sat, 3 Feb 2001 05:22:27 +0100

> >  >          System Administrator / Smith & Jones

I thought they would be necessary in any case to make appletalk work,
but do you have the appletalk entries in your /etc/services:

#
# make apple talk more friendly
#
rtmp            1/ddp           # Routing Table Maintenance Protocol
nbp             2/ddp           # Name Binding Protocol
echo            4/ddp           # AppleTalk Echo Protocol
zip             6/ddp           # Zone Information Protocol
 
#
# Appletalk
#
afpovertcp      548/tcp         # AFP over TCP
afpovertcp      548/udp         # AFP over UCP

?

Just an idea, since your server doesn't show up in the chooser list.

Regards

	Carsten