Subject: Re: (OT) Permissions yet again...

From: [email-masked]
Date: Fri, 24 Aug 2001 15:41:59 PDT

On Fri, 24 Aug 2001 15:34:36 -0700 Kerry Hormann wrote:
> What exactly is the problem you're having?

Oops - forgot that detail, huh?  ;-)
Logged in through the Chooser, I try to save a file from any program
other than 
SimpleText (?) and I get a Permission denied error.  Quark Xpress tells
me "Mac 
OS error (-500)".  And the net result is that it creates an empty file
with the 
filename I just tried to save as.  (Which is what inspired my little
experiment 
with touch!)

> > Logged in as 'luser' ("Lowly User";), I touch a file and it has the
> > following permissions:
> > -rw-rw----    1 (date/time)    test.txt
> > 
> > I've got a umask value of 007 for all users, so this shouldn't be
> > happening.  
> 
> Sounds right to me.  A MASK of 007 will give you permissions of 770
> for new
> files.  But touch doesn't automatically create an executable file,
> thus the
> 660 permissions.
>
>
>
> Kerry Hormann
> 
> Email [email-masked]
> ------------------------------------------
> <esc>:q!<enter>
> 
> 
> 
> > From: Rob deMallac <[email-masked]>
> > Date: Fri, 24 Aug 2001 15:08:28 -0700 (PDT)
> > To: [email-masked]
> > Subject: (OT) Permissions yet again...
> > Resent-From: [email-masked]
> > Resent-Date: Fri, 24 Aug 2001 18:14:12 -0400 (EDT)
> > 
> > Hello all-
> > 
> > I've got some strange file permission problems that, although
> unrelated to
> > netatalk, are preventing it from working properly.
> > 
> > I'm using 1.5pre6, installed from RPM, on Mandrake 8.
> > 
> > I've got a umask value of 007 for all users, so this shouldn't be
> > happening.  Going through the very helpful archives, I followed
> advice to
> > chmod 2775 on the actual share and chmod g+s for all the little .Apple
> > files, but still no dice.
> > 
> > Any help greatly appreciated, and my undying gratitude to the kind soul
> > who prevents me from turning this into a stupid NT box next week!
> > 
> > Cheers!
> > -Rob
> > =)
> > 
> > *********************************
> > Rob deMallac
> > Network Manager
> > SFSU Journalism Department
> > http://www.journalism.sfsu.edu/
> > *********************************
> >

---

From: Kerry Hormann <[email-masked]>
Date: Fri, 24 Aug 2001 18:28:26 -0700

What are you running the daemons as (afpd, etc.).  It could be they don't
have permission to the share directory.

But you say you can save via SimpleText???!!

Kerry

NT...No Thanks

> From: [email-masked]
> Reply-To: [email-masked]
> Date: Fri, 24 Aug 2001 15:41:59 PDT
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: (OT) Permissions yet again...
> Resent-Date: Fri, 24 Aug 2001 18:44:20 -0400 (EDT)
>