Subject: 1.5pre xx & Freehand

From: "Mika Vuokko" <[email-masked]>
Date: Wed, 17 Oct 2001 19:02:23 +0300

Hi.

We are experiening serious problems when using netatalk server 1.5pre7 ( linux, mandrake 8.0 precompiled RPM ) and a Mac client with FreeHand software. FreeHand documents which has links to various pictures in different folders (within the same share) breaks up when the document is saved are reopened. Is it something to do with the DID? The customer I have saved all work previously on a Mac server and worked there perfectly... None of the documents are not corrupted - just the links break. 

Strange.

I also tried to compile directly from the sources (1.5 pre8), but for some reason the pam uams module does not compile (with the --shadow --pam magic )...

Thanks for *any* help on this one :)

// Mika

---

Mika Vuokko
Programmer 
Scandinavia Online
Finland

Tel: +358-20-1234518
Mobile: +358-40-8334884
Email:   [email-masked]
Web:    http://www.suomi24.fi

---

From: Sebastian Rittau <[email-masked]>
Date: Wed, 17 Oct 2001 20:44:02 +0200

> I also tried to compile directly from the sources (1.5 pre8), but for some reason the pam uams module does not compile (with the --shadow --pam magic )...

That's a bug in pre8. If you have autoconf installed, you might apply
the attached patch to configure.in and re-run autoconf.

 - Sebastian
--- netatalk-1.5pre8.orig/configure.in
+++ netatalk-1.5pre8/configure.in
@@ -339,30 +339,29 @@
 fi
 
 # Check for PAM libs
-PAM_MSG="yes"
+AC_MSG_CHECKING([whether PAM support should be enabled])
 AC_ARG_WITH(pam,
-    [  --with-pam              Enable PAM support ],
-    [
-        if test "x$withval" = "xno" ; then
-                       PAM_MSG="no"
-               else 
-            PAM_MSG="yes"
-        fi
-    ]
+    [  --with-pam              Enable PAM support],
+    [PAM_MSG="$withval"],
+    [PAM_MSG="yes"]
 )
+AC_MSG_RESULT($PAM_MSG)
 
 if test "x$PAM_MSG" = "xyes"; then
-       AC_MSG_RESULT([enabling pam modules support])
-       if test "x$ac_cv_header_security_pam_appl_h" != "xyes" ; then
-               AC_MSG_ERROR([PAM headers not found]) 
-       fi
+        if test "x$ac_cv_header_security_pam_appl_h" != "xyes" ; then
+                AC_MSG_ERROR([PAM headers not found]) 
+        fi
         
-       AC_CHECK_LIB(dl, dlopen, , )
-       AC_CHECK_LIB(pam, pam_set_item, , AC_MSG_ERROR([*** libpam missing]))
-       AC_CHECK_FUNCS(pam_getenvlist)
-
-       AC_DEFINE(USE_PAM)
-       use_pam_so=yes
+        AC_CHECK_LIB(dl, dlopen, , )
+        AC_CHECK_LIB(pam, pam_set_item, , AC_MSG_ERROR([libpam missing]))
+        AC_CHECK_FUNCS(pam_getenvlist, , AC_MSG_ERROR([invalid libpam]))
+
+        AC_DEFINE(USE_PAM)
+        use_pam_so=yes
+        compile_pam=yes
+else
+        use_pam_so=no
+        compile_pam=no
 fi
 
 shadowpw=no