Subject: netatalk 1.5.1.1 installation

From: Mac Conin <[email-masked]>
Date: Fri, 01 Feb 2002 16:31:41 +0100

Hi everybody,

just a 'simple' question ...

We're currently running 1.5pre6 on an intel server with Suse Linux 2.2.4

The system was configured with:
./configure --enable-suse --with-shadow --with-pam --with-flock-locks
--with-uams-path=/etc/atalk/uams --with-config-dir=/etc/atalk --enable-lastdid

What is the best way for us to 'upgrade to the latest version
without too much hassle? It's a productive system so I don't have much
time for
testing.... Do we have to remove the older version first
(I read that somewhere with previous versions).

Any suggestions - thanks in advance

-- 

mit freundlichen grüssen

........................................................

Mac Conin                        Taubengasse 9
                                 D 50676 Koeln          
Neue Telefonnummern!....................................
EUC Online Service GmbH          tel : +49-221-58 007-20
........................................................
unix is like a tipi: no windows, no gates and an apache inside!

---

From: Thomas Kaiser <[email-masked]>
Date: Fri, 01 Feb 2002 16:50:28 +0100

am 01.02.2002 16:31 Uhr schrieb Mac Conin:

> without too much hassle?

I would install the most recent version of netatalk in another location, eg.
/usr/local/netatalk-1.5.1

If you first do a "mv /etc/init.d/atalk /etc/init.d/atalk-1.5pre6" and then
configure with:

./configure --enable-suse --with-shadow --with-pam --with-flock-locks
--prefix=/usr/local/netatalk-1.5.1 --with-config-dir=/etc/atalk
--with-uams-path=/usr/local/netatalk-1.5.1/etc/netatalk/uams
--with-did=last

you can switch between the pre-release and 1.5 easily :-)

Regards,

Thomas

---

From: Mac Conin <[email-masked]>
Date: Wed, 13 Feb 2002 14:52:20 +0100

Thanks Thomas,

it was nearly as easy as setting up a mac :)

-- 

mit freundlichen grüssen

Mac Conin                        Taubengasse 9
                                 D 50676 Koeln            
Neue Telefonnummern!....................................
CONIN - Agentur                  tel : +49-221-58 007-10
EUC Online Service GmbH          tel : +49-221-58 007-20
punktum postscript-Service       tel : +49-221-58 007-70
Fax Zentrale                     tel : +49-221-58 007-58
........................................................