Subject: papd error

From: James Pione <[email-masked]>
Date: Mon, 18 Jun 2001 09:32:37 -0400 (EDT)

Hi All.
	I'm running netatalk 1.4b2 on a FreeBSD 4.2 box as a file and
print server for a bunch of macs. First, I have to say netatalk generally
runs great. Unfortunately, papd keeps on returning an error message
whenever one of the macs sends a print job. Here's the message:

papd[314]: select: Interrupted system call
papd[239]: child 314 exited with 1
papd[239]: child 314 exited with 1

Here's my papd.conf:

morlock:\
	:pr=|usr/bin/lpr -Plp:\
	:pd=/usr/share/lib/ppd/LASERWRITER12640PS.ppd

Fortunately, even though papd returns this error, the user's jobs still
print. Thanks in advance for anyone's ideas.

---

From: jeff <[email-masked]>
Date: Mon, 18 Jun 2001 09:51:46 -0400

> print. Thanks in advance for anyone's ideas.

You may want to try a newer version, such as 1.5pre6, available on
sourceforge, as there have been many improvements to netatalk since the
1.4b2 release.

Thanks,
Jeff

---

From: Patrick Gardella <[email-masked]>
Date: Mon, 18 Jun 2001 08:35:09 -0700 (PDT)

Is the printer local (/dev/lpt0) or is it a Mac printer? And is your printer an actual Laserwriter
like your PPD says?  (i.e. Do you have a Postscript printer attached, or do you use ghostscript)

I'm having exactly the same problem, but my pages don't print at all (I'm on -current).

Patrick

> print. Thanks in advance for anyone's ideas.

__________________________________________________
Do You Yahoo!?
Spot the hottest trends in music, movies, and more.
http://buzz.yahoo.com/

---

From: James Pione <[email-masked]>
Date: Wed, 20 Jun 2001 10:16:13 -0400 (EDT)

Yes, the printer is a local laser printer, and is a Laserwriter 12/640.

---

From: Carsten Neumann <[email-masked]>
Date: Wed, 20 Jun 2001 19:30:06 +0200

> print. Thanks in advance for anyone's ideas.

What makes me wonder is that it works at all!
You will probably want to change the `pr=' option to:
	:pr=|/usr/bin/lpr -Plp:
i.e. making the path to `lpr' absolute and not relative to /,
relying on that your working dir is /.

Kind regards

	Carsten