Subject: Baffled with papd

From: Patrick Gardella <[email-masked]>
Date: Sun, 17 Jun 2001 12:56:27 -0700 (PDT)

I've just gotten a new printer that doesn't have the appletalk port built in.  So I figured that
since I've been using netatalk (asun 1.4b2-2.1.3_1) for years now for file sharing that I would
set up printing again (done in other situations).

Now for the baffling part:
My new Lexmark shows up on the Mac just fine, and I have the PPD file from Lexmark.  If I print
from the Mac to the printer,  I see:

papd [XXXXX] child XXXXX for Lexmark from XXXXX.XXX (Mac's atalk address)
papd [XXXXX] child XXXXX done
But it never prints anything.  Nothing ever gets into lpd.  And I've switched the "pr=" line in
papd.conf to be both "pr=lp" and "pr=/usr/bin/lpr -Plp"  Same thing.

Printing from the FreeBSD box (-current) using "lpr" works.
Printing from the FreeBSD box using "pap -p Lexmark test.ps" works.
Printing to a file on the Mac, dropping it in the shared folder, and printing with both "lpr" and
"pap" work.  

The only thing that doesn't work is printing from the Mac to the printer.  Same file to print in
all these tests.

Other pertinet data:
Mac with 8.1
LaserWriter 8.6 with LaserWriter II NTX driver.

Any ideas?  

(I figured that since "pap" on the BSD box works, the one from the Mac should as well.)

Patrick

__________________________________________________
Do You Yahoo!?
Spot the hottest trends in music, movies, and more.
http://buzz.yahoo.com/

---

From: Thomas Kaiser <[email-masked]>
Date: Mon, 18 Jun 2001 12:15:00 +0200

on Sun, 17 Jun 2001 12:56:27 -0700 (PDT), Patrick Gardella wrote:

> My new Lexmark shows up on the Mac just fine, and I have the PPD file from
> Lexmark.  If I print from the Mac to the printer,  I see:
                                           ^^^^^^^
To the printer? You mean a Netatalk spooler, I think?

> papd [XXXXX] child XXXXX done

Okay. At this point the printjob has been accepted and queued locally into
the lpd spooling system. What does "lpc status" say at this time?

> papd.conf to be both "pr=lp" and "pr=/usr/bin/lpr -Plp"  Same thing.

In the latter case there is a missing pipe symbol, isn't it?

(compare <http://www.giub.unibe.ch/~eugster/appleprint.html>)

How is "lp" configured? How look your printcap's entries like?

> Printing to a file on the Mac, dropping it in the shared folder, and printing
> with both "lpr" and "pap" work.

Maybe a permission problem that prevents papd to communicate with lpd? In
this case 'pr="|/usr/bin/lpr -Plp"' should help.

regard,

Thomas

---

From: Patrick Gardella <[email-masked]>
Date: Mon, 18 Jun 2001 04:36:56 -0700 (PDT)

> To the printer? You mean a Netatalk spooler, I think?

Correct.

> the lpd spooling system. What does "lpc status" say at this time?

Nothing.  "lpc status all" shows nothing.

> In the latter case there is a missing pipe symbol, isn't it?

Indeed, I mistyped that. 

> How is "lp" configured? How look your printcap's entries like?

I don't have it in front of me at the moment (here at work), but I set it up with "apsfilter".

> this case 'pr="|/usr/bin/lpr -Plp"' should help.

I was thinking it was, so I changed the permissions on /var/spool/lpd/lp so it was world
read/write, but that didn't do anything.  Neither does piping the command.

Patrick

---

From: Thomas Kaiser <[email-masked]>
Date: Mon, 18 Jun 2001 13:50:33 +0200

>>> Printing from the FreeBSD box using "pap -p Lexmark test.ps" works.

There's is something I didn't noticed in my first reply -->
on Sun, 17 Jun 2001 12:56:27 -0700 (PDT), Patrick Gardella wrote:
"a new printer that doesn't have the appletalk port built in"

This means, that if you print via pap from your FreeBSD Box, you actually
print via Netatalk's papd, lpd and via remote lpr (or parallel or ...) to
the printer?

The job's transmission from papd to lpd is working if you print locally via
'pap' but it doesn't work from the Mac's side?

Thomas

---

From: Patrick Gardella <[email-masked]>
Date: Mon, 18 Jun 2001 08:32:44 -0700 (PDT)

> print via Netatalk's papd, lpd and via remote lpr (or parallel or ...) to

Parallel, yes.

> 'pap' but it doesn't work from the Mac's side?

Correct.  And the Mac can see it in the Chooser, and even talk to the papd on the FreeBSD box, but
it doesn't print.  I get the "child exited with 1" error.

Patrick