Subject: Re: Guest users OK, real users can't get in

From: Lee Howard <[email-masked]>
Date: Mon, 05 Feb 2001 11:52:00 -0700

At 10:17 AM 2/5/01 -0800, Matisse Enzer wrote:
>Hi folks,
>
>I've just installed netatalk v1.5
>
>OS:        RedHat linux 6.1 system  (kernal: 2.2.12-20smp)
>Compiler:  egcs-2.91.66
>openssl:   0.9.6
>
>I enabled shadow passwords by adding   -DSHADOWPW   to  the CFLAGS in
>etc/afpd/Makefile

This doesn't work with v1.5.  You need to "./configure --with-shadow"

Lee.

---

From: Matisse Enzer <[email-masked]>
Date: Mon, 5 Feb 2001 15:21:29 -0800 (PST)

Thanks.

That did it.

By the way, I also had to add:

	-L/usr/local/ssl/lib

to      {sourcedir}/etc/uams/Makefile

So I have:

---------------------------------------cut here------------------------
.c.so:
        $(COMPILE) -DHAVE_CONFIG_H -fPIC -DPIC \
          -I$(top_srcdir) -fomit-frame-pointer -c $< ; \
        $(LD) -shared $(LDSHAREDFLAGS) -o $@ $*.o $(LIBS) \
	-L/usr/local/ssl/lib