Subject: Re: App copy problems (-50)

From: "Bryn Hughes" <[email-masked]>
Date: Mon, 19 Mar 2001 16:46:04 -0800

The .AppleDouble directory does exist... ug+rwX.

On another share, the problem seems to have been caused by the .Parent file within .AppleDouble being given execute permissions.  Taking those away fixed the problem.  

The root level of this share is read-only to everyone, will this matter?  The .AppleDouble directory has its own permissions set obviously.

Bryn

>>> Carsten Neumann <[email-masked]> - 3/19/01 3:01 PM >>>
On Mon, 19 Mar 2001, Bryn Hughes wrote:
> I'm having problems copying 'Application' files to my YellowDog Linux 1.2 with netatalk-1.4b2+asun2.1.3.
> 
> Any time I try to copy an application file I get a -50 error.   My logs at that time show the following:
> 
> Mar 19 10:39:52 ccmf1 afpd[20189]: afp_addicon: Permission denied
> 
> I own this directory, I have full ownership of the .AppleDouble directory contained within it. 
> 
> What causes this?  This also happens on several other areas of the server.  All files other than this can be copied no problem!
> 
> Bryn

Who's the owner / what are the permissions of the ".AppleDesktop" dir (at top of the exported Apple Volume!)?
Does it exist at all?

Regards

	Carsten

---

From: Carsten Neumann <[email-masked]>
Date: Tue, 20 Mar 2001 02:27:14 +0100

> The .AppleDouble directory does exist... ug+rwX.

Once more:
I wrote (and meant) ".AppleDesktop".

DESKTOP, _not_ DOUBLE!
TOP OF DESK, not TWICE OF SINGLE! ;-)

Thats the database where the location of Apps and its icons are stored for the Creators of files.

> Who's the owner / what are the permissions of the ".AppleDesktop" dir (at top of the exported Apple Volume!)?

Regards, again

	Carsten