Subject: "Password incorrect" problems

From: Rory Campbell-Lange <[email-masked]>
Date: Mon, 23 Apr 2001 15:19:39 +0100

Thanks for everyone's help getting me onto 1.5pre6. I have eventually
got 1.5pre6 installed from deb.

I'm having trouble getting errors "sorry your password is incorrect.
Please reenter it" when the user treetop tries to log on. I've had the
same problem with the other 1.5pre releases I've installed from deb.

The 1.4b2+asun release I replaced did not have these problems.

--------------------------------------------------------------------------

atalkd.conf:
    no contents
afpd.conf
    "Penquin" -uamlist uams_clrtxt.so
AppleVolumes.default
    /home/treetop/test "Test" 
    
etc/pam.d/netatalk
    #%PAM-1.0
    auth       required /lib/security/pam_pwdb.so shadow
    account    required /lib/security/pam_pwdb.so 
    #password   required    /lib/security/pam_cracklib.so
    #password   required    /lib/security/pam_pwdb.so shadow use_authtok
    session    required /lib/security/pam_pwdb.so 
    
syslog:

14:24:37 hopnet2 afpd[29078]: Penquin:AFPServer@* started on 6.218:128
(1.5pre6)
14:24:37 hopnet2 afpd[29078]: ASIP started on x.x.x.x:548(2) (1.5pre6)
14:24:37 hopnet2 afpd[29078]: uam : Loading
(/etc/netatalk/uams/uams_clrtxt.so)
14:24:37 hopnet2 afpd[29078]: uam: uams_clrtxt.so loaded
14:24:37 hopnet2 afpd[29078]: uam: "Cleartxt Passwrd" available

....

14:53:16 hopnet2 afpd[29140]: ASIP session:548(2) from
x.x.x.247:49456(0)
14:53:16 hopnet2 afpd[29140]: cleartext login: treetop
14:53:16 hopnet2 afpd[29140]: 0.08KB read, 0.07KB written
14:53:16 hopnet2 afpd[29078]: server_child[1] 29140 done
    <--- no note of failed login!

---

From: Matthew Keller <[email-masked]>
Date: 23 Apr 2001 11:48:52 -0400

1) You sure the password is correct? ;)
2) If you're using PAM (as it looks like you are) are you sure that
netatalk is compiled with --with-pam?.. Hmmm... Looks like you installed
from a package. That's why I can't stand packages, you never know what
flags were used at compile time. *hurumph*

I forget who the .DEB maintainer is - Perhaps he/she can mention a word?
Sorry for the cross-post: Trying to nail down a solution.

-- 

Matthew Keller
Enterprise System Analyst
Computing & Technology Services
Information Services Division
State University of NY at Potsdam
Potsdam, NY USA

http://mattwork.potsdam.edu/

---

From: Danny Sauer <[email-masked]>
Date: Mon, 23 Apr 2001 11:07:42 -0500

ldd `which afppasswd` | grep pam

replace `which afppasswd` with the path to whatever binary you want to
look at.

--Danny

---

From: Rory Campbell-Lange <[email-masked]>
Date: Mon, 23 Apr 2001 17:46:18 +0100

Thanks for the mails, Danny & Matthew

ldd /usr/sbin/afpd | grep pam
    libpam.so.0 => /lib/libpam.so.0 (0x4012f000)

ldd /usr/sbin/afpd | grep pam
    libpam.so.0 => /lib/libpam.so.0 (0x4012f000)

I'll ask Sebastian, the package maintainer, if he can shed some light on
the packaging settings.

On 23/4/01, [email-masked] (Matthew Keller) wrote:

> netatalk is compiled with --with-pam?.. Hmmm... Looks like you
> installed from a package. That's why I can't stand packages, you never
> know what flags were used at compile time. *hurumph*
> 
> I forget who the .DEB maintainer is - Perhaps he/she can mention a
> word? Sorry for the cross-post: Trying to nail down a solution.
> 
> > Thanks for everyone's help getting me onto 1.5pre6. I have
> > eventually got 1.5pre6 installed from deb.
> > 
> > Please reenter it" when the user treetop tries to log on. I've had
> > the same problem with the other 1.5pre releases I've installed from
> > deb.
> > 
> > 14:24:37 hopnet2 afpd[29078]: ASIP started on x.x.x.x:548(2)
> > (1.5pre6) 14:24:37 hopnet2 afpd[29078]: uam : Loading

---

From: Matthew Keller <[email-masked]>
Date: 23 Apr 2001 13:21:43 -0400

That's enough to confirm that it's compiled with PAM support. *sigh*

    Anyone else using the .DEB's and either working ok, or not? Anyone
    on a Debian based system compiling from source and have feedback?

-- 

Matthew Keller

---

From: Rob Lineweaver <[email-masked]>
Date: 23 Apr 2001 14:29:54 -0400

>     on a Debian based system compiling from source and have feedback?

I've had success with 1.5pre6 compiled from source on Debian/m68k
unstable.  Configured with:

./configure --prefix=/usr/local --with-config-dir=/etc/atalk
--with-uams-path=/etc/atalk/uams --with-msg-dir=/etc/atalk/msg
--enable-lastdid  --with-pam --with-shadow --with-tcp-wrappers
--with-ssl

I'm not sure if the --with-shadow is necessary or not but it might be
something to try (it's probably in the .deb anyway, but I've never used
the deb).  I would recommend compiling from source with the above (or
similar) configuration to see if that fixes it.

Also, I'm wondering why the original poster was only allowing cleartext
logins.  Is there some reason you actively don't want uams_dhx.so?

Which appleshare client(s) are you using?

good luck,

Rob Lineweaver
:)

---

From: Rory Campbell-Lange <[email-masked]>
Date: Tue, 24 Apr 2001 00:13:56 +0100

On 23/4/01, [email-masked] (Rob Lineweaver) wrote:

> ../configure --prefix=/usr/local --with-config-dir=/etc/atalk

I've tried OS 9, 9.0.4 and 9.1 clients. No go. I'll try compiling myself
tomorrow; thanks for the really useful configure line.

Cheers.
Rory

--
	Rory Campbell-Lange
	The Campbell-Lange Workshop
 	London

---

From: Sebastian Rittau <[email-masked]>
Date: Tue, 1 May 2001 03:48:17 +0200

On Mon, Apr 23, 2001 at 02:29:54PM -0400, Rob Lineweaver wrote:

> the deb).

It was not in the deb, thatswhy it didn't work. --enable-shadow is
necessary.

 - Sebastian