Subject: O-BSD 2.8 1.5pre5 compile errors (was rand2num)

From: Karen A Swanberg <[email-masked]>
Date: Wed, 21 Mar 2001 13:31:04 -0600 (CST)

This contains the message I mistakenly sent to umich, which should have
gone to sourceforge. It's quite long, as it contains the output of my
compile, my compile.log and compile.status, as well as the errors
encountered during the make.

Basically, the 
./configure --with-tcp-wrappers --with-ssl-dirs=/usr

command works great, but when I make, I get errors I can't track down. The
makefiles it references don't seem to have useful information on the lines
the errors list. It's all below.

on 03/21/01, Hauke Fath wisely declared:

> >It is appropriate to this list to post compilation problems, or should
> >those just be sent to the [email-masked] address?

> Depending on the sources version, either here (for pre-Sourceforge),
> or on the Sourceforge netatalk-devel list. AFAIK, the last Netatalk
> version that umich.edu released was 1.4b2.
...
> >I have been unable to compile anything above 1.4b2+asun2.1.3 on my
> >system. I dropped the umich folks a note about it. I'm on
> >1.4b2+asun2.1.3/OpenBSD 2.8.

> Strange... I have built asun-2.1.4pre3[5789] on NetBSD 1.4.x without
> problems. What compile errors do you see?

>       hauke

---------- Forwarded message ----------
Date: Tue, 20 Mar 2001 17:00:15 -0600 (CST)
From: Karen A Swanberg <[email-masked]>
To: [email-masked]
Subject: OpenBSD 2.8 1.5pre5 i386 compile errors

Greetings, I think this is a bug. I've included everything I think should
be useful, but I'd be happy to provide more. If this is hopelessly basic,
I apologize.

SUBJECT: compile errors on 1.5pre5 on OpenBSD 2.8 during make
install. Using 1.5pre5 in order to utilize DHX, my ./configure was:
./configure --with-tcp-wrappers --with-ssl-dirs=/usr

The compile ran fine, but the 'make' then died with the error:

#make
make  all-recursive
Making all in libatalk

Making install in libatalk 
"Makefile", line 317: Need an operator 
Fatal errors encountered -- cannot continue
*** Error code 1

Stop in /home/swanberg/netatalk/netatalk-1.5pre5 (line 178 of Makefile).
*** Error code 1

Stop in /home/swanberg/netatalk/netatalk-1.5pre5 (line 311 of Makefile).

Line 178 of libatalk/Makefile is:
.s.lo:
        $(LIBTOOL) --mode=compile $(COMPILE) -c $<
#178 is this blank line#
.S.lo:
        $(LIBTOOL) --mode=compile $(COMPILE) -c $<

Line 311 of the libatalk/Makefile is:

(cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) top_distdir=../$(top_distdir)
distdir=../$(distdir)/$$subdir distdir) \
              || exit 1; \      #this is line 311#
          fi; \
        done

DEPS_MAGIC := $(shell mkdir .deps > /dev/null 2>&1 || :)

ENVIRONMENT:

I have these packages: 
ssl-2.7-USA 
libtool-1.3.5 
automake-1.4
autoconf-2.13

Running OpenBSD 2.8 on a Dell PowerEdge 1400, pretty basic i386 install.
Samba is also running, along with Amanda. Nothing else.

What other info do you need here? Hardware info?

DESCRIPTION:

The configure runs fine, the 'make' dies, as does 'make check' with the
error mentioned above. I can't get beyond it.

Here are my logs:

output for ./configure --with-tcp-wrappers --with-ssl-dirs=/usr

loading cache ./config.cache
checking host system type... i386-unknown-openbsd2.8
checking target system type... i386-unknown-openbsd2.8
checking build system type... i386-unknown-openbsd2.8
checking for a BSD compatible install... (cached) /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... (cached) yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... found
checking for ranlib... (cached) ranlib
checking for gcc... (cached) gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for ld used by GCC... (cached) /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... (cached) no
checking for BSD-compatible nm... (cached) /usr/bin/nm -p
checking whether ln -s works... (cached) yes
checking for object suffix... o
checking for executable suffix... no
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.lo... yes
checking if gcc supports -fno-rtti -fno-exceptions ... yes
checking if gcc static flag -static works... -static
checking if the linker (/usr/bin/ld) is GNU ld... no
checking whether the linker (/usr/bin/ld) supports shared libraries... yes
checking command to parse /usr/bin/nm -p output... ok
checking how to hardcode library paths into programs... immediate
checking for /usr/bin/ld option to reload object files... -r
checking dynamic linker characteristics... openbsd2.8 ld.so
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking for objdir... .libs
creating libtool
loading cache ./config.cache
checking for gawk... (cached) nawk
checking for gcc... (cached) gcc
checking whether the C compiler (gcc -g -O2 ) works... yes
checking whether the C compiler (gcc -g -O2 ) is a cross-compiler... no
checking whether we are using GNU C... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for a BSD compatible install... /usr/bin/install -c
checking whether ln -s works... (cached) yes
checking whether make sets ${MAKE}... (cached) yes
checking for object suffix... o
checking for executable suffix... no
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.lo... yes
checking if gcc supports -fno-rtti -fno-exceptions ... yes
checking if gcc static flag -static works... -static
checking if the linker (/usr/bin/ld) is GNU ld... no
checking whether the linker (/usr/bin/ld) supports shared libraries... yes
checking command to parse /usr/bin/nm -p output... ok
checking how to hardcode library paths into programs... immediate
checking for /usr/bin/ld option to reload object files... -r
checking dynamic linker characteristics... openbsd2.8 ld.so
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking for objdir... .libs
creating libtool
loading cache ./config.cache
checking for main in -labs... (cached) no
checking for main in -laudit... (cached) no
checking for main in -lauth... (cached) no
checking for main in -lcmd... (cached) no
checking for main in -lcom_err... (cached) yes
checking for main in -lcrypt... (cached) no
checking for main in -ld... (cached) no
checking for main in -ldb... (cached) no
checking for main in -ldl... (cached) no
checking for main in -lkauth... (cached) no
checking for main in -lkrb... (cached) yes
checking for main in -llwp... (cached) no
checking for main in -ln... (cached) no
checking for main in -lnsl... (cached) no
checking for main in -lprot... (cached) no
checking for main in -lresolv... (cached) yes
checking for main in -lrpcsvc... (cached) yes
checking for main in -lrx... (cached) no
checking for main in -lrxkad... (cached) no
checking for main in -lsocket... (cached) no
checking for main in -lsys... (cached) no
checking for main in -lubik... (cached) no
checking for access... (cached) yes
checking for dirent.h that defines DIR... (cached) yes
checking for opendir in -ldir... (cached) no
checking how to run the C preprocessor... (cached) gcc -E
checking for ANSI C header files... (cached) yes
checking for sys/wait.h that is POSIX.1 compatible... (cached) yes
checking for fcntl.h... (cached) yes
checking for limits.h... (cached) yes
checking for stdint.h... (cached) no
checking for strings.h... (cached) yes
checking for sys/fcntl.h... (cached) yes
checking for sys/file.h... (cached) yes
checking for sys/ioctl.h... (cached) yes
checking for sys/time.h... (cached) yes
checking for syslog.h... (cached) yes
checking for unistd.h... (cached) yes
checking for termios.h... (cached) yes
checking for sys/termios.h... (cached) yes
checking for netdb.h... (cached) yes
checking for sgtty.h... (cached) yes
checking for sys/cdefs.h... (cached) yes
checking for working const... (cached) yes
checking for uid_t in sys/types.h... (cached) yes
checking for inline... (cached) inline
checking for mode_t... (cached) yes
checking for off_t... (cached) yes
checking for pid_t... (cached) yes
checking for size_t... (cached) yes
checking for st_rdev in struct stat... (cached) yes
checking whether time.h and sys/time.h may both be included... (cached) yes
checking whether struct tm is in sys/time.h or time.h... (cached) time.h
checking type of array argument to getgroups... (cached) gid_t
checking whether gcc needs -traditional... (cached) no
checking for 8-bit clean memcmp... (cached) yes
checking whether sys/types.h defines makedev... (cached) yes
checking for unistd.h... (cached) yes
checking for getpagesize... (cached) yes
checking for working mmap... (cached) yes
checking return type of signal handlers... (cached) void
checking whether utime accepts a null argument... (cached) yes
checking for wait3 that fills in rusage... (cached) yes
checking for getcwd... (cached) yes
checking for gethostname... (cached) yes
checking for gettimeofday... (cached) yes
checking for getusershell... (cached) yes
checking for mkdir... (cached) yes
checking for rmdir... (cached) yes
checking for select... (cached) yes
checking for socket... (cached) yes
checking for strdup... (cached) yes
checking for strstr... (cached) yes
checking for strtoul... (cached) yes
checking for setpgrp... (cached) yes
checking whether setpgrp takes no argument... (cached) no
checking for pam_start in -lpam... (cached) no
checking for hosts_access in -lwrap... (cached) yes
enabling TCP wrappers support
setting configuration files location to /etc/atalk
 * OpenBSD specific configuration
checking for main in -lcrypto... (cached) yes
checking for main in -ldes... (cached) yes
Found ssl and enabling RANDNUM and DHX support /usr
creating ./config.status
creating Makefile
creating bin/Makefile
creating bin/adv1tov2/Makefile
creating bin/aecho/Makefile
creating bin/afile/Makefile
creating bin/afppasswd/Makefile
creating bin/getzones/Makefile
creating bin/megatron/Makefile
creating bin/nbp/Makefile
creating bin/pap/Makefile
creating bin/psorder/Makefile
creating config/Makefile
creating contrib/Makefile
creating contrib/nu/Makefile
creating contrib/printing/Makefile
creating contrib/shell_utils/Makefile
creating contrib/timelord/Makefile
creating distrib/Makefile
creating distrib/config/Makefile
creating distrib/config/netatalk-config
creating distrib/initscripts/Makefile
creating distrib/m4/Makefile
creating etc/Makefile
creating etc/afpd/Makefile
creating etc/afpd/nls/Makefile
creating etc/atalkd/Makefile
creating etc/uams/Makefile
creating etc/uams/uams_krb4/Makefile
creating etc/papd/Makefile
creating etc/psf/Makefile
creating include/Makefile
creating include/atalk/Makefile
creating libatalk/Makefile
creating libatalk/adouble/Makefile
creating libatalk/asp/Makefile
creating libatalk/atp/Makefile
creating libatalk/compat/Makefile
creating libatalk/dsi/Makefile
creating libatalk/nbp/Makefile
creating libatalk/netddp/Makefile
creating libatalk/util/Makefile
creating man/Makefile
creating man/man1/Makefile
creating man/man3/Makefile
creating man/man4/Makefile
creating man/man5/Makefile
creating man/man8/Makefile
creating sys/Makefile
creating sys/netatalk/Makefile
creating config.h
config.h is unchanged

config.status:

#! /bin/sh
# Generated automatically by configure.
# Run this file to recreate the current configuration.
# This directory was configured as follows,
# on host epidote:
#
# ./configure  --with-tcp-wrappers --with-ssl-dirs=/usr
#
# Compiler output produced by configure, useful for debugging
# configure, is in ./config.log if it exists.

ac_cs_usage="Usage: ./config.status [--recheck] [--version] [--help]"
for ac_option
do
  case "$ac_option" in
  -recheck | --recheck | --rechec | --reche | --rech | --rec | --re | --r)
    echo "running ${CONFIG_SHELL-/bin/sh} ./configure  --with-tcp-wrappers --with-ssl-dirs=/usr --no-create --no-recursion"
    exec ${CONFIG_SHELL-/bin/sh} ./configure  --with-tcp-wrappers --with-ssl-dirs=/usr --no-create --no-recursion ;;
  -version | --version | --versio | --versi | --vers | --ver | --ve | --v)
    echo "./config.status generated by autoconf version 2.13"
    exit 0 ;;
  -help | --help | --hel | --he | --h)
    echo "$ac_cs_usage"; exit 0 ;;
  *) echo "$ac_cs_usage"; exit 1 ;;
  esac
done

ac_given_srcdir=.
ac_given_INSTALL="/usr/bin/install -c"

trap 'rm -fr Makefile
	bin/Makefile
	bin/adv1tov2/Makefile
	bin/aecho/Makefile
	bin/afile/Makefile
	bin/afppasswd/Makefile
	bin/getzones/Makefile
	bin/megatron/Makefile
	bin/nbp/Makefile
	bin/pap/Makefile
	bin/psorder/Makefile
	config/Makefile
	contrib/Makefile
	contrib/nu/Makefile
	contrib/printing/Makefile
	contrib/shell_utils/Makefile
	contrib/timelord/Makefile
	distrib/Makefile
	distrib/config/Makefile
	distrib/config/netatalk-config
	distrib/initscripts/Makefile
	distrib/m4/Makefile
	etc/Makefile
	etc/afpd/Makefile
	etc/afpd/nls/Makefile
	etc/atalkd/Makefile
	etc/uams/Makefile
	etc/uams/uams_krb4/Makefile
	etc/papd/Makefile
	etc/psf/Makefile
	include/Makefile
	include/atalk/Makefile
	libatalk/Makefile
	libatalk/adouble/Makefile
	libatalk/asp/Makefile
	libatalk/atp/Makefile
	libatalk/compat/Makefile
	libatalk/dsi/Makefile
	libatalk/nbp/Makefile
	libatalk/netddp/Makefile
	libatalk/util/Makefile
	man/Makefile
	man/man1/Makefile
	man/man3/Makefile
	man/man4/Makefile
	man/man5/Makefile
	man/man8/Makefile
	sys/Makefile
	sys/netatalk/Makefile
	 config.h conftest*; exit 1' 1 2 15

# Protect against being on the right side of a sed subst in config.status.
sed 's/%@/@@/; s/@%/@@/; s/%g$/@g/; /@g$/s/[\\&%]/\\&/g;
 s/@@/%@/; s/@@/@%/; s/@g$/%g/' > conftest.subs <<\CEOF
/^[ 	]*VPATH[ 	]*=[^:]*$/d

s%@SHELL@%/bin/sh%g
s%@CFLAGS@%-g -O2 -I$(top_srcdir)/include -I$(top_srcdir)/sys -I/usr/include -I/usr/include/openssl%g
s%@CPPFLAGS@%%g
s%@CXXFLAGS@%%g
s%@FFLAGS@%%g
s%@DEFS@%-DHAVE_CONFIG_H%g
s%@LDFLAGS@% -L$(top_srcdir)/libatalk/ -L/usr/lib -L/usr%g
s%@LIBS@%-ldes -lcrypto -lrpcsvc -lresolv -lkrb -lcom_err  -lwrap%g
s%@exec_prefix@%${prefix}%g
s%@prefix@%/usr%g
s%@program_transform_name@%s,x,x,%g
s%@bindir@%${exec_prefix}/bin%g
s%@sbindir@%${exec_prefix}/sbin%g
s%@libexecdir@%${exec_prefix}/libexec%g
s%@datadir@%${prefix}/share%g
s%@sysconfdir@%${prefix}/etc%g
s%@sharedstatedir@%${prefix}/com%g
s%@localstatedir@%${prefix}/var%g
s%@libdir@%${exec_prefix}/lib%g
s%@includedir@%${prefix}/include%g
s%@oldincludedir@%/usr/include%g
s%@infodir@%${prefix}/info%g
s%@mandir@%${prefix}/man%g
s%@NETATALK_VERSION@%1.5pre5%g
s%@host@%i386-unknown-openbsd2.8%g
s%@host_alias@%i386-unknown-openbsd2.8%g
s%@host_cpu@%i386%g
s%@host_vendor@%unknown%g
s%@host_os@%openbsd2.8%g
s%@target@%i386-unknown-openbsd2.8%g
s%@target_alias@%i386-unknown-openbsd2.8%g
s%@target_cpu@%i386%g
s%@target_vendor@%unknown%g
s%@target_os@%openbsd2.8%g
s%@build@%i386-unknown-openbsd2.8%g
s%@build_alias@%i386-unknown-openbsd2.8%g
s%@build_cpu@%i386%g
s%@build_vendor@%unknown%g
s%@build_os@%openbsd2.8%g
s%@INSTALL_PROGRAM@%${INSTALL}%g
s%@INSTALL_SCRIPT@%${INSTALL_PROGRAM}%g
s%@INSTALL_DATA@%${INSTALL} -m 644%g
s%@PACKAGE@%netatalk%g
s%@VERSION@%1.5pre5%g
s%@ACLOCAL@%aclocal%g
s%@AUTOCONF@%autoconf%g
s%@AUTOMAKE@%automake%g
s%@AUTOHEADER@%autoheader%g
s%@MAKEINFO@%makeinfo%g
s%@SET_MAKE@%%g
s%@RANLIB@%ranlib%g
s%@CC@%gcc%g
s%@LN_S@%ln -s%g
s%@LIBTOOL@%$(SHELL) $(top_builddir)/libtool%g
s%@AWK@%nawk%g
s%@CPP@%gcc -E%g
s%@LIBOBJS@%%g
s%@BUILD_PAM_TRUE@%#%g
s%@BUILD_PAM_FALSE@%%g
s%@CONFIG_DIR@%/etc/atalk%g
s%@UAMS_PATH@%/etc/atalk/uams%g
s%@LDSHAREDFLAGS@%%g
s%@SOLARIS_MODULE_TRUE@%#%g
s%@SOLARIS_MODULE_FALSE@%%g
s%@USE_DHX_TRUE@%%g
s%@USE_DHX_FALSE@%#%g
s%@USE_KERBEROS_TRUE@%#%g
s%@USE_KERBEROS_FALSE@%%g
s%@USE_PAM_SO_TRUE@%#%g
s%@USE_PAM_SO_FALSE@%%g
s%@USE_PAM_TRUE@%#%g
s%@USE_PAM_FALSE@%%g
s%@USE_PGP_TRUE@%#%g
s%@USE_PGP_FALSE@%%g
s%@USE_COBALT_TRUE@%#%g
s%@USE_COBALT_FALSE@%%g
s%@USE_REDHAT_TRUE@%#%g
s%@USE_REDHAT_FALSE@%%g
s%@USE_SUSE_TRUE@%#%g
s%@USE_SUSE_FALSE@%%g
s%@USE_SHADOWPW_TRUE@%#%g
s%@USE_SHADOWPW_FALSE@%%g
s%@USE_TRU64_TRUE@%#%g
s%@USE_TRU64_FALSE@%%g

CEOF

# Split the substitutions into bite-sized pieces for seds with
# small command number limits, like on Digital OSF/1 and HP-UX.
ac_max_sed_cmds=90 # Maximum number of lines to put in a sed script.
ac_file=1 # Number of current file.
ac_beg=1 # First line for current file.
ac_end=$ac_max_sed_cmds # Line after last line for current file.
ac_more_lines=:
ac_sed_cmds=""
while $ac_more_lines; do
  if test $ac_beg -gt 1; then
    sed "1,${ac_beg}d; ${ac_end}q" conftest.subs > conftest.s$ac_file
  else
    sed "${ac_end}q" conftest.subs > conftest.s$ac_file
  fi
  if test ! -s conftest.s$ac_file; then
    ac_more_lines=false
    rm -f conftest.s$ac_file
  else
    if test -z "$ac_sed_cmds"; then
      ac_sed_cmds="sed -f conftest.s$ac_file"
    else
      ac_sed_cmds="$ac_sed_cmds | sed -f conftest.s$ac_file"
    fi
    ac_file=`expr $ac_file + 1`
    ac_beg=$ac_end
    ac_end=`expr $ac_end + $ac_max_sed_cmds`
  fi
done
if test -z "$ac_sed_cmds"; then
  ac_sed_cmds=cat
fi

CONFIG_FILES=${CONFIG_FILES-"Makefile
	bin/Makefile
	bin/adv1tov2/Makefile
	bin/aecho/Makefile
	bin/afile/Makefile
	bin/afppasswd/Makefile
	bin/getzones/Makefile
	bin/megatron/Makefile
	bin/nbp/Makefile
	bin/pap/Makefile
	bin/psorder/Makefile
	config/Makefile
	contrib/Makefile
	contrib/nu/Makefile
	contrib/printing/Makefile
	contrib/shell_utils/Makefile
	contrib/timelord/Makefile
	distrib/Makefile
	distrib/config/Makefile
	distrib/config/netatalk-config
	distrib/initscripts/Makefile
	distrib/m4/Makefile
	etc/Makefile
	etc/afpd/Makefile
	etc/afpd/nls/Makefile
	etc/atalkd/Makefile
	etc/uams/Makefile
	etc/uams/uams_krb4/Makefile
	etc/papd/Makefile
	etc/psf/Makefile
	include/Makefile
	include/atalk/Makefile
	libatalk/Makefile
	libatalk/adouble/Makefile
	libatalk/asp/Makefile
	libatalk/atp/Makefile
	libatalk/compat/Makefile
	libatalk/dsi/Makefile
	libatalk/nbp/Makefile
	libatalk/netddp/Makefile
	libatalk/util/Makefile
	man/Makefile
	man/man1/Makefile
	man/man3/Makefile
	man/man4/Makefile
	man/man5/Makefile
	man/man8/Makefile
	sys/Makefile
	sys/netatalk/Makefile
	"}
for ac_file in .. $CONFIG_FILES; do if test "x$ac_file" != x..; then
  # Support "outfile[:infile[:infile...]]", defaulting infile="outfile.in".
  case "$ac_file" in
  *:*) ac_file_in=`echo "$ac_file"|sed 's%[^:]*:%%'`
       ac_file=`echo "$ac_file"|sed 's%:.*%%'` ;;
  *) ac_file_in="${ac_file}.in" ;;
  esac

  # Adjust a relative srcdir, top_srcdir, and INSTALL for subdirectories.

  # Remove last slash and all that follows it.  Not all systems have dirname.
  ac_dir=`echo $ac_file|sed 's%/[^/][^/]*$%%'`
  if test "$ac_dir" != "$ac_file" && test "$ac_dir" != .; then
    # The file is in a subdirectory.
    test ! -d "$ac_dir" && mkdir "$ac_dir"
    ac_dir_suffix="/`echo $ac_dir|sed 's%^\./%%'`"
    # A "../" for each directory in $ac_dir_suffix.
    ac_dots=`echo $ac_dir_suffix|sed 's%/[^/]*%../%g'`
  else
    ac_dir_suffix= ac_dots=
  fi

  case "$ac_given_srcdir" in
  .)  srcdir=.
      if test -z "$ac_dots"; then top_srcdir=.
      else top_srcdir=`echo $ac_dots|sed 's%/$%%'`; fi ;;
  /*) srcdir="$ac_given_srcdir$ac_dir_suffix"; top_srcdir="$ac_given_srcdir" ;;
  *) # Relative path.
    srcdir="$ac_dots$ac_given_srcdir$ac_dir_suffix"
    top_srcdir="$ac_dots$ac_given_srcdir" ;;
  esac

  case "$ac_given_INSTALL" in
  [/$]*) INSTALL="$ac_given_INSTALL" ;;
  *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
  esac

  echo creating "$ac_file"
  rm -f "$ac_file"
  configure_input="Generated automatically from `echo $ac_file_in|sed 's%.*/%%'` by configure."
  case "$ac_file" in
  *Makefile*) ac_comsub="1i\\
# $configure_input" ;;
  *) ac_comsub= ;;
  esac

  ac_file_inputs=`echo $ac_file_in|sed -e "s%^%$ac_given_srcdir/%" -e "s%:% $ac_given_srcdir/%g"`
  sed -e "$ac_comsub
s%@configure_input@%$configure_input%g
s%@srcdir@%$srcdir%g
s%@top_srcdir@%$top_srcdir%g
s%@INSTALL@%$INSTALL%g
" $ac_file_inputs | (eval "$ac_sed_cmds") > $ac_file
fi; done
rm -f conftest.s*

# These sed commands are passed to sed as "A NAME B NAME C VALUE D", where
# NAME is the cpp macro being defined and VALUE is the value it is being given.
#
# ac_d sets the value in "#define NAME VALUE" lines.
ac_dA='s%^\([ 	]*\)#\([ 	]*define[ 	][ 	]*\)'
ac_dB='\([ 	][ 	]*\)[^ 	]*%\1#\2'
ac_dC='\3'
ac_dD='%g'
# ac_u turns "#undef NAME" with trailing blanks into "#define NAME VALUE".
ac_uA='s%^\([ 	]*\)#\([ 	]*\)undef\([ 	][ 	]*\)'
ac_uB='\([ 	]\)%\1#\2define\3'
ac_uC=' '
ac_uD='\4%g'
# ac_e turns "#undef NAME" without trailing blanks into "#define NAME VALUE".
ac_eA='s%^\([ 	]*\)#\([ 	]*\)undef\([ 	][ 	]*\)'
ac_eB='$%\1#\2define\3'
ac_eC=' '
ac_eD='%g'

if test "${CONFIG_HEADERS+set}" != set; then
  CONFIG_HEADERS="config.h"
fi
for ac_file in .. $CONFIG_HEADERS; do if test "x$ac_file" != x..; then
  # Support "outfile[:infile[:infile...]]", defaulting infile="outfile.in".
  case "$ac_file" in
  *:*) ac_file_in=`echo "$ac_file"|sed 's%[^:]*:%%'`
       ac_file=`echo "$ac_file"|sed 's%:.*%%'` ;;
  *) ac_file_in="${ac_file}.in" ;;
  esac

  echo creating $ac_file

  rm -f conftest.frag conftest.in conftest.out
  ac_file_inputs=`echo $ac_file_in|sed -e "s%^%$ac_given_srcdir/%" -e "s%:% $ac_given_srcdir/%g"`
  cat $ac_file_inputs > conftest.in

  cat > conftest.frag <<CEOF
${ac_dA}PACKAGE${ac_dB}PACKAGE${ac_dC}"netatalk"${ac_dD}
${ac_uA}PACKAGE${ac_uB}PACKAGE${ac_uC}"netatalk"${ac_uD}
${ac_eA}PACKAGE${ac_eB}PACKAGE${ac_eC}"netatalk"${ac_eD}
${ac_dA}VERSION${ac_dB}VERSION${ac_dC}"1.5pre5"${ac_dD}
${ac_uA}VERSION${ac_uB}VERSION${ac_uC}"1.5pre5"${ac_uD}
${ac_eA}VERSION${ac_eB}VERSION${ac_eC}"1.5pre5"${ac_eD}
${ac_dA}HAVE_LIBCOM_ERR${ac_dB}HAVE_LIBCOM_ERR${ac_dC}1${ac_dD}
${ac_uA}HAVE_LIBCOM_ERR${ac_uB}HAVE_LIBCOM_ERR${ac_uC}1${ac_uD}
${ac_eA}HAVE_LIBCOM_ERR${ac_eB}HAVE_LIBCOM_ERR${ac_eC}1${ac_eD}
${ac_dA}HAVE_LIBKRB${ac_dB}HAVE_LIBKRB${ac_dC}1${ac_dD}
${ac_uA}HAVE_LIBKRB${ac_uB}HAVE_LIBKRB${ac_uC}1${ac_uD}
${ac_eA}HAVE_LIBKRB${ac_eB}HAVE_LIBKRB${ac_eC}1${ac_eD}
CEOF
  sed -f conftest.frag conftest.in > conftest.out
  rm -f conftest.in
  mv conftest.out conftest.in

  cat > conftest.frag <<CEOF
${ac_dA}HAVE_LIBRESOLV${ac_dB}HAVE_LIBRESOLV${ac_dC}1${ac_dD}
${ac_uA}HAVE_LIBRESOLV${ac_uB}HAVE_LIBRESOLV${ac_uC}1${ac_uD}
${ac_eA}HAVE_LIBRESOLV${ac_eB}HAVE_LIBRESOLV${ac_eC}1${ac_eD}
${ac_dA}HAVE_LIBRPCSVC${ac_dB}HAVE_LIBRPCSVC${ac_dC}1${ac_dD}
${ac_uA}HAVE_LIBRPCSVC${ac_uB}HAVE_LIBRPCSVC${ac_uC}1${ac_uD}
${ac_eA}HAVE_LIBRPCSVC${ac_eB}HAVE_LIBRPCSVC${ac_eC}1${ac_eD}
${ac_dA}HAVE_ACCESS${ac_dB}HAVE_ACCESS${ac_dC}1${ac_dD}
${ac_uA}HAVE_ACCESS${ac_uB}HAVE_ACCESS${ac_uC}1${ac_uD}
${ac_eA}HAVE_ACCESS${ac_eB}HAVE_ACCESS${ac_eC}1${ac_eD}
${ac_dA}HAVE_DIRENT_H${ac_dB}HAVE_DIRENT_H${ac_dC}1${ac_dD}
${ac_uA}HAVE_DIRENT_H${ac_uB}HAVE_DIRENT_H${ac_uC}1${ac_uD}
${ac_eA}HAVE_DIRENT_H${ac_eB}HAVE_DIRENT_H${ac_eC}1${ac_eD}
CEOF
  sed -f conftest.frag conftest.in > conftest.out
  rm -f conftest.in
  mv conftest.out conftest.in

  cat > conftest.frag <<CEOF
${ac_dA}STDC_HEADERS${ac_dB}STDC_HEADERS${ac_dC}1${ac_dD}
${ac_uA}STDC_HEADERS${ac_uB}STDC_HEADERS${ac_uC}1${ac_uD}
${ac_eA}STDC_HEADERS${ac_eB}STDC_HEADERS${ac_eC}1${ac_eD}
${ac_dA}HAVE_SYS_WAIT_H${ac_dB}HAVE_SYS_WAIT_H${ac_dC}1${ac_dD}
${ac_uA}HAVE_SYS_WAIT_H${ac_uB}HAVE_SYS_WAIT_H${ac_uC}1${ac_uD}
${ac_eA}HAVE_SYS_WAIT_H${ac_eB}HAVE_SYS_WAIT_H${ac_eC}1${ac_eD}
${ac_dA}HAVE_FCNTL_H${ac_dB}HAVE_FCNTL_H${ac_dC}1${ac_dD}
${ac_uA}HAVE_FCNTL_H${ac_uB}HAVE_FCNTL_H${ac_uC}1${ac_uD}
${ac_eA}HAVE_FCNTL_H${ac_eB}HAVE_FCNTL_H${ac_eC}1${ac_eD}
${ac_dA}HAVE_LIMITS_H${ac_dB}HAVE_LIMITS_H${ac_dC}1${ac_dD}
${ac_uA}HAVE_LIMITS_H${ac_uB}HAVE_LIMITS_H${ac_uC}1${ac_uD}
${ac_eA}HAVE_LIMITS_H${ac_eB}HAVE_LIMITS_H${ac_eC}1${ac_eD}
CEOF
  sed -f conftest.frag conftest.in > conftest.out
  rm -f conftest.in
  mv conftest.out conftest.in

  cat > conftest.frag <<CEOF
${ac_dA}HAVE_STRINGS_H${ac_dB}HAVE_STRINGS_H${ac_dC}1${ac_dD}
${ac_uA}HAVE_STRINGS_H${ac_uB}HAVE_STRINGS_H${ac_uC}1${ac_uD}
${ac_eA}HAVE_STRINGS_H${ac_eB}HAVE_STRINGS_H${ac_eC}1${ac_eD}
${ac_dA}HAVE_SYS_FCNTL_H${ac_dB}HAVE_SYS_FCNTL_H${ac_dC}1${ac_dD}
${ac_uA}HAVE_SYS_FCNTL_H${ac_uB}HAVE_SYS_FCNTL_H${ac_uC}1${ac_uD}
${ac_eA}HAVE_SYS_FCNTL_H${ac_eB}HAVE_SYS_FCNTL_H${ac_eC}1${ac_eD}
${ac_dA}HAVE_SYS_FILE_H${ac_dB}HAVE_SYS_FILE_H${ac_dC}1${ac_dD}
${ac_uA}HAVE_SYS_FILE_H${ac_uB}HAVE_SYS_FILE_H${ac_uC}1${ac_uD}
${ac_eA}HAVE_SYS_FILE_H${ac_eB}HAVE_SYS_FILE_H${ac_eC}1${ac_eD}
${ac_dA}HAVE_SYS_IOCTL_H${ac_dB}HAVE_SYS_IOCTL_H${ac_dC}1${ac_dD}
${ac_uA}HAVE_SYS_IOCTL_H${ac_uB}HAVE_SYS_IOCTL_H${ac_uC}1${ac_uD}
${ac_eA}HAVE_SYS_IOCTL_H${ac_eB}HAVE_SYS_IOCTL_H${ac_eC}1${ac_eD}
CEOF
  sed -f conftest.frag conftest.in > conftest.out
  rm -f conftest.in
  mv conftest.out conftest.in

  cat > conftest.frag <<CEOF
${ac_dA}HAVE_SYS_TIME_H${ac_dB}HAVE_SYS_TIME_H${ac_dC}1${ac_dD}
${ac_uA}HAVE_SYS_TIME_H${ac_uB}HAVE_SYS_TIME_H${ac_uC}1${ac_uD}
${ac_eA}HAVE_SYS_TIME_H${ac_eB}HAVE_SYS_TIME_H${ac_eC}1${ac_eD}
${ac_dA}HAVE_SYSLOG_H${ac_dB}HAVE_SYSLOG_H${ac_dC}1${ac_dD}
${ac_uA}HAVE_SYSLOG_H${ac_uB}HAVE_SYSLOG_H${ac_uC}1${ac_uD}
${ac_eA}HAVE_SYSLOG_H${ac_eB}HAVE_SYSLOG_H${ac_eC}1${ac_eD}
${ac_dA}HAVE_UNISTD_H${ac_dB}HAVE_UNISTD_H${ac_dC}1${ac_dD}
${ac_uA}HAVE_UNISTD_H${ac_uB}HAVE_UNISTD_H${ac_uC}1${ac_uD}
${ac_eA}HAVE_UNISTD_H${ac_eB}HAVE_UNISTD_H${ac_eC}1${ac_eD}
${ac_dA}HAVE_TERMIOS_H${ac_dB}HAVE_TERMIOS_H${ac_dC}1${ac_dD}
${ac_uA}HAVE_TERMIOS_H${ac_uB}HAVE_TERMIOS_H${ac_uC}1${ac_uD}
${ac_eA}HAVE_TERMIOS_H${ac_eB}HAVE_TERMIOS_H${ac_eC}1${ac_eD}
CEOF
  sed -f conftest.frag conftest.in > conftest.out
  rm -f conftest.in
  mv conftest.out conftest.in

  cat > conftest.frag <<CEOF
${ac_dA}HAVE_SYS_TERMIOS_H${ac_dB}HAVE_SYS_TERMIOS_H${ac_dC}1${ac_dD}
${ac_uA}HAVE_SYS_TERMIOS_H${ac_uB}HAVE_SYS_TERMIOS_H${ac_uC}1${ac_uD}
${ac_eA}HAVE_SYS_TERMIOS_H${ac_eB}HAVE_SYS_TERMIOS_H${ac_eC}1${ac_eD}
${ac_dA}HAVE_NETDB_H${ac_dB}HAVE_NETDB_H${ac_dC}1${ac_dD}
${ac_uA}HAVE_NETDB_H${ac_uB}HAVE_NETDB_H${ac_uC}1${ac_uD}
${ac_eA}HAVE_NETDB_H${ac_eB}HAVE_NETDB_H${ac_eC}1${ac_eD}
${ac_dA}HAVE_SGTTY_H${ac_dB}HAVE_SGTTY_H${ac_dC}1${ac_dD}
${ac_uA}HAVE_SGTTY_H${ac_uB}HAVE_SGTTY_H${ac_uC}1${ac_uD}
${ac_eA}HAVE_SGTTY_H${ac_eB}HAVE_SGTTY_H${ac_eC}1${ac_eD}
${ac_dA}HAVE_ST_RDEV${ac_dB}HAVE_ST_RDEV${ac_dC}1${ac_dD}
${ac_uA}HAVE_ST_RDEV${ac_uB}HAVE_ST_RDEV${ac_uC}1${ac_uD}
${ac_eA}HAVE_ST_RDEV${ac_eB}HAVE_ST_RDEV${ac_eC}1${ac_eD}
CEOF
  sed -f conftest.frag conftest.in > conftest.out
  rm -f conftest.in
  mv conftest.out conftest.in

  cat > conftest.frag <<CEOF
${ac_dA}TIME_WITH_SYS_TIME${ac_dB}TIME_WITH_SYS_TIME${ac_dC}1${ac_dD}
${ac_uA}TIME_WITH_SYS_TIME${ac_uB}TIME_WITH_SYS_TIME${ac_uC}1${ac_uD}
${ac_eA}TIME_WITH_SYS_TIME${ac_eB}TIME_WITH_SYS_TIME${ac_eC}1${ac_eD}
${ac_dA}GETGROUPS_T${ac_dB}GETGROUPS_T${ac_dC}gid_t${ac_dD}
${ac_uA}GETGROUPS_T${ac_uB}GETGROUPS_T${ac_uC}gid_t${ac_uD}
${ac_eA}GETGROUPS_T${ac_eB}GETGROUPS_T${ac_eC}gid_t${ac_eD}
${ac_dA}HAVE_UNISTD_H${ac_dB}HAVE_UNISTD_H${ac_dC}1${ac_dD}
${ac_uA}HAVE_UNISTD_H${ac_uB}HAVE_UNISTD_H${ac_uC}1${ac_uD}
${ac_eA}HAVE_UNISTD_H${ac_eB}HAVE_UNISTD_H${ac_eC}1${ac_eD}
${ac_dA}HAVE_GETPAGESIZE${ac_dB}HAVE_GETPAGESIZE${ac_dC}1${ac_dD}
${ac_uA}HAVE_GETPAGESIZE${ac_uB}HAVE_GETPAGESIZE${ac_uC}1${ac_uD}
${ac_eA}HAVE_GETPAGESIZE${ac_eB}HAVE_GETPAGESIZE${ac_eC}1${ac_eD}
CEOF
  sed -f conftest.frag conftest.in > conftest.out
  rm -f conftest.in
  mv conftest.out conftest.in

  cat > conftest.frag <<CEOF
${ac_dA}HAVE_MMAP${ac_dB}HAVE_MMAP${ac_dC}1${ac_dD}
${ac_uA}HAVE_MMAP${ac_uB}HAVE_MMAP${ac_uC}1${ac_uD}
${ac_eA}HAVE_MMAP${ac_eB}HAVE_MMAP${ac_eC}1${ac_eD}
${ac_dA}RETSIGTYPE${ac_dB}RETSIGTYPE${ac_dC}void${ac_dD}
${ac_uA}RETSIGTYPE${ac_uB}RETSIGTYPE${ac_uC}void${ac_uD}
${ac_eA}RETSIGTYPE${ac_eB}RETSIGTYPE${ac_eC}void${ac_eD}
${ac_dA}HAVE_UTIME_NULL${ac_dB}HAVE_UTIME_NULL${ac_dC}1${ac_dD}
${ac_uA}HAVE_UTIME_NULL${ac_uB}HAVE_UTIME_NULL${ac_uC}1${ac_uD}
${ac_eA}HAVE_UTIME_NULL${ac_eB}HAVE_UTIME_NULL${ac_eC}1${ac_eD}
${ac_dA}HAVE_WAIT3${ac_dB}HAVE_WAIT3${ac_dC}1${ac_dD}
${ac_uA}HAVE_WAIT3${ac_uB}HAVE_WAIT3${ac_uC}1${ac_uD}
${ac_eA}HAVE_WAIT3${ac_eB}HAVE_WAIT3${ac_eC}1${ac_eD}
CEOF
  sed -f conftest.frag conftest.in > conftest.out
  rm -f conftest.in
  mv conftest.out conftest.in

  cat > conftest.frag <<CEOF
${ac_dA}HAVE_GETCWD${ac_dB}HAVE_GETCWD${ac_dC}1${ac_dD}
${ac_uA}HAVE_GETCWD${ac_uB}HAVE_GETCWD${ac_uC}1${ac_uD}
${ac_eA}HAVE_GETCWD${ac_eB}HAVE_GETCWD${ac_eC}1${ac_eD}
${ac_dA}HAVE_GETHOSTNAME${ac_dB}HAVE_GETHOSTNAME${ac_dC}1${ac_dD}
${ac_uA}HAVE_GETHOSTNAME${ac_uB}HAVE_GETHOSTNAME${ac_uC}1${ac_uD}
${ac_eA}HAVE_GETHOSTNAME${ac_eB}HAVE_GETHOSTNAME${ac_eC}1${ac_eD}
${ac_dA}HAVE_GETTIMEOFDAY${ac_dB}HAVE_GETTIMEOFDAY${ac_dC}1${ac_dD}
${ac_uA}HAVE_GETTIMEOFDAY${ac_uB}HAVE_GETTIMEOFDAY${ac_uC}1${ac_uD}
${ac_eA}HAVE_GETTIMEOFDAY${ac_eB}HAVE_GETTIMEOFDAY${ac_eC}1${ac_eD}
${ac_dA}HAVE_GETUSERSHELL${ac_dB}HAVE_GETUSERSHELL${ac_dC}1${ac_dD}
${ac_uA}HAVE_GETUSERSHELL${ac_uB}HAVE_GETUSERSHELL${ac_uC}1${ac_uD}
${ac_eA}HAVE_GETUSERSHELL${ac_eB}HAVE_GETUSERSHELL${ac_eC}1${ac_eD}
CEOF
  sed -f conftest.frag conftest.in > conftest.out
  rm -f conftest.in
  mv conftest.out conftest.in

  cat > conftest.frag <<CEOF
${ac_dA}HAVE_MKDIR${ac_dB}HAVE_MKDIR${ac_dC}1${ac_dD}
${ac_uA}HAVE_MKDIR${ac_uB}HAVE_MKDIR${ac_uC}1${ac_uD}
${ac_eA}HAVE_MKDIR${ac_eB}HAVE_MKDIR${ac_eC}1${ac_eD}
${ac_dA}HAVE_RMDIR${ac_dB}HAVE_RMDIR${ac_dC}1${ac_dD}
${ac_uA}HAVE_RMDIR${ac_uB}HAVE_RMDIR${ac_uC}1${ac_uD}
${ac_eA}HAVE_RMDIR${ac_eB}HAVE_RMDIR${ac_eC}1${ac_eD}
${ac_dA}HAVE_SELECT${ac_dB}HAVE_SELECT${ac_dC}1${ac_dD}
${ac_uA}HAVE_SELECT${ac_uB}HAVE_SELECT${ac_uC}1${ac_uD}
${ac_eA}HAVE_SELECT${ac_eB}HAVE_SELECT${ac_eC}1${ac_eD}
${ac_dA}HAVE_SOCKET${ac_dB}HAVE_SOCKET${ac_dC}1${ac_dD}
${ac_uA}HAVE_SOCKET${ac_uB}HAVE_SOCKET${ac_uC}1${ac_uD}
${ac_eA}HAVE_SOCKET${ac_eB}HAVE_SOCKET${ac_eC}1${ac_eD}
CEOF
  sed -f conftest.frag conftest.in > conftest.out
  rm -f conftest.in
  mv conftest.out conftest.in

  cat > conftest.frag <<CEOF
${ac_dA}HAVE_STRDUP${ac_dB}HAVE_STRDUP${ac_dC}1${ac_dD}
${ac_uA}HAVE_STRDUP${ac_uB}HAVE_STRDUP${ac_uC}1${ac_uD}
${ac_eA}HAVE_STRDUP${ac_eB}HAVE_STRDUP${ac_eC}1${ac_eD}
${ac_dA}HAVE_STRSTR${ac_dB}HAVE_STRSTR${ac_dC}1${ac_dD}
${ac_uA}HAVE_STRSTR${ac_uB}HAVE_STRSTR${ac_uC}1${ac_uD}
${ac_eA}HAVE_STRSTR${ac_eB}HAVE_STRSTR${ac_eC}1${ac_eD}
${ac_dA}HAVE_STRTOUL${ac_dB}HAVE_STRTOUL${ac_dC}1${ac_dD}
${ac_uA}HAVE_STRTOUL${ac_uB}HAVE_STRTOUL${ac_uC}1${ac_uD}
${ac_eA}HAVE_STRTOUL${ac_eB}HAVE_STRTOUL${ac_eC}1${ac_eD}
${ac_dA}HAVE_SETPGRP${ac_dB}HAVE_SETPGRP${ac_dC}1${ac_dD}
${ac_uA}HAVE_SETPGRP${ac_uB}HAVE_SETPGRP${ac_uC}1${ac_uD}
${ac_eA}HAVE_SETPGRP${ac_eB}HAVE_SETPGRP${ac_eC}1${ac_eD}
CEOF
  sed -f conftest.frag conftest.in > conftest.out
  rm -f conftest.in
  mv conftest.out conftest.in

  cat > conftest.frag <<CEOF
${ac_dA}ADMIN_GRP${ac_dB}ADMIN_GRP${ac_dC}1${ac_dD}
${ac_uA}ADMIN_GRP${ac_uB}ADMIN_GRP${ac_uC}1${ac_uD}
${ac_eA}ADMIN_GRP${ac_eB}ADMIN_GRP${ac_eC}1${ac_eD}
${ac_dA}TCPWRAP${ac_dB}TCPWRAP${ac_dC}1${ac_dD}
${ac_uA}TCPWRAP${ac_uB}TCPWRAP${ac_uC}1${ac_uD}
${ac_eA}TCPWRAP${ac_eB}TCPWRAP${ac_eC}1${ac_eD}
${ac_dA}CONFIG_DIR${ac_dB}CONFIG_DIR${ac_dC}"/etc/atalk"${ac_dD}
${ac_uA}CONFIG_DIR${ac_uB}CONFIG_DIR${ac_uC}"/etc/atalk"${ac_uD}
${ac_eA}CONFIG_DIR${ac_eB}CONFIG_DIR${ac_eC}"/etc/atalk"${ac_eD}
${ac_dA}UAMS_PATH${ac_dB}UAMS_PATH${ac_dC}"/etc/atalk/uams"${ac_dD}
${ac_uA}UAMS_PATH${ac_uB}UAMS_PATH${ac_uC}"/etc/atalk/uams"${ac_uD}
${ac_eA}UAMS_PATH${ac_eB}UAMS_PATH${ac_eC}"/etc/atalk/uams"${ac_eD}
CEOF
  sed -f conftest.frag conftest.in > conftest.out
  rm -f conftest.in
  mv conftest.out conftest.in

  cat > conftest.frag <<CEOF
${ac_dA}BSD4_4${ac_dB}BSD4_4${ac_dC}1${ac_dD}
${ac_uA}BSD4_4${ac_uB}BSD4_4${ac_uC}1${ac_uD}
${ac_eA}BSD4_4${ac_eB}BSD4_4${ac_eC}1${ac_eD}
${ac_dA}HAVE_LIBCRYPTO${ac_dB}HAVE_LIBCRYPTO${ac_dC}1${ac_dD}
${ac_uA}HAVE_LIBCRYPTO${ac_uB}HAVE_LIBCRYPTO${ac_uC}1${ac_uD}
${ac_eA}HAVE_LIBCRYPTO${ac_eB}HAVE_LIBCRYPTO${ac_eC}1${ac_eD}
${ac_dA}HAVE_LIBDES${ac_dB}HAVE_LIBDES${ac_dC}1${ac_dD}
${ac_uA}HAVE_LIBDES${ac_uB}HAVE_LIBDES${ac_uC}1${ac_uD}
${ac_eA}HAVE_LIBDES${ac_eB}HAVE_LIBDES${ac_eC}1${ac_eD}
${ac_dA}OPENSSL_DHX${ac_dB}OPENSSL_DHX${ac_dC}1${ac_dD}
${ac_uA}OPENSSL_DHX${ac_uB}OPENSSL_DHX${ac_uC}1${ac_uD}
${ac_eA}OPENSSL_DHX${ac_eB}OPENSSL_DHX${ac_eC}1${ac_eD}
CEOF
  sed -f conftest.frag conftest.in > conftest.out
  rm -f conftest.in
  mv conftest.out conftest.in

  cat > conftest.frag <<CEOF
${ac_dA}UAM_DHX${ac_dB}UAM_DHX${ac_dC}1${ac_dD}
${ac_uA}UAM_DHX${ac_uB}UAM_DHX${ac_uC}1${ac_uD}
${ac_eA}UAM_DHX${ac_eB}UAM_DHX${ac_eC}1${ac_eD}
${ac_dA}UAM_RNDNUM${ac_dB}UAM_RNDNUM${ac_dC}1${ac_dD}
${ac_uA}UAM_RNDNUM${ac_uB}UAM_RNDNUM${ac_uC}1${ac_uD}
${ac_eA}UAM_RNDNUM${ac_eB}UAM_RNDNUM${ac_eC}1${ac_eD}
s%^[ 	]*#[ 	]*undef[ 	][ 	]*[a-zA-Z_][a-zA-Z_0-9]*%/* & */%
CEOF
  sed -f conftest.frag conftest.in > conftest.out
  rm -f conftest.in
  mv conftest.out conftest.in

  rm -f conftest.frag conftest.h
  echo "/* $ac_file.  Generated automatically by configure.  */" > conftest.h
  cat conftest.in >> conftest.h
  rm -f conftest.in
  if cmp -s $ac_file conftest.h 2>/dev/null; then
    echo "$ac_file is unchanged"
    rm -f conftest.h
  else
    # Remove last slash and all that follows it.  Not all systems have dirname.
      ac_dir=`echo $ac_file|sed 's%/[^/][^/]*$%%'`
      if test "$ac_dir" != "$ac_file" && test "$ac_dir" != .; then
      # The file is in a subdirectory.
      test ! -d "$ac_dir" && mkdir "$ac_dir"
    fi
    rm -f $ac_file
    mv conftest.h $ac_file
  fi
fi; done

test -z "$CONFIG_HEADERS" || echo timestamp > stamp-h
chmod a+x distrib/config/netatalk-config contrib/shell_utils/apple_*

exit 0

config.log:

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

configure:637: checking host system type
configure:658: checking target system type
configure:676: checking build system type
configure:710: checking for a BSD compatible install
configure:763: checking whether build environment is sane
configure:820: checking whether make sets ${MAKE}
configure:866: checking for working aclocal
configure:879: checking for working autoconf
configure:892: checking for working automake
configure:905: checking for working autoheader
configure:918: checking for working makeinfo
configure:1006: checking for ranlib
configure:1036: checking for gcc
configure:1149: checking whether the C compiler (gcc  ) works
configure:1165: gcc -o conftest    conftest.c  1>&5
configure:1191: checking whether the C compiler (gcc  ) is a cross-compiler
configure:1196: checking whether we are using GNU C
configure:1224: checking whether gcc accepts -g
configure:1267: checking for ld used by GCC
configure:1329: checking if the linker (/usr/bin/ld) is GNU ld
configure:1345: checking for BSD-compatible nm
configure:1381: checking whether ln -s works
ltconfig:603: checking for object suffix
ltconfig:604: gcc -c -g -O2  conftest.c 1>&5
ltconfig:629: checking for executable suffix
ltconfig:630: gcc -o conftest -g -O2   conftest.c  1>&5
ltconfig:776: checking if gcc PIC flag -fPIC works
ltconfig:777: gcc -c -g -O2 -fPIC -DPIC  conftest.c 1>&5
ltconfig:829: checking if gcc supports -c -o file.o
ltconfig:830: gcc -c -g -O2 -o out/conftest2.o  conftest.c 1>&5
ltconfig:862: checking if gcc supports -c -o file.lo
ltconfig:863: gcc -c -g -O2 -c -o conftest.lo  conftest.c 1>&5
ltconfig:914: checking if gcc supports -fno-rtti -fno-exceptions
ltconfig:915: gcc -c -g -O2 -fno-rtti -fno-exceptions -c conftest.c  conftest.c 1>&5
ltconfig:958: checking if gcc static flag -static works
ltconfig:959: gcc -o conftest -g -O2   -static conftest.c  1>&5
ltconfig:1653: checking if global_symbol_pipe works
ltconfig:1654: gcc -c -g -O2  conftest.c 1>&5
ltconfig:1657: eval "/usr/bin/nm -p conftest.o | sed -n -e 's/^.*[ 	]\([BCDEGRST]\)[ 	][ 	]*\(\)\([_A-Za-z][_A-Za-z0-9]*\)$/\1 \2\3 \3/p' > conftest.nm"
cannot find nm_test_var in conftest.nm
ltconfig:1653: checking if global_symbol_pipe works
ltconfig:1654: gcc -c -g -O2  conftest.c 1>&5
ltconfig:1657: eval "/usr/bin/nm -p conftest.o | sed -n -e 's/^.*[ 	]\([BCDEGRST]\)[ 	][ 	]*\(_\)\([_A-Za-z][_A-Za-z0-9]*\)$/\1 \2\3 \3/p' > conftest.nm"
ltconfig:1709: gcc -o conftest -g -O2 -fno-builtin -fno-rtti -fno-exceptions   conftest.c conftstm.o 1>&5
configure:1578: checking for gawk
configure:1610: checking for gcc
configure:1723: checking whether the C compiler (gcc -g -O2 ) works
configure:1739: gcc -o conftest -g -O2   conftest.c  1>&5
configure:1765: checking whether the C compiler (gcc -g -O2 ) is a cross-compiler
configure:1770: checking whether we are using GNU C
configure:1798: checking whether gcc accepts -g
configure:1841: checking for a BSD compatible install
configure:1894: checking whether ln -s works
configure:1915: checking whether make sets ${MAKE}
ltconfig:603: checking for object suffix
ltconfig:604: gcc -c -g -O2  conftest.c 1>&5
ltconfig:629: checking for executable suffix
ltconfig:630: gcc -o conftest -g -O2   conftest.c  1>&5
ltconfig:776: checking if gcc PIC flag -fPIC works
ltconfig:777: gcc -c -g -O2 -fPIC -DPIC  conftest.c 1>&5
ltconfig:829: checking if gcc supports -c -o file.o
ltconfig:830: gcc -c -g -O2 -o out/conftest2.o  conftest.c 1>&5
ltconfig:862: checking if gcc supports -c -o file.lo
ltconfig:863: gcc -c -g -O2 -c -o conftest.lo  conftest.c 1>&5
ltconfig:914: checking if gcc supports -fno-rtti -fno-exceptions
ltconfig:915: gcc -c -g -O2 -fno-rtti -fno-exceptions -c conftest.c  conftest.c 1>&5
ltconfig:958: checking if gcc static flag -static works
ltconfig:959: gcc -o conftest -g -O2   -static conftest.c  1>&5
ltconfig:1653: checking if global_symbol_pipe works
ltconfig:1654: gcc -c -g -O2  conftest.c 1>&5
ltconfig:1657: eval "/usr/bin/nm -p conftest.o | sed -n -e 's/^.*[ 	]\([BCDEGRST]\)[ 	][ 	]*\(\)\([_A-Za-z][_A-Za-z0-9]*\)$/\1 \2\3 \3/p' > conftest.nm"
cannot find nm_test_var in conftest.nm
ltconfig:1653: checking if global_symbol_pipe works
ltconfig:1654: gcc -c -g -O2  conftest.c 1>&5
ltconfig:1657: eval "/usr/bin/nm -p conftest.o | sed -n -e 's/^.*[ 	]\([BCDEGRST]\)[ 	][ 	]*\(_\)\([_A-Za-z][_A-Za-z0-9]*\)$/\1 \2\3 \3/p' > conftest.nm"
ltconfig:1709: gcc -o conftest -g -O2 -fno-builtin -fno-rtti -fno-exceptions   conftest.c conftstm.o 1>&5
configure:2023: checking for main in -labs
configure:2066: checking for main in -laudit
configure:2109: checking for main in -lauth
configure:2152: checking for main in -lcmd
configure:2195: checking for main in -lcom_err
configure:2238: checking for main in -lcrypt
configure:2281: checking for main in -ld
configure:2324: checking for main in -ldb
configure:2367: checking for main in -ldl
configure:2410: checking for main in -lkauth
configure:2453: checking for main in -lkrb
configure:2496: checking for main in -llwp
configure:2539: checking for main in -ln
configure:2582: checking for main in -lnsl
configure:2625: checking for main in -lprot
configure:2668: checking for main in -lresolv
configure:2711: checking for main in -lrpcsvc
configure:2754: checking for main in -lrx
configure:2797: checking for main in -lrxkad
configure:2840: checking for main in -lsocket
configure:2883: checking for main in -lsys
configure:2926: checking for main in -lubik
configure:2978: checking for access
configure:3036: checking for dirent.h that defines DIR
configure:3074: checking for opendir in -ldir
configure:3157: checking how to run the C preprocessor
configure:3237: checking for ANSI C header files
configure:3341: checking for sys/wait.h that is POSIX.1 compatible
configure:3386: checking for fcntl.h
configure:3386: checking for limits.h
configure:3386: checking for stdint.h
configure:3386: checking for strings.h
configure:3386: checking for sys/fcntl.h
configure:3386: checking for sys/file.h
configure:3386: checking for sys/ioctl.h
configure:3386: checking for sys/time.h
configure:3386: checking for syslog.h
configure:3386: checking for unistd.h
configure:3386: checking for termios.h
configure:3386: checking for sys/termios.h
configure:3386: checking for netdb.h
configure:3386: checking for sgtty.h
configure:3424: checking for sys/cdefs.h
configure:3484: checking for working const
configure:3559: checking for uid_t in sys/types.h
configure:3593: checking for inline
configure:3633: checking for mode_t
configure:3666: checking for off_t
configure:3699: checking for pid_t
configure:3732: checking for size_t
configure:3765: checking for st_rdev in struct stat
configure:3799: checking whether time.h and sys/time.h may both be included
configure:3834: checking whether struct tm is in sys/time.h or time.h
configure:3869: checking type of array argument to getgroups
configure:3941: checking whether gcc needs -traditional
configure:3987: checking for 8-bit clean memcmp
configure:4023: checking whether sys/types.h defines makedev
configure:4132: checking for unistd.h
configure:4171: checking for getpagesize
configure:4224: checking for working mmap
configure:4395: checking return type of signal handlers
configure:4436: checking whether utime accepts a null argument
configure:4481: checking for wait3 that fills in rusage
configure:4545: checking for getcwd
configure:4545: checking for gethostname
configure:4545: checking for gettimeofday
configure:4545: checking for getusershell
configure:4545: checking for mkdir
configure:4545: checking for rmdir
configure:4545: checking for select
configure:4545: checking for socket
configure:4545: checking for strdup
configure:4545: checking for strstr
configure:4545: checking for strtoul
configure:4545: checking for setpgrp
configure:4598: checking whether setpgrp takes no argument
configure:4873: checking for pam_start in -lpam
configure:4971: checking for hosts_access in -lwrap
configure:5312: checking for main in -lcrypto
configure:5355: checking for main in -ldes

Repeat-by:

./configure --with-tcp-wrappers --with-ssl-dirs=/usr
make

As you can probably tell, debugging isn't my strong suit. I love how well
1.5pre5 is documented, much better than any of the other netatalk packages
I've tried. Thank you very much.

Sincerely,

*                                                     *
Karen Swanberg              |                         
Network Admin.              | Error: Sector not found-- 
Dept. of Geology/Geophysics |search behind couch? (Y/N)
206 Pillsbury Hall          |                         
310 Pillsbury Ave. SE       |                         
University of Mn            |  Enter any 11-digit prime
Minneapolis, MN 55455       |     number to continue...
(612) 624-6541              |                         
*                                                     *

---

From: Jean-Philippe Rey <[email-masked]>
Date: Wed, 21 Mar 2001 21:30:53 +0100

Hi Karen,

I too had some problems installing netatalk 1.5pre3 on OpenBSD 2.8.

First the standard make cannot be used, you have to install gnu make. 
I used the package gmake-3.79.1.tgz which works fine.

I had a problem that I traced back to libtool (I used the package 
libtool-1.3.5.tgz). I worked around the problem by editing the 
libtool script created in the source directory by configure. I added 
the line

      output_objdir=.

near the beginning, after line 368.

And by the way, libtool should reside in /usr (and not /usr/local as 
is the default location for the package). Install the package like 
that:

      pkg_add -p /usr libtool-1.3.5.tgz

or you have to change the symlinks (config.guess, config.sub, 
ltconfig, etc.) in the netatalk source directory.

I also had a problem with undefined symbols in libwrap.a, I just 
dropped the --with-tcp-wrappers parameter of configure.

I had a last problem because configure did not set the config_h 
parameter correctly. So I edited the file config.h and added the line

#define NO_CRYPT_H 1

And after that everything went smoothly.

Summary
-------

./configure
vi libtool   -> 368a   output_objdir=.
vi config.h  ->   6a   #define NO_CRYPT_H 1
gmake
gmake install

worked for me.

Hope that helps.
-- 
Jean-Philippe Rey           Délégué informatique - École Centrale Paris
[email-masked]            92295 Châtenay-Malabry Cedex - France

---

From: Hauke Fath <[email-masked]>
Date: Wed, 21 Mar 2001 22:22:10 +0100

>be useful, but I'd be happy to provide more. If this is hopelessly basic,

Almost all problems are simple -- after you solved them.  ;)

>Fatal errors encountered -- cannot continue

Sit back and relax: You've just been bitten by the progressing gnuification
of Netatalk.

For whatever reason (I tried to track it down, but got lost in the twisty
maze that the output of GNU automake is) the Makefiles of Sourceforge
Netatalk want GNU make, and GNU make only.

Now, didn't I say it's simple?  ;)

	hauke

--
"It's never straight up and down"     (DEVO)

---

From: Paul Krohn <[email-masked]>
Date: Wed, 21 Mar 2001 22:28:59 -0800

Speaking of compile errors, i get the following when i try to compile
1.5pre5 on my cobalt qube 2:

afp_config.c: In function `ASPConfigInit':
afp_config.c:181: `VERSION' undeclared (first use this function)
afp_config.c:181: (Each undeclared identifier is reported only once
afp_config.c:181: for each function it appears in.)
afp_config.c: In function `DSIConfigInit':
afp_config.c:230: `VERSION' undeclared (first use this function)

it's a redhat-5 based setup. i recently upgraded from gcc 2.7.2 to
egcs-2.90.27 -- made no difference with this problem.

which reminds me, none of the binaries seem to be willing to cough up
what version they are -- ie 'afpd -v' just barks at you about usage. is
there any interest in adding that? is that what happened and it is
broken for my system?

---

From: Bob Rogers <[email-masked]>
Date: Thu, 22 Mar 2001 09:56:52 -0500

From: Paul Krohn <[email-masked]>
   Date: Wed, 21 Mar 2001 22:28:59 -0800

   Speaking of compile errors, i get the following . . .

The daemons all spew version information into the log when started, but
that's not very useful if you can't get to that point.  Which argues for
supporting "-v" or "--version" on the command line.

					-- Bob Rogers

---

From: Karen A Swanberg <[email-masked]>
Date: Thu, 22 Mar 2001 10:33:41 -0600 (CST)

(was O-BSD 2.8 1.5pre5 compile errors)

Greetings again;

gmake fixed the compile issues, a sincere thank you, but now my
uam/encryption libraries won't load. More details below.

on 03/21/01, Jean-Philippe Rey wisely declared:

<snip>
> vi config.h  ->   6a   #define NO_CRYPT_H 1

I tried all this, exactly as written, and with a few variations: not
making the libtool/config.h changes, compiling with and without
--with-tcp-wrappers and --with-ssl-dirs=/usr.

For every variation, this comes up in my logs when the daemons are
starting:

afpd[] uam_load(uams_guest.so): mod_symbol error
afpd[] uam_load(uams_clrtxt.so): mod_symbol error
afpd[] uam_load(uams_dhx.so): mod_symbol error

Unsuprisingly, the macs can't log in, and they get the error usually
associated with not having the most up-to-date AppleShare client, which I
got for good measure, although I know the problem is with the above
errors.

During the gmake install, the following errors occurred:

In file included from auth.c:25:
uam_auth.h:35: warning: `struct papfile' declared inside parameter list
uam_auth.h:35: warning: it's scope is only this definition or declaration,
with is probably not what you want.

the same error occurred with uam.c:25

Jean-Philippe Rey suggested not adding in the --with-tcp-wrappers during
the compile. Is this because they won't work in this beta, or does the
compile adds them in manually? I would very much like to use them. The
whole reason I'm up here on the bleeding beta edge is to use a mostly
secure version of netatalk, I have a perfectly functional version of
1.4b2+asun2.1.3, it just doesn't encrypt anything, but it does use
wrappers. If wrappers don't work now, would people recommend staying with
a wrapped / non-encrypted netatalk, or go non-wrapped / encrypted
(assuming I can get this problem ironed out)? I have no solid evidence of
sniffers on my dept. network, but I'm at a big University, and I'm
starting the migration to SSH as well, so it seems silly to insist on SSH
when my netatalk connections are cleartext.

My environment:
#pkg_info
ssl-2.7-USA
amanda-2.4.1p1
libtool-1.3.5
automake-1.4
autoconf-2.13
gettext-0.10.35
gmake-3.79.1

on OpenBSD 2.8/i386

Again, many thanks for the quick turn-around and helpful answers.

*                                                     *
Karen Swanberg              |

---

From: Jean-Philippe Rey <[email-masked]>
Date: Thu, 22 Mar 2001 18:18:08 +0100

>afpd[] uam_load(uams_dhx.so): mod_symbol error

Now that you mention it, I also encountered this problem. I solved it by adding

                  #define DLSYM_PREPEND_UNDERSCORE 1

in the config.h file, and then gmake again.

>when my netatalk connections are cleartext.

My netatalk server already resides in a protected network, so 
wrappers are not so important for me. When I saw that it won't work 
out of the box, I didn't try to make it work. But it was before I add 
the DLSYM_PREPEND_UNDERSCORE line, that may solve also the wrapper 
library problem. Give it a try.
-- 
Jean-Philippe Rey           Délégué informatique - École Centrale Paris
[email-masked]            92295 Châtenay-Malabry Cedex - France

---

From: jeff <[email-masked]>
Date: Thu, 22 Mar 2001 07:37:54 -0500

> in the config.h file, and then gmake again.

Just patched configure.in to define DLSYM_PREPEND_UNDERSCORE for
OpenBSD.

Thanks,
jeff

---

From: R Cent <[email-masked]>
Date: Fri, 23 Mar 2001 06:13:30 -0800 (PST)

Hi,

Why does the v7.0-2 Mandrake Update utility want to update
(install?) the text editor called "Joe" on my server?  I have
removed any files related to Joe and the updater still presents
it.  Thanks.

_____________________________
Bob Cent
University of Washington
Box 357330
Seattle, WA  98195-7330

mailto: [email-masked]
voice:  206.543.1433
fax:    206.685.0305
_____________________________

---

From: Karen A Swanberg <[email-masked]>
Date: Mon, 26 Mar 2001 17:29:54 -0600 (CST)

(was: O-BSD uam_load errors + wrap/encrypt?)

I too am getting the errors recently discussed under the subject "Problems
copying to shares," with the setdirowner: chown -1/0 .AppleDouble/.Parent
..." error on the BSD server, and "The Item <anyfile> cannot be
written..." on the Mac. I assume this is still an on-going problem? If so,
I'm just reporting that I get it too, and any files copied onto the BSD
server are 0K, so it's a showstopper here too. What's the status on this,
if I may ask?

Expanding on Jean-Philippe Rey's notes, to get 1.5pre5 to compile and make
on OpenBSD:

Summary
-------

gmake install

successfully compiles on OpenBSD 2.8, however there are still more issues.

When compiling with both --tcp-wrappers and -ssl, I get these errors when
starting the daemons from rc.local, and atalkd never successfully starts:

/usr/libexec/ld.so: Undefined symbol "_deny_severity" in 
atalkd:/usr/lib/libwrap.so.1.1

/usr/libexec/ld.so: Undefined symbol "_deny_severity" in
nbprgstr:/usr/lib/libwrap.so.1.1

/usr/libexec/ld.so: Undefined symbol "_deny_severity" in
timelord:/usr/lib/libwrap.so.1.1

When I compiled without tcp-wrappers, I was getting this error:
afpd[] Can't register machine:AFPServer&*

However, adding my interface, fxp0 to my atalkd.conf file fixed that
immediately. Now all of my passwords are being sent encrypted! Thank you
very much!

And finally,

Is there a particular reason that all of the executables go in SBINDIR
except nbprgstr, which goes into BINDIR? I'm happy with it there, just
curious.

System info for the curious:
ssl-2.7-USA
amanda-2.4.1p1
libtool-1.3.5
automake-1.4
autoconf-2.13
gettext-0.10.35
gmake-3.79.1

and I keep all the output  from my .configure/gmake/gmake installs if
anyone wants them to help debug the tcpwrap thing.

So, except for the showstopping setdirowner error, and something wrong
with tcp-wrappers, 1.5pre5 seems to be working well on OpenBSD 2.8.

Sincerely;

*                                                     *
Karen Swanberg              |