Subject: Files not appearing in folder on mac client

From: "Stuart Haas" <[email-masked]>
Date: Mon, 27 Aug 2001 16:54:17 -0400

Hi,

I've encountered a strange problem with files that exist on the server not
showing up on Mac clients.  Mainly this happens with Microsoft office
documents created on a PC (running SAMBA on the server).  I can view the
documents fine on the PC, but you can't see them on the Mac.

I noticed that if you look in the .AppleDouble folder, that the files that
can't be seen on the Mac, don't appear there.

I am running the Netatalk 1.5pre6rh7, AFP over TCP/IP, on Redhat 7.1, with
2.4.6 kernel.

Any suggestions?

Stuart
------------------------------
Stuart Haas
IT Director
Vibe/Spin  Ventures
212.448.7493

---

From: Nigel Pegram <[email-masked]>
Date: Tue, 28 Aug 2001 11:33:58 +1000

Are the file names greater than that allowed on the Mac? I understand that
filenames longer than 32 characters cause the files not to show up in
netatalk.

HTH
Nigel.

> From: "Stuart Haas" <[email-masked]>
> Organization: Vibe/Spin Ventures
> Date: Mon, 27 Aug 2001 16:54:17 -0400
> To: <[email-masked]>, <[email-masked]>
> Subject: Files not appearing in folder on mac client
> Resent-From: [email-masked]
> Resent-Date: Mon, 27 Aug 2001 17:06:05 -0400 (EDT)
>

---

From: Ryan McBeth <[email-masked]>
Date: Tue, 28 Aug 2001 07:15:47 -0400

Stwart,

	Is it possible that the PC people are creating files with 
longer than 32 characters in the filename?

	Are they creating files with colon's ( : ) in the filename?

	Ryan

>I am running the Netatalk 1.5pre6rh7, AFP over TCP/IP, on Redhat 7.1, with

__________________________________
Ryan McBeth
Systems Administrator, Mobius New Media
Voice: (302) 475-9880 x11
FAX: (302) 475-9894
www.mobiusnm.com
__________________________________
You can't build a reputation on what you are going to do.
  - Henry Ford

---

From: Carsten Neumann <[email-masked]>
Date: Tue, 28 Aug 2001 13:12:28 +0200

> filenames longer than 32 characters cause the files not to show up in

31 chars!
One is for the (PASCAL-)string length. ;-)

---

From: Thomas Kaiser <[email-masked]>
Date: Tue, 28 Aug 2001 14:06:36 +0200

> One is for the (PASCAL-)string length. ;-)

31 bytes. Remember that there exist doublebyte fonts too, which are limited
to 15 chars ;-)

Regards,

Thomas

---

From: "Stuart Haas" <[email-masked]>
Date: Tue, 28 Aug 2001 08:10:57 -0400

No, the test files I was creating had short file names....

----- Original Message -----
From: "Nigel Pegram" <[email-masked]>
To: "Stuart Haas" <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Monday, August 27, 2001 9:33 PM
Subject: [Netatalk-devel] Re: Files not appearing in folder on mac client

> _______________________________________________
> Netatalk-devel mailing list
> [email-masked]
> http://lists.sourceforge.net/lists/listinfo/netatalk-devel
>

---

From: Carsten Neumann <[email-masked]>
Date: Tue, 28 Aug 2001 14:50:06 +0200

> No, the test files I was creating had short file names....

Could you please give one or two example (UNIX!) file names which aren't seen from the Mac side?

Regards

	Carsten

---

From: "Stuart Haas" <[email-masked]>
Date: Tue, 28 Aug 2001 09:49:34 -0400

Problem solved - it turns out that the file names were too long.  I guess 32
characters is not that long.

Thanks for all the replies.

----- Original Message -----
From: "Nigel Pegram" <[email-masked]>
To: "Stuart Haas" <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Monday, August 27, 2001 9:33 PM
Subject: Re: Files not appearing in folder on mac client

---

From: Simon Bazley <[email-masked]>
Date: Tue, 28 Aug 2001 16:38:59 +0100

Files created with SAMBA don't create .AppleDouble files, cause they don't
have resource fork.
All the problems I had with Samba and Netatalk came down to the access rights
of the users concerned.  Check that the user trying to see the file has read
access to the file and has execute on the directory its sitting in. If they
can see other files in the same directory then the execute bit is already set,
and its probably a rights issue, so check the owner of the file.
The problem I used to get was files would be created in the editorial
directory with rw-r--r-- and owned by fred.fred and the rest of the editorial
team couldn't access it.  I got round it on the samba side by ensuring the
editorial share had "force group=+Editorial" and the global "create mask =
0664" (and "directory mask = 0775").  The + on force group means only force
people to that group if they are a member of that group already.
Sadly I couldn't get the same thing to work with netatalk so I had to set the
primary group of all of editorial to editorial, so files were created
fred.editorial and hence everoyne was happy.  Clearly that breaks if the mac
users go creating files in other shares, but I couldn't see a way to work
around that problem.  In the end if anyone found they couldn't access a file,
they'd call my office and I'd just go into where the file was and do a "chown
.editorial * -R" and "chmod g+wrX * -R".  Less than ideal, but it worked.

Simon

---

From: Harald Wagener <[email-masked]>
Date: Tue, 28 Aug 2001 18:28:56 +0200

> 0664" (and "directory mask = 0775").  The + on force group means only force

You could set the sticky bit on directories (2775 instead of 0775). all files
created in the folder then belong to the group of the folder. The sticky 
it is honored by  netatalk as well, being handled on the underlying 
(file system) layer.

Regards,
	Harald
-- 
Harald Wagener      |                                Systemadministrator 
FCB/Wilkens GmbH    |                              Tel.:+49-40-2881-1252 
An der Alster 42    |                              Fax.:+49-40-2881-1263 
20099 Hamburg       |                         http://www.fcb-wilkens.com

---

From: Tom Fitzgerald <[email-masked]>
Date: Tue, 28 Aug 2001 12:55:25 -0400

> it is honored by  netatalk as well, being handled on the underlying 

Not to be pedantic or anything, but 2xxx is the setgid bit.  It's still
what you want.  The sticky bit is 1xxx and does something else.

---

From: "A. Lester Burke" <[email-masked]>
Date: Tue, 28 Aug 2001 15:07:23 -0400

Hello,
I need some help,
I have netatalk running on FreeBSD The volume is set to mount via IP
when a user logs in. via Macintosh Manager
It was working yesterday.  Today when I login to my ASIP server, the
Netatalk volume will not mount.

I can get to the server via Appleshare IP with no problem

the messages log reports the following errors :
dsi_stream_read(-1)
dsi_stream_write: Broken pipe
afp_openfork: ad_open: Permission denied
afp_alarm: Chilled timed out

Anybody have any idea what is happening to my netatalk box ?  What would
have changed.
--
A. Lester Burke
Network Analyst
Arlington Public Schools, VA
V 703-228-6057
E [email-masked]

---

From: "A. Lester Burke" <[email-masked]>
Date: Tue, 28 Aug 2001 18:29:56 -0400

I need to have a bunch of users 75 mount and access a volume on a
Netatalk box.  Is this possible to do.. say have everybody login as the
same user? If yes where do I make that change ?

Thanks

---

From: Vic Landi <[email-masked]>
Date: Wed, 29 Aug 2001 08:15:46 -0400

We do this here and it seems to work fine (as long as you have your users
set high enough in your config file)

There are a few drawbacks -

1) All the folder settings are common to all users

(from the mac one user opens a folder, sorts it by list and then starts
flipping the arrows on the directories to see the folder contents, the next
person to connect will see this mess)

2) Anything that is put in the trash can will be deleted if another user
empties their trash

Vic Landi

> From: "A. Lester Burke" <[email-masked]>
> Organization: Arlington Public Schools
> Reply-To: [email-masked]
> Date: Tue, 28 Aug 2001 18:29:56 -0400
> To: [email-masked]
> Subject: multiple logins under the same user name
> Resent-Date: Tue, 28 Aug 2001 18:35:52 -0400 (EDT)
>