Subject: Netatalk 1.5 Release Candidate 2

From: Sebastian Rittau <[email-masked]>
Date: Wed, 19 Dec 2001 07:12:55 +0100

The second release candidate to Netatalk 1.5 is now available at
http://me.in-berlin.de/~jroger/netatalk/netatalk-1.5rc2.tar.gz, and
hopefully also at SourceForge, soon. Its changes to RC1 are minimal and
so we hope to be able to release a final 1.5.0 soon:

* This release does now contain a NEWS file, which lists the
  changes since the last release. These changes are:

* FIX: contrib/shell_utils/lp2pap.sh was erased when "make clean" was called.
       Now we distribute lp2pap.sh.tmpl instead, and lp2pap.sh is automatically
       generated during package build.
* FIX: Some platforms (notably Tru64) don't have the snprintf() call, which
       was used in etc/afp/afp_config.c. This call was replaced by sprintf()
       and prior bounds checking.

BTW: We should think about the text for the final announcement. Please send
your brainstorming notes to [email-masked].

 - Sebastian

---

From: Joe Clarke <[email-masked]>
Date: 19 Dec 2001 01:24:19 -0500

> your brainstorming notes to [email-masked].

How about:

Sunday! Sunaday! Sunday!  One day only: Netatalk 1.5 RELEASE!

Too over-the-top?

Joe

> 
>  - Sebastian
> 
> 
> _______________________________________________
> Netatalk-devel mailing list
> [email-masked]
> https://lists.sourceforge.net/lists/listinfo/netatalk-devel
>

---

From: Thomas Baumann <[email-masked]>
Date: Wed, 19 Dec 2001 07:32:10 +0100

Can you please update your description for
sending messages, when compiled with --with-msg-dir
option ? When I have a message in my /msgdir/message 
and kill the PID of my logged in user with e.g.
kill -SIGUSR2 4711 I got only the message \"The Server
has closed its connection\", but this was not the
text of my /msgdir/message file.

Thanks to all

Maybe sb. has ha solution or a hint.

I Use Mac OS 9.0.4 and Netatalk 1.5pre6

thomas

Zitiere Sebastian Rittau <[email-masked]>:

> 
>
> > ----------
> > From: 	Sebastian Rittau[SMTP:[email-masked]
BERLIN.DE]
> > Sent: 	Wednesday, December 19, 2001 7:12:55 AM
> > To: 	[email-masked]; 
[email-masked]
> > Subject: 	Netatalk 1.5 Release Candidate 2
> > Auto forwarded by a Rule
> >
> * FIX: contrib/shell_utils/lp2pap.sh was erased 
when \"make clean\" was
> called.
>        Now we distribute lp2pap.sh.tmpl instead, and 
lp2pap.sh is
> automatically
> * FIX: Some platforms (notably Tru64) don\'t have the 
snprintf() call, which
>        was used in etc/afp/afp_config.c. This call 
was replaced by
> sprintf()

------------------------------------------------------
                            T h o m a s  B a u m a n n
                                     Postfach 11 01 15
[email-masked]                          D-64216 Darmstadt
Tel. 07000 6646466  Fax 070000 329329 (= 070000 FAXFAX)
------------------------------------------------------

-----------------------------------------------------
This mail sent through IMP: http://web.horde.org/imp/

---

From: Joe Clarke <[email-masked]>
Date: 19 Dec 2001 01:38:06 -0500

> text of my /msgdir/message file.

This option has been replaced with:

--with-message-dir=PATH

This is seen by doing a ./configure --help.  I will update doc/INSTALL
et al to reflect this.  Thanks for the heads-up.

Joe

---

From: Fred Jensen <[email-masked]>
Date: Thu, 20 Dec 2001 10:57:31 -0500

Just a note to advise that there seems to be a minor install glitch on RedHat...

System: RedHat 7.1 (Linux version 2.4.7-10)
CPU: Intel Pentium III (Coppermine)
Netatalk: netatalk-1.5rc2

Installed netatalk-1.5rc2.tar.gz from http://me.in-berlin.de/~jroger/netatalk/

./configure --prefix=/usr/local/netatalk --with-did=last --with-shadow
--with-pam=/etc/pam.d  --with-flock-locks --enable-redhat --with-uams-path=/etc/atalk/uams
make
make install

tail /var/log/messages
 Dec 20 11:22:46 adm afpd[6231]: uam: uams_dhx.so loaded
 Dec 20 11:22:46 adm afpd[6231]: uam: "DHCAST128" available
 Dec 20 11:22:46 adm afpd[6231]: uam: "Cleartxt Passwrd" available
 Dec 20 11:22:54 adm afpd[6234]: session from 65293.7:246 on 65280.42:129
 Dec 20 11:22:54 adm afpd[6234]: dhx login: fredj
 Dec 20 11:22:54 adm afpd[6234]: uams_dhx_pam.c :PAM: PAM_Error:
Authentication failure -- No such file or directory
 Dec 20 11:23:01 adm afpd[6235]: session from 65293.7:246 on 65280.42:130
 Dec 20 11:23:01 adm afpd[6235]: dhx login: gps
 Dec 20 11:23:01 adm afpd[6235]: uams_dhx_pam.c :PAM: PAM_Error:
Authentication failure -- No such file or directory
 Dec 20 11:23:04 adm afpd[6234]: atp_rresp: Connection timed out

On investigation, it appears that the netatalk pam file gets installed
as /etc/pam.d/etc/pam.d/netatalk instead of just /etc/pam.d/netatalk. I
added a symlink...

ln -s /etc/pam.d/etc/pam.d/netatalk /etc/pam.d/netatalk

And everything works. I wonder if it would have worked if I set the
configure as '--with-pam=/' ?