Subject: printing problems: 'lp_open failed' error

From: Matt Lynch <[email-masked]>
Date: Thu, 19 Jul 2001 18:04:05 +0100

Hi,

I know this problem has been discussed before on netatalk-admins but having
tried every suggestion I'm still getting the follow message in my log when I
try and print from an iMac (running OS9.1) to a HP Laserjet 1200 installed
as a local printer on the linux server (running redhat 7.1 and
netatalk-1.5pre6-1rh7):

papd[27358]: child 27371 for "HPLJ1200" from 65338.250
papd[27371]: lp_init: lock: No such file or directory
papd[27371]: lp_open failed
papd[27358]: child 27371 done

The iMac simply returns a "Postscript error" message.

My papd.conf is as follows:

HPLJ1200:\
:pr=|/usr/bin/lpr -Plp:\
        :op=root:pd=/etc/atalk/HP1200PS.PPD:

and /etc/printcap is:

lp:\
        :sh:\
        :ml=0:\
        :mx=0:\
        :sd=/var/spool/lpd/lp:\
        :lp=/dev/lp0:\
        :lpd_bounce=true:\
        :if=/usr/share/printconf/mf_wrapper:

Any suggestions for what could be the source of the problem?

Apologies if I'm missing something obvious.

-Matt Lynch

---

From: Carsten Neumann <[email-masked]>
Date: Thu, 19 Jul 2001 21:53:39 +0200

> Apologies if I'm missing something obvious.

Can you print locally from your linux server via `lpr'?

Kind regards

	Carsten

---

From: Matthew Lynch <[email-masked]>
Date: Thu, 19 Jul 2001 23:31:19 +0100

On Thursday, July 19, 2001, at 08:53 PM, Carsten Neumann wrote:

>> tried every suggestion I'm still getting the following message in my 
>> log when I
Yes, (un)fortunately I can. Is there anything else that could be the 
problem? When I tried printing direct (i.e. with 'pr=lp' in papd.conf) 
the same error occurred.
-Matt