Subject: RE: Mac OS X and netatalk...

From: "Temple, Matthew H." <[email-masked]>
Date: Tue, 3 Apr 2001 21:52:09 -0400

All,

Once upon a time in a land far away,  Apple and Digital Equipment actually
worked together to port a genuine appletalk stack for VMS/Ultix/Dec Unix.  I
think
Sun was in on this too.
Unfortunately, after that product became Pacer software it  was bought by a
cannibal company and later destroyed.   CAP and Netatalk have done quite well
up to this point, but a little help/cooperation with/from Apple would be handy.
I suppose that since they've got their own Unix product right now, they
probably won't be pushing hard to insinuate themselve into the netatalk world.
>From their unwillingness to port to Intel, etc., you see how they studiously
avoid having a larger market share unless it just can't be avoided.

						mht

-----Original Message-----
From: QUIGLEY,JASON (HP-Spain,ex1)
To: Lorenzo Perone
Cc: [email-masked]
Sent: 4/3/01 7:23 PM
Subject: Re: Mac OS X and netatalk...

Hi Lorenzo!

A little late perhaps, I have been rebuilding my work system and mail 
archives (Beta 2 trashed the hard disk type problems!!).

Anyway, the option you should be trying is: -DUSE_FLOCK_LOCKS

I tried this for myself but didn't get much joy. It's been mentioned 
that it's the client's fault or the server's fault but I've got my test 
system running with netatalk-1.4b2+asun2.1.3_1 - just barely. I'm 
getting the usual permissions crap with directories. Compiling the 
asun2.1.4 versions is broken under FreeBSD. The pre series on source 
forge is broken (compiles okay) with 10 - unexpected shutdowns. I'm 
going to try and run 2 sets of servers - the pre series for 9- machines 
and the one that barely works for 10+ machines binding to different 
addresses to see if this is a solution.

I think the general impression that I get is that nobody really has a 
clue what's at fault and as the jocks on source forge don't really care 
too much about anything other Linux, those of us who like to run stable 
setups are in for a long wait for a resolution.

Does anybody know if Apple is interested in supporting anything other 
the Mac OS X Server or Appleshare IP? It would be nice to know what 
changes are going on in the client side, at least.

Sorry if I sound pissed off, but I have tried to compile, or have 
compiled (into the wee hours) every version of netatalk that I could get

my hands on and every one has a different set of problems. I think the 
frustration is starting to get to me!!

Cheers,
Jason.

On Saturday, March 31, 2001, at 10:47  am, Lorenzo Perone wrote:

> Hi fellow neta-admins,
>
> I've been 'going down deep' into the OSX/netatalk adventure ;-)
>
> I've tried the -DFLOCKS (adding it to the DEFS line - correct?) thing 
> and pre-asun2.1.4-38b_test.
> No success, I get -43 and -37 errors _everywhere_  (uploading and 
> downloading) - looks like an .AppleDouble problem? (thought they were 
> related to resources, those errors).
> But the same dirs used to work perfectly with pre3m (I'll check
thisone 
> out, anyway!).
>
> With pre-asun2.1.4-37b it got better:
> Mounts OK, downloads and gives the -43 error only on some files.
> But then, after throwing one copied folder to the trash, when trying
to 
> empty it, I get a message with 'not enough privileges to perform 
> operation'.
> Weird enough: I got into the terminal, su-rooted (with an enabled root

> account, via NetInfoManager).
> This is what I got when I tried to rm the stuff in
/Users/lopez/.Trash:
>
> override rwx------  lopez/staff for 
> 6100's/Preferences/UMAX/VistaScan/Viewer Files/BRI4.JPG? y
> rm: 6100's/Preferences/UMAX/VistaScan/Viewer Files/BRI4.JPG: Operation

> not permitted
>
> I tried to chmod 660 all the stuff in there:
>
> root# chmod -R 660 *
> chmod: 6100's//Preferences/UMAX/VistaScan/Viewer Files/Y9.JPG: 
> Operation not permitted
> sort of weird! How can I get rid of that stuff now??
>
> it could well be that it's the names of that folder I tried with,
which 
> contain 'Preferences' and other strange mac chars. Anyway, an ls -la
in 
> the undeletable folder items gives:
>
> -rwx------    1 lopez  staff    6988 May 27  1998 Y5_4.JPG
> -rwx------    1 lopez  staff    6940 May 27  1998 Y5_5.JPG
> ....
>
> After testing with other folders, things looked much better, but I 
> still get
> - unsufficient privileges
> - an item with the name 'Icon' already exists
> - some other errors
>
> but with other dirs I did not have the trashing-permission 
> problem........
>
> ....at least, I got to mount the volumes on Mac OS X 10.0.0, which I 
> never got to work with netatalk 1.4.99 and sourceforge-successors.
> I'd be glad if someone has a solution...... anyway, I'm sure as soon
as 
> rufustfirefly or asun or anybody else involved will get to reproduce 
> the problems, they'll be solved.
> Damned...... I'd really like to start using OSX now, despite it being 
> some kind of  'Beta 2'.
> I tried hard, with all versions of netatalk I could find. I'm not a C 
> programmer, just a web developer, and sysadmin.
> I compiled mostly on LinuxPPC (cause there I have our most important 
> files).
>
>
> :-(
>
>
>
> Allright, now I'll reboot into macos9, and since it worked so well
with 
> OS9, switch back to 1.5pre3........
>
> Lorenzo
>
> p.s.
>
> here's a list of my experiments....... if it can be useful to anybody,

> anyway. I mean, it can be a reference only to those that see matching 
> experiences in at least 2 cases ;)
>
> === 1.4b2+asun2.1.3: ===
>
> Same experience with the following OSes:
>
> SuSE Linux 6.3/Intel:
> SuSE Linux 7.0/Intel
> SuSE Linux 7.0/PPC
> LinuxPPC 2000 Q4
>
> - distri standard;
> - works with OS9, slow. resource, ownership, ID related problems on
OS9;
> - OSX client connects and mounts, but plenty of problems when opening
/ 
> editing files;
>
> === netatalk-pre-asun2.1.4-38b_test ===
>
> LinuxPPC 2000 Q4
>
> - works with OS9, FAST. seems OK on OS9, but I'd have to make more 
> tests, no time now.
> - OSX client connects and mounts, but -43 and -37 errors EVERYWHERE, 
> also with files without resources or type/creators;
>
> === netatalk-pre-asun2.1.4-37b===
>
> LinuxPPC 2000 Q4
>
> - OS9 not tested yet
> - OSX client connects and mounts, but -43 and -37 errors when copying,

> but only on some files.
> - When putting things of SOME folders to the trash (looks like folder 
> name problems!), can't empty trash 'not enough privileges'
> - otherwise _very fast_ on OSX, also on many folders and files!
>
> === netatalk-1.4.99-0.20001108 ===
>
> SuSE Linux 6.3/Intel:
> - works with OS9; fast. alias problems;
> - OSX clients get disconnected immediately after share choice;
>
> LinuxPPC 2000 Q4:
> - compiled but didn't work: disconnect upon file share choice with
OS9.
>
>
> === netatalk-1.5pre3 ===
>
> SuSE Linux 6.3/Intel:
> - works with OS9; fast. folder alias problems;
> - OSX clients get disconnected immediately after share choice; slow 
> sherlock name searches;
> - best choice for me now (production).
>
> SuSE Linux 7.0/Intel
> - works with OS9; fast. folder alias problems;
> - OSX clients get disconnected immediately after share choice; slow 
> sherlock name searches;
> - best choice for me now (production).
>
> LinuxPPC 2000 Q4
> - configure-related problems (setpgrp...), 'commented' out to get
ahead.
> - works with OS9; fast. folder alias problems; extremely slow sherlock

> name searches;
> - OSX clients get disconnected immediately after share choice;
> - best choice for me now (production).
>
> === netatalk-1.5pre4 ===
>
> LinuxPPC 2000 Q4
> - compiled but didn't work: disconnect upon file share choice with OS9

> (same problem as with OSX).
>
> SuSE Linux 6.3/Intel:
> - problems compiling
>
> === netatalk-1.5pre5 ===
>
> LinuxPPC 2000 Q4
> - configure-related problems (can not check if setpgrp is cross 
> compiling...), 'commented' out some configure lines to get ahead.
> - suspicious messages when making
> - install problems: codepages not found? had to get them from an older

> /etc/atalk file
> - after a few hours of work, when i came back and netatalk had
crashed.
> - switched back to pre3
>
> .....
>
> :-|
>
> p.p.s.
>
> I like thisone quite a bit. It' s just about almost everything:
>
>> ========================================================
>>
>> "Always ask the question, never assume the answer."
>> 		Marcus Radich 1999
>>
>> ========================================================
>
> assuming is a bad habit......
> difficult to give up, in some cases, too......
> (it always gives the illusion to be effective - especially in 
> programming issues)
>
> ;-)
>
>
> Lorenzo
>
>
>
> At 12:09 Uhr +1200 29.03.2001, Marcus Radich wrote:
>> OK, I originally found that asun2.1.3 was wicked for serving quark 
>> dox, but when I updated to 214, I started having file locking
problems 
>> with quark (typical). Also seems to happen with codewarrior(noted by
a 
>> friend).
>> So after reading through asun's notes, I found a section which refers

>> to the "old style" of byte locking. Adding the DEF= line and 
>> recompiling works perfectly. I have over 20 servers in production 
>> proving that!
>>
>> Go to: ftp://ftp.cobaltnet.com/pub/users/asun/testing/  if you need
it.
>>
>> I'm currently running MacOS X 4L5 (10.0.1), which BTW is quite a bit 
>> snappier than 4K78 (10.0.0), and connecting to these servers shows no

>> issues. Confirmed and tested!
>>
>> (Also, for those "Mac OS X is too slow" people. Get 10.0.1 when it 
>> comes out (soon), and get Plus for X. It allows you to change Genie
to 
>> scale and other less-CPU-intensive things. Look on versiontracker for

>> a link to this)
>>
>> I still use 1.4b2+asun214-37b because it works. I think I will start 
>> experimenting with 1.5 soon.
>>
>> mrad01
>>
>>
>> At 12:08 PM -0500 28/3/2001, Steven Karel wrote:
>>> 1. Just wanted to concur with Marcus that 
>>> netatalk-1.4b2+asun2.1.4-pre37b
>>> works fine with the appleshare client in OS X 10.0,.whereas the
public
>>> beta failed horribly . Not all versions of netatalk are that well 
>>> behaved,
>>> however. I haven't tested exhaustively, but I do know that 37b works

>>> on at
>>> least 4 of our servers (RH 6.2/RH 7.0). Also, the old version 
>>> 1.4b2-2.1.3
>>> seems to work as well.
>>>
>>> 2. Setting -DUSE_FLOCK_LOCKS doesn't seem to be necessary for this
>>> purpose, although it may help with file locking for other reasons. 
>>> Marcus,
>>> if you could be so kind, can you explain for us again what problems
it
>>> solves, and where exactly you recommend setting it? (I added
>>> -DUSE_FLOCK_LOCKS in the sys/linux/Makefile DEFS= line)
>>>
>>> README.ASUN says:
>>>
>>>
>>> 	byte locks should now work. if you want to enable the old way
>>>        of doing things, add -DUSE_FLOCK_LOCKS.
>>>
>>>
>>>
>>> thanks,
>>>
>>> stevne
>>>
>>> On Wed, 28
>>> Mar 2001, Marcus Radich wrote:
>>>
>>>>
>>>> BTW, netatalk 1.4b2+asun 214 -37b works very well with Mac OS X as
>>>> long as you add the DEFS= -DFLOCKS thingy to the sys/Linux/Makefile
>>>> before you compile. I haven't tried 1.5. You can only connect via
IP
>>>> (great!) and transferring files large and small has worked for me
>>>> since 4K46
>>>>
>>>> mrad01
>>>>
>>
>>
>>
>> --
>> ========================================================
>>
>> "Always ask the question, never assume the answer."
>> 		Marcus Radich 1999
>>
>> ========================================================
>

---

From: Leland Wallace <[email-masked]>
Date: Thu, 5 Apr 2001 13:53:58 -0700

Folks,
   No need to be cynical, Apple has been and will keep helping the 
netatalk
project. I and my engineers have been in communication with Adrian, and
other folks from the sourceforge effort. I have had no directives from my
management to the contrary. At least one of the problems with copying 
from
the Mac OS X client is related to the behavior of the CloseFork call. 
The other
is with advertising a 4Gig (maxint) buffer size in the options 
negotiation
(we fixed our end for GM).

One thing that you can be sure of, the Mac OS X client is a complete 
rewrite
and as such the patterns of calls will be different.

Hope this helps
Leland Wallace
AppleShare Client Lead

+-----------------------------------------------------------------------------------
Leland Wallace           Working in            AppleShare Engineering
[email-masked]    but not speaking for     Apple Computer Inc.
http://www2.inow.com/~randall
+-----------------------------------------------------------------------------------