Subject: atalkd doesn't start anymore

From: Carsten Neumann <[email-masked]>
Date: Mon, 10 Dec 2001 19:33:47 +0100

Hi all,

I've been successfully using netatalk 1.5pre6.
Now I tried the latest CVS versions and
http://www.marcuscom.com/netatalk/cnid/netatalk-1.5cnid.tar.gz

They all led to the following error at netatalk startup:
  Starting atalkd:AppleTalk not up! Check your syslog for the reason. Child died.

In my /var/log/messages are no errors logged.

When I start 1.5pre6 all is fine again.
I also tested the 1.5pre8 tarball: is also OK.

My CNID configuration is
./configure \
        --prefix=/usr/local \
        --enable-timelord \
        --with-shadow \
        --enable-suse \
        --with-config-dir=/etc \
        --with-pkgconfdir=/usr/local/etc/netatalk \
        --mandir=/usr/local/share/man \
        --with-did=cnid \
        --with-db3=/usr/local/BerkeleyDB.3.3

I've also added a --enable-debug: still no errors in any logs.

Could someone please give me a hint what could be wrong?

Thank you

	Carsten

BTW: It would be fine if the default man directory would be PREFIX/share/man instead of PREFIX/man
for FHS compatibility.

---

From: Sebastian Rittau <[email-masked]>
Date: Mon, 10 Dec 2001 21:55:10 +0100

> BTW: It would be fine if the default man directory would be PREFIX/share/man instead of PREFIX/man

Please use the --enable-fhs configure option.

 - Sebastian

---

From: Carsten Neumann <[email-masked]>
Date: Mon, 10 Dec 2001 23:39:43 +0100

> Please use the --enable-fhs configure option.

That didn't help! - At least for the CVS stuff.
Does this work for you?

	Carsten

---

From: Sebastian Rittau <[email-masked]>
Date: Tue, 11 Dec 2001 01:22:32 +0100

> That didn't help! - At least for the CVS stuff.

Yeach... I should at least have looked into configure.in:

  dnl FIXME: NEED TO HAVE --mandir=/usr/share/man AT SOME POINT...

Nevertheless --mandir=/usr/share/man should do the trick for now.
/usr/man is the default for autoconf, it seems, and I am very reluctant
to change autoconf defaults when no configure option (like --enable-fhs
or --mandir) is given.

I will change --enable-fhs to default to /usr/share/man, though.

 - Sebastian