Subject: Can not share a disk between 2 networks

From: Toni Anzlovar <[email-masked]>
Date: Thu, 18 Oct 2001 11:07:24 +0200 (CEST)

Hello, netatalk admins!

I have come across a slight problem, that might be easy to solve, but I have been stabbing in the dark for a week now.

I am using 1.4b2+asun2.1.3 on Some antient mandrake distribution. I have 2 fully operational and configured NICs.
In atalk.conf I am bringing up 2 nics with -seed. Obviously none of the networks have any routers, so I let the -seed take care of everything.
When afpd starts (afpd.conf has only 1 entry in it) it starts services ONLY on the second card. If I put eth1 before eth0 in atalk.conf, it iwll of course work on eth0. If eth0 is first and eth1 second, the eth1 will advertise the machine in afpd.conf.

One more interesting thing. If I do nbplkup after atalk is up, I only get the machines, connected to the NIC listed last in the atalk.conf. If I try to nbplkup network during the atalk restart, I will briefly see the network from the first card, then it will be completely replaced by the second card's connections.

This is the log:

Oct 18 09:31:06 dexter kernel: NET4: AppleTalk 0.18 for Linux NET4.0
Oct 18 09:31:06 dexter atalkd[787]: restart (1.4b2+asun2.1.3)
Oct 18 09:31:08 dexter atalkd[787]: zip_getnetinfo for eth1
Oct 18 09:31:26 dexter last message repeated 2 times
Oct 18 09:31:36 dexter atalkd[787]: as_timer configured eth1 phase 2 from seed
Oct 18 09:31:37 dexter atalkd[787]: zip_getnetinfo for eth0
Oct 18 09:31:46 dexter last message repeated 2 times
Oct 18 09:31:56 dexter atalkd[787]: as_timer configured eth0 phase 2 from seed
Oct 18 09:31:56 dexter atalkd[787]: ready 0/0/0
Oct 18 09:31:57 dexter atalk: atalkd startup succeeded
Oct 18 09:32:09 dexter atalk: afpd startup succeeded
Oct 18 09:32:15 dexter afpd[799]: 1111:AFPServer@* started on 65280.36:128 (1.4b2+asun2.1.3)

Can I getc 1111 running on 65280.119 (which is on eth1) as well as 65280.36?

Thanx for any info.

__
BP Toni

__
BP Toni
_________________________________________________________________
SkavtNET Slovenia - http://www.skavt.net - http://zskss.skavt.net
                         Ekipa SkavtNETa - http://ekipa.skavt.net

---

From: Alistair Riddell <[email-masked]>
Date: Thu, 18 Oct 2001 12:48:21 +0100 (BST)

Perhaps you should post your atalkd.conf...

If there are no other routers on the network then you will and you want to
seed the two interfaces properly then I think you'll have to fully specify
each interface in atalkd.conf. i.e. have a -net statement for each
interface.

-- 
Alistair Riddell - BOFH
IT Manager, George Watson's College, Edinburgh
Tel: +44 131 446 6070    Fax: +44 131 452 8594
Microsoft - because god hates us