Subject: HELP please ! !

From: marco a <[email-masked]>
Date: Wed, 14 Mar 2001 17:09:53 -0500

I've posted this last week, perhaps there was no enough traffic on the
list
scuse me if redundant...
+++++++++++++++++++++++
Hi,
i just put eth1 in my atalkd.conf file, i have eth0 plugged on the
external network and eth1 on the internal one,
with 2 macs (g3-macOS9.1, g4-macOS9.1) and the linuxbox with
netatalk-1.4b2+asun2.1.3-22 installed
I start atalkd... 10'' and the name "laptop" appears in the chooser, i
can connect to the linux box, good !
20'' later when i relaunch the chooser for any reason, there is no
"laptop" in the chooser, and the led is flashing continuously,
I can connect with it just by the ip number
When I to stop here is the message:
[
root@laptop init.d]# ./atalk stop
Shutting down AppleTalk services: Can't unregister laptop:Workstation@*
Can't unregister laptop:netatalk@*
appletalk: Device or resource busy

the atalkd.conf was filled by herself :
eth1 -phase 2 -net 65280-65534 addr 65280.0

ifconfig gives :

[root@laptop init.d]# /sbin/ifconfig
eth0      Link encap:Ethernet  HWaddr 00:10:4B:DE:57:84
          inet addr:24.201.28.100  Bcast:24.201.28.255
Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:38833 errors:0 dropped:0 overruns:0 frame:0
          TX packets:48214 errors:0 dropped:0 overruns:0 carrier:0
          collisions:58

eth1      Link encap:Ethernet  HWaddr 00:E0:98:83:CF:F1
          inet addr:192.168.0.1  Bcast:192.168.0.255  Mask:255.255.255.0

          EtherTalk Phase 2 addr:65310/136
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:298361 errors:0 dropped:0 overruns:0 frame:673
          TX packets:282057 errors:0 dropped:0 overruns:0 carrier:0
          collisions:357

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          EtherTalk Phase 2 addr:0/0
          UP LOOPBACK RUNNING  MTU:3924  Metric:1
          RX packets:382 errors:0 dropped:0 overruns:0 frame:0
          TX packets:382 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0

could you diagnose something doctor ??
or point me on a new way to do ?
thanks

---

From: C <[email-masked]>
Date: Wed, 14 Mar 2001 18:05:41 -0600

> I've posted this last week, perhaps there was no enough traffic on the
<snip>
> or point me on a new way to do ?

If you are using a laptop, then I'm assuming you are using PCMCIA cards for
networking. I think I remember reading some place that in order for the
AppleTalk protocol to work correctly on some NICS, you had to turn on
promiscous mode on that eth interface.

-- 
C.