Subject: netatalk with Solaris 8

From: Matthew Hallam <[email-masked]>
Date: Thu, 08 Nov 2001 17:27:02 +0000

Hello all.

Im trying put in place a Solaris 8 box with netatalk-1.5pre8 and have 
come to a halt. Ive got it compiled and installed ok.. but it doesnt 
seem to be working (!).. ie it doesnt up in the apple's chooser, and when
you do a nbplkup, none of the other macs (or indeed the other netatalk 
server we're running) show up - just the local machine (they are all on 
the same subnet).

The messages file looks like this:

Nov  8 10:02:28 barage atalkd[522]: [ID 602610 daemon.info] restart (1.5pre7)
Nov  8 10:02:28 borage atalkd[522]: [ID 430690 daemon.info] setsockopt incompatible w/ Solaris STREAMS module.
Nov  8 10:02:30 barage last message repeated 1 time
Nov  8 10:02:30 barage atalkd[522]: [ID 875075 daemon.info] zip_getnetinfo for le0
Nov  8 10:02:48 barage last message repeated 2 times
Nov  8 10:02:58 barage atalkd[522]: [ID 882285 daemon.info] as_timer configured le0 phase 2 from seed
Nov  8 10:02:58 barage atalkd[522]: [ID 128247 daemon.info] ready 0/0/0
Nov  8 10:03:12 barage afpd[534]: [ID 950474 daemon.info] ASIP started on x.
x.x.x:548(1) (1.5pre7)
Nov  8 10:03:12 barage afpd[534]: [ID 526081 daemon.info] uam: uam not found (status=-1)

modinfo shows the ddp device has loaded ok:

 88 f619a000   3be5  54   1  ddp (DDP Streams device)
 88 f619a000   3be5  19   1  ddp (DDP Streams module)

i have added :

  ddp        tpi_clts      -    appletalk ddp   /dev/ddp        -

to /etc/netconfig

The interesting thing is if I truss the startup of atalkd, i gives a 
load of EAFNOSUPPORT errors, as in :

  so_socket(16, 1, 0, "", 1)                      Err#124 EAFNOSUPPORT

Anyone any ideas?

cheers
Matt

---

From: Matthew Keller <[email-masked]>
Date: 08 Nov 2001 13:08:32 -0500

Try going to the server manually by using the "Server Address" option
in the chooser, and typing in the IP address. I suspect it's a DDP
problem, not Netatalk.

-- 

Matthew Keller
Enterprise System Analyst
Computing & Technology Services
Information Services Division
State University of NY at Potsdam
Potsdam, NY USA

http://mattwork.potsdam.edu/