Subject: max number of concurrent connections

From: "A. Lester Burke" <[email-masked]>
Date: Wed, 29 Aug 2001 08:57:09 -0400

Under the Linux configuration of Netatalk there is a file called config
that allows for the setting of the maximum number of clients that can
connect at one time.

Where is the equivalent parameter set in FreeBSD 4.3.

Thank You

--
A. Lester Burke
Network Analyst
Arlington Public Schools, VA
V 703-228-6057
E [email-masked]

---

From: Benjamin Boksa <[email-masked]>
Date: Wed, 29 Aug 2001 15:10:51 +0200

Hi Lester!

I don't know much about Netatalk with FreeBSD, but I know that there is the
possibility to start afpd with the max number of clients:

/usr/sbin/afpd -c 10

Will start Netatalk with 10 possible concurrent clients.

I hope this information helps you.

Regards,

Benjamin Boksa

---

From: Jason Quigley <[email-masked]>
Date: Wed, 29 Aug 2001 15:17:13 +0200

/usr/local/etc/netatalk.conf (I'm using the cvs version, but the ports one
should be the same)

Cheers,
Jason.

---

From: Fred Condo <[email-masked]>
Date: Wed, 29 Aug 2001 08:54:57 -0700

> Where is the equivalent parameter set in FreeBSD 4.3.

Assuming you have used the ports mechanism to install netatalk, apply
this patch to /usr/local/etc/rc.d/netatalk.sh:

--- netatalk.sh.old	Wed Aug 29 08:47:50 2001
+++ /usr/local/etc/rc.d/netatalk.sh	Wed Aug 29 08:48:34 2001
@@ -19,7 +19,8 @@
 	/usr/local/bin/nbprgstr -p 4 ${HOSTNAME}:netatalk &
 	/usr/local/sbin/papd
 	/usr/local/sbin/afpd -s /usr/local/etc/AppleVolumes.system \
-		-f /usr/local/etc/AppleVolumes.default
+		-f /usr/local/etc/AppleVolumes.default \
+		-c 36
 	;;
 stop)
 	killall afpd

Next, do these commands:

# /usr/local/etc/rc.d/netatalk.sh stop
# /usr/local/etc/rc.d/netatalk.sh start

The number after -c is the maximum number of connections, so adjust it
to suit your requirements.

---

From: Carsten Neumann <[email-masked]>
Date: Wed, 29 Aug 2001 22:26:27 +0200

> that allows for the setting of the maximum number of clients that can

Actually, under linux there is NO file called "config".
(Of all versions of netatalk I know: 1.4b2+asun, 1.5pre{5,6})

There are four configuration files:

afpd.conf
atalkd.conf
netatalk.conf
papd.conf

usually found under /etc/atalk.

I think there is no specific limitation on the number of clients,
but you can set the maximum number of AFP (AppleShare) clients in afpd.conf:

AFPD_MAX_CLIENTS=20

sets this to 20 ;-)

I think you can't change the maximum number of clients of other protocols (e.g. PAP,NBP,ZIP).

> Where is the equivalent parameter set in FreeBSD 4.3.

The names/path should be equal/similar.

> Thank You

Kind regards

	Carsten