Subject: Large Volumes

From: Edward Plese <[email-masked]>
Date: Thu, 25 Jan 2001 11:55:34 -0800 (PST)

How well does netatalk handle large volumes, many
files, and many clients?  Would netatalk have any
problems with 40GB of data in 350,000 files on a
single volume with simultaneous connectinos from 300
client Macintosh computers?  I am new to netatalk and
have only done testing on a small scale, so any info
would be greatly appreciated.

Thanks,
Ed Plese
[email-masked]

__________________________________________________
Do You Yahoo!?
Yahoo! Auctions - Buy the things you want at great prices. 
http://auctions.yahoo.com/

---

From: Matthew Keller <[email-masked]>
Date: Thu, 25 Jan 2001 15:25:01 -0500

The main issues with Netatalk under these situations aren't Netatalk's
problem, rather it's the client's problem. Mac's, in general, have
issues displaying folders that contain a large number of files/folders.
If you organize the file structure properly, the below requirements are
trivial- I have environments that are much more demanding. However if
you throw those 350,000 files in the root of that volume, your clients
will choke... Miserably.
	Tip: RAID0/1 RAID0/1 RAID0/1

-- 

 Matthew Keller
 WebMaster, Interim Network Manager & 
   Host Systems Analyst
 Computing & Technology Services
 Information Services Division
 State University of New York at Potsdam
 
 Website: http://mattwork.potsdam.edu/
 PGP: http://mattwork.potsdam.edu/crypto/