Subject: RE: Solaris build

From: [email-masked]
Date: Tue, 27 Nov 2001 15:35:29 -0800

I'm looking at the same problem - did you build with gcc or Sun C?  It
appears that someone got rid of all the <#include strings.h> in the Solaris
code, which works okay with Sun C, but appears to be a BIG problem with GCC,
and one of the reasons we are having so much trouble with the build on
Solaris 8, 64-bit problems aside. Every call to bcopy spews out a bunch of
error messages!

> ----------
> From: 	Lance Levsen
> Sent: 	Tuesday, November 27, 2001 1:48 PM
> To: 	netatalk-admins
> Subject: 	Solaris build
> 
> Hey folks. For those of you running afp on Solaris, and who are
> having problems w/ incorrect file sizes, bogus disk space and
> the like please send me your info.
>  
> I'm mostly concerned w/ fs type, device, mount point, mount
> options, kilobytes used and available.
> 
> This is all available in /etc/vfstab and df -k. (Assuming it's
> an automounted mount).
> 
> I'm also curious if there is anyone using the DDP kernel module or if
> everyone is only using afpovertcp.
> 
> 
> Cheers,
> Lance Levsen, 477-3166
> Unix Systems Administrator,
> PWGroup - Saskatoon
> 
> 
>

---

From: Lance Levsen <[email-masked]>
Date: Tue, 27 Nov 2001 18:50:44 -0600

> Solaris 8, 64-bit problems aside. Every call to bcopy spews out a bunch of

I'm using GNU binutils, gcc 3.0.2, Solaris 7, 32-bit. I'm getting
clean compiles and installs. The kernel module kills the kernel if I
modload it (* don't use kinstall! *). 

I figure the reason I can't login is the PAM problem, checking that
out now.

As far as the kernel module goes, I have to learn more before I can
really tackle that one.

Cheers,
Lance Levsen, 477-3166