Subject: 1.5pre8 - OSX 10.1 kernel panic (client)

From: Lorenzo Perone <[email-masked]>
Date: Wed, 24 Oct 2001 03:23:56 +0200

Hi all,

Just thought to give a notice about a kernel panic on OSX 10.1 that occurred to me shortly after connection to a netatalk 1.5p8 (CVS build of 2001.10.10, --enable-cnid-db) share running on SuSE Linux 7.2/i686.

I could reproduce it at any time: connect, enter password, choose share, double click, panic.
It happened only with one specific share on the same server. the others  mounted and worked well.

I guess the cause was a missing resource part for the .VolumeIcon.icns file
(this file was created by OS X after pasting an icon on the share volume). 
The resource part was missing because I had removed manually that particular .AppleDouble directory before.

Removing the remaining .VolumeIcon.icns data file caused the share to be mounted without panic;
Re-pasting the icon onto the volume afterwards and unmounting/remounting also showed no more panics....

It shouldn't be such a common scenario, but a kernel panic is nasty.

Notes: 
- It should not be that easy to crash an OSX client.... ;-)
- Maybe adding the right type/creator in AppleVolumes.system for .icns files will help preventing this, as I can't find anything else in those .AppleDouble/ .VolumeIcon.icns than type/creator information.

Regards,
Lorenzo

---

From: Sebastian Rittau <[email-masked]>
Date: Wed, 24 Oct 2001 09:28:08 +0200

> Just thought to give a notice about a kernel panic on OSX 10.1 that occurred to me shortly after connection to a netatalk 1.5p8 (CVS build of 2001.10.10, --enable-cnid-db) share running on SuSE Lin…

We had another report about a kernel panic on netatalk-devel. There is not
much we can do about that. Please contact the Linux Kernel folks. Which
version of the Kernel are you using?

 - Sebastian

---

From: Lorenzo Perone <[email-masked]>
Date: Wed, 24 Oct 2001 12:16:18 +0200

>version of the Kernel are you using?

It's the _client_, Darwin Kernel that crashes (sorry if it wasn't clear enough!!!).
The Linux server does just fine.

anyway,
Client: Darwin Kernel Version 1.4 - OSX 10.1
Server: SuSE Linux 7.1 (some packages 7.2), Kernel 2.4.0-4GB (SuSE).

Regards,
Lorenzo

---

From: Brice D Ruth <[email-masked]>
Date: Thu, 25 Oct 2001 09:49:39 -0500

I'm not sure if you've been told this already, but if you haven't done 
so already, I'd suggest you file a bug at bugreport.apple.com (I believe 
that's the URL - if not, its close :)).  Apple will definitely want to 
know about this since they appreciate that many, many places use 
netatalk systems and they're constantly striving to make OS X as stable 
as possible!

Sincerely,
Brice Ruth

On Tuesday, October 23, 2001, at 08:23 PM, Lorenzo Perone wrote:

> Hi all,
>
> Just thought to give a notice about a kernel panic on OSX 10.1 that 
> occurred to me shortly after connection to a netatalk 1.5p8 (CVS build 
> of 2001.10.10, --enable-cnid-db) share running on SuSE Linux 7.2/i686.
>
> The resource part was missing because I had removed manually that 
> particular .AppleDouble directory before.
>
> Re-pasting the icon onto the volume afterwards and 
> unmounting/remounting also showed no more panics....
>
> - Maybe adding the right type/creator in AppleVolumes.system for .icns 
> files will help preventing this, as I can't find anything else in those 
> .AppleDouble/ .VolumeIcon.icns than type/creator information.
>
>
> Regards,
> Lorenzo
>
>
>
WebProjkt, Inc.
VP, Director of Internet Technology
http://www.webprojkt.com/

---

From: Leland Wallace <[email-masked]>
Date: Thu, 25 Oct 2001 10:51:17 -0700

On Thursday, October 25, 2001, at 07:49 AM, Brice D Ruth wrote:

> so already, I'd suggest you file a bug at bugreport.apple.com (I 
> believe that's the URL - if not, its close :)).  Apple will definitely 
> want to know about this since they appreciate that many, many places 
> use netatalk systems and they're constantly striving to make OS X as 
> stable as possible!
>
> Sincerely,
> Brice Ruth

Brice is correct,
   Please send bugreports to Apple at https://bugreport.apple.com. I 
monitor this list, but it's best if the problem reports
get into the system so they can be tracked. When reporting kernel 
panics, we need all the text put up on the screen,
as well as the build of the system (look at the about this mac dialog & 
click on the "version" string). If you are seeing
basic weirdness, a packet trace would be really helpful. We tend to use 
etherpeek, but Ethereal looks like it should
work just fine. For login problems it is helpful to launch the Finder 
from terminal after setting the env variable
AFP_DEBUG_LEVEL to 8 and trying to reproduce the problem. This turns on 
the logging built into the AppleShare Client,
It will spew reams of info to stderr.

Hope this helps
Leland Wallace
AppleShare Client Lead

+-----------------------------------------------------------------------------------
Leland Wallace           Working in            AppleShare Engineering
[email-masked]    but not speaking for      Apple Computer Inc.
http://www2.inow.com/~randall
+-----------------------------------------------------------------------------------

---

From: Lorenzo Perone <[email-masked]>
Date: Fri, 26 Oct 2001 18:24:44 +0200

Got it.
As soon as a digicam pops up again in the office, I'll make a screenshot and try to upload it with a report to that address.

Meanwhile there's an update to the issue: it looks like the problem is not solved with the .VolumeIcon.icns stuff. I had the panic again, this time on the share that used to work. Deleting the .AppleDouble directory (this was not deleted previously, so it was legacy of netatalk 1.4asun214. It contained only the .parent file) and restarting netatalk seemed to do the trick once again, but I'm not sure about it anymore and will investigate further as time permits.

Another 'detail' about those two problematic shares of mine:
one of them is made up of symbolic links to directories which are, in fact, sub-subdirectories of the other share.

To clarify:
share 1: share 'projects'
/projects/customername/customername.workdir
these are all real directories.

share 2: workdirs
/workdirs/customername.workdir
workdirs is a real directory, whereas customername.workdir is a ln -s to /projects/customername/customername.workdir

It used to work with 1.4+asun2.14,
I wonder whether the cnid-db stuff is getting confused here. Is this possible?

[ I know it sounds like a strange environment, but this solution is a feature we definitively need here! ;-) ]

:-)

Regards,

Lorenzo

At 10:51 Uhr -0700 25.10.2001, Leland Wallace wrote:
>>I'm not sure if you've been told this already, but if you haven't done so already, I'd suggest you file a bug at bugreport.apple.com (I believe that's the URL - if not, its close :)).  Apple will definitely want to know about this since they appreciate that many, many places use netatalk systems and they're constantly striving to make OS X as stable as possible!
>>
>>Sincerely,
>>Brice Ruth
>
>Brice is correct,
>  Please send bugreports to Apple at https://bugreport.apple.com. I monitor this list, but it's best if the problem reports
>get into the system so they can be tracked. When reporting kernel panics, we need all the text put up on the screen,
>as well as the build of the system (look at the about this mac dialog & click on the "version" string). If you are seeing
>basic weirdness, a packet trace would be really helpful. We tend to use etherpeek, but Ethereal looks like it should
>work just fine. For login problems it is helpful to launch the Finder from terminal after setting the env variable
>AFP_DEBUG_LEVEL to 8 and trying to reproduce the problem. This turns on the logging built into the AppleShare Client,

---

From: Lorenzo Perone <[email-masked]>
Date: Fri, 2 Nov 2001 20:07:39 +0100

To whom it might concern,

[OS X 10.1 Kernel panic issue]
The OS X 10.1 Kernel panic described before seems to occur only on the --enable-cnid-db  build of netatalk 1.5p8. 

So far, (3 workdays in multiuser testing and many, many mounts and remounts) the version compiled only with 
--with-did=mtab \
--with-flock-locks \
--with-pam \
--with-shadow

is doing fine both with OS9 and with OS X 10.1 clients on a SuSE Linux 7.1 intel / libc6 / Kernel 2.4.0-4GB server. 

I'm looking forward to installing 1.5p8 on our other servers, this one being SuSE Linux 7.1 / Intel / Kernel 2.4.0-4GB.

I also did not have the problems described by other people on the list about data loss (up to now), but of course I am watching it.

[ISO names]
I am also running options:mswindows,nohex,usedots 
(for the first time with the p-releases) and it is translating fine from / to ISO 8859-1.

To rename previously :hex named files, a nifty utility provided by the mysql package is worth mentioning here: 'replace', which used in combination with 'find' made all needed conversions.  Sure, people accustomed to awk or sed will laugh, but for this issue replace worked just fine :-). 

Regards,
Lorenzo