Subject: Re: Mac OS X - connecting to Netatalk servers

From: Marcus <[email-masked]>
Date: Fri, 16 Mar 2001 3:28:52 +0000

I have been using one of the "later than the public beta(4k17)" versions of OSX(4k78), and connecting to netatalk-1.4b2+asun214-37b servers fine. Last night I backed up my Titanium Powerbook to a netatalk server (4GB of data) without a problem.
I have had a friend of mine report that coping a HUGE amount of data would cause OSX to kernel panic, but that was 4k29.
Don't use the "official" public beta for testing, it is a completely different OS to the later ones...which is a relief. I am running netatalk on a Mandrake 7.2 on a IBM e-server x200, and using netatalk-1.4b2+asun214-37b with encrypted passwords support.

mrad01 

> 
> From: "David J. Shaub" <[email-masked]>
> Date: Thu, 15 Mar 2001 20:05:30 -0500
> To: [email-masked]
> Subject: Mac OS X - connecting to Netatalk servers
> 
> Although I haven't helped anyone on this list yet - maybe one day I can.
> 
> I have been playing around with Mac OS X and it seems there is a 
> problem.  Netatalk volumes are not accessible.  While watching 
> /var/log/messages, it seems the authentication goes through.  You then 
> get your list of accessible shares, but when you attempt to mount them - 
> the server disconnects the client(Mac OS X box). 
>

---

From: Matthew Geier <[email-masked]>
Date: Fri, 16 Mar 2001 21:01:56 +1100

Marcus wrote:
kernel panic, but that was 4k29.
> Don't use the "official" public beta for testing, it is a completely different OS to the later ones...which is a relief. 

 So the public beta was basicly a con job and completely useless for
testing network interoperablity. Which was the only reason we got it in
the first place. Fortunatly 
we were sent the copy, and didn't actually have to buy it...

 Would have been nice if they actually made use of its update tool and
let people update their beta copies in line with the current development
track.

---

From: [email-masked]
Date: Thu, 15 Mar 2001 05:34:16 -0600 (CST)

Public beta was not a con job, and it was not a "completely different
OS". It was an early version of the OS, and just like all prerelease OS's,
there were things that weren't done. If everything was done it wouldn't be
'beta', it would be release.

-mab

---

From: "David J. Shaub" <[email-masked]>
Date: Fri, 16 Mar 2001 11:25:04 -0500

On Thursday, March 15, 2001, at 10:28 PM, Marcus wrote:

> I have been using one of the "later than the public beta(4k17)" 
> versions of OSX(4k78), and connecting to netatalk-1.4b2+asun214-37b
Have the same trouble with 4k78.  In fact the log files I captured were 
from an attempt by a 4k78 box.
>  servers fine. Last night I backed up my Titanium Powerbook to a 
> netatalk server (4GB of data) without a problem.
> I have had a friend of mine report that coping a HUGE amount of data 
> would cause OSX to kernel panic, but that was 4k29.
Are you using EXT2 for your disks?  Would using HFS+ volumes in Linux 
make any difference on how Netatalk handles the the connection to the 
client(Resource fork emulation..).
> Don't use the "official" public beta for testing, it is a completely 
> different OS to the later ones...which is a relief. I am running 
> netatalk on a Mandrake 7.2 on a IBM e-server x200, and using 
> netatalk-1.4b2+asun214-37b with encrypted passwords support.
Your version of Netatalk(the asun part) seems to have a  slightly 
different version numbers scheme.  Did you get a special build from 
somewhere other than the normal places(Sourceforge etc.), maybe I can 
try your build....