Subject: Re: Quark XPress File Locking - 1.5.1.1

From: [email-masked]
Date: Thu, 28 Feb 2002 11:36:32 +0100

Hi Steve,

Hereby you will find my config.

OS/Kernel : RedHat 7.2 / Kernel 2.4.7-10 (standard from RedHat)
AppleShare Client :  Appletalk FU 3-1.1 (standard from Mac OS 9.1)
Finder 9.1.1
Server FileSystem : Ext3 with journaling, RAID 5 on Adaptec 2100S, 3 x 36GB
IBM 15krpm
Quark XPress version : 4.11
Client connecting via Appletalk
No particular option during configure  ./configure
--with-message-dir=/var/log/atalk --enable-overwrite (as I downgraded from
1.5.2)

It seems there are no problem with other applications, nor with new files.
Only when modifying existing files on existing connnections.

Regards

Jacques

                      Steve Freitas                                                                                                     
                      <[email-masked]        To:       <[email-masked]>, <[email-masked]>                     
                      >                        cc:                                                                                      
                                               Subject:  Re: Quark XPress File Locking - 1.5.1.1                                        
                      28/02/2002 11:05                                                                                                  

Hi Jacques,

What version of OS/kernel? What version of AppleShare Client? What server
filesystem? What version of QuarkXPress? Is the client connecting via
TCP/IP
or AppleTalk? What configure options were used when compiling Netatalk?

Steve

> From: [email-masked]
> Date: Thu, 28 Feb 2002 10:13:34 +0100
> To: <[email-masked]>
> Subject: Quark XPress File Locking - 1.5.1.1
> Resent-From: [email-masked]
> Resent-Date: Thu, 28 Feb 2002 04:30:38 -0500 (EST)
>
> As I'm new in the list, I've no way to browse the archive...
>
> Well, my problem could be resumed as this.
>
> I installed version 1.5.2 (it is my first install) and encountered some
> problems (bad eof in Photoshop docs).
> I downgraded to 1.5.1 (with --enable-overwrite of config files for a new
> install) wich fixed the Photoshop problem.
>
> Then I get a new problem with Quark XPress.   Error -49. When you work on
> an existing file on the server, you cannot write it back and you receive
a
> file locked error.
>
> Is there a way to avoid this?
>
>
> Regards
>
>
> Jacques Petit
> Brussels
>
>
>
>
>

---

From: Carl Walters <[email-masked]>
Date: Thu, 28 Feb 2002 16:22:17 GMT

If you use the configure option ( –with-flock-locks ) the issue will be 
resolved.

>>>>>>>>>>>>>>>>>> Original Message <<<<<<<<<<<<<<<<<<

On 2/28/2002, 10:54:59 AM, Robert Thiemann <[email-masked]> wrote 

TCP/IP

> I have the same problem, but it's intermittent. And my situation is a
> little different.

> I just did a Fresh install of RH7.2 with netatalk 1.5.1.1 installed via 
RPM.

> OS/Kernel:  Linux version 2.4.7-10smp
> AppleShare:  3.8.8 (standard 9.1 install)
> Server Filesystem:  EXT3
> QuarkXpress Version:  4.11
> Client:  Connects via chooser, but auto-negotiates to connect via TCP/IP
> Options:  Dunno. Installed via RPM.

> A user found this, and it's not consistent. He opened a Quark
> Document, worked on it, closed it. Opened it later, worked on it it,
> saved it. Printed it. Then when he went to save it again, he got the
> error.

> And that's all I have.
> --
> Robert Thiemann
> Network Engineer
> VCU Adcenter
> [email-masked]