Subject: so, options:noadouble just plain doesn't work?

From: Charles Mangin <[email-masked]>
Date: Thu, 27 Sep 2001 14:53:45 -0400

after banging my head on the problem i described in a previous email 
- namely that i could copy files to my netatalk linux server without 
trouble except when said files were enclosed in a folder - i watched 
closely on the server what exactly was going on. i mistakenly thought 
that there was one .AppleDouble directory at the root of a 
mountpoint, like there is one .AppleDesktop, and that that was having 
permission problems. chowning and chmodding it made no difference. 
then i realized there was a .AppleDouble inside every folder i 
created, despite the fact that i had specified noadouble in the 
options in the server config file. realizing that was what was having 
permission problems, i turned off that switch, and the problem went 
away.

so, essentially, with noadouble enabled, the idea is not to create a 
.AppleDouble until it's absolutely necessary - i.e. when there is a 
file that has a resource fork copied onto the server - but the 
directory is created anyway, even though there might not be anything 
in it. when something does have to go in there, the permissions 
aren't set right, so the resource fork can't be written there, and it 
fails, giving up with a -50 or "file is locked" error on the client.

with noadouble disabled, the .AppleDouble is created as always, but 
with the correct write permissions, since it knows ahead of time that 
resource forks are going to be written willy-nilly.

this, of course, is only how i understand it. i'm probably wrong or 
terribly misguided. please clarify anything that i've missed.

---

From: Charles Mangin <[email-masked]>
Date: Thu, 27 Sep 2001 15:52:57 -0400

>Have you upgraded netatalk since your original install? When I went 
>from 1.4.x to 1.5pre3 I found the .appledouble data to be 
>incompatible. I was able to move/delete files existing on the 
>server, but could not write new files without a -50 error.

nope. this is a new install of 1.5pre. i had figured ther would be 
problems in upgrading, since so much changed from 1.4x to 1.5

the options:noadouble is the culprit, i'm certain now. i created two 
shares on the server, one with noadouble enabled, and one with 
noadouble disabled, both pointing to the same place. copying a folder 
with files in it to one share worked fine; copying the same files to 
the other share failed every time with "file is locked"

---

From: [email-masked]
Date: Fri, 28 Sep 2001 03:37:25 +0200

About those -50 errors.
I now know why they happend so totally irregular here on RH7.1,
they also do in Slackware here.

As I monitor the 'ifconfig -a'....
suddenly I get an RX error, then 10 seconds later the transfer stops and 
the mac says -50 error.
This -50 error is not due to a permission problem even tho -50 is supposed 
to mean that.
I have tried chmod -R 777 /home etc. etc.

At home I have a simple hub so I hope this is the problem. It also occurs
when I connect the mac<->linux with a crossedwire cable, just not as often. 
I have
tried changing the NIC in the linux box to a 3com 905b from realtec 8139 
based one, still RX errors (even more often).
I hope this will be solved when I use a switch, if not its got to be the 
mac having problems sending packets.

Could someone with hub OR crosswired cable confirm or deny this?

All the best /Mikko

---

From: Kim Holburn <[email-masked]>
Date: Fri, 28 Sep 2001 12:03:53 +1000

I had a problem like this on RH7.1 with a realtek ethernet card.  Nothing to do with netatalk.  All network traffic would hang after an arbitrary amount of data <10K transferred.  Went away after using another card.

At 03:37 AM 28/09/2001 +0200, [email-masked] wrote:
>suddenly I get an RX error, then 10 seconds later the transfer stops and the mac says -50 error.
>This -50 error is not due to a permission problem even tho -50 is supposed to mean that.
>when I connect the mac<->linux with a crossedwire cable, just not as often. I have
>tried changing the NIC in the linux box to a 3com 905b from realtec 8139 based one, still RX errors (even more often).
>I hope this will be solved when I use a switch, if not its got to be the mac having problems sending packets.
>

--
Kim Holburn  Network Consultant  P: +61 2 61258620 M: +61 0417820641
Email: [email-masked] - PGP Public Key on request

Life is complex - It has real and imaginary parts.
     Andrea Leistra (rec.arts.sf.written.Robert-jordan)

---

From: Lorenzo Perone <[email-masked]>
Date: Sun, 30 Sep 2001 18:51:54 +0200

At 15:52 Uhr -0400 27.09.2001, Charles Mangin wrote:
>>Have you upgraded netatalk since your original install? When I went from 1.4.x to 1.5pre3 I found the .appledouble data to be incompatible. I was able to move/delete files existing on the server, but could not write new files without a -50 error.
>
>
>nope. this is a new install of 1.5pre. i had figured ther would be problems in upgrading, since so much changed from 1.4x to 1.5
>
>the options:noadouble is the culprit, i'm certain now. i created two shares on the server, one with noadouble enabled, and one with noadouble disabled, both pointing to the same place. copying a folder with files in it to one share worked fine; copying the same files to the other share failed every time with "file is locked"

[ I confirm..... same behavior on our servers. ]

It would be great if some future version of netatalk could implement some kind of -cleanfs option, where any HFS-related filesystem meta-information, as well as resource forks, are not saved at all on the ext2 or ufs filesystem, but instead provided 'by template' to the client (such as with AppleVolumes.system.)

Of course that would mean no resource forks, no folder settings, no labels, etc... but who cares for them, at least on _some_ cross-platform  web or media shares?

BTW, I just got over an interesting article on arstechnica on mac-filesystem issues....
(not directly related to netatalk, but.... worth browsing)
http://www.arstechnica.com/reviews/01q3/metadata/metadata-1.html

:-|

Lorenzo

---

From: Gregg Healy <[email-masked]>
Date: Sun, 30 Sep 2001 11:15:24 -0700

I am having a bear of a time getting anything to go to a Stylus 740 
connected to the parallel port under Red HAT 7.1.

When trying to echo to the device (lp0) I get a message stating 
"Device or  Resource Busy".

Do I need to reset this port somehow? I am new and still learning so 
I apologize if this is a stupid question but Ive spent many hours 
trying to get this thing to work, again. It worked fine for a while.

I also get a message at boot when lpd starts saying "Winbond Super 
I-O Detection, checking ports... Is this a related issue or trying to 
tell me something?

Any help appreciated. My goal here is to get the printer working with 
my Macs using Netatalk.

Gregg Healy
President

PhotoAd.com, Inc.
http://photoad.com
800 471-3737