Subject: "The item cannot be written.."

From: cpaul <[email-masked]>
Date: Mon, 12 Nov 2001 20:44:12 +1100

hi

i am running netatalk-1.5pre2-6 from the redhat powertools on my rh7.1 system.

i have a linux directory mounted on a macos 9.2.1 system.

the linux directory is on a fat volume.

very often when i try to copy a file from the mac system into the appletalk-
mounted directory, macos complains:

  The item "file.psd" cannot be written, because it is in use. 
  Do you want to continue?  [stop] [continue]

whether i stop or continue, it won't copy the file.

the file is not being used anywhere.  if i duplicate and rename the
file and try to copy it to the mounted directory, i still get the 
same error.

is this problem familiar to anyone?  

thanks

chris paul

---

From: cpaul <[email-masked]>
Date: Mon, 12 Nov 2001 21:01:00 +1100

> the linux directory is on a fat volume.

i can't reproduce the problem if copying to a ext2 volume.

is there a known problem with fat?

chris paul

---

From: Thomas Schierle <[email-masked]>
Date: Mon, 12 Nov 2001 21:19:06 +0100

Don't know specifics about FAT volumes, but even the current
pre8 has issues with other non-native volumes as well.

In my understanding, FAT support is just meant as a way
to access files residing on non-native media from a Linux box,
but it isn't considered a suitable file system for Linux
boxes and therefore of cause not suitable to be shared out r/w.

Though in an ideal world your setup should work, I'd strongly
recommend to reconsider your server/workflow layout -- I don't
believe any of the Netatalk developers is willing to spent
time on FAT volume support unless the next release version
once gets rolled out. Even then, there is quite large to-do list
remaining, you should better give up on FAT support.

-Thomas

-- 
Thomas Schierle, Munich, Germany

PGP key [DSS/DH] 0xA23CDA1D available at various public key servers

---

From: Nigel Pegram <[email-masked]>
Date: Tue, 13 Nov 2001 10:05:44 +1100

I sometimes get that error when accessing a 4th Dimension database on a
shared ext2 volume after having previously used it. I have to unmount and
then remount the volume and the problem disappears. It is not caused by
another user accessing the database as it even occurs when I'm the only
person who has previously accessed it.

Nigel.

> From: Thomas Schierle <[email-masked]>
> Date: Mon, 12 Nov 2001 21:19:06 +0100
> To: Netatalk-Admins <[email-masked]>
> Subject: Re: "The item cannot be written.."
> Resent-From: [email-masked]
> Resent-Date: Mon, 12 Nov 2001 15:25:50 -0500 (EST)
>

---

From: cpaul <[email-masked]>
Date: Tue, 13 Nov 2001 09:01:07 +1100

> boxes and therefore of cause not suitable to be shared out r/w.

please don't consider this a request for FAT support :-)

thanks.