Subject: permissions, eh?

From: Walt <[email-masked]>
Date: Mon, 09 Apr 2001 12:06:50 -0400

Can anyone tell me what I have to do
for the files that my mac creates to
have correct permissions? I am running
the 1.4b2+asun build and this part of it
has always worked in the past but now
after upgrading to and then downgrading
from 1.5pre5 permissions are 664
instead of 775 or 774, which is causing
some real annoying problems.

Thanks! I've really been through a lot
trying to get this back the way it was...

Walt

-~

    Sometimes truth comes riding into history on the back of error.
                         Reinhold Niebuhr

---

From: Lorenzo Perone <[email-masked]>
Date: Wed, 11 Apr 2001 11:43:26 +0200

>some real annoying problems.

I've only had some problems with directories in the past - but what about
chmod 2771 for dirs (which makes the group stick to the files and dirs created inside a folder), and
chmod 660 for files?

I had also to set the umask in each user's shell profile (i set it to 117).

At my site it works fine - occasionally I have to run a script to resume the rights - since Netatalk has no setting like samba's <force new unix dir / file mode>...

Are your mac clients writing software for Your UX? Why do you need them 2 be executable?

:-)

Lorenzo