Subject: dsi_getsess: Connection refused

From: "Stuart Haas" <[email-masked]>
Date: Thu, 07 Feb 2002 12:23:31 -0500

Hi -

I seem to be having a problem.  I am working with the
 1.5.1.1 from the RPM available on falsehope.com, on Redhat
 7.1, 2.4.17 kernel.

When I start afp, encounter 

----
Feb  7 11:58:24 app1 afpd[1068]: main: atp_open: Cannot
 assign requested address
Feb  7 11:58:24 app1 afpd[1068]: ASIP started on
 192.168.0.8:548(1) (1.5.1.1)
Feb  7 11:58:24 app1 afpd[1068]: uam: uams_dhx.so loaded
Feb  7 11:58:24 app1 afpd[1068]: uam: "DHCAST128" available
Feb  7 11:58:24 app1 atalk: afpd startup succeeded
----

Then when I try to connect from an OS 9 client, I get:

---
Feb  7 11:56:54 app1 afpd[850]: refused connect from
 192.168.0.119
Feb  7 11:56:54 app1 afpd[850]: dsi_getsess: Connection
 refused
---

Any suggestions?

Thanks,

Stuart

-

This email has been scanned for all viruses by the MessageLabs SkyScan service. http://www.messagelabs.com/

---

From: Joe Clarke <[email-masked]>
Date: Thu, 7 Feb 2002 12:38:28 -0500 (EST)

I think that RPM use TCP Wrappers.  You might be missing an entry in
/etc/hosts.allow for afpd.  Something like:

afpd: .marcuscom.com : allow

Joe

On Thu, 7 Feb 2002, Stuart Haas wrote:

> _______________________________________________
> Netatalk-devel mailing list
> [email-masked]
> https://lists.sourceforge.net/lists/listinfo/netatalk-devel
>
>

---

From: "Daniel E. Lautenschleger" <[email-masked]>
Date: Thu, 7 Feb 2002 11:41:31 -0600 (CST)

afpd : .marcuscom.com

...is the correct entry for /etc/hosts.allow

-Dan

---

From: Joe Clarke <[email-masked]>
Date: Thu, 7 Feb 2002 12:46:23 -0500 (EST)

works for me on FreeBSD.

Joe

---

From: "Daniel E. Lautenschleger" <[email-masked]>
Date: Thu, 7 Feb 2002 11:48:19 -0600 (CST)

For all I know, they both work :-)

I don't use FreeBSD but *do* know that on Linux what I stated works. I
just didn't want an incorrect hosts.allow entry to further confuse the
lad.

-Dan

---

From: Joe Clarke <[email-masked]>
Date: Thu, 7 Feb 2002 12:52:16 -0500 (EST)

> just didn't want an incorrect hosts.allow entry to further confuse the

The allow might be understood in hosts._allow_ ;-)

Joe

---

From: "Stuart Haas" <[email-masked]>
Date: Thu, 7 Feb 2002 12:55:43 -0500

Thanks solved it,  thanks!

----- Original Message -----
From: "Joe Clarke" <[email-masked]>
To: "Daniel E. Lautenschleger" <[email-masked]>
Cc: "Stuart Haas" <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Thursday, February 07, 2002 12:52 PM
Subject: Re: [Netatalk-devel] dsi_getsess: Connection refused

> > > > > > This email has been scanned for all viruses by the MessageLabs
SkyScan service. http://www.messagelabs.com/

---

From: Robert Thiemann <[email-masked]>
Date: Thu, 7 Feb 2002 14:11:29 -0500

Hey all,

This is kind of a newbie-ish question, but hopefully not too much.

I just set up netatalk 1.5.1.1 on a freshly installed RedHat 7.2 serrver.

I set netatalk up via the rpm I found on rpmfind.net for the 
appropriate platform.

The server shows up in the Chooser, and it exports shares as I now 
expect. But it's only connecting via AFP over AppleTalk. It won't 
autoswitch over to AFP over IP.

I can go to the Chooser and manually type in the IP, and it'll work over IP.

I've used a friend of mine's netatalk on a Debian server he has, and 
it works fine.

All of my config files are as they ship by default (I haven't gotten 
any further than that).

Is there something I'm missing to make this work?

On a side note, i'm fixing to add this line to my afpd.conf file:

"ADC_Admin" -ipaddr 128.172.20.38 -transall -uamlist 
uams_clrtxt.so,uams_dhx.so -nosavepassword

So I can get the right name to show up in the chooser. That is 
essentially the default setup file, with me having just added 
ADC_Admin and the -ipaddr setting in the hopes that that will force 
it to switch.

Is there something I'm missing?

Thanks,

-- 
Robert Thiemann
Network Engineer
VCU Adcenter
[email-masked]

---

From: Thomas Kaiser <[email-masked]>
Date: Thu, 07 Feb 2002 20:47:44 +0100

> Is there something I'm missing to make this work?

What is the first entry in your /etc/hosts? If this is set to 127.0.0.1 and
localhost, then try to move the entry with the right interface's ip address
to the top, eg. '128.172.20.38  my.netatalk.server'

> uams_clrtxt.so,uams_dhx.so -nosavepassword

Hmm. I always thought, supplying a correct ip address in afpd.conf will fix
the issue. Are you sure that with this line enabled and afpd restartet
things still won't work? Did you trash the AppleShare prefs on the macs from
which you try to connect?

> ADC_Admin and the -ipaddr setting in the hopes that that will force

Normally this should be the right way.

If one of your macs is running MacOS X, then you can use the 'setenv
AFP_DEBUG_LEVEL 8' method, Leland provided, for debugging purposes.

Regards,

Thomas