Subject: connection to server

From: John Arends <[email-masked]>
Date: Sat, 14 Apr 2001 13:47:25 -0500

I'm considering using a netatalk server in a school with 3rd through 5th
graders. Right now we have one big novell server that handles library stuff
which is all PC, and also has the student files. (all student machines are
macs) It isn't working well.

I'd like to put up a netatalk server for student files, but I have some
issues with how students will connect to it. We don't want them using the
chooser, so we have resorted to desktop aliases so far.

I have 2 possible solutions, but neither works ideally.

#1 A setup like we have now. I create a netatalk volume for /home/ and it
has all the users folders in it. The click on their folder and save into it.
This is what we have now. Novell's permissions allow folders that the
students don't have access to to be invisible. When they open the users
folder, the only folder they see in it is their own. With netatalk, folders
the kids don't have access to just have the icons showing they can't open
them. With close to 500 users this isn't acceptable to have that many
folders visible. it will be too slow. Does anyone know a way to make the
other users' folders invisible?

#2 share the users' home directory(~). This will be similar to apple's idisk
where an icon shows up on the desktop  with the username and all the files
will be in it. The problem with this approach is that I can't use an alias
to connect to the server since every user's volume has a different name. I
don't want the kids messing with the chooser. Does anyone know of an
application or an applescript or something that will allow you to connect to
a server and gets its list of volumes?

One way I could solve #2 is to name the home directory "Home" rather than
the username. The problem with this however is that people will not be able
to tell who is logged in since it will always be called home. Therefore I
definitely do not want to do this.

Comments anyone? I'd be really interested how other people have this set up.

---

From: Joseph Annino <[email-masked]>
Date: Sat, 14 Apr 2001 15:11:42 -0400

I just setup netatalk on a RedHat Linux 7.0 intel box using the rpms in 
RedHat's contrib ftp server.  While I can mount both my home directory 
and a volume I have in /hom/shared from the OS X finder, I cannot write 
any files to these areas.  Whenever I try to write a file it creates a 
0k empty file in the server side, and then the finder gives an error 
code of -43 or -2.  I checked the permissions of these directories and 
the user and group I log in as can write to them, as some of the FAQs 
mention.  I'm not sure what else to try now.  Any help would be great.

---

From: Chad Cunningham <[email-masked]>
Date: Sun, 15 Apr 2001 10:41:30 -0400 (EDT)

I believe the answer is: it don't work.

I've had the best luck with 1.4b2+asu2.1.4, which seems to work fine
except that resource forks don't show up (ok, so it doesn't work fine).

For whoever maintains the SourceForge sight, any possibility of putting
this in the FAQ? I think this may pop up fairly regularly....

-- 

Chad Cunningham
[email-masked]

"Well, once again my friend, we find that science is a two-headed beast. One
head is nice, it gives us aspirin and other modern conveniences,...but the
other head of science is bad! Oh beware the other head of science, Arthur, it
bites!"

---

From: Matthew Keller <[email-masked]>
Date: 15 Apr 2001 17:24:05 -0400

Unofficial $0.02 - Don't use RPM builds from RedHat, they're generally
bad. 1.4B2+asun2.1.4 is quite stable when built from source, although it
is considered "untested" by the old maintainers (I can say, however,
that it's pretty solid for most environments (unless you use Quark ;)
 
The current developers working on 1.5 (currently in a "pre1.5" state) -
And more importantly the builds being released off of the SourceForge
site - Are the only real "developer supported" releases- There simply
aren't enough developers to "deal" with maintaining both code bases- As
far as FAQ entries regarding 1.4b2 releases, there isn't anything
consistant to put in the FAQ's except a big 240point "YMMV" and "Stay
away from ANY builds from distributions (Debian, RedHat and SuSe
(possibly others as well) builds tend to be quite buggy, and use
non-normal build options). Patches against the 1.4B2 tree are still
being looked at for inclusion into 1.5 (if they get to the right
place/people), but are more prone to being rejected than patches against
the 1.5 code. I recommend any patches be submitted through the
SourceForge patch manager (http://sourceforge.net/projects/netatalk/) or
to the netatalk-devel list (subscribe off of the aforementioned URL).

-- 

Matthew Keller
Enterprise System Analyst
Computing & Technology Services
Information Services Division
State University of NY at Potsdam
Potsdam, NY USA

http://mattwork.potsdam.edu/

---

From: Lorenzo Perone <[email-masked]>
Date: Tue, 17 Apr 2001 23:36:38 +0200

Hi,

>a server and gets its list of volumes?

-  If it can be of any interest -
I could only get one kind of AppleScript to mount Netatalk volumes fairly reliably (on OS9 as well as on OSX + NetAtalk):

try
	mount volume "ShareNameAsInAppleVolumes.default/user" on server "ServerNameAsInAfpd.ConfConfigurationLine" as user name "username"
on error
	say "oohps!"
end try

On OSX, and in general with NetAtalk, the password option did not work for me, and to make the above script work, I had first to save the passwords in the KeyChain and allow access, and then call them like that. In some cases it was enough to specify the server without the user name. Note that "on server"  seems to require the Server name as it appears in the chooser - even if you have atalkd not running and / or AppleTalk switched off.

Are the kids already able to type their names?

In that case an AS _could_ look like

on run
set KidQuestion to display dialog "Please type Your name" default answer "here" buttons {"no","done")
if button returned of KidQuestion is "no" then return
set KidAnswer to text returned of KidQuestion
set KidServer to KidAnswer & " Home" -- (or just KidAnswer)
try
mount volume KidServer on server "ServerNameAsInAfpd.ConfConfigurationLine" as user KidAnswer
on error
say "Are You trying to KID me?"
end try
end run

depending on how long and how much you fight with the mount volume command, you might get it to do what you need.... (in this case, the password would still be taken from the KeyChain)

:-)

Lorenzo

---

From: Lorenzo Perone <[email-masked]>
Date: Wed, 25 Apr 2001 04:49:19 +0200

Hi,

I succesfully got netatalk 1.5pre6 to work with my SuSE 6.3 box, thanks to MacConin for the /etc/pam.d/netatalk trick on SuSE, and to ./configure --with-pam --with-shadow --enable-suse --with-flock-locks --with-config-dir=/etc/atalk.
To work, I mean it _looks like_ the best version _working fine_ with OS 9 until now. 

-[In our case, _fine_ means: fair speed in transfers of thousands of small files and dirs;  opening/saving big image files on the server;  opening/saving text files;  succesful use of GoLive's site features (a hard test, I know...;); use of FileMaker files; with a lower priority, but still important: succesful launching of applications from the server; succesful mounting and use of images (.smis and .imgs and .dimgs). 
The first are the tests that I usually perform after a new build. Apps and Images follow if the first pass. When I want to be really evil, I also try to open MS Office files on the server ;)]-

1.5p6 passed all tests with OS 9 (still testing for reliability and with more clients, though)... but OSX is still cut out of the sourceforge tree... or did anyone get it to work any 1.5pX reliably?

After compiling different versions on different platforms, it came out, in my cases, that:

only netatalk 1.4b2+asun2.1.4pre37_test (with -DUSE-FLOCK-LOCKS) gives the impression to work with OSX (few errors, succesful transfers...), but then causes sooner or later Darwin to panic. On the other hand, my OS9 clients keep freezing and caughing with the asun builds....

all sourceforge netatalk versions I tried (and some newer asun builds) rarely caused Darwin to panic, login was possible (some _only_ thanks to the trick of using -loginmesg "something"  in afpd.conf), but then they caused OSX to display a lot of Error -43's, sometimes -50, and one time 8021. 

netatalk 1.5pre6 behaves the same with OSX (-43s), except that with --enable-lastdid did files where transferred partially (even if the error message was displayed in the osx finder).

and 1.5pre6  still causes the

afpd[xxx]: setdirowner: chown -1/0
.AppleDouble/.Parent: Operation not permitted

messages noticed recently...
(when used with _OS 9_ - I couldn't get it to happen with an OSX client)

One strange thing of these messages: they seem to assume that afpd is running as root, as noticed by M.K. - I've seen this happening only with netatalk1.5pre3 on LinuxPPC 2000 Q4: All afpd processes were running as root, but the users still got their correct access rights to the share folders (note: no admingroup, plain users).
I also noticed that that was the only combination of Linux+NetAtalk which transfered very fast also directories with thousands of files and subdirs: > 5MB/sec on a PMac G3 DT/266, while others don't get over 1-2-3 MB/s.
Where can this (root/nonroot) be set? Is it set by --enable-redhat (which I used for LPPC)?

...hope this post helps...

please keep it going, you're doing a good work on the sourceforge project, I believe - but pleeeease let us netatalkers enjoy OSX soon ... ;)

:-|

LP

---

From: Sak Wathanasin <[email-masked]>
Date: Wed, 25 Apr 2001 14:41:31 +0100

In reply to Lorenzo Perone's message of the 25/04/2001 at 04:49 +0200,

>only netatalk 1.4b2+asun2.1.4pre37_test (with -DUSE-FLOCK-LOCKS) 
>gives the impression to work with OSX (few errors, succesful 
>transfers...), but then causes sooner or later Darwin to panic. On 
>the other hand, my OS9 clients keep freezing and caughing with the 
>asun builds....

Well, I'm running RH7.0 (6.2 previously) and not SUSE but 
netatalk-1.4b2+asun2.1.4-pre39 runs 24 X 7 with no problems. It eeven 
works with OSX, though I haven't run that for any sustained period. I 
have a variety of Mac clients, mostly 9.1 but 8.1 and 7.6 as well. I 
have my servers mounted at startup and they stay mounted until I 
shutdown. I don't see any signs of "OS9 clients keep freezing and 
caughing" here, not because of netatalk anyway: when I poke around 
with Macsbug, I find that the culprit is usually IE5.

-- 
Sak Wathanasin
Network Analysis Limited
178 Wainbody Ave South, Coventry CV3 6BX, UK

Internet: [email-masked]
Phone: (+44) 24 76 41 99 96        Mobile: (+44) 79 70 75 19 12 
Fax: (+44) 24 76 69 06 90

---

From: Lorenzo Perone <[email-masked]>
Date: Thu, 26 Apr 2001 17:16:51 +0200

At 14:41 Uhr +0100 25.04.2001, Sak Wathanasin wrote:
>Well, I'm running RH7.0 (6.2 previously) and not SUSE but netatalk-1.4b2+asun2.1.4-pre39 runs 24 X 7 with no problems. It eeven works with OSX, though I haven't run that for any sustained period. I have a variety of Mac clients, mostly 9.1 but 8.1 and 7.6 as well. I have my servers mounted at startup and they stay mounted until I shutdown. I don't see any signs of "OS9 clients keep freezing and caughing" here, not because of netatalk anyway: when I poke around with Macsbug, I find that the culprit is usually IE5.

Good hint, thanx (IE).  How to do without it, anyway....(?)... M$ seems to like to make the macs look even more unstable than they would be without all those M$ extensions and apps...

Dunno, but by 'caughing' I mean problems in the 'realworld use'. i.e. opening, saving, moving... especially writing to volumes. Would You try pre39 from OSX for some more time (like editing a file in pshop, saving, copying a big file tree to the server and back)? I could trigger the panic on 10.0.1/pre37/SuSE6.3 quite reliably by alt-dragging (ie duplicating) files on the server itself (into a different dir). Note - we have 2771 on those dirs and 0660 on files (if that can be relevant somehow).

I'm not saying that the 1.5 tree doesn't have any problems (and I've been swearing at this tree _much_ more than at asuns when confing & compiling), but it feels like it's getting smoother, and it looks quite a bit faster with the 'new did'.   BUT I'd immediately try post-pre37s if someone could confirm that there is really a way to make it work with OSX without panics (again: sometimes it takes some time b4 they happen...)

BTW: I've seen OSX going lightning fast over netatalk+asun2.1.4-pre37test - especially in things like folder listings. Rescanning a site in golive is a charm.... Unfortunately only in the short moments before darwin panics... (which it seems to do most when writing, rather than reading)  :..-(

:-)

Lorenzo