Subject: directory sgid inheritance (was: security issue,nt1.5rc2+OSX...)

From: Lorenzo Perone <[email-masked]>
Date: Wed, 2 Jan 2002 15:53:47 +0100

Sorry if I'm insisting on this, but I'm fairly astonished that this doesn't seem to represent a problem for anybody else; on the other hand, maybe I missed some new option in rc2 / release:

how is it possible to make newly created directories via Finder on netatalk shares to inherit the sticky bit  on the group no matter how 'deep' they are in the share tree?

(still having the behavior of: first directory created: inherits; subdirectories of new directory: don't...)

this as  of 1.5rc2, but I browsed thru the last changes mails on netatalk-devel and couldn't find somebody telling that this was changed from rc2 to release...

thanx for listening,

Regards, and a HNY
Lorenzo

---

From: Rick Zeman<[email-masked]>
Date: Wed, 2 Jan 2002 11:24:00 -0400

>
>Sorry if I'm insisting on this, but I'm fairly astonished that this doesn't seem to represent a problem for anybody else; on the other 
>hand, maybe I missed some new option in rc2 / release:
>
>this as  of 1.5rc2, but I browsed thru the last changes mails on netatalk-devel and couldn't find somebody telling that this was changed 
>from rc2 to release..

Apple has to change the OS X Finder.  That's what's causing the problem, not netatalk.

---

From: Thomas Kaiser <[email-masked]>
Date: Wed, 02 Jan 2002 17:34:02 +0100

> Apple has to change the OS X Finder.  That's what's causing the problem, not

I think, Lorenzo speaks of two different concepts: explicit and inherited
permissions (in AFP 2.x days, there didn't existed file permissions, so
every file will be treated like the enclosing folder. And how the folder's
permissions are set is depending on the permission scheme). A good starting
point might be this here: <http://www.tandb.com.au/appleshare/privileges/>

Regards,

Thomas