Subject: setting up ghostscript

From: "Jerome Cintas" <[email-masked]>
Date: Tue, 31 Jul 2001 18:25:42 +1000

Hi all,

in the process of setting up an Epson Photo EX printer locally connected to my linux box,
i successfully setup netatalk for file share access with my mac, and have the printer working fine fro linux.

now to setup the printer to print from the mac, i keep having trouble setting up the filter for the queue to use ghostscript.

there is a an info page with the following link:
http://artoo.hitchcock.org/~flowerpt/projects/linux-netatalk/ghostscript.html
but doesn't seem to be up.
can anyone give me alink or info on how to setup my filter for ghostscript ?

FYI,my filter is as follow:

PATH=/usr/local/atalk/bin:/usr/local/bin:/bin:$PATH
export PATH

( echo '%!' ;
  echo '{0.333 exp} dup dup currenttransfer setcolortransfer' ;
  cat -
) | gs -q -dNOPAUSE -sDEVICE=epson -sOutputFile=- - | pap -E

and  i have the error :
 lp_init: lock: No such file or directory
 lp_open failed
when trying to print from the mac,
and a 'postscript error' message appears on the mac.

thanks !!

---

From: Nigel Pegram <[email-masked]>
Date: Wed, 01 Aug 2001 09:42:52 +1000

We use lprng, with magicfilter (which uses gs for some of its translations).
Thus all we had to do was provide postscript input to the linux box and the
lprng settings took care of converting the postscript to whatever output was
necessary. All I had to do was set up netatalk to send the print job to
lprng.

HTH
Nigel

From: "Jerome Cintas" <[email-masked]>
Date: Tue, 31 Jul 2001 18:25:42 +1000
To: "Netatalk Admins" <[email-masked]>
Subject: setting up ghostscript
Resent-From: [email-masked]
Resent-Date: Tue, 31 Jul 2001 04:38:02 -0400 (EDT)

Hi all,
 
in the process of setting up an Epson Photo EX printer locally connected to
my linux box,
i successfully setup netatalk for file share access with my mac, and have
the printer working fine fro linux.
 
now to setup the printer to print from the mac, i keep having trouble
setting up the filter for the queue to use ghostscript.
 
there is a an info page with the following link:
http://artoo.hitchcock.org/~flowerpt/projects/linux-netatalk/ghostscript.htm
l
but doesn't seem to be up.
can anyone give me alink or info on how to setup my filter for ghostscript ?