Subject: RE: Guest Access only, no authentication

From: [email-masked]
Date: Fri, 6 Apr 2001 14:46:00 -0500

my login attempts were from OS 9.1. Cleartext would be fine. I disabled guest by
specifying only uams_clrtxt.so in my uamlist. Of course I tried adding other
non-guest UAMS to the list, even though I'm not certain the Mac OS supports
them. Which UAM are your users currently authenticating with?

Guess I'd better try the RPM. :)

-----Original Message-----
From:     Walt Reed <[email-masked]> at Internet-RAC
Sent:     Friday, April 06, 2001 11:20 AM
To:     Sherry, Jonathan; [email-masked] at Internet-RAC
Subject:     RE: Guest Access only, no authentication

are you running os 9?  i've had problems with user authentication from 8.6 and
earlier.  once i moved everyone to os 9 i was able to disable cleartext
passwords
on the shares.  i'm running 1.5pre3 on redhat 7.0 boxes.  you might try adding
"-uamlist uams_clrtxt.so" to your afpd.conf if you are using one of the 1.5preX
(just to get a login, then you can config for crypto later).  if you are
suddenly
able to log in, you know it's a uams issue.  then you can either update the mac
os if you need to, or figure out what's going on with pam.

i also liked the other walt's advice on using an rpm.  i've had good experience
with mine.

w

[email-masked] wrote:

> I'm a linux neophyte. I managed to get netatalk up and running following the
> infamous Anders instructions. Only guest access is an option. If I disable
> guest, I get the error that basically says "couldn't find appropriate UAM on
> your client computer". I've got cleartext enabled. I added -DSHADOWPW and
> recompiled, still no authentication.
>
> I'm running a standard server install of Redhat 7, and added DES, etc. per the
> instructions, frankly 'cause I found it easier ultimately to add all
> authentication options than to find all the lines to comment out, when I was
> compiling.
>
> Any tips would be appreciated.
>
> Jonathan Sherry
> Manager of Publishing & Production Systems
> Golden Books

---

From: Walt <[email-masked]>
Date: Fri, 06 Apr 2001 15:24:54 -0400

In Mac OS versions prior to 9, I think you have
to install the Mac AppleShare Client 3.8.6
update to get better passwords...

I am a lousy one to give advice, however, since
I keep having permissions errors with every
install of Netatalk since I attempted 1.5pre5
including a patched version that I installed from
source. *Sigh* Oddly enough, even when I
uninstalled it and switched back to 1.4+asun,
my Mac client still uses a somewhat invalid
permission scheme (Creates files 666 instead
of 775) and it seems to have problems saving
from certain applications. Patiently awaiting
next release and wishing I knew C. :-)

Walt

-~

     It is easy to build a philosophy.  It doesn't have to run.
                         Charles Kettering

---

From: Walt Reed <[email-masked]>
Date: Fri, 06 Apr 2001 12:36:24 -0700

here's my /etc/atalk/afpd.conf:

Daphne -address 192.168.xxx.xxx -transall -uamslist uams_dhx.so -nosavepasswd

it works, but like i said only w/ os 9 or later.

w