Subject: NFS and netatalk folder permissions

From: Rich Winkel <[email-masked]>
Date: Thu, 4 Oct 2001 20:25:51 -0500 (CDT)

I'm running netatalk-1.5p7 on freebsd 4.3-release.
It appears that NFS messes up netatalk's access perms unless the
nfs mount is done with root permissions (i.e. root on the nfs client
has root credentials on the nfs'd disk).

Is this a known bug?  Is there a good workaround?

Thanks!
Rich

---

From: Mike Egglestone <[email-masked]>
Date: Fri, 05 Oct 2001 08:56:45 -0700 (PDT)

Hi,
Are you using /etc/fstab to mount the partition?
What does your /etc/fstab look like?
I know nothing about freebsd, so if there is no
/etc/fstab, then I can't help.   :)

Mike

---

From: Rich Winkel <[email-masked]>
Date: Fri, 5 Oct 2001 11:40:21 -0500 (CDT)

> /etc/fstab, then I can't help.   :)

Thanks for the reply!
The fstab entry is:
grok:/home/grok         /home/grok      nfs     rw,nosuid,nodev 0       0

But the permissions of root on the nfs disk are determined by the
/etc/exports file on the server.  When root is mapped to "nobody",
everyone's netatalk permissions are messed up.  For instance, for
a unix directory,

drwxr-xr-x is mapped to ro,ro,ro under netatalk.
drwxrwxr-x is mapped to ro,rw,ro.
drwxrwxrwx is mapped (correctly) to rw,rw,rw.
drwx--x--x = "?",--,--  (yes, a question mark shows up in the
                         get-info->sharing window)
drwxr-x--x = "?",ro,--
drwxrwx--x = "?",rw,--
d--xrwxrwx = rw,rw,rw

The settings of the suid and sgid bits have no effect on this problem.
Under the owner's unix shell account there is no such problem with
permissions.
When the nfs server's /etc/exports grants root permissions to root
on the nfs client, the problem goes away.

Rich