Subject: Printing problem under RedHat 7.1

From: Wade Masshardt <[email-masked]>
Date: Sun, 3 Jun 2001 16:43:04 -0500

I'm trying to get papd working on my RedHat 7.1 box with a HP 2100M 
hooked to the parallel port (/dev/lp0). I can print fine from the 
console on that machine and from Windows machines (via samba), but I 
can't seem to get papd configured quite right. I've been following 
the documents on the web 
(<http://www.linuxdoc.org/LDP/lame/LAME/linux-admin-made-easy/netatalk-file-and-print.html>, 
<http://www.umich.edu/~rsug/netatalk/>, 
<http://thehamptons.com/anders/netatalk/>, and 
<http://www.giub.unibe.ch/~eugster/appleprint.html> but I'm still 
running into problems. Here is my /etc/printcap (the none-comment 
lines) for reference:

lp|HP2100M:\
         :sh:\
         :ml=0:\
         :mx=0:\
         :sd=/var/spool/lpd/lp:\
         :lp=/dev/lp0:\
         :lpd_bounce=true:\
         :if=/usr/share/printconf/mf_wrapper:

My /etc/atalk/papd.conf:

HP-LaserJet-2100M:\
         :pr=lp:op=operator:\
         :pd=/etc/atalk/HPLaserJet2100.PPD:

The printer shows up in my Mac's Chooser as "HP-LaserJet-2100M", so 
that seems to be working. When I print, the job gets spooled and 
nothing ever comes out. Here is what is in /var/log/messages:

papd[26370]: lp_conn_unix connect /dev/printer: No such file or directory
papd[26370]: lp_print: lp_conn_unix: No such file or directory
papd[26340]: child 26370 done

(at this point, I made a symlink from /dev/printer to /dev/lp0 and tried again)

papd[26340]: child 26387 for "HP-LaserJet-2100M" from 65280.128
papd[26387]: lp_conn_unix connect /dev/printer: Connection refused
papd[26387]: lp_print: lp_conn_unix: Connection refused
papd[26340]: child 26387 done

I'm pretty much scratching my head over this, so any help would be appreciated.
-- 
+----------------------------+-------------------------------------+
|       Wade Masshardt       |  The Wisconsin Alumni Association   |
|  Tech Support Coordinator  |                                     |
|        608-265-8766        |       <http://uwalumni.com/>        |
+----------------------------+-------------------------------------+
|                <mailto:[email-masked]>               |
+------------------------------------------------------------------+

---

From: Paul Krohn <[email-masked]>
Date: Sun, 3 Jun 2001 22:58:12 -0700

it's late, so a blind guess seems appropriate:

'operator' doesn't have adequate permissions on /dev/lp0.

by default (on my rh 5 system), permissions are:

> crw-r-----   1 root     daemon     6,   0 Dec 31  1979 lp0

and 'operator' isn't in the 'daemon' group.

On Sunday, June 3, 2001, at 02:43 PM, Wade Masshardt wrote:

> hooked to the parallel port (/dev/lp0). I can print fine from the console 
> on that machine and from Windows machines (via samba), but I can't seem 
> to get papd configured quite right. I've been following the documents on 
> the web (<http://www.linuxdoc.org/LDP/lame/LAME/linux-admin-made-
> easy/netatalk-file-and-print.html>, <http://www.umich.edu/~rsug/netatalk/
> >, <http://thehamptons.com/anders/netatalk/>, and <http://www.giub.unibe.
> ch/~eugster/appleprint.html> but I'm still running into problems. Here is 
> my /etc/printcap (the none-comment lines) for reference:
>
> lp|HP2100M:\
>         :sh:\
>         :ml=0:\
>         :mx=0:\
>         :sd=/var/spool/lpd/lp:\
>         :lp=/dev/lp0:\
>         :lpd_bounce=true:\
> The printer shows up in my Mac's Chooser as "HP-LaserJet-2100M", so that 
> seems to be working. When I print, the job gets spooled and nothing ever 
> comes out. Here is what is in /var/log/messages:
>
> -- +----------------------------+-------------------------------------+