Subject: netatalk only uses one unix group to identify a persons permissions :-(

From: Sebastian Frankfurt <[email-masked]>
Date: Mon, 09 Jul 2001 08:24:05 +0200

Hello,

I have set up a netatalk with

   netatalk-1.4b2+asun2.1.3-7

on

   RedHat 6.2 (Kernel 2.2.17-6)

Okay, I made a user 'fred' (uid=500) with a primary group 'users' (gid=100).
The user fred is also member of the following groups

   admin    (gid=101)
   software (gid=102)
   develop  (gid=103)
   fred     (gid=500)

A look into /var/log/messages shows me, that netatalk
always identifies 'fred' with only ONE group -> 'users'.

His home directory is under /users/fred

/users        -> root.root  rwx r-x r-x

/users/fred   -> fred.fred  rwx r-x ---

It is impossible for user 'fred' to write to it's
homedirectory, because the group of it's home is
group 'fred' (gid=500) but he will always identified
with group 'users' (gid=100).

Is there a configuration option, to tell netatalk
also to get all groups where 'fred' is in?

On UNIX those permission settings are working, because
the owner settings allows 'fred' to write into his
home.

I DO NOT WANT TO CHANGE THE PERMISSIONS.

I need that users are able to write to directories
where the group is not their primary group!!!

What other solutions could you provide?

thanx in advance,

Sebastian

PS: Please do a cc to [email-masked] 'cause I'm not
     in the list ;-)

---

From: Steve Freitas <[email-masked]>
Date: Mon, 09 Jul 2001 00:43:59 -0700

>   RedHat 6.2 (Kernel 2.2.17-6)

I don't know if this has been fixed, but your version of netatalk is pretty
old. We're at 1.5pre6. See netatalk.sourceforge.net. Give it a try and see
if the problem persists.

Steve