Subject: Need help with papd

From: Roger Fischer <[email-masked]>
Date: Tue, 28 Aug 2001 20:03:03 -0700

When I try to print from my MacOS X computer to my RedHat 7.1 Linux computer,
I get the following error on my MacOS X computer:

	"This print job failed due to a printer PostScript
	error. (Spooler error.)"

When I look at /var/log/messages on the linux computer, I see the following:

*- snip -*
Aug 28 19:49:15 icarus papd[9865]: child 9874 for "stc800" from 65397.229
Aug 28 19:49:17 icarus papd[9874]: lp_init: lock: No such file or directory
Aug 28 19:49:17 icarus papd[9874]: lp_open failed
Aug 28 19:49:20 icarus papd[9865]: child 9874 done
*- snip -*

I setup up the printer using printconf-gui, and printing works fine 
directly from the Linux box.  This same configuration was working 
fine under RedHat 6.1.
I'm using Netatalk version.  netatalk-1.4b2+asun2.1.3-6

Any help would be greatly appreciated since Mac OS X doesnt' support my
serial Epson Stylus Color 800.  (USB ones are no problem).

Thanks,
	-Roger

Here's what my config files look like:

*-snip -*
# /etc/printcap
stc800|lp:\
         :sh:\
         :ml=0:\
         :mx=0:\
         :sd=/var/spool/lpd/stc800:\
         :lp=/dev/lp0:\
         :lpd_bounce=true:\
         :if=/usr/share/printconf/mf_wrapper:
*- snip -*

*-snip-*
# /etc/atalk/papd.conf
stc800:\
         :pr=stc800:\
         :op=admin:\
         :pd=/etc/atalk/EpsonStylusColor800.ppd:
*-snip-*

---

From: [email-masked] (Christopher M. Anderson)
Date: Wed, 29 Aug 2001 09:27:59 -0400

I also have been experiencing this problem with Redhat 7.1, MacOS 9.0.4,
and netatalk 1.5pre6.  The error on the Mac side is:
"[file] could not be printed on printer [printer] because of a Postscript
error."

The errors on the linux side (in messages) are exactly those Roger found.

I, too, would appreciate any suggestions for resolving this.

Thanks,
Chris

---

From: [email-masked] (Christopher M. Anderson)
Date: Wed, 12 Sep 2001 10:19:32 -0400

>am 29.08.2001 15:27 Uhr schrieb Christopher M. Anderson:
>
>> and netatalk 1.5pre6.
>Looks like you are using LPRng instead of old-style lpr?
>
>If so, take a look at
>
>    <http://www.rodsbooks.com/network/network-netatalk.html>
>
>and report on the list, please.

This modification of papd.conf works for me.  I'm holding in my hand the
first page I've printed directly from my mac since I upgraded!  Now I can
delete my manualspool directory, where I've been saving ps files generated
from the mac onto the netatalk volume to be manually lpr'd.  This has made
my day.  Thanks!

Chris

***************************************************************************
Christopher M. Anderson                                   [email-masked]
Assistant Professor of Experimental Economics             O: (401) 874-4587
Environmental and Natural Resource Economics              H: (401) 729-7520
University of Rhode Island                                F: (401) 782-4766
213 Kingston Coastal Institute
1 Greenhouse Road
Kingston, RI   02881
***************************************************************************