Subject: Re: Samba and Netatalk

From: "Bryn Hughes" <[email-masked]>
Date: Wed, 07 Mar 2001 10:37:44 -0800

Here's a question... is this issue resolved if using an HFS volume to do the file sharing?  As HFS doesn't allow filenames longer than 32 chars, users just plain wouldn't be able to create them in the first place, correct?  This also helps with some issues with Mac aliases getting confused, etc. AFAIK.  I know there are limitations to HFS with regards to volume and file size and how efficiently the disk is used with larger volumes, but for smaller shares this could be a solution.

Bryn

>>> Ryan McBeth <[email-masked]> - 3/7/01 4:09 AM >>>

	Daniel,

	The two seem to co-exist together pretty well.  Rich made a 
few valid points with .AppleDouble files.

	However, there is one thing that you may want to bring up in 
regards to Windows and Linux users.  You need to let them know that 
they can't create files greater than 32 characters or the Mac users 
won't be a able to see them.  And you will get holy hell from your 
Mac users when they call you and day "Bob said that he put the file 
on the server, but I can't see it, is the server broken?"
	So, you may need to do some social engineering with your 
Windows and Linux users to make sure that they understand the 
limitation.  They will forget about it anyway, so make sure you have 
them sign something.  :-)  Can you tell I've been an Admin for way 
too long?

	Ryan

>Would anyone care to comment on experiences they've had sharing data out
>on a volume that was accessed by Netatalk and Samba? Any glitches? No
>problem, go ahead and do it, your nuts, dude..., etc...
>
>Thanks. I have a dream that I can take one of our NT file servers and
>replace it with a Linux/Samba/Netatalk box. What a fine realization that
>would be...
>
>Thanks.
>-Dan

__________________________________
Ryan McBeth
Systems Administrator, Mobius New Media
Voice: (302) 475-9880 x11
FAX: (302) 475-9894
www.mobiusnm.com
__________________________________
The secret to not getting burned out is to play at
working hard, and not taking things too seriously.
- Linus Torvalds

---

From: Seanano <[email-masked]>
Date: Wed, 7 Mar 2001 13:07:06 -0600 (CST)

> Here's a question... is this issue resolved if using an HFS volume to
> do the file sharing?  As HFS doesn't allow filenames longer than 32
> chars, users just plain wouldn't be able to create them in the first
> place, correct?  This also helps with some issues with Mac aliases
> getting confused, etc. AFAIK.  I know there are limitations to HFS
> with regards to volume and file size and how efficiently the disk is
> used with larger volumes, but for smaller shares this could be a
> solution.

  IMHO, I would think the lack of file permissions with HFS wouldn't make
this very useful for anything other than read only (which wouldn't have
the problem anyway since nothing could be changed) or single user shares.

Sean