Subject: Re: Install path problem on Debian

From: Rory Campbell-Lange <[email-masked]>
Date: Fri, 20 Apr 2001 13:03:16 +0100

On 19/4/01, [email-masked] (Mike Johnson) wrote:

> It sounds like you need to run the configure again. Just cd into the
> directory and run ./configure, then run "make clean" and "make
> uninstall".
> 
> I think you still have stuff on your system that needs to be removed.
> Then you can run configure and make again (your configure line looks
> good, but you might want --with-shadow if you're using shadow
> passwords).

Hi Mike

I really must apologise for taking up everyone's time with this.

Thanks for the very clear instructions. The "make uninstall" worked
great. The only thing still left are the system init scripts - I hope
these are ok to leave.

The install is not working now at all.
Below are some of the errors reported from make when using the following
config line:

    ./configure --prefix=/usr --with-config-dir=/etc \
                --with-uams-path=/etc/uams --with-shadow
                
Am I missing some linker config files, or am I using the wrong version
of ld? Or perhaps I need to FIRST make directories such as /etc/uams?

Thanks again for any help
Rory

----------------------------------------------------------------------

Extracts from make output

configure:1333: checking if the linker (/usr/bin/ld) is GNU ld
GNU ld version 2.9.5 (with BFD 2.9.5.0.37)

ltconfig:959: gcc -o conftest -g -O2   -static conftest.c  1>&5
GNU ld version 2.9.5 (with BFD 2.9.5.0.37)

...

configure:2027: checking for main in -labs
configure:2042: gcc -o conftest -g -O2   conftest.c -labs   1>&5
/usr/bin/ld: cannot find -labs
collect2: ld returned 1 exit status
configure: failed program was:
#line 2035 "configure"
#include "confdefs.h"

int main() {
main()
; return 0; }
configure:2070: checking for main in -laudit
configure:2085: gcc -o conftest -g -O2   conftest.c -laudit   1>&5
/usr/bin/ld: cannot find -laudit
collect2: ld returned 1 exit status
configure: failed program was:
#line 2078 "configure"
#include "confdefs.h"

int main() {
main()
; return 0; }
configure:2113: checking for main in -lauth
configure:2128: gcc -o conftest -g -O2   conftest.c -lauth   1>&5
/usr/bin/ld: cannot find -lauth
collect2: ld returned 1 exit status
configure: failed program was:
#line 2121 "configure"
#include "confdefs.h"

...

configure:4602: checking whether setpgrp takes no argument
configure:4630: gcc -o conftest -g -O2   conftest.c -lrpcsvc -lresolv
-lnsl -ldl -ldb -lcrypt  1>&5
configure: In function `main':
configure:4622: too many arguments to function `setpgrp'
configure: failed program was:
#line 4610 "configure"
#include "confdefs.h"

configure:4877: checking for pam_start in -lpam
configure:4896: gcc -o conftest -g -O2   conftest.c -lpam  -lrpcsvc
-lresolv -lnsl -ldl -ldb -lcrypt  1>&5
/usr/bin/ld: cannot find -lpam
collect2: ld returned 1 exit status
configure: failed program was:
#line 4885 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char pam_start();

int main() {
pam_start()
; return 0; }
configure:5172: checking for sys/quota.h
configure:5182: gcc -E  conftest.c >/dev/null 2>conftest.out

---

From: Mike Johnson <[email-masked]>
Date: Fri, 20 Apr 2001 21:45:54 -0700

hmmm.... That's strange.

It looks like you might not be running with pam. It said something like 
"cannot find pam".

I don't use debian with netatalk.... so I don't know. Try this:

[root@behemoth netatalk]# ldconfig -p | grep pam
        libpam_misc.so.0 (libc6) => /lib/libpam_misc.so.0
        libpam_misc.so (libc6) => /lib/libpam_misc.so
        libpam.so.0 (libc6) => /lib/libpam.so.0
        libpam.so (libc6) => /lib/libpam.so
[root@behemoth netatalk]#

If the pam libraries aren't listed, you might either have to configure your 
system to use pam (assuming you want to use it), or find out where they are 
installed and check /etc/ld.so.conf.

hope that helps.

- Mike

On Friday 20 April 2001 05:03, Rory Campbell-Lange wrote:
>     ./c/configure --prefix=/usr --with-config-dir=/etc \
>onfigure --prefix=/usr --with-config-dir=/etc \