Subject: Printing and free space error - was [Fwd: Netatalk 1.5 Success]

From: Xiaping Lin <[email-masked]>
Date: Tue, 08 Jan 2002 12:47:34 +1000

Thanks Thomas for your reply. I will be looking at upgrading MacOS and AppleShare
client for a few Macs.

I do have 2 more questions/problems:
1)For every printing job, /var/adm/messages on Solaris 8 server display error such
as following:

Jan  8 10:00:16 papd[3285]: [ID 242679 lpr.info] child 21392 for "Printer1" from
65280.158
Jan  8 10:00:21 papd[21392]: [ID 973532 lpr.info] child 21393 done
Jan  8 10:00:21 papd[21392]: [ID 514041 lpr.error] select: Interrupted system call
Jan  8 10:00:21 papd[3285]: [ID 973532 lpr.info] child 21392 done

papd.conf for this printer is:

Printer1:\
       :pr=|/usr/bin/lp -d printer1:\
       :op=daemon:\
       :pd=/usr/local/atalk/etc/netatalk/ppd/laserjet4100.ppd

I did not set up /etc/printcap file, or should I?
I have seen previous report of this error, but cannot found answer:

http://www.umich.edu/~rsug/netatalk/archive/admins/1999/0069.html

2) Wrong used and free space displayed
df -k output:
Filesystem                  kbytes         used       avail       capacity
Mounted on
/dev/md/dsk/d3       10323610   2009106 8211268    20%      /var

/var/tmp is shared by Netatalk.
du -sk /var/tmp is 870429KB on server, but MacOS7.5.5(Appleshare client 3.6.3)
reports
zero K in disk, 1.9GB available in the header of shared volume(/var/tmp) window.
Disk usage
of sub-directories is also wrong.

Is this a bug or configuration issue?

Thanks very much!

Thomas Kaiser wrote:

> On Mon, 07 Jan 2002 14:17:49 +1000, Xiaping Lin wrote:
>
> > Why uams_dhx.so does not work ?
>
> Please post the relevant lines from your messages when you startup afpd.
>
> > [...]
> > It seems that if both uams_clrtxt.so and uams_dhx.so are listed in afpd.conf,
> > MacOS7.x machines pickups clear_text password method to authenticate, but
> > MacOS9 pick up uams_dhx.so for password authentication,
>
> When you connect to an AFP server the client gets a list of possible UAMs
> (User Authentication Modules). He compares the server's list with the ones,
> he is able to handle (either builtin or via third-party modules in
> SystemFolder) and tries to choose the best match.
>
> DHX Authentication worked the first time with AppleShare Client 3.8.1 (see
> <http://docs.info.apple.com/article.html?artnum=58373>) but with MacOS up to
> 7.5.3 you can only use 3.7.x. So you should upgrade to OS 7.6.1 and choose
> 3.8.3 (to avoid some problems with 3.8.1 and server aliases). Look at this
> overview to find out, which AppleShare client to use with which OS version:
> <http://docs.info.apple.com/article.html?artnum=60792>
>
> > but did not work in my case.
>
> Do you have a MacOS X box around? As Leland wrote once before, you can turn
> on debugging output that helps in situations like these, too:
>
> | On Thu, 15 Nov 2001 09:33:21 -0800, Leland Wallace wrote:
> |
> | > From the terminal in Mac OS X type:
> | > setenv AFP_DEBUG_LEVEL 8
> | > mkdir /Volumes/volname
> | > /sbin/mount -t afp afp://username:password@servername/volume \
> | >     /Volumes/volname
> | >
> | > replacing username, password, servername, volume, and volname with your
> | > local names
>
> This will give you probably some hints, what's happening...
>
> > I would like to get DHX authentication working for both MacOS7.x and MacOS9
> > machines. Is this possible?
>
> If you upgrade the MacOS 7.x machines to 7.6.1 and their AppleShare Client
> to 3.8.3 then it should.
>
> Regards,
>
> Thomas

--
Xiaping Lin

---

From: Thomas Kaiser <[email-masked]>
Date: Tue, 08 Jan 2002 08:40:07 +0100

> :pr=|/usr/bin/lp -d printer1:\

Does this local printer exists? What does a '/usr/bin/lpc status printer1'
say?

> I did not set up /etc/printcap file, or should I?

I have no experience with Solaris' own printing system (as we are using
Helios for this purpose). But generally speaking, you should first try to
get your printers to work locally on the server (eg. printing the famous
'ghostscript tiger' -- '/usr/share/ghostscript/gsx.xx/examples/tiger.ps' or
from elsewhere on the web -- from the command line) and if that works, start
to share them.

Regards,

Thomas