Subject: Re: Unidentified subject!

From: [email-masked]
Date: Mon, 24 Dec 2001 12:58:41 +0000

What's the maximum length of a filename for netatalk?

At 24/12/2001 12:11:22, Jason Quigley <[email-masked]> wrote:
#  > From: [email-masked]
#  > Date: Mon, 24 Dec 2001 11:24:53 +0000
#  > To: [email-masked]
#  > Cc: netatalk-admins <[email-masked]>, Rick Zeman
<[email-masked]>
#  > Subject: Unidentified subject!
#  > Resent-From: [email-masked]
#  > Resent-Date: Mon, 24 Dec 2001 06:25:12 -0500 (EST)
#  >
#  > I've had the patches on a netatalk server (rc2,Linux 7.1) since friday -
tried
#  > to copy across a chunk o'stuff (800mb+), failed with -37. I got one DID
#  > conflict
#  > yesterday. Used did=last.
#
#
#  This error normally indicates that one of the filenames is too long for the
#  netatalk volume.
#
#  I suppose progress on this problem can occur when the CNID code has
#  stabilised. I'm going to start studying C (Shouldn't be too difficult as I
#  can already code in perl and other languages) as I'll hopefully have some
#  time next year to start helping.
#
#
#  Cheers,
#  Jason.
#
#
Roger

---

From: Jason Quigley <[email-masked]>
Date: Mon, 24 Dec 2001 16:44:21 +0100

31 bytes, I believe.

> From: [email-masked]
> Date: Mon, 24 Dec 2001 12:58:41 +0000
> To: Jason Quigley <[email-masked]>
> Cc: netatalk-admins <[email-masked]>, Rick Zeman <[email-masked]>,
> [email-masked]
> Subject: Re: Unidentified subject!
>

---

From: Joe Clarke <[email-masked]>
Date: 24 Dec 2001 13:56:31 -0500

> What's the maximum length of a filename for netatalk?

AFP 2.x defines 27 character volume names and 31 characters for
filename.  AFP pathname strings can be a maximum of 255 characters.

AFP 3.0 defines the AFPName structure which can contain "almost infinite
number of path elements."  UNIX, however, limits path names to 1024
characters.  Currently Netatalk only supports up to AFP 2.2.

Joe