Subject: Re: Login Problems

From: [email-masked]
Date: Sun, 07 Oct 2001 04:05:40 +0200

Try this:

./configure --enable-redhat --with-pam

then put
/usr/local/etc/pam.d/netatalk
in
/etc/pam.d/

my pam.d/netatalk lokks like this:
auth            required        pam_unix_auth.so
account         required        pam_unix_acct.so
session         required        pam_unix_session.so
password        required        pam_unix_passwd.so

and it works

/cheers, Mikko

At 03:38 2001-10-07, you wrote:
>I am at my wit s end on this one.  I have compiled netatalk with the 
>with-shadows flag and I still can t log in.  I am using netatalk-1.5pre8 
>and Linux 7.1.  I don t know what else to try.  Any help would be appreciated.
>
>Thanks,
>     Floyd

---

From: [email-masked]
Date: Mon, 08 Oct 2001 10:04:57 +0200

Hi,

This solved my login problems on 1.5pre7.....

I tried to upgrade to 1.5pre8 this weekend but it didnt work.
I compiled/installed it the same way as 1.5pre7 but now the problem is the
same as yours, users cannot login. If you solve this problem please let me 
know.

/Mikko

At 14:32 2001-10-07, you wrote:
>On 10/6/01 10:05 PM, "[email-masked]" <[email-masked]> sat down and 
>composed:
>Try this:
>
>Thanks for the help, but it didn t work. :(  I re-compiled with the flags 
>you suggested and I made my /etc/pam.d/netatalk file look just like 
>yours.  I still get the User unknown, password incorrect, or logon 
>disabled error. Any other ideas?
>
>Thanks,
>     Floyd

---

From: [email-masked]
Date: Tue, 09 Oct 2001 01:26:13 +0200

Hi,
Here is a complete (I hope) list of what I did to get 1.5pre8 working on RH7.1:

tar xzf netatalk-1.5pre8.tar.gz
cd  netatalk-1.5pre8

./configure --with-pam --with-shadow --with-config-dir=/etc --with-did=last 
--with-flock-locks --with-msg-dir=/etc/netatalk/msg

vi etc/uams/Makefile
-----------------------------------------------------------------------------------------------------------------------
UNCOMMENT:
#UAMS_PAM = uams_pam.la
#UAMS_DHX_PAM = uams_dhx_pam.la
UAMS_CLRTXT_LINK = uams_pam.so
#UAMS_CLRTXT_LINK = uams_passwd.so
UAMS_DHX_LINK = uams_dhx_pam.so
#UAMS_DHX_LINK = uams_dhx_passwd.so

TO:
UAMS_PAM = uams_pam.la
UAMS_DHX_PAM = uams_dhx_pam.la
UAMS_CLRTXT_LINK = uams_pam.so
#UAMS_CLRTXT_LINK = uams_passwd.so
UAMS_DHX_LINK = uams_dhx_pam.so
#UAMS_DHX_LINK = uams_dhx_passwd.so
-----------------------------------------------------------------------------------------------------------------------

make
make install

mkdir /etc/netatalk/msg
cp distrib/initscripts/rc.atalk.redhat.tmpl /etc/init.d/atalk
cd /etc/init.d

vi atalk
-----------------------------------------------------------------------------------------------------------------------
CHANGE:
ATALK_BIN=:BINDIR:
ATALK_CONF_DIR=:ETCDIR:
ATALK_SBIN=:SBINDIR:

TO:
ATALK_BIN=/usr/local/bin
ATALK_CONF_DIR=/etc/netatalk
ATALK_SBIN=/usr/local/sbin

COMMENT OUT:
/sbin/modprobe appletalk || echo "[could not load appletalk module]"

TO:
#/sbin/modprobe appletalk || echo "[could not load appletalk module]"
-----------------------------------------------------------------------------------------------------------------------
(this last step is if you have appletalk compiled into the kernel as I 
have, cosmetics)

chmod 755 atalk

cd ../rc3.d (or whatever runlevel)
ln -s ../init.d/atalk S81atalk (or whatever number)
ln -s ../init.d/atalk S36atalk (or whatever number)
cd /etc/pam.d

vi netatalk
-----------------------------------------------------------------------------------------------------------------------
auth            required                pam_unix_auth.so
account required                pam_unix_acct.so
session required                pam_unix_session.so
password        required                pam_unix_passwd.so
-----------------------------------------------------------------------------------------------------------------------
(this is my /etc/pam.d/netatalk, and it works....)

edit the config files in /etc/netatalk, then type:
/etc/init.d/atalk start
to start it up, or reboot.

I'm not a Linux guru but after alot of fights I got this going.
I would appreciate any coments.

Best regards /Mikko