Subject: Intergrating an MS Windows classroom with an Apple classroom?

From: Shane Pearson <[email-masked]>
Date: Sat, 10 Nov 2001 22:00:21 +1100

Hello all,

I have recently been requested to get an MS Windows
classroom, connected with ethernet to an Apple classroom,
on speaking terms. They are getting sick of moving data
from class to class with Zip disks and are not having
much joy with some smb-for-Apple type software.

So I was thinking of perhaps setting up a Linux or
FreeBSD machine, with Samba and netatalk with a common
share, as a go-between for their file sharing and maybe
also common print serving along with internet
gateway/proxy through their ISDN connection.

Does this sound like the best solution for sharing files
and printers between these two classes?

I've never used netatalk and don't yet have a Mac at
home, so I'm a little concerned that getting all this
going in a reasonable amount of time for them could be
difficult? I've also never touched ISDN, so I'm
interested to know whether Linux or FreeBSD is the
best solution with ISDN?

Many thanks,

Bye for now.

---

From: Sebastian Rittau <[email-masked]>
Date: Sat, 10 Nov 2001 16:27:47 +0100

> gateway/proxy through their ISDN connection.

We are doing exactly that at my former school. We've got a network with
a central file server. Connected to that network are two rooms, one room
with Macs, and one with PCs as well as some more Macs and PCs scattered
in the building. It works quite well.

 - Sebastian

---

From: Neil Klepeis <[email-masked]>
Date: Sat, 10 Nov 2001 12:51:50 -0800

Greetings,

I have my Mac/Linux network sharing files like a dream. 

The only problem is that I can't 'see' any of my Linux-CUPS printers
from the Mac client (in the chooser).  Maybe I am missing something
extremely obvious (I am not super familiar with the Mac OS).  

Some details/diagnostics are below.

Thanks in advance!

Neil

*The Network*

2 x RedHat Linux 7.1, netatalk 1.5pre2 (installed on both from RH rpm)
-Intel EtherPro 100 on 1st, 3Com 3c905C on 2nd

1 x Mac Performa 6360, OS 8.5
-Farallon PCI RTL8139 

D-Link DSS-8+ Switch

2 printers on 1st Linux Computer, served by CUPS 1.1.10

*nbplkup*

               waftage:AFPServer                          5.97:128
               waftage:netatalk                           5.97:4
               waftage:Workstation                        5.97:4
      HP LaserJet 1200:LaserWriter                        5.72:129
              linuxbox:AFPServer                          5.72:130
Epson Photo Stylus 870:LaserWriter                        5.72:128
              linuxbox:netatalk                           5.72:4
              linuxbox:Workstation                        5.72:4
          Mac Computer:AFPServer                          5.175:249
          Mac Computer:ARA - Client-Only                  5.175:2
          Mac Computer:  Power Macintosh                  5.175:252
          Mac Computer:Workstation                        5.175:4

*getzones* (`Linuxbox' shows up as a zone in the AppleTalk panel on the
Mac)

Linuxbox

*atalkd.conf* on linuxbox

eth0 -router -phase 2 -net 5 -addr 5.72 -zone "Linuxbox" 

*atalkd.conf* on waftage

eth0 -router -phase 2 -net 5 -addr 5.97 -zone "Linuxbox"

*papd.conf* on linuxbox

HP LaserJet 1200:\
       :pr=|/usr/bin/lp -d LaserJet:\
       :op=daemon:\
       :pd=/etc/cups/ppd/LaserJet.ppd:
 
Epson Photo Stylus 870:\
       :pr=|/usr/bin/lp -d Epson870:\
       :op=daemon:\
       :pd=/etc/cups/ppd/Epson870.ppd:

-- 
___________________________________________________________
Neil E. Klepeis -- School of Public Health, UC Berkeley and
Lawrence Berkeley National Laboratory, Berkeley, CA USA

---

From: Shane Pearson <[email-masked]>
Date: Sun, 11 Nov 2001 11:22:59 +1100

Thanks Sebastian,

That's good to hear. Do you know if Linux or FreeBSD is
being used for that?

I'm wondering since netatalk originated on BSD?

BFN.

---

From: Sebastian Rittau <[email-masked]>
Date: Sun, 11 Nov 2001 14:36:52 +0100

> That's good to hear. Do you know if Linux or FreeBSD is

We use Linux servers, but I doubt that there are serious problems with
FreeBSD.

 - Sebastian

---

From: Shane Pearson <[email-masked]>
Date: Wed, 21 Nov 2001 23:02:34 +1100

Hi guys,

I've set up a Debian 2.2r4 server with Netatalk and
Samba, to service these rooms including Samba's
veto files options.

The IBM's see the server and so do the Macs.
Permissions are fine for the IBM's (students have
read only access), but I'm trying to get the same
for the Apples.

Is there an easy way to allow Admin staff (with
Apples) to have write access to the Linux server
while the student Apple machines only have R/O?

I've tried a few things, and searched the net,
docs etc, but can't get it going. Is there some
really verbose doco for Netatalk hiding somewhere
that I missed?

PS, also, I've hit a big snag with one of the staff
machines that I hope someone will know how to fix.
I set my boss G3 PowerMac (ouch) to use Multiple
Logins, in the hope that I could somehow setup
another login ("safely":) that would get onto the
Linux server with something other than "nobody", and
thus set write permissions through Linux....well...

She has'nt used a password on her machine for 3
years or so and now it's asking for her password
if I choose her profile at login, she usually gets
in without a password prompt. And the profile I
set up has limited privs on her machine and cannot
undo what I have done. Yikes.

Can I crack her local passwords or have I been
spoiled by Microsoft in the past?	; )
Please tell me there is a L0pht Crack for Macs!

Many thanks,

Bye for now.

---

From: Shane Pearson <[email-masked]>
Date: Thu, 13 Dec 2001 00:14:07 +1100

Hi guys,

Perhaps this is really simple, but I can't seem
to get it going. I am trying to configure netatalk
and Linux so that I can serve a share that staff
members can write to (with password prompting),
yet student machines can see and read without a
password?

I thought maybe I could hard link another directory
to the current share, giving seperate privs to each
and serving seperately with the staff share
requiring a password. I thought this might work but
I can't get hard linking working for directories
even as root, according the ln --help or the man
page for ln. Neither Linux 2.2.19 or 2.4.16 seems
to be letting me do this, on ext2fs or reiserfs.

Is there an easy way to otherwise get this done?

Many thanks.

---

From: Thomas Kaiser <[email-masked]>
Date: Wed, 12 Dec 2001 14:28:38 +0100

On Thu, 13 Dec 2001 00:14:07 +1100, Shane Pearson wrote:

> I am trying to configure netatalk and Linux so that I can serve a share
> that staff members can write to (with password prompting), yet student
> machines can see and read without a password?

1) Create a group staff and a group students if not happened already

2) Set up two different Volumes in AppleVolumes.system or
   AppleVolumes.default like

   /path/to/share/ "Staff" access=@staff password=[8 chars max. passwd]
   /path/to/share/ "Students"

   (see the documentation in AppleVolumes.default for details)

3) Make all inside this share writable for staff and readable for staff
   and students

You're done.

(This won't work with recent Netatalk versions -- 1.5pre9 and above -- and
the new ID scheme CNID enabled)

Regards,

Thomas