Subject: Re: Mac OS X and netatalk...

From: Scott Every <[email-masked]>
Date: Tue, 27 Mar 2001 14:31:53 -0500

i used th db on an ibook 300 for over a month as my only machine and had no 
problems other than classic was terrible in the beta.  i imagine that 
configured correctly, it will run just fine.  the key is a clean classic OS 
with no extra extensions.

let me repeat...classic works suprisingly well with most apps.

s

--On Tuesday, March 27, 2001 9:11 PM +0200 Jason Quigley <[email-masked]> 
wrote:

> On Tuesday, March 27, 2001, at 08:51  pm, Scott Every wrote:
>
>> actually, i use it in the real world and it runs VERY well on the new
>> pbg4
>
> pbg4 says it all. OS X has acceleration for G4 machines. Those of us with
> with G3's have to live in a world where, in comparison,  OS 8.1 feels
> positively spritely on a 7100/66! ;-)
>
> Cheers,
> Jason.

---

From: Chad Cunningham <[email-masked]>
Date: Tue, 27 Mar 2001 15:13:41 -0500 (EST)

I agree, I've got the final release on an iBook G3 300 and it works great.
The slowness associated with PB is gone, doesn't get hung up switching
active windows, etc. Apps are still a bit slow to launch, but waking up
from sleep is much much faster. Speed on classic apps is excellent, much
much better than PB.

Really, I think it will run fine on any G3 with sufficient ram (at least
128 if you want to use classic).

-- 

Chad Cunningham
[email-masked]

"Well, once again my friend, we find that science is a two-headed beast. One
head is nice, it gives us aspirin and other modern conveniences,...but the
other head of science is bad! Oh beware the other head of science, Arthur, it
bites!"

---

From: Jason Quigley <[email-masked]>
Date: Tue, 27 Mar 2001 22:31:31 +0200

Everybody is talking about Classic here. Granted, that's faster, but 
things like re-sizing windows and using the finder are just as slow, 
even if they do look prettier.

Cheers,
Jason.

---

From: Marcus Radich <[email-masked]>
Date: Wed, 28 Mar 2001 09:12:04 +1200

OK, it's slower. Bugger. Next topic.

For those of you who are reasonably new to the Mac platform, I can 
tell you from experience:

System 1.1 was faster than System 4.2
System 6.0.7 was MUCH faster than System 7
System 7.6.1 was MUCH faster than Mac OS 8.

I went back and forward between System 6.0.5 and System 7 SEVERAL 
times on my SE/30 back in 1991. System 6.0.5 was a ROCKET on the 
SE/30, System 7 was a DOG!

Today, we don't run 6.0.5, we got over it, we accepted 7, it turned 
out better after 7.1, we moved on.

Think about it.

mrad01

BTW, netatalk 1.4b2+asun 214 -37b works very well with Mac OS X as 
long as you add the DEFS= -DFLOCKS thingy to the sys/Linux/Makefile 
before you compile. I haven't tried 1.5. You can only connect via IP 
(great!) and transferring files large and small has worked for me 
since 4K46

mrad01

-- 
========================================================

"Always ask the question, never assume the answer."
		Marcus Radich 1999

========================================================

---

From: David <[email-masked]>
Date: Tue, 27 Mar 2001 16:45:40 -0500

Marcus,

I will give that a try.  I hope it works so I can get DHX 
authentication back.  I will try recompiling with the added flag on 
1.5 first and see what happens.

BTW:  What does DEFS=-DFLOCKS do and why does it seem only to affect 
OS X clients?  Just curious if you happen to know.

Thanks for helping out, this has been bugging me for a while now.

David Shaub

---

From: Scott Every <[email-masked]>
Date: Tue, 27 Mar 2001 16:47:10 -0500

right, think 1.0 release of a new os.  it WILL get fixed.  they had to get 
this out so developers would stop dragging their feet.  of course its not 
perfect.  wait until the first update.

s

--On Tuesday, March 27, 2001 10:31 PM +0200 Jason Quigley <[email-masked]> 
wrote:

> things like re-sizing windows and using the finder are just as slow, even
> if they do look prettier.
>
> Cheers,
> Jason.
>
>

---

From: Jason Quigley <[email-masked]>
Date: Wed, 28 Mar 2001 09:09:24 +0200

Hi Marcus!

I tried your suggestion about the -DFLOCKS with 
netatalk-1.4.99-0.20001108 but I don't think that it is related to the 
problem, at least not on a FreeBSD system, as I get the same results 
when connecting:

afpd[37429]: dsi_stream_read(0): Operation not supported

The 0 is the length of data returned which causes the code to return the 
error. Why, I don't know.

Any ideas?

Thanks,
Jason.

On Tuesday, March 27, 2001, at 11:12  pm, Marcus Radich wrote:

>
> BTW, netatalk 1.4b2+asun 214 -37b works very well with Mac OS X as long 
> as you add the DEFS= -DFLOCKS thingy to the sys/Linux/Makefile before 
> you compile. I haven't tried 1.5. You can only connect via IP (great!) 
> and transferring files large and small has worked for me since 4K46
>
> mrad01

---

From: Steven Karel <[email-masked]>
Date: Wed, 28 Mar 2001 12:08:16 -0500 (EST)

1. Just wanted to concur with Marcus that netatalk-1.4b2+asun2.1.4-pre37b
works fine with the appleshare client in OS X 10.0,.whereas the public
beta failed horribly . Not all versions of netatalk are that well behaved,
however. I haven't tested exhaustively, but I do know that 37b works on at
least 4 of our servers (RH 6.2/RH 7.0). Also, the old version 1.4b2-2.1.3
seems to work as well.

2. Setting -DUSE_FLOCK_LOCKS doesn't seem to be necessary for this
purpose, although it may help with file locking for other reasons. Marcus,
if you could be so kind, can you explain for us again what problems it
solves, and where exactly you recommend setting it? (I added
-DUSE_FLOCK_LOCKS in the sys/linux/Makefile DEFS= line)

README.ASUN says:

	byte locks should now work. if you want to enable the old way
        of doing things, add -DUSE_FLOCK_LOCKS.

thanks,

stevne

 On Wed, 28

---

From: Jason Quigley <[email-masked]>
Date: Thu, 29 Mar 2001 01:51:46 +0200

Hi Steven!

Where do we get the source for this beast?

Many thanks,
Jason.

---

From: Marcus Radich <[email-masked]>
Date: Thu, 29 Mar 2001 12:09:23 +1200

OK, I originally found that asun2.1.3 was wicked for serving quark 
dox, but when I updated to 214, I started having file locking 
problems with quark (typical). Also seems to happen with 
codewarrior(noted by a friend).
So after reading through asun's notes, I found a section which refers 
to the "old style" of byte locking. Adding the DEF= line and 
recompiling works perfectly. I have over 20 servers in production 
proving that!

Go to: ftp://ftp.cobaltnet.com/pub/users/asun/testing/  if you need it.

I'm currently running MacOS X 4L5 (10.0.1), which BTW is quite a bit 
snappier than 4K78 (10.0.0), and connecting to these servers shows no 
issues. Confirmed and tested!

(Also, for those "Mac OS X is too slow" people. Get 10.0.1 when it 
comes out (soon), and get Plus for X. It allows you to change Genie 
to scale and other less-CPU-intensive things. Look on versiontracker 
for a link to this)

I still use 1.4b2+asun214-37b because it works. I think I will start 
experimenting with 1.5 soon.

mrad01

---

From: Jason Quigley <[email-masked]>
Date: Thu, 29 Mar 2001 14:18:08 +0200

Hi everybody!

I got the version that Marcus suggested. I have a problem compiling it 
though. I get an error with the TCP wrappers support for a lib called 
nsl. I searched the web and it was suggested that this lib may not be 
needed on my system (FreeBSD). Is this the case? I compiled without it 
and got the server up and running. It shows up under 9.0.4's chooser and 
10.0.0 seems to think it's there as I get the following error when 
attempting a connection:

Mar 29 14:01:38 vulcan afpd[93813]: uam_load(uams_guest.so): failed to 
load.
Mar 29 14:01:38 vulcan afpd[93813]: uam_load(uams_clrtxt.so): failed to 
load.
Mar 29 14:01:38 vulcan afpd[93813]: uam_load(uams_dhx.so): failed to 
load.

Everything seemed to compile okay. I had to tweak the Makefile a little 
for FreeBSD, i.e. use /usr/ instead of /usr for the OpenSSL libraries.

I am stumped now. Any suggestions?

Many thanks,
Jason.

On Thursday, March 29, 2001, at 02:09  am, Marcus Radich wrote:

> OK, I originally found that asun2.1.3 was wicked for serving quark dox, 
> but when I updated to 214, I started having file locking problems with 
> quark (typical). Also seems to happen with codewarrior(noted by a 
> friend).
> <snip>

---

From: Lorenzo Perone <[email-masked]>
Date: Sat, 31 Mar 2001 10:47:17 +0200

Hi fellow neta-admins,

I've been 'going down deep' into the OSX/netatalk adventure ;-)

I've tried the -DFLOCKS (adding it to the DEFS line - correct?) thing and pre-asun2.1.4-38b_test.
No success, I get -43 and -37 errors _everywhere_  (uploading and downloading) - looks like an .AppleDouble problem? (thought they were related to resources, those errors).
But the same dirs used to work perfectly with pre3m (I'll check thisone out, anyway!).

With pre-asun2.1.4-37b it got better:
Mounts OK, downloads and gives the -43 error only on some files.
But then, after throwing one copied folder to the trash, when trying to empty it, I get a message with 'not enough privileges to perform operation'.
Weird enough: I got into the terminal, su-rooted (with an enabled root account, via NetInfoManager).
This is what I got when I tried to rm the stuff in /Users/lopez/.Trash:

override rwx------  lopez/staff for 6100's/Preferences/UMAX/VistaScan/Viewer Files/BRI4.JPG? y
rm: 6100's/Preferences/UMAX/VistaScan/Viewer Files/BRI4.JPG: Operation not permitted

I tried to chmod 660 all the stuff in there:

root# chmod -R 660 *
chmod: 6100's//Preferences/UMAX/VistaScan/Viewer Files/Y9.JPG: Operation not permitted
sort of weird! How can I get rid of that stuff now??

it could well be that it's the names of that folder I tried with, which contain 'Preferences' and other strange mac chars. Anyway, an ls -la in the undeletable folder items gives:

-rwx------    1 lopez  staff    6988 May 27  1998 Y5_4.JPG
-rwx------    1 lopez  staff    6940 May 27  1998 Y5_5.JPG
....

After testing with other folders, things looked much better, but I still get
- unsufficient privileges
- an item with the name 'Icon' already exists
- some other errors

but with other dirs I did not have the trashing-permission problem........

....at least, I got to mount the volumes on Mac OS X 10.0.0, which I never got to work with netatalk 1.4.99 and sourceforge-successors.
I'd be glad if someone has a solution...... anyway, I'm sure as soon as rufustfirefly or asun or anybody else involved will get to reproduce the problems, they'll be solved.
Damned...... I'd really like to start using OSX now, despite it being some kind of  'Beta 2'.
I tried hard, with all versions of netatalk I could find. I'm not a C programmer, just a web developer, and sysadmin.
I compiled mostly on LinuxPPC (cause there I have our most important files).

:-(

Allright, now I'll reboot into macos9, and since it worked so well with OS9, switch back to 1.5pre3........

Lorenzo

p.s.

here's a list of my experiments....... if it can be useful to anybody, anyway. I mean, it can be a reference only to those that see matching experiences in at least 2 cases ;)

=== 1.4b2+asun2.1.3: ===

Same experience with the following OSes:

SuSE Linux 6.3/Intel:
SuSE Linux 7.0/Intel
SuSE Linux 7.0/PPC
LinuxPPC 2000 Q4

- distri standard;
- works with OS9, slow. resource, ownership, ID related problems on OS9;
- OSX client connects and mounts, but plenty of problems when opening / editing files;

=== netatalk-pre-asun2.1.4-38b_test ===

LinuxPPC 2000 Q4

- works with OS9, FAST. seems OK on OS9, but I'd have to make more tests, no time now.
- OSX client connects and mounts, but -43 and -37 errors EVERYWHERE, also with files without resources or type/creators;

=== netatalk-pre-asun2.1.4-37b===

LinuxPPC 2000 Q4

- OS9 not tested yet
- OSX client connects and mounts, but -43 and -37 errors when copying, but only on some files.
- When putting things of SOME folders to the trash (looks like folder name problems!), can't empty trash 'not enough privileges'
- otherwise _very fast_ on OSX, also on many folders and files!

=== netatalk-1.4.99-0.20001108 ===

SuSE Linux 6.3/Intel:
- works with OS9; fast. alias problems;
- OSX clients get disconnected immediately after share choice;

LinuxPPC 2000 Q4:
- compiled but didn't work: disconnect upon file share choice with OS9.

=== netatalk-1.5pre3 ===

SuSE Linux 6.3/Intel:
- works with OS9; fast. folder alias problems;
- OSX clients get disconnected immediately after share choice; slow sherlock name searches;
- best choice for me now (production).

SuSE Linux 7.0/Intel
- works with OS9; fast. folder alias problems;
- OSX clients get disconnected immediately after share choice; slow sherlock name searches;
- best choice for me now (production).

LinuxPPC 2000 Q4
- configure-related problems (setpgrp...), 'commented' out to get ahead.
- works with OS9; fast. folder alias problems; extremely slow sherlock name searches;
- OSX clients get disconnected immediately after share choice;
- best choice for me now (production).

=== netatalk-1.5pre4 ===

LinuxPPC 2000 Q4
- compiled but didn't work: disconnect upon file share choice with OS9 (same problem as with OSX).

SuSE Linux 6.3/Intel:
- problems compiling

=== netatalk-1.5pre5 ===

LinuxPPC 2000 Q4
- configure-related problems (can not check if setpgrp is cross compiling...), 'commented' out some configure lines to get ahead.
- suspicious messages when making
- install problems: codepages not found? had to get them from an older /etc/atalk file
- after a few hours of work, when i came back and netatalk had crashed.
- switched back to pre3

.....

:-|

p.p.s.

assuming is a bad habit......
difficult to give up, in some cases, too......
(it always gives the illusion to be effective - especially in programming issues)

;-)

Lorenzo

At 12:09 Uhr +1200 29.03.2001, Marcus Radich wrote:
>OK, I originally found that asun2.1.3 was wicked for serving quark dox, but when I updated to 214, I started having file locking problems with quark (typical). Also seems to happen with codewarrior(noted by a friend).
>So after reading through asun's notes, I found a section which refers to the "old style" of byte locking. Adding the DEF= line and recompiling works perfectly. I have over 20 servers in production proving that!
>
>I'm currently running MacOS X 4L5 (10.0.1), which BTW is quite a bit snappier than 4K78 (10.0.0), and connecting to these servers shows no issues. Confirmed and tested!
>
>(Also, for those "Mac OS X is too slow" people. Get 10.0.1 when it comes out (soon), and get Plus for X. It allows you to change Genie to scale and other less-CPU-intensive things. Look on versiontracker for a link to this)
>
>I still use 1.4b2+asun214-37b because it works. I think I will start experimenting with 1.5 soon.
>
>mrad01
>
>

---

From: Chad Cunningham <[email-masked]>
Date: Tue, 3 Apr 2001 15:23:11 -0400 (EDT)

So, what was the version people said worked fine (arg, no archives?)

I haven't had much luck either, the 1.5 series don't cut it and the
1.4b2+asun2.1.3 redhat powertools rpm actually managed to crash the OSX
finder repeatedly... I was briefly excited to learn that the finder
recognizes NFS mounts in the final release, which is at least a temporary
fix, but I have a lot of older files that need to store resource data.

-- 

Chad Cunningham

---

From: "QUIGLEY,JASON (HP-Spain,ex1)" <[email-masked]>
Date: Wed, 4 Apr 2001 01:23:38 +0200

Hi Lorenzo!

A little late perhaps, I have been rebuilding my work system and mail 
archives (Beta 2 trashed the hard disk type problems!!).

Anyway, the option you should be trying is: -DUSE_FLOCK_LOCKS

I tried this for myself but didn't get much joy. It's been mentioned 
that it's the client's fault or the server's fault but I've got my test 
system running with netatalk-1.4b2+asun2.1.3_1 - just barely. I'm 
getting the usual permissions crap with directories. Compiling the 
asun2.1.4 versions is broken under FreeBSD. The pre series on source 
forge is broken (compiles okay) with 10 - unexpected shutdowns. I'm 
going to try and run 2 sets of servers - the pre series for 9- machines 
and the one that barely works for 10+ machines binding to different 
addresses to see if this is a solution.

I think the general impression that I get is that nobody really has a 
clue what's at fault and as the jocks on source forge don't really care 
too much about anything other Linux, those of us who like to run stable 
setups are in for a long wait for a resolution.

Does anybody know if Apple is interested in supporting anything other 
the Mac OS X Server or Appleshare IP? It would be nice to know what 
changes are going on in the client side, at least.

Sorry if I sound pissed off, but I have tried to compile, or have 
compiled (into the wee hours) every version of netatalk that I could get 
my hands on and every one has a different set of problems. I think the 
frustration is starting to get to me!!

Cheers,
Jason.

On Saturday, March 31, 2001, at 10:47  am, Lorenzo Perone wrote:

> No success, I get -43 and -37 errors _everywhere_  (uploading and 
> downloading) - looks like an .AppleDouble problem? (thought they were 
> related to resources, those errors).
> But then, after throwing one copied folder to the trash, when trying to 
> empty it, I get a message with 'not enough privileges to perform 
> operation'.
> override rwx------  lopez/staff for 
> 6100's/Preferences/UMAX/VistaScan/Viewer Files/BRI4.JPG? y
> it could well be that it's the names of that folder I tried with, which 
> contain 'Preferences' and other strange mac chars. Anyway, an ls -la in 
> the undeletable folder items gives:
>
> ....at least, I got to mount the volumes on Mac OS X 10.0.0, which I 
> never got to work with netatalk 1.4.99 and sourceforge-successors.
> I'd be glad if someone has a solution...... anyway, I'm sure as soon as 
> rufustfirefly or asun or anybody else involved will get to reproduce 
> the problems, they'll be solved.
> I tried hard, with all versions of netatalk I could find. I'm not a C 
> programmer, just a web developer, and sysadmin.
> here's a list of my experiments....... if it can be useful to anybody, 
> anyway. I mean, it can be a reference only to those that see matching 
> experiences in at least 2 cases ;)
>
> === 1.4b2+asun2.1.3: ===
>
> - OSX client connects and mounts, but -43 and -37 errors EVERYWHERE, 
> also with files without resources or type/creators;
>
> - When putting things of SOME folders to the trash (looks like folder 
> name problems!), can't empty trash 'not enough privileges'
> - configure-related problems (can not check if setpgrp is cross 
> compiling...), 'commented' out some configure lines to get ahead.
>> dox, but when I updated to 214, I started having file locking problems 
>> with quark (typical). Also seems to happen with codewarrior(noted by a 
>> friend).
>> comes out (soon), and get Plus for X. It allows you to change Genie to 
>> scale and other less-CPU-intensive things. Look on versiontracker for 
>> a link to this)
>>

---

From: Jason Quigley <[email-masked]>
Date: Wed, 4 Apr 2001 01:26:05 +0200

Hi Chad!

Don't go the way of NFS if you're going to be mixing client platforms. 
That's bad karma, in my experience. 10 messes things up for 9 and can't 
read things that 9 puts on the share.

Cheers,
Jason.

On Tuesday, April 3, 2001, at 09:23  pm, Chad Cunningham wrote:

>> But then, after throwing one copied folder to the trash, when trying 
>> to empty it, I get a message with 'not enough privileges to perform 
>> operation'.
>> it could well be that it's the names of that folder I tried with, 
>> which contain 'Preferences' and other strange mac chars. Anyway, an ls 
>> -la in the undeletable folder items gives:
>>
>> I'd be glad if someone has a solution...... anyway, I'm sure as soon 
>> as rufustfirefly or asun or anybody else involved will get to 
>> reproduce the problems, they'll be solved.

---

From: Chad Cunningham <[email-masked]>
Date: Wed, 4 Apr 2001 14:49:47 -0400 (EDT)

> read things that 9 puts on the share.

Trust me, I don't *want* to :) But it's currently the only way I have of
accessing files on my linux box... I've tried various versions of netatalk
with no luck.

-- 

Chad Cunningham

---

From: Ian Wojtowicz <[email-masked]>
Date: Thu, 05 Apr 2001 01:04:01 -0700

> changes are going on in the client side, at least.

We need to lobby Apple to become involved in Netatalk development. Just like
the Linux version of QuickTime Streaming Server, Apple needs to promote Mac
connectivity on other platforms.

Use the Mac OS X feedback form to encourage Apple's involvement with
Netatalk.

http://www.apple.com/macosx/feedback/

___________________________________________________________________________
ian wojtowicz                                                http://woj.com

---

From: Ian Wojtowicz <[email-masked]>
Date: Thu, 05 Apr 2001 01:39:07 -0700

I've noticed that using Mac OS alias files that point to netatalk folders
can produce very unreliable results (the wrong folder is opened). Has anyone
else experienced this? Any ideas for fixes?

---

From: Jürgen Weltzer <[email-masked]>
Date: Thu, 5 Apr 2001 12:33:57 +0200

>else experienced this? Any ideas for fixes?

No problems with 1.4.pre39 and OS 8.6 or higher
-- 
Mit freundlichen Grüßen
Jürgen Weltzer

- - - - - - - - - - - - - - - - - - -
Werbeagentur Weltzer
Max-Eyth-Straße 8
71065 Sindelfingen
Tel. +49 (0) 70.31.81.32.31
Fax +49 (0) 70.31.81.16.01
http://www.w-ww.de/
- - - - - - - - - - - - - - - - - - -

I never wanted to be average,  because when you are average you are 
just as far from the top as you are from the bottom. (Stan Cottrell)

---

From: Vic Landi <[email-masked]>
Date: Thu, 05 Apr 2001 08:44:45 -0500

Also, seeing as Apple has failed to include any compatability with non-IP
appletalk in the current version of OSX, it may become beneficial to get
netatalk running on OSX.

Vic Landi

> From: Ian Wojtowicz <[email-masked]>
> Date: Thu, 05 Apr 2001 01:04:01 -0700
> To: <[email-masked]>
> Subject: Re: Mac OS X and netatalk...
> Resent-From: [email-masked]
> Resent-Date: Thu, 5 Apr 2001 04:14:20 -0400 (EDT)
>

---

From: Chad Cunningham <[email-masked]>
Date: Thu, 5 Apr 2001 09:47:52 -0400 (EDT)

I seem to remember someone having gotten it running on OSX Server at one
time, but I think it was IP only. I would assume if OSX had kernel support
for appletalk, then the finder would support it. I could be wrong, but...
If not, someone would have to hack together kernel support, which might
prove to be a bit of a challenge...

-- 

Chad Cunningham

---

From: Lorenzo Perone <[email-masked]>
Date: Fri, 6 Apr 2001 00:52:45 +0200

Hi all,

Did you know that it is possible to mount volumes over the _Classic Chooser_ under OS X???

I mounted """succesfully""" netatalk shares running on 

SuSE Linux / Intel / 6.4 / netatalk-1.5pre3

then mounted volumes out of

SuSE Linux / Intel / 6.3 / netatalk-1.4.99-0.20001108 

and guess what, they were appearing correctly in the OS X finder!

Playing MP3s from the share on the SuSE Linux / Intel / 6.4 / netatalk-1.5pre3 box worked fine, but trying to copy ended in a -47 error.

When trying to copy some files from the 
SuSE Linux / Intel / 6.3 / netatalk-1.4.99-0.20001108  box, I got the kernel to panic:

panic(cpu 8): lockngr: locking against myself
backtrace: 0x0008c2f4 ..... (and more addresses)
....
kernel modules in backtrace: afpsf_fs(155)@0x8ec7000
Debugger(panic)

Waiting for remote debugger connection.

Options.... Type 
-----------------
continue.... ´c ´
reboot .... ´r´

still have to try the -DUSE FLOCK LOCKS (tried -DFLOCKS), but thought this info could be interesting...  maybe someone else among you is luckier, and can work in the mean time  mounting the shares over Classic chooser (!¡!).

Huh. I'll try my old mounting AppleScripts - who knows what's gonna happen? Maybe my OSX will start to fly...

;-!

Lorenzo

---

From: Lorenzo Perone <[email-masked]>
Date: Fri, 6 Apr 2001 03:33:55 +0200

Hi!

>Anyway, the option you should be trying is: -DUSE_FLOCK_LOCKS

I just tried this one. Now I get to connect, but password verification fails with OSX as well as with OS9. Sounds like an old problem I had at the beginning with SuSE 6.x, that is, no shadow support? But I don't know where to adjust this in asun's 2.1.4 pre37 (no configure)... any hint for this one? ...

>I tried this for myself but didn't get much joy. It's been mentioned that it's the client's fault or the server's fault but I've got my test system running with netatalk-1.4b2+asun2.1.3_1 - just barely. I'm getting the usual permissions crap with directories. Compiling the asun2.1.4 versions is broken under FreeBSD. The pre series on source forge is broken (compiles okay) with 10 - unexpected shutdowns. I'm going to try and run 2 sets of servers - the pre series for 9- machines and the one that barely works for 10+ machines binding to different addresses to see if this is a solution.
>
>I think the general impression that I get is that nobody really has a clue what's at fault and as the jocks on source forge don't really care too much about anything other Linux, those of us who like to run stable setups are in for a long wait for a resolution.

Yes, this is annoying: on one hand it's true that it's free, so one should not complain, one should go DIY. We can just hope those who are working on it now will fix all the bugs..
or maybe _repackage_ the software in a way that works! I mean, if not a clean rpm, at least clean configuration and makefiles, with all docs that are needed.

I have also the impression that there must be some compiles that fail or don't fail depending which netatalk-devel you have on your system. That is, maybe using an older one (but not too old) could make a newer version work on a particular system....
just an assumption.... but I've got quite enough of making assumptions on netatalk ;-(

>Does anybody know if Apple is interested in supporting anything other the Mac OS X Server or Appleshare IP? It would be nice to know what changes are going on in the client side, at least.
>Sorry if I sound pissed off, but I have tried to compile, or have compiled (into the wee hours) every version of netatalk that I could get my hands on and every one has a different set of problems. I think the frustration is starting to get to me!!

.... it's very near here, too.... fortunately under OS9.1 I stil can see al my servers... netatalk is the only thing holding me back from working with OSX. I need those shares, and I need them from the Linux box....

:..-(

Lorenzo

---

From: Matthew Keller <[email-masked]>
Date: 05 Apr 2001 23:57:51 -0400

At 1:23 Uhr +0200 04.04.2001, QUIGLEY,JASON (HP-Spain,ex1 wrote:
> clue what's at fault and as the jocks on source forge don't really
> care too much about anything other Linux, those of us who like to 
> run stable setups are in for a long wait for a resolution.

Mr Quigley,

Perhaps you'd like to volunteer to help submit bugfixes. I don't see any
contributions by you at all, yet you have the gall to accuse the "jocks
on sourceforge" of anything? The "jocks on sourceforge" use whichever
machines they have and know. We've got people using Solaris, FreeBSD,
and Linux on 4 architectures that I know of working on the code- Some
people are working on MacOSX, HPUX and other platforms too. Instead of
contributing to the FUD and poo hooing those who are working to make
this product better, perhaps you can contribute. Don't give me any of
this "I've submitted patches but they all get rejected" like many of
your ilk do - Because I can verify that your name has not come up on a
single line of submitted code. 

I hate politics. More than hating politics I hate people who have
platform zealousy issues. If you feel that whichever platform you're
using is under-represented among the "jocks on sourceforge", perhaps you
could bring yourself down to our/their level and contribute. Not a
single "jock on sourceforge" has any grudge against any platform - Sure,
we all have preferences - But to insinuate that we/they intentionally
ignore or "code against" a certain platform is beyond ludicrous- Not too
mention rude.

Furthermore, perhaps you noticed a certain three (3) letters in the
names of the releases that the "jocks on sourceforge" have made. "PRE".
"PRE" means "THIS FUCKING SHIT ISN'T SUPPOSED TO WORK YET BECAUSE WE'RE
STILL DEVELOPING IT SO IF YOU DON'T HAVE ANYTHING ***CONSTRUCTIVE*** TO
SAY OR CODE TO CONTRIBUTE BACK THE FUCK OFF". *straightening jacket* The
code coming out of the **PRE** 1.5 tree is considered alpha quality at
best - Somedays a good Beta quality.

We all have wishlists. We all would like Netatalk to be *the* AppleShare
server on ALL *IXish machines. We would like to have a lot of success,
meet 100% of peoples feature requests, and in general have a fun time
doing it - And it's getting there. Slowly. 

So, Mr. Quigley, although your views and opinions are welcome - I'll be
the last person to suppress that - I think you should get your facts in
line before making inflammatory statements about the people who are
trying to make a product you *CONSUME* as good as it can be- People,
mind you, who aren't getting paid for this. People who do it so that
they can actually CONTRIBUTE to something, instead of COMPLAINING about
it. Inflammatory, derogatory statements like yours only hurts production
as it disheartens those who work hard on this project. If you aren't a
coder - That's cool - Can you write docs? Maybe English isn't your first
language so you could translate them into other languages? Perhaps you
could use a debugger and send on debugging symbols to make the
bug-hunters lives a little easier? Hell, we could all probably use
bigger harddrives, more RAM, a couple days of "pay" to take time off
from our busy lives and spend the day coding and bug-hunting, maybe an
OS X server to give us something to test on. There's a LOT of ways you
can help- And you've already found one grevious way to hurt.

-- 

Matthew Keller
Enterprise System Analyst
Computing & Technology Services
Information Services Division
State University of NY at Potsdam

http://mattwork.potsdam.edu/

---

From: Mac Conin <[email-masked]>
Date: Fri, 06 Apr 2001 09:58:07 +0200

Okeydokey,

gimme some manuals, I'll try my best translating it to german

> At 1:23 Uhr +0200 04.04.2001, QUIGLEY,JASON (HP-Spain,ex1 wrote:
...
> language so you could translate them into other languages? 

...

-- 
--schnipp-- 

mit freundlichen grüssen

-----------------------------------------------------------
Mac Conin                        EUC Online Service GmbH
Geschäftsführer                  Taubengasse 9
[email-masked]                    D 50676 Koeln
http://www.euc.de                HRB Köln 32038
tel : +49-221-923 27 33          fax : +49-221-239 651
-----------------------------------------------------------
EUC sponsort Clean up Cologne - eine Iniative der IHK Köln,
der Abfallwirtschaftsbetriebe Köln (AWB) und dem
Grünflächenamt der Stadt Köln. http://www.clean-up-cologne.de

---

From: Matthew Keller <[email-masked]>
Date: 06 Apr 2001 10:26:34 -0400

That's the spirit! You can get the distro-included docs off of CVS, if
you're interested in those ( http://sourceforge.net/projects/netatalk/ )
- We're also using the SourceForge DocManager (URL below) to give a nice
user-friendly feel to it. **EVERYONE** can contribute to that by
asking/answering FAQ's, etc. SourceForge accounts are free, and you can
email Jeff if you'd like inclusion. Currently there are English and
Japanese versions of most of the docs - I'd love to see more languages. 

    http://sourceforge.net/docman/?group_id=8642

Mac- Thanks for the offer, it's much appreciated!

-- 

Matthew Keller

---

From: Lorenzo Perone <[email-masked]>
Date: Sat, 12 May 2001 18:40:31 +0200

just to get this one back to discussion: any new version with osx-related bugs fixed on the way? I've been trying some alternatives, such as sharity (see vtracker) to mount samba shares via NFS on OSX, but in my opinion it is a) way slow b) not really worth the money.
Besides, all resource stuff gets lost that way, which is not a problem for our website directories, but indeed for our source work directories. 

I'd love to find out there's a specific patch out there for the OSX 'flush fork' issue... (for either tree, asun or sourceforge:  they're both there, ready to _(re-re-re-re...)make_....).

....

:-)

Lorenzo

---

From: "Chris Garrigues" <[email-masked]>
Date: Sat, 12 May 2001 12:07:52 -0500

> From:  Lorenzo Perone <[email-masked]>
> Date:  Sat, 12 May 2001 18:40:31 +0200
>
> 
> just to get this one back to discussion: any new version with osx-related b
> ugs fixed on the way? I've been trying some alternatives, such as sharity (
> see vtracker) to mount samba shares via NFS on OSX, but in my opinion it is
>  a) way slow b) not really worth the money.
> Besides, all resource stuff gets lost that way, which is not a problem for 
> our website directories, but indeed for our source work directories. 
> 
> I'd love to find out there's a specific patch out there for the OSX 'flush 
> fork' issue... (for either tree, asun or sourceforge:  they're both there, 
> ready to _(re-re-re-re...)make_....).
> 
> ....
> 
> :-)

Last I heard was in this message on the devel list, which makes it sound like 
we're on our way, but nowhere near ready for production.

Subject: [Netatalk-devel] MacOS X
From: Netatalk <[email-masked]>
To: [email-masked]
Date: Tue, 8 May 2001 01:19:15 +0200
List-Id: <netatalk-devel.lists.sourceforge.net>

Hi folks,

I wanted to report my success with MacOS X patch 2 and the recent netatalk
version from sourceforge, checked out today:

- mounting works fine (ASIP)
- listing directories from finder works
- copying files from finder by drag'n'drop does NOT work
- copying files by terminal does work and files are correctly copied
  over to local hard disk where they can be opened normally
- no crashes seen up to now

I'll research further into what makes a finder copy different from a copy
by terminal. Strange indeed.

CU

Roland

_______________________________________________
Netatalk-devel mailing list
[email-masked]
http://lists.sourceforge.net/lists/listinfo/netatalk-devel
-- 
Chris Garrigues                 http://www.DeepEddy.Com/~cwg/
virCIO                          http://www.virCIO.Com
4314 Avenue C                   
Austin, TX  78751-3709		+1 512 374 0500

  My email address is an experiment in SPAM elimination.  For an
  explanation of what we're doing, see http://www.DeepEddy.Com/tms.html 

    Nobody ever got fired for buying Microsoft,
      but they could get fired for relying on Microsoft.