Subject: Problem with netatalk-1.5pre2-6 on a RH 7.1 system

From: "Karl-Heinz Schulz" <[email-masked]>
Date: Mon, 14 May 2001 11:56:51 -0400

I have problems to connect the Mac client to the server.
When shutting doen the server I receive the error

Shutting down AppleTalk services: Can't unregister barasnt3:Workstation@*
Can't unregister barasnt3:netatalk@*
Note: /etc/modules.conf is more recent than /lib/modules/2.4.2-2/modules.dep

"barasnt3 is the HOSTNAME"

When starting the error is

[root@barasnt3 atalk]# /etc/rc.d/init.d/atalk start
Starting AppleTalk services: (backgrounded)

after 10 seconds

[root@barasnt3 atalk]# nbp_rgstr: Connection timed out
Can't register barasnt3:Workstation@*
nbp_rgstr: Connection timed out
Can't register barasnt3:netatalk@*

I use shadowed password on the system - Could this cause it?

Thank you

---

From: Claus Atzenbeck <[email-masked]>
Date: Tue, 15 May 2001 22:57:34 +0200 (CEST)

> When shutting doen the server I receive the error

I have the same problem with netatalk-1.5pre6-1mdk on Mandrake 8.0

This is what happens:

*****
[root@thor root]# /etc/rc.d/init.d/atalk start
nbp_rgstr: Connection timed out                            [  OK  ]
Can't register thor:Workstation@*
nbp_rgstr: Connection timed out
Can't register thor:netatalk@*
                                                           [  OK  ]
[root@thor root]# /etc/rc.d/init.d/atalk stop
Can't unregister thor:Workstation@*                        [  OK  ]
Can't unregister thor:netatalk@*
                                                           [  OK  ]
*****

This is my /etc/atalk/netatalk.conf (comment lines deleted):

*****
AFPD_MAX_CLIENTS=20
ATALK_NAME=`echo ${HOSTNAME}|cut -d. -f1`
AFPD_GUEST=nobody
ATALKD_RUN=yes
PAPD_RUN=yes
AFPD_RUN=yes
TIMELORD_RUN=no
ATALK_BGROUND=no
*****

Anybody out there who can tell us how to solve this problem??

Thanks a lot!
Claus

---

From: Olaf Hering <[email-masked]>
Date: Tue, 15 May 2001 23:04:51 +0200

> Can't register thor:netatalk@*

Dont start the the atalkd with the `deamon` tool, I tried `startproc`
here, that doesnt work because startproc returns and atalkd is not yet
running. Well, if it works with earlier releases, no idea then.

Gruss Olaf

-- 
 $ man clone

BUGS
       Main feature not yet implemented...

---

From: Claus Atzenbeck <[email-masked]>
Date: Tue, 15 May 2001 23:45:48 +0200 (CEST)

> running. Well, if it works with earlier releases, no idea then.

I'm afraid that I don't understand what to do. Sorry...
What is "startproc"? What is wrong starting with "atalk start"?
Usually atalk is started on boot.

Please give me some more help...

Thanks so much!
Claus

---

From: Olaf Hering <[email-masked]>
Date: Wed, 16 May 2001 00:22:48 +0200

> Please give me some more help...

look at /etc/rc.d/init.d/atalk 
There is something like 
        daemon ${ATALK_SBIN}/atalkd

daemon picks your atalkd and launch it in the background. Then the next
service is started, which depends on atalkd . atalkd is not yet ready
and you get these error messages.
just remove "daemon".

Gruss Olaf

-- 
 $ man clone

BUGS

---

From: Claus Atzenbeck <[email-masked]>
Date: Wed, 16 May 2001 09:34:44 +0200 (CEST)

> and you get these error messages.

Thanks, Olaf, but it is still the same result. I have removed any word
"daemon" in /etc/rc.d/init.d/atalk ans I also was adding
"alias net-pf-5 appletalk" to module.conf (thanks to Craig), but:

*****
[root@thor init.d]# ./atalk stop
Can't unregister thor:Workstation@*                        [FEHLER]
Can't unregister thor:netatalk@*
                                                           [  OK  ]
[root@thor init.d]# ./atalk start
Starting AppleTalk services: nbp_rgstr: Connection timed out
Can't register thor:Workstation@*
nbp_rgstr: Connection timed out
Can't register thor:netatalk@*
*****

Any idea left??

Thanks a lot...
Claus

---

From: Karen A Swanberg <[email-masked]>
Date: Wed, 16 May 2001 09:27:01 -0500 (CDT)

What does your atalkd.conf file have in it? When I get this problem, it's
because I don't have my network interface listed. So I start with my
atalkd.conf file with this:

fxp0

and netatalk fills it in with this on the first successful start:

fxp0 -phase 2 -net 51321 -addr 51321.238 -zone "Geology"

This is on an OpenBSD box, perhaps the interface is something like eth0,
or le0. Whichever you see with an ifconfig -a command, or the equiv. on
your system.

After making this change I generally reboot, but I'm not an uptime
fanatic, and have spent way too much time in windows-world. =)

-Karen

> Can't register thor:netatalk@*

*                                                     *
Karen Swanberg              |                         
Network Admin.              |               GNUmusk, an 
Dept. of Geology/Geophysics |        opensource cologne
206 Pillsbury Hall          |                         
310 Pillsbury Ave. SE       |       Old geeks never die                    
University of Mn            |          They just revert
Minneapolis, MN 55455       |              to cleartext
(612) 624-6541              |                         
*                                                     *

---

From: Claus Atzenbeck <[email-masked]>
Date: Wed, 16 May 2001 16:48:59 +0200 (CEST)

> atalkd.conf file with this:

Great! I just had to add eth0 in atalkd.conf and atalk starts and
stops without errors!

Thanks a lot Karen!

Claus

---

From: Carsten Neumann <[email-masked]>
Date: Wed, 16 May 2001 20:12:05 +0200

> Can't register thor:netatalk@*

You probably have to put your network interface (ethernet?) into promiscuous mode
before starting appletalk.
E.g.: "ifconfig eth0 promisc"

HTH

Kind regards

	Carsten