Subject: file names don't appear right

From: Jürgen Weltzer <[email-masked]>
Date: Wed, 29 Aug 2001 15:38:04 +0200

Hi,

I made 3 pdf files on the mac, with names "file.1-1.pdf", 
"file.1-2.pdf", "file.1-3.pdf" which are saved on Macs desktop.
After that I wanted to save them on the linux box - but I can't copy 
the 2nd and 3rd file, cause the names are cut to "file." and the mac 
says "can't copy file 2 because theres another with the same name."

Whats that?
-- 
Mit freundlichen Grüßen
Jürgen Weltzer

- - - - - - - - - - - - - - - - - - -
Werbeagentur Weltzer
Max-Eyth-Straße 8
71065 Sindelfingen
Tel. +49 (0) 70.31.81.32.31
Fax +49 (0) 70.31.81.16.01
http://www.w-ww.de/
- - - - - - - - - - - - - - - - - - -

Der Vorteil der Klugheit besteht darin, daß man sich dumm stellen kann.
Das Gegenteil ist schon schwieriger. (Kurt Tucholsky)

---

From: Jürgen Weltzer <[email-masked]>
Date: Wed, 29 Aug 2001 17:18:00 +0200

>says "can't copy file 2 because theres another with the same name."

I found out that this appears when the Distiller cuts the filenames, 
cause they would be too long with its suffix .pdf.

The filenames written by Distiller are exaktly "file....1.pdf", "file....2.pdf"
By copying to the linux box all after "file." is cut off.
Does anyone know why? I'm using 1.5.6 on suse 7.1
-- 
Mit freundlichen Grüßen
Jürgen Weltzer

---

From: Thomas Schierle <[email-masked]>
Date: Wed, 29 Aug 2001 19:50:35 +0200

> Does anyone know why? I'm using 1.5.6 on suse 7.1

Welcome to the joys of non-working code page translation -- Distiller
doesn't name the files "file....1.pdf" etc, in fact the names are
"fileŠ.1.pdf" where the first three dots are an ellipsis.

The Netatalk pre series up to pre6 simply cuts filenames where a character
occurs that cannot be translated to the target character set.

Fixed -- or at least improved -- with pre7.

-- 
Thomas Schierle, Munich, Germany

PGP key [DSS/DH] 0xA23CDA1D available at various public key servers

---

From: Lorenzo Perone <[email-masked]>
Date: Sun, 2 Sep 2001 22:00:47 +0200

Hi all, 

I've been fighting (I wonder when I've ever NOT been fighting with netatalk...) with the codepage issue all day now. 
No message on this list could help me this time unfortunately.
Still using 1.4b2+asun2.1.4pre_37_test, BTW (best bet for me...). 
The server OS is SuSE Linux 7.1 on an Intel Box. 

I fought... until I finally found out a message in /var/log/messages that pointed out:

Sep  2 15:56:31 myhost afpd[5609]: /usr/local/atalk/etc/nls/maccode.iso8859-1: codepage version not supported

So I gathered together all the 'maccode.iso8859-1' codepages I had in the (as always) multiple installations of netatalk, and tried them one by one until I finally had the working one. 

In fact, I think this happened because I ended up mixing atalk directories... (so picking the one compiled with your favorite ntalk should do), but one never knows with netatalk... 

Pasting those cpages into this message sure won't make any sense (I can mail a .tar with the ones I have if anybody wishes so) - but mind /var/log/messages.... 
if they're not missing they might be the wrong ones...

just in case you (have) run into the same problem....

(yuppeee, finally filenames on a common ISO ground.....)

:-!

Lorenzo