Subject: RE:uam: uam not found

From: "Rolf Schoepfer" <[email-masked]>
Date: Sat, 2 Feb 2002 01:03:27 +0100

---------- Original Message ----------------------------------
From: Thomas Kaiser <[email-masked]>
Date:  Fri, 01 Feb 2002 21:18:09 +0100

>On Fri,  1 Feb 2002 20:12:09 +0100, Rolf Schoepfer wrote:
>
>> [...]
>> Feb  1 19:58:48 www afpd[5862]: uam: uam not found (status=-1)
>
>Which path for the UAMs did you supply while configuring
>(--with-uams-path=)?
>

I didn't specify this parameter. It defaults to /usr/lib/netatalk and there are some libraries for guest and passwd.
There's unfortunately a wrong link for uams_clrtxt.so, which points to a no existing library uams_pam.so.
After changing this link pointing to uams_passwd.so, I get on the Mac the login window. But it doesn't accept username / password.
I build the source --with-shadow option.

Any idea?

---

From: Thomas Kaiser <[email-masked]>
Date: Sat, 02 Feb 2002 01:14:42 +0100

am 02.02.2002 1:03 Uhr schrieb Rolf Schoepfer:

> I didn't specify this parameter.

And if you try it with this parameter set?

> It defaults to /usr/lib/netatalk and there are some libraries for guest and
> passwd. There's unfortunately a wrong link for uams_clrtxt.so, which points to
> a no existing library uams_pam.so.

Did you configure with '-with-pam'?

> After changing this link pointing to uams_passwd.so, I get on the Mac the
> login window. But it doesn't accept username / password.

What messages appear in syslog?

BTW: If you are trying this as root, it will always fail.

Regards,

Thomas