Subject: Re: Hidden Files Not Being Copied

From: "Philip J Spence" <[email-masked]>
Date: Thu, 18 Jan 2001 18:21:38 +0000

The AppleVolumes.default shipped with netatalk-1.4.99-0.20001108 contains 
these lines.

# nohex           -> don't do :hex translations for anything
#                except dot files. specify usedots as well if
#            you want that turned off. note: this option
#            makes the / character illegal.
# usedots             -> don't do :hex translation for dot files. note: when
#                        this option gets set, certain file names
#            become illegal. these are .Parent and
#            anything that starts with .Apple. also, dot
#            files created on the unix side are marked
#            invisible.

Useful?
>
> It should be possible to get netatalk to tell the mac about dot files,
> but mark them hidden.  "Just a Simple Matter of Programming." (TM)
>
> Naturally, special care would have to be taken for the .AppleDouble
> directory.
>
> Go on, tell me I'm wrong - I've not verified any of this.
>
> Cheers,
>
>
>
> Duncan.
>
>

---

From: Ray Zimmerman <[email-masked]>
Date: Thu, 18 Jan 2001 13:58:16 -0500

>#            files created on the unix side are marked

Anyone played with this?

Sounds like 'usedots' may only do the dot->invisible translation but 
not the other way.

I'll have to check this out if I get some time.

	Ray