Subject: Re: uam: uam not found

From: "Rolf Schoepfer" <[email-masked]>
Date: Mon, 4 Feb 2002 12:10:35 +0100

---------- Original Message ----------------------------------
From: Thomas Kaiser <[email-masked]>
Date:  Sat, 02 Feb 2002 01:14:42 +0100

>am 02.02.2002 1:03 Uhr schrieb Rolf Schoepfer:
>
>> From: Thomas Kaiser <[email-masked]>
>> [...]
>>> Which path for the UAMs did you supply while configuring
>>> (--with-uams-path=)?
>>> 
>> 
>> I didn't specify this parameter.
>
>And if you try it with this parameter set?

Do I need to unpack shadow-suite and point --with-uams-path to this directory?

>
>> It defaults to /usr/lib/netatalk and there are some libraries for guest and
>> passwd. There's unfortunately a wrong link for uams_clrtxt.so, which points to
>> a no existing library uams_pam.so.
>
>Did you configure with '-with-pam'?

No, i didn't:

./configure --with-shadow --enable-fhs --sysconfdir=/etc/config --with-flock-locks

>
>> After changing this link pointing to uams_passwd.so, I get on the Mac the
>> login window. But it doesn't accept username / password.
>
>What messages appear in syslog?

------------------ start /usr/sbin/atalkd ---------------------
Feb  4 10:07:42 www atalkd[118]: restart (1.5.1.1)
Feb  4 10:07:43 www atalkd[118]: zip_getnetinfo for eth0
Feb  4 10:08:02 www last message repeated 2 times
Feb  4 10:08:12 www atalkd[118]: config for no router
Feb  4 10:08:13 www atalkd[118]: ready 0/0/0
------------------ start /usr/sbin/afpd ---------------------
Feb  4 10:08:34 www afpd[120]: sample:AFPServer@* started on 65280.168:128 (1.5.1.1)
Feb  4 10:08:34 www afpd[120]: ASIP started on 10.10.10.197:548(1) (1.5.1.1)
Feb  4 10:08:34 www afpd[120]: uam: loading (/usr/lib/netatalk/uams_clrtxt.so)
Feb  4 10:08:34 www afpd[120]: uam: uams_clrtxt.so loaded
Feb  4 10:08:34 www afpd[120]: uam: loading (/usr/lib/netatalk/uams_dhx.so)
Feb  4 10:08:34 www afpd[120]: uam: uam not found (status=-1)
Feb  4 10:08:34 www afpd[120]: uam: "Cleartxt Passwrd" available
------------------ choose linuxbox ---------------------
Feb  4 10:08:38 www afpd[121]: ASIP session:548(1) from 10.10.10.202:49152(2)
Feb  4 10:08:38 www afpd[120]: server_child[1] 121 done
------------------ user /pwd -> fails ---------------------
Feb  4 10:09:16 www afpd[122]: ASIP session:548(1) from 10.10.10.202:49153(2)
Feb  4 10:09:16 www afpd[122]: cleartext login: szrolf
Feb  4 10:09:16 www afpd[122]: 0.08KB read, 0.07KB written
Feb  4 10:09:16 www afpd[120]: server_child[1] 122 done

>
>BTW: If you are trying this as root, it will always fail.

We logon with another user.

Kind regards

Rolf

---

From: Thomas Kaiser <[email-masked]>
Date: Mon, 04 Feb 2002 12:59:51 +0100

> Feb  4 10:08:34 www afpd[120]: uam: uam not found (status=-1)

Okay. That means, either in your netatalk.conf or directly in afpd.conf you
want both UAMs to be loaded by specifying them with -U... ?

> Feb  4 10:08:34 www afpd[120]: uam: "Cleartxt Passwrd" available

If you run configure, do you get those lines:

    checking for SSL... /usr (enabling RANDNUM and DHX support)
    checking for main in -lcrypto... yes
    checking for main in -ldes... yes

(you need OpenSSL to get the better authentication schemes DHX and (2 Way)
RandNum working)

Leland provided us with an overview about the many authentication schemes:
<ftp://terminator.rsug.itd.umich.edu/unix/netatalk/archive/netatalk-admins-m
ail/0647.html>

> Feb  4 10:09:16 www afpd[120]: server_child[1] 122 done

And your shadow passwords working correctly?

> We logon with another user.

Strange. I would try to avoid using cleartext passwords. MacOS X 10.0.x had
problems with it. Maybe older MacOS versions also?

Regards,

Thomas