Subject: PPD distribution to clients

From: Markus Boie <[email-masked]>
Date: Thu, 31 Aug 2000 18:37:32 +0200

Hello,

i have set up a print server with netatalk (netatalk-1.4b2+asun2.1.3-7, RPM version). AFPD is not running.

I am using CUPS to speak to the network printers. The PPDs on the print server have been changed to reflect the printer's features (more RAM and paper trays). Here's my papd.conf entry:

   QE:QE@print-server:\
         :pr=|/usr/bin/lp -d QE:\
         :op=daemon:\
         :pd=/etc/cups/ppd/APLWBGR1.PPD

Whenever I create a printer on a Mac client it gets the printer type from the server but then uses it's local PPD for that printer. Because the Mac cannot talk to the printer directly it fails to adopt the PPD and reports PS level 1 and 16 megs of RAM instead of level 3 and 48 MB.

Is there a way to have netatalk force the client to use the PPD on the server? What's the :pd= entry in papd.conf for?

Thanks
Markus

___________________________________________________________
Markus Boie                       Phone: +49 40 3.06.36-0
Information Services Manager      Fax:   +49 40 3.06.36-333

Adobe Systems Engineering GmbH
Grosse Elbstrasse 39
D-22767 Hamburg, Germany

---

From: andrew morgan <[email-masked]>
Date: Thu, 31 Aug 2000 10:34:18 -0700 (PDT)

On Thu, 31 Aug 2000, Markus Boie wrote:

> Hello,
> 
> i have set up a print server with netatalk
> (netatalk-1.4b2+asun2.1.3-7, RPM version). AFPD is not running.
> 
> I am using CUPS to speak to the network printers. The PPDs on the
> print server have been changed to reflect the printer's features (more
> RAM and paper trays). Here's my papd.conf entry:
> 
>    QE:QE@print-server:\
>          :pr=|/usr/bin/lp -d QE:\
>          :op=daemon:\
> Whenever I create a printer on a Mac client it gets the printer type
> from the server but then uses it's local PPD for that printer. Because
> the Mac cannot talk to the printer directly it fails to adopt the PPD
> and reports PS level 1 and 16 megs of RAM instead of level 3 and 48
> MB.
> 
> Is there a way to have netatalk force the client to use the PPD on the
> server? What's the :pd= entry in papd.conf for?

The PPD on the server is not distributed to the client in any way.  It is
used by the print server (papd) to answer queries about the printer.  So
if your mac asks how much ram the printer has, papd will respond with
whatever is in the PPD file.  The PPD file itself does not get sent to the
mac though.

	Andy

---

From: Markus Boie <[email-masked]>
Date: Thu, 31 Aug 2000 19:51:58 +0200

Andy,

thanks for the answer.

It doesn't seem as if the server is answering queries about the printer. When I request info on a printer my Mac tells me "status: printer spooler processing job" and never finishes. Instead the server should simply and immediately return the requested information from the PPD, right?

Does PAPD possibly require a running AFPD for some obscure reasons?

Markus