Subject: Log rotation

From: "Marc J. Miller" <[email-masked]>
Date: Wed, 6 Sep 2000 18:53:22 -0700

The logs have to be stopped for daily rotation and then continued afterward.  My logrotate.d/netatalk file is as follows; tell me if I'm doing this right (it's based on the Samba log rotate files):

/var/log/netatalk {
    notifempty
    missingok
    postrotate
        /usr/bin/killall -HUP afpd
    endscript
}

---

From: andrew morgan <[email-masked]>
Date: Thu, 7 Sep 2000 09:41:17 -0700 (PDT)

>         /usr/bin/killall -HUP afpd

Sending a single HUP to afpd will disable logins.  Sending two HUPs will
tell afpd to reload its config files.  If your afpd logs are really being
handled by syslog, then you should killall -HUP syslog, not afpd.

	Andy