Subject: Re: Aliases

From: "E. Scholtz" <[email-masked]>
Date: Thu, 20 Jan 00 12:19:27 +0100

>A client has been noticing the problem of aliases on netatalk
>shares linking to random locations, frequently changing(with netatalk
>1.4b2+asun2.1.3).  Has anyone experienced any simaler problems, or any
>problems with aliases)?
>
>

Hello,

yes, we've got the same problem. It seems to work with the 
netatalk-1.4b2+asun2.1.4 (up to now my aliases are correct for over three 
days!)

But with asun 2.1.4 RagTime 3.2 does not work correctly.

Best regards
Erik

************************************
..........ArgonSoft GmbH............
...........- Karlsruhe -............
....................................
........Key-Account Manager.........
....................................
......Tel: +49 721 92 92 5 - 0......
......Fax: +49 721 92 92 5 - 55.....
************************************

---

From: "Jon F." <[email-masked]>
Date: Thu, 20 Jan 2000 15:29:41 -0500 (EST)

Has anyone experienced any problems with linking between files? (ex:
pagemaker files.)  I'm hoping this update will fix this as well.

we are also having the problem of shares disconnecting every 30 mins or so
on a maching running 8.6.

---

From: Casey Lewis <[email-masked]>
Date: Thu, 20 Jan 2000 13:43:57 -0800

We had a similar problem with Macs dropping connections to a netatalk
box (Slackware 4.0, kernel 2.0.37)... we updated the Appleshare client
on the Mac and it seemed to fix the majority of the problems.  It still
drops every now and then, but not near as bad as it was before.  I think
we updated to AppleShare 3.8.3 on the 7.6.1 machines.  I'm almost
positive their is an AppleShare update for OS 8.6 (AppleShare 3.9.2 or
something)

HTH.
Please let us know how you solve your problem.
-casey
-- 
=====================================================================
Casey Lewis                     email:	[email-masked]
Technology Coordinator          phone:  702.228.0222
R&R Partners                    fax:    702.228.7885
=====================================================================

---

From: xav <[email-masked]>
Date: Thu, 20 Jan 2000 22:59:10 +0100

I had also that kind of problem, the mac was dropping the connection and then
afpd had zombie processes. My solution was in the configuration of afpd. As my
machine has an ip address wich was declared in the DNS with more than one name
alias. The machine was defined  to use an alias instead of its real DNS name. So
my solution was to define the ip address in afpd.conf and my problem went away. I
don't notice any dropping connection until now. It may be your solution too.

afpd.conf :

"LinuxBox" -address 192.168.1.1

Hope, it can help you

xav

---

From: Jean Richelle <[email-masked]>
Date: Fri, 21 Jan 2000 09:47:37 +0100 (MET)

I couldn't find described the option -address in the afpd.conf. Is it the
same as -ipaddr ?

Jean

> "LinuxBox" -address 192.168.1.1

_____________________________________________________________________________
Jean Richelle <[email-masked]>
Unité de Conformation des Macromolécules Biologiques   Tel: +32 (0)2 650 3587
Université libre de Bruxelles                          FAX: +32 (0)2 648 8954
av. FD Roosevelt 50 - CP160/16, B-1050 Bruxelles, Belgium
_____________________________________________________________________________

---

From: Xavier Reigner <[email-masked]>
Date: Fri, 21 Jan 2000 16:38:25 +0100

Maybe, 

Here you have my afpd.conf and its comments line so you can compare...

read you

xav

#
# Format of lines in this file:
#
#    server [ -tcp ] [ -ddp ] [ -guest ] [ -loginmesg message ] ...
#
# To specify a line with the default server name, use a "-" as the
# server name.
#
# There are a whole plethora of options available. Here they are for
# your edification:
#       toggles (-no<option> turns that option off; -<option> turns
#               it on):
#               transports: tcp, ddp, transall
#               debug: nodebug (can only turn off debug)
#               auth: cleartxt, afskrb, krbiv, guest, randnum, rand2num, 
#                     authall (doesn't include randnum/rand2num)
#               passwd: savepassword, setpassword
#               user volumes: uservolfirst, 
#                             nouservol (don't look for ~/.AppleVolumes)
#               
#
#       options w/ arguments (-<option> <argument>):
#               defaultvol, systemvol, loginmesg, guestname 
#               address (binds a server to a specific address)
#               port (has to be specified if more than one tcp server
#                    is to be served)
#               tickleval (sets the tickle interval in seconds)
#               uampath, nlspath
#               
# Order of precedence:
#       options in afpd.conf > command-line options > built-in options
#
# Some examples:
#
#       The simplest case is to not have an afpd.conf.
#
#       4 servers w/ names server1-3 and one w/ the hostname. servers
#       1-3 get routed to different ports with server 3 being bound 
#       specifically to address 192.168.1.3
#               -
#               server1 -port 12000
#               server2 -port 12001
#               server3 -port 12002 -address 192.168.1.3
#
#       a dedicated guest server, a user server, and a special
#       ddp-only server:
#               "Guest Volume" -nocleartxt -loginmesg "Welcome guest!"
#               "User Volume" -noguest -port 12000
#               "special" -notcp -defaultvol <path> -systemvol <path>
#
"LinuxBox" -noguest -address 192.168.1.1

---

From: "Jon F." <[email-masked]>
Date: Fri, 21 Jan 2000 12:38:06 -0500 (EST)

Are there any major issues with asun 2.1.4 that I should be aware of?