Subject: Re: Printing to HP LaserJet printer

From: Peter Gutowski <[email-masked]>
Date: 10 Jun 2000 12:48:59 -0400

>I'm using lpr -h because the Printer would do a banner page
>(even if it's suppressed in printcap).

Most HP Printers on a network have, in essence, a JetDirect Card, which has it's own "banner" settings as well. If this is your situation your can telnet into the JetDirect interface and turn off the banner setting. E.g.:

$ telnet <jetdirect>  <-- ip address or name of your printer
HP JetDirect

Please type "?" for HELP, or "/" for current settings
> /

   ===JetDirect Telnet Configuration===
        Firmware Rev.   : J.07.03
        MAC Address     : 08:00:09:5f:87:b3
        Config By       : USER SPECIFIED

        IP Address      : 192.168.3.12
        Subnet Mask     : 255.255.255.0
        Default Gateway : 192.168.2.32
        Syslog Server   : Not Specified
        Idle Timeout    : 90 Seconds
        Set Cmnty Name  : Not Specified
        Host Name       : NPI5F87B3

        DHCP Config     : Disabled
        Passwd          : Disabled
        IPX/SPX         : Enabled
        DLC/LLC         : Enabled
        Ethertalk       : Enabled
        Port[1] Banner page     : Enabled <-
        Port[2] Banner page     : Disabled
        Port[3] Banner page     : Disabled
> port:1           <- this particular one is a 3-port box
> banner:0         <- sets banner to "off"
> /                <- display settings

   ===JetDirect Telnet Configuration===
        Firmware Rev.   : J.07.03
        MAC Address     : 08:00:09:5f:87:b3
        Config By       : USER SPECIFIED

        IP Address      : 192.168.3.12
        Subnet Mask     : 255.255.255.0
        Default Gateway : 192.168.2.32
        Syslog Server   : Not Specified
        Idle Timeout    : 90 Seconds
        Set Cmnty Name  : Not Specified
        Host Name       : NPI5F87B3

        DHCP Config     : Disabled
        Passwd          : Disabled
        IPX/SPX         : Enabled
        DLC/LLC         : Enabled
        Ethertalk       : Enabled
        Port[1] Banner page     : Disabled <-
        Port[2] Banner page     : Disabled
        Port[3] Banner page     : Disabled

> quit         <-- saves changes and quits
$

Hope that helps.

-pg

---

From: Patrik Schindler <[email-masked]>
Date: Sat, 10 Jun 2000 19:06:40 +0200

>Most HP Printers on a network have, in essence, a JetDirect Card, which has it's own "banner" settings as well. If this is your situation your can telnet into the JetDirect interface and turn off th…

Thank you for this really great tip!
I'll try it (the printer is located in my company and currently switched off).

:wq! PoC