Subject: Help!

From: "Bryn Hughes" <[email-masked]>
Date: Tue, 14 Nov 2000 07:54:25 -0800

Everything was working fine on my server until I enabled my second NIC... I had been using eth1 for everything, and I just activated eth0 as well.  My default TCP/IP connection is on eth0, but I want netatalk to use eth1.  Now I can't get atalkd to even start!  Here's what I get:

Nov 14 08:42:07 ccmf1 modprobe: modprobe: Can't open dependencies file /lib/modu
les/2.2.15-2.9.0/modules.dep (No such file or directory)
Nov 14 08:42:07 ccmf1 atalkd: socket: Invalid argument
Nov 14 08:42:07 ccmf1 atalkd: atalkd: can't get interfaces, exiting.
Nov 14 08:42:07 ccmf1 atalk: atalkd startup failed
Nov 14 08:42:07 ccmf1 modprobe: modprobe: Can't open dependencies file /lib/modu
les/2.2.15-2.9.0/modules.dep (No such file or directory)                       

Thanks in advance

---

From: Christian Schmidt <[email-masked]>
Date: Wed, 15 Nov 2000 00:17:27 +0100

Bryn Hughes schrieb am 14.11.2000:

>  Everything was working fine on my server until I enabled my second 
>NIC... I had been using eth1 for
>  everything, and I just activated eth0 as well.  My default TCP/IP 
>connection is on eth0, but I want
>  netatalk to use eth1.  Now I can't get atalkd to even start! 
>Here's what I get:
>  [...]

Did you change the interface entry in your atalkd.conf?
Instead of
eth0 [and so on]
you should try
eth1 [and so on].

If you want your server to be an AppleTalk Router both eth0 and eth1 
need entries in etalkd.conf.

My atalkd.conf looks like this and works fine:
eth0 -seed -phase 2 -net 1 -addr 1.1 -zone "1stFloor"
eth1 -seed -phase 2 -net 2 -addr 2.1 -zone "2ndFloor"

hth,
Christian
-- 
Made with a Macintosh...
[email-masked]
http://home.t-online.de/home/chrischmi/