Subject: Printcap problem...

From: "Tom Watson" <[email-masked]>
Date: Thu, 25 May 2000 01:48:40 -0800

I thought it would be simple.  Just setup a pap server and have it spool
out to the LPR queue.  It isn't that easy...

>From the file '/var/log/lpr.log' (written by papd):
(all with machine ID and papd process id number)
...: restart (1.4b2+asun2.0a18.2)
...: No such printer: lp
...: printcap problem: lp
...: register dr-bond:EpsonLQ2@*
...: unregister dr-bond:EpsonLQ2@*

(The last message promptefd after a kill of the papd process)

I thought it would be simple because my files are pretty simple:
File '/etc/netatalk/papd.conf':
# Test Printer:pr=test:

\:EpsonLQ2:op=tsw:pr=lp:

---

From: Moritz Kaiser <[email-masked]>
Date: Thu, 25 May 2000 13:28:08 +0200 (CEST)

> (The last message promptefd after a kill of the papd process)
There are some syntax errors in your papd.conf

> File '/etc/netatalk/papd.conf':
Why that backslash at the beginning of the line??? You will need it at the
end of a line, if the printer definition continues within the next line.
Also some versions of papd don't like more than one information per line.
The best version would be:
8<-------------------------*snip*
# Endless comments.
EpsonLQ2:\
	:op=tsw:\
	:pr=lp:
8<-------------------------*snip*

mfg,
Moritz Kaiser

__________________________________________________________
Moritz Kaiser
Studentische Vertretung, Technische Universitaet Muenchen
Europe / Germany

---

From: John Grieg <[email-masked]>
Date: Thu, 25 May 2000 15:09:28 +0100

I have successfylly set up papd.conf with an Epson 3000

Epson \:EpsonLQ2:op=lp:pr=lp:

This works well from the Mac (I had to disable chech printer before printing),
choosing an AT-Stylus (?) ---> Epson  in the Chooser.

( I AM USING EPSONs OWN PRINTER software (NOT A LASERWRITER))

and the linux box sends the job (raw data) to the printer.

There is only one problem -- there is too much "linefeed"
i.e. a red square would print as

red stripe
white stripe
red stripe
white stripe
red stripe

Any ideas

[email-masked]