Subject: Re: Serious Problems

From: "Luke McNeilage" <[email-masked]>
Date: Thu, 08 Jun 2000 11:04:33 +1000

============================================================================
Luke McNeilage
Technical Director
D2P (Australasia) Pty Ltd
Email: [email-masked]
Web: www.d2p.com.au

Australia's leading file delivery system for publishing & graphic arts.

Tel: +61 (0)3 9429 3233
Fax: +61 (0)3 9427 0929
Mobile: 0419 512 868

Suite 3/243 Bridge Road
Richmond VIC 3121
Australia

----------
>> You SUDO-UNIX people really shouldn't make grand statements about Mac
>> Pre-press applications. Everything you have identified above is user
>> privileges.
>
> Perhaps you're right, but it was not described as such.  Besides,
> and to my surprise, I have seen many applications behave
> differently in respect to AFP.  Why do you say SUDO-UNIX?  It
> sounds odd.
>
>> Try doing a chmod -R 777 on the entire shared volume and see if you still
>> have the same problems. If they have gone away (as they did when I first
>> started with Netatalk) them you can start a user & group plan of the server.
>
> Doing this may be dangerous.  That depends on the content of
> course.  Another obvious thing is that one may loose other
> permission bits (like sticky for directories).
>
>> When you make users, DO NOT make individual groups. That totally screws up a
>> Mac workflow, because whoever touches a file is the only person how can
>> touch it after that.
>
> This is to general a statement.  There are different security
> needs.
>
> Best regards,
>
> Dejan
>

I call you sudo because you are neither UNIX nor MAC. The moment you raise
issues about security and all that UNIX paranoia, you should get out of
pre-press. Work-Flow depends on just that, open flow of ideas.

Did you try what I said first. Then look at you security. Its a work-flow
issue, first, security second.

---

From: Chip Mefford <[email-masked]>
Date: Wed, 07 Jun 2000 21:44:36 -0400

>
>I call you sudo because you are neither UNIX nor MAC.

Ahh! pseudo, I was completely stumped.

>  The moment you raise

EVERYTHING in networking is about the open flow of ideas, Security has come
about out of necessity, being burned too many times, and learning the hard 
way. As pre-press becomes more and more interconnected, pre-press with
figure that out as well.

Many permission/security schemes are quite complex and work quite well.
chmod -R 777 * could undo a whole lot of good as well as a many hours
of hair pulling. I wouldn't recommend it.

I do however, concur with you completely, that in the end, so much of this
is screwed up perms.

>issue, first, security second.

I don't agree, not at all.

And you are also right, I am neither a Unix nor a Mac person, nor a Windows
person either, I hate all computers with equal vehemence.
------------------------------------------------------------
  Chip Mefford BOFH
  SysMom                               Zz
  [email-masked]                zZ
  Audiovisual-Washington, Inc        |\ z    _,,,---,,_
  1 Export Drive                     /,`.-'`'    _   ;-;;,_
  Sterling, Virginia  USA           |,4-  ) )-,_..;\ (  `'_'
  20164-4421                       '---''(_/--'  `-'\_)
  800.731.2090 FAX 703.404.8940
  LAT 38.59'37.3" N LON 77.25'35.8" W
  -------------------------------------------------------------

---

From: Patrik Schindler <[email-masked]>
Date: Thu, 8 Jun 2000 18:20:08 +0200

At 11:04 Uhr +1000 08.06.2000, Luke McNeilage wrote:

Would you please stop doing full quotes? Thanks.

>pre-press. Work-Flow depends on just that, open flow of ideas.

You miss two points:

As networks grow, chances grow similarly that you indruder won't come from outside your corporate network. Think about WAN links to 3rd party providers and your network looks like a swiss cheese. It's VERY important to talk about security, even in pre-press. We produce a daily newspaper. If one likes to trash the production for the day then there's no newspaper. Much money lost.
So security IS an issue. The bigger the company, the more important.

Users are stupid. ;-) They delete files, overwrite them and this all by accident. In a big company one has a full-day job restoring thise files from the latest backup(s).

You should NOT call somebody SUDO-UNIX when he knows his job.

:wq! PoC

---

From: "Lancaster, David Matthew" <[email-masked]>
Date: Thu, 8 Jun 2000 14:12:24 -0300 (ADT)

> Users are stupid. ;-) They delete files, overwrite them and this all
> by accident. In a big company one has a full-day job restoring thise
> files from the latest backup(s).

And especially of late, it's become obvious that the lower a user's
permissions are, the less damage he can inflict when he double-clicks on
an email attachment. (Not exactly Mac/netatalk relevant, but an important
security consideration)

David Lancaster                       (506) 454-2167
  690 Gregg Ct.                       Upper Apartment
  Fredericton, NB  Canada             E3B 4H5
  [email-masked]       "Don't anthropomorphize computers, they hate that."

---

From: Lance Levsen <[email-masked]>
Date: Fri, 09 Jun 2000 00:38:31 -0600

Patrik Schindler <[email-masked]> writes

> You should NOT call somebody SUDO-UNIX when he knows his job.

Thank you for tactfully bringing the concepts of real world IS to the user. 

"security and all that UNIX paranoia" [sic]. Mon Dieu!

Cheers, 

-- 
Lance Levsen, Programmer
Product Innovation,Web Development
PWGroup - S'toon.
477-3166