Subject: netatalk will not accept password with 1.4b2+asun2.1.4

From: "S.Ecker" <[email-masked]>
Date: Tue, 30 May 2000 13:03:32 -0700 (PDT)

Hi,

I installed pre-asun2.1.4-39_test.tar.gz, everything
compiled nicely.  I'm using redhat6.2 with pam and
shadowpasswords enabled.  My Mac clients try to log on
using cleartext passwords and get the error: "Sorry
the password you entered is incorrect. Please re-enter
it."  All that I can figure went wrong is I may have
overlooked configuring pam support when compiling. 
The documentation said it would see if pam was
installed and compile it automatically if it was.  I
put .passwd in each users directory and chmod 770 it.
I used 2.1.4-39_test on the recommendation that it was
actually a fully working version with lots of the bugs
worked out from earlier versions.  Does anyone else
wish that netatalk was as easy to setup as samba?

-Scott
--------------------
My afpd.conf
"server" -tcp -ddp -port 548 -address 192.168.254.2
 -cleartxt-noguest -uampath /usr/local/atalk/etc/uams
 -uamlist uams_clrtxt.so, uams_pam.so

--------------------
My atalkd.conf
eth0 -phase 2 -net 0-65534 -addr 65280.53

--------------------
My netatalk.conf
AFPD_MAX_CLIENTS=20
ATALK_NAME=server
AFPD_GUEST=nobody
ATALKD_RUN=yes
PAPD_RUN=yes
AFPD_RUN=yes
ATALK_BGROUND=yes

--------------------
/var/log/messages says when starting up and attemping
to logon:
May 30 12:43:17 server atalkd[927]: restart
(1.4b2+asun2.1.4)
May 30 12:43:18  atalkd[927]: zip_getnetinfo for eth0
May 30 12:43:37 server last message repeated 2 times
May 30 12:43:47 server atalkd[927]: config for no
router
May 30 12:43:48 server atalkd[927]: ready 0/0/0
May 30 12:43:48 server atalk: atalkd startup succeeded
May 30 12:44:01 server papd[940]: restart
(1.4b2+asun2.1.4)
May 30 12:44:01 server papd[940]: No such printer: lp
May 30 12:44:01 server papd[940]: printcap problem: lp
May 30 12:44:01 serfer atalk: papd startup succeeded
May 30 12:44:01 server atalk: afpd startup succeeded
May 30 12:44:07 server papd[940]: register
server:LaserWriter@*
May 30 12:44:07 server afpd[949]: server:AFPServer@*
started on 65280.53:1
30 (1.4b2+asun2.1.4)
May 30 12:44:07 server afpd[949]: ASIP started on
192.168.254.2:548(2) (1.4b2
+asun2.1.4)
May 30 12:44:07 server afpd[949]: uam: uams_clrtxt.so
loaded
May 30 12:44:07 server afpd[949]: uam: "Cleartxt
Passwrd" available
May 30 12:49:30 server afpd[968]: ASIP session:548(2)
from 192.168.254.17:208
6(0)
May 30 12:49:30 server afpd[949]: server_child[1] 968
done
May 30 12:49:41 server afpd[969]: ASIP session:548(2)
from 192.168.254.17:208
7(0)
May 30 12:49:41 server afpd[969]: cleartext login:
user1
May 30 12:49:41 server afpd[969]: 0.08KB read, 0.07KB
written
May 30 12:49:41 server afpd[949]: server_child[1] 969
done
May 30 12:50:03 server afpd[972]: ASIP session:548(2)
from 192.168.254.55:491
52(0)
May 30 12:50:03 server afpd[949]: server_child[1] 972
done
May 30 12:50:14 server afpd[973]: ASIP session:548(2)
from 192.168.254.55:491
53(0)
May 30 12:50:14 server afpd[973]: cleartext login:
user1
May 30 12:50:14 server afpd[973]: 0.08KB read, 0.07KB
written
May 30 12:50:14 server afpd[949]: server_child[1] 973
done

__________________________________________________
Do You Yahoo!?
Kick off your party with Yahoo! Invites.
http://invites.yahoo.com/

---

From: "Scott R. Every" <[email-masked]>
Date: Wed, 31 May 2000 15:08:30 -0400

I too am having the same trouble.  Does anyone know which was the last 
version that supported cleartext pw's?

s

--
Scott R. Every - mailto:[email-masked]
EMJ Internet - http://www.emji.net
voice : 1-888-258-8959  fax : 1-919-363-4425

---

From: Patrik Schindler <[email-masked]>
Date: Wed, 31 May 2000 23:34:06 +0200

>version that supported cleartext pw's?

asun 2.1.3

:wq! PoC

---

From: "Scott R. Every" <[email-masked]>
Date: Wed, 31 May 2000 18:00:09 -0400

so no version of the 2.1.4 series will work?
why was this done?

s

---

From: Patrik Schindler <[email-masked]>
Date: Thu, 1 Jun 2000 00:11:01 +0200

>so no version of the 2.1.4 series will work?

2.1.4 works for me and many others very fine.

>why was this done?

Usually, encrypted passwords will improve security. So it was done.

I had problems because I don't use PAM and had to apply the separate -lcrypt to the Makefile and something in the source to get it working.

:wq! PoC

---

From: Tim Carlson <[email-masked]>
Date: Wed, 31 May 2000 16:18:45 -0600 (MDT)

> so no version of the 2.1.4 series will work?

It will work. I think Patrik may have been asleep when he said that :)
I'm using pre-asun2.1.4-37b.tar.gz on Solaris with cleartext.

Tim

Tim Carlson                                  Voice:    (505) 984-8800x255
Director of Computing: Santa Fe Institute    Fax:      (505) 982-0565
WWW: http://www.santafe.edu/~tim             Email:   [email-masked]

---

From: "Scott R. Every" <[email-masked]>
Date: Wed, 31 May 2000 18:29:51 -0400

> 2.1.4 works for me and many others very fine.

sorry, with cleartext pw's.  i know it works, but if you can't login its 
not very useful.

> I had problems because I don't use PAM and had to apply the separate
> -lcrypt to the Makefile and something in the source to get it working.

i'm using slackware 7.0 which does support glic and crypt.  what 
authentication method would you suggest that
1) does not use PAM
2) does not require anything special on the client side

thanx

s

---

From: Patrik Schindler <[email-masked]>
Date: Thu, 1 Jun 2000 00:35:05 +0200

>sorry, with cleartext pw's.  i know it works, but if you can't login its 

It works even with cleartext-pws for me and others.
I'm sorry, I should have stated this clearer.

>2) does not require anything special on the client side

The same as me :-)

I followed the suggestions from Philipp Trautmann:

>At 7:04 Uhr +0200 23.05.2000, Philipp Trautmann wrote:
>
>>here are the steps needed to make this setup work:
>>
>>1. Verify the presence of /usr/include/shadow.h, /lib/libcrypt.so.1,
>>/usr/lib/libcrypt.a and /usr/lib/libcrypt.so in your system (the path
>>might be different, but make must be able to find them)
>>
>>2. Under the netatalk tree, insert the following lines near the top of
>>etc/afpd/auth.c and etc/afpd/uam.c:
>>
>>#ifdef SHADOWPW
>>#include <shadow.h>
>>#endif SHADOWPW
>>
>>3. Add -DSHADOWPW to the CFLAGS in etc/afpd/Makefile and 
>>etc/uams/Makefile.
>>
>>4. In sys/linux/Makefile change "ADDLIBS=" to "ADDLIBS= -lcrypt -lrpcsvc".
>>
>>5. Compile and install. Test.

I modified step 3: I added -DSHADOWPW to sys/linux/Makefile in the appropriate CFLAGS section instead.

This works perfectly for me.

:wq! PoC

---

From: "Scott R. Every" <[email-masked]>
Date: Thu, 01 Jun 2000 22:44:42 -0400

I followed these instructions for 2.1.4pre39 and this is what i get in the 
logs:
Jun  1 22:43:28 beast afpd[11868]: ASIP session:548(1) from 
207.100.35.247:49763
(2)
Jun  1 22:43:28 beast afpd[11523]: server_child[1] 11868 done
Jun  1 22:43:34 beast afpd[11870]: ASIP session:548(1) from 
207.100.35.247:49764
(2)
Jun  1 22:43:34 beast afpd[11870]: dhx login: scott
Jun  1 22:43:34 beast afpd[11870]: 0.17KB read, 0.13KB written
Jun  1 22:43:34 beast afpd[11523]: server_child[1] 11870 done

it will not let me login at all.

any other suggestions?

s

---

From: "Scott R. Every" <[email-masked]>
Date: Thu, 01 Jun 2000 23:01:22 -0400

oops, nevermind.
i missed the -DSHADOWPW part

it does work.  thank you very much!

s

---

From: Patrik Schindler <[email-masked]>
Date: Fri, 2 Jun 2000 08:39:15 +0200

>it does work.  thank you very much!

Fine! How could we feed this to the FAQ-o-matic?

:wq! PoC

---

From: "Hirokazu Nomoto" <[email-masked]>
Date: Mon, 5 Jun 2000 19:47:12 +0900

Hi!
I haved same problem. now i solved it.
The pre-asun2.1.4-37b and 38b,39b have same problem.
I did clean install by following.
  vi Makefile
  make
  make install
The result is no error, but not copied file under /usr/lib/atalk/uams/.

My workarround is:
  mkdir /usr/lib/atalk
  mkdir /usr/lib/atalk/uams
  vi Makefile
  make
  make install

OR
  vi Makefile
  make
  make install
  make install

[email-masked]

-----Original Message-----
From: S.Ecker [mailto:[email-masked]]
Sent: Wednesday, May 31, 2000 5:04 AM
To: [email-masked]
Subject: netatalk will not accept password with 1.4b2+asun2.1.4

Hi,

-Scott
--------------------
My afpd.conf

--------------------
My atalkd.conf

--------------------
My netatalk.conf
AFPD_MAX_CLIENTS=20
ATALK_NAME=server
AFPD_GUEST=nobody
ATALKD_RUN=yes
PAPD_RUN=yes
AFPD_RUN=yes
ATALK_BGROUND=yes

--------------------