Subject: RE: Printcap problem... EPSON almost there

From: Sean Page <[email-masked]>
Date: Thu, 25 May 2000 09:29:42 -0600

Excellent!
How did you get the Epson driver to recognize the printer spool? I tried to
do the same thing, but was unable to get the printer to show up in the
chooser with the Epson AT driver...
I ended up using LaserWriter 8 with ghostscript for PS conversion...

Sean.

> ----------
> From: 	John Grieg
> Sent: 	Thursday, May 25, 2000 8:09 AM
> To: 	[email-masked]
> Subject: 	Re: Printcap problem... EPSON almost there
> 
> I have successfylly set up papd.conf with an Epson 3000
> 
>  File '/etc/netatalk/papd.conf':
> 
> Epson \:EpsonLQ2:op=lp:pr=lp:
> 
> This works well from the Mac (I had to disable chech printer before
> printing),
> choosing an AT-Stylus (?) ---> Epson  in the Chooser.
> 
> ( I AM USING EPSONs OWN PRINTER software (NOT A LASERWRITER))
> 
> 
> and the linux box sends the job (raw data) to the printer.
> 
> There is only one problem -- there is too much "linefeed"
> i.e. a red square would print as
> 
> red stripe
> white stripe
> red stripe
> white stripe
> red stripe
> 
> 
> 
> Any ideas
> 
> [email-masked]
> 
> 
>

---

From: "Tom Watson" <[email-masked]>
Date: Thu, 25 May 2000 12:18:20 -0800

> I ended up using LaserWriter 8 with ghostscript for PS conversion...
<<<deletia>>>

The 'secret' is to make the 'type' that is registered via 'papd' to
be "EpsonLQ2".  I found out by looking at some packet tracings of the
NBP packets that the Epson chooser module emits.  The ':' needs to be
escaped (with a '\') since that is how the NBP software likes the
entity passed to it.  See nbp_name(3) for how things are parsed.

I've got similar problems with an Epson Color Stylus printer.  The spool
is a little 'wierd'.  I'm still investigating.  But I see that you
didn't need to specify a pipe as part of the printer.  I haven't
gotten THAT part to function yet.

-- 
Tom Watson         Generic short signature
[email-masked]     (I'm at home now)

---

From: Sean Page <[email-masked]>
Date: Mon, 29 May 2000 09:19:24 -0600

Well, keep us posted on your progress, many of us are interested!

Thanks!
Sean

> ----------
> From: 	Tom Watson
> Sent: 	Thursday, May 25, 2000 2:18 PM
> Subject: 	RE: Printcap problem... EPSON almost there
>