Subject: print/papd issues

From: Dejan Muhamedagic <[email-masked]>
Date: Thu, 27 Jan 2000 16:18:57 +0100

Hello,

I've spent a lot of time to install appletalk->linux print
spool.  The problem was that papd runs as root and it
passes the print request by creating the file in spool
directory of the destination printer.  The file is created
with permissions "root.root 640" and lpd is not able to read
it.  The remedy was to

# chgrp lpd papd; chmod g+s papd

The other one would probably be to specify

pr="|lpr -Plw"

in papd.conf.

A couple of questions regarding spooling jobs:

1.  Can anybody say just when does it pay off to do
        Mac-(appletalk)->Linux-(tcp print)->Printer
instead of 
        Mac-(appletalk)->Printer
the point being to use big hard disk on Linux to relieve the
Mac application given that the Printer speaks both Appletalk
and TCP print.

2.  Would I be better off with the LPRng in place of good,
old, sometimes-so-problematic lpr?  Any good/bad experience
with LPRng?

The Linux distribution is SuSE 6.3/Alpha, with lprold.rpm
v3.0.46 and netatalk is pre-asun2.1.4-36a.

Cheers.

-- 

Dejan Muhamedagic   mailto:[email-masked]
UNIX and Linux Support   mailto:[email-masked]

Quant-X Service & Consulting Ges.m.b.H.  http://www.quant-x.com
Phn: +43 4212 90555-0     Fax: 90555-20    Free: +800 90555 000

---

From: andrew morgan <[email-masked]>
Date: Thu, 27 Jan 2000 09:50:10 -0800 (PST)

> The other one would probably be to specify

Another member of this mailing list (sorry, forgot the name) posted a
patch to papd so that it would change the ownership of the file to allow
lpd to read it.  I was hoping to roll that patch into my own papd patches
when I finish my own changes.

> old, sometimes-so-problematic lpr?  Any good/bad experience

I've been very happy with LPRng.  We're using it to handle about 40
printers and many thousands of jobs per day.  We use Samba and Netatalk as
front-ends to the system.  We have always used the pr=|lpr -Pblah method
in papd.conf though.  This is much more reliable than letting papd stick
its hands in the spool directory...

	Andy