Subject: afpd not reading AppleVolumes.*?

From: Rolf <[email-masked]>
Date: Wed, 3 May 2000 18:23:42 +1000

hello

I have just installed (and am new to netatalk in general) 1.4b2+asun2.1.3.

All appears ok with atalkd, afpd and papd all showing up in the process list.

I can connect using the Mac chooser ok but nothing I put in AppleVolumes.default or AppleVolumes.system is seen and recognised. I don't think afpd is reading those files at all as I get my home directory (due to the ~ in AppleVolumes.default?) but if rename or delete that file it makes no difference. Similarly putting volume path names into it is not seen.

Conversely the $HOME/AppleVolumes file works perfectly - whatever I place in there shows up ok for whichever user I do it for.

I have done a completely default install. So the daemons launch from /usr/local/atalk/etc/* and the AppleVolumes files are in the same directory. I have tried launching afpd with -f /explicit-path-to-files and -s ... but no difference. Likewise guest user does not see any listed volumes.

Running afpd -d ie in the foreground to see what it does shows no indication of reading the volumes files (does it ever?).

So I've run out of ideas and would very much appreciate any help.

Many thanks

Rolf.

---

From: Rolf <[email-masked]>
Date: Thu, 4 May 2000 10:08:06 +1000

hello,

The problem was the permissions of the two files AppleVolumes.default and AppleVolumes.system. They were set to read/write by owner (root) only. Setting them to readable by anyone fixes the problem. I don't know the reason for this (afpd is owned by root ...), but as I don't know the inner workings at all, if someone would care to enlighten me. I can only presume that the connecting user's id is somehow relevant when afpd advertises the available volumes.

Thanks to John Chia <[email-masked]> for suggesting that the files may not have been readable; so alerting me to check permissions.

r.