Subject: login solved but codepage still broken in netatalk-1.4.99-0.20001108.tar.gz

From: Frank Joerdens <[email-masked]>
Date: Sun, 19 Nov 2000 18:22:37 +0100

My login issues were solved with the ./configure --with-shadow option, but the codepage
support seems still broken. The codepage stuff was working in pre-asun2.1.4-37b.tar.gz
(where i couldn't get authentication working because I don't know how to enable the
shadown passoword stuff in the Makefile; and also, there was the funny issue with the tmp
volume that was nowhere configured but appeared anyway . . . ), but not anymore in
pre-asun2.1.4-38b_test.tar.gz.

Now, working with the sourceforge sources, everything is nicer - a decent ./configure
interface, and everything looks much smoother. But what to do about the codepage support?

If the /etc/atalk/nls/maccode.iso8859-1 isn't there or if I use the wrong one (I tried
using the one from the older sources), netatalk will complain:

/etc/atalk/nls/maccode.iso8859-1: codepage version not supported

 . . . which leads me to conclude that they do get loaded (no error if I do makecode under
/etc/atalk/nls to generate the codepages, which is documented nowhere by the way) but
unfortunately to no avail . . . 

- Frank

---

From: Dick Visser <[email-masked]>
Date: Mon, 20 Nov 2000 23:26:00 +0100 (CET)

Perhaps a stupid question, but when I unpack the sources, alot of files
are symlinks to files I don't have (on my mandrake 7.2 box).
Also when I tried to compile it on OpenBSD2.7 I did have the files but
the links were poiting at the wrong directory (the assumed /usr/local
should have been /usr/share/local). When I fixed the links I got piles of
errors when I tried to make the thing (Error:** Stop, or something like
that..). The ./configure prior to that was very quit though.....
I checked the makefile on what error in what line but that was too much
for me as a non-programmer ;-)

Bye
-- 

Dick Visser
Amsterdam
The Netherlands
www.tienhuis.nl
linux - mac

---

From: Dick Visser <[email-masked]>
Date: Mon, 20 Nov 2000 23:34:08 +0100 (CET)

> are symlinks to files I don't have (on my mandrake 7.2 box).

I didn't have the right packages installed. After I installed:

automake-1.4-14mdk.noarch.rpm
libtool-1.3.5-2mdk.i586.rpm

all the links were resolved.

> for me as a non-programmer ;-)

Havent looked after this yet.

-- 

Dick Visser

---

From: Dick Visser <[email-masked]>
Date: Mon, 20 Nov 2000 23:54:32 +0100 (CET)

Hi

On the homepage / docs / HowToUseServermessages I see a hint telling that
if you use --with-msg-dir as an option for configure, netatalk is able to
message users. Ok thats nice but what other options are there with
configure?
I tried ./configure --help but that gives me only the general options of
configure (I guess?).
Is there a way to check out all the possible options for configure with
netatalk?
Sorry if this this is a general configure question.

-- 

Dick Visser