Subject: Modules not loading with asun2.1.4pre39

From: "jeff b" <[email-masked]>
Date: Mon, 05 Jun 2000 21:08:09 +0000 (GMT)

For one reason or another, none of my UAMs will load, with the exceptions
of uams_randnum.so and uams_guest.so

here's a startup (with all modules except uams_guest.so):
----
Jun  5 15:40:38 test atalk: afpd startup succeeded
Jun  5 15:40:44 test afpd[17596]: test:AFPServer@* started on 5919.27:128
(1.4b2+asun2.1.4)
Jun  5 15:40:44 test afpd[17596]: ASIP started on (ip-address-here):548(1)
(1.4b2+asun2.1.4)
Jun  5 15:40:44 test afpd[17596]: uam: uams_randnum.so loaded
Jun  5 15:40:44 test afpd[17596]: uam: "2-Way Randnum exchange" available
Jun  5 15:40:44 test afpd[17596]: uam: "Randnum exchange" available
----

and here is one with all but uams_randnum.so:
----
Jun  5 15:53:40 test atalk: afpd startup succeeded
Jun  5 15:53:46 test afpd[23168]: test:AFPServer@* started on 5972.200:128
(1.4b2+asun2.1.4)
Jun  5 15:53:46 test afpd[23168]: ASIP started on (ip-address-here):548(1)
(1.4b2+asun2.1.4)
Jun  5 15:53:46 test afpd[23168]: uam: uams_clrtxt.so loaded
Jun  5 15:53:46 test afpd[23168]: uam: "Cleartxt Passwrd" available
----

All uams in the directory were specified (with one exception, in each
case), and yet only those two modules were loaded.

Also, has anyone had any luck forcing netatalk to use /etc/afppasswd
instead of ~/.passwd (~/.passwd is such a pain to maintain....)?
     
*************************
jeff b
system administrator
university communications
university of connecticut
[email-masked]

---

From: Dejan Muhamedagic <[email-masked]>
Date: Tue, 6 Jun 2000 21:16:04 +0200

Hi,

> case), and yet only those two modules were loaded.

Do you mean specified in the startup file as arguments to afpd?
Are you definitely sure that this is the case?  Because, if an UAM
can't be loaded then an error message should be issued.  You
should be able to see how afpd was started by using 'ps auxw |
grep afpd' and looking at the process which is running as root.
Or trace (set -x) the startup script.

If UAMs are specified on the line, don't load and there are no
error messages than I'm in a complete dark.

Best regards,

Dejan