Subject: Re: compiling problems

From: ian reinhart geiser <[email-masked]>
Date: Tue, 21 Mar 2000 14:31:30 -0600 (CST)

On Tue, 21 Mar 2000, Patrik Eriksson wrote:

	i get the same thing under Alpha Linux.  I think it is
	a problem with RH 6.1 cause the SRPM will not even build.

	-ian reinhart geiser

> Hi,
> 
> I'm new to this list and I don't know if this has been up before.
> 
> When compiling netatalk 1.4b2+asun2.1.3 I recevie this error message.
> 
> gcc  -DNEED_QUOTACTL_WRAPPER   -DUAM_RNDNUM -O2 -fomit-frame-pointer
> -fsigned-ch
> ar -Wunused -Wuninitialized -I../../include   -I/usr/local/include
> -DUSE_PAM -
> DAPPLCNAME  -o afpd unix.o afs.o kuam.o send_to_kdc.o lifetime.o ofork.o
> main.o
> switch.o auth.o volume.o directory.o file.o enumerate.o desktop.o filedir.o
> fork
> .o appl.o gettok.o bprint.o status.o afp_options.o afp_asp.o afp_dsi.o
> messages.
> o config.o nfsquota.o codepage.o -L../../libatalk    -L/usr/local/lib
> -latalk
>   -ldes  -lrpcsvc -lwrap -lpam -ldl
> /usr/lib/libwrap.a(hosts_access.o): In function `host_match':
> hosts_access.o(.text+0x400): undefined reference to `yp_get_default_domain'
> collect2: ld returned 1 exit status
> make[4]: *** [afpd] Error 1
> make[4]: Leaving directory `/root/netatalk-1.4b2+asun2.1.3/etc/afpd'
> make[3]: *** [all] Error 2
> make[3]: Leaving directory `/root/netatalk-1.4b2+asun2.1.3/etc/afpd'
> make[2]: *** [afpd] Error 2
> make[2]: Leaving directory `/root/netatalk-1.4b2+asun2.1.3/etc'
> make[1]: *** [../../etc] Error 2
> make[1]: Leaving directory `/root/netatalk-1.4b2+asun2.1.3/sys/linux'
> make: *** [all] Error 2
> 
> Is there some wrong with the libwrap.a file (like; need a patch etc) or do I
> have to make a change in some the Makefiles?
> 
> I'm running RedHat 6.1 with 2.2.14 kenel.
> 
> Hope that some of you can help me.
> Thanks in a advance
> 
> Patrik Eriksson
> 

-------------------------------------------------
Ian Reinhart Geiser <[email-masked]>
DEC Unix Systems Adimistrator and
	Computer Engineering Student
http://www.msoe.edu/~geiseri/finger.phtml

---

From: anthony <[email-masked]>
Date: Tue, 21 Mar 2000 16:22:34 -0500

>         a problem with RH 6.1 cause the SRPM will not even build.

i had no problems with RH6.1 using the default kernel (2.2.12). mayhaps
you didn't compile appletalk into the kernel? do a "dmesg | grep Apple"
as shown in the anders HOWTO.

for the record, the RPM i used is shown below. an important thing to
note is that the config files are all in /etc/atalk/, even tho copies of
those files also get installed at /etc/ 

ftp: contrib.redhat.com

/pub/contrib/libc6/i386/netatalk-1.4b2+asun2.1.3-7.i386.rpm

the one for alpha is here

/pub/contrib/libc6/alpha/netatalk-1.4b2+asun2.0a18.2-oa1.alpha.rpm