Subject: Netatalk and Transfer between MAC and Windows NT

From: "Jürgen Knott" <[email-masked]>
Date: Tue, 25 Jul 2000 08:18:24 +0200

Hi!
I have a problem with netatalk (fron SUSE6.3 Distribution).
When a file is transfered from a MAC on the Linuxcomputer, they will be
created a file called icon. This file have a length from 0 Byte. How can i
make that this file is not created?

When i transfer a file to the Linux Computer from the Mac, and the file is
longer 27 chars, the File is not seen on a Windows Computer. How can i
change it?

Thanks a lot

Greetings Juergen

---

From: "Marc J. Miller" <[email-masked]>
Date: Mon, 24 Jul 2000 23:52:46 -0700

I'm not sure those problems can be solved, as I think they're *designed* to work that way.  But I can tell you a possible reason *why* it does that.

Well, the icon is a 0-byte file because the real data is in the resource.frk folder or the .appledouble folder.  It's a 0-byte file with resources (basically, the Macintosh header for the file) that are stored elsewhere.  The system wouldn't know to look for Icon's resources unless there was a placeholder.  As for file names larger than 27 characters not being seen by Windows (at least, I think that's what you're talking about), there is a limit to how long a Windows file name can be.  It may be 27 characters.  It may be that Windows NT chooses to ignore files that long rather than deal with chopping off the end of it and try to track that "really long file name which " is actually "really long file name which is more than 27 characters long" and not "really long file name which is at least 40 characters long" (each would be truncated the same way).

----- Original Message ----- 
  From: Jürgen Knott 
  To: [email-masked] 
  Sent: Monday, July 24, 2000 11:18 PM
  Subject: Netatalk and Transfer between MAC and Windows NT

  Hi!
  I have a problem with netatalk (fron SUSE6.3 Distribution).
  When a file is transfered from a MAC on the Linuxcomputer, they will be created a file called icon. This file have a length from 0 Byte. How can i make that this file is not created?

  When i transfer a file to the Linux Computer from the Mac, and the file is longer 27 chars, the File is not seen on a Windows Computer. How can i change it?

  Thanks a lot

  Greetings Juergen

---

From: Harry Zink/Netatalk List <[email-masked]>
Date: Tue, 25 Jul 2000 00:16:26 -0700

on 7/24/00 11:18 PM, Jürgen Knott at [email-masked] wrote:

> longer 27 chars, the File is not seen on a Windows Computer. How can i change
> it?

Don't know about the icon problem, but this sounds like something you need
to set and configure in SAMBA, not netatalk.

Harry

---

From: Hauke Fath <[email-masked]>
Date: Tue, 25 Jul 2000 09:34:39 +0200

>to set and configure in SAMBA, not netatalk.

Exactly. You need something like

delete veto files = Yes
veto files = /.AppleDouble/.AppleDesktop/Network Trash 
Folder/DesktopFolderDB/resource.frk/ICON?/Icon?/TheVolumeSettingsFolder/TheFindByContentFolder/

in your Samba smb.conf (the "veto files" entry is one line, whatever 
your mailer may say ;).

	hauke

-- 
Hauke Fath                        Tangro Software Components GmbH
                                         D-69115 Heidelberg
[email-masked]                       Ruf +49-6221-13336-35, Fax -21