Subject: Re: Re: [Netatalk-devel] Antwort: Re: Compiling netatalk-1.4.99 - ARRGGHH!!!

From: [email-masked]
Date: Mon, 9 Oct 2000 10:14:31 +0200

Now that I had the weekend to NOT think about netatalk I resume the hunt for
errors.

>#if defined(__EXTENSIONS__) || \
>        (!defined(_POSIX_C_SOURCE) && !defined(_XOPEN_SOURCE))
>struct comment {
>        char    *c_dept;
>        char    *c_name;
>        char    *c_acct;
>        char    *c_bin;
>};
>#endif /* defined(__EXTENSIONS__) || (!defined(_POSIX_C_SOURCE) && ... */
>
>We could probably seach-and-replace 'comment' in the papd source for a
>different name.
>
>As a temporary fix, you might try adding a "#undef __EXTENSIONS__" to
>etc/papd/queries.c to get it to compile.

Adding #undef __EXTENSIONS__ at the beginning of queries.c did not help -
apparently _POSIX_C_SOURCE and _XOPEN_SOURCE are NOT defined. (Defining one of
them removed the former error but others appeared.).

How long do you think it would take you/the developpers to change 'comment' into
something like 'atalk_comment'?

WDL.

---

From: andrew morgan <[email-masked]>
Date: Mon, 9 Oct 2000 08:44:28 -0700 (PDT)

> something like 'atalk_comment'?

I've commited the change to CVS now.  I renamed 'struct comment' to
'struct papd_comment'.  It seems to compile fine, but I don't have a
system to test papd on right now.

	Andy