Subject: netatalk doesn't work

From: Claus Atzenbeck <[email-masked]>
Date: Wed, 8 Nov 2000 08:58:52 +0100 (CET)

I have Linux Mandrake 7.2 and netatalk-1.4.99-0.20000927mdk.

I cannot use file sharing from my Mac, because after I enter my Linux
user name and password, my Mac tells me that the file server is not
reachable at the moment.

This is my /etc/atalk/netatalk.conf file:

*****
AFPD_MAX_CLIENTS=20
ATALK_NAME=`echo ${HOSTNAME}|cut -d. -f1`
AFPD_UAMLIST="-U uams_clrtxt.so,uams_randnum.so,uams_dhx.so,uams_guest.so"
AFPD_GUEST=nobody
ATALKD_RUN=yes
PAPD_RUN=yes
AFPD_RUN=yes
ATALK_BGROUND=no
*****

Any idea what could be wrong?

I appreciate any help!
Claus.

---

From: andrew morgan <[email-masked]>
Date: Wed, 8 Nov 2000 00:48:20 -0800 (PST)

> AFPD_UAMLIST="-U uams_clrtxt.so,uams_randnum.so,uams_dhx.so,uams_guest.so"

Have you tried to the connect over TCP/IP by clicking the Server IP
Address button in the chooser?

	Andy

---

From: Claus Atzenbeck <[email-masked]>
Date: Wed, 8 Nov 2000 10:13:00 +0100 (CET)

> Address button in the chooser?

Same thing: After typing in my Linux user name and password, my Mac
tells me that it cannot make the connection to the server.

Maybe my config files have errors? E.g. AFPD_UAMLIST was originally
commented out, but then I only was able to log in as guest.

Any ideas?

Thanks so much!
Claus.

---

From: Wes Yates <[email-masked]>
Date: Wed, 08 Nov 2000 06:24:24 -0500

>Any idea what could be wrong?

Claus, I could have your request incorrect, but do you have AppleTalk 
compiled in to the kernel OR as an insertable module? Try `dmesg | grep -i 
apple` and look for a response regarding AppleTalk. If you do not see 
anything, you need to rebuild the kernel with AppleTalk inside or as a module.

The other part could be, if you do see the server, you may be having 
problems with PAM or shadow passwords. That I have no idea how to correct. 
I have problems with the new 1.4+asun2.1.4 netatalk. I suggest get the 
source for the netatalk+asun (2.1.4) and compile that and see if that works 
better.

It already looks as though you have a recent version of atalk and I can't 
determine if its the asun version or not, but I bet it isn't.

I would look at /var/log/messages and see if you can find out what is or 
isn't loading when you start netatalk. I had little luck, but I do know 
that uams_dhx.so loaded on the compiled version, but I couldn't log in, but 
when I installed the RPM, ums_dhx.so didn't load but I _was_ able to login.

hope that helps

-Wes Yates
Netatalk Admin
Arts Engraving Company.

"The box said it 'Requires Windows95 or better.' So I installed Linux"

---

From: Claus Atzenbeck <[email-masked]>
Date: Wed, 8 Nov 2000 16:46:25 +0100 (CET)

Wes, first of all, thanks for your mail!

> compiled in to the kernel OR as an insertable module? Try `dmesg | grep -i 

$ dmesg |grep -i apple
NET4: AppleTalk 0.18 for Linux NET4.0

> source for the netatalk+asun (2.1.4) and compile that and see if that works 

I have installed: netatalk-1.4.99-0.20000927mdk.i586.rpm
I also tried:     netatalk-1.4b2+asun2.1.3-6.i386.rpm

The second one used to work with Mandrake 7.1, but now I have Mandrake
7.2... both versions doesn't work.

> determine if its the asun version or not, but I bet it isn't.

asun is not part of the rpm file name, so I guess it is not included.
What stands asun for anyway? It seems to be the "official" newest
version.

> when I installed the RPM, ums_dhx.so didn't load but I _was_ able to login.

This is what /var/log/messages says when restarting atalk services:

Nov  8 16:33:17 thor atalk: papd shutdown succeeded
Nov  8 16:33:19 thor timelord[1562]: Can't unregister thor
Nov  8 16:33:22 thor atalk: timelord shutdown succeeded
Nov  8 16:33:23 thor atalkd[1518]: done
Nov  8 16:33:23 thor atalk: atalkd shutdown succeeded
Nov  8 16:33:23 thor afpd[1572]: shutting down on signal 15
Nov  8 16:33:24 thor atalk: afpd shutdown succeeded
Nov  8 16:33:24 thor atalkd[4187]: restart (1.5)
Nov  8 16:33:25 thor atalkd[4187]: zip_getnetinfo for eth0
Nov  8 16:33:44 thor last message repeated 2 times
Nov  8 16:33:54 thor atalkd[4187]: config for no router
Nov  8 16:33:56 thor atalkd[4187]: ready 0/0/0
Nov  8 16:33:56 thor atalk: atalkd startup succeeded
Nov  8 16:34:09 thor papd[4199]: restart (1.5)
Nov  8 16:34:09 thor atalk: papd startup succeeded
Nov  8 16:34:09 thor papd[4199]: No such printer: lp
Nov  8 16:34:09 thor papd[4199]: printcap problem: lp
Nov  8 16:34:09 thor atalk: timelord startup succeeded
Nov  8 16:34:09 thor atalk: afpd startup succeeded
Nov  8 16:34:15 thor papd[4199]: Authentication disabled: HP-DeskJet500
Nov  8 16:34:15 thor papd[4199]: register HP-DeskJet500:LaserWriter@*
Nov  8 16:34:15 thor timelord[4209]: thor:TimeLord started
Nov  8 16:34:15 thor afpd[4219]: thor:AFPServer@* started on 65280.29:250 (1.5)
Nov  8 16:34:15 thor afpd[4219]: ASIP started on 192.168.1.1:548(1) (1.5)
Nov  8 16:34:15 thor afpd[4219]: uam: uams_randnum.so loaded
Nov  8 16:34:15 thor afpd[4219]: uam: uams_guest.so loaded
Nov  8 16:34:15 thor afpd[4219]: uam: "No User Authent" available
Nov  8 16:34:15 thor afpd[4219]: uam: "2-Way Randnum exchange" available
Nov  8 16:34:15 thor afpd[4219]: uam: "Randnum exchange" available

Anything wrong with this?
The only thing I don't understand is that "No such printer: lp",
because I have a printer queue called "lp".

I really appreciate any help I get!
Thanks so much!
Claus.

---

From: Wes Yates <[email-masked]>
Date: Wed, 8 Nov 2000 11:51:10 -0500

>NET4: AppleTalk 0.18 for Linux NET4.0

good.

>I also tried:     netatalk-1.4b2+asun2.1.3-6.i386.rpm

The asun version you have is old. the latest should be 2.1.4

>7.2... both versions doesn't work.

I wonder if it is the kernel or maybe PAM/shadow???

>What stands asun for anyway? It seems to be the "official" newest

Adrian Sun has a source distribution of Netatalk that incorporates 
AppleTalk over TCP/IP. It takes advantage of AppleShare IP Client.

The source I used was from netatalk-1.4b2+asun2.1.4 . I could only 
get clear text passwords and that source wouldn't let me log in as 
anything but "Guest".

>Nov  8 16:34:15 thor afpd[4219]: thor:AFPServer@* started on 

from the above line, it looks as though you have ASIP (AppleShare IP) 
running. I'm curious about the (1.5) though. Mine says 
(1.4b2+asun2.1.4).

>Nov  8 16:34:15 thor afpd[4219]: uam: "Randnum exchange" available

See, I want to know how you got the 2-way Random number to work... 
tell me what uam modules you have... Do you have the uams in 
/etc/atalk/uams or /usr/local/atalk/etc/uams or what?

>because I have a printer queue called "lp".

Mine says the same thing. But I don't use print spooling so...

-- 
-Wes Yates
Arts Engraving
704-523-5115
[email-masked]

"It is now safe to shut off your computer"

Yes. Fitting last words.

---

From: andrew morgan <[email-masked]>
Date: Wed, 8 Nov 2000 10:08:16 -0800 (PST)

> commented out, but then I only was able to log in as guest.

See my other message to this list about symlinks for uams.  I don't know
where your uams directory is located, but make sure you have symlinks for
uams_clrtxt.so and uams_dhx.so.

It might also be a problem with your server's hostname.  What do you have
in your /etc/hosts file?

	Andy

---

From: Claus Atzenbeck <[email-masked]>
Date: Wed, 8 Nov 2000 19:34:18 +0100 (CET)

> I wonder if it is the kernel or maybe PAM/shadow???

I was re-compiling the kernel with appletalk support (module). Just to
make sure.

> >Nov  8 16:33:24 thor atalkd[4187]: restart (1.5)
[...]
> running. I'm curious about the (1.5) though. Mine says 

Indeed, it is running. I even get a login screen on my Mac where I can
put my user name and password or login as guest. After typing my
login, I get the message that the file server cannot be reached.

I have netatalk-1.4.99-0.20000927mdk installed. This might be the
reason why there is version 1.5 at /var/log/messages.

> /etc/atalk/uams or /usr/local/atalk/etc/uams or what?

This is /etc/atalk/uams:

uams_clrtxt.so -> uams_passwd.so
uams_dhx.so -> uams_dhx_passwd.so
uams_dhx_pam.so
uams_dhx_passwd.so
uams_guest.so
uams_pam.so
uams_passwd.so
uams_randnum.so

I made both symlinks. (See Andy Morgan's mail.)
It is still not working. :-(

> Mine says the same thing. But I don't use print spooling so...

Printing isn't working anyway. :-(

I have any clue about where the problem might be. Maybe the config
files?? I need netatalk so badly...

Claus.

---

From: Claus Atzenbeck <[email-masked]>
Date: Wed, 8 Nov 2000 19:38:26 +0100 (CET)

> uams_clrtxt.so and uams_dhx.so.

I made symlinks for both (see my other message), but without success.

> It might also be a problem with your server's hostname.  What do you have

127.0.0.1       localhost.localdomain   localhost
192.168.1.1     thor.germania.lan       thor

But this should be no problem, because I have also tried to connect
via IP at the Mac Chooser. Same thing: I am asked about login and
password and then I am told that the file server cannot be connected.

Claus.

---

From: andrew morgan <[email-masked]>
Date: Wed, 8 Nov 2000 11:03:39 -0800 (PST)

> password and then I am told that the file server cannot be connected.

What do you see in /var/log/messages when netatalk starts and when you
attempt to login?

	Andy

---

From: Claus Atzenbeck <[email-masked]>
Date: Wed, 8 Nov 2000 20:35:48 +0100 (CET)

> What do you see in /var/log/messages when netatalk starts and when you

This happens in /var/log/messages when I try to connect to the
file server from my Mac:

Nov  8 20:32:54 thor afpd[6056]: ASIP session:548(1) from 192.168.1.99:2051(2)
Nov  8 20:32:54 thor afpd[5993]: server_child[1] 6056 done
Nov  8 20:33:03 thor afpd[6058]: ASIP session:548(1) from 192.168.1.99:2052(2)
Nov  8 20:33:03 thor afpd[6058]: randnum/rand2num login: claus
Nov  8 20:33:03 thor afpd[6058]: Failed to open /etc/atalk/afppasswd
Nov  8 20:33:03 thor afpd[6058]: 0.07KB read, 0.07KB written
Nov  8 20:33:03 thor afpd[5993]: server_child[1] 6058 done

I don't have any /etc/atalk/afppasswd file.
What is it for? How does it look like?

Claus.

---

From: jeff <[email-masked]>
Date: Wed, 08 Nov 2000 15:31:14 -0500

> What is it for? How does it look like?

The randnum authentication module uses a password file called
/etc/atalk/afppasswd to authenticate. You can use the afppasswd utility,
which should reside in /usr/bin/, to add users, etc.

jeff

---

From: Wes Yates <[email-masked]>
Date: Wed, 8 Nov 2000 15:54:51 -0500

>I was re-compiling the kernel with appletalk support (module). Just to

Good, I usually compile Appletalk in the kernel, but it really makes 
no difference to me.

>login, I get the message that the file server cannot be reached.

Yes, I see. One member noted I have the asun version and to try the 
source from sourceforge. I had downloaded it and don't seem to have 
"configure".

>It is still not working. :-(

I wondered.

>Printing isn't working anyway. :-(

I haven't tried it on mine, but I will soon.

>files?? I need netatalk so badly...

I have no clue either. Do you have the ability to try compiling or 
installing on another machine/distro?

-- 
-Wes Yates
Arts Engraving
704-523-5115
[email-masked]

Yes. Fitting last words.

---

From: Wes Yates <[email-masked]>
Date: Sat, 11 Nov 2000 21:27:37 -0500

I fixed the problems _I_ had with netatalk. I'm using netatalk+asun2.1.4 
and loving it. I know there is a better, sourceforge version, but I just 
_had_ to get this one working since I did it at home.

I updated the kernel to 2.2.16 and recompiled and installed the netatalk. I 
thought the kernel might have been the culprit. In the +asun version, I 
still don't have 2-way passwords, but, WTF. I'm on an internal lan....

-Wes

At 03:54 PM 11/8/00 -0500, you wrote:
>Good, I usually compile Appletalk in the kernel, but it really makes no 
>difference to me.
>
>>
>Yes, I see. One member noted I have the asun version and to try the source 
>from sourceforge. I had downloaded it and don't seem to have "configure".
>

-Wes Yates
[email-masked]

"The Beer Song"

(Do)  Dough, the stuff that buys me beer.
(Re)  Ray, the guy that sell me beer.
(Mi)  Me, the one that drinks the beer.
(Fa)  Far, a long way to my beer.
(So)  So, I think I'll have a beer.
(La)  La, la, la, la, la, la, beer!
(Ti)  Tea, not thanks, I'll have a beer.

Now that brings us back to Do!