Subject: netatalk & samba

From: Johan Kjellman <[email-masked]>
Date: Sat, 24 Jun 2000 16:53:28 +0200

I have shared a directory on my linuxbox to both Mac and windows, whit
netatalk and samba. But when i create a folder on the mac whit the
swedish characters ÅÄÖ i cant see them on the windows computer.. 
How to i fix this?

Johan Kjellman

---

From: [email-masked] (Hans-Peter Jansen)
Date: Sat, 24 Jun 2000 23:12:10 +0200

> swedish characters ÅÄÖ i cant see them on the windows computer..

Have a look at the iso-codepages. I'm using:

   character set = ISO8859-1

in the global section of /etc/smb.conf and

~ codepage:maccode.iso8859-1 options:mswindows
/ext/mac codepage:maccode.iso8859-1

in my AppleVolumes.default file.

Note that is for 1.42b+2.1.4-3* versions, where
the option format has changed.

Note also, that in my case a few iso-8859-1 codes
where wrong.

Hope, this helps
Cheers
hp

-- 
#define QUESTION ((bb) || !(bb)) /* Shakespeare */

--- makecode.c  Tue Feb 22 11:34:39 2000
+++ makecode-new.c      Wed Apr 19 15:28:01 2000
@@ -9,20 +9,28 @@
 
 /* map of cp10000 (mac roman) to iso-latin-1 */
 static const unsigned char mac_to_isolatin1_map[] = {
+/* 0x80 */
 0xC4, 0xC5, 0xC7, 0xC9, 0xD1, 0xD6, 0xDC, 0xE1,
 0xE0, 0xE2, 0xE4, 0xE3, 0xE5, 0xE7, 0xE9, 0xE8,
+/* 0x90 */
 0xEA, 0xEB, 0xED, 0xEC, 0xEE, 0xEF, 0xF1, 0xF3,
 0xF2, 0xF4, 0xF6, 0xF5, 0xFA, 0xF9, 0xFB, 0xFC,
+/* 0xa0 */
 0x00, 0xB0, 0xA2, 0xA3, 0xA7, 0xB7, 0xB6, 0xDF,
 0xAE, 0xA9, 0x00, 0xB4, 0xA8, 0x00, 0xC6, 0xD8,
+/* 0xb0 */
 0x00, 0xB1, 0x00, 0x00, 0xA5, 0xB5, 0xF0, 0x00,
-0x00, 0x00, 0x00, 0xAA, 0xBA, 0x00, 0xE6, 0xF8,
+0x00, 0x00, 0x00, 0x00, 0xBA, 0x00, 0xE6, 0xF8,
+/* 0xc0 */
 0xBF, 0xA1, 0xAC, 0x00, 0x00, 0x00, 0x00, 0xAB,
 0xBB, 0x00, 0xA0, 0xC0, 0xC3, 0xD5, 0x00, 0x00,
+/* 0xd0 */
 0xAD, 0x00, 0x00, 0x00, 0x00, 0x00, 0xF7, 0x00,
 0xFF, 0x00, 0x00, 0xA4, 0x00, 0x00, 0x00, 0x00,
-0x00, 0x00, 0xB8, 0x00, 0x00, 0xC2, 0xCA, 0xC1,
+/* 0xe0 */
+0x00, 0xB7, 0xB8, 0x00, 0x00, 0xC2, 0xCA, 0xC1,
 0xCB, 0xC8, 0xCD, 0xCE, 0xCF, 0xCC, 0xD3, 0xD4,
+/* 0xf0 */
 0x00, 0xD2, 0xDA, 0xDB, 0xD9 
 /*, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
   0x00, 0x00, 0x00, 0x00, 0x00 */