Subject: Speeding up netatalk

From: John Grieg <[email-masked]>
Date: Fri, 14 Apr 2000 11:55:01 +0100

I have a Pentium 266 Linux Box with 4 SQSI (Adaptec 2940) disks (fast and
wide) 20 Mb, 9Mb, 2x4Mb
and 128 Mb RAM and a 3c905b 100 network card.

I was pretty satisfied with the transfer times (we had NT earlier) at
almost 2 Mb a sec.

Then I read about someone transfering 500 Mb in a minute.

Where should I start to speed up this?
I am seldom transfering more than 100Mb at the same time
There are only 2 Macs transfering much data (the other ones are using DCS
JPEG (kind of OPI))

[email-masked]

---

From: Lutz Michaelsen <[email-masked]>
Date: Fri, 14 Apr 2000 18:23:56 +0200

> Then I read about someone transfering 500 Mb in a minute.

Whow ... 8,3MB/sec. How can they do this?

I think the transfer rate of your hardisks are limiting the thruput.

I'm running a K6-2/300 with rather the same Ultra-SCSI-Controller with 9GB disks
(1-2 years old) and the maximum thruput I can get with ftp/netatalk is around
3-4MB/sec. (with big files). If you have a lot of small files it will slow down.

Do you have a switched network?
How is your Linux box connected to your clients?
Are you using "afpoverip" ?

To accelerate the thruput you can buy faster harddisks (>7200rpm) or configure a
soft raid 0 with your old harddisks.

Best Regards,
Lutz Michaelsen

-- 
EASi-Engineering GmbH		Tel.	++49 (0) 89 / 1407-9872
Pelkovenstr. 81-b		Fax	++49 (0) 89 / 1407-9696
D-80992 Muenchen		eMail 	mailto:[email-masked]
Germany				WWW	http://www.easi.de

---

From: Marcus Radich <[email-masked]>
Date: Sat, 15 Apr 2000 11:22:07 +1200

Greetings

We have over 20 systems (we are a consulting firm, these are in 
client sites) here in NZ which deliver OVER 9MB/sec throughput. We 
have measured this with Helios Lantest and by manually timing large 
copies.

Our servers have insanely fast motherboards and hard disk speeds. Try 
this on your system:

/sbin/hdparm -tT /dev/sda           (or hda, or md0   whatever your disk is)

I ran this on a system we installed last week and the figures were:

Buffer-cache reads: 144MB/sec
Buffered-disk reads: 60.14MB/sec

This 'roughly' shows a fast motherboard and a fast RAID (in this case)

Configuration:
Intel Lancewood motherboard (L440GX+)
Pentium III 550
128MB RAM
4xIBM 34GB Ultra2 drives - software RAID O+1
Digital 21143 based ethernet card (not onboard)

Red Hat 6.1
Netatalk asun2.1.4 37b (with my slight modifications)

The Helios Lantest figures (with a 30MB test file) for this server 
testing from a G4/450 were:
Reads: 9.2MB/sec
Writes: 9.3MB/sec

This is running through a Lucent Cajun P120 switch over 100BaseT.

Make sure your Macs are mounting your netatalk server over IP (get 
info on the server icon to see it's connection type), this makes a 
HUGE difference.

mrad01

>soft raid 0 with your old harddisks.

========================================================

"Always ask the question, never assume the answer."
		Marcus Radich 1999

========================================================

---

From: John L Grantham <[email-masked]>
Date: Sat, 15 Apr 2000 02:02:44 +0200

At 11:22 Uhr +1200 15.04.2000, Marcus Radich wrote:
>Our servers have insanely fast motherboards and hard disk speeds. 
>Try this on your system:
>

Just for grins and giggles...

[root@heorot root]# /sbin/hdparm -tT /dev/sda

/dev/sda:
  Timing buffer-cache reads:   128 MB in  5.65 seconds =22.65 MB/sec
  Timing buffered disk reads:  64 MB in 17.74 seconds = 3.61 MB/sec

This is on the following config (just for comparison):

PowerMac 9500/132
LinuxPPC 2000
144 MB RAM
NarrowSCSI 2 GB Seagate Barracuda HD
On-board Ethernet card

I generally get about 1 or 2 MB/s, depending on what I'm copying 
(yes, I use TCP/IP). I'm running netatalk-1.4b2+asun2.1.3-7.

Just thought it would be fun to compare the two. Of course, the 9500 
gets trounced by that monster of yours, but it's not too shabby... :-)

cya

John
-- 

John Grantham | Dipl.-Designer (FH)
               | Homepage http://surf.to/multimedia
               | Linux for Macs: http://www.maclinux.de/

---

From: Simon Buchanan <[email-masked]>
Date: Sat, 15 Apr 2000 13:51:37 +1200

>gets trounced by that monster of yours, but it's not too shabby... 

 From netfinity 3000 with 128MB and RAID 2x 9.1GB IBM SCSI 3:

  Timing buffer-cache reads:   128 MB in  1.06 seconds =120.75 MB/sec
  Timing buffered disk reads:  64 MB in  3.33 seconds =19.22 MB/sec

5 x Macs all get 9+MB/sec read and write transfer rate.

As Marcus said... it really does come down to motherboard/disk spees, 
not the proccessor (or thou it helps im sure:)

-- 
Simon Buchanan   -   Technical Design and Administration
--------------- New Media Communications ---------------
mailto:[email-masked]  http://www.newmediacom.net
------------ By the way, what does BTW mean? -----------

---

From: John L Grantham <[email-masked]>
Date: Sat, 15 Apr 2000 16:14:40 +0200

At 13:51 Uhr +1200 15.04.2000, Simon Buchanan wrote:
>>Just thought it would be fun to compare the two. Of course, the 
>>9500 gets trounced by that monster of yours, but it's not too 
>>shabby... :-)
>
>As Marcus said... it really does come down to motherboard/disk 
>spees, not the proccessor (or thou it helps im sure:)

Yeah, the main brake on my 9500 is undoubtedly the hard drive (narrow 
SCSI). It handles Perl and PHP content very well, actually, 
especially considering the computer's age and type. I could stick a 
Ultra SCSI card in there and pump it up, but somehow the idea of 
doing that to a computer that only sits there for testing my websites 
seems like a waste. ;-)

Of course, once I get that bundle of T1s in my bathroom, maybe I'll 
spring for a  UW-SCSI card on the thing. ;-)

I'd be curious to see benchmarks from others with netatalk on other 
older hardware, just for more realistic comparisons...so far y'all 
all seem to have the computer equivalent of monster trucks. I've just 
got an old Pinto. ;-)

Though I like to think of it as a used Jaguar instead.

cya

John
--

---

From: Steven Karel <[email-masked]>
Date: Sat, 15 Apr 2000 17:49:20 -0400 (EDT)

On my intel linux box (350 MHz PII with one UW SCSI disk and one
IDE disk which get about equivalent sustained transfer
speeds...)

[root@squirrel /root]# /sbin/hdparm -tT /dev/sda

/dev/sda:
 Timing buffer-cache reads:   64 MB in  0.69 seconds =92.75 MB/sec
 Timing buffered disk reads:  32 MB in  2.30 seconds =13.91 MB/sec
[root@squirrel /root]# /sbin/hdparm -tT /dev/hda

/dev/hda:
 Timing buffer-cache reads:   64 MB in  0.71 seconds =90.14 MB/sec
 Timing buffered disk reads:  32 MB in  2.44 seconds =13.11 MB/sec

transferring to an iMac DV SE over 100 Mbit switched ethernet in my
office:

move a 426 MB file from SCSI disk: 50 sec (8.5 MB/s)
move same 426 MB from IDE disk: 55 sec (7.7 MB/s)

However, moving a typical 633 MB folder containing 4300 files (the hard
drive contents of a "standard" iMac for our lab)...

from the SCSI disk: 9 minutes 11 sec (first 40 sec was just "counting
files") or... 1.3 MB/s

unfortunately, my wife's done in the lab so I have to go home now,
otherwise I'd do the experiment with the IDE disk (I _think_ it'll be
significantly slower due to the slower "seek time".

My point here is that to get the really fast transfer rates...

	you don't necessary need a snazzy disk array, but
	you DO need to be moving large files. 

If you're moving a lot of small files, expect it to be much slower.

steven

On Sat,
15 Apr 2000, John

> Though I like to think of it as a used Jaguar instead.

Steven Karel, Ph.D.
Biology Department, Brandeis Univ, MS 008
415 South St Waltham MA 02454-9110
TEL 781 736 3104   FAX 781 736 3107

---

From: Marcus Radich <[email-masked]>
Date: Sun, 16 Apr 2000 10:51:20 +1200

>from the SCSI disk: 9 minutes 11 sec (first 40 sec was just "counting

Yes, we have this too. I guess the reason we use these benchmarks is 
to show what the full potential of the system is. Since most of our 
customers are design oriented, 400MB files are the norm.

>If you're moving a lot of small files, expect it to be much slower.

The snazzy disk array, being RAID 0+1, is mainly for security, but it 
also means that *several* clients can get excellent service from the 
server - not just one. If you want to feed 5 or 10 Macs at 100BaseT, 
you may find that the seek and transfer of a single disk will not be 
sufficient, that's where the RAID comes in.

Here is a benchmark of a slower system I have sitting at home as a 
backup server:

Celeron 400
VIA 133pro chipset motherboard
128MB RAM
Ultra33
IBM 13GB IDE disk

/dev/hda:
  Timing buffer-cache reads:   128 MB in  3.11 seconds =41.16 MB/sec
  Timing buffered disk reads:  64 MB in  8.21 seconds = 7.80 MB/sec

Using Helios Lantest, I get 6MB/sec read/writes.

Copying a folder of over 3000 files shows about 2MB/sec....

mrad01

---

From: Jaime Mantel <[email-masked]>
Date: Mon, 17 Apr 2000 00:57:15 -0700

I once saw a posting in this list about the UAM for MacOS
not working for MacOS above 8.1.  Is this true?  And if so
is there a UAM that does work for MacOS 8.5 and above?

TIA,
Jaime Mantel

---

From: Phil Wenzlawski <[email-masked]>
Date: Mon, 17 Apr 2000 14:31:24 +0200

hi there !

i've a pentium 266 box with 2 x promise ultra66 ide controller
and 4 x 37gb ibm ide disks configured as raid5 for data and
a old 9 gb seagate barracude disk for system & swap. 128mb ram,
networkcard is a dec 100mbit (tulip) card, and network is
switched 100mbit.

we got also transfer with rates about 8-9 mbyte per second :)

we also have a much bigger dual p3-450 box running nt 4 with
services for macintosh. but with this we only get about 3-4
mbyte per second. this is because nt 4 don't only supports
appletalk over tcp/ip.

phil wenzlawski

---

From: Sak Wathanasin <[email-masked]>
Date: Mon, 17 Apr 2000 21:03:53 +0100

In reply to Marcus Radich's message of the 16/04/00 at 10:51 +1200,

>Copying a folder of over 3000 files shows about 2MB/sec....

I don't if this is generally known, but if you're not running a very 
recent kernel (2.3.x), UDMA (33, 66) isn't enabled by default. Try 
adding the following to your rc.local script and rebooting:

	hdparm -c1 -u1 -d1 -m16 /dev/hda

On my systems (PIII/500, VIA IDE chipset, ATA/33 disk, 5400 rpm), the 
hdparm disk-read went from about 4 MB/sec to 14+ MB/sec when I did 
this; Lantest now reports file xfer times around 9000 kbytes/s.  YMMV.

-- 
Sak Wathanasin
Network Analysis Limited
178 Wainbody Ave South, Coventry CV3 6BX, UK

Internet: [email-masked]
Phone: (+44) 2476 419996        Mobile: (+44) 7970 751912 
Fax: (+44) 2476 690690

---

From: Bill Tihen -- TECHNOLOGY <[email-masked]>
Date: Mon, 15 May 2000 15:48:43 +0200

Hello,

I am using RH6.1 and I have installed: 
	netatalk-1.4b2+asun2.1.3-7.i386.rpm

I see the server in the mac's chooser menu, but clicking
on this says no response from the server.  However, if I
type in the IP address -- that works just fine.  I think
I have seen this issue raised before, but I don't
remember seeing the answer.

In anycase, I tried to locate the problem, but I don't
see anything wrong.  Here is what I checked.  Sorry
about the length, I have included lots of files
including /etc/services -- I didn't edit them incase I
am over looking something obvious.
________________________

I configured: /etc/atalk/config as (I didn't configure
the other files at all papd.conf and atalk.conf):

# Appletalk configuration
   # Change this to increase the maximum number of
clients that can connect:
   AFPD_MAX_CLIENTS=50
   # Change this to set the machine's atalk name:
   ATALK_NAME=`echo ${HOSTNAME}|cut -d. -f1`
   # Set which daemons to run:
   # printer daemon
   PAPD_RUN=no
   # apple file system daemon
   AFPD_RUN=yes
   # Control whether the daemons are started in the
background
   ATALK_BGROUND=yes

__________________

To see if netatalk is running I did
ps -ax, which gives:

  PID TTY      STAT   TIME COMMAND
       1 ?        S      0:04 init [3]
       2 ?        SW     0:00 [kflushd]
       3 ?        SW     0:00 [kupdate]
       4 ?        SW     0:00 [kpiod]
       5 ?        SW     0:02 [kswapd]
       6 ?        SW<    0:00 [mdrecoveryd]
     302 ?        S      0:00 portmap
     355 ?        S      0:00 syslogd -m 0
     366 ?        S      0:00 klogd
     382 ?        S      0:00 /usr/sbin/atd
     398 ?        S      0:00 crond
     414 ?        S      0:00 inetd
     461 ?        S      0:00 httpd
     464 ?        S      0:00 httpd
     465 ?        S      0:00 httpd
     466 ?        S      0:00 httpd
     467 ?        S      0:00 httpd
     468 ?        S      0:00 httpd
     469 ?        S      0:00 httpd
     470 ?        S      0:00 httpd
     471 ?        S      0:00 httpd
     472 ?        S      0:00 httpd
     473 ?        S      0:00 httpd
     507 ?        S      0:00 atalkd
     508 ?        S      0:00 smbd -D
     519 ?        S      0:00 nmbd -D
     531 ?        S      0:00 /usr/sbin/dhcpd eth0
     548 tty2     S      0:00 /sbin/mingetty tty2
     549 tty3     S      0:00 /sbin/mingetty tty3
     550 tty4     S      0:00 /sbin/mingetty tty4
     551 tty5     S      0:00 /sbin/mingetty tty5
     552 tty6     S      0:00 /sbin/mingetty tty6
     567 ?        S      0:00 afpd -c 50 -n students
     569 tty1     S      0:00 login -- root    
     570 tty1     S      0:00 -bash
     603 tty1     R      0:00 ps -ax

This seems reasonable.
____________________

So I checked the boot up messages.  Which give:

May 15 14:43:15 localhost syslogd 1.3-3: restart.
   May 15 14:43:15 localhost syslog: syslogd startup
succeeded
   May 15 14:43:15 localhost syslog: klogd startup
succeeded
   May 15 14:43:15 localhost kernel: klogd 1.3-3, log
source = /proc/kmsg started.
   May 15 14:43:15 localhost kernel: Inspecting
/boot/System.map-2.2.12-20
   May 15 14:43:15 localhost kernel: Loaded 6865 symbols
from
   /boot/System.map-2.2.12-20.
   May 15 14:43:15 localhost kernel: Symbols match
kernel version 2.2.12.
   May 15 14:43:15 localhost kernel: No module symbols
loaded.
   May 15 14:43:15 localhost kernel: 3c59x.c:v0.99H
11/17/98 Donald Becker
   http://cesdis.gsfc.nasa.gov/linux/drivers/vortex.html 
   May 15 14:43:15 localhost kernel: eth0: 3Com 3c905B
Cyclone 100baseTx at 0xb000, 
   00:50:04:34:de:d6, IRQ 10 
   May 15 14:43:15 localhost kernel:   8K byte-wide RAM
5:3 Rx:Tx split,
   autoselect/Autonegotiate interface. 
   May 15 14:43:15 localhost kernel:   MII transceiver
found at address 24, status 782d.

   May 15 14:43:15 localhost kernel:   Enabling
bus-master transmits and whole-frame
   receives. 
   May 15 14:43:15 localhost atd: atd startup succeeded
   May 15 14:43:16 localhost crond: crond startup
succeeded
   May 15 14:43:16 localhost inet: inetd startup
succeeded
   May 15 14:43:16 localhost dhcpd: Internet Software
Consortium DHCP Server 2.0
   May 15 14:43:16 localhost dhcpd: Copyright 1995,
1996, 1997, 1998, 1999 The Internet
   Software Consortium.
   May 15 14:43:16 localhost dhcpd: All rights reserved.
   May 15 14:43:16 localhost dhcpd: 
   May 15 14:43:16 localhost dhcpd: Please contribute if
you find this software useful.
   May 15 14:43:16 localhost dhcpd: For info, please
visit
   http://www.isc.org/dhcp-contrib.html
   May 15 14:43:16 localhost dhcpd: 
   May 15 14:43:16 localhost dhcpd: Internet Software
Consortium DHCP Server 2.0
   May 15 14:43:16 localhost dhcpd: Copyright 1995,
1996, 1997, 1998, 1999 The Internet
   Software Consortium.
   May 15 14:43:16 localhost dhcpd: All rights reserved.
   May 15 14:43:16 localhost dhcpd: 
   May 15 14:43:16 localhost dhcpd: Please contribute if
you find this software useful.
   May 15 14:43:16 localhost dhcpd: For info, please
visit
   http://www.isc.org/dhcp-contrib.html
   May 15 14:43:16 localhost dhcpd: 
   May 15 14:43:16 localhost dhcpd: Listening on
LPF/eth0/00:50:04:34:de:d6/192.168.1.0
   May 15 14:43:16 localhost dhcpd: Listening on
LPF/eth0/00:50:04:34:de:d6/192.168.1.0
   May 15 14:43:16 localhost dhcpd: Sending on  
LPF/eth0/00:50:04:34:de:d6/192.168.1.0
   May 15 14:43:16 localhost dhcpd: Sending on  
Socket/fallback/fallback-net
   May 15 14:43:17 localhost dhcpd: Sending on  
LPF/eth0/00:50:04:34:de:d6/192.168.1.0
   May 15 14:43:17 localhost dhcpd: Sending on  
Socket/fallback/fallback-net
   May 15 14:43:17 localhost dhcpd: dhcpd startup
succeeded
   May 15 14:43:17 localhost keytable: Loading keymap: 
   May 15 14:43:17 localhost keytable: Loading
   /usr/lib/kbd/keymaps/i386/qwerty/us.kmap.gz
   May 15 14:43:17 localhost keytable: Loading system
font: 
   May 15 14:43:17 localhost rc: Starting keytable
succeeded
   May 15 14:43:18 localhost httpd: httpd startup
succeeded
   May 15 14:43:18 localhost kernel: NET4: AppleTalk
0.18 for Linux NET4.0 
   May 15 14:43:18 localhost atalkd[507]: restart
(1.4b2+asun2.1.3)
   May 15 14:43:19 localhost smb: smbd startup succeeded
   May 15 14:43:19 localhost smb: nmbd startup succeeded
   May 15 14:43:19 localhost linuxconf-setup: Linuxconf
final setup
   May 15 14:43:19 localhost atalkd[507]: zip_getnetinfo
for eth0
   May 15 14:43:20 localhost dhcpd: Internet Software
Consortium DHCP Server 2.0
   May 15 14:43:20 localhost dhcpd: Copyright 1995,
1996, 1997, 1998, 1999 The Internet
   Software Consortium.
   May 15 14:43:20 localhost dhcpd: All rights reserved.
   May 15 14:43:20 localhost dhcpd: 
   May 15 14:43:20 localhost dhcpd: Please contribute if
you find this software useful.
   May 15 14:43:20 localhost dhcpd: For info, please
visit
   http://www.isc.org/dhcp-contrib.html
   May 15 14:43:20 localhost dhcpd: 
   May 15 14:43:20 localhost dhcpd: Listening on
LPF/eth0/00:50:04:34:de:d6/192.168.1.0
   May 15 14:43:20 localhost dhcpd: Sending on  
LPF/eth0/00:50:04:34:de:d6/192.168.1.0
   May 15 14:43:20 localhost dhcpd: Sending on  
Socket/fallback/fallback-net
   May 15 14:43:20 localhost linuxconf-setup:    
Executing: /sbin/route add -net
   255.255.255.255 netmask 255.255.255.255 dev eth0
   May 15 14:43:20 localhost linuxconf-setup:    
Killing /usr/sbin/dhcpd with signal 15
   return 0
   May 15 14:43:20 localhost linuxconf-setup:    
Executing: /usr/sbin/dhcpd eth0 2>&1
   May 15 14:43:20 localhost linuxconf-setup:         >
Internet Software Consortium
   DHCP Server 2.0
   May 15 14:43:20 localhost linuxconf-setup:         >
Copyright 1995, 1996, 1997,
   1998, 1999 The Internet Software Consortium.
   May 15 14:43:20 localhost linuxconf-setup:         >
All rights reserved.
   May 15 14:43:20 localhost linuxconf-setup:         > 
   May 15 14:43:20 localhost linuxconf-setup:         >
Please contribute if you find
   this software useful.
   May 15 14:43:20 localhost linuxconf-setup:         >
For info, please visit
   http://www.isc.org/dhcp-contrib.html
   May 15 14:43:20 localhost linuxconf-setup:         > 
   May 15 14:43:20 localhost linuxconf-setup:         >
Listening on
   LPF/eth0/00:50:04:34:de:d6/192.168.1.0
   May 15 14:43:20 localhost linuxconf-setup:         >
Sending on  
   LPF/eth0/00:50:04:34:de:d6/192.168.1.0
   May 15 14:43:20 localhost linuxconf-setup:         >
Sending on  
   Socket/fallback/fallback-net
   May 15 14:43:20 localhost rc: Starting
linuxconf-setup succeeded
   May 15 14:43:28 localhost atalkd[507]: zip_getnetinfo
for eth0
   May 15 14:43:38 localhost atalkd[507]: zip_getnetinfo
for eth0
   May 15 14:43:48 localhost atalkd[507]: config for no
router
   May 15 14:43:49 localhost atalkd[507]: ready 0/0/0
   May 15 14:43:49 localhost atalk: atalkd startup
succeeded
   May 15 14:44:01 localhost atalk: afpd startup
succeeded
   May 15 14:44:02 localhost PAM_pwdb[547]:
authentication failure; LOGIN(uid=0) -> root
   for login service
   May 15 14:44:03 localhost login[547]: FAILED LOGIN 1
FROM (null) FOR root,
   Authentication failure
   May 15 14:44:03 localhost login[547]: FAILED LOGIN 2
FROM (null) FOR , User not known
   to the underlying authentication module
   May 15 14:44:08 localhost afpd[567]:
students:AFPServer@* started on 65280.217:128
   (1.4b2+asun2.1.3)
   May 15 14:44:08 localhost afpd[567]: ASIP started on
127.0.0.1:548(1)
   (1.4b2+asun2.1.3) 
   May 15 14:47:09 localhost PAM_pwdb[569]: (login)
session opened for user root by
   LOGIN(uid=0)

__________________________
more /etc/services gives:

# /etc/services:
   # $Id: services,v 1.4 1997/05/20 19:41:21 tobias Exp
$
   #
   # Network services, Internet style
   #
   # Note that it is presently the policy of IANA to
assign a single well-known
   # port number for both TCP and UDP; hence, most
entries here have two entries
   # even if the protocol doesn't support UDP
operations.
   # Updated from RFC 1700, ``Assigned Numbers''
(October 1994).  Not all ports
   # are included, only the more common ones.

   tcpmux          1/tcp                           # TCP
port service multiplexer
   echo            7/tcp
   echo            7/udp
   discard         9/tcp           sink null
   discard         9/udp           sink null
   systat          11/tcp          users
   daytime         13/tcp
   daytime         13/udp
   netstat         15/tcp
   qotd            17/tcp          quote
   msp             18/tcp                          #
message send protocol
   msp             18/udp                          #
message send protocol
   chargen         19/tcp          ttytst source
   chargen         19/udp          ttytst source
   ftp-data        20/tcp
   ftp             21/tcp
   fsp             21/udp          fspd
   ssh             22/tcp                          # SSH
Remote Login Protocol
   ssh             22/udp                          # SSH
Remote Login Protocol
   telnet          23/tcp
   # 24 - private
   smtp            25/tcp          mail
   # 26 - unassigned
   time            37/tcp          timserver
   time            37/udp          timserver
   rlp             39/udp          resource        #
resource location
   nameserver      42/tcp          name            # IEN
116
   whois           43/tcp          nicname
   re-mail-ck      50/tcp                          #
Remote Mail Checking Protocol
   re-mail-ck      50/udp                          #
Remote Mail Checking Protocol
   domain          53/tcp          nameserver      #
name-domain server
   domain          53/udp          nameserver
   mtp             57/tcp                          #
deprecated
   bootps          67/tcp                          #
BOOTP server
   bootps          67/udp
   bootpc          68/tcp                          #
BOOTP client
   bootpc          68/udp
   tftp            69/udp
   gopher          70/tcp                          #
Internet Gopher
   gopher          70/udp
   rje             77/tcp          netrjs
   finger          79/tcp
   www             80/tcp          http            #
WorldWideWeb HTTP
   www             80/udp                          #
HyperText Transfer Protocol
   link            87/tcp          ttylink
   kerberos        88/tcp          kerberos5 krb5  #
Kerberos v5
   kerberos        88/udp          kerberos5 krb5  #
Kerberos v5
   supdup          95/tcp
   # 100 - reserved
   hostnames       101/tcp         hostname        #
usually from sri-nic
   iso-tsap        102/tcp         tsap            #
part of ISODE.
   csnet-ns        105/tcp         cso-ns          #
also used by CSO name server
   csnet-ns        105/udp         cso-ns
   # unfortunately the poppassd (Eudora) uses a port
which has already
   # been assigned to a different service. We list the
poppassd as an
   # alias here. This should work for programs asking
for this service.
   # (due to a bug in inetd the 3com-tsmux line is
disabled)
   #3com-tsmux     106/tcp         poppassd
   #3com-tsmux     106/udp         poppassd
   rtelnet         107/tcp                         #
Remote Telnet
   rtelnet         107/udp
   pop-2           109/tcp         postoffice      # POP
version 2
   pop-2           109/udp
   pop-3           110/tcp                         # POP
version 3
   pop-3           110/udp
   sunrpc          111/tcp         portmapper      # RPC
4.0 portmapper TCP
   sunrpc          111/udp         portmapper      # RPC
4.0 portmapper UDP
   auth            113/tcp         authentication tap
ident
   sftp            115/tcp
   uucp-path       117/tcp
   nntp            119/tcp         readnews untp   #
USENET News Transfer Protocol
   ntp             123/tcp
   ntp             123/udp                         #
Network Time Protocol
   netbios-ns      137/tcp                         #
NETBIOS Name Service
   netbios-ns      137/udp
   netbios-dgm     138/tcp                         #
NETBIOS Datagram Service
   netbios-dgm     138/udp
   netbios-ssn     139/tcp                         #
NETBIOS session service
   netbios-ssn     139/udp
   imap2           143/tcp         imap            #
Interim Mail Access Proto v2
   imap2           143/udp         imap
   snmp            161/udp                         #
Simple Net Mgmt Proto
   snmp-trap       162/udp         snmptrap        #
Traps for SNMP
   cmip-man        163/tcp                         # ISO
mgmt over IP (CMOT)
   cmip-man        163/udp
   cmip-agent      164/tcp
   cmip-agent      164/udp
   xdmcp           177/tcp                         # X
Display Mgr. Control Proto
   xdmcp           177/udp
   nextstep        178/tcp         NeXTStep
NextStep       # NeXTStep window
   nextstep        178/udp         NeXTStep
NextStep       # server
   bgp             179/tcp                         #
Border Gateway Proto.
   bgp             179/udp
   prospero        191/tcp                         #
Cliff Neuman's Prospero
   prospero        191/udp
   irc             194/tcp                         #
Internet Relay Chat
   irc             194/udp
   smux            199/tcp                         #
SNMP Unix Multiplexer
   smux            199/udp
   at-rtmp         201/tcp                         #
AppleTalk routing
   at-rtmp         201/udp
   at-nbp          202/tcp                         #
AppleTalk name binding
   at-nbp          202/udp
   at-echo         204/tcp                         #
AppleTalk echo
   at-echo         204/udp
   at-zis          206/tcp                         #
AppleTalk zone information
   at-zis          206/udp
   qmtp            209/tcp                         # The
Quick Mail Transfer Protocol
   qmtp            209/udp                         # The
Quick Mail Transfer Protocol
   z3950           210/tcp         wais            #
NISO Z39.50 database
   z3950           210/udp         wais
   ipx             213/tcp                         # IPX
   ipx             213/udp
   imap3           220/tcp                         #
Interactive Mail Access
   imap3           220/udp                         #
Protocol v3
   rpc2portmap     369/tcp
   rpc2portmap     369/udp                         #
Coda portmapper
   codaauth2       370/tcp
   codaauth2       370/udp                         #
Coda authentication server
   ulistserv       372/tcp                         #
UNIX Listserv
   ulistserv       372/udp
   https           443/tcp                         #
MCom
   https           443/udp                         #
MCom
   snpp            444/tcp                         #
Simple Network Paging Protocol
   snpp            444/udp                         #
Simple Network Paging Protocol
   saft            487/tcp                         #
Simple Asynchronous File Transfer
   saft            487/udp                         #
Simple Asynchronous File Transfer
   npmp-local      610/tcp         dqs313_qmaster  #
npmp-local / DQS
   npmp-local      610/udp         dqs313_qmaster  #
npmp-local / DQS
   npmp-gui        611/tcp         dqs313_execd    #
npmp-gui / DQS
   npmp-gui        611/udp         dqs313_execd    #
npmp-gui / DQS
   hmmp-ind        612/tcp         dqs313_intercell#
HMMP Indication / DQS
   hmmp-ind        612/udp         dqs313_intercell#
HMMP Indication / DQS
   #
   # UNIX specific services
   #
   exec            512/tcp
   biff            512/udp         comsat
   login           513/tcp
   who             513/udp         whod
   shell           514/tcp         cmd             # no
passwords used
   syslog          514/udp
   printer         515/tcp         spooler         #
line printer spooler
   talk            517/udp
   ntalk           518/udp
   route           520/udp         router routed   # RIP
   timed           525/udp         timeserver
   tempo           526/tcp         newdate
   courier         530/tcp         rpc
   conference      531/tcp         chat
   netnews         532/tcp         readnews
   netwall         533/udp                         #
-for emergency broadcasts
   uucp            540/tcp         uucpd           #
uucp daemon
   afpovertcp      548/tcp                         # AFP
over TCP
   afpovertcp      548/udp                         # AFP
over TCP
   remotefs        556/tcp         rfs_server rfs  #
Brunhoff remote filesystem
   klogin          543/tcp                         #
Kerberized `rlogin' (v5)
   kshell          544/tcp         krcmd           #
Kerberized `rsh' (v5)
   kerberos-adm    749/tcp                         #
Kerberos `kadmin' (v5)
   #
   webster         765/tcp                         #
Network dictionary
   webster         765/udp
   #
   # From ``Assigned Numbers'':
   #
   #> The Registered Ports are not controlled by the
IANA and on most systems
   #> can be used by ordinary user processes or programs
executed by ordinary
   #> users.
   #
   #> Ports are used in the TCP [45,106] to name the
ends of logical
   #> connections which carry long term conversations. 
For the purpose of
   #> providing services to unknown callers, a service
contact port is
   #> defined.  This list specifies the port used by the
server process as its
   #> contact port.  While the IANA can not control uses
of these ports it
   #> does register or list uses of these ports as a
convienence to the
   #> community.
   #
   ingreslock      1524/tcp
   ingreslock      1524/udp
   prospero-np     1525/tcp                        #
Prospero non-privileged
   prospero-np     1525/udp
   datametrics     1645/tcp        old-radius      #
datametrics / old radius entry
   datametrics     1645/udp        old-radius      #
datametrics / old radius entry
   sa-msg-port     1646/tcp        old-radacct     #
sa-msg-port / old radacct entry
   sa-msg-port     1646/udp        old-radacct     #
sa-msg-port / old radacct entry
   radius          1812/tcp                        #
Radius
   radius          1812/udp                        #
Radius
   radacct         1813/tcp                        #
Radius Accounting
   radacct         1813/udp                        #
Radius Accounting
   cvspserver      2401/tcp                        # CVS
client/server operations
   cvspserver      2401/udp                        # CVS
client/server operations
   venus           2430/tcp                        #
codacon port
   venus           2430/udp                        #
Venus callback/wbc interface
   venus-se        2431/tcp                        # tcp
side effects
   venus-se        2431/udp                        # udp
sftp side effect
   codasrv         2432/tcp                        # not
used
   codasrv         2432/udp                        #
server port
   codasrv-se      2433/tcp                        # tcp
side effects
   codasrv-se      2433/udp                        # udp
sftp side effect
   mysql           3306/tcp                        #
MySQL
   mysql           3306/udp                        #
MySQL
   rfe             5002/tcp                        #
Radio Free Ethernet
   rfe             5002/udp                        #
Actually uses UDP only
   cfengine        5308/tcp                        #
CFengine
   cfengine        5308/udp                        #
CFengine
   bbs             7000/tcp                        # BBS
service
   #
   #
   # Kerberos (Project Athena/MIT) services
   # Note that these are for Kerberos v4, and are
unofficial.  Sites running
   # v4 should uncomment these and comment out the v5
entries above.
   #
   kerberos4       750/udp         kerberos-iv kdc #
Kerberos (server) udp
   kerberos4       750/tcp         kerberos-iv kdc #
Kerberos (server) tcp
   kerberos_master 751/udp                         #
Kerberos authentication
   kerberos_master 751/tcp                         #
Kerberos authentication
   passwd_server   752/udp                         #
Kerberos passwd server
   krb_prop        754/tcp                         #
Kerberos slave propagation
   krbupdate       760/tcp         kreg            #
Kerberos registration
   kpasswd         761/tcp         kpwd            #
Kerberos "passwd"
   kpop            1109/tcp                        # Pop
with Kerberos
   knetd           2053/tcp                        #
Kerberos de-multiplexor
   zephyr-srv      2102/udp                        #
Zephyr server
   zephyr-clt      2103/udp                        #
Zephyr serv-hm connection
   zephyr-hm       2104/udp                        #
Zephyr hostmanager
   eklogin         2105/tcp                        #
Kerberos encrypted rlogin
   #
   # Unofficial but necessary (for NetBSD) services
   #
   supfilesrv      871/tcp                         # SUP
server
   supfiledbg      1127/tcp                        # SUP
debugging
   #
   # Datagram Delivery Protocol services
   #
   rtmp            1/ddp                           #
Routing Table Maintenance Protocol
   nbp             2/ddp                           #
Name Binding Protocol
   echo            4/ddp                           #
AppleTalk Echo Protocol
   zip             6/ddp                           #
Zone Information Protocol
   #
   # Services added for the Debian GNU/Linux
distribution
   poppassd        106/tcp                         #
Eudora
   poppassd        106/udp                         #
Eudora
   mailq           174/tcp                         #
Mailer transport queue for Zmailer
   mailq           174/tcp                         #
Mailer transport queue for Zmailer
   ssmtp           465/tcp                         #
SMTP over SSL
   gdomap          538/tcp                         #
GNUstep distributed objects
   gdomap          538/udp                         #
GNUstep distributed objects
   snews           563/tcp                         #
NNTP over SSL
   ssl-ldap        636/tcp                         #
LDAP over SSL
   omirr           808/tcp         omirrd          #
online mirror
   omirr           808/udp         omirrd          #
online mirror
   rsync           873/tcp                         #
rsync
   rsync           873/udp                         #
rsync
   simap           993/tcp                         #
IMAP over SSL
   spop3           995/tcp                         #
POP-3 over SSL
   socks           1080/tcp                        #
socks proxy server
   socks           1080/udp                        #
socks proxy server
   rmtcfg          1236/tcp                        #
Gracilis Packeten remote config server
   xtel            1313/tcp                        #
french minitel
   support         1529/tcp                        #
GNATS
   cfinger         2003/tcp                        # GNU
Finger
   ninstall        2150/tcp                        #
ninstall service
   ninstall        2150/udp                        #
ninstall service
   afbackup        2988/tcp                        #
Afbackup system
   afbackup        2988/udp                        #
Afbackup system
   icp             3130/tcp                        #
Internet Cache Protocol (Squid)
   icp             3130/udp                        #
Internet Cache Protocol (Squid)
   postgres        5432/tcp                        #
POSTGRES
   postgres        5432/udp                        #
POSTGRES
   fax             4557/tcp                        # FAX
transmission service        (old)
   hylafax         4559/tcp                        #
HylaFAX client-server protocol  (new)
   noclog          5354/tcp                        #
noclogd with TCP (nocol)
   noclog          5354/udp                        #
noclogd with UDP (nocol)
   hostmon         5355/tcp                        #
hostmon uses TCP (nocol)
   hostmon         5355/udp                        #
hostmon uses TCP (nocol)
   ircd            6667/tcp                        #
Internet Relay Chat
   ircd            6667/udp                        #
Internet Relay Chat
   webcache        8080/tcp                        # WWW
caching service
   webcache        8080/udp                        # WWW
caching service
   tproxy          8081/tcp                        #
Transparent Proxy
   tproxy          8081/udp                        #
Transparent Proxy
   mandelspawn     9359/udp        mandelbrot      #
network mandelbrot
   amanda          10080/udp                       #
amanda backup services
   kamanda         10081/tcp                       #
amanda backup services (Kerberos)
   kamanda         10081/udp                       #
amanda backup services (Kerberos)
   amandaidx       10082/tcp                       #
amanda backup services
   amidxtape       10083/tcp                       #
amanda backup services
   isdnlog         20011/tcp                       #
isdn logging system
   isdnlog         20011/udp                       #
isdn logging system
   vboxd           20012/tcp                       #
voice box system
   vboxd           20012/udp                       #
voice box system
   binkp           24554/tcp                       #
Binkley
   binkp           24554/udp                       #
Binkley
   asp             27374/tcp                       #
Address Search Protocol
   asp             27374/udp                       #
Address Search Protocol
   tfido           60177/tcp                       #
Ifmail
   tfido           60177/udp                       #
Ifmail
   fido            60179/tcp                       #
Ifmail
   fido            60179/udp                       #
Ifmail

   # Local services

   linuxconf 98/tcp
   swat              901/tcp                         #
Add swat service used via inetd

________________________________________

This also looked okay, so I looked for the ddp module,
to see if RH still has this.   and I found the
following:

/usr/doc/rhl-rg-6.1en/figs/gnorpm/gnoaddpkg.gif
   /usr/man/man4/ddp.4
   /usr/man/man7/ddp.7
  
/usr/src/linux-2.2.12/include/linux/modules-BOOT/ddp.stamp
  
/usr/src/linux-2.2.12/include/linux/modules-BOOT/ddp.ver
  
/usr/src/linux-2.2.12/include/linux/modules-smp/ddp.stamp
  
/usr/src/linux-2.2.12/include/linux/modules-smp/ddp.ver
  
/usr/src/linux-2.2.12/include/linux/modules-up/ddp.stamp
  
/usr/src/linux-2.2.12/include/linux/modules-up/ddp.ver
  
/usr/src/linux-2.2.12/Documentation/networking/ipddp.txt
   /usr/src/linux-2.2.12/drivers/net/ipddp.c
   /usr/src/linux-2.2.12/drivers/net/ipddp.h
   /usr/src/linux-2.2.12/net/appletalk/ddp.c
   /lib/modules/2.2.12-20/net/ipddp.o

Which looks like it is there, but I guess I can't be
sure it is loading. 

What do I try next?

Thanks.
__________________________________________
TASIS (The American School In Switzerland)
Lugano-Montagnola, Switzerland
<http://www.tasis.ch/>

---

From: Patrik Schindler <[email-masked]>
Date: Mon, 15 May 2000 18:09:00 +0200

>remember seeing the answer.

Syslog looks all okay. Logging on as root (as tried) won't work anyway.

>am over looking something obvious.

You told nothing about the Mac side...

:wq! PoC

---

From: Bill Tihen -- TECHNOLOGY <[email-masked]>
Date: Wed, 17 May 2000 14:53:15 +0200

I'm not sure if my last message got through.  Sorry if
this is a duplicate.

Thanks Scott,

   You were right.  For some reason my /etc/hosts file
was
   wrong.  It had

      127.0.0.1 localhost.localdomain localhost students

   I changed it to:

      127.0.0.1    localhost.localdomain localhost
      192.168.1.10 students.tasis.ch     students

   Now everything works perfectly!  I didn't have to
   restart any processes.  I guess Netatalk reads the
   /etc/hosts file with each and every login request?

   I wonder why RH's default set up is the first way.  I
   just noticed my workstation is this way.  It used to
do
   it the second way by default which is more correct
   anyway.

   Anyway -- Thanks again.

   Bill

   Quoting "S.Ecker" <[email-masked]>:

   > Look where you have 127.0.0.1 in your log file. 
That
   > indicates that you have the default redhat loopback
ip
   > in your /etc/hosts file.  Change it from 127.0.0.1
to
   > your actual network IP address.  That should fix
the

   > > Am I over looking something obvious?

   > >    May 15 14:44:08 localhost afpd[567]: ASIP
started
   on 127.0.0.1:548(1) (1.4b2+asun2.1.3) 
__________________________________________
TASIS (The American School In Switzerland)
Lugano-Montagnola, Switzerland
<http://www.tasis.ch/>

---

From: Bill Tihen -- TECHNOLOGY <[email-masked]>
Date: Wed, 17 May 2000 16:04:43 +0200

Hello,

Is there anyhope that I will be able to use long
usernames (longer than 8 characters, ie tihen.bill) in
the near future with Netatalk?  

On my mail server the students are enjoying having a
meaningful username (on the mail server they are only
allowed to use pop and imap, but they work fine with
long usernames -- why doesn't netatalk?

Bill Tihen

---

From: Bill Tihen -- TECHNOLOGY <[email-masked]>
Date: Wed, 17 May 2000 16:08:18 +0200

Hello,

I would like to make my student file server so that the
students may not telnet in, but I understand that
Netatalk requires a full login account.  Will this
change?  Is there a way around this?  I suppose I could
remove the telnet service.  Any other ideas?

Thanks

Bill