Subject: Help for a newbie

From: Colin Murphy <[email-masked]>
Date: Tue, 19 Sep 2000 15:13:39 +0800

Hi, I have two problems with netatalk which I hope someone can help me with.

I have and old 486 running Redhat 6.0 (2.2.5-15 kernel)
with samba (2.0.7-4) and netatalk 1.4b2+asun both of
which were installed from rpms.  Both Macs and PCs share
a common directory on the Linux box.  This has been running
without stop for about a year.

I have now installed two more Linux boxes running Pentium
processors (one celeron 600 the other P111 733)
These are running Redhat 6.2 (2.2.14 kernel) and samba
and netatalk as the RH6.0 box.

I am also running ProFTPD on both of them without problems.

Now the problems
Problem ONE

All the Macs can see the RH6.0 box from the Chooser and can
log on as guest.  But they cannot see the new boxes but can
log on as guest when the IP number is entered from the Chooser.
When I check the startup logs of them (the 6.2 boxes) I see:

atalkd: socket: invalid argument
atalkd: socket: invalid argument
atalkd: atalkd: can't get interfaces, exiting
atalk: atalkd startup failed

Despite this, I can log on as guest provided I enter the IP number.

How can I fix this? Have I provided the right info.  I do not want
to recompile the kernel at this stage.

Problem TWO
I wish to restrict access to one of the machines based on IP Numbers.
This is no problem for me with samba but how do I set the config
(which config) file to do this for netatalk?  I want the
(restricted) Macs to have guest access, but no access for any other Macs

I may as well make a pig of myself while I'm here.
How do I set up a config file so that a Mac can log in with a password
but be restricted to read or write priveleges?

I have read oodles of docs and .man files but some of them assume a
level of knowledge that I do not have.

Thanking you kindly

Colin

Colin Murphy
Manager.  Photographic Unit
The University of Western Australia
Nedlands. 6907 Ph +61 (08) 9380 3056.
http://cyclone.graphics.uwa.edu.au

---

From: Harry Zink/Netatalk List <[email-masked]>
Date: Tue, 19 Sep 2000 08:46:40 -0700

...if he had stock in Cobalt, which I hope he did.

http://slashdot.org/article.pl?sid=00/09/19/1347243&mode=thread

So, technically he now works for SUN - couple that with SUN just hiring away
our local Apple rep, things start to fall into place - i.e. that they might
be really interested in breaking into the low-end market, instead of just
buying Cobalt and putting it out of business.

Still, they'll need to provide a better AppleTalk stack if they plan on
replacing some of our boxes with Cobalt boxes - which I'd be in favor of.

Harry

---

From: Ron Chmara <[email-masked]>
Date: Thu, 21 Sep 2000 22:02:57 -0700

> replacing some of our boxes with Cobalt boxes - which I'd be in favor of.

Sun needs leadership, direction.... this seems like another flailing
(Failing)? in the marketplace to me. 

Not to mention that this product line is anathema to _everything_ else
they offer (Closed source, High dollar, sealed box, etc. etc.)... how
can somebody gracefully transition from a Qube with sendmail to NMS/SIMS?

>From 20 Qubes to SIMS? There's no path.

I've admin'ed both (I currently do some work on the side for Sun, doing
SIMS admin for their clients), and the Cobalt line has absolutely nothing
in common with Sun. It's like, well, John Deere (tractors) announcing a
purchase of a line of sports motorcycles.

I guess they're both a "blue box" theme....

-Bop 

--
Brought to you from boop!, the dual boot Linux/Win95 Compaq Presario 1625
laptop, currently running RedHat 6.1. Your bopping may vary.

---

From: Ryan McBeth <[email-masked]>
Date: Fri, 22 Sep 2000 07:10:45 -0400

I've worked on cobalt before.  Seems like a great way to give 
an office a file/mail/intranet server.  My office actually looked 
into getting one before I was hired.

>they offer (Closed source, High dollar, sealed box, etc. etc.)... how

It might seem kind of strange, but I can understand Sun's decision.

One of the problems that I encounter every day is that most 
non-technical people can't comprehend that some computers cost more 
than $2000.

So when you go to your CFO and say: "I need $4,000 for a Sun running 
at 333Mhz with 128 MB of RAM, the CFO scratches his head, looks down 
at his Dell, and can't figure out why the Sun is going to cost more 
than the Dell.  He wants to be the dot is com as bad as anyone, he 
just doesn't see why he has to pay an extra $2000 for it.

So, what if you took a Qube, put in a UltraSPARC chip, slapped a Sun 
logo on it, and said "Here's our new low end business appliance, 
starting at $999."  It helps keep Sun in the game for low end 
servers.

Ryan

__________________________________
Ryan McBeth
Systems Administrator, Mobius New Media
Voice: (302) 475-9880 x11
FAX: (302) 475-9894
www.mobiusnm.com
__________________________________
If you want to achieve excellence, you can get there today. As of 
this second, quit doing less-than-excellent work.
-Thomas Watson, founder of IBM

---

From: Harry Zink/Netatalk List <[email-masked]>
Date: Sat, 23 Sep 2000 00:14:53 +0000

> (Failing)? in the marketplace to me.

Don't get me wrong - no contest on your views on Sun. That's why they aren't
even close to a market threat anywhere. They are desperately buying up
products, and hoping one of them will magically become profitable all by
itself...

Harry
-- 
CAN'T SEE MAC IN CHOOSER UNDER RedHat 6.2: If you get errors starting
AppleTalk under RedHat 6.2 and Mandrake 7.1, you need to manually add "alias
net-pf-5 appletalk" to your /etc/conf.modules file.

---

From: Matthew Keller <[email-masked]>
Date: Sat, 23 Sep 2000 22:58:31 -0400

> products, and hoping one of them will magically become profitable all by

	Sun has a firm hold on the high-end UNIX market. No other UNIX OS can
scale the way Solaris does, and the E10000 is far and away the workhorse
of the UNIX world... Many many of the worlds most critical processing
systems are Sun Enterprise servers, and they should be as they are
damned spiffy.

-- 

 Matthew Keller
 WebMaster & Lead Programmer/Analyst
 Distributed Computing/Telemedia
 Information Services Division
 State University of New York at Potsdam
 
 Website: http://mattwork.potsdam.edu/
 PGP: http://mattwork.potsdam.edu/crypto/
 Webcam:  http://webcam.mattwork.potsdam.edu:85/

---

From: [email-masked]
Date: Sun, 24 Sep 2000 10:31:48 -0400

> From:    Matthew Keller <[email-masked]>
> To:      Harry Zink/Netatalk List <[email-masked]>

> systems are Sun Enterprise servers, and they should be as they are

And no one in the market for an e10000 is planning to replace it with a
$999 box...

:wes

---

From: Matthew Keller <[email-masked]>
Date: Sun, 24 Sep 2000 12:49:23 -0400

> And no one in the market for an e10000 is planning to replace it with a

	*lmao* That is quite accurate. :)

-- 

 Matthew Keller