Subject: asun2.1.4pre39-5mdk

From: Jürgen Weltzer <[email-masked]>
Date: Thu, 3 Aug 2000 10:25:44 +0100

Hi all,

after 3 days of testing the asun2.1.4pre39-5mdk (from jeffb) I havn't 
got any file corruption up to now.

But the aliases don't work on my system (Suse 6.3) Is there something 
to change in the config-files? Cause Harry Zink and Reed Loefgren 
told, that the alias are working...
-- 
Viele Grüße
Jürgen Weltzer

- - - - - - - - - - - - - - - - - - -
Werbeagentur Weltzer
Max-Eyth-Straße 8
71065 Sindelfingen
Tel. +49 (0) 70.31.81.32.31
Fax +49 (0) 70.31.81.16.01
http://www.w-ww.de/
- - - - - - - - - - - - - - - - - - -

Windows95/98/NT (noun): 32 bit extension and a graphical shell for a 16 bit
patch to an 8 bit operating system originally coded for a 4 bit
microprocessor, written by a 2 bit company, that can't stand 1 bit of
competition

---

From: Stephen Welker <[email-masked]>
Date: Thu, 03 Aug 2000 19:21:06 +1000

--On Thursday, 3 August 2000 10:25 AM +0100 Jürgen Weltzer 
<[email-masked]> wrote:

> But the aliases don't work on my system (Suse 6.3) Is there something to
> change in the config-files? Cause Harry Zink and Reed Loefgren told, that
> the alias are working...

Could you tell us what MacOS version you are using?

Depending on the MacOS version, aliases are broken when linked to servers.

This is what Adrian Sun wrote on 18 January, 2000...

> if somebody could enter this as a faq, that would be great. there
> seems to be some confusion on why aliases don't work. here's the
> answer:
>	 1) macos pre-8.6 used a path composed of fileid/directory id's
>	    to lookup aliases.
>	 2) in afpd, file id's are fixed, but directory id's are
>	    variable.
>
> as a result, macos pre-8.6 will just fail with aliases that refer to
> files that are more than one directory level deep. with macos 8.6 or
> higher, the alias manager will attempt to resolve those by
> pathname. as long as a directory doesn't get assigned the same
> directory id as one in the alias, things should be all right. for
> files, this algorithm should be good enough as file id's are not
> likely to be duplicated on a system. for directory aliases, however,
> this can fail because directory ids can get re-assigned between
> connections.

-- 
Stephen Welker

NetBSD - because Unix isn't just #include <linux.h>, i386, ILP32, ELF, ...!

---

From: Jürgen Weltzer <[email-masked]>
Date: Thu, 3 Aug 2000 12:38:09 +0100

>Depending on the MacOS version, aliases are broken when linked to servers.

Here are my Mac configurations.

G3, OS 8.5.1, Appeleshare 3.8.1
Power Book 5300cs, OS 7.5.5 Rev.2, Appleshare 3.6.1
PPC 8100, OS 8.5.1, Appleshare 3.8.1
PPC 7100, OS 7.5.3 update 2.0, Appleshare 3.6.1
PPC 7100, OS 8.0, Appleshare 3.7.1

If it depends to macOS there is no chance to get running aliases from 
older macs. Or does someone know a solution?

Thanks for the answer.

-- 
Viele Grüße
Jürgen Weltzer