Subject: How to get client name ?

From: MATSUDA Hitoshi <[email-masked]>
Date: Wed, 2 Feb 2000 16:59:41 +0900

Hello,

Does anyone know how to get client names who are connecting to Netatalk
AppleShare server ?

Thanks,

+++
MATSUDA Hitoshi
Hirakata, Osaka, JAPAN
e-mail:[email-masked]

---

From: "Josh Miller" <[email-masked]>
Date: Wed, 2 Feb 2000 08:00:47 -0700

I found a perl script that does this - it's called "nu" (netatalk users).  I
can't remember where to find it, but I can mail it to you if you like.

-Josh

> -----Original Message-----
> From: MATSUDA Hitoshi [mailto:[email-masked]]
> Sent: Wednesday, February 02, 2000 1:00 AM
> To: [email-masked]
> Subject: How to get client name ?
>
>
> Hello,
>

---

From: "thomas.riewe" <[email-masked]>
Date: Thu, 3 Feb 2000 17:05:20 +0100 (CET)

not really nice, but works as a bash script for me (as root)

---cut---
echo
echo "                          NetATalk"
echo "                          --------"
ps axuw|grep atalkd|grep root|grep -v grep|sort|cut -c
1-15,42-51,59,70-160
ps axuw|grep afp|grep root|grep -v grep|sort|cut -c 1-15,42-51,59,70-160
ps axuw|grep papd|grep root|grep -v grep|sort|cut -c 1-15,42-51,59,70-160
echo "                "
echo "Clients    PID Sta. Start Binary"
echo "
---------------------------------------------------------------------"
ps axuw|grep afp|grep -v root|sort|cut -c 1-15,42-51,59,70-160
echo
---cut---

well one should fill in the paths ...

hth,
thomas

---

From: [email-masked]
Date: Thu, 03 Feb 2000 17:34:12 +0100

> ps axuw|grep atalkd|grep root|grep -v grep|sort|cut -c
thank you, it works well!

uwe