Subject: Re: restricted shares

From: Peter Gutowski <[email-masked]>
Date: 17 Mar 2000 11:35:00 -0500

The easiest thing that I find is to create a ~/.AppleVolumes file in each users home directory. This *can* be symbolic link to another file. Many of my users of a certain category have this file symlinking to another file in /etc

Works for me.
-- 
Peter Gutowski

[email-masked] • http://www.powervue.com/~peterg

On Friday, March 17, 2000, [email-masked] wrote:
>I want to have shared folders that some users have access to and othrs
>do not.  Is this handled through setting setting the proper UNIX
>permissions on the shared directories or is this handled through a
>configuration file.  
>
>also can I restrict following symbolic links in netatalk?  Should I?  
>What file is the proper file to put global shares in,
>AppleVolumes.default or AppleVolumes.system?
>
>Thank you
>
>___________________
>
>Jt "The Squeegy" Chiodi
>
>http://www.squeegy.org/
>[email-masked]
>

---

From: Peter Gutowski <[email-masked]>
Date: 17 Mar 2000 12:38:26 -0500

Example:

(As root) create symbolic links as desired...

[user1] $ ln -s /etc/AppleVolues-restricted .AppleVolumes

So now we have this file/directory structure:
/home
  /user1
     .AppleVolumes -> /etc/AppleVolumes-restricted  [note: symlink]
  /user2
     .AppleVolumes -> /etc/AppleVolumes-restricted  [note: symlink]
  /user3
     .AppleVolumes -> /etc/AppleVolumes-webeditor   [note: symlink]
  /user4
     .AppleVolumes -> /etc/AppleVolumes-webeditor   [note: symlink]
  /user5
     .AppleVolumes  [note: real file]

Case 1:
--------- Contents of /etc/AppleVolumes-restricted ----------
~
------------------
These users get access to their home directory only and it shows up on their desktop as their login name. Alternatively the line in the AppleVolumes-restricted file could read:

~          "Home Directory"

in which case it would show up on the desktop as `Home Directory'. It would appear the same to user1 and user2, although they would only be seeing their *own* directory. (Quotes only needed when you wish spaces in the volume name)

Case 2:
--------- Contents of /etc/AppleVolumes-webeditor ----------
~
/home/httpd/html        "www.ourwebsite.com"
/home/clients/company1  "www.company1.com"
/home/clients/company2  "www.company2.com"
/home/clients/company3  "www.company3.com"
------------------
These users get to mount more shares (website directories for which they might be responsible for doing maintenance, etc) plus their home directory

Case 3:
--------- Contents of /home/user5/.AppleVolumes ----------
~
/home/ftp                "FTP Site"
------------------
This user is responsible for monitoring FTP and so get both his/her home directory as well as the main directory for the FTP site.

-- 
Peter Gutowski

On Friday, March 17, 2000, Chip Mefford <[email-masked]> wrote:
>Helly Peter;
>
>This issue is making me crazy as well. 
>
>Can you explain this in a bit more detail? 
>
>I am completely confused. 
>
>Sorry to be a trouble. 
>
>I was initially, and for a while, simply using netatalk
>to provide my mac users /another/ place to put files, their
>own files, and only had the default home shares in place. This
>worked fine. In fact, it worked so well, that folks wanted me
>to build it up into a true file server. 
>
>Creating groups and shared directories has me totally stumped. 
>
>thanx in advance. 
>
>At 11:35 AM 03/17/2000 -0500, you wrote:
>>The easiest thing that I find is to create a ~/.AppleVolumes file in each
>users home directory. This *can* be symbolic link to another file. Many of
>my users of a certain category have this file symlinking to another file in
>/etc
>>
>>Works for me.
>>-- 
>>Peter Gutowski