Subject: Duplicating Folders / Lost links / Conversion?

From: Harald Neiss <[email-masked]>
Date: Fri, 24 Mar 2000 09:09:17 +0100

Hi.

I'm new at the world of Apple and NetATalk and -guess what- have a few
Problems. I read through a lot of docs and listend to this list for
quite
a while. Hope somebody can help me.

1) If somebody tries to duplicate a folder one of two things can happen
   a) Error message that you do not have enough rights
   b) The folder was created but no files are duplicated

   I looked through the users and all have 'users' as the primary
   group. All folders are created (if) with the rights as all the other
   folders.

2) If somebody links images within an Freehand, Quark, Photoshop doc
   which is stored on the server, he must relink the images if he
   reloads the document later. As they told me, it worked in the past -
   the difference - the server has been a M$-NT-Server ...

3) If an images is stored it happens that the file is getting corrupted.
   I read a lot about the CRLF-conversion problems. I'm not quite sure
   if the currently running version does CRLF-conversion, but it looks
   if the server is converting these Freehand, Photoshop and all other
   documents. 

   a) Is there a switch to disable crlf without recompiling NetATalk?
      I think my head is not at the point to reinstall it properly

   b) Please have a look at the AppleVolumes.system file at the end of
      this mail. I looked through the folders and nearly all documents
      do NOT have extensions. How does the server get the filetype
      information? How does the server use this file?

4) Are there good books/tutorials about Mac-Networking, NetATalk and
   all the things around it?

ALL comments are welcome.

Kind regards
   Harald

#
# This file is read before (after if -u is specified) the user's
# AppleVolume file.  Add extension mappings and volumes here.
#

# default translation -- note that CR <-> LF translation is done on all
# files of type TEXT.  The first line turns off translation for files of
# unknown type, the second turns this translation on.
.       BINA    UNIX
# .       TEXT    UNIX

# sounds
.mod    STrk    STrk
.mid    Midi    ttxt
.aiff   AIFF    SNdm
.wav    WAVE    SNdm
.au     ULAW    SNdm

# video
.moov   MooV    mMPG
.mov    MooV    mMPG
.mpg    MPEG    mMPG
.mpeg   MPEG    mMPG

# formatted text
.html   TEXT    MOS!
.rtf    TEXT    MSWD
.doc    WDBN    MSWD
.pdf    CARO    PDF

# compressed archives
.bin    BINA    MB2P
.zip    ZIP     ZIP 
.tar    TARF    TAR!
.gz     Gzip    Gzip
.Z      ZIVM    LZIV
.sea    ????    SITx
.cpt    PACT    CPCT
.sit    SIT!    SIT!
.hqx    TEXT    SITx

# graphics
.tiff   TIFF    JVWR
.tif    TIFF    JVWR
.bmp    BMPp    JVWR
.pct    PICT    ttxt
.pict   PICT    ttxt
.jpeg   JPEG    JVWR
.jpg    JPEG    JVWR
.gif    GIFf    JVWR
.psd    PSDD    JVWR

---

From: Patrik Schindler <[email-masked]>
Date: Fri, 24 Mar 2000 20:55:22 +0100

>   b) The folder was created but no files are duplicated

This sometimes happens on a machine not for duplicating but for creating a folder in a users homedirectory (indeed, while duplicating, this forces the creation of a folder).

>   group. All folders are created (if) with the rights as all the other

Do they have g+w rights?

>   the difference - the server has been a M$-NT-Server ...

This is a known issue with the Mac's alias mechanism. Will be fixed in a future (non-development) release.

>      I think my head is not at the point to reinstall it properly

Yes, and in the sample config you attached it's done right.
If in doubt, it will be better if you tell the exact version of netatalk you are using.

>      information? How does the server use this file?

It's only used when afpd doesn't find a corresponding resource file in .AppleDouble (in the same folder).
You may download a .jpg via commandline-ftp and open this from a netatalk volume through double-click (if you have the programm JPEGView laying around on your harddisk). afpd makes this .jpg appear as of JPEGView without a resourcefork.

>   all the things around it?

None is known to me. It's not too much one must know about. I think it's so little that a book could not get filled.

:wq! PoC