Subject: HELP: QX document damaged

From: Dejan Muhamedagic <[email-masked]>
Date: Tue, 1 Feb 2000 10:27:10 +0100

Hello,

Yesterday was not a good day for netatalk/Quark.  One of the
QX documents has been damaged.  The document has been
created before and yesterday a user wanted to make minor
corrections just before printing.  The document has been
opened OK, changes done, but then, when he wanted to save
the document back, MAC reported error -50.  As this is
happening from time to time, user went on to do some other
things and just left QX running as it was.  Then his MAC
wasn't responding anymore (it crashed for I don't know what
reason) and he had to reset it.  From this point on it was
not possible to open the document anymore.

I've peeked into it and it looks normal, i.e. it's beginning
and ending look as in other QX docs, but then I'm no expert
on QX doc format.  Tried to attach .qxd to its name---didn't
do any good.

afpd only reported that the client was not responding
anymore thus shutting down the connection but this was due
to a crash and not to a "file save error".

My users/customers/friends are a little bit worried.  The
document in question was an ad worth a few hours of work.
What if it's been a 200 pages book and the dog ate last
night's backup tape.  Some serious talks are due and I've
really no grounds to claim that their work is safe with
netatalk/Linux.

Now, I *really* need some assistance here, if possible.  I'm
not able to find out what's going on and I don't know where
to start.  On one side, QX behaves like a madman and on the
other afpd doesn't seem to take any notice.  As if they
speak different languages.  How should I approach this
problem?  Is there a debugging tool of some sort or do I
have to burry myself in the source code?  Anybody willing to
take a look at the "damaged" QX document?  I've got to
resolve this and fast, otherwise...

Today I'm going to install the 37b version.  I also have
there installed 2.1.3, but I'm not sure is it wise to go
back.  Any advice on these?  Perhaps I can use some other
version.  Anybody over there using QuarkXPress v3.32?

I'll attach below my previous message to this list regarding
the similar problem to which nobody responded.

Cheers.

Dejan

----- Forwarded message from Dejan Muhamedagic <[email-masked]> -----

Date: Thu, 27 Jan 2000 16:00:31 +0100
From: Dejan Muhamedagic <[email-masked]>
To: [email-masked]
Subject: quark and linocolor save file problems
Reply-To: Dejan Muhamedagic <[email-masked]>
Organization: Quant-X Service & Consulting Ges.m.b.H.
X-Operating-System: Linux 2.2.13 (i686)
Resent-From: [email-masked]
X-Mailing-List: <[email-masked]> archive/latest/165
X-Loop: [email-masked]
Resent-Sender: [email-masked]

Hello,

I'm in a process of moving a neat pre-press company from
Helios/Irix to netatalk/Linux/Alpha.  There have been
several problems with Quark and Linocolor (the scanning
app).  The netatalk installed is pre-asun2.1.4-36a, but I'm
hoping to upgrade to 37b in next few days.

Linocolor is, sometimes (around 60-70% as claimed by users),
not able to save the scan to a volume.  The interesting
thing is that the application gives document a name like
"Scan 1 1-12633878068", then user is trying to save it under
different name, but the error refers to the original name.
I was not able to find a reference to this application in
the archives.

Quark (v3.32) does not want to do "Save as" and "Save all to
one folder" (please assume that these quotes may not be
exactly as they are---I'm in Austria and all of their apps
are in German).  With both, the file(s) is actually saved by
afpd, but Quark reports error -54 and afpd thinks that this
was just business as usual.  Because if you try to open the
"Save as..." file, it says that the file is locked (or
already opened, error -49) and it actually is (by afpd).  It
seems that there's some kind of misunderstanding between
netatalk and Quark.  I've found a single reference to this
error and it boiled down to disabling Autosave feature, but
my users swear that they are not using this.  BTW, Passport
v3.31 has no problems with either of these save options.

The old Helios software still works and they have never had any
problems with it, so you may guess just how suspiciously they
look at me.

Many TIA,

Dejan Muhamedagic

-- 

Dejan Muhamedagic   mailto:[email-masked]
UNIX and Linux Support   mailto:[email-masked]

Quant-X Service & Consulting Ges.m.b.H.  http://www.quant-x.com
Phn: +43 4212 90555-0     Fax: 90555-20    Free: +800 90555 000

----- End forwarded message -----

-- 

Dejan Muhamedagic   mailto:[email-masked]
UNIX and Linux Support   mailto:[email-masked]

Quant-X Service & Consulting Ges.m.b.H.  http://www.quant-x.com
Phn: +43 4212 90555-0     Fax: 90555-20    Free: +800 90555 000

---

From: bryan stalcup <[email-masked]>
Date: Tue, 01 Feb 2000 05:16:26 -0500

> not possible to open the document anymore.

Dejan,

i'm definitely not qualified to give you the technical answer here, but a
few thoughts:

i support a network of about 15 macs for a printing company. my wife is
also a graphic designer with several macs here at home. i have had a linux
server at home running redhat 5.2, 6.0, and now 6.1 with netatalk+asun2.1.0
through 2.1.3 for over a year and a half. i have NOT installed a
netatalk-based server at the printing company.

it has been quite a learning experience. i have had similar problems with
QuarkXPress files getting eaten. at this point it is standard practice here
at home to save important QuarkXPress documents to the local hard drive as
often as every other save (and that's with frequent saving). netatalk is
not yet perfect. in a high pressure production environment, this is
obviously not acceptable. however, netatalk is free.

i would recommend you seriously consider purchasing Helios' appletalk
implementation for linux. knowing prepress, you can't afford to have these
kinds of quirks. netatalk is a general purpose implementation, but Helios
is targeting our market specifically, and they have long ago worked through
the bugs/quirks in prepress software packages. i'm sure netatalk will catch
up at some point, but in the meantime, can you afford to lose files?

Bryan Stalcup
[email-masked]

---

From: Dejan Muhamedagic <[email-masked]>
Date: Tue, 1 Feb 2000 13:57:42 +0100

Hello,

Yes, purchasing Helios would probably be a safe bet.  However, I've
gathered that netatalk is used widely and, I guessed, in high production
or commercial setups too.  This prepress company was not very
enthusiastic about continuing to use Helios (which they run on an old
SGI box) for they've been asked $$$ just for a software upgrade which
was Y2K ready (though their old version seems to run fine regardless).
I would, of course, hate to go this way, but perhaps they will have to
unless I give them some firm proof that the problems which they have can
be fixed and that I can't do at the moment.  Any commercial setup out
there using netatalk?  Anybody?

Thanks for your input.

Dejan

--

---

From: Dejan Muhamedagic <[email-masked]>
Date: Tue, 1 Feb 2000 14:31:48 +0100

Hello,

On Tue, Feb 01, 2000 at 12:29:24PM +0100, Stefan Barth wrote:
> Dejan Muhamedagic wrote:
> 
> > Anybody willing to
> > take a look at the "damaged" QX document?
> 
> Yes. Stuff it and send it.

It's attached.  One stuffed and one unstuffed.

> This does happen, with netatalk and without.
> I keep preaching to use both backup mechanisms in Quark, and save to
> different volumes, different physical disks if possible.

Both backup mechanisms?  Sorry, I'm not very versatile about Quark---
what would you suggest?  There were some reports about Autosave feature
making troubles.  However, having autobackup would be nice, i.e.
renaming the previous copy of a document under different name.
Versioning would be the best, but I don't think we'll find it here.

> Quark is not perfect either, and it costs a shitload of money.

Yes, so I've heard.  Well, this seems to be expensive business in terms
of software.

> Stefan

Many thanks.

Dejan

--

---

From: Glen Shere <[email-masked]>
Date: Tue, 1 Feb 2000 09:57:35 -0500 (EST)

Quark+Netatalk problems:

We have several labs with Quark 4.1 available, and the students use the
netatalk server to store their documents.

Occasionally a user comes to us panicking because they can't save a
document anymore; the workaround we provide is to open a new document, cut
and paste everything from the 'non-savable' to the new document; the new
document will then save without a problem. 

This of course works only if you don't close quark before requesting help.
:-)

Honestly, I think Netatalk is exposing bugs in Quark, and that it ought to
be reported to Quark-the-company for fixes.

-----
Glen Shere
Institutional Technology
Ringling School of Art and Design

---

From: "Josh Miller" <[email-masked]>
Date: Tue, 1 Feb 2000 08:19:00 -0700

We've had similar problems with both Netatalk and AppleShare, so it would
seem to be a Quark problem.  The message we get is, I believe, "Disk not
found" (or something along those lines - been a while since I've seen it).
Is Quark giving you an error message in these instances?

-Josh

> -----Original Message-----
> From: Glen Shere [mailto:[email-masked]]
> Sent: Tuesday, February 01, 2000 7:58 AM
> To: Dejan Muhamedagic
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Quark+Netatalk...
>
>
>
> Quark+Netatalk problems:
>

---

From: "Jon F." <[email-masked]>
Date: Tue, 1 Feb 2000 10:56:02 -0500 (EST)

are there any major problems with the latest pre-release of asun?

---

From: Tony Grant <[email-masked]>
Date: Tue, 01 Feb 2000 17:02:52 +0100

> be reported to Quark-the-company for fixes.

The same old one since Quark XPress 1.0. We've been shouting at them for
years. They have adopted the MS business model - rake in the cash,
ignore clients...

And when you can't open the file any more and the only solution is to
trash it and it represents 10 days work and there is no backup copy...

Been there seen that.

Cheers

Tony Grant

---

From: Darron Froese <[email-masked]>
Date: Tue, 01 Feb 2000 09:04:02 -0700

>> be reported to Quark-the-company for fixes.

None of this is actually new - and Quark doesn't really seem to care. A
couple years ago on the AppleShare IP List one of the AppleShare IP
Engineers said this:

<http://public.lists.apple.com/digests/appleshareip/1999/99-Feb/v01.n851>

> (Leland Wallace)
> I've looked at what Quark does when saving files, bizzare is the first
> word that comes to mind, but not the last.

The general consensus there was that Quark files should not be saved/opened
off of a network drive (Netatalk or AppleShare IP) - they pointed to an FAQ
on the Quark List (which I couldn't find then or now).

It was also stated (without official confirmation) that Quark has known
about this and has not done anything - search the ASIP Lists for more info.
-- 
Darron
[email-masked]

---

From: Ron Chmara <[email-masked]>
Date: Tue, 01 Feb 2000 21:10:56 -0700

> on the Quark List (which I couldn't find then or now).

Sorry, my fault. I never set up a web page for it. If you
search the Indiana.edu Quark list, it's subject is usually "The sic FAQ!".

I've copied out relevant sections below.

> about this and has not done anything - search the ASIP Lists for more info.

I doubt they'd get more official than the post to the Quark list by Ed Post,
Quark Inc. Sr. Software Engineer (also author of "Real Programmers Don't use
Pascal", for you old school folks :-)  ). He basically detailed *why* Quark
is so touchy, it's because of using server temp files. Quark would never
admit error or liability for it, because, well, legally, that's a really bad
move. I havn't searched the archives for the post in a while, I don't know if
the archives even go back that far. He no longer works for them, either...

Lewis Pennock wrote: 
> Both the Quark and ASIP lists have had numerous threads about these
> "Access Denied -5000" errors and everyone seems to agree that it's
> something Quark needs to fix, but for whatever reason just hasn't.  The
> copy and paste recovery method is the only one I know of.
> -Lewis

There's a few more recovery tricks.. Also copied below.

>From the sic FAQ, v 2.5:
> Q. When working off of a networked drive, my Quark files seem much
> less stable. I get -39 or EOF (end of file) errors, etc. and my files
> get corrupted often. Why can't quark work reliably over a network?
> A. The way Quark is able to open a 10Mb file on a 4Mb machine is due
> to using "temp" files for it's pages. These files are created wherever
> the opened document resides. This is where the problem occurs....Quark
> works just fine on 100% stable networks, but on a network where Quark
> loses the "temp" files, you can lose a document. Since most networks
> are almost *never* 100% stable, Quark Inc. has recommended never
> working on a document over a network. (yes, never.) This does not mean
> you have a bad network, it means that most networks aren't built
> in cleanrooms and run in EMI-free environments. Of course, this
> *does not* apply to the other elements in the file, just the quark
> document itself.  You can keep the quark files locally, and the
> links somewhere on the network, with little to no difficulty. If you
> want to make it work, try to run with the latest version of Quark,
> the latest NLM's or service packs or (fill in the patch format for
> your server software here).
> 
> Q. Well, the documents aren't getting corrupted, but for some reason
> my Appleshare IP server is giving me access denied, invalid access,
> etc. error messages. Everything else on the network is crystal clear,
> all certified, the geeks have exhausted themselves on building the
> perfect network, and I still have this problem! Is there something
> I can do about this?
> A. Yes. You need to increase your user's permission to the hard drive
> so quark's temp files are working. You can do this by sharing the
> whole drive, rather than just sharing a single folder, *or*  by giving
> the user Admin priveleges. *or* by using Resedit (or another
> disk tool) to make the "Temporary Items" folder on the drive
> visible, and then changing the priveleges for that folder.
> 
> Q. Oh No! Quark is saying I can't save my last 5 hours of work!
> "Unexpected End Of File"! I'm going to kill something!
> A. Put the triple-espresso *down*. There are a variety of ways to
> fix this. The most important thing to remember is that you need
> to get your work into _another_ file, quickly. If you have a library
> file open, put it there. If you have another file open that *will*
> save, put it on that file's pasteboard. You will have to do some
> deleting in the "helper" file, but your work will be recoverable.
> 
> Q. Quark keeps giving me the message "Can't find required volume
> or folder"? What does this mean, and how can I fix it?
> A. It's basically the same problem as "End of File", but rather
> than not finding the file pieces, it's not finding where the
> pieces should be. Try turning on auto-save, setting the save to
> the minimum time, and letting QXP try to make a new backup. In
> a few seconds, go back to your preferences, turn it off, and see
> if you can get back to working.

HTH,
-Boppers