Subject: Appletalk routing.... please help!!!

From: Konstantin Reznitsky <[email-masked]>
Date: Mon, 8 May 2000 23:21:47 -0400

Sorry, guys, this will be a little off-topic, but people here seem to know about appletalk more then anywhere I know of.
This does not have much to do with netatalk, but with RTMP in general.
Can appletalk handle multiple routes, what sometimes is called multipath? Is there such a thing in the appletalk world? From what I know about RTMP - it is RIP based, so here might be a problem.
If yes, how does it handle equal cost multipath (when more then one route have the some number of hops)?
Can appletalk be used in the multiroute environment with the redundancy in mind?
Can the same be done to balance the load over several routes?
As I said, this is not about capabilities of atalkd, but appletalk routing mechanisms in general. But I'm also interested can the above structure be implemented using netatalk. The original network is based on the routing switches which support only basic appletalk features (Cajun 550R - Lucent stuff, if anybody is interested).
Does anybody know any places to look for information on this matter? Any pointers are welcome. 

One more thing, I stopped getting the list messages for some reason. I will try to subscribe again, but if you can cc the reply to [email-masked] would be great.
Thanks.

Konstantin.

---

From: Patrik Schindler <[email-masked]>
Date: Tue, 9 May 2000 17:45:39 +0200

>From what I *think* (this means I'm not certain) Apple tried to make AppleTalk as foolproof as possible. So I think it can handle multipathing.

>Can appletalk be used in the multiroute environment with the redundancy in mind?

Yes, when one route is dead, another one will be established.
This is only true if statement 1 is true :-)

>Can the same be done to balance the load over several routes?

Uhm...try.

>Does anybody know any places to look for information on this matter? Any pointers are welcome. 

Have a look at "NetWare for Macintosh Installation and Maintenance" Manual if you can grab one. The explanations there are -of course- Netware-specific but there are also good explanation of network basics.

[...later...]

>From there I found that more than one route to a destination is explicitly allowed. The routers choose always the smallest hop-count available for a destination. I think that if the hop-count is equal the first entry in the routing table will be used.

:wq! PoC