Subject: Re: Two servers --getting closer

From: "Joe Rhodes" <[email-masked]>
Date: Fri, 03 Nov 2000 13:44:58 CST

As luck would have it, I DO have ssh turned on on the other box.  Here are 
the HOSTNAME and /etc/hosts files for it:

HOSTNAME
localhost

/etc/hosts:
127.0.0.1               localhost localhost.localdomain

For comparision.

Thanks!
-Joe Rhodes

Thanks for the suggestions.  Thus far, here's what I get.  (I'm at work now, 
so I cannot get to both machines.  I only have one set up with ssh.

On the one machine, the command hostid comes back with :
17f00
If you sign extend that to 8 digits (32 bits) it matches up with the Server 
Signature I'm getting.  Well, almost,.
The server signature is 0017e00  a whole bunch of times.

I don't know how to change what I get back from the hostid command. I'd be 
open to suggestions.

By way of suggestion, I check the HOSTNAME file on the one machine, and it's 
machine specific.   Same with /etc/hosts--
127.0.0.1 is NOT localhost on the one machine.  (It probably is on the other 
machine though.)

I have the same problem with two Red Hat 6.2 Netfinity servers on a seperate 
network.  So it must be something on how the software is set up, not the 
hardware it's running on. (LinuxPPC 2000 on a beige G3 and on an 8500/120)

Here's my /etc/hosts file from the one machine I can get to now:

(Yes, I know it's a bit odd.  I don't have a great grasp for just how this 
should look, all I know is it works fo now....)

127.0.0.1       decameron       localhost.localdomain
127.0.0.1 decameron localhost.localdomain
208.166.201.117         decameron
208.166.201.117 joerhodes.com
208.166.201.117 decameron.dyndns.org
~

joerhodes.com is my domain name that points at this box.
decameron.dyndns.org is another, although I don't own it.

My HOSTNAME file has but one line:
decameron

The other box is set up however RedHat does it right out of the box.  I 
haven't really played with that one at all.  My guess is it still is listed 
as
127.0.0.1 localhost localhost.localdomain

But I don't have access to it right now.  When I get home, I'll send  that 
info out as well.

Any insights will win you my undying appreciation!

Cheers!
-Joe Rhodes

"Contrary to popular belief, UNIX is very user friendly.
It's just picky about who its friends are."

_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

Share information about yourself, create your own public profile at 
http://profiles.msn.com.

---

From: "Bryn Hughes" <[email-masked]>
Date: Fri, 03 Nov 2000 13:23:12 -0800

Sure:

Server 1:

cat /etc/hosts

192.168.129.10          ccmf1.vcc.bc.ca
127.0.0.1               localhost localhost.localdomain

Server 2:

cat /etc/hosts

192.168.129.47          old_srv.vcc.bc.ca
127.0.0.1               localhost localhost.localdomain

Notice that the actual IP number of the server comes FIRST, before localhost.  Don't know if this makes a difference. 

Bryn

----------------------------------------------
Bryn Hughes
Macintosh Technical Support
ICS
Vancouver Community College

ph: (604) 443.8702
fax: (604) 443.8353
email: [email-masked]
----------------------------------------------

>>> bryan stalcup <[email-masked]> - 11/3/00 10:42 AM >>>
if you have a working set of two or more servers, could you post your /etc/hosts files from each server? i've got this problem with three netatalk servers and they all have different hostnames.

thanks!
bryan stalcup

Bryn Hughes wrote:

> I actually saw something similar to this myself when I was setting up my second server.  Check and see what the actual host names of each machine are, I believe this is where Netatalk generates its server signature from.  If both servers are NOT set up to use TCP/IP and think their IP addresses are 127.0.0.1 (localhost) they are probably both going to return the same signature.
>
> Places to look:
>
> In /etc look for a file called HOSTNAME.  Check and see what's in there, and make sure it's different for each server.
> Same with /etc/hosts
> check your atalk/config file, it is probably set up to set the server name to whatever the contents of your HOSTNAME file are (the AppleTalk signature is this name, AFAIK)
>
> Bryn
>
> ----------------------------------------------
> Bryn Hughes
> Macintosh Technical Support
> ICS
> Vancouver Community College
>
> ph: (604) 443.8702
> fax: (604) 443.8353
> email: [email-masked]
> ----------------------------------------------
>
> >>> "Joe Rhodes" <[email-masked]> - 11/2/00 9:13 PM >>>
> Well, I think I'm getting closer...
>
> On Jon Newman's suggestions, I downloaded ServerInfo.  (Cool little utility,
> BTW.  Thanks!)
>
> Indeed, both of the linux boxes have the same server signature:
>
> 0x00017e0000017e0000017e0000017e00
>
> Now the question is, How the hell does one change this?  Is it something
> compiled in or is it set somewhere?  I don't see anything that looks like it
> would help in the config files.
>
> BTW:  what does the "server_quantum" flag do in the afpd.conf file do?  (I
> tried changing this in hopes it might be the signature--no luck.)
>
> Thanks!
> -Joe Rhodes
>
> "Contrary to popular belief, Unix is very user friendly.
> It's just very picky about who its friends are."