Subject: Re: Two servers --getting closer

From: "Bryn Hughes" <[email-masked]>
Date: Fri, 03 Nov 2000 09:32:15 -0800

I actually saw something similar to this myself when I was setting up my second server.  Check and see what the actual host names of each machine are, I believe this is where Netatalk generates its server signature from.  If both servers are NOT set up to use TCP/IP and think their IP addresses are 127.0.0.1 (localhost) they are probably both going to return the same signature.  

Places to look:  

In /etc look for a file called HOSTNAME.  Check and see what's in there, and make sure it's different for each server.
Same with /etc/hosts
check your atalk/config file, it is probably set up to set the server name to whatever the contents of your HOSTNAME file are (the AppleTalk signature is this name, AFAIK)

Bryn

----------------------------------------------
Bryn Hughes
Macintosh Technical Support
ICS
Vancouver Community College

ph: (604) 443.8702
fax: (604) 443.8353
email: [email-masked]
----------------------------------------------

>>> "Joe Rhodes" <[email-masked]> - 11/2/00 9:13 PM >>>
Well, I think I'm getting closer...

On Jon Newman's suggestions, I downloaded ServerInfo.  (Cool little utility, 
BTW.  Thanks!)

Indeed, both of the linux boxes have the same server signature:

0x00017e0000017e0000017e0000017e00

Now the question is, How the hell does one change this?  Is it something 
compiled in or is it set somewhere?  I don't see anything that looks like it 
would help in the config files.

BTW:  what does the "server_quantum" flag do in the afpd.conf file do?  (I 
tried changing this in hopes it might be the signature--no luck.)

Thanks!
-Joe Rhodes

"Contrary to popular belief, Unix is very user friendly.
It's just very picky about who its friends are."
_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

Share information about yourself, create your own public profile at 
http://profiles.msn.com.

---

From: bryan stalcup <[email-masked]>
Date: Fri, 03 Nov 2000 13:40:50 -0500

if you have a working set of two or more servers, could you post your /etc/hosts files from each server? i've got this problem with three netatalk servers and they all have different hostnames.

thanks!
bryan stalcup