Subject: Re: login problems (cleartext passwords)...

From: Philipp Trautmann <[email-masked]>
Date: Tue, 23 May 2000 07:04:42 +0200

In a display of truly Socratic spirit Casey Lewis wrote on 5-23-2000 0:47:

>Hi all!
>
>I'm able to login as Guest, but it fails when I try to login as a
>Registered User.
>
>Background::
>Slackware 7.0 - Kernel 2.2.13
>Netatalk 2.1.4-test_39
> I've added -DSHADOWPW to the etc/afpd/Makefile in the CFLAGS section
> Commented out the DES and Crypto defs in the Makefile.
> Added -lcrypt -lrpcsvc to the DEFs section of sys/linux/Makefile
>

Casey,

here are the steps needed to make this setup work:

1. Verify the presence of /usr/include/shadow.h, /lib/libcrypt.so.1,
/usr/lib/libcrypt.a and /usr/lib/libcrypt.so in your system (the path
might be different, but make must be able to find them)

2. Under the netatalk tree, insert the following lines near the top of
etc/afpd/auth.c and etc/afpd/uam.c:

#ifdef SHADOWPW
#include <shadow.h>
#endif SHADOWPW

3. Add -DSHADOWPW to the CFLAGS in etc/afpd/Makefile and 
etc/uams/Makefile.

4. In sys/linux/Makefile change "ADDLIBS=" to "ADDLIBS= -lcrypt -lrpcsvc".

5. Compile and install. Test.

Regards,

Philipp

---

From: Patrik Schindler <[email-masked]>
Date: Thu, 25 May 2000 23:25:37 +0200

>5. Compile and install. Test.

Thanks! I installed pre-2.4.1-37b this evening and after this it worked. What a pity, Adrian counts more into pam than in classic unix authentication.

Unfortunately, my chooser forces an user break into MacsBug when I use dhx login and provide a wrong password. Okay, I may continue but it's like a hair in my soup. :-) I use AppleShare 3.8.3 within System 7.6.1. Anybody have a clue how to work around this?

:wq! PoC