Subject: Compiling netatalk-1_4_99-0.20001108 on Solaris 7 (32-bit)

From: [email-masked]
Date: Thu, 9 Nov 2000 09:33:01 +0100

Hi there,

I'm back again with compile problems on Solaris 7.

(1) On a standard Solaris installation there is no /usr/share/libtool - is it
necessary to use the absolute path notation or should the PATH variable be used
instead?

(2) Compiling of the sources led to the following output:

Making all in uams
make[3]: Entering directory `/opt/sources/netatalk/netatalk/etc/uams'
Makefile:256: warning: overriding commands for target `install-strip'
Makefile:191: warning: ignoring old commands for target `install-strip'
gcc      -I../../sys/generic -I../../sys/generic -g -O2 -I../../include -I../../
sys -DHAVE_CONFIG_H -fPIC -DPIC \
  -I../.. -fomit-frame-pointer -c uams_guest.c ; \
ld -shared -o uams_guest.so uams_guest.o -lsys -lsocket -lrpcsvc -lresolv -lnsl
-lkrb -ldl -lcrypt -lcmd -lauth  -L../../libatalk/
ld: fatal: option -h and building a dynamic executable are incompatible
ld: fatal: Flags processing errors
make[3]: *** [uams_guest.so] Error 1
make[3]: Leaving directory `/opt/sources/netatalk/netatalk/etc/uams'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/opt/sources/netatalk/netatalk/etc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/opt/sources/netatalk/netatalk'
make: *** [all-recursive-am] Error 2

Who could help?

WDL.
___________________________________________
Wulf-Dirk Leuschner, Dr.
Resarch Scientist Bioinformatics

EPIDAUROS Biotechnologie AG
Am Neuland 1
82347 Bernried
Germany
Tel.: ++49 - 8158 - 99 85 53 - Fax: ++49 - 8158 - 99 85 48
[email-masked]
http://www.epidauros.com

---

From: Wes Yates <[email-masked]>
Date: Thu, 9 Nov 2000 08:37:46 -0500

>make: *** [all-recursive-am] Error 2

My build does the same thing on Linux RH6.0. I will be following this thread
-- 
-Wes Yates
Arts Engraving
704-523-5115
[email-masked]

"It is now safe to shut off your computer"

Yes. Fitting last words.