Subject: Printer Access Control

From: "Bryn Hughes" <[email-masked]>
Date: Thu, 27 Jul 2000 15:25:03 -0700

Is there any way to restrict access to print queues with netatalk+asun?  I have a couple printers set up on my server, and can print to them successfully, so I know how to do that part of it.  I haven't been able to find a HOWTO that explains a way of putting a password on a print queue, if such a thing is possible.

Thanks in advance,

Bryn

---------------------------------
Bryn Hughes
Macintosh Technical Support
Vancouver Community College

ph: (604) 443.8702
fax: (604) 443.8353
email: [email-masked]
---------------------------------

---

From: andrew morgan <[email-masked]>
Date: Thu, 27 Jul 2000 15:55:33 -0700 (PDT)

On Thu, 27 Jul 2000, Bryn Hughes wrote:

> Is there any way to restrict access to print queues with
> netatalk+asun?  I have a couple printers set up on my server, and can
> print to them successfully, so I know how to do that part of it.  I
> haven't been able to find a HOWTO that explains a way of putting a
> password on a print queue, if such a thing is possible.

Grab my authenticated printing patches from:

http://web.orst.edu/~morgan/netatalk/

These are patches against asun2.1.4pre37/39 versions.  You should have a
look at the README in that directory first though to understand how it
works.  You'll need to be running LaserWriter 8.5.1 or greater on your
macs for it to work.

I'll have a patch for CAP-style authenticated printing which will work
with any mac sometime in the near future.

	Andy

---

From: Aaron Levitt <[email-masked]>
Date: Mon, 31 Jul 2000 09:39:56 -0700

Greets everyone..

We have recently mounted an AIX volume to the RH box running netatalk pre39 and made it a netatalk share.  It worked for a day or two, and now if it is mounted from a mac using  netatalk, the files don't update.  This what /var/log/messages looks like when someone mounts the volume now (only the names have been changed to protect the innocent)..

Jul 28 16:48:08 atalkmachine afpd[29337]: cleartext login: user1
Jul 28 16:48:08 atalkmachine PAM_pwdb[29337]: (netatalk) session opened for user user1 by (uid=0)
Jul 28 16:48:08 atalkmachine afpd[29337]: login user1 (uid 1021, gid 12)
Jul 28 16:48:08 atalkmachine afpd[29337]: nfsquota: can't retrieve nfs quota information. make sure that rpc.rquotad is running on AIXbox.

Is there a setting in afpd somewhere that can be changed to tell it not to use nfs quotas.. or does this need to be done in rpc??  If the answer is rpc, does anyone know how to do this??  I looked at the man pages for rpc and it is about as clear as mud.

Thanx in advance..

-Aaron
>>>>====--------====<<<<>>>>====--------====<<<<
Aaron Levitt		1616 Franklin Street
Systems Administrator	Oakland, CA  94612
Navis LLC		Tel:  510-763-5715
http://www.navis.com	Fax:  510-763-2516
>>>>====--------====<<<<>>>>====--------====<<<<

---

From: "David Zimmer" <[email-masked]>
Date: Mon, 31 Jul 2000 18:50:13 +0200

unsubscribe