Subject: Sharing a Mac cdrom

From: Leon Martin <[email-masked]>
Date: Fri, 31 Mar 2000 13:20:59 +1000

Hi,
I'm currently using netatalk-1.4b2+asun2.1.3-6.i386 on a server running RedHat
Linux 6.1 (Intel hardware). I would like to share a Mac cdrom.
The cd mounts fine under linux
mount -t hfs -o afpd /dev/cdrom /mnt/Apple_updates/cdrom
and can be listed etc. I've shared the directory above the cd mount 
point in AppleVolumes.system.
The volume mounts fine from a Mac, but as soon as I double click on 
it, the volume is lost. /var/log/messages shows afpd[718]: 
server_child[1] 1032 killed.
I've read everything I can find on this list and others. I've also 
read whatever www pages I can find related to netatalk and still 
can't solve this one.
Any tips would be appreciated.
Thanks, Leon.

     ____
    |    |                     Dr. C.Leon Martin,
   /     |          _          Dept. Pathology & Immunology,
  |      |-------> ( )         Monash University Medical School,
   \     |          ~          Commercial Rd., Prahran, Victoria,
    |____|         /|          Australia, 3181.
   __| |__     ___/ |
  |_______|^^^^   ---          Net:    [email-masked]
                 |             Voice:  +61 3  990 30545
                 |             Fax:    +61 3  952 98359
               --              Postmaster for cobra.path.monash.edu.au

---

From: Benjamin Gilbert <[email-masked]>
Date: Fri, 31 Mar 2000 16:11:04 -0600

At 3/30/00 9:20 PM, Leon Martin ([email-masked]) wrote:
>Linux 6.1 (Intel hardware). I would like to share a Mac cdrom. [...]

Some changes were made to the HFS module starting in early 2.2-series 
kernels which end up breaking netatalk.  If you're running a modern 
kernel (later 2.2-series), you need pre-asun2.1.4 for HFS compatibility.

<ftp://ftp.cobaltnet.com/pub/users/asun/testing/>

--Benjamin Gilbert