Subject: Re: easy way to check which version?

From: Casey Lewis <[email-masked]>
Date: Fri, 06 Oct 2000 15:48:27 -0700

Marc Miller wrote:
> 
> I'd be more worried if it was left open, and I remain concerned that
> someone could exploit the port if they could figure out how to enter
> a valid dsi packet header.  Why are you telnetting to that port
> anyway?  Do most services yield a version number when telnetted to?

I'm not too worried that's its left open because the machine is behind a
firewall and that service is blocked via the firewall.
I telnetted into that port to see if I could get a version number...
Some services announce their version numbers when you telnet into their
port. (i.e smtp, pop) but there are many services that don't, I figured
it was worth chance. :)

> 
> As for querying the version, there's a file called VERSION in the top
> level of the source code.  That's the only way I know of finding out the
> version.  I'm sure that if you'd like to add that to netatalk 1.5 your
> contribution would be appreciated.
> http://sourceforge.net/projects/netatalk

I'll see what I can do about that :)
Thanks for the reply.
-casey

> 
> On Fri, 6 Oct 2000, Casey Lewis wrote:
> 
> > Hi all!
> > Is there an easy way to verify which version of Netatalk is running on a
> > machine?
> > I've tried telnet'in into 'hostname 548', but once I connect if I hit
> > any key the connection closes and I get the following in the syslog:
> >
> > Oct  6 14:43:44 lvfs afpd[701]: dsi_tcp_open: invalid header
> >
> > I've also looked through the man pages for afpd and atalkd for a '-v'
> > command line switch, but I couldn't find one. I tried it anyway and it
> > didn't work ;)
> >
> > Should I be worried about the telnet to port 548 closure?
> > Thanks!

---

From: Bob Rogers <[email-masked]>
Date: Sun, 8 Oct 2000 11:10:18 -0400 (EDT)

From: Casey Lewis <[email-masked]>
   Date: Fri, 06 Oct 2000 15:48:27 -0700

   Marc Miller wrote:
   > version . . .

With an RPM, it's easier to look at the startup log:

	Oct  5 09:16:20 h0050da615e79 atalkd[642]: restart (1.4b2+asun2.1.3)

At least that works for the old versions.

					-- Bob Rogers

---

From: "Marc J. Miller" <[email-masked]>
Date: Mon, 9 Oct 2000 02:24:04 -0700

With an RPM, you can query the package manager:

rpm -q netatalk

But if the logging is consistent, you should be able to check the log no
matter what form of netatalk is being used.