Subject: Re: LPRng and netatalk

From: rgp systems <[email-masked]>
Date: Thu, 24 Aug 2000 20:32:28 -0400

Did some more snooping and found the following:

One is a postcript error showing in lpd-errs log
    Error: undefined    Offending command: ^D

Also found this in messages
    modprobe: can't locate module binfmt-0000

on 8/24/00 10:28 AM, rgp systems at [email-masked] wrote:

> I've got netatalk 2.1.38 running good on Yellow Dog Linux on a Mac G3. My
> printer is a HP
> LJ4M.
> 
> I installed LPRng, as per recommendations on netatalk lists. Everything
> seems to be set up correctly. If I print with lpr -Plp test.ps it shows up
> in the
> queue. My HP blinks a few times -- then nothing. Guess the server keeps
> trying cause a few seconds later the printer will blink twice again -- and
> still nothing.
> 
> So: the file spools ok, the printer is being seen, but the job isn't going
> through.
> 
> Printing with pap (pap -p "LJ4" test.ps) works fine.
> 
> I also installed LPRng on a completely different, well-functioning appletalk
> network, using MkLinux with a LaserWriter IIg -- with the same results.
> 
> HELP!
> 
> 
> Below are my config files:
> 
> 
> Printcap ***
> lp|LJ4|Randy's Laserjet: \
> :lp=| -$ /usr/bin/pap -e -p "Randy's Laserjet": \
> :sd=/var/spool/lpd/lp: \
> :ifhp=model=ps,status@: \
> :filter=/usr/local/libexec/filters/ifhp
> 
> papd.conf ***
> 
> :pr=| /usr/bin/lpr -Plp:\
> :op=netatalk:\
> :pd=/usr/local/lib/PPDs/Hewlett-Packard/LaserJet4
> 
> 
> atalkd.conf ***
> eth0 -phase 2 -net 0-65534 -addr 65280.164
> 
> afpd.conf ***
> "G3 Netatalk"  -tcp
> 

-- 
Randy Perry
rgp systems

Mac Consulting/Sales

---

From: rgp systems <[email-masked]>
Date: Thu, 14 Sep 2000 10:41:56 -0400

Well, I decided to play around a bit more with config files, and found
something that works. Here's my printcap:

lp:\
    :sd=/var/spool/lpd/lp:\
    :mx#0:\
    :sh:\
    :lp=| -$ /usr/bin/pap -e -p "Randy's Laserjet":\
    :ifhp=model=ps,status@:\
    :filter=/usr/lib/atalk/filters/ifpap

I just replaced ifhp with ifpap in the 'filter' parameter. Not sure why it
works, or if there are useless or redundant settings here, but it works and
I'm not messing with it.

Unfortunately, pap is not offering the printer on appletalk. Here's my
papd.conf:

LJ4:\
    :pr=| /usr/bin/lpr -Plp:\
    :pd=/usr/local/lib/ppd/lj4:

But, I was able to successfully create LPR printers with Apple's desktop
printer utility; so no big deal.

Below is my original post.

-- 
Randy Perry
rgp systems

Mac Consulting/Sales

---

From: BWS - Offwhite <[email-masked]>
Date: Thu, 14 Sep 2000 10:17:12 -0500 (CDT)

If you are using LPR, you do not need to have papd.conf set up with
Netatalk.  That is, if you are talking directly to the printer's IP.

I had to get a private network of Macs to talk to a laser printer outside
that network, on the public network, a while back and eventually found
that I couse the Desktop Printer Utility to talk to the printer's IP
directly.  I then shut down all papd.conf files and gave up on making that
work after several hours of troubleshooting and days of it working for
some cases and not working for others.

Now it always works with LPR.  After I got it work I placed a README file
in the "Installs & Upgraders" folder on the Netatalk fileserver in a
Printer directory.  The text of the README is below.  It basically
explains how to use the Desktop Printer Utility to set up LPR and the
folder includes the PPD file needed for our specific printer.  The folder
also the Desktop Printer Utility as a few of the people on the network
choose to delete key utilities such as that from their computers.

README.printer

How to Set Up the Printer

1) Start the Desktop Printer Utility by double-clicking the icon.

2) Select LPR from the list of printing options.

3) Set the printer type to "HP LaserJet 5Si Mopier."  If you cannot
   find that file on your local machine, you can copy the one in
   this folder to your local computer.

4) Set the IP of the printer to 207.7.33.254

5) Finally, save the new desktop printer calling it, "HP LaserJet 5Si."

Need more information, visit:
 - http://www.hp.com/cposupport/printers/support_doc/bpm01128.html

--- end README

Brennan Stehling - web developer and sys admin
projects: www.greasydaemon.com | www.onmilwaukee.com | www.sncalumni.com