Subject: Sudden Netatalk Printing Problems

From: Erik Oliver <[email-masked]>
Date: Thu, 02 Mar 2000 20:50:29 -0800

As of last night, my Mac computers can no longer print via Appletalk to
Netatalk on my Linux machine (i686/RedHat 6.1 Linux).

    Key points:
        Had been ok printing for 12 months.
        Suddenly stopped working, had even worked AFTER I upgraded the lpr
            package to Redhat's newest version.
        No changes on Macs, mix of 8.6 and 9.0.
        Printer: HP Laserjet 4ML (postscript)
        Continues to print from within Linux w/ /usr/bin/lpr for both PS and
            text.

    Attempted Fixes:
        Reinstalling lpr packages
        Restarted print server system
        Used RedHat printtool to remove and re-add printer
        Start-Shutdown of lpr
        Start-shutdown of atalkd/papd/etc in between.
        Changing papd.conf to use a pipe.
        Reselecting printer in chooser on Macs.

    Known changes:
        I attempted to configure a second Linux machine to print to mage
            as a remote lpd server. I did add an /etc/hosts.lpd naming
            the second Linux machine. No luck printing. Removed file,
            restarted lpd.
    
        Did not test Macs immediately after that, but today (the next
            afternoon), none could print.

Thoughts welcome,
Erik

Following includes error messages followed by relevant configurations:

----- syslog errors ----
Mar  2 20:27:23 mage papd[5942]: child 5966 for "Laserjet" from 65280.128
Mar  2 20:27:23 mage papd[5966]: lp_print queued
Mar  2 20:27:23 mage papd[5942]: child 5966 done
Mar  2 20:27:23 mage lpd[5967]: lp: job could not be printed
(cfA017mage.valdemar.net)

------ e-mail sent from LPD -----
Your printer job (estimated taxes worksheet)
was not printed because it was not linked to the original file

------- /etc/printcap ------
lp:\
        :sd=/var/spool/lpd/lp:\
        :mx#0:\
        :sh:\
        :lp=/dev/lp0:\
        :if=/var/spool/lpd/lp/filter:

------  /etc/atalk/papd.conf ----
Laserjet:\
# this had worked until 3/2/2000
        :pr=lp:pd=/etc/atalk/4ml.ppd:op=erik:
# tried below in an in attempt to fix the problem
#       :pr=|/usr/bin/lpr -Plp:pd=/etc/atalk/4ml.ppd:op=erik:

--
Erik Oliver             |   [I]f we only engage in projects we think will
[email-masked]       |     be noncontroversial, using as our yardstick
                        | whether what we do can be misused, then we will
                        |        wind up doing nothing because nothing of
                        |           scientific worth will pass that test.
                        |     And we'll always be afraid of what we find.
                        |                          -Dr. Angela Pattatucci

---

From: Doug Mandell <[email-masked]>
Date: Fri, 03 Mar 2000 10:13:54 -0800

I had seemingly the same problem you had, just a couple weeks back.  Can I 
ask you what lpr package you installed?  There is an issue with the lpr 
package on the RedHat site.  My problem was fixed by upgrading to lpr-0.50-3.

I think I may have been using 0.49-something...if you are as well, try the 
upgrade.

Hope this is of some help,

Doug

---

From: Erik Oliver <[email-masked]>
Date: Fri, 3 Mar 2000 10:23:47 -0800 (PST)

I am currently using lpr-0.48-? from RedHat, I will try the newer version
later tonight.

One other oddness, if I use
	root# lpc stop lp

and then print from a Mac and then try to manually print the df#### file
from the /var/spool/lpd/lp directory from the command line, e.g.
	root# lpr /var/spool/lpd/lpc/df#####
and then restart the print queue, the UNIX spooled version prints.

Also, today, I tried setting the debugging options ON in the RedHat's
filter, the filter is NEVER called by Mac print jobs, e.g. lpd cannot even
"open"/stat them whatever to be able to pass them to the filter.

Other checks, with the print queue stopped, I looked at file permissions
for UNIX vs. Mac print jobs, no significant differences.

-Erik
--
Erik Oliver
[email-masked]