Subject: [email-masked]

From: Joachim Kohlmorgen <[email-masked]>
Date: Tue, 20 Jun 2000 17:09:42 +0200

hello everyone,

   we successfully installed netalk (latest version) on Suse 6.4  but now a problem
   occured:

   4 Mac-Users are connected to the server. Any further attempt to
   login gets an AppleShare system error message. This is what the logfile
   says:

Jun 20 17:01:40 kepler afpd[1789]: ASIP session:548(1) from 172.17.0.33:2048(2)
Jun 20 17:01:40 kepler afpd[179]: server_child[1] 1789 done
Jun 20 17:01:53 kepler afpd[1790]: ASIP session:548(1) from 172.17.0.33:2049(2)
Jun 20 17:01:53 kepler afpd[1790]: dsi_getsess: too many connections
Jun 20 17:01:53 kepler afpd[179]: server_child[1] 1790 exited 1

   any suggestions?

 Joachim                          mailto:[email-masked]

---

From: Chip Mefford <[email-masked]>
Date: Tue, 20 Jun 2000 11:27:50 -0400

Hi Joachim;

This is pretty straightforward.

Go to /etc/atalk
check for a file named "conf"

in conf, edit the line for
AFPD_MAX_CLIENTS=5
to something reasonable like
AFPD_MAX_CLIENTS=50 keeping in mind
that each session eats something like 130k of memory.

restart /etc/rc.d/init.d/atalk and you should be
set.

lemme know
chipper

---

From: andrew morgan <[email-masked]>
Date: Tue, 20 Jun 2000 08:34:43 -0700 (PDT)

> Jun 20 17:01:53 kepler afpd[179]: server_child[1] 1790 exited 1

Look in your netatalk.conf file.  There is a setting there which is passed
to afpd to limit the maximum number of connections:

# Appletalk configuration
# Change this to increase the maximum number of clients that can connect:
AFPD_MAX_CLIENTS=20

Just set this to however many clients you need to support.

	Andy

---

From: "J.Riedler" <[email-masked]>
Date: Wed, 21 Jun 2000 09:35:00 +0200

Try it with this line in the start script /sbin/init.d/atalk
Cu Joe

---

From: "J.Riedler" <[email-masked]>
Date: Wed, 21 Jun 2000 11:34:05 +0200

Sorry!!!!
And now the linestartproc /usr/sbin/afpd ||-c 100 return=$rc_failed

----- Original Message -----
From: J.Riedler <[email-masked]>
To: Joachim Kohlmorgen <[email-masked]>; <[email-masked]>
Sent: Wednesday, June 21, 2000 9:35 AM
Subject: Re: [email-masked]

> >    we successfully installed netalk (latest version) on Suse 6.4  but
now
> a problem

---

From: Joachim Kohlmorgen <[email-masked]>
Date: Wed, 21 Jun 2000 13:36:32 +0200

Hello again,

  thanx for the lot of tips I received concerning my posting. I mixed
  everything together tried out and finaly changed the corresponding
  line in /sbin/init.d/atalk to

             startproc /usr/local/atalk/etc/afpd $ATALK_AFPD_PARAMS || return=$rc_failed

  where $ATALK_AFPD_PARAMS is read from the rc.config  and
  is set to -c  40
  
  I've tried to put all parameters in the afpd.conf but the -c didn't
  work.
  
regards from Hamburg,

Tuesday, June 20, 2000, 5:09:42 PM, I wrote:

JK> hello everyone,

JK>    we successfully installed netalk (latest version) on Suse 6.4  but now a problem
JK>    occured:

JK>    4 Mac-Users are connected to the server. Any further attempt to
JK>    login gets an AppleShare system error message. This is what the logfile
JK>    says:

JK> Jun 20 17:01:40 kepler afpd[1789]: ASIP session:548(1) from 172.17.0.33:2048(2)
JK> Jun 20 17:01:40 kepler afpd[179]: server_child[1] 1789 done
JK> Jun 20 17:01:53 kepler afpd[1790]: ASIP session:548(1) from 172.17.0.33:2049(2)
JK> Jun 20 17:01:53 kepler afpd[1790]: dsi_getsess: too many connections
JK> Jun 20 17:01:53 kepler afpd[179]: server_child[1] 1790 exited 1

JK>    any suggestions?

JK>  Joachim                          mailto:[email-masked]