Subject: Re: Dropboxes?

From: Jeff Thompson <[email-masked]>
Date: Fri, 26 May 2000 10:36:34 -0500 (CDT)

Rich -

    You must make the permissions write and execute for the group, and you
must set the group sticky bit. for example, you would type

    chmod 2730 dropbox

    or if you want everyone to write to it

    chmod 2733 dropbox

    I think that will solve your problem.

-Jeff Thompson
jeff@zaius(.dyndns).org, [email-masked], [email-masked]

Where do you think you're going today?

---

From: Rich Winkel <[email-masked]>
Date: Wed, 31 May 2000 18:38:53 -0500 (CDT)

I tried this but I'm still having trouble.  When I try to copy a file
into the drop box from another userid, I get an error that the file can't
be written because of an error of type -50.  There IS a file created,
but it has zero length, and is owned by the originating user rather
than the owner of the drop box.  The system log says
afpd[15957]: afp_openfork: ad_open: Permission denied

I'm using netatalk-1.4b2+asun-2.1.3 on freebsd 3.4-stable with the
netatalk and suiddir kernel options.

Thanks for any help!!

---

From: Chip Mefford <[email-masked]>
Date: Thu, 1 Jun 2000 06:59:36 -0400 (EWT)

Just in case anyone cares, 

I worked on this for days, tried everything I could 
think of, tried everything everyone on the list suggested
and in the end, couldn't get it to work and gave up. 

Now my "drop_boxes" are rw by everyone on the
machine. 

I did it like this;

/home/user1
/home/user2 and so on

and;
/home/drop_box

built a new user script that works like this;
u="$1"
g="$2"
if [ "$1" -a "$2" ]
then
user="/home/dropbox/$u"
        mkdir -p "$user"
        ln -s "$user" "/home/$u/drop_box"
        chown -R "$u" "$user"
        chgrp -R "$g" "$user"
        chmod g+rwx "$user"
        chmod o+rwx "$user"

so there is a share called "drop_box" in that
share is a dir for each user, anyone can mount
that share and get to anyone elses drop box, if they
are a member of the same group, kinda
like a physical company mailbox, any one user
can see his own dropbox via a symlink from their
home dir, so user1 can just move stuff into
his own drop_box and tell user2 it is there if they
are too lazy to mount the share "drop_box" and drop
whatever into user2s drop_box. 

It works out pretty well for my users as they
all had a hard time with the appleshare concept
of drop boxes. Folks used to whine at me that they 
couldn't see what was in other folks dropboxes and 
kept telling them it wasn't any of their busines, and
that didn't work. 

This seems to be a decent compromise. 

Works good on samba as well.