Subject: Re: performance once again...

From: Dave Ritter <[email-masked]>
Date: Mon, 16 Oct 2000 12:37:51 -0500

what type of network are you using (cards, speed, hubs or switches)?

> From: andrew morgan <[email-masked]>
> Reply-To: andrew morgan <[email-masked]>
> Date: Mon, 16 Oct 2000 02:14:31 -0700
> To: David Fickes <[email-masked]>
> Cc: [email-masked]
> Bcc: "Dave Ritter" <[email-masked]>
> Subject: Re: performance once again...
> 
> 
> 
> On Sun, 15 Oct 2000, David Fickes wrote:
> 
>> I've seen a few messages regarding this but none seems to answer
>> my couple of questions definitively. I'm interested in gauging
>> netatalk performance in the following environment.
>> 
>> I'm running netatalk-asun on a FreeBSD 4.0 system. The clients
>> are a mix of MacOS9 (iMac 350s) and a G4/450.
>> 
>> The software where we need the performance is MYOB which shares
>> the datafile and does lookups when requestings lists of data
>> such as customers and such.
>> 
>> MYOB has two options for network access: TCP/IP and Appletalk
>> 
>> The server is currently an AMD K62 / 350 with minimal RAM at this
>> time. The drive is a new ATA66.
>> 
>> Client access on the netatalk server seems to be better than from the
>> iMac but not by much of course having the datafile on your local machine
>> is MUCH better.
>> 
>> I'm wondering where the bottlenecks are in the system.
>> Options are:
>> 
>> RAM (currently 64 MB)
>> Faster disk drive (I have a spare U2W drive and card)
>> Faster CPU?
>> 
>> I'm interested in any suggestions.
> 
> On your server, try running top, vmstat, or iostat to see what is
> happening.  In top, look at the information at the top of the screen to
> see if you are spending most of your time in 'iowait' or 'kernel' or
> 'system' (whichever is appropriate for your top).
> 
> Also look at your free memory and swap used readings.  If your swap used
> is too high (maybe 50% of your total physical memory -- 32MB), you may
> want more memory, and that may also affect the amount of time your system
> spends in 'iowait' if it is actively swapping.
> 
> Rarely is a file server cpu-bound.
> 
> Probably, you don't have a fast enough disk array.  If you are using a
> single disk drive, you probably won't get more than 4-5MB per second out
> of it (sustained).  You'll need some form of disk striping (RAID 0 or 5 or
> LVM) to really get the most IO performance.
> 
> I'm not familiar with MYOB, so I don't know what kinds of accesses you
> need to support.  Small, random IO?  Large blocks of data?  Does this act
> like a database server or a file server?
> 
> Hope this helps...
> 
> Andy
> 
>

---

From: Steve Freitas <[email-masked]>
Date: Mon, 16 Oct 2000 12:27:00 -0700

If you've got multiple users accessing the disk simultaneously, SCSI 
makes a world of difference over IDE. Although IDE mechanisms are quite 
nice these days (and are frequently identical to their SCSI 
counterparts), the SCSI protocol is still far better at gracefully 
scheduling disparate accesses and is highly recommended for any kind of 
halfway-serious fileserver.

Steve Freitas