Subject: setting up netatalk

From: Hong F Du <[email-masked]>
Date: Tue, 27 Jun 2000 10:22:01 -0400

Subject: setting up netatalk
From: Hong F Du <[email-masked]>
To: netatalk-mails-support <[email-masked]>
Date: Thu, 22 Jun 2000 14:14:38 -0400

Hi All,
I am trying to setup netatalk on Redhat 6.1, but it is not working.

Here is what I did:
1)downloaded the netatalk-1.4b2+asun2.1.3-7.i386.rpm
2) then install it by command 'rpm -ivh
netatalk-1.4b2+asun2.1.3-7.i386.rpm'
3) edited only two lines in afpd.conf, they are
    -
    phys2 -port 12000 -address 134.74.32.31

4)atalkd.conf file was untouched
5) run atalkd, and afpd

>From a mac, I can see the file server name phys2. But when I click on
it, I got message say the server doesn't response, please try again.

Then, I rebooted my Linux server. I got message "can't register
eshop:netatalk@*"
After that, I cannot see any file server name from the mac anymore even
I restarted afpd and atalkd manually

What was I missing or did wrong?  How do I fix it? Thank you for your
help in advanced.

By the way I have ipmaq running, and the mac can access the internet.

Regards,

feng

---

From: Peter Gutowski <[email-masked]>
Date: 28 Jun 2000 06:41:58 -0400

On Wednesday, June 28, 2000, Paul Krohn <[email-masked]> wrote:
>#     -port <number>      Specifies the TCP port the server should respond
>#                         to (default is 548)
>
>if you change the port with the -port option, you must also hack every 
>copy of AppleShare on your network to speak to that port (there's an 
>apple utility for this, whose name i've forgotten). best bet is almost 
>always to not use the -port option, unless you have a
>compelling local reason to use it.

Regardless of the motivations behind "why" you would want to had an additional server responding to a certain port, it is certainly possible to connect to a non-standard port _without_ 'hacking very copy of AppleShare on the network':

Instead of typing into the "Server IP Address..." dialog:

      host.domain.com

you would type:

      host.domain.com 12000          // i.e.: <host><whitespace><port>

where '12000' is the target port number in the afpd.conf file. It can have its own separate 'AppleVolumes.*' files, etc, etc, so that what's presented to the client is different from the options at port 548. Naturally the user interface to this isn't as intuitive as using the chooser, which will try to make the connection to the default port 548.

-P