Subject: Re: Re: Modules not loading with asun2.1.4pre39

From: "jeff b" <[email-masked]>
Date: Tue, 06 Jun 2000 20:12:17 +0000 (GMT)

On Tue, 6 Jun 2000 Dejan Muhamedagic  wrote:
> Hi,
> 
> On Mon, Jun 05, 2000 at 09:08:09PM +0000, jeff b wrote:
> > For one reason or another, none of my UAMs will load, with the exceptions
> > of uams_randnum.so and uams_guest.so
> > 
> > All uams in the directory were specified (with one exception, in each
> > case), and yet only those two modules were loaded.
> 
> Do you mean specified in the startup file as arguments to afpd?
> Are you definitely sure that this is the case?  Because, if an UAM
> can't be loaded then an error message should be issued.  You
> should be able to see how afpd was started by using 'ps auxw |
> grep afpd' and looking at the process which is running as root.
> Or trace (set -x) the startup script.
> 
> If UAMs are specified on the line, don't load and there are no
> error messages than I'm in a complete dark.

The UAMs were specified in the netatalk.conf script (which is passed as -U [modules]) and also in the afpd configuration file. They don't load. 
I have only been checking /var/log/messages for errors, of which there are none.

I ldd'd the modules, and it turns out that uams_randnum.so and uams_guest.so (the two modules that work) are for some reason statically 
linked. Any idea why they are, or why this could be causing problems? Even the cleartext modules aren't working. I didn't see anything in the 
etc/uams/Makefile to indicate static compilation of specific modules...
     
*************************
jeff b
system administrator
university communications
university of connecticut
[email-masked]

---

From: Dejan Muhamedagic <[email-masked]>
Date: Tue, 6 Jun 2000 23:28:28 +0200

Hi,

> etc/uams/Makefile to indicate static compilation of specific modules...

I don't think that this is a culprit.  But it may be a hint.
The reason is probably that those which happened to be statically
linked don't use any functions from other libraries (i.e. they're
more or less empty and pretty useless).  Use nm(1) to see the list
of defined symbols.  In particular uam_setup should be present.
Each of uams which doesn't contain uam_setup function has probably
been excluded in the Makefile with #define (or a lack of one).
Perhaps you should check the top level Makefile one more time.  I
think that between versions 2.1.4-37b and 39_test some #defines in
respect to authentication have changed defaults.  At the moment I
can't help you any more because I don't have a working netatalk
here.  I should be able to check it out tomorrow.

BTW, I may have been wrong when I said that error should be
reported if the module was specified and wasn't loaded.  Not sure
anymore.

Good luck.

Dejan