Subject: Ignored AppleVolumes.*? (empty chooser with NetBSD 1.41/netatalk)

From: Heiko <[email-masked]>
Date: Fri, 5 May 2000 20:57:27 +0200

Hi,

since the mailservers in my office are down (I love you-virus...), I'm now writing from my home account.

Anyway, my problem, the empty chooser, remains. All AppleVolumes.* seem to be allright. Permissions are double-checked.

Now I trashed the precompiled package, und compiled my own from netatalk-990130 (from ftp.netbsd.org), but with no affect.

Then I downloaded the netatalk-1.4b2, portet to NetBSD, compiled it, but the problem still remains.
Has anyone an idea?
Heiko

---

From: Patrik Schindler <[email-masked]>
Date: Fri, 5 May 2000 21:21:13 +0200

>Anyway, my problem, the empty chooser, remains. All AppleVolumes.* seem to be allright. Permissions are double-checked.

If BSD has strace, what says "strace afpd -d"?

:wq! PoC

---

From: Heiko <[email-masked]>
Date: Mon, 8 May 2000 22:12:49 +0200

Hi,

since nobody had an suggestion, here are some more informations that may (hopefully) help:

-------->8--------AppleVolumes.system----------->8------------
.	BINA	UNIX
~
/tmp	Temp
/export	Mordor
# DAS ist das Ende der Datei...:-)
-------->8--------AppleVolumes.system----------->8------------

-------->8--------`afpd -d`---------->8------------
starting appletalk daemons: atalkd nbprgstrcommand: 18
12 0E 41 46 50 56 65 72 73 69 6F 6E 20 32 2E 30 	..AFPVersion 2.0
10 43 6C 65 61 72 74 78 74 20 70 61 73 73 77 72 	.Cleartxt passwr
64 05 68 65 69 6B 6F 00 00 00 00 00 00 00 00 00 	d.heiko.joshu...
(end)
reply: -5023, 0
(end)
done
command: 18
12 0E 41 46 50 56 65 72 73 69 6F 6E 20 32 2E 30 	..AFPVersion 2.0
10 43 6C 65 61 72 74 78 74 20 70 61 73 73 77 72 	.Cleartxt passwr
64 05 68 65 69 6B 6F 00 00 00 00 00 00 00 00 00 	d.heiko.joshua..
(end)
reply: 0, 0
(end)
command: 16
10                                              	.               
(end)
reply: 0, 1
39 17 05 05 00 00 00 00 03 72 64 6F 72 00 04 54 	9........rdor..T
65 6D 70 00 05 68 65 69 6B 6F                   	emp..heiko      
(end)
-------->8--------`afpd -d`---------->8------------

As you may see, I entered the wrong password once ;-) ....on the second try, there was an outgoing (?) packet including fragments of the names of the two volumes, which should appear in the chooser (in fact, they don't).

Can anybody please translate the packets and tell me what they mean, and what is going wrong!?

Heiko