Subject: Can't Log in as use, Shadow supported

From: GoRN ToTheRescue <[email-masked]>
Date: Sat, 6 May 2000 00:24:48 -0700 (PDT)

Hello, I use shadow passwords and have a shadow supported netatalk but i still can only log in as
guest. I think it may have to do with the encryption of my shadow file, it looks like this:
$1$DRmt30q.$lwTR.GAcQQ9U------ that isn't the whole thing.... anyway is there a way to have
netatalk look at a differnet password file with the right encryption or to have it read this
encryption? or is this not even my problem? I'm great with macs and i'm learning linux, i think i
might be able to use chroot but i don't know how, any and all help is awsome! thanks!

__________________________________________________
Do You Yahoo!?
Send instant messages & get email alerts with Yahoo! Messenger.
http://im.yahoo.com/

---

From: "David Lancaster" <[email-masked]>
Date: Sat, 6 May 2000 12:41:13 -0300

If you're trying to use randnum/rand2num instead of cleartext, afpd can't
check the password against the encrypted shadow file, since it doesn't have
the plaintext password.  It needs the password stored in the user's home
directory in the file .passwd, which it then encrypts with randnum/rand2num
and checks against the encrypted password transmitted from the client.

To check if that's you're problem, look at the bottom of the login box when
you select your netatalk box from the chooser.  If it says 2 way Encrypted,
that's your problem.

Oh, make sure that the permissions of the .passwd file are 600, and the uid
and gid are the same as the user's uid and *primary* gid.

D.