Subject: Re: problems with papd

From: Patrik Schindler <[email-masked]>
Date: Sun, 7 May 2000 13:01:50 +0200

At 15:51 Uhr +0200 06.05.2000, Moritz Kaiser wrote:

>Starting AppleTalk daemons (this will take a while): atalkd afpdBad
>termcap entry
>Bad papcap entry
> papd.

Try to start papd by hand with -d switch to force debug output. Perhaps this will tell you more. Double-check your /etc/printcap for errors. What printing system have you installed on your Debian machine?

:wq! PoC

---

From: Moritz Kaiser <[email-masked]>
Date: Sun, 7 May 2000 15:58:40 +0200 (CEST)

On Sun, 7 May 2000, Patrik Schindler wrote:

> Try to start papd by hand with -d switch to force debug output.
> Perhaps this will tell you more. Double-check your /etc/printcap for
> errors. What printing system have you installed on your Debian
> machine?
papd -d produces nearly the same output:
8<--------------------
Bad termcap entry
Bad papcap entry
8<--------------------
The first funny thing is, there is no termcap in my etc. I'm using
terminfo database.
The second funny thing is, if i remove /etc/netatalk/papd.conf and replace
it with touch /etc/netatalk/papd.conf, no errors are encountered.
What the hell is going on?
My local printing system is good old BSD-style lpd.
My printcap has no errors, because I'm able to print via Samba without any
problems.

Greetings,
Moritz

Ah, PS: my /etc/printcap:
8<-----------------------
lp|kyo|kyocera:\
	:lp=/dev/lp2:sd=/var/spool/lpd/kyo:\
	:sh:pw#80:pl#72:px1440:mx#0:\
	:if=/etc/magicfilter/psonly600-filter:\
	:af=/var/log/lp-acct:lf=/var/log/lp-errs:

lp2|kyo2|kyocera:\
	:lp=/dev/lp2:sd=/var/spool/lpd/kyo:\
	:sh:fq:\
	:af=/var/log/lp-acct:lf=/var/log/lp-errs:
8<-----------------------
__________________________________________________________
Moritz Kaiser
Studentische Vertretung, Technische Universitaet Muenchen
Europe / Germany

---

From: Dejan Muhamedagic <[email-masked]>
Date: Sun, 7 May 2000 17:51:36 +0200

Hi,

> The first funny thing is, there is no termcap in my etc. I'm using

Not sure where this exactly stems from, but it definitely refers to
printcap and not termcap.  The point being, however, that the same
syntax is used for both.

> it with touch /etc/netatalk/papd.conf, no errors are encountered.

And you have no printers served :)

> My printcap has no errors, because I'm able to print via Samba without any

This is interesting.  It could be that there's a bug in papd function
which is parsing /etc/printcap.  Or, perhaps, lpd handles errors in
printcap gracefully.

> Ah, PS: my /etc/printcap:
Could there be an err^^or (px#1440)?

Regardless, I would suggest that you try with a very simple printcap
entry (referred to from papd.conf) and then try adding more capabilities
until you find an error.  Also, did you try changing the lp capability
to pipe in papd.conf as it was suggested?

Dejan

---

From: Moritz Kaiser <[email-masked]>
Date: Sun, 7 May 2000 19:00:29 +0200 (CEST)

> printcap and not termcap.  The point being, however, that the same
hmm, I also installed a common termcap but the results were the same.

> And you have no printers served :)
Oh, I _have_ printers served. But I cannot provide .PPDs which are
essential for driving Kyocera FS1700+.

> Could there be an err^^or (px#1440)?
Even if when I disabled the first part of my printcap with hashes, the
same errors occured.

> Regardless, I would suggest that you try with a very simple printcap
I will do so.
> to pipe in papd.conf as it was suggested?
I did so. No effect.

desperately,
Moritz

---

From: Patrik Schindler <[email-masked]>
Date: Sun, 7 May 2000 20:11:52 +0200

>papd -d produces nearly the same output:

Bad thing.

>The first funny thing is, there is no termcap in my etc. I'm using

I don't know for what reason papd need termcap.

>it with touch /etc/netatalk/papd.conf, no errors are encountered.

Hm, without a printer, it won't jump into a routinge which insists on a termcap. And on reading /etc/printcap. You may verify this with strace.

>My local printing system is good old BSD-style lpd.

Very good. This is known to work.

>My printcap has no errors, because I'm able to print via Samba without any

Very strange.

Did you compile it yourself or installed a precompiled package? Perhaps you should try the first...

:wq! PoC