Subject: Re: crazy syslog errors!

From: "Jamie McParland" <[email-masked]>
Date: Sat, 29 Apr 2000 09:46:05 -0700

Per your advice i removed the -seed option from eth1. 

eth0 -seed -phase 2 -net 40-49 -addr 41.1 -zone "100 baseLinux Box"
eth1 -phase 2 -net 40-49 -addr 42.1

After a restart i looked in the chooser and no zones show up, and when i
click on my linux box in the chooser i get the connection failed error. But
i can still connect aftovertcp. This has been my problem ever since i set up
netatalk a few months ago. Anyway so when i check the atalkd.conf it looks
to automatically changed my config to this

eth0 -seed -phase 2 -net 40-49 -addr 41.1 -zone "100 baseLinux Box"
eth1 -phase 2 -net 65280-65534 -addr 65280.168

whats up with that! LOL!

My net work is a 266 imac, a B&W G3 400 and a laserwriter pro 600 (actually
the printer is disconnected  from the network)

I would have tryed this
-======-=-=-==-=-==-=-==-=
Try to completely shut down netatalk (and watch with ps that it's gone),
unload the appletalk kernel module to get rid of all AppleTalk stuff.
Now check your atalkd.conf again to make sure, atalkd has not modified it's
contents. Then re-start netatalk.
-==-=-=-==-=-=-=-==-=

but i have no idea how to unload appletalk from the kernel

Thanks!
Jamie McParland
Apple Certified Technician
Apple Product Professional

[email-masked]

----------
>From: Benjamin Gilbert <[email-masked]>
>To: "Jamie McParland" <[email-masked]>, "netatalk"
<[email-masked]>
>Subject: Re: crazy syslog errors!
>Date: Sat, Apr 29, 2000, 9:32 AM
>

>  (-seed) on an interface
> which already has a seed router (thus zones), and your net range doesn't
> match the other seed router's net range.  If this is the case, *shut down
> atalkd immediately* until you can fix the problem.  Conflicting seed
> routers can really screw up an AppleTalk network.
> (Computers/printers/zones will spontaneously appear and disappear in the
> Chooser; not all Macs will be able to see all other Macs; ...)

---

From: Patrik Schindler <[email-masked]>
Date: Sat, 29 Apr 2000 21:19:13 +0200

>Per your advice i removed the -seed option from eth1. 

To whom advice?

>eth1 -phase 2 -net 65280-65534 -addr 65280.168

Yeah, right. If you don't have an AppleTalk router on eth1, there's no way how atalkd could guess the network configuration for eth1.

>but i have no idea how to unload appletalk from the kernel

rmmod appletalk (lsmod shows available modules).

So restore your old atalkd.conf and try again.

:wq! PoC