Subject: Follow up on sudden netatalk printing problems

From: Erik Oliver <[email-masked]>
Date: Sat, 04 Mar 2000 07:46:26 -0800

Followed Doug Mandell's helpful advice and upgraded to lpr-0.50 from the
RedHat 6.2beta.

Unfortunately, netatalk printing still gives the same errors. It is as if
there is some bizarre interplay where the way papd has stored the file in
/var/spool/lpd/lp is not accessible to lpd.

Any other thoughts?

Right now, my next step is to order an Asante Etherprint (or similar device)
as an interim solution for the Macs...

-Erik

---- repeat of error message info etc.----

    Key points:
        Had been ok printing for 12 months.
        Suddenly stopped working, had even worked AFTER I upgraded the lpr
            package to Redhat's newest version.
        No changes on Macs, mix of 8.6 and 9.0.
        Printer: HP Laserjet 4ML (postscript)
        Continues to print from within Linux w/ /usr/bin/lpr for both PS and
            text.

    Attempted Fixes:
        Reinstalling lpr packages
        Restarted print server system
        Used RedHat printtool to remove and re-add printer
        Start-Shutdown of lpr
        Start-shutdown of atalkd/papd/etc in between.
        Changing papd.conf to use a pipe.
        Reselecting printer in chooser on Macs.

    Known changes:
        I attempted to configure a second Linux machine to print to mage
            as a remote lpd server. I did add an /etc/hosts.lpd naming
            the second Linux machine. No luck printing. Removed file,
            restarted lpd.
    
        Did not test Macs immediately after that, but today (the next
            afternoon), none could print.

Thoughts welcome,
Erik

Following includes error messages followed by relevant configurations:

----- syslog errors ----
Mar  2 20:27:23 mage papd[5942]: child 5966 for "Laserjet" from 65280.128
Mar  2 20:27:23 mage papd[5966]: lp_print queued
Mar  2 20:27:23 mage papd[5942]: child 5966 done
Mar  2 20:27:23 mage lpd[5967]: lp: job could not be printed
(cfA017mage.valdemar.net)

------ e-mail sent from LPD -----
Your printer job (estimated taxes worksheet)
was not printed because it was not linked to the original file

------- /etc/printcap ------
lp:\
        :sd=/var/spool/lpd/lp:\
        :mx#0:\
        :sh:\
        :lp=/dev/lp0:\
        :if=/var/spool/lpd/lp/filter:

------  /etc/atalk/papd.conf ----
Laserjet:\
# this had worked until 3/2/2000
        :pr=lp:pd=/etc/atalk/4ml.ppd:op=erik:
# tried below in an in attempt to fix the problem
#       :pr=|/usr/bin/lpr -Plp:pd=/etc/atalk/4ml.ppd:op=erik:

--
Erik Oliver                     | Of the choice of two evils, I pick
[email-masked]               |    the one I've never tried before

---

From: andrew morgan <[email-masked]>
Date: Sat, 4 Mar 2000 08:34:26 -0800 (PST)

> /var/spool/lpd/lp is not accessible to lpd.

Have you restarted the lpd daemon after upgrading?

I will forward a message to netatalk-admins from the last guy who had this
problem.  It includes a patch to netatalk to work around this problem.

	Andy

---

From: Erik Oliver <[email-masked]>
Date: Sat, 04 Mar 2000 08:45:24 -0800

Erik bangs his head against the wall.

I had assumed that the rpm -Uvh would restart lpd, it did not. Problem is
solved. My bad.

My thanks go to both Andy and Doug for their combined efforts.

-Erik