Subject: Re: [Fwd: Quark Save As Error w/Netatalk 2.1.3]

From: Peter Gutowski <[email-masked]>
Date: 18 Feb 2000 17:03:27 -0500

I've mostly read and ignored this thread, since we've installed Xinet FullPress on a Sun this past fall. But until that point for two years we had been using netatalk as our mail file server. Since our business is digital prepress, we use Quark A LOT. I've never experienced any of the problems that you seem to show in the message. We do still use netatalk, but not for our principal file server anymore. We're currently using netatalk1.4b2+asun2.1.4 (pre-37 I believe) on a Linux 2.2.13 kernel machine running on a 350mhz Pentium. Just out of interest I copied quark files to my home directory, accessed via netatalk, open, changed and re-saved without incident.

My suspicion is a permission thing on your file system. Just my 0.02.

-- 
Peter Gutowski

[email-masked] • http://www.powervue.com/~peterg

On Saturday, April 8, 1939, Mitch McNeel <[email-masked]> wrote:
>Is there a patch to fix this??  
>
>Any suggestion welcome!!!
>
>I get this in /var/adm/messages file:
>
>Feb 17 11:04:19 unix: netatalk 1.4b2+asun2.1.3
>Feb 17 11:58:28 afpd[4391]: afp_openfork: ad_open:
>Permission denied
>Feb 17 12:02:22 afpd[4391]: dsi_stream_read(-1): Connection
>reset by peer
>Feb 17 12:02:22 afpd[4391]: dsi_stream_write: Broken pipe
>Feb 17 12:02:22 last message repeated 1 time
>Feb 17 12:10:54 afpd[4435]: dsi_stream_read(-1): Connection
>reset by peer
>Feb 17 12:10:54 afpd[4435]: dsi_stream_write: Broken pipe
>Feb 17 12:10:54 last message repeated 1 time
>
>Thanks in advance
>Mitch
>
>-------- Original Message --------
>Subject: Quark Save As Error w/Netatalk 2.1.3
>Date: Thu, 17 Feb 2000 12:15:44 -0800
>From: "Glen Schuler" <[email-masked]>
>To: [email-masked]
>
>Get this error when trying to save as with Quark version
>4.04:
>
>Unkown error. [-1072]
>
>"Server(ipaddress) via TCP/IP"
>
>The file server's connection has unexpectedly closed down
>[12:10 PM on 2/17/00].
>
>Can you send list to Netatalk List.
>
>Thanks
>Glen

---

From: Marcus Radich <[email-masked]>
Date: Sat, 19 Feb 2000 11:57:09 +1300

I admin 12 different companies using RHLinux 6.1 netatalk servers, 
and I can tell you that it is related to the fact that you are using 
2.1.3, not permissions.
The problem *only* shows up when running OS9 on new hardware. asun 
confirmed with the following:

<asun>
it's actually a bug with the appleshare client. i've implemented a
workaround in my current development code to deal with it.
</asun>

Compile 2.1.437b on your machine, and remember to include the DEFS= 
as I specified in my last email.

I have upgraded all my clients now, and the problems have all disappeared.
(asun2.1.3 was my standard setup for a long time until G4/OS 9 arrived!)

At 5:03 PM -0500 18/2/2000, Peter Gutowski wrote:
>I've mostly read and ignored this thread, since we've installed 
>Xinet FullPress on a Sun this past fall. But until that point for 
>two years we had been using netatalk as our mail file server. Since 
>our business is digital prepress, we use Quark A LOT. I've never 
>experienced any of the problems that you seem to show in the 
>message. We do still use netatalk, but not for our principal file 
>server anymore. We're currently using netatalk1.4b2+asun2.1.4 
>(pre-37 I believe) on a Linux 2.2.13 kernel machine running on a 
>350mhz Pentium. Just out of interest I copied quark files to my home 
>directory, accessed via netatalk, open, changed and re-saved without 
>incident.
>

========================================================

"Always ask the question, never assume the answer."
		Marcus Radich 1999

This message has been checked with GRIMEsweeper which has detected a virus
embedded in this plain text message. You should now delete your entire hard
drive and rinse your eyes with soapy water to ensure it doesn't spread.

========================================================

---

From: R Cent <[email-masked]>
Date: Fri, 18 Feb 2000 17:45:07 -0800 (PST)

> I have upgraded all my clients now, and the problems have
> all disappeared. (asun2.1.3 was my standard setup for a long
> time until G4/OS 9 arrived!)

This seems like a significant juncture for Netatalk.  Any chance
this version will be available in RPM form?  

_____________________________
Bob Cent 
University of Washington
Box 357330
Seattle, WA  98195-7330  

mailto: [email-masked]
voice:  206.543.1433
fax:    206.685.0305
_____________________________