Subject: Re: netatalk in production environments....(RFC)

From: "S.Ecker" <[email-masked]>
Date: Wed, 31 May 2000 17:56:47 -0700 (PDT)

(slightly OT) What I want to know is what the
commercial linux hardware/software resellers are using
when they say they support Appletalk protocol for file
sharing.  Cobalt (www.cobalt.com) sells linux
file/mail/dns/etc servers for windows/unix/mac
environments, but they don't say what they use for
their Appletalk server protocol.  If they're using
netatalk, aren't they taking a great risk by deploying
unsupported server code to their customers?

-Scott

--- andrew morgan <[email-masked]> wrote:
> 
> 
> On Wed, 31 May 2000, Daniel E. Lautenschleger wrote:
> 
> > Are these tweaks, changes and mods incorporated
> into a new
> > version of Netatalk on a frequent enough basis? Is
> Adrian Sun the only
> > person who maintains the Netatalk program any
> longer?
> 
> There are a few people contributing to parts of
> netatalk at least.  Andras
> Kadinger and I have made some improvements to papd
> recently, but Adrian is
> the only one making substantial changes to afpd that
> I know of.
> 
> > By the way, where has he been? He used to post
> quite frequently and I have
> > not seen a posting in quite a long time.
> 
> I haven't heard a word from him for a while either. 
> I've submitted some
> patches to him directly, but I haven't received any
> response.  I hope he
> is okay!
> 
> > It appears that the folks at the University of
> Michigan now view Netatalk
> > as an open source program. Frankly, I use the
> program and am excited about
> > its potential, but am not pleased with the
> documentation and
> > updating issues surrounding Netatalk. It appears
> the archives of the
> > mailing list are *way* out of date as well.
> 
> The documentation is definately lacking, especially
> some simple
> installation instructions.  Fortunately, this is
> something netatalk users
> without programming experience can contribute!
> 
> > I realize it is a free program and am mostly
> satisfied with the results
> > I've had using the program. I too want to roll
> this product out on a much
> > larger scale than I have already, but it just
> isn't ready for prime time
> > yet. I only wish my programming skills were up to
> snuff so that I could
> > contribute in a positive manner.
> > 
> > I'm complaining out of frustration, folks. I
> really hope to someday be
> > serving 200+ Mac clients of my Linux boxes using
> Netatalk:-)
> 
> If Adrian Sun is really out of the picture, maybe we
> should grab the
> latest code and start a site on SourceForge for a
> more collaborative
> development environment...  That would allow the
> rest of the community to
> contribute code and documentation without having to
> funnel it through
> Adrian.
> 
> Any thoughts?
> 
> 	Andy
> 

__________________________________________________
Do You Yahoo!?
Send instant messages & get email alerts with Yahoo! Messenger.
http://im.yahoo.com/

---

From: Ron Chmara <[email-masked]>
Date: Wed, 31 May 2000 18:58:51 -0700

"S.Ecker" wrote:
> sharing.

Depends on the vendor. Helios wrote their own, but most
vendors are using a bundled, or customised, version of
netatalk+asun. I rarely see CAP in use anymore.

> Cobalt (www.cobalt.com) sells linux
> their Appletalk server protocol.

Er... tee hee<g>.

netatalk+asun is the software package used by most
vendors, including Cobalt.

[email-masked] wrote most of the current appleshareIP
code. (See anything in common?)

ASun=Adrian Sun. Cobalt is employing an *author* of the
code. Much like actully having the programmers of software
working for you, an _extremely_ rare thing at OS and
systems vendors (most current Microsoft Employees did not
write the original code for windows, they just support and
maintain the code.) I guess cobalt gets the most of
Adrian's time, but he's not the only netatalk hacker.
Other people have released GUI's, patched code, etc.

> If they're using

What do you mean by "unsupported"? Cobalt supports their
packages. If you want to buy support from Linuxcare you
can, if you wish to take the code apart, line by line,
and change it, you can. If you wish to use, oh, Torque
for your systems, you can get support from them.

How is netatalk "unsupported"? Do you want 1-800 numbers
where you can pay on a company credit card by the minute,
or what?

-Ronabop

--
Brought to you from iBop the iMac, a MacOS, Win95, Win98, LinuxPPC machine,
which is currently in MacOS land.  Your bopping may vary.