Subject: Re: Serious Problems

From: Robert Bell <[email-masked]>
Date: Thu, 08 Jun 2000 11:21:56 -0700

> >Try doing a chmod -R 777 on the entire shared volume and see if you still
> >have the same problems. If they have gone away (as they did when I first
> >started with Netatalk) them you can start a user & group plan of the server.
> 
> Why have files executable? It makes no sense at all and if files have 
>to be accessed from the unix side, this could be confusing. At least it's 
>unpleasant.

My understanding of netatalk,
The group permissions are very important, the owner permission are secondary.

And since you do not execute "MAC" files or programs on the netatalk host,

I would do a 

chmod -R 2666  (do allow everyone access including 
                when someone creates new folders)
or 
chmod -R 2660  (do allow only those in the group to access 
                including when someone in the group creates a sub-folder)

  Robert Bell.

---

From: "Lancaster, David Matthew" <[email-masked]>
Date: Thu, 8 Jun 2000 15:31:06 -0300 (ADT)

David Lancaster                       (506) 454-2167
  690 Gregg Ct.                       Upper Apartment
  Fredericton, NB  Canada             E3B 4H5
  [email-masked]       "Don't anthropomorphize computers, they hate that."

>                 including when someone in the group creates a sub-folder)

You need +x to enter a directory....

---

From: Robert Bell <[email-masked]>
Date: Thu, 08 Jun 2000 12:12:27 -0700

> You need +x to enter a directory....

you are right.

If using Linux do both of the following find commands,

find . -type d -print0 | xargs -0 chmod 2777   (or 2770 or 2775)
find . ! -type d -print0 | xargs -0 chmod 2666 (or 2660 or 2664)

first numbers are for read and write access by everyone
second numbers are for read and write by group only
third numbers are for read and write by group, and read by everyone.

---

From: Patrik Schindler <[email-masked]>
Date: Fri, 9 Jun 2000 00:46:12 +0200

>The group permissions are very important, the owner permission are secondary.

Partially wrong.

>And since you do not execute "MAC" files or programs on the netatalk host,

Mac, not MAC. MAC has something to do with Ethernet.

:wq! PoC

---

From: Patrik Schindler <[email-masked]>
Date: Sat, 10 Jun 2000 15:13:38 +0200

At 16:15 Uhr -0700 08.06.2000, Robert Bell wrote:

>Where am I wrong?

We're doing shared directories beween users here and first authority which may o may not write is the user. As with unix, too.
If you set up an appropriate environment, the group may also write or not, but this isn't something the user has nothing to do with.

:wq! PoC