Subject: Problems with afpd option ...

From: "Ralf Krause-Dietering" <[email-masked]>
Date: Thu, 27 Jan 2000 21:40:48 +0100

Hi,

I am trying to set up my Linux box as a CDROM server for Mac using kernel 2.3.39 and netatalk-1.4b2+asun2.1.3-42.

Mounting the HFS CDs works fine, my Mac can access to the files on the CD, but all files are listed as generic documents - they haven't got any type or creator.

Mounting the HFS-CD with "-o afpd" or "-o fork=netatalk" brings up the problem, that the CD is shown in the Mac's chooser only in grey characters and not accessable.

I read in the mailing lists, that there were problems with kernels 2.2.x: The afpd-options doesn't work with these kernels. But doesn't it work with kernel 2.3.39, too?

---

From: Patrik Schindler <[email-masked]>
Date: Thu, 27 Jan 2000 22:27:32 +0100

At 21:40 Uhr +0100 27.01.2000, Ralf Krause-Dietering wrote:
>     Hi,   I am trying to set up my Linux box as a CDROM  server for Mac using kernel 2.3.39 and netatalk-1.4b2+asun2.1.3-42.   Mounting the HFS CDs works fine, my Mac can access  to the files on the CD, but all files are listed as generic documents - they  haven't got any type or creator.   Mounting the HFS-CD with "-o afpd" or "-o  fork=netatalk" brings up the problem, that the CD is shown in the Mac's chooser  only in grey characters and not accessable.   I read in the mailing lists, that there were problems with kernels 2.2.x:  The afpd-options doesn't work with these kernels. But doesn't it work with  kernel 2.3.39, too?

Please switch off sending mail as HTML. Thank you.

afpd has no chance to set up a desktop database an a r/wo medium.
Solution 1: Place the database somewhere else (afpd option)
Solution 2: Mount your CD-ROM one step deeper in a tree but the AppleVolume is one step higher. Example:

mkdir -p /netatalk-cdrom/cdrom; mount /dev/scd0 ... /netatalk-cdrom/cdrom
echo "/netatalk-cdrom" >> AppleVolumes.whatever

Afpd can now build a database on your / and you can access the CD-ROM.

:wq! PoC