Subject: Page count from printer

From: Michael Harlow <[email-masked]>
Date: Thu, 06 Apr 2000 15:19:12 +1000

The following code (in atalk/etc) is supposed to return the page count from 
postscript printers:

%!PS-Adobe-3.0 Query
%%?BeginQuery: PageCount
statusdict begin pagecount (*) print = flush end
%%?EndQuery: Unknown
%%EOF

This works fine on most printers, but some are giving back 0 (zero).
Is there any other code that may work on those printers (Xerox C410 amongst 
others).

Are there any good Internet resources for advanced Postscript, including 
setting printer option/reading status values ?

Anyone know of any Internet resources detailing PCL codes, and PCL headers 
etc ?

Thanks
Michael.
-------------------------------------------------------------------
Michael J Harlow                    email : [email-masked]
Computer Systems Officer, School of Geography and Env. Studies,
University of Tasmania, GPO Box 252-78, Hobart, Tas 7001, Australia.
Phone : (03) 6226 2212 or 0419 585 308      fax  : (03) 6226 2989
Web : http://www.geol.utas.edu.au/geog
-------------------------------------------------------------------

---

From: Patrik Schindler <[email-masked]>
Date: Thu, 6 Apr 2000 13:01:05 +0200

>Is there any other code that may work on those printers (Xerox C410 amongst 

Hm, there is only one variable pagecount available in the printer. No idea...

>setting printer option/reading status values ?

You may want to start at Ghostscript's home which has links to many PostScript resources in the net.

:wq! PoC