Subject: asun2.1.3 on RH6.1 - disconnects after about 2 mins

From: Rusty Carruth <[email-masked]>
Date: Tue, 11 Apr 100 11:11:12 -0700 (MST)

(Sorry if this turns out to be a duplicate!)

Well, I dug through the archives as well as I could looking for help,
and in 1999 (the most
recent year I see) the questions all seemed to not apply to me.

So, here's the thing:

I have netatalk-1.4b2+asun2.1.3 running on a RedHat 6.1 system, 64 meg
ram, P133,
2 ethernet cards (atalk currently only on one of them, with no routing
enabled).

Connecting to a fairly new Powerbook running Mac OS9.

I finally got it to work with user logins (I'd been stuck with guest for
a long time),
but now I've lost guest!  the attempt to connect as guest times out
after a long time,
probably 2-3 minutes...

Oh, well - I don't really need guest access now that I've got user login
to work.

the real thing I'm stuck over is the fact that most of the time I get
disconnected
from the server after approximately 2 minutes of inactivity  (I timed it
- 2:02.80, but
that includes my detection delay ;-)

Here's the only non-comment line in my afpd.conf file:

"SA linux box private"  -rand2num   -loginmesg "a message"

The only non comment lines in my AppleVolumes.default are:

~
/html_pages/appleshare "AppleShare on SA linux box"
options=crlf,noadouble password=apassword
/tmp/foo "private, temporary" access=me options=crlf,noadouble

I even added this to my hosts.allow

afpd: ALL
atalkd: ALL

Any ideas?

rusty

---

From: Rusty Carruth <[email-masked]>
Date: Tue, 11 Apr 100 12:05:32 -0700 (MST)

> (Sorry if this turns out to be a duplicate!)
well, it did.  My apologies all around!

> from the server after approximately 2 minutes of inactivity  (I timed it

well, ok, sometime around 2 minutes (I've had 1:50 as well)

anyway, the point of this is that I went and got netatalk+asun
from the suse site (as an rpm), installed it, copied my config
files to its new location, and tried again.

Same thing, but the amusing (for negative values of amusing) thing
to me is that the server process (thread) is STILL RUNNING!!!
And there is no debug output saying that it has quit!  (the
Suse build actually puts out some logging, whereas the build
i did didn't)...

So - the mac things the connection has been closed when in fact
it appears as though it has not.  Any ideas????

(for those who wonder, I found it by looking at that great
rpmfind web site - remember it starts with 'n', not 'a'!)

rusty

---

From: andrew morgan <[email-masked]>
Date: Tue, 11 Apr 2000 12:52:57 -0700 (PDT)

> it appears as though it has not.  Any ideas????

Have you tried compiling the latest test release from source?  I don't
trust the older 2.1.3 rpms...

	Andy