Subject: netatalk and samba and national characters

From: Andreas Lehmann <[email-masked]>
Date: Tue, 28 Mar 2000 14:08:33 +0200

Dear list,

we have running SuSE-linux 6.3 system running samba and netatalk. The files
are shared among Mac and Windows PC clients. 

The users use to write file names with (german) national characters like
u-umlaut. 

Now the following happens:

	File names created by the Mac are ok to the Mac (an "ü" (u-umlaut) appears
as an "ü" (u-umlaut)).

	File names created by the PC are ok to the PC (     
"                         "           ).

	File names created by the Mac show wrong names to the PC ("ü" (u-umlaut)
show as "9f" on the PC).
	File names created by the PC show wrong names to the Mac ("ü" (u-umlaut)
show as "," on the Mac).

What are we doing wrong here? Is there any known solution for this?

Thanks in advance

	Andreas

---

From: Patrik Schindler <[email-masked]>
Date: Tue, 28 Mar 2000 17:53:36 +0200

>What are we doing wrong here? Is there any known solution for this?

First: Look at the console with ls or (preferred) echo * if the umlauts are okay on disk when created with windows.

Second, look at your AppleVolumes.*

# volume format:
# path [name] [casefold=x] [codepage=y] [options=z,l,j] \
#   [access=a,@b,c,d] [dbpath=path] [password=p]
#
#
# casefold options:
# tolower    -> lowercases names in both directions
# toupper    -> uppercases names in both directions
# xlatelower -> client sees lowercase, server sees uppercase
# xlateupper -> client sees uppercase, server sees lowercase
#
# access format:
# user1,@group,user2  -> restricts volume to listed users/groups
#
# miscellaneous options
# prodos              -> make compatible with appleII clients.
# crlf                -> enable crlf translation for TEXT files.
# noadouble           -> don't create .AppleDouble unless a resource
#                        fork needs to be created.
#
# codepage=filename   -> load filename from nls directory.
# dbpath=path         -> store the database stuff in the following path.
# password=password   -> set a volume password (8 characters max)
#

I used maccode.iso8859-1 as codepage and since then all is okay.

:wq! PoC

---

From: Sascha Dengler <[email-masked]>
Date: Tue, 28 Mar 2000 16:10:05 +0200

> What are we doing wrong here? Is there any known solution for this?

Hi Andreas,

you have to compile NLS-Support into your kernel (optional modular).
The modul is named "nls_iso8859-1". Now is your linux capable of
interpreting ISO8859-1 (standard character set for english/german/etc.)

Now you have to set your share in atalk => Applevolumes.default:
    /mnt/share      "DATA" codepage=maccode.iso8859-1
Important is the codepage instruction.

Now you have to set your share in samba => smb.conf:
    [DATA]
    path = /mnt/share
    character set = iso8859-1
Important is the character set instruction.
I think it's a global setting, try.

Now load the module with insmod/modprobe and restart atalk and samba.

Finished.
It works fine for me, but it is not perfect.

Sascha
[email-masked]

P.S. A little goodie, I also use in smb.conf:
veto files = /.AppleDouble/.bin/.AppleDesktop/Network TrashFolder/\
/TheFindByContentFolder/TheVolumeSettingsFolder/
to hide the Mac-Files! :-)

---

From: Patrik Schindler <[email-masked]>
Date: Wed, 29 Mar 2000 02:22:39 +0200 (MEST)

On Tue, 28 Mar 2000, Sascha Dengler wrote:

It's not neccessary to quote the whole message back to the list. Thank
you.

> interpreting ISO8859-1 (standard character set for english/german/etc.)

This is a wrong information. This isfor filesystem-support like FAT and
these and have nothing to to with netatalk.
I'm running umlauts and such successfully without having loaded any of
these modules.

> Important is the codepage instruction.

This is right.

> Now load the module with insmod/modprobe and restart atalk and samba.

Changes in AppleVolumes.* will be reflected as soon as you log out and
back in.

:wq! PoC

---

From: Steve Frampton <[email-masked]>
Date: Wed, 29 Mar 2000 09:32:12 +0900 (JST)

> interpreting ISO8859-1 (standard character set for english/german/etc.)

Hmmm...sounds like a possible solution for me, too.  What's the isoxxxx
character set for Japanese EUC?

- --------------< LINUX: The choice of a GNU generation. >--------------
Steve Frampton    <[email-masked]>    Japan Communications, Inc.
Software Developer/Systems Administrator    http://www.j-com.co.jp/
GNU Privacy Guard ID: D055EBC5  (see http://www.gnupg.org for details)
GNU-PG Fingerprint: EEFB F03D 29B6 07E8 AF73  EF6A 9A72 F1F5 D055 EBC5

---

From: Jean Richelle <[email-masked]>
Date: Wed, 29 Mar 2000 10:40:45 +0200

Hi,

I tried that; now my AppleVolume file look like this
~ "~jean" codepage=maccode.iso8859-1
~/sow "StarOffice Work" codepage=maccode.iso8859-1

And now the chooser propose only one volume named 
codepage=maccode.iso8859-1; i can mount it and it corresponds to my ~ 
!

What's wrong ?

Jean

-- 
_____________________________________________________________________________
Jean Richelle <[email-masked]>
Service de Conformation des Macromolécules Biologiques   Tel: +32 02 650 3587
et de Bioinformatique - Université libre de Bruxelles    FAX: +32 02 648 8954
av. F.D. Roosevelt 50 - CP160/16, B-1050 Bruxelles, Belgium
_____________________________________________________________________________

---

From: Sascha Dengler <[email-masked]>
Date: Wed, 29 Mar 2000 12:20:53 +0200

on 2000-03-29 2:32 Uhr, Steve Frampton at [email-masked] wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.0.0 (GNU/Linux)
> Comment: For info see http://www.gnupg.org
> 
> iD8DBQE44U8PmnLx9dBV68URAkMkAJ4wq8DJfZS6rvTan/KYONc37fTqWwCglSAT
> KegFFZxCMYgITszWBpmrVXw=
> =8+S9
> -----END PGP SIGNATURE-----
> 

Hi Steven,

as far as I know, atalk supports only Codepage 437, 850 and iso-8559-1,
sorry!

Sascha
[email-masked]

---

From: Sascha Dengler <[email-masked]>
Date: Wed, 29 Mar 2000 12:24:01 +0200

>>> Important is the codepage instruction.

Hi Jean,

perhaps it's a version problem. I use netatalk-1.4b2+asun2.1.3-30.

Sascha
[email-masked]

---

From: Sascha Dengler <[email-masked]>
Date: Wed, 29 Mar 2000 12:11:34 +0200

> I'm running umlauts and such successfully without having loaded any of

You're right that no module is needed to get ISO-support for atalk or samba
because both manage it for themselves. But you need it to see the umlauts
under Linux (console/shell/etc.)

>> Important is the codepage instruction.

Thanx.

> Changes in AppleVolumes.* will be reflected as soon as you log out and

I'm sorry. I didn't know that. But I think it's the better way to reinitiate
the whole atalk-system to be sure everything goes right.

Sascha
[email-masked]

---

From: Steve Frampton <[email-masked]>
Date: Wed, 29 Mar 2000 23:34:54 +0900 (JST)

> as far as I know, atalk supports only Codepage 437, 850 and iso-8559-1,

Would it be a very difficult thing to add support for Japanese
encoding?  If the functionality for other code pages is already there, ...

Regards...

(The Mac is *very* popular in Japan, btw.)

---

From: Patrik Schindler <[email-masked]>
Date: Wed, 29 Mar 2000 18:35:38 +0200

At 12:11 Uhr +0200 29.03.2000, Sascha Dengler wrote:

>But you need it to see the umlauts

Even this is false for ext2 Filesystems. These modules are only for translation of FAT and related filesystems umlauts.

:wq! PoC