Subject: Re: AppleTalk HowTo?

From: "Jason Davis" <[email-masked]>
Date: Tue, 28 Nov 2000 15:26:17 -0700

I think you have to have the usb print sharing installed on both computer.  Then use the Desktop Printer Utility to add it.  You can also use Desktop Printer Utility to print to lpr printers.

http://asu.info.apple.com/swupdates.nsf/artnum/n11726

-Jason

>>> Tobias Weber <[email-masked]> - 11/28/00 2:25 PM >>>
On 28 Nov, BWS - Offwhite wrote:

Hello,

> My best guess is that you need to get the iMac to share that
> printer.  Then you can use nbplkup to see the name for that printer.  It
> may be possible to use the netatalk printing tools and documentation to
> take it from there.

I already managed to export the printer via "USB Sharing", but it
doesn't show up in the Mac's "Network Browser". Don't iMacs see their
own shares or did I do sth wrong?

I fetched atalkconf, but it's lookup function doesn't see anything,
either.

BTW I found the HowTo by now (anders.com), but one has to be familiar
with the protocol to understand that, too.

-- 
  Tobias Weber

---

From: Tobias Weber <[email-masked]>
Date: Wed, 29 Nov 2000 20:33:29 +0100 (CET)

On 28 Nov, Jason Davis wrote:

> I think you have to have the usb print sharing installed on both
> computer.  Then use the Desktop Printer Utility to add it.  You can
> also use Desktop Printer Utility to print to lpr printers.

I didn't find the "Desktop Printer Utility", but I want to print *to*
the Mac and not from there to lpr. And there is no USB Sharing on my
linux system, neither do I have access to another Mac to check if the
printer was exported correctly.

> http://asu.info.apple.com/swupdates.nsf/artnum/n11726

According to this page the USB Printer Sharing goes directly via tcp and
that AppleTalk was not supported. Can I use it with netatalk?

The documentation is a little dubious as to whether "AppleTalk" refers
to transport or application layer of the network, i.e. is a replacement
for tcp or runs on top of it.

Also on that page: "Plug-in Adapters are not supported". It's a parallel
printer with the original HP Adaptor Kit, and on Apple's Compatibility
List for the Sharing Package. Hmm...

-- 
  Tobias Weber

---

From: Thomas Schierle <[email-masked]>
Date: Thu, 30 Nov 2000 00:47:41 +0100

> List for the Sharing Package. Hmm...

Maybe employing a TCP sniffer at the Macintosh (Interarchy, OTSessionWatcher
-- trial available) is worth the trouble to figure out what's going on?

Try launching one of these gems and start printer sharing afterwards.

Sorry, though interested in the subject I can't offer any additional help,
my trusty 'n dusty Stylewriter 1200 connected through Keyspan adaptor isn't
IP-sharable for sure ...

-- 
Thomas Schierle, Munich, Germany

PGP key [DSS/DH] 0xA23CDA1D available at various public key servers

---

From: SF Karel <[email-masked]>
Date: Fri, 01 Dec 2000 07:52:57 -0500

Another possibility is to run LPD on the Mac. There was an announcement
of a freeware LPD port on http://www.versiontracker.com/ this morning. I
haven't had time or need to try it out, but it might work for you. See:

http://www.geocities.com/barijaona/print66.html

quote:

> 
> Print66 is a utility that implements the Berkeley Line Printer Protocols on the Macintosh. It normally spools files sent from a remote host (for instance an Unix machine) and sends them to a LaserWriter on the Mac
> network, a Serial printer or an USB printer. It can also be used to print any file to a Laserwriter printer.
> 
> Print66 should run under System 7 and requires MacTCP or OpenTransport TCP/IP.
> 
> Print66 is a quick port from the lpDaemon program originally written by Casper Boon in Think C. The lpDaemon version 3.3.2 sources have been ported to Metrowerks CodeWarrior environment and have been
> recompiled. Some parts of the code have been rewritten due to the change of environment and the evolutions of Mac Headers, and I corrected a few bugs (and may have inadvertently added new ones :-) ).
> 
> I did this work because I wanted to print some AS/400 print files on a printer connected directly to my desktop Macintosh. The possibility to print to a serial port or USB printer appears nowadays more interesting
> than the use of AppleTalk, because many modern network printers already handle directly TCP/IP and LPR/LPD, and most of my work focused on serial print.
>