Subject: Problem setting up an AppleTalk network

From: "Aidan Pryde" <[email-masked]>
Date: Fri, 10 Mar 2000 13:48:01 +0100

Hello!
 
 I've got a problem setting up an AppleTalk network with NetAtalk.
 I'm a Linux beginner and built up a litte home ethernet
 containing three computers. Two Win-PCs and one Mac, all using the
 AppleTalk protocol.
 One of my PCs is now running under Linux. With yast I sucessfully
 configured my network device as eth0. Then I installed NetAtalk.
 Following the manual, I deleted the config file (atalkd.conf).
 Now (and before I deleted this file) if I want to start NetAtalk
 via "rcatalk start" I get the following messages:
 -
 Starting netatalk:socket: Invalid argument
 atalkd: can't get interfaces, exiting.            failed
 -
 What's going wrong? With Windows, my network works fine.
 I'm using SuSE Linux 6.0 (i386) Kernel 2.0.36 and the version
 1.4b2+asun2.0a18.2-22 of NetAtalk.

 Thanks in advance.

---

From: "thomas.riewe" <[email-masked]>
Date: Fri, 10 Mar 2000 14:22:59 +0100 (CET)

>  What's going wrong? 
ask SuSE ... (scnr)
>  With Windows, my network works fine.
looks like the ddp-support is missing 
you'll need either a fitting module or a
monolithic kernel with compiled-in ddp 

thomas (R)

---

From: sat <[email-masked]>
Date: Fri, 10 Mar 2000 11:37:33 -0500

You need to compile a Linux kernel with support for the AppleTalk Protocal, 
or you need to compile the Appletalk Protocol Kernel Module for use with 
your system.

I believe that the SuSE 6.3 kernels have the Appletalk protocol compiled 
directly into the kernel.

sat

---

From: Patrik Schindler <[email-masked]>
Date: Fri, 10 Mar 2000 18:15:13 +0100

> atalkd: can't get interfaces, exiting.            failed

Look into /var/log/messages, there you'll find further information.

> With Windows, my network works fine.

This won't say much. :->

> 1.4b2+asun2.0a18.2-22 of NetAtalk.

Get something newer. May Bugs have been fixed since this release.
ftp://ftp.cobaltnet.com//pub/users/asun/release/netatalk-1.4b2+asun2.1.3.tar.gz

Instructions for compiling will be found in the README files.
If you have trouble, report the output of ls -l /libc* here and you'll get help.

Tip: Use Yast to delete the old netatalk before attempting to install a new one.

:wq! PoC