Subject: On Mac: How is file type and creator determined?

From: Brandon Warren <[email-masked]>
Date: Wed, 10 May 2000 11:33:31 -0700 (PDT)

How is the type and creator determined for Mac files?

If a resource fork exists, then it comes from that, right?

If a resource fork does not exist, then what?

On netatalk, how does the AppleVolumes.system file fit into
this?  It seems to supply the type and creator when the
resource fork is missing, but how?  I opened a file with
Res Edit.  This file's type and creator was filled in by
AppleVolumes.system, yet Res Edit said that there was no
resource fork.  How can netatalk inform the Mac of the
type and creator if not by creating a resource fork?

Is any of this info stored in the Desktop?

Thanks in advance for any insight or pointers!

Brandon

---

From: Brian Bergstrand <[email-masked]>
Date: Wed, 10 May 2000 15:46:02 -0500

on 5/10/2000 1:33 PM, Brandon Warren at [email-masked] wrote

> If a resource fork exists, then it comes from that, right?
No.

> If a resource fork does not exist, then what?
The type/creator comes from the Desktop Database that the Finder maintains.
On the Mac you use Get/SetFInfo (for Finder info) to access the
type/creator.

HTH.
--
Brian Bergstrand
Systems Programmer  Northern Illinois University
Use the Source, Luke.

---

From: "Donald L. Nash" <[email-masked]>
Date: Wed, 10 May 2000 16:05:53 -0500

> The type/creator comes from the Desktop Database that the Finder

No, the type/creator is part of the directory entry for the file.  The 
Desktop Database is maintained by the Finder only to associate data files 
with their applications (so that double-clicking does what you expect) and 
icons.

-- 
Donald L. Nash, <[email-masked]>, PGP Key ID: 0x689DA021
The University of Texas System Office of Telecommunication Services

---

From: Patrik Schindler <[email-masked]>
Date: Thu, 11 May 2000 08:45:17 +0200

>From the settings in one .AppleVolumes file.

>resource fork is missing, but how?

Look into the examples in the source tree.

> I opened a file with

The Resource Fork itself has nothing to do with Mac-file-flags.
The .AppleDouble file stores more than just Resources. Therefore it is named .AppleDouble, not .rsrc as with Helios.

No.

:wq! PoC