Subject: Re: AppleVolumes.system need to be updated?

From: Steve Freitas <[email-masked]>
Date: Wed, 2 Aug 2000 22:05:48 -0700

David R Bosso sez:
>Maybe the defaults should use as much Apple stuff as possible.  QuickTime 
>Player, PictureViewer, and Simpletext for the common types that they 
>handle.  Not neccessarily my choices, but it could be a good compromise as 
>the default settings.

Paul Krohn sez:
>well, my first thought is that trying to anticipate what people's 
>preferences will be is for the birds. i would be to choose the openest 
>and free-est defaults, with good instructions on how to customize.

Sounds logical to me. So is the next logical step to go through the file 
and make the assignments?

>does 
>anyone know, offhand, which of the pointing-to-graphicconverter file 
>types can be handled by the ubiquitous PictureViewer?

Quickest way to find out would probably be to grab a slew of questionable 
pictures (filetypes, not content) and try them out.

Steve

---

From: "Michael J. Flynn" <[email-masked]>
Date: Thu, 3 Aug 2000 08:50:16 -0400 (EDT)

> pictures (filetypes, not content) and try them out.

That or use ResEdit to look at the BNDL Resource. For Picture Viewer it
has icons for the following types of graphics. So I am assuming it
supports those types. Course I would prefer native PhotoShop files to
goto PhotoShop.

BMP: ogle/BMP
BMP: ogle/BMPf
BMP: ogle/BMPp
FPX: ogle/FPix
GIF: ogle/GIF
GIF: ogle/GIFf
GX: ogle/qdgx
JPEG: ogle/JPEG
MacPaint: ogle/PNTG
PhotoShop: ogle/8BPS
PICT: ogle/PICT
PNG: ogle/PNG
PNG: ogle/PNGf
QTIF: ogle/qtif
SGI: ogle/.SGI
TARGA: ogle/TPIC
TIFF: ogle/TIFF
??: ogle/APPL
??: ogle/qmed

Laters

mike flynn - [email-masked]
The Company Store - http://www.magpage.com/~flynnmj/tcs.html

          Brought to you by <B>Team SPAM!</B> where we believe:
                   <I>"Information in the noise!"</I>

---

From: Greg Lincoln <[email-masked]>
Date: Thu, 03 Aug 2000 07:44:53 -0700

> pictures (filetypes, not content) and try them out.

Or peek at the bundle bits in ResEdit. Here's what I got, although some of
the files I've never heard of. This is directly out of the BNDL, so here you
go:

File:           Type Code:
GIF             GIFf,GIF
JPEG          JPEG
BMP           BMPf,BMP,BMPp
Photoshop   8BPS
??               PNTG
PICT           PICT
PNG           PNGf,PNG
GX             qdgx
QTIF           qtif
SGI             .SGI
Targa         TPIC
TIFF            TIFF
FPX             FPix,FPX
??                qmed

___________________________________
Greg Lincoln, Creative Director
Southwest Strategies, LLC

[email-masked]
858.597.7555

---

From: David R Bosso <[email-masked]>
Date: Thu, 03 Aug 2000 08:31:29 -0700

--On Wednesday, August 2, 2000 10:05 PM -0700 Steve Freitas 
<[email-masked]> wrote:

> David R Bosso sez:
>> Maybe the defaults should use as much Apple stuff as possible.
>> QuickTime  Player, PictureViewer, and Simpletext for the common types
>> that they  handle.  Not neccessarily my choices, but it could be a good
>> compromise as  the default settings.
>
> Paul Krohn sez:

I'll volunteer to do this if nobody else is already tackling it.  Let me 
know if you're already working on it.

-David