Subject: Re: AppleVolumes.default, can't see shared directories

From: "S.Ecker" <[email-masked]>
Date: Wed, 10 May 2000 14:25:22 -0700 (PDT)

here is /etc/rc.d/init.d/atalk.  Sorry about the
formatting:

# Source function library.
. /etc/rc.d/init.d/functions

# Source networking configuration.
. /etc/sysconfig/network

test -x /usr/local/atalk/sbin/atalkd || exit 0

test -f /usr/local/atalk/etc/netatalk.conf || exit 0

# read in netatalk configuration
. /usr/local/atalk/etc/netatalk.conf

# Check that networking is up.
[ ${NETWORKING} = "no" ] && exit 0

# startup code for everything
atalk_startup() {
    daemon /usr/local/atalk/sbin/atalkd

    if [ -x /usr/local/atalk/bin/nbprgstr ]; then     
 
            /usr/local/atalk/bin/nbprgstr -p 4
"${ATALK_NAME}:Workstation${ATA
LK_ZONE}"
            /usr/local/atalk/bin/nbprgstr -p 4
"${ATALK_NAME}:netatalk${ATALK_
ZONE}"
    fi  

    if [ x"${PAPD_RUN}" = x"yes"  -a -x
/usr/local/atalk/sbin/papd ]; then
            daemon /usr/local/atalk/sbin/papd
    fi

    if [ x"${AFPD_RUN}" = x"yes" -a -x
/usr/local/atalk/sbin/afpd ] ; then
            daemon /usr/local/atalk/sbin/afpd
${AFPD_UAMLIST} -g ${AFPD_GUEST}
 \
                -c ${AFPD_MAX_CLIENTS} -n
"${ATALK_NAME}${ATALK_ZONE}"
    fi

    if [ -x /usr/local/atalk/sbin/timelord ]; then
            daemon /usr/local/atalk/sbin/timelord
    fi
}

case "$1" in
'start')
        echo -n 'Starting AppleTalk services: '
        if [ x"${ATALK_BGROUND}" = x"yes" ]; then 
            echo -n "(backgrounded)"
            atalk_startup >& /dev/null &
        else
            atalk_startup
        fi
        echo 
        touch /var/lock/subsys/atalk
        ;;
'stop')
        echo -n 'Shutting down AppleTalk services: '
        if [ -x /usr/local/atalk/sbin/papd ]; then
                killproc papd
        fi

        if [ -x /usr/local/atalk/sbin/afpd ]; then
                killproc afpd
        fi

        if [ -x /usr/local/atalk/sbin/timelord ]; then
                killproc timelord
        fi

        /usr/local/atalk/bin/nbpunrgstr
"${ATALK_NAME}:Workstation${ATALK_ZONE
}"
        /usr/local/atalk/bin/nbpunrgstr
"${ATALK_NAME}:netatalk${ATALK_ZONE}"

        # kill atalkd last, since without it the
plumbing goes away.
        if [ -x /usr/local/atalk/sbin/atalkd ]; then
                killproc atalkd
        fi
        rm -f /var/lock/subsys/atalk
        echo ""
        ;;
  'restart'|'reload')
        $0 stop
        $0 start
        ;;
  'status')
        status atalkd
        ;;
  *)
        echo "Usage: atalk
{start|stop|restart|status}"
        exit 1

-------------------------------------------------------
And here is /etc/sysconfig/network (gateway obscured):

NETWORKING=yes
HOSTNAME="SAFFRON"
GATEWAY="111.222.333.444"
GATEWAYDEV="eth0"
FORWARD_IPV4="yes"

--- andrew morgan <[email-masked]> wrote:
> 
> 
> On Wed, 10 May 2000, S.Ecker wrote:
> 
> > The wierd thing here is that it says "uam:
> "Cleartxt
> > Passwrd" available" even though I specified
> > -nocleartxt in afpd.conf.  There are no other
> versions
> > of this file anywhere on the server.  All the
> netatalk
> > stuff is in /usr/local/atalk/.
> 
> I still say that it is looking in a different
> directory for its
> configuration info.  What does your netatalk startup
> script
> (/etc/rc.d/init.d/atalk) look like?
> 
> 	Andy
> 

__________________________________________________
Do You Yahoo!?
Send instant messages & get email alerts with Yahoo! Messenger.
http://im.yahoo.com/

---

From: andrew morgan <[email-masked]>
Date: Wed, 10 May 2000 15:08:11 -0700 (PDT)

> here is /etc/rc.d/init.d/atalk.  Sorry about the

All that looked normal...  Looking at the code for afpd (in volume.c), it
shows that it will read, in this order:

~/AppleVolumes
~/.AppleVolumes
~/applevolumes
~/.applevolumes
$$ETCDIR/Applevolumes.default

Could there be one of these files with incorrect permissions?  Or maybe it
is reading the info from the ~/xxx files instead?

If you're good enough with C, look for the readvolfile function in
volume.c and add some debugging code.  I could probably help with this...

	Andy