Subject: PCL over PAP (was Re: Unfamiliar with netatalk printing...)

From: "Tom Watson" <[email-masked]>
Date: Thu, 04 May 2000 12:44:01 -0800

On Thu, 4 May 2000 13:08:52 -0400 (EDT), [email-masked] wrote:
> At 1:18 Uhr -0400 04.05.2000, Kevin White wrote:
> 
<<<deletia>>>
> 
> I don't know any Mac driver with PAP support which generates PCL (only
> local). Which doesn't mean that it's not existing, tough.

OK, now that this has been brought up, does anyone know of such a driver
for a Mac.  I've got an HP Color LaserJet, but no postscript module.  I
have the localtalk module though.  I assume that it wants PCL via pap.

I guess the alternative is to have the Linux box recieve PAP and then
GhostScript to PCL, sending it out.  Proper configuration files necessary
to do this would be a nice "cookbook" solution.

-- 
Tom Watson         Generic short signature
[email-masked]     (I'm at home now)

---

From: Patrik Schindler <[email-masked]>
Date: Fri, 5 May 2000 08:03:41 +0200

>to do this would be a nice "cookbook" solution.

First thing is getting printing to work under unix.
If you want to send data via pap to the printer, create a file named ".paprc" in the spooldir of the printer. It contains the full NBP-String of the printer:

QMS-PS 410:LaserWriter@*

Even if there are spaces inside I need no quotes around this.
You may look up the exact string with nbplkup.

My printcap entry for a DeskWriter looks like this:

dw|HP DeskWriter:\
    :sd=/var/spool/lpd/hpdw:\
    :lp=/dev/null:\
    :of=/usr/local/printerfilter/ps2dj500:\
    :mx#0:sh:

and the "of" is this (ripping data thru gs and send the output via pap to the printer):

#!/bin/sh
trap '' SIGINT
#
DDICT="-dSAFER -dNOPAUSE -dBATCH -dSHORTERRORS -dQUIET"
SDICT="-sPAPERSIZE=a4 -sDEVICE=cdjmono -sOutputFile=-"
OPTS="-q"
#
/usr/bin/gs $OPTS $DDICT $SDICT - |/usr/local/bin/pap -E -e -sstatus

Hope that helps.

:wq! PoC