Subject: LaserWriter printing problems

From: "Steve Cullingworth" <[email-masked]>
Date: Fri, 21 Jan 2000 16:56:25 -0800

We have just replaced our useless NT server with a Linux server running
Samba and Netatalk.  So far everything is great, but I can't get the Linux
server to print to our LaserWriter 16/600 PS printer.  It has no problem
seeing the printer, but after connecting, we get an error as follows:

[root@fileserver2 /etc]# pap -p "LaserWriter 16/600 PS" hosts
Trying 65280.129:129 ...
status: idle
Connected to LaserWriter 16/600 PS:LaserWriter@*.
%%[ Error: undefined; OffendingCommand: 127.0.0.1 ]%%
%%[ Flushing: rest of job (to end-of-file) will be ignored ]%%
Connection closed.
[root@fileserver2 /etc]#

Any suggestions?  Also, I would like to set up this Linux box with Samba so
that the PC clients can print to the AppleTalk printer.  How do I setup my
/etc/printcap file to automatically use pap to print to the LaserWriter?  Is
there a FAQ about this setup?

Many thanks,
Steve

---

From: Xavier Reigner <[email-masked]>
Date: Sat, 22 Jan 2000 15:04:25 +0100

Try to send to your "LaserWriter 16/600 PS" not a file in text format, but in
postscript format, I guess the result will be quit different.

pap -p "LaserWriter 16/600 PS" img.ps

for configuring printcap under redhat you can use "printtool"
for the help have a look at http://www.giub.unibe.ch/~eugster/appleprint.html

xav

---

From: Nico De Ranter <[email-masked]>
Date: Mon, 24 Jan 2000 08:32:28 +0100 (MET)

We have a few LaserWriter 16/600 printers in our network (SUN/SGI/NT/Linux).
The entry in my printcap for that printer looks like:

lp5
        :lp=laserwriter5
        :bq=[email-masked]
        :cm=Johan's printer
        :sd=/var/spool/LPRng/laserwriter5
        :lf=/var/log/LPRng/laserwriter5
        :if=/usr/local.host/LPRng/bin/lpf
        :mx#0
        :sh
        :sf

(note: this is from an SGI but that shouldn't make much difference).  To print
to it through samba I use the following config file:

[global]
...
        printing = bsd
        printcap name = /etc/printcap
...
[printers]
   comment = All Printers
   browseable = no
   printable = yes
   public = no
   writable = no
   create mode = 0700

Why are you trying to print through appletalk? The LaserWriter 16/600 PS does
support bsd printing.

Nico

> there a FAQ about this setup?

--------------------------------------------------------
 "It has been said that there are only two businesses
  refer to customers as users: illegal drug trade and
               the computer industry." 
--------------------------------------------------------
Nico De Ranter
Sony Service Center (SUPC-E/DME-B)
Sint Stevens Woluwestraat 55 (Rue de Woluwe-Saint-Etienne)
1130 Brussel (Bruxelles), Belgium, Europe, Earth
Telephone: +32 2 724 86 41 Telefax: +32 2 726 26 86
e-mail: [email-masked]