Subject: Help with Permissions...

From: Simon Buchanan <[email-masked]>
Date: Tue, 29 Feb 2000 15:57:07 +1300

Could someone please clarify the way to do this:

I have 3 users User1, User2 and User3. All are part of the group 
Users. Here is my AppleVolumes.default file:

# Begin
#
/home/public Public access:@users
~

# End

The home dirs are fine: rwx by the owner. The public dir is chown(ed) 
root.users

How do i set the ownership/permissions for the public folder so that 
all three users can read, write and trash files from this dir.

I am told to set the sticky bit.. but even doing this the "Network 
Trash Folder" still is shown and users can't trash files as the files 
are owned by one user not the other.

Im sure once someone gives me some examples/help i'll get my head around it :)

Cheers

-- 
Simon Buchanan   -   Technical Design and Administration
--------------- New Media Communications ---------------
mailto:[email-masked]  http://www.newmediacom.net
------------ By the way, what does BTW mean? -----------

---

From: Stephen Welker <[email-masked]>
Date: Thu, 02 Mar 2000 13:05:22 +1100

> Im sure once someone gives me some examples/help i'll get my head around it :)

This is an excert of the response I posted to the list early in January 2000
in regard to the "Network Trash Folder" (a shared forlder).

>> Do a g+x on the Network Trash Folder, and the .AppleDouble directory inside.
>> That should fix it.
> 
> It at least made the icon vanish for non-owners.
> 
> However, non-owners could not move items to the trash.
> 
> So I performed chmod g+rwx on the .AppleDouble directory (this made it like
> all other "folders") and a chmod g+rw on the file "Trash Can Usage Map" (also
> inside the Network Trash Folder).

You may be able to use it for your situation.

-- 
Stephen