Subject: Backup

From: Dale Ang <[email-masked]>
Date: Sun, 28 May 2000 23:35:49 -0700 (PDT)

I've got a small network of 3 macs and 3 pcs, with a
linux box serving all.  How can I backup the mac
shares (homes etc) from the PC's?

__________________________________________________
Do You Yahoo!?
Kick off your party with Yahoo! Invites.
http://invites.yahoo.com/

---

From: Moritz Kaiser <[email-masked]>
Date: Mon, 29 May 2000 11:26:34 +0200 (CEST)

> shares (homes etc) from the PC's?
What are you using for serving the PCs? SAMBA?
If so, you only have to define a SAMBA share for your PCs which serves all
mac shares.
For example:
Mac shares are located in:
/home/mac

then a entry in smb.conf has to be done:
8<------------------------*snip*
[macshares]
	path = /home/mac
	guest ok = no
	users = admin
	read only = yes
8<------------------------*snip*

You may define some other options here. For those look up "man
smb.conf" or use swat.

Hope, this will help you.

Best regards,
Moritz

__________________________________________________________
Moritz Kaiser
Studentische Vertretung, Technische Universitaet Muenchen
Europe / Germany

---

From: Ryan McBeth <[email-masked]>
Date: Tue, 30 May 2000 07:09:36 -0400

>> shares (homes etc) from the PC's?

	It's funny to see this, because I've spent a good part of my
weekend writing an addendum to the SAMBA HOWTO just for this case.  I'm
hoping to submit it to the Samba group some time this week.  If you want
it, I'll e-mail it to you.

	But the main point is that you can write a batch file that uses
xcopy to back up all of the shares that you need backed up.  For example,
if you have /opt/customer/accounts mapped as drive G: you could say:

	xcopy /C /E G: *.* C:\backups\customer\accounts

	Now, if you use the scheduler that's built into Windows 98, you can
put all of the xcopy commands into a batch file that will back up as many
shares as you want.

	If you are using NT, and you want this to run when you've gone home
for the night and logged out, you need to have the batch file connect up to
the linux box before it begins the transfer.  So you would put this command
before the xcopy command:

	net use G: \\myLinuxBox\accounts /user:backup mypassword

	If you need help, don't hesitate to let me know.  I already have
someting like this set up at my office and it works quite well.

	Ryan

__________________________________
Ryan McBeth
Systems Administrator, Mobius New Media
Voice: (302) 475-9880 x11
FAX: (302) 475-9894
www.mobiusnm.com
__________________________________
If you want to achieve excellence, you can get there today. As of this
second, quit doing less-than-excellent work.
-Thomas Watson, founder of IBM

---

From: Malcolm McLeary <[email-masked]>
Date: Wed, 31 May 2000 10:41:45 +1000

Hi Dale, 

> shares (homes etc) from the PC's?

Install Retrospect Backup for Windows and backup the SAMBA shares ... I
image you have SAMBA and Netatalk serving the same directories to both
platforms.

    http://www.betterbackup.com/

    http://www.dantz.com/

If you are serious about BACKUP and RESTORE you'll buy and install an
appropriate tool ... its not worth the effort to hack something together
with an OS task scheduler and command procedures.

Cheers,  Malcolm
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

                       Information Alchemy Pty Ltd
                             ACN 089 239 305
                           Canberra, Australia

Malcolm McLeary                                  Mobile:   0412 636 086
Managing Director                                Email:  [email-masked]

     This message was sent using Outlook Express 5.0 for Macintosh.