Subject: Re: netatalk in production environments....(RFC)

From: "Luke McNeilage" <[email-masked]>
Date: Thu, 01 Jun 2000 18:58:56 +1000

>From: Ron Chmara <[email-masked]>
>To: Harry Zink/Netatalk List <[email-masked]>
>Subject: Re: netatalk in production environments....(RFC)
>Date: Thu, 1 Jun 2000 6:27 PM
>

>> > Seriously, though, certain things have _always_
>> > been considered "not best practice" in one environment I admin for, and
using
>> > aliases (which can point to the wrong volume, server, or job) is one of
>> > them.
>> They don't point to the wrong locations when you use an ASIP server, or even
>> standard (old) AppleShare.
>
> They most certainly do. They are put on the local desktop and given
> names like "stuff". Of course, when "stuff" fails to point to the user's
> intended location, it means that the alias is "broken". :-)
>
> More to the point, a pre-press house I used to work in once blew $500 of
> bad film, matchprint, *and* missed a press date, because an alias was
> pointing to a folder that supposedly held the right data. It did not,
> it pointed to an *older* version. This almost cost the company a $120K
> client.... hence, their standing rule to _only_ access data by a direct
> path

Absof*&^$%ing-lutly.

Everybody learn from this example! I see it over and over again in so called
"production" environments.

============================================================================
Luke McNeilage
Technical Director
D2P (Australasia) Pty Ltd
Email: [email-masked]
Web: www.d2p.com.au

Australia's leading file delivery system for publishing & graphic arts.

Tel: +61 (0)3 9429 3233
Fax: +61 (0)3 9427 0929
Mobile: 0419 512 868

Suite 3/243 Bridge Road
Richmond VIC 3121
Australia

----------

---

From: Chip Mefford <[email-masked]>
Date: Thu, 1 Jun 2000 11:15:07 -0400 (EWT)

> "production" environments.

Seconded, 

I encourage the use of local aliases only.

I don't "stop" folks from using aliases on shared volumes, but
I do strongly discourage users from doing so. As I let the
folks that are actually EARNING THE MONEY here do pretty
much what they want and try to offer what guidance I can, 
I've seen it time and time again that a collaborative project
will get bumped in revision by one person working late at night
the others folks accessing the document via an alias will continue
on working on the old document, the work will fork off in
different directions, blah blah blah. 

Yes, to fix this all one needs do is point fingers, thats
always the easy way. The other way is a bit more arcane, and
it involves helping folks to understand that it is important
to KNOW what they are working on and to take as little for
granted as possible.

---

From: Harry Zink/Netatalk List <[email-masked]>
Date: Sat, 03 Jun 2000 13:16:38 -0700

> different directions, blah blah blah.

Uh...hum... How is the different from not allowing alias' and having the
users access the folder directly - it seems to me that this exact same
problem can still happen, at least the way it was described.

NOT using alias' won't miraculously make users smarter about working in a
broken workflow environment.

Harry