Subject: no printing joy with Redhat 6.2

From: Steve Maller <[email-masked]>
Date: Wed, 7 Jun 2000 23:02:40 -0700

This may be a FAQ, but I can't seem to get printing working right 
after upgrading to Redhat 6.2.

Thanks in advance!

When I print (even with something like ls | lpr), I get spewage like this:

Jun  7 22:18:48 hippo ofpap[2012]: starting for root
Jun  7 22:18:48 hippo ofpap[2012]: accounting with psa[2013]
Jun  7 22:18:48 hippo ofpap[2012]: sending to pap[2014]
Jun  7 22:18:48 hippo ofpap[2012]: straight text
Jun  7 22:18:48 hippo ofpap[2012]: 2014 died with 2
Jun  7 22:18:48 hippo lpd[2011]: lp: job could not be printed 
(cfA007hippo.maller.com)

When I look in my error log as specified in /etc/printcap, I see this:

nbp_lookup: Cannot assign requested address
Didn't find initial page count!

Finally, I have a HP Laserjet 2100TN (a postscript printer), and here 
is my /etc/printcap file:

lp|My Laserjet|My Laserjet:\
         :sd=/var/spool/lp:\
         :lp=/dev/null:\
         :pl#63:\
         :pw#85:\
         :mx#0:\
         :sh:\
         :sf:\
         :lf=/var/log/laserjet-errs:\
         :if=/usr/lib/atalk/filters/ofpap:

I've tried (as per man psf) to change "ofpap" to "ofwmpap", but to no avail.
-- 
Steve Maller
http://www.maller.com

What counts is not necessarily the size of the dog in the fight -
it's the size of the fight in the dog.
     -- Dwight D. Eisenhower, 1958

---

From: Sak Wathanasin <[email-masked]>
Date: Thu, 8 Jun 2000 08:57:31 +0100

In reply to Steve Maller's message of the 07/06/2000 at 23:02 -0700,

>Didn't find initial page count!

Printing needs AppleTalk - in RH6.2 I believe it's off by default. Put a

alias net-pf-5 appletalk

in your /etc/conf.modules

-- 
Sak Wathanasin
Network Analysis Limited
178 Wainbody Ave South, Coventry CV3 6BX, UK

Internet: [email-masked]
Phone: (+44) 24 76 41 99 96        Mobile: (+44) 79 70 75 19 12 
Fax: (+44) 24 76 69 06 90