Subject: disconnection

From: Vincent Propice <[email-masked]>
Date: Mon, 24 Jul 2000 11:33:05 +0200

I work with GNU/Linux (SuSE 6.2) and latest beta release (1.4b2 ) of
netatalk.
My Macs always lose the link with the server after few minutes, how can
I avoid that ?
Vincent

---

From: "Marc J. Miller" <[email-masked]>
Date: Mon, 24 Jul 2000 12:17:53 -0700

We found that by default, netatalk sends a tickle every 30 seconds.  The
MacOS, however, does its tickling every 120 seconds.  Sometimes it seems to
respond on second 119 and it remains connected (the server is allowed to
miss 3 tickles before disconnecting).  After we changed MacOS to 30 seconds,
everything was fine on our machines.

---

From: "Marc J. Miller" <[email-masked]>
Date: Thu, 28 Sep 2000 08:40:42 -0700

I have a couple of corrections to this post:

1.  We used a third-party program to modify it.  I think our resident MacOS
expert said it was called Network Assistant?  That may not be right.
2.  The default actually is 30 seconds.  I hadn't realized that the lab
machines (as well as my test machine) had been changed to 120 seconds to
troubleshoot a Columbia Appletalk problem.

----- Original Message -----
From: "Andreas Griesmayer" <[email-masked]>
To: "Marc J. Miller" <[email-masked]>
Sent: Thursday, September 28, 2000 2:41 AM
Subject: Re: disconnection

> "Marc J. Miller" wrote:
> im not very familiar with macs - how did you changed MacOS to 30 secs ?
>
> tia, gismo
>

---

From: Matthew Temple <[email-masked]>
Date: Fri, 29 Sep 2000 12:31:59 -0400

All,

	One of our Linux managers has encountered the 
following unexpected event when using DNA-Star and saving
files directly to his Netatalk volume.   He says:
===========================================================
	Using the program LaserGene the following happens -
[If I] edit a DNA sequence, and then save it directly into
a Netatalk volume (netatalk-1.4b2+asun2.1.3-7, RH 6.2.)
then, later open that file with LaserGene, I find that
there are several empty spaces added at the beginning
of the DNA sequence.
	But if the sequence is saved either to the local
hard disk or to a native ASIP server, there is no problem.
(If the saved file from the server is then copied to the Netatalk
volume there is also no problem.)
===========================================================
Does anyone out there have any idea what might be going
wrong?

					Matthew Temple

-- 
=============================================================
Matthew Temple                Tel:    617/632-2597
Director, Research Computing  Fax:    617/632-4012
Dana-Farber Cancer Institute     
44 Binney Street, Smith 345   [email-masked]
Boston, MA 02115              IMAP LIVES!
=============================================================

---

From: Matthew Keller <[email-masked]>
Date: Fri, 29 Sep 2000 13:33:38 -0400

Could you send the snippet from AppleVolumes.default that deals with
this volume? The only time I've seen something like this is if some of
the AV.def options are set strange (like CRLF, or ProDOS or some other
setting).

-- 

 Matthew Keller
 WebMaster & Lead Programmer/Analyst
 Distributed Computing/Telemedia
 Information Services Division
 State University of New York at Potsdam
 
 Website: http://mattwork.potsdam.edu/
 PGP: http://mattwork.potsdam.edu/crypto/
 Webcam:  http://webcam.mattwork.potsdam.edu:85/

---

From: Harry Zink/Netatalk List <[email-masked]>
Date: Fri, 29 Sep 2000 10:47:08 +0000

> Does anyone out there have any idea what might be going

Try the same with the latest version, 1.4.99, and see if it does the same.

Harry
-- 
CAN'T SEE MAC IN CHOOSER UNDER RedHat 6.2: If you get errors starting
AppleTalk under RedHat 6.2 and Mandrake 7.1, you need to manually add "alias
net-pf-5 appletalk" to your /etc/conf.modules file.

---

From: Matthew Temple <[email-masked]>
Date: Fri, 29 Sep 2000 14:09:03 -0400

Bill and the group,

	We will be testing this later.  I gather the newest version of
netatalk also includes the ability to have an volume administrator, 
somethin which has been a very important lack.   Now that
I look at this discussion, I'm convinced I'll find that DNAStar does 
exactly what I've guessed below.

	As usualy thanks to you all, the best tech support group
there is!

					mht

"William R. Knox" wrote:
> 
> Yes, sadly, more and more applications seem to be pulling this rather
> funky stunt when saving files. The new versions of netatalk
> (asun2.1.4pre39 as well as the netatalk 1.5 now in development at
> SourceForge) have the capability to do crlf on a per share basis, so it
> may be worthwhile for the folks who need to have it disabled to have
> their own share on an upgraded version.
>
>           S N I P
> --
>                         Bill Knox
>                         Senior Operating Systems Programmer/Analyst
>                         The MITRE Corporation
> 
> Matthew Temple wrote:
> >
> > Bill,
> >
> >         Actually, that's an interesting thought.   If DNA-Star say,
> > opens the file as a text document then changes the CREATOR/TYPE
> > after the fact, then Netatalk would get confused, wouldn't it?
> >
> >         Of course, if CR/LF translation gets turned off, then the
> > ordinary text documents get munged, don't they?
> >