Subject: RE: Trouble Starting Netatalk - Invalid Arguments to 'socket'??

From: Michalowski Thierry <[email-masked]>
Date: Tue, 21 Nov 2000 13:33:10 +0100

I suggest you verify the appletalk module is loaded into your kernel.

HTH
Thierry

-----Original Message-----
From: Basil Hussain [mailto:[email-masked]]
Sent: Tuesday, November 21, 2000 1:13 PM
To: Netatalk List
Subject: Trouble Starting Netatalk - Invalid Arguments to 'socket'??

Hi all,

I've just tried installing the latest (8th Nov) RPM of Netatalk from
Sourceforge on a stock RedHat 6.2 machine. I'm having a bit of trouble
getting Netatalk to start. Upon starting, I get these errors:

# /etc/rc.d/init.d/atalk start
Starting AppleTalk services: socket: Invalid argument
socket: Invalid argument
atalkd: can't get interfaces, exiting.
                                                           [  OK  ]

And I also get this in the system log:

Nov 21 11:52:07 vic20 atalkd: socket: Invalid argument
Nov 21 11:52:07 vic20 atalkd: socket: Invalid argument
Nov 21 11:52:07 vic20 atalkd: atalkd: can't get interfaces, exiting.
Nov 21 11:52:07 vic20 atalk: atalkd startup failed
Nov 21 11:52:07 vic20 atalk: timelord startup succeeded
Nov 21 11:52:07 vic20 timelord[617]: main: atp_open: Invalid argument

Why wouldn't atalkd be able to get a socket? What is providing invalid
arguments, whatever it may be?

I can't think what it could be that's stopping it working - I installed the
same RPM onto a virtually identical machine (they only differ in the model
of Intel network card) with RH 6.2 only the other day, which works
absolutely fine.

I'm thinking it might possibly be something to do with my config, but I have
nothing strange there. In my netatalk.conf file I have these directives:

AFPD_MAX_CLIENTS=20
ATALK_NAME=`echo ${HOSTNAME}`
AFPD_GUEST=nobody
ATALKD_RUN=yes
PAPD_RUN=no
AFPD_RUN=yes
ATALK_BGROUND=no

In my afpd.conf file I have:

- -transall -uamlist uams_dhx.so -nosavepassword

And I have a couple of entries in the AppleVolumes.default file:

~
/home/httpd/html "Discussions Web Root" casefold:tolower

Can anyone assist here?

Regards,

------------------------------------------------
Basil Hussain ([email-masked])

---

From: Basil Hussain <[email-masked]>
Date: Tue, 21 Nov 2000 13:12:44 +0000

Hi all,

> I suggest you verify the appletalk module is loaded into your kernel.

# /sbin/lsmod 
Module                  Size  Used by
eepro100               15652   1  (autoclean)

Doh, it's not! I don't know why that didn't occur to me. Probably because I
expected it to be there - every other RH 6.2 install I've done has had it
loaded by default. My other machine running the latest Netatalk RPM, which I
didn't set up any differently, has it loaded:

# /sbin/lsmod
Module                  Size  Used by
appletalk              17472  13  (autoclean)
eepro100               15652   1  (autoclean)

I had a quick browse of the mailing list archive and found that in cases
where you haven't got the module loaded, you need to add "alias net-pf-5
appletalk" to your /etc/conf.modules. But, the strange thing is, my other
machine has the module loaded, but has nothing in conf.modules that has
anything to do with Appletalk. I wonder how it gets loaded, then?

Anyway, problem solved. I just added the line to conf.modules and rebooted.
Perhaps I should've checked the list archive sooner... :)

Regards,