Subject: Re: maintaining type/creator

From: Peter Gutowski <[email-masked]>
Date: 04 Sep 2000 20:03:43 -0400

On Monday, September 4, 2000, Brice Ruth <[email-masked]> wrote:
>Harry,
>
>Thanx for the response.  To my knowledge, I'm running the latest netatalk
>(1.4b2+asun?).  I'm running on RedHat 6.2, I downloaded the src & compiled it.
>I have a AppleVolumes file in the user's home directory, but from what I can
>see, if it doesn't have an extension, netatalk just sends it back as UNIX/TEXT
>(i.e. not what it was to begin with).  Since control panels, extensions, fonts,
>etc. don't have a '.' extension, from what little I'm able to determine, the
>AppleVolumes file can't help me ...
>
>Please correct any wrongs :)

The filetypes and creator information is stored along with a file's resource fork in the [various] .AppleDouble directories. Unless these directories [the .AppleDouble dirs]  have permissions/ownership problems, Mac files don't need any extensions to show up as the correct type. The file extension mappings in the AppleVolumes.system file  is a *convenience* feature to allow files created by other systems to show up as the proper Mac types. E.g. 

.tif     TIFF

Ordinarily, the copying of a Mac file onto a netatalk server maintains type/creator without any other interaction.

-- 
Peter Gutowski / [email-masked]

"Millions long for immortality who don't know what to do on a rainy day." -- Susan Ertz (c. 1894-1985), American Writer

---

From: Brice Ruth <[email-masked]>
Date: Mon, 04 Sep 2000 19:38:15 -0500

So, let me make sure I understand this - if Mac user A creates PDF: 
my-invoice and saves it to the netatalk drive "Temp" - Mac user B can 
mount "Temp" and will see "my-invoice" as a Acrobat PDF?

-- 
Brice Ruth
VP, Director of Internet Technology
WebProjkt, Inc.
http://www.webprojkt.com

---

From: Harry Zink/Netatalk List <[email-masked]>
Date: Mon, 04 Sep 2000 18:32:13 -0700

> mount "Temp" and will see "my-invoice" as a Acrobat PDF?

Uhm, yes, that *IS* the way this is designed to work.

Harry
-- 
CAN'T SEE MAC IN CHOOSER UNDER RedHat 6.2: If you get errors starting
AppleTalk under RedHat 6.2 and Mandrake 7.1, you need to manually add "alias
net-pf-5 appletalk" to your /etc/conf.modules file.