Subject: papd.conf

From: Sam Noble <[email-masked]>
Date: Thu, 3 Aug 2000 14:17:31 -0700

First of all, I'm using andrew morgan's authenticated printing
patches with papd.

	In papd.conf I've listed appropriate ppd files that I expected the
clients to just download automatically.  Unfortunately when I setup a
printer it still expects me to tell it what ppd to use.  Should I instead
just put the name of the ppd used on the Macintosh (rather than a pathname
on the server) in the papd.conf instead or am I just doing something
blatantly wrong?

an entry from my papd.conf:

my_printer@my_zone:\
        :pr=|/usr/bin/lpr -Pmy_printer:\
        :pd=/usr/local/atalk/etc/ppd/LaserWriter8500.ppd:\
        :au:\
        :am=uams_clrtxt.so:

---

From: andrew morgan <[email-masked]>
Date: Thu, 3 Aug 2000 15:03:37 -0700 (PDT)

>         :pd=/usr/local/atalk/etc/ppd/LaserWriter8500.ppd:\

I'm guessing you are trying to use the mac's "Auto Setup" function when
configuring a printer.  My best guess is that this only works with real
printers or a real apple print server because it certainly doesn't work
with papd.  :)

The ppd which you define in papd.conf just allows papd to answer some
basic questions about the printer:

Postscript Language Level
Postscript Language Version
Product name of the printer
Is color supported?
What true-type fonts are supported
What fonts are stored in the printer.

I think you should still choose a local PPD file on your mac so you can
set all the printer options, such as which output tray to use, etc.  You
have the correct setup in your papd.conf file.

Here is the output that papd gets from our HP8100 ppd file:

Font: Wingdings-Regular
Font: Univers-MediumItalic
Font: Univers-Medium
Font: Univers-Condensed-MediumItalic
Font: Univers-Condensed-Medium
Font: Univers-Condensed-BoldItalic
Font: Univers-Condensed-Bold
Font: Univers-BoldItalic
Font: Univers-Bold
Font: TimesNewRoman-Italic
Font: TimesNewRoman-BoldItalic
Font: TimesNewRoman-Bold
Font: TimesNewRoman
Font: SymbolMT
Font: Marigold
Font: LetterGothic-Italic
Font: LetterGothic-Bold
Font: LetterGothic
Font: Garamond-KursivHalbfett
Font: Garamond-Kursiv
Font: Garamond-Halbfett
Font: Garamond-Antiqua
Font: CourierHP-Italic
Font: CourierHP-BoldItalic
Font: CourierHP-Bold
Font: CourierHP
Font: Coronet
Font: Clarendon-Condensed-Bold
Font: CGTimes-Italic
Font: CGTimes-BoldItalic
Font: CGTimes-Bold
Font: CGTimes
Font: CGOmega-Italic
Font: CGOmega-BoldItalic
Font: CGOmega-Bold
Font: CGOmega
Font: Arial-Italic
Font: Arial-BoldItalic
Font: Arial-Bold
Font: Arial
Font: AntiqueOlive-Italic
Font: AntiqueOlive-Bold
Font: AntiqueOlive
Font: Albertus-Medium
Font: Albertus-ExtraBold
Font: ZapfDingbats
Font: ZapfChancery-MediumItalic
Font: Times-Roman
Font: Times-Italic
Font: Times-BoldItalic
Font: Times-Bold
Font: Symbol
Font: Palatino-Roman
Font: Palatino-Italic
Font: Palatino-BoldItalic
Font: Palatino-Bold
Font: NewCenturySchlbk-Roman
Font: NewCenturySchlbk-Italic
Font: NewCenturySchlbk-BoldItalic
Font: NewCenturySchlbk-Bold
Font: Helvetica-Oblique
Font: Helvetica-Narrow-Oblique
Font: Helvetica-Narrow-BoldOblique
Font: Helvetica-Narrow-Bold
Font: Helvetica-Narrow
Font: Helvetica-BoldOblique
Font: Helvetica-Bold
Font: Helvetica
Font: Courier-Oblique
Font: Courier-BoldOblique
Font: Courier-Bold
Font: Courier
Font: Bookman-LightItalic
Font: Bookman-Light
Font: Bookman-DemiItalic
Font: Bookman-Demi
Font: AvantGarde-DemiOblique
Font: AvantGarde-Demi
Font: AvantGarde-BookOblique
Font: AvantGarde-Book
Feature: *LanguageLevel "2"
Feature: *PSVersion "(2014.112) 0"
Feature: *FreeVM "13000000"
Feature: *Product "(HP LaserJet 8100 Series)"
Feature: *PCFileName "HP8100_H.PPD"
Feature: *ModelName "HP LaserJet 8100 Series"
Feature: *NickName "HP LaserJet 8100 Series"
Feature: *ColorDevice False
Feature: *FaxSupport (null)
Feature: *TTRasterizer Type42

Enjoy...

	Andy

---

From: Stephen Welker <[email-masked]>
Date: Fri, 04 Aug 2000 12:05:19 +1000

--On Thursday, 3 August 2000 3:03 PM -0700 andrew morgan <[email-masked]> 
wrote:

>> just put the name of the ppd used on the Macintosh (rather than a
>> pathname on the server) in the papd.conf instead or am I just doing
>> something blatantly wrong?
>>

I beg to differ ;-)

I have configured a fully featured PPD file for my Canon BJ200 printer 
(combined with Ghostscript) for use with papd and the Mac. After a clean 
system install it is just a matter of using "Auto Setup" and everybody is 
happy. So if you have a matching PPD files on your Macs and Netatalk 
everything is easy.

The hard part is writing the PPD files as they seem to be scarce. 
Especially when the printer is supported through Ghostscript.

Postscript printers are well supported on Adobe's web site.

Any hints on where to get more PPD files for Ghostscript based printers?

-- 
Stephen Welker

---

From: Jørgen Nørgaard <[email-masked]>
Date: Fri, 04 Aug 2000 09:03:25 +0200

Hi

I am using a LaserWriter II NT and a Lexmark 4079 plus.
I opened the ppd files on the Macintosh in BBEdit and
saved them with Unix line breaks.
I copied the ppd's to the Linux box.
When I create a desktop printer on the Macintosh client
its selects the right ppd on the Macintosh. All I have
to do, is to tell which options are intalled on the
Lexmark (amount of RAM and harddisk).

Joergen

> Fra: andrew morgan <[email-masked]>
> Dato: Thu, 3 Aug 2000 15:03:37 -0700 (PDT)
> Til: Sam Noble <[email-masked]>
> Cc: [email-masked]
> Emne: Re: papd.conf
> Gensendt fra: [email-masked]
> Gensendelsesdato: Thu, 3 Aug 2000 18:03:43 -0400 (EDT)
> 
> 
>