Subject: Single link multi homing

From: Brian Bennett <[email-masked]>
Date: Sat, 19 Feb 2000 21:57:37 -0800

Hi

I've got a network where each computer is connected to my ISP via cable
modem.  Because my neighborhood transfer rates are capped to about 50k I've
added additional IP addresses to each of my computers in the 192.168.1.x
range.

To simplify:  each computer has 1 ethernet card, and 2 IP Addresses.

When I connect to netatlk through the chooser it connects to the external IP
(ie, the one assigned by my ISP) which makes things really slow (10-20
seconds to transfer 3k).

My question:
How do I make netatalk use my private IP as it's primary IP address in the
chooser rather than the one assigned by my ISP?

Thanks,
Brian

---

From: Ron Chmara <[email-masked]>
Date: Sun, 20 Feb 2000 21:01:04 -0700

Brian Bennett wrote:
> ...I've

What's happening (to summarize): Your machines are connecting over an
IP you don't want to use.

Solution? Try this: See if you can connect over the IP you do want to use.
Chooser-> Appleshare->Server IP address.
Make aliases to that IP.

Possible complications:
1. If your routing isn't set up right, you may have to go to the public IP,
or change your routing.
2. If Netatalk tries to bind afp over tcp the first address assigned, change
the order you assign them.
3. If you try to connect via DNS name, or some other method that uses the
public IP, you have to use that IP.

HTH,
-Bop

--
Brought to you from iBop the iMac, a MacOS, Win95, LinuxPPC machine,
which is currently in MacOS land.  Your bopping may vary.

---

From: Brian Bennett <[email-masked]>
Date: Sun, 20 Feb 2000 20:32:07 -0800

Thanks Ron, those will make due as a workaround.  But still, does anyone
know a way to tell netatalk which IP address to use?  If not, maybe this
needs to be added in future versions.

B

> From: Ron Chmara <[email-masked]>
> Reply-To: [email-masked]
> Date: Sun, 20 Feb 2000 21:01:04 -0700
> To: Brian Bennett <[email-masked]>
> Cc: [email-masked]
> Subject: Re: Single link multi homing
> 
> Brian Bennett wrote:
>> ...I've

---

From: [email-masked]
Date: Mon, 21 Feb 2000 11:00:04 +0100

> >> To simplify:  each computer has 1 ethernet card, and 2 IP Addresses.
How does your "/etc/netatalk/afpd.conf" look like? ----------^ ?????

Uwe

---

From: Brian Bennett <[email-masked]>
Date: Mon, 21 Feb 2000 09:33:32 -0800

Ah, that's it!!

My afpd.conf is nothing but a bunch of commented out lines, but it shows
exactly how to bind it to one IP address.

Thanks!!
B

> From: [email-masked]
> Date: Mon, 21 Feb 2000 11:00:04 +0100
> Cc: [email-masked], [email-masked]
> Resent-From: [email-masked]
> Resent-Date: Mon, 21 Feb 2000 08:51:41 -0500 (EST)
> 
>

---

From: [email-masked]
Date: Mon, 21 Feb 2000 19:14:58 +0100

> exactly how to bind it to one IP address.

"<server name>" -tcp -ddp -port 548 -address 192.168.1.199 -noguest
-uservolfirst -loginmesg "Welcome at my Linux server!"