Subject: [Fwd: Quark Save As Error w/Netatalk 2.1.3]

From: Mitch McNeel <[email-masked]>
Date: Fri, 18 Feb 2000 11:38:18 -0800

Is there a patch to fix this??  

Any suggestion welcome!!!

I get this in /var/adm/messages file:

Feb 17 11:04:19 unix: netatalk 1.4b2+asun2.1.3
Feb 17 11:58:28 afpd[4391]: afp_openfork: ad_open:
Permission denied
Feb 17 12:02:22 afpd[4391]: dsi_stream_read(-1): Connection
reset by peer
Feb 17 12:02:22 afpd[4391]: dsi_stream_write: Broken pipe
Feb 17 12:02:22 last message repeated 1 time
Feb 17 12:10:54 afpd[4435]: dsi_stream_read(-1): Connection
reset by peer
Feb 17 12:10:54 afpd[4435]: dsi_stream_write: Broken pipe
Feb 17 12:10:54 last message repeated 1 time

Thanks in advance
Mitch

-------- Original Message --------
Subject: Quark Save As Error w/Netatalk 2.1.3
Date: Thu, 17 Feb 2000 12:15:44 -0800
From: "Glen Schuler" <[email-masked]>
To: [email-masked]

Get this error when trying to save as with Quark version
4.04:

Unkown error. [-1072]

"Server(ipaddress) via TCP/IP"

The file server's connection has unexpectedly closed down
[12:10 PM on 2/17/00].

Can you send list to Netatalk List.

Thanks
Glen

---

From: Marcus Radich <[email-masked]>
Date: Sat, 19 Feb 2000 09:31:12 +1300

This happened to me too.

Upgrade to asun2.1.437b and add 'DEFS= -DUSE_FLOCK_LOCKS' to the 
sys/linux/Makefile in your netatalk source.
This retains the 'old' filelocking of asun2.1.3, therefore working 
around Quark's strange habit of randomly locking files under 
asun2.1.437b's file locking code.

I guess your Mac(s) are new iMacs or G4s running OS 9....these are 
the problems I had. All fixed now!

>Can you send list to Netatalk List.

========================================================

"Always ask the question, never assume the answer."
		Marcus Radich 1999

This message has been checked with GRIMEsweeper which has detected a virus
embedded in this plain text message. You should now delete your entire hard
drive and rinse your eyes with soapy water to ensure it doesn't spread.

========================================================

---

From: Mitch McNeel <[email-masked]>
Date: Mon, 21 Feb 2000 08:57:55 -0800

> the problems I had. All fixed now!

I'm running Netatalk on Solaris 2.6. w/latest patches.  Do I just add the same
line to the sys/solaris/Makefile instead of sys/linux/Makefile.????

Do I need to comment out this line `DEFS= -DNO_STRUCT_TM_GMTOFF -D__svr4__
-DSOLARIS -I../../sys/generic \
   ${OSDEFS} ${MACHINEDEFS}` , or do I just add the other line below or
above???

Thanks

--
                     |||||
                   ((~) (~))
                    ( (_) )
                     { ~ }
                       V
-----------------oOO0-----0OOo-----------------------
Mitch McNeel                # Phone Ext. 6236
Unix Systems Administrator  # Phone Num. 619-552-6210
Maintenance Warehouse, Inc. # http://www.mwh.com
-----------------------------------------------------

---

From: [email-masked] (Jørgen Binningsbø)
Date: 21 Feb 2000 22:10:03 +0100

hi!

I have read with interest the articles lately about G4s, OS9 and
Quark problems, and so far I have not dared upgrading either Quark
(4.04->4.1), MacOS (8.6->9) or netatalk.

Instead, my student newspaper is considering changing over to Adobe
InDesign.  I have found little, if none, traffic on this list
regarding InDesign, so I'm just curious if someone have positive or
negative experience with the Indesign+Netatalk combination.

best regards, jørgen
-- 
jørgen binningsbø                    Heretter kjem politisk journalistikk
sivilarbeider i Under Dusken               i Noreg til å dreie seg om når
www.underdusken.no                            Jens Stoltenberg skal felle
                                                    Kjell Magne Bondevik.
heime:  73 53 05 16 | 73 92 19 33                    
ud:     73 89 96 70 | 73 53 18 13                     -leiar i Dag og Tid