Subject: Re: Apple Double?

From: Dave Ritter <[email-masked]>
Date: Mon, 03 Apr 2000 16:04:34 -0500

some applications put almost nothing in the resource fork, others put
everything in the resource fork...

most applications are entirely composed of resources and little or nothing
in the data fork....

> From: Philip Bertuglia <[email-masked]>
> Reply-To: Philip Bertuglia <[email-masked]>
> Date: Mon, 03 Apr 2000 17:46:16 -0700
> To: Patrik Schindler <[email-masked]>
> Cc: [email-masked]
> Bcc: "Dave Ritter" <[email-masked]>
> Subject: Re: Apple Double?
> 
> Is it true that on most applications the resource fork contains more then
> just he creator information? I was under the impression that the
> application uses the information as well. Thus, a file with no resource fork
> is almost totally useless. I hope I'm wrong, because this would save me a
> lot of time. 
> 
> Phil
> 
> 
> On Mon, 3 Apr 2000, Patrik Schindler wrote:
> 
>> At 15:01 Uhr -0500 03.04.2000, Bill Carlson wrote:
>> 
>>> I'm at 1.42b+asun2.1.3 on Solaris 2.6. I was having all sorts of problems
>>> with clients reading .AppleDouble files (from a 1.42.b+asun2.1.0 setup),
>>> so I decided to cleanse the file system by removing all the .AppleDouble
>>> files, figuring they would be recreated, no big deal.
>> 
>> If you don't have any programs, this is okay.
>> 
>>> Well, that went ok and works, users have to open their files within the
>>> application for the document, no big deal. However, the .AppleDouble files
>>> created are bogus, I've been getting the following in syslog:
>>> afpd[17612]: ad_refresh: can't parse AppleDouble header.
>>> afpd[17084]: ad_refresh: can't parse AppleDouble header.
>> 
>> Are you sure that they have been recreated at this point?
>> 
>>> I've also noticed that the icon given to the file is not that of the
>>> application used to modify/save the file.
>> 
>> If there are no .AppleDouble files, files are mapped via extension mappings
>> in
> an AppleVolumes File. Have a look into this.
>> 
>>> Seems to me a field is off
>>> somewhere. Is there a fix for this? The only compile time settings I
>>> changed were to leave out PAM support and enable Berkeley DB. Is there
>>> something else I should have included?
>> 
>> No, I dont' think so.
>> 
>> :wq! PoC
>> 
>> 
> 
>

---

From: Joerg Bullmann <[email-masked]>
Date: Mon, 10 Apr 2000 17:25:23 +0800

>This Monday, the older netatalk package I
>was running on a Linux 2.2.13  kernel quit
>on me. Client Macs would totally lock up

How did this happen? All of a sudden? Or
did you upgrade either your kernel, libs,
or netatalk?

Just out of interest.

Joerg

---

From: pbertugl <[email-masked]>
Date: Mon, 10 Apr 2000 07:59:43 -0400

Joerg,

All of a sudden. It just started locking up clients one morning. I did an 
md5sum
on all of the binaries and they look ok. Tripwire didn't see and changes. The
network wasn't change at all to my knowledge. The package starts up with no
error at all.

I removed the kernel module and reinstalled it, I even when to the extreme and
restarted the kernel (reboot). This did nothing (it never does with 
Linux/Unix).

Any ideas?

>===== Original Message From Joerg Bullmann <[email-masked]> =====

---

From: Joerg Bullmann <[email-masked]>
Date: Wed, 12 Apr 2000 10:44:52 +0800

Hi Philip,

>All of a sudden. It just started locking up

How mean. Sorry to hear that. No ideas how this
might have happened. Our netatalk works acceptably
with virtually NO maintenance (knock on wood).

One thing that only now seems a bit strange is this:
isn't Adrian Sun (that's his name, right?) aware of
the .AppleDouble trouble?

Just to repeat the situation:

1) the old netatalk "had a crash on you"
2) you installed the new stuff
3) the .AppleDouble files didn't work anymore

That was it, if I recall it correctly, no?

Has Adrian changed anything in the .AppleDouble
handling? I would be amazed if there was a change
in file formats of .AppleDouble. That stuff
exists for such a long time already.

Did anybody have a look at the contents of a "new"
and an "old" .AppleDouble file? Philip, you yourself
converted files (you described it in one of your
recent emails) from old (not working anymore) to
new (working with the new netatalk).

I have written code to read and write .AppleSingle
format in my MacCVSClient application. This is
essentially the same kind of format, just that both
data fork and resource fork are held in one file.
So I am sure I have detailed docs about .Apple* file
formats flying around somewhere...

I could have a look at a pair of .AppleDouble files
(new and old) and try to find out what changed. I
can't promise to do it "yesterday", but I am willing
to help.

What I would need is this: at least one pair of
.AppleDouble files (old and new version). To have
several pairs would be better.

Now, please don't flood me with files! ;-)

Cheerio,
Joerg