Subject: afpd errors

From: Jürgen Weltzer <[email-masked]>
Date: Thu, 9 Nov 2000 21:42:08 +0100

Hi All,

here's a part of var/log/messages: I was creating a new folder from a 
Mac on the Linux box - and got the message "server is not available" 
but 2 seconds later it worked. This were the messages:

Nov 7 16:54:28 linux afpd[23908]: WARNING: DID conflict for 
'Temporary Items' and 'Neuer Ordner'. Are these the same file?

Nov 7 16:55:15 linux afpd[23640]: WARNING: DID conflict for 'Neuer 
Ordner 1' and 'ISDN HFG offene Dateien'. Are these the same file?

Whats wrong there?

And sometimes I find a message like this:
Nov 7 17:51:49 linux afpd[24492]: setdirowner: chown -1/0 
.AppleDouble/.Parent: Operation not permitted

But I thought that with CHMOD -R 776 /usr/my_directory the 
permissions were right. Or not?

I'm using asun2.1.4pre39-5 (from jeffb)
-- 
Viele Grüße
Jürgen Weltzer

- - - - - - - - - - - - - - - - - - -
Werbeagentur Weltzer
Max-Eyth-Straße 8
71065 Sindelfingen
Tel. +49 (0) 70.31.81.32.31
Fax +49 (0) 70.31.81.16.01
http://www.w-ww.de/
- - - - - - - - - - - - - - - - - - -

Windows95/98/NT: 32 bit extension and a graphical shell for a 16 bit
patch to an 8 bit operating system originally coded for a 4 bit
microprocessor, written by a 2 bit company, that can't stand 1 bit of
competition

---

From: Marc Miller <[email-masked]>
Date: Thu, 9 Nov 2000 13:20:47 -0800 (PST)

I know about the chown() problem; thought I'd solved that problem already,
but it looks like it came back.  :P  

> I'm using asun2.1.4pre39-5 (from jeffb)

============================================================
	/\/\arc ._|. /\/\iller ([email-masked])
	Computer Room Consultant
	Information Technology/Lab Management
============================================================
I can be contacted through the Communication Center link from
http://www.mother.com/~mjmiller/

---

From: "Marc J. Miller" <[email-masked]>
Date: Mon, 13 Nov 2000 16:32:51 -0800

Okay; my problem was just some old code that needed a "make clean."  Yours 
looks a bit different, and I think I know what your chown error is 
from.  Linux is one flavor of unix which doesn't allow anyone but "root" 
(or someone logged in as root such as through the netatalk 1.5 admin group 
feature) to change the owner of a file.  A user can't even give their own 
file to someone else.  As I understand it, it's because disk quotas would 
be hard to track if that operation was allowed.  A non-root user on your 
system probably tried to change the owner of a directory.  Still, there's a 
peculiarity here which I can't account for.  The uid shouldn't be -1, and 
the gid shouldn't be 0.  I'd be interested to know how to repeat this 
error.  Maybe it's a bug that still needs to be fixed in 1.5.

At 09:42 PM 11/9/00 +0100, Jürgen Weltzer wrote:
>  Hi All,
>
>here's a part of var/log/messages: I was creating a new folder from a Mac 
>on the Linux box - and got the message "server is not available" but 2 
>seconds later it worked. This were the messages:
>
>Nov 7 16:54:28 linux afpd[23908]: WARNING: DID conflict for 'Temporary 
>Items' and 'Neuer Ordner'. Are these the same file?
>
>
>Nov 7 16:55:15 linux afpd[23640]: WARNING: DID conflict for 'Neuer Ordner 
>1' and 'ISDN HFG offene Dateien'. Are these the same file?
>
>Whats wrong there?
>
>
>But I thought that with CHMOD -R 776 /usr/my_directory the permissions 
>were right. Or not?
>