Subject: Problem with make

From: Jürgen Knott <[email-masked]>
Date: Mon, 11 Sep 2000 14:02:12 +0200

Hi all!

I had installed REDHAT 6.2 on my Computer and now i will install Netatalk.
I have the netatalk-1.4b2+asun2.1.3.tar.gz downloaded and unpacked with
"tar -xvzf netatalk-1.4b2+asun2.1.3.tar.gz" and
it was created a directory called netatalk-1.4b2+asun2.1.3.
I change in this directory and type "make".
After a few seconds i become error messages. I will typing the end of this
message:

--- Begin ---
switch.o(.data+0x494): undefined reference to `afp_changepw´
auth.o: In function `clrtxt_login´:
auth.o(.text+0x60a): undefined reference to `crypt´
/usr/bin/ ../lib/libwrap.a(hosts_access.o): In function `host_match´:
host_access.o(.text+0x400): undefind reference to `yp_get_default_domain´
collect2: ld returned 1 exit status
make[4]: *** [afpd] Error 1
make[3]: ***[all] Error 2
make[2]: ***[afpd] Error 2
make[1]: ***[../..etc] Error 2
make: *** [all] Error 2

--- End ---

I installed Red Hat 6.2 as a Server, compiled the kernel with AppleTalk
Support (fix in the Kernel, no Modul).

Who can help me?

Bye Juergen

---

From: andrew morgan <[email-masked]>
Date: Mon, 11 Sep 2000 07:36:46 -0700 (PDT)

> make[1]: ***[../..etc] Error 2

This is a known bug in asun2.1.3.  To fix it, add "-lnsl" to the LIBS line
in sys/linux/Makefile of the source distribution.

	Andy