Subject: compiling w/ tcp_wrappers option on a Solaris 2.6 box

From: clark <[email-masked]>
Date: Mon, 6 Mar 2000 15:49:14 -0500 (EST)

I"m trying to build netatalk with the tcp_wrappers option. Keep getting this err 
msg 

"make[4]: Entering directory `/opt/netatalk-1.4b2+asun2.1.3/etc/afpd'
gcc -D__svr4__ -DSOLARIS -I../../sys/solaris    -O -I../../include       
-DAPPLCNAME  -o afpd unix.o afs.o kuam.o send_to_kdc.o lifetime.o ofork.o main.o 
switch.o auth.o volume.o directory.o file.o enumerate.o desktop.o filedir.o 
fork.o appl.o gettok.o bprint.o status.o afp_options.o afp_asp.o afp_dsi.o 
messages.o config.o nfsquota.o codepage.o -L../../libatalk   -L/usr/sbin/lib    
-latalk    -lsocket -lnsl -lrpcsvc -lwrap  
ld: fatal: library -lwrap: not found
ld: fatal: File processing errors. No output written to afpd
make[4]: *** [afpd] Error 1
make[4]: Leaving directory `/opt/netatalk-1.4b2+asun2.1.3/etc/afpd'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/opt/netatalk-1.4b2+asun2.1.3/etc/afpd'
make[2]: *** [afpd] Error 2
make[2]: Leaving directory `/opt/netatalk-1.4b2+asun2.1.3/etc'
make[1]: *** [../../etc] Error 2
make[1]: Leaving directory `/opt/netatalk-1.4b2+asun2.1.3/sys/solaris'
make: *** [all] Error 2"

I've copied tcpd.h into the netatalk include dir. PATHS appear to be correct. 
Anyone know what lib this is so I can install it?

-Daniel

---

From: Patrik Schindler <[email-masked]>
Date: Mon, 6 Mar 2000 22:24:33 +0100

>ld: fatal: File processing errors. No output written to afpd

You need libwrap.a somewhere in your LD_LIBRARY_PATH.
Without this lib, you cannot build with tcp wrappers.

:wq! PoC