Subject: Authentication problem

From: Roger Fischer <[email-masked]>
Date: Sun, 2 Apr 2000 22:16:10 -0700

I've been using Netatalk on a Mac Centris610 running NetBSD for quite a
while now.  It connect to the NebBSD box from my G3 running Mac OS 8.6.

Everything has been fine for quite some time.
Today, I started having an authentication problem.

I open chooser, select my NetBSD computer "max", enter
my login name and password, then I get the response

"Sorry, the password you entered is incorrect.
Please reenter it."

But here's the problem, it's only happening on one account.
If I try to login under a different account it works.  I can't
figure what I might have changed that would cause this.
If I telnet to the machine, it works fine, so the password
that I'm using is correct.

Does anybody have any ideas?
Thanks,
Roger

---

From: Patrik Schindler <[email-masked]>
Date: Mon, 3 Apr 2000 10:42:00 +0200

>that I'm using is correct.

Perhaps this is caused by some password expiries one can set in /etc/shadow (does BSD have this?). For myself, this is one of the remaining mysteries of unix in general: Some things work (telnet, shell), some not (afpd, pop3, ...).

:wq! PoC

---

From: Roger Fischer <[email-masked]>
Date: Mon, 3 Apr 2000 20:57:23 -0700

At 1:42 AM -0700 4/3/00, Patrik Schindler wrote:
>Perhaps this is caused by some password expiries one can set in
>/etc/shadow (does BSD have this?). For myself, this is one of the
>remaining mysteries of unix in general: Some things work (telnet, shell),
>some not (afpd, pop3, ...).

A-Ha.  Found the problem.  Duh, it was in the faq.

Netatalk checks for a valid shell when you log in, and compares it to whats
listed in /etc/shells.  I had recently switched my login shell to bash.

I added the line "/usr/pkg/bin/bash" to my /etc/shells file
and all is right in the world again.

Thanks,
Roger

---

From: Patrik Schindler <[email-masked]>
Date: Tue, 4 Apr 2000 12:17:32 +0200

>and all is right in the world again.

Fine! :-)

:wq! PoC