Subject: Re: Routing issue with atalkd

From: "Konstantin Reznitsky" <[email-masked]>
Date: Thu, 01 Jun 2000 19:30:53 +0000 (GMT)

Hi, guys!!! Finally!

I was talking about this several months ago... (with asun 2.1.3 that time).
I have a strong feeling that your primary interfaces on the routing linux
boxes a set to the outside networks (NOT on the link in between). I had even more wierd situation (in my setup I had two macs - one on each side)- one of the macs could see another, but revers didn't work, I had even a thought to hide the networks this way. asun recomended to upgrade to the latest by then kernel, but that did not help. Anyway, to make this thing to work both ways I had to make primary netatalk interfaces to be on the link connecting the boxes. I also had to force the afpds to the zones I wanted (not default). I'm still not sure how all this will work in a chain with more then two routing linux boxes (luckely I never needed this).

Konstantin.

I'm still very interesed in the solution, so if you'll find one, let me know.

On Thu, 1 Jun 2000 Patrik Schindler  wrote:
> Hello,
> 
> since the elder days of the original 1.4b code I saw an issue which I could not explain.

> 
> Take two linux-2.2.15-glibc-2.1.2 hosts. Install and run atalkd on both machines,
which both have two network interfaces. Every machine has one connection to the other.
This connection is a modem link (with vtun).
> I don't think, this is an issow, because I had a similar setup 2 years ago with stock
1.4b2 via pure ethernet and the same problems.
> The free network interface is connected to a Mac (OS 7.6.1/w OT 1.3 and stock OS 8.1
respectively). One side has also a 2nd linux-box running.
> 
> Nbplkup shows both linux machines (afpd) very fine. But one mac can't see the other.

> 
> I looked into /proc/atalk_iface and /proc/atalk_route and saw that the routes get
set okay as expected. I also nbplkup'ed a bit and aechoed remote machines: Works perfectly.

> 
> Name propagation seems to be reliable only locally:
> 
> This is the view on the remote side. You see 17.124 (Mac/8.1).
> 
>              newgen TurboPS/480:LaserWriter                        5.1:132
>           Apple Laserwriter NTR:LaserWriter                        5.1:131
>           Apple Laserwriter NTX:LaserWriter                        5.1:129
>                          shauny:AFPServer                          5.1:130
>         Tektronix Phaser IIIpxi:LaserWriter                        5.1:128
>                          shauny:netatalk                           5.1:4
>                          shauny:Workstation                        5.1:4
>                             Mc:  Power Macintosh                  17.124:251
>                             Mc:Workstation                        17.124:4
> 
> This is the local view.
> 
>              newgen TurboPS/480:LaserWriter                        5.1:132
>           Apple Laserwriter NTR:LaserWriter                        5.1:131
>           Apple Laserwriter NTX:LaserWriter                        5.1:129
>                          shauny:AFPServer                          5.1:130
>         Tektronix Phaser IIIpxi:LaserWriter                        5.1:128
>                          shauny:netatalk                           5.1:4
>                          shauny:Workstation                        5.1:4
> 
> And this is the local view from the 2nd box.
> 
>              newgen TurboPS/480:LaserWriter                        5.1:132
>           Apple Laserwriter NTR:LaserWriter                        5.1:131
>           Apple Laserwriter NTX:LaserWriter                        5.1:129
>                          shauny:AFPServer                          5.1:130
>         Tektronix Phaser IIIpxi:LaserWriter                        5.1:128
>                          shauny:netatalk                           5.1:4
>                          shauny:Workstation                        5.1:4
> 
> I could verify this behaviour with trawl from the local Mac: No Mc on the other side.

> 
> Has anyone verified this behaviour befor or am I the only one which has such a "big"
network?:-)
> :wq! PoC

Konstantin

---

From: Patrik Schindler <[email-masked]>
Date: Fri, 2 Jun 2000 08:25:52 +0200

At 19:30 Uhr +0000 01.06.2000, Konstantin Reznitsky wrote:

>boxes a set to the outside networks (NOT on the link in between)

I know the term "primary interface" only with MarsNWE. Could you explain this further?

>asun recomended to upgrade to the latest by then kernel, but that did not help. 

He wrote that to me, too.

>I also had to force the afpds to the zones I wanted (not default). I'm still not sure how all this will work in a chain with more then two routing linux boxes (luckely I never needed this).

Badly enough, it seems that multicasting (used for broadcasting nbp information) won't really work (reliable) further away than one hop.

I'll have a look at atalkd but I don't have much hope to get this fixed.

:wq! PoC