Subject: Extreme performance problem

From: "Yan FITTERER" <[email-masked]>
Date: Mon, 18 Sep 2000 11:43:14 +0100

Problem with Netatalk on Linux RH 6.2:
Macs connect OK, and can write to the Netatalk volume OK, but if they try to 
read (either by copying a file locally or by opening a file remotely), the read 
seems to hang horribly.
The file is eventually read, but with very long pauses (10-20 seconds).

It had been working OK for a week before this started to happen.

As I don't get any errors message (nothing looking abnormal in the syslog), I'm 
really stuck as to what to try.

Any ideas anyone?

Thanks
Yan

-----------------
Yan Fitterer,                                    |
IT Manager,                                      | 
Royal Academy of Music                           |
                                                 |
E-mail : [email-masked]                    |    
Phone (work) (+44) 171 873 7365                  |
Fax   (work) (+44) 171 873 7364                  | 
                                                 |
Phone (home) (+44) 181 830 3035                  |

---

From: "Yan FITTERER" <[email-masked]>
Date: Mon, 18 Sep 2000 18:01:44 +0100

> In reply to Yan FITTERER's message of the 18/09/2000 at 11:43 +0100,
> 
> 
> We'll need more information than that: what version of netatalk, Mac 
> OS (or more importantly version of AppleShare client). Also does this 
> affect all users or just some; is it every file or just some. Also 
> are they connected via AppleTalk or TCP/IP.
> 
> Are you able to get a pkt trace for a small file? If so, send it to 
> me and I might be able to figure it out (don't flood my mbox with a 
> multi-MB trace please).
> 

Hi. Thanks for that. I guess you mean a tcpdump output?
If yes, I'll generate one and pass it on. (if not, what should I use?)

BTW, I'm using Netatalk 1.4b2 + asun2.1.3-7, (installed from rpm) all clients 
have the problem, with mixture of OS8 and OS9, they connect via AppleTalk 
(2.0.3 driver 60.0a6 and 2.6 driver 61.0), and every file I tried was the same.

May be interesting to note that it seems to have broken itself after I 
unloaded/reloaded the network services (/etc/rc.d/init.d/network script), and 
added and deleted a few IP routes. But I didn't change any of the config... 
Beside what I can't see what config messups could relate to those symptoms... :(

Thanks for your time!
Bye
Yan
-----------------
Yan Fitterer,                                    |
IT Manager,                                      | 
Royal Academy of Music                           |
                                                 |