Subject: ppp interface in atalkd.conf????

From: Peter Gutowski <[email-masked]>
Date: 26 Sep 2000 08:35:45 -0400

I've set up a VPN between my work server and home linux machines following the [excellent] directions in the VPN-Howto. Both are running netatalk 1.4b2+asun2.1.4p37 in general quite nicely.

The VPN creates a ppp interface to the other network thru which all traffic to that network is routed. (As it travels over the internet, the packet contents are encrypted by ssh.) It all works transparently and I can log onto machines behind the firewall from home using TCP/IP. 

But there are some appletalk devices that I'd like to be able to "see" in the chooser and communicate with. My first course was to simply add the ppp0 interface into the atalk.conf file and restart netatalk.

Well, after a number of attempts (just adding ppp0 into atalkd.conf, and other more specific conf parameters), I'm stumped: atalkd rewrites the atalkd.conf file each time, but without any reference to the ppp0 interface. 

Perhaps those more familiar with the low-level interaction between the atalkd and the interfaces could shed some light on this.

Thanks in advance!

-Peter Gutowski

---

From: Matthew Geier <[email-masked]>
Date: Wed, 27 Sep 2000 07:43:15 +1100

> Perhaps those more familiar with the low-level interaction between the atalkd and the interfaces could shed some light on this.

 ppp needs to transport AppleTalk. By default it only does TCP/IP on
linux boxes at least. There are hooks in pppd for other protocols,
particularly IPX and AppleTalk, but the kernel PPP driver needs to know
what to do as well. IPX is supported, im not sure the kernel AppleTalk
driver does.

 I found a document some time ago about setting up a linux based 'access
server' to bridge AppleTalk for the dial in users. That persons desire
was to bridge, and you may want to route, but the ideas might help. I no
longer know who/where this ppp/AT document was. Use your favourite
search engine and look for AppleTalk linux and ppp.