Subject: RE: Some problems on solaris 7

From: Michalowski Thierry <[email-masked]>
Date: Tue, 14 Nov 2000 09:11:17 +0100

This problem is well-known as "dancing icons"...
Check your resource forks, a.k.a. the permissions on the .AppleDouble
directories . They should match the permissions of the corresponding
directory/files.

HTH
Thierry Michalowski

> -----Original Message-----
> From: Chris G. Sellers [mailto:[email-masked]]
> Sent: Monday, November 13, 2000 11:05 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: Some problems on solaris 7
> 
> 
> I don't seem to have any problems either.  Occasionally I have a file
> that will dup it'self but it's rare and is usually a new file that
> was just added.  It goes away after resizing the window or closing
> and opening again.
> 
> Sellers
> 
> 
> > 
> > On Mon, 13 Nov 2000, Frederic Goudal wrote:
> > 
> > > one file appears 2 times than 3 times than 4 times and 
> this loop starts again.
> > > Always the same file. Ok my directory is bit big (500 files).
> > > Another thing afpd core dumps while not used on an 
> strncpy function call.
> > > 
> > > I'm using the compiled version that I have found on
> > > 
> > > ftp://ftp.santafe.edu/pub/unix/netatalk/
> > 
> > What Mac clients are these?  I haven't seen this problem with 8.6 or
> > greater. I have a directory that has over 900 files and 
> don't see this
> > activity.
> > 
> > Tim
> > 
> > Tim Carlson                                  Voice:    
> (505) 984-8800x255
> > Director of Computing: Santa Fe Institute    Fax:      
> (505) 982-0565
> > WWW: http://www.santafe.edu/~tim             Email:   
> [email-masked]
> > 
> > 
> 
> 
> =	-	-	-	-	-	-	-	=
> 
>    Sellers , Chris G.		Scientific Programmer Analyst
>     Information & Instructional Technology 
>     Oakland University - Rochester, Michigan 48309-4401	
>     Phone: (248) 370.2016    FAX: (248) 370.4209
>     Oak Archives Co-Manager		http://oak.oakland.edu
>

---

From: Frederic Goudal <[email-masked]>
Date: Tue, 14 Nov 2000 09:17:13 +0100

> This message is in MIME format. Since your mail reader does not understand
> this format, some or all of this message may not be legible.
> 
> ------_=_NextPart_001_01C04E12.76992620
> Content-Type: text/plain;
> 	charset="iso-8859-1"
> 

THere is was no such entry in the .AppleDouble of the corresponding file/dir
(see my preceding mail).
I have closed the window reopened it, now the answer is : no such file...

But by main problem is the crash of the afpd daemon : I can't use
netatalk in production with such a problem.

f.g.

> ------_=_NextPart_001_01C04E12.76992620
> Content-Type: text/html;
> 	charset="iso-8859-1"
> Content-Transfer-Encoding: quoted-printable
> 
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
> <HTML>
> <HEAD>
> <META HTTP-EQUIV=3D"Content-Type" CONTENT=3D"text/html; =
> charset=3Diso-8859-1">
> <META NAME=3D"Generator" CONTENT=3D"MS Exchange Server version =
> 5.5.2652.35">
> <TITLE>RE: Some problems on solaris 7</TITLE>
> </HEAD>
> <BODY>
> 
> <P><FONT SIZE=3D2>This problem is well-known as &quot;dancing =
> icons&quot;...</FONT>
> <BR><FONT SIZE=3D2>Check your resource forks, a.k.a. the permissions on =
> the .AppleDouble directories . They should match the permissions of the =
> corresponding directory/files.</FONT></P>
> 
> <P><FONT SIZE=3D2>HTH</FONT>
> <BR><FONT SIZE=3D2>Thierry Michalowski</FONT>
> </P>
> 
> <P><FONT SIZE=3D2>&gt; -----Original Message-----</FONT>
> <BR><FONT SIZE=3D2>&gt; From: Chris G. Sellers [<A =
> HREF=3D"mailto:[email-masked]">mailto:[email-masked]</A>]</FON=
> T>
> <BR><FONT SIZE=3D2>&gt; Sent: Monday, November 13, 2000 11:05 PM</FONT>
> <BR><FONT SIZE=3D2>&gt; To: [email-masked]</FONT>
> <BR><FONT SIZE=3D2>&gt; Cc: [email-masked]; =
> [email-masked]</FONT>
> <BR><FONT SIZE=3D2>&gt; Subject: Re: Some problems on solaris 7</FONT>
> <BR><FONT SIZE=3D2>&gt; </FONT>
> <BR><FONT SIZE=3D2>&gt; </FONT>
> <BR><FONT SIZE=3D2>&gt; I don't seem to have any problems either.&nbsp; =
> Occasionally I have a file</FONT>
> <BR><FONT SIZE=3D2>&gt; that will dup it'self but it's rare and is =
> usually a new file that</FONT>
> <BR><FONT SIZE=3D2>&gt; was just added.&nbsp; It goes away after =
> resizing the window or closing</FONT>
> <BR><FONT SIZE=3D2>&gt; and opening again.</FONT>
> <BR><FONT SIZE=3D2>&gt; </FONT>
> <BR><FONT SIZE=3D2>&gt; Sellers</FONT>
> <BR><FONT SIZE=3D2>&gt; </FONT>
> <BR><FONT SIZE=3D2>&gt; </FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; </FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; On Mon, 13 Nov 2000, Frederic Goudal =
> wrote:</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; </FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; one file appears 2 times than 3 times =
> than 4 times and </FONT>
> <BR><FONT SIZE=3D2>&gt; this loop starts again.</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; Always the same file. Ok my directory =
> is bit big (500 files).</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; Another thing afpd core dumps while =
> not used on an </FONT>
> <BR><FONT SIZE=3D2>&gt; strncpy function call.</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; </FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; I'm using the compiled version that I =
> have found on</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; </FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; &gt; <A =
> HREF=3D"ftp://ftp.santafe.edu/pub/unix/netatalk/" =
> TARGET=3D"_blank">ftp://ftp.santafe.edu/pub/unix/netatalk/</A></FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; </FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; What Mac clients are these?&nbsp; I =
> haven't seen this problem with 8.6 or</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; greater. I have a directory that has over =
> 900 files and </FONT>
> <BR><FONT SIZE=3D2>&gt; don't see this</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; activity.</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; </FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; Tim</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; </FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; Tim =
> Carlson&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp=
> ;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp=
> ;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
> Voice:&nbsp;&nbsp;&nbsp; </FONT>
> <BR><FONT SIZE=3D2>&gt; (505) 984-8800x255</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; Director of Computing: Santa Fe =
> Institute&nbsp;&nbsp;&nbsp; Fax:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </FONT>
> <BR><FONT SIZE=3D2>&gt; (505) 982-0565</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; WWW: <A =
> HREF=3D"http://www.santafe.edu/~tim" =
> TARGET=3D"_blank">http://www.santafe.edu/~tim</A>&nbsp;&nbsp;&nbsp;&nbsp=
> ;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Email:&nbsp;&nbsp; =
> </FONT>
> <BR><FONT SIZE=3D2>&gt; [email-masked]</FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; </FONT>
> <BR><FONT SIZE=3D2>&gt; &gt; </FONT>
> <BR><FONT SIZE=3D2>&gt; </FONT>
> <BR><FONT SIZE=3D2>&gt; </FONT>
> <BR><FONT SIZE=3D2>&gt; =3D&nbsp;&nbsp;&nbsp;&nbsp; =
> -&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
> -&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
> -&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
> -&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
> -&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
> -&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
> -&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =3D</FONT>
> <BR><FONT SIZE=3D2>&gt; </FONT>
> <BR><FONT SIZE=3D2>&gt;&nbsp;&nbsp;&nbsp; Sellers , Chris G. =
> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Scientific Programmer =
> Analyst</FONT>
> <BR><FONT SIZE=3D2>&gt;&nbsp;&nbsp;&nbsp;&nbsp; Information &amp; =
> Instructional Technology </FONT>
> <BR><FONT SIZE=3D2>&gt;&nbsp;&nbsp;&nbsp;&nbsp; Oakland University - =
> Rochester, Michigan 48309-4401&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
> </FONT>
> <BR><FONT SIZE=3D2>&gt;&nbsp;&nbsp;&nbsp;&nbsp; Phone: (248) =
> 370.2016&nbsp;&nbsp;&nbsp; FAX: (248) 370.4209</FONT>
> <BR><FONT SIZE=3D2>&gt;&nbsp;&nbsp;&nbsp;&nbsp; Oak Archives =
> Co-Manager&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; <A =
> HREF=3D"http://oak.oakland.edu" =
> TARGET=3D"_blank">http://oak.oakland.edu</A></FONT>
> <BR><FONT SIZE=3D2>&gt; </FONT>
> </P>
> 
> </BODY>
> </HTML>
> ------_=_NextPart_001_01C04E12.76992620--

---

From: Tim Carlson <[email-masked]>
Date: Tue, 14 Nov 2000 10:25:14 -0700 (MST)

> netatalk in production with such a problem.

Is there a specific program which causes the crash?

Is you Solaris machine patched reasonably well?  I don't know of any
actual patches that affect netatalk, but it can't hurt to have a recent
set of recommended patches installed. My kernel level is 106541-11 and I
haven't seen these problems. 

Tim

---

From: Frederic Goudal <[email-masked]>
Date: Tue, 14 Nov 2000 18:37:28 +0100

> Is there a specific program which causes the crash?

Finally I think it crashes when I disconnect the Mac client. 

The gdb trace is the following.

#0  0xff1b76dc in strncpy ()
(gdb) bt
#0  0xff1b76dc in strncpy ()
#1  0x33ab4 in rfc931 ()
#2  0x33b20 in eval_user ()
#3  0x33180 in spawn_option ()
#4  0x32e98 in process_options ()
#5  0x3276c in table_match ()
#6  0x3257c in hosts_access ()
#7  0x2f90c in dsi_tcp_open ()
#8  0x2ecf4 in dsi_getsession ()
#9  0x28d14 in dsi_start ()
#10 0xffbef8dc in ?? ()

But I do not see an rfc931 in the source tree.

> haven't seen these problems. 

I'm in 06 revision. I will try to patch to 11 revision.

---

From: "Jonathan Newman" <[email-masked]>
Date: Tue, 14 Nov 2000 09:55:16 -0800

> But I do not see an rfc931 in the source tree.

hosts_access is a libwrap routine (tcpwrappers) which explains why
rfc931 is not anywhere in the netatalk code.

Jon

---

From: Frederic Goudal <[email-masked]>
Date: Wed, 15 Nov 2000 09:54:48 +0100

> rfc931 is not anywhere in the netatalk code.

Finally I have compiled it without tcp_wrapper support and it does
not seems to crash anymore.
Btw I have not seen any doc on how to fill the tcp_wrapper files for
netatalk.

f.g.