Subject: AppleVolumes.default, can't see shared directories

From: "S.Ecker" <[email-masked]>
Date: Wed, 10 May 2000 11:48:17 -0700 (PDT)

Hi,

Ok, almost everything works now, except I can't see
anything other than the user's root directory when I
log in.  My AppleVolumes.default conatains the
following:

~  (can see this just fine)
/home/Documents/ "Documents" (can't see this)

I've tried removing the trailing /, removing the
quotes, and removing "Documents" alltogether. 
AppleVolumes.default is in /usr/local/atalk/etc with
permissions set as follows:

-rw-rw-rw-    1 nobody   users       2

The permissions on /home/Documents are:

drwxrwxr-x   21 nobody   users        4096 May 10
09:10 Documents

/usr/local/atalk/etc/afpd.conf
"SAFFRON" -tcp -ddp -port 548 -address 216.231.60.66
-nocleartxt -randnum -rand2num -noguest

I even put a symbolic link in each user's root called
~/.AppleVolumes linked to
/usr/local/atalk/etc/AppleVolumes.default (as
suggested in an old post)

The output from my /var/log/messages upon restarting
atalk:

May 10 11:41:54 SAFFRON atalkd[1252]: restart
(1.4b2+asun2.1.4)
May 10 11:41:55 SAFFRON atalkd[1252]: zip_getnetinfo
for eth0
May 10 11:42:14 SAFFRON last message repeated 2 times
May 10 11:42:24 SAFFRON atalkd[1252]: config for no
router
May 10 11:42:25 SAFFRON atalkd[1252]: ready 0/0/0
May 10 11:42:25 SAFFRON atalk: atalkd startup
succeeded
May 10 11:42:37 SAFFRON papd[1264]: restart
(1.4b2+asun2.1.4)
May 10 11:42:37 SAFFRON atalk: papd startup succeeded
May 10 11:42:37 SAFFRON atalk: afpd startup succeeded
May 10 11:42:43 SAFFRON afpd[1273]:
SAFFRON:AFPServer@* started on 65280.139:1
28 (1.4b2+asun2.1.4)
May 10 11:42:43 SAFFRON afpd[1273]: ASIP started on
216.231.60.66:548(2) (1.4b
2+asun2.1.4)
May 10 11:42:43 SAFFRON afpd[1273]: uam: uams_guest.so
loaded
May 10 11:42:43 SAFFRON afpd[1273]: uam:
uams_clrtxt.so loaded
May 10 11:42:43 SAFFRON afpd[1273]: uam: "Cleartxt
Passwrd" available
May 10 11:42:43 SAFFRON afpd[1273]: uam: "No User
Authent" available

The wierd thing here is that it says "uam: "Cleartxt
Passwrd" available" even though I specified
-nocleartxt in afpd.conf.  There are no other versions
of this file anywhere on the server.  All the netatalk
stuff is in /usr/local/atalk/.

-Scott

__________________________________________________
Do You Yahoo!?
Send instant messages & get email alerts with Yahoo! Messenger.
http://im.yahoo.com/

---

From: andrew morgan <[email-masked]>
Date: Wed, 10 May 2000 12:15:52 -0700 (PDT)

> stuff is in /usr/local/atalk/.

I still say that it is looking in a different directory for its
configuration info.  What does your netatalk startup script
(/etc/rc.d/init.d/atalk) look like?

	Andy

---

From: Dejan Muhamedagic <[email-masked]>
Date: Thu, 11 May 2000 23:56:15 +0200

Hello,

> /home/Documents/ "Documents" (can't see this)

This does sound strange.  Did you try with

$ strings afpd | grep AppleVolumes

The output should give you what afpd will try to read (the full path) as
a system/default list of volumes.

Dejan