Subject: Re: Can't Log in as use, Shadow supported

From: GoRN ToTheRescue <[email-masked]>
Date: Sun, 7 May 2000 09:59:19 -0700 (PDT)

> Look into /etc/syslog.conf

Thanks it was in /usr/adm/messages, here is what i found:
May  7 01:05:11 Nixel atalkd[3574]: restart (1.4b2+asun2.1.1)
May  7 01:05:11 Nixel atalkd[3574]: rtmp: service unknown
May  7 01:05:11 Nixel atalkd[3574]: nbp: service unknown
May  7 01:05:11 Nixel atalkd[3574]: echo: service unknown
May  7 01:05:11 Nixel atalkd[3574]: zip: service unknown
May  7 01:05:11 Nixel atalkd[3574]: rtmp: service unknown
May  7 01:05:11 Nixel atalkd[3574]: nbp: service unknown
May  7 01:05:11 Nixel atalkd[3574]: echo: service unknown
May  7 01:05:11 Nixel atalkd[3574]: zip: service unknown
May  7 01:05:12 Nixel atalkd[3574]: zip_getnetinfo for eth0
May  7 01:05:21 Nixel atalkd[3574]: zip_getnetinfo for eth0
May  7 01:05:31 Nixel atalkd[3574]: zip_getnetinfo for eth0
May  7 01:05:41 Nixel atalkd[3574]: config for no router
May  7 01:05:42 Nixel atalkd[3574]: ready 0/0/0
May  7 01:06:01 Nixel afpd[3585]: Nixel:AFPServer@* started on 65280.246:128 (1.4b2+asun2.1.1)
May  7 01:06:01 Nixel afpd[3585]: ASIP started on 192.168.1.1:548(1) (1.4b2+asun2.1.1) 
May  7 01:06:59 Nixel afpd[3588]: ASIP session:548(1) from 192.168.1.2:49832(2)
May  7 01:06:59 Nixel afpd[3585]: server_child[1] 3588 done
May  7 01:07:02 Nixel afpd[3589]: ASIP session:548(1) from 192.168.1.2:49833(2)
May  7 01:07:02 Nixel afpd[3589]: login noauth
May  7 01:42:49 Nixel afpd[3589]: logout
May  7 01:42:49 Nixel afpd[3589]: 3.28KB read, 4.86KB written
May  7 01:42:49 Nixel afpd[3585]: server_child[1] 3589 done
May  7 01:43:44 Nixel afpd[4760]: ASIP session:548(1) from 192.168.1.2:49864(2)
May  7 01:43:44 Nixel afpd[3585]: server_child[1] 4760 done
May  7 01:43:46 Nixel afpd[4761]: ASIP session:548(1) from 192.168.1.2:49865(2)
May  7 01:43:46 Nixel afpd[4761]: login noauth
May  7 01:43:50 Nixel afpd[4761]: logout
May  7 01:43:50 Nixel afpd[4761]: 0.17KB read, 0.13KB written
May  7 01:43:50 Nixel afpd[3585]: server_child[1] 4761 done
May  7 01:44:09 Nixel afpd[4764]: ASIP session:548(1) from 192.168.1.2:49866(2)
May  7 01:44:09 Nixel afpd[3585]: server_child[1] 4764 done
May  7 01:44:13 Nixel afpd[4765]: ASIP session:548(1) from 192.168.1.2:49867(2)
May  7 01:44:13 Nixel afpd[4765]: login noauth
May  7 11:41:49 Nixel afpd[3185]: ASIP session:548(1) from 192.168.1.2:49179(2)
May  7 11:41:49 Nixel afpd[2271]: server_child[1] 3185 done
May  7 11:41:50 Nixel afpd[3186]: ASIP session:548(1) from 192.168.1.2:49180(2)
May  7 11:41:50 Nixel afpd[2271]: server_child[1] 3186 done
May  7 11:42:20 Nixel afpd[2293]: logout
May  7 11:42:20 Nixel afpd[2293]: 195.38KB read, 8738.41KB written
May  7 11:42:20 Nixel afpd[2271]: server_child[1] 2293 done
May  7 11:42:30 Nixel afpd[3242]: ASIP session:548(1) from 192.168.1.2:49181(2)
May  7 11:42:30 Nixel afpd[2271]: server_child[1] 3242 done
May  7 11:42:46 Nixel afpd[3262]: ASIP session:548(1) from 192.168.1.2:49182(2)
May  7 11:42:46 Nixel afpd[3262]: 0.07KB read, 0.05KB written
May  7 11:42:46 Nixel afpd[2271]: server_child[1] 3262 done
May  7 11:42:55 Nixel afpd[3268]: ASIP session:548(1) from 192.168.1.2:49183(2)
May  7 11:42:55 Nixel afpd[2271]: server_child[1] 3268 done
May  7 11:42:56 Nixel afpd[3278]: ASIP session:548(1) from 192.168.1.2:49184(2)
May  7 11:42:56 Nixel afpd[3278]: login noauth

and this is running from a precompiled http://www.thehamptons.com/anders/netatalk/impatient.html
i was going to compile it but the bytesex.h couldn't be found.  This is ver 1.4B2.
The mac is mac os 9.

Thanks for all the help so far!
- GoRN Out -

__________________________________________________
Do You Yahoo!?
Send instant messages & get email alerts with Yahoo! Messenger.
http://im.yahoo.com/

---

From: "David Lancaster" <[email-masked]>
Date: Sun, 7 May 2000 14:36:15 -0300

asun2.1.1 is old, IIRC 2.1.3-x is the current release, with pre2.1.4 almost
done?
And it sounds like you're missing the service lines in /etc/services.

What info do you get in /usr/adm/messages when you try to login as a valid
user/pass?
What's your *nix distribution/revision?

D.

----- Original Message -----
From: "GoRN ToTheRescue" <[email-masked]>
To: <[email-masked]>
Sent: Sunday, May 07, 2000 1:59 PM
Subject: Re: Can't Log in as use, Shadow supported

> and this is running from a precompiled
http://www.thehamptons.com/anders/netatalk/impatient.html

---

From: Patrik Schindler <[email-masked]>
Date: Sun, 7 May 2000 20:19:21 +0200

>May  7 01:05:11 Nixel atalkd[3574]: zip: service unknown

You will have to add appropriate entries to /etc/services as stated in the services.atalk file of the source distribution.

>May  7 01:05:42 Nixel atalkd[3574]: ready 0/0/0

Okay, atalkd is up and running here.

>May  7 01:42:49 Nixel afpd[3589]: logout

All reads pretty normal.

>i was going to compile it but the bytesex.h couldn't be found.  This is ver 1.4B2.

Bad thing. Did you try a newer asun version to compile?

:wq! PoC

---

From: "Alexander Fordyce" <[email-masked]>
Date: Sun, 7 May 2000 17:00:46 -0700

Hi all.

Looks like traffic in this group has increased dramatically since I last
asked my question, so I'll ask it again now.  I finally got 2.1.4 to compile
and build after days of misery with the released versions, and it's almost
working, but I'm still having what looks like a very common problem... I
can't log in as a registered user.  I've already tried all the solutions in
all the faqs I've found.

Redhat Linux 6.1 with all available updates installed, shadow passwords
Mac OS 9.0.4
Netatalk-1.4b2+asun2.1.4, using the default settings in the makefile... it's
set up to use OpenSSL, which is cool (I think) because I'm already using it
for other stuff.  Makefile says CRYPTODIR overrides DESDIR.

Relevant lines from Makefile:
CRYPTODIR=/usr/local/ssl
#DESDIR=/usr/local
TCPWRAPDIR=/usr
#PAMDIR=/usr

and from sys/linux/Makefile:
DEFS=$$OSDEFS $$MACHINEDEFS $$QUOTADEF -DSHADOWPW

Here's what /var/log/messages says when I try to login as registered user
"www" (I do have a .passwd file in /home/www with the clear text password;
the appletalk login box says "Encrypted Password Transport"; can't login
(says password is incorrect)):

May  7 16:14:23 warlock afpd[13579]: ASIP session:548(1) from
208.37.xxx.xxx:49198(2)
May  7 16:14:23 warlock afpd[4785]: server_child[1] 13579 done
May  7 16:14:42 warlock afpd[13580]: ASIP session:548(1) from
208.37.xxx.xxx:49199(2)
May  7 16:14:42 warlock afpd[13580]: dhx login: www
May  7 16:14:42 warlock afpd[13580]: 0.17KB read, 0.13KB written
May  7 16:14:42 warlock afpd[4785]: server_child[1] 13580 done

And when I login as guest (works fine - I opened a small file (read-only)
and logged out):

May  7 16:14:54 warlock afpd[13582]: ASIP session:548(1) from
208.37.xxx.xxx:49201(2)
May  7 16:14:54 warlock afpd[13582]: login noauth
May  7 16:14:54 warlock afpd[13582]: login nobody (uid 99, gid 99)
May  7 16:15:34 warlock afpd[13582]: logout nobody
May  7 16:15:34 warlock afpd[13582]: 6.58KB read, 19.11KB written
May  7 16:15:34 warlock afpd[4785]: server_child[1] 13582 done

Thanks in advance for any help.
Cheers,
Alex

---

From: Steven Karel <[email-masked]>
Date: Sun, 7 May 2000 20:27:51 -0400 (EDT)

> May  7 16:14:42 warlock afpd[4785]: server_child[1] 13580 done

Alex,

Note above the log says you're using DHX to log in - you AREN'T using the
older style Apple encryption method. With this method, you don't need the
.password file; you get encrypted login using the password from
/etc/passwd. 

As I understand it, the appleshare client in MacOS 9.0.4 (3.8.5? 3.8.6?)
uses Diffie-Hellman (DHX) by default if it's available.

steven

Steven Karel, Ph.D.
Biology Department, Brandeis Univ, MS 008
415 South St Waltham MA 02454-9110
TEL 781 736 3104   FAX 781 736 3107

---

From: andrew morgan <[email-masked]>
Date: Sun, 7 May 2000 17:36:53 -0700 (PDT)

> Relevant lines from Makefile:

Why are you compiling with PAM support if you are using Redhat 6.1?
Redhat likes to default to md5 password hashes instead of standard crypt.
Netatalk has no way to detect which you are using, so it defaults to
crypt.

> May  7 16:14:42 warlock afpd[4785]: server_child[1] 13580 done

You are logging in with DHX encrypted passwords, which is good, but it
does not use the .passwd file.  So setting up the .passwd file isn't doing
any good.  Recompile with PAM support enabled...

	Andy

---

From: Cliff Crawford <[email-masked]>
Date: Sun, 7 May 2000 21:00:16 -0400

> for other stuff.  Makefile says CRYPTODIR overrides DESDIR.

Make sure you're using version 0.9.4 of OpenSSL.  0.9.5 doesn't seem to
work with netatalk.  (though you probably wouldn't have been able to get
it to compile if you had 0.9.5)

> Relevant lines from Makefile:

If you're using RedHat, you probably have PAM on your system too, right?
If so you want to enable PAM support.

-- 
cliff crawford    -><-    http://www.people.cornell.edu/pages/cjc26/
"One man's nirvana is another man's map."              icq 68165166

---

From: "Alexander Fordyce" <[email-masked]>
Date: Sun, 7 May 2000 18:27:23 -0700

yup, 0.9.4.

OK, I'll try recompiling with PAM.  One question... which directories do I
need to point it at?  I'm using the pam-0.68-10 rpm which comes with RedHat.
When I "rpm -ql pam", it shows libpam_misc.a in /lib, a whole bunch of .so
files in /lib/security, and all the .h files in /usr/lib/security.  I'm not
quite sure what it's looking for.

Thanks much,
Alex

> -----Original Message-----
> From: Cliff Crawford [mailto:[email-masked]]
> Sent: Sunday, May 07, 2000 6:00 PM
> To: Alexander Fordyce
> Cc: [email-masked]
> Subject: Re: another poor soul who can't login as registered user
>
>

---

From: "Alexander Fordyce" <[email-masked]>
Date: Sun, 7 May 2000 18:51:50 -0700

I'm not (PAMDIR is commented out).  Did you mean "why are you not"?
thanks,
alex

> From: andrew morgan [mailto:[email-masked]]
> Sent: Sunday, May 07, 2000 5:37 PM

> > "www" (I do have a .passwd file in /home/www with the clear 
> > text password; the appletalk login box says "Encrypted Password 
> > Transport"; can't login (says password is incorrect)):
> >

---

From: andrew morgan <[email-masked]>
Date: Sun, 7 May 2000 19:14:02 -0700 (PDT)

It will compile correctly on RedHat with the default already in the
Makefile.

	Andy