Subject: Re2: performance once again...

From: Dave Ritter <[email-masked]>
Date: Mon, 16 Oct 2000 14:03:35 -0500

the network card you are using should be fine, I use 3Com cards if I really
need speed. (stay away from intel cards, they don't work very well with
appletalk)

on a server I set up last summer, much like yours, I was having some speed
problems so I put a cheap scsi card in the PC and put in a junk 2gig scsi
hard drive. The speed difference to and from the server was very noticeable.
this was in a newspaper workflow.

in my experience, a switch is almost always better if you are looking for
speed...

have you tested the through put from the macs with any software?

I use "LanTest-2.5.2" it's free...  :)

I can email it to you if you like

Dave

> From: David Fickes <[email-masked]>
> Reply-To: David Fickes <[email-masked]>
> Date: Mon, 16 Oct 2000 11:41:03 -0700
> To: "Dave Ritter" <[email-masked]>
> Subject: Re: performance once again...
> 
> The cards in the PC are Netgear PCI 10/100 and the hub is an 8 port
> Netgear 10/100. I don't know if it matters but there is ONE 10 Mbs
> connection on the hub but it is an older Unix system that isn't
> relevant to the file sharing.
> 
> -d
> 
> 
> 
>> what type of network are you using (cards, speed, hubs or switches)?
>> 
>>> From: andrew morgan <[email-masked]>
>>> Reply-To: andrew morgan <[email-masked]>
>>> Date: Mon, 16 Oct 2000 02:14:31 -0700
>>> To: David Fickes <[email-masked]>
>>> Cc: [email-masked]
>>> Bcc: "Dave Ritter" <[email-masked]>
>>> Subject: Re: performance once again...
>>> 
>>> 
>>> 
>>> On Sun, 15 Oct 2000, David Fickes wrote:
>>> 
>>>> I've seen a few messages regarding this but none seems to answer
>>>> my couple of questions definitively. I'm interested in gauging
>>>> netatalk performance in the following environment.
>>>> 
>>>> I'm running netatalk-asun on a FreeBSD 4.0 system. The clients
>>>> are a mix of MacOS9 (iMac 350s) and a G4/450.
>>>> 
>>>> The software where we need the performance is MYOB which shares
>>>> the datafile and does lookups when requestings lists of data
>>>> such as customers and such.
>>>> 
>>>> MYOB has two options for network access: TCP/IP and Appletalk
>>>> 
>>>> The server is currently an AMD K62 / 350 with minimal RAM at this
>>>> time. The drive is a new ATA66.
>>>> 
>>>> Client access on the netatalk server seems to be better than from the
>>>> iMac but not by much of course having the datafile on your local machine
>>>> is MUCH better.
>>>> 
>>>> I'm wondering where the bottlenecks are in the system.
>>>> Options are:
>>>> 
>>>> RAM (currently 64 MB)
>>>> Faster disk drive (I have a spare U2W drive and card)
>>>> Faster CPU?
>>>> 
>>>> I'm interested in any suggestions.
>>> 
>>> On your server, try running top, vmstat, or iostat to see what is
>>> happening.  In top, look at the information at the top of the screen to
>>> see if you are spending most of your time in 'iowait' or 'kernel' or
>>> 'system' (whichever is appropriate for your top).
>>> 
>>> Also look at your free memory and swap used readings.  If your swap used
>>> is too high (maybe 50% of your total physical memory -- 32MB), you may
>>> want more memory, and that may also affect the amount of time your system
>>> spends in 'iowait' if it is actively swapping.
>>> 
>>> Rarely is a file server cpu-bound.
>>> 
>>> Probably, you don't have a fast enough disk array.  If you are using a
>>> single disk drive, you probably won't get more than 4-5MB per second out
>>> of it (sustained).  You'll need some form of disk striping (RAID 0 or 5 or
>>> LVM) to really get the most IO performance.
>>> 
>>> I'm not familiar with MYOB, so I don't know what kinds of accesses you
>>> need to support.  Small, random IO?  Large blocks of data?  Does this act
>>> like a database server or a file server?
>>> 
>>> Hope this helps...
>>> 
>>> Andy
>>> 
>>> 
> 
> -- 
> David Fickes                             +1 650 620-9905
> ADVICE Press                             +1 650 620-9906 fax
> 951 Old County Road # 103                [email-masked]
> Belmont, CA 94002                        www.advicepress.com
>

---

From: David Fickes <[email-masked]>
Date: Mon, 16 Oct 2000 13:46:10 -0700

I got LanTest and ran two comparisons. The first is against
the current iMac and the second is against the FreeBSD machine
running netatalk. I think the issue is obvious to anyone
(call it the writes -- everything else is faster which is
why I've been a bit confused by some things running faster and
other slower.
						netatalk
				iMac 350	FreeBSD		units
Create 100 files (20KB)	 	4.20		2.58		[sec]
Open/Close 100 files		1.25		.85		[sec]
Remove 100 files		1.85		.75		[sec]
Write 30000 KB to file		1588.70		33.11		[KB/sec]
Read 30000 KB from file		1823.25		2893.89		[KB/sec]
Lock/Unlock 4000 times		16.28		15.45		[sec]
Read Directory/320 files	.20		.12		[sec]

The FreeBSD numbers for write are not a typo (33.11 KB/sec) any
good ideas?

-d

---

From: andrew morgan <[email-masked]>
Date: Mon, 16 Oct 2000 14:13:58 -0700 (PDT)

> The FreeBSD numbers for write are not a typo (33.11 KB/sec) any

How fast can you FTP a file to the FreeBSD machine?  (ie - is this
netatalk or something wrong with the system/network).

	Andy

---

From: David Fickes <[email-masked]>
Date: Mon, 16 Oct 2000 14:50:24 -0700

ftp runs at 1800 KB/sec writing to the machine. Also the
iMac runs on the same network and was tested from the same
client.

-d

---

From: andrew morgan <[email-masked]>
Date: Mon, 16 Oct 2000 15:14:08 -0700 (PDT)

Okay, that means it is something to do with netatalk.  Are you connecting
over IP or Appletalk?

	Andy

---

From: Nigel Pegram <[email-masked]>
Date: Tue, 17 Oct 2000 09:40:03 +1100

> need speed. (stay away from intel cards, they don't work very well with

Could you expand on this? We have Intel EtherExpress cards on our PC on which
we are running netatalk. Everything "seems" fine.

Also, just converted the latest rpm from sourceforge to a debian package and 
installed it. Works well and seems to solve the alias problem. The only hiccough
is that it currently only allows guest login. Suggestions?

TIA
Nigel

---

From: David Fickes <[email-masked]>
Date: Mon, 16 Oct 2000 15:57:09 -0700

Just to confuse matters more, I ran a few more tests.

RAMdisk - FreeBSD using the /tmp device which maps to the swap.
RAMdisk - iMac350 using a standard Mac ramdisk
Sun SS10 - a SPARC 10 using a 10M/bps link and running Solaris 2.5

>	                                        netatalk        new 
>drive       RAMdisk    SPARC      RAMdisk
>                              iMac 350           FreeBSD 
>FreeBSD        FreeBSD   SS10/150   iMac 350     units  
>Create 100 files (20KB)            4.20            2.58 
>3.10         2.38      9.86        3.33       [sec]
>Open/Close 100 files               1.25             .85 
>.78         2.52      1.18        1.09       [sec]
>Remove 100 files                   1.85             .75 
>.90          .56      5.69        1.12       [sec]
>Write 30000 KB to file          1588.70           33.11 
>44.19      1097.90    694.58     1945.95      [KB/sec]
>Read 30000 KB from file         1823.25         2893.89 
>3130.43      3185.84    821.17     2578.80      [KB/sec]
>Lock/Unlock 4000 times            16.28           15.45 
>13.83        13.85     15.99       15.62       [sec]
>Read Directory/320 files            .20             .12 
>.13          .17       .27         .10       [sec]

It is interesting to note that the iMac RAMdisk does give you a 
better performing machine
but it doesn't beat the FreeBSD server except for the writes! There 
is something
seriously wrong with the disk writes on this FreeBSD machine. The RAMdisk shows
improvement in the writes but not dramatic changes in the other operations.

I will try and get a test of a SCSI drive at some point, I just don't happen
to have a working drive right now.

-d