Subject: Compiling netatalk-1.4.99 - ARRGGHH!!!

From: [email-masked]
Date: Wed, 4 Oct 2000 11:58:34 +0200

My nth try to compile netatalk-1.4.99... (Solaris 32-bit mode)

What I did this time:

(1) Installed m4, autoconf, automake, libtool, and GNUmake
(2) Merged libtool.m4 and aclocal.m4
(3) Ran ./autogen.sh
(4) Ran ./configure --prefix=/usr/local/atalk/
(5) Started make (GNUmake!) and got:

...
Making all in adouble
make[3]: Entering directory `/opt/sources/netatalk/netatalk/libatalk/adouble'
/bin/sh ../../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../..     -g
-O2 -I../../include -I../../sys -c ad_open.c
mkdir .libs
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -g -O2 -I../../include -I../../sys -Wp,-MD,.
deps/ad_open.pp -c ad_open.c  -fPIC -DPIC -o .libs/ad_open.lo
In file included from ad_open.c:42:
../../include/atalk/adouble.h:35: sys/cdefs.h: No such file or directory
ad_open.c:89: warning: `ADEDOFF_FILEI' redefined
../../include/atalk/adouble.h:136: warning: this is the location of the previous
 definition
make[3]: *** [ad_open.lo] Error 1
make[3]: Leaving directory `/opt/sources/netatalk/netatalk/libatalk/adouble'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/opt/sources/netatalk/netatalk/libatalk'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/opt/sources/netatalk/netatalk'
make: *** [all-recursive-am] Error 2

Seems that the PATH to  cdefs.h is unknown. But how come that people compiling
the same distribution on LINUX-systems do not have this problem???

_______________________________________________
Dr. Wulf Dirk Leuschner
Epidauros Biotechnologie AG
Am Neuland 1
D-82347 Bernried
Tel.:    ++49-(0)8158-99 85 53
FAX:    ++49-(0)8158-99 85 48
e-mail:   [email-masked]

---

From: Hauke Fath <[email-masked]>
Date: Wed, 04 Oct 2000 14:08:59 +0200

>the same distribution on LINUX-systems do not have this problem???

It would seem that some OSes are more equal than others...

Given that asun2.1.4p38 has built just fine for me on Solaris 7 a few days 
ago, I sometimes wonder if the gain of auto{conf,make} & friends is really 
worth the additional complexity of yet another config layer.

May I kindly ask those who have advocated the transition to ship a short 
intro document about the auto-configure framework with Netatalk-current?

It should list the tools we have to have available, pointers to background 
information (homepages, online info pages, man pages if existant), and any 
Netatalk specific details relevant to those unhappy souls who, while trying 
to set up Netatalk on a Lesser Platform ;) find themselves in a maze of 
little configure scripts, all alike.

         hauke

--
Hauke Fath                        Tangro Software Components GmbH
                                         D-69115 Heidelberg
[email-masked]                       Ruf +49-6221-13336-0, Fax -21

---

From: jeff b <[email-masked]>
Date: Wed, 04 Oct 2000 10:24:49 -0400

> (5) Started make (GNUmake!) and got:

-- SNIP --

> ../../include/atalk/adouble.h:136: warning: this is the location of the previous

-- SNIP --

> Seems that the PATH to  cdefs.h is unknown. But how come that people
> compiling the same distribution on LINUX-systems do not have this
> problem???

Seems as though netatalk provides a wrapper for non-sys/cdefs.h systems
in sys/generic/sys/cdefs.h . I just modified the configure script to use
that if sys/cdefs.h isn't found.

The ADEDOFF_FILEI thing was a hack to keep code that worked with
netatalk 1.3 working with the new code. For the sake of cleanliness, I
put an ifdef in, so that warning shouldn't be popping up anymore.

jeff

(once again, I apologize for the cross-post)