Subject: NetBSD dies when connecting

From: T&B <[email-masked]>
Date: Thu, 20 Jul 2000 02:45:11 +1000

Hi all,

I've been trying to setup netatalk on my NetBSD 1.4.2 system on a Mac IIcx test machine.

My questions are:
1. Is there a binary package of netatalk asun available for NetBSD on 68k?
2. Do I need PAM for the compile and where can I get it?
3. Why won't my compiled atalkd work?
4. How can I stop afpd dying after the first launch and client connection?

Here is the sordid tale:

I managed to install from a package:
ftp ftp://ftp.netbsd.org//pub/NetBSD/packages/1.4.2/mac68k/net/netatalk-19990130.tgz
pkg_add netatalk-19990130.tgz
vi /usr/pkg/etc/AppleVolumes.system  #created to contain a test path: /home/tom
vi /usr/pkg/etc/AppleVolumes.default #created to contain just a comment
/usr/pkg/sbin/atalkd
/usr/pkg/sbin/afpd

which worked fine, allowing AFP connections over AppleTalk.

But I want TCP/IP support, so needed the asun version. I couldn't find a binary package, so I had to get the source:

ftp ftp://ftp.cobaltnet.com//pub/users/asun/release/netatalk-1.4b2+asun2.1.3.tar.gz
tar -xzfp netatalk-1.4b2+asun2.1.3.tar.gz
cd netatalk-1.4b2+asun2.1.3
make

I got an error:
auth.h:12: security/pam_appl.h: No such file or directory

I checked:
http://www.redhat.com/support/manuals/RHL-6.0-Manual/install-guide/manual/doc089.html

but couldn't find a download. So I edited the MakeFile and commented out PAM:
#PAMDIR=/usr

Then I did:
make                       #again, without error this time
make install

cp /usr/local/atalk/etc/rc.atalk /etc

vi /etc/rc.local
# in vi I added:
. /etc/rc.atalk            #start appletalk and afp (AppleShare)

vi /etc/rc.atalk
# in vi I commented out then pap startup (I don't need a print server)

After rebooting, I tried to connect from an AppleShare client via AppleTalk and TCP/IP. Both failed. The message log shows:

Jul 19 14:12:53 macbsd afpd[197]: dsi_tcp_open: sigaction: Invalid argument
Jul 19 14:12:53 macbsd afpd[180]: server_child[1] 197 exited 1

Closer examination of the boot log revealed:

atalkdnbp_rgstr: Connection timed out
Can't register macbsd:Workstation@*
nbp_rgstr: Connection timed out
Can't register macbsd:netatalk@*

The compiled netatalk package (without ASUN's IP support) that I installed before in /usr/pkg/bin/ worked okay (ie booted without error and allowed AppleShare (via AppleTalk) client connections. But this new netatalk ASUN install, that I compiled from source and installed in /usr/local/atalk/ seems problematic.

I think I've isolated the problem to just the atalkd binary. This one seems okay:
/usr/pkg/sbin/atalkd
but this one causes time outs in nbprgstr and afpd:
/usr/local/atalk/etc/atalkd

I rebooted and manually executed:
/usr/pkg/sbin/atalkd
/usr/local/atalk/etc/afpd

After reboot this time, the boot log was okay, but I could not connect. The message log had:

  afpd[193]: dsi_tcp_open: sigaction: Invalid argument
  afpd[175]: server_child[1] 193 exited 1

After a few seconds it killed afpd so I manually started it again with:

/usr/local/atalk/etc/afpd

and then I could connect okay from an AppleShare client via AppleTalk or TCP/IP.

So, in my current system, afpd seems to need launching twice.

So my immediate problem and needs may be solved: I can connect via AppleShare IP to MacBSD. But having to install the package and compile another copy from binary, hybridizing the result, and then launch afpd twice is somewhat inefficient.

What is the best way to resolve this? Has anyone else compiled and installed netatalk + asun and made it work directly on NetBSD Mac 68k? How? Could or have you produced a package?

Any help appreciated.

Thanks,
Tom
T&B

---

From: Hauke Fath <[email-masked]>
Date: Wed, 19 Jul 2000 19:24:04 +0200

At 2:45 Uhr +1000 20.07.2000, T&B wrote:

>What is the best way to resolve this? Has anyone else compiled and 
>installed netatalk + asun and made it work directly on NetBSD Mac 
>68k? How? Could or have you produced a package?

What you ran into is a known problem in the NetBSD 1.4.2 kernel atalk 
code. It was not present in 1.4.1 and will be fixed in 1.4.3 of which 
an alpha binary snapshot is available below 
<ftp://ftp.netbsd.org/pub/NetBSD/arch/mac68k/snapshots/> .

So, you can either roll back to 1.4.1 (works for me on a IIci), roll 
forward to 1.4.3 (at least the kernel) or, if you are feeling 
adventurous, install a 1.5_ALPHA snapshot.

	hauke

-- 
Hauke Fath                        Tangro Software Components GmbH
                                         D-69115 Heidelberg
[email-masked]                       Ruf +49-6221-13336-35, Fax -21