Subject: Re: Netatalk up but invisible to Macs

From: "Matthew Reilly"<[email-masked]>
Date: Fri, 2 Jun 2000 11:45:03 +400

Thanks Jason, 

Yes, I can ping the Macs from the server but I cannot access the 
Appletalk volume via the IP address from the Macs. I don't have 
Appletalk IP enabled on the server (no afpd.conf). 

I just can't understand why it worked before but now won't work 
with the new NIC.

Matthew

>Hi Matthew!
>
>Can you see the server if you use the IP address? Can you ping 
each of the
>Macs from the server?
>
>Cheers,
>Jason.
>
>> From: Matthew Reilly <[email-masked]>
>> Date: Fri, 02 Jun 2000 09:01:06 -0400
>> To: Netatalk <[email-masked]>
>> Subject: Netatalk up but invisible to Macs
>> Resent-From: [email-masked]
>> Resent-Date: Fri, 2 Jun 2000 09:14:13 -0400 (EDT)
>> 
>> I'm having a problem with my Netatalk setup after switching 
ethernet cards.
>> I'm running netatalk-19990130 NetBSD/macppc on a Supermac 
C500. I previously
>> had two Dayna (DEC based cards) and I just switched one to a 
SMC card. The
>> setup was running fine before I made the switch. The Dayna 
card I pulled
>> handled the Netatalk interface on my internal network. I 
changed the
>> atalkd.conf to reflect the new interface name.
>> 
>> When I boot the Netatalk daemons start up with no messages 
and there are no
>> messages in the syslog. If I do a nbplkup I get:
>> 
>> mojo:AFPServer   65280.20:128
>> mojo:netatalk   65280.20:4
>> mojo:Workstation   65280.20:4
>> AXIS37CB89_CFG:LaserWriter   65384.224:129
>> Stylus_740:EPSONLQ2   65384.224:128
>> 
>> The bottom two entries are for my Axis print server on my 
Stylus 740. The
>> strange thing is that my Mac doesn't show up here and the 
Netatalk server
>> doesn't show up in the Mac's chooser. I've tried rebooting 
after removing
>> the adress and network info in atalkd.conf (leaving only the 
interface name)
>> but it doesn't make any difference.
>> 
>> Any ideas?
>> 
>> Cheers, 
>> 
>> Matthew Reill

---

From: "Lancaster, David Matthew" <[email-masked]>
Date: Fri, 2 Jun 2000 13:01:38 -0300 (ADT)

I recall reading something somewhere (hate to contribute to
vague-assumptions, but it might be relevant) that netatalk makes
"agressive" use of multicasting in register nbp names, and for
the Appletalk protocol. I recall having an SMC card that wouldn't see my
Laserwriter II (no other Macs on the network), so I swapped in a 3Com and
it worked. I can only presume that SMC cards have poor/non-functional
multicasting, that somehow breaks or hobbles netatalk.

David Lancaster                       (506) 454-2167
  690 Gregg Ct.                       Upper Apartment
  Fredericton, NB  Canada             E3B 4H5
  [email-masked]       "Don't anthropomorphize computers, they hate that."

---

From: andrew morgan <[email-masked]>
Date: Fri, 2 Jun 2000 09:14:39 -0700 (PDT)

> I just can't understand why it worked before but now won't work 

I don't know if there are similar problems on the Powermac platform, but
there are some network cards which don't work well with appletalk.  The
network card needs to have multicast support.  Sometimes you can make it
work by putting the network card into promiscuous mode.  Just a thought...

	Andy