Subject: Re: Permissions question (No Netatalk content)

From: Steve Freitas <[email-masked]>
Date: Fri, 4 Aug 2000 20:56:15 -0700

Thanks for your help, y'all. I had trouble with the spaces, but I used:

find ./ type -d -printf "\"%p\" " | xargs chmod 755

And it worked. Thanks for your help! Now back to Netatalk... :-)

Steve

---

From: Robert Bell <[email-masked]>
Date: Mon, 07 Aug 2000 09:40:37 -0700

Remember, with Netatalk, you usually want the directory perms
to have set-group-id.
Therefore, instead of 755, you would use 2755.

Also, with Linux, I use the following to handle spaces

find . -type d -print0 | xargs -0 chmod 2755

note that it is a zero in the -print0 and -0

  Robert.