Subject: Re: starting appletalk daemons: ge0: Protocol not supported.

From: Mitch McNeel <[email-masked]>
Date: Thu, 04 May 2000 14:23:44 -0700

Thanks for the reply,

        How important is the atalkd daemon??  Do both atalkd
and afpd need to be running for netatalk to work properly??
>From what I've been reading in the afpd.conf file, it looks
to me that I can setup a server to only accept TCP/IP
connections...  Do you know if this would be a true
statement???

        My mac's are still able to connect to  the server
via chooser-> Server IP Address (or server alias).  But
server doesn't show up in the chooser via->appletalk.  Also,
I've noticed that atalkd daemon doesn't spawn off children,
but the afpd daemon does....

        Any comments or suggestions are welcome...

Thanks again.

"thomas.riewe" wrote:

> >
> > starting appletalk daemons: ge0: Protocol not supported
> > Can't configure multicast.
> > can't establish STREAMS plumbing, exiting.
> >  atalkd nbprgstr afpd.
> sorry if the hint seems stupid,
> but thus messages would arise
> while not being able to use ddp/ethertalk/appletalk
>
> hth,
> thomas (R)

--
                     |||||
                   ((~) (~))
                    ( (_) )
                     { ~ }
                       V
-----------------oOO0-----0OOo-----------------------
Mitch McNeel                # Phone Ext. 6236
Unix Systems Administrator  # Phone Num. 619-552-6210
Maintenance Warehouse, Inc. # http://www.mwh.com
-----------------------------------------------------

---

From: Dejan Muhamedagic <[email-masked]>
Date: Fri, 5 May 2000 03:24:33 +0200

Hello,

You don't need atalkd if you want to use only AS over IP and your users
don't complain about not seeing stuff in the chooser.  However, if you
want printing through PAP, then you have to run atalkd.  I think that
there's an LPR implementation on Mac, but not sure for which Macos
release and how does it perform.

Hope that this helps (a bit).

Dejan

---

From: rek2 <[email-masked]>
Date: Thu, 4 May 2000 21:47:30 -0400

HEllo all, I had a lot of help, but i'm moving and I don't whant to create
email bounce in the server you gays have this...
can i know the command to unsuscribe? usualli is name-unsuscribe but i tryied

see you all
Christian

---

From: Patrik Schindler <[email-masked]>
Date: Fri, 5 May 2000 08:15:30 +0200

At 14:23 Uhr -0700 04.05.2000, Mitch McNeel wrote:

>        How important is the atalkd daemon??

Without atalkd you've no AppleTalk protocol.
Services which require AppleTalk won't work without it.
Afpd (in the asun versions) support afp over ip Connections in which case you don't need atalkd (you will get an error message at startup, however).

>but the afpd daemon does....

Without atalkd, selecting the server from a listof available ones in the chooser doesn't work.

Atalkd is a protocol daemon which sits on the network interfaces to do its Job. It doesn't need to fork.
Afpd forks for easier coding and handling of permissions.

:wq! PoC

---

From: Patrik Schindler <[email-masked]>
Date: Fri, 5 May 2000 08:22:56 +0200

At 3:24 Uhr +0200 05.05.2000, Dejan Muhamedagic wrote:

>I think that

It's not very stable. But with LaserWriter > 8.5.1 and OpenTransport one can print directly to an LPR queue.

:wq! PoC

---

From: Mitch McNeel <[email-masked]>
Date: Fri, 05 May 2000 10:46:35 -0700

Thanks to all that replied.

        But the real question is??  How do I get atalkd running if I need to have AppleTalk on my Network??  I
still get this error when trying to start atalkd:  ge0: Protocol not supported.

        I'm trying to start atalkd version Netatalk-1.4b2+asun2.1.4-38b on a Solaris 2.6 (with latest patches)
UE-3500 Sun Machine.  I've added entries to my service file, have a atalkd.conf file in the {NETATALK_DIR}/etc
directory and made sure that the interface (gig-E, ge0) is up...
ONE SIDE NOTE: I'm also running Veritas First Watch Cluster on this machine, but not sharing binaries (HA
Pair).  Start up script is the very last thing in the boot stream, also tried to start manually.  No
success!!!.

        I'm currently running the same version on a Solaris 2.6 (with latest patches) UE-450 with no problems
running over gigabit ethernet interface (Not a HA pair, no Veritas Cluster).

Any Help would be appreciated...

Thanks again...

---

From: Patrik Schindler <[email-masked]>
Date: Fri, 5 May 2000 20:10:23 +0200

>still get this error when trying to start atalkd:  ge0: Protocol not supported.

It nothing I can aid you, sorry. I have no expirience in netatalk on solaris (altough I tried to compile this but it fails because I have no compatibility thingies installed on my Sparc 2 - no /usr/ucb*).

:wq! PoC

---

From: Dejan Muhamedagic <[email-masked]>
Date: Fri, 5 May 2000 21:31:50 +0200

Hello,

>         I'm trying to start atalkd version Netatalk-1.4b2+asun2.1.4-38b on a Solaris 2.6 (with latest patches)

Not so familiar with Solaris, but in general, you should have support
for DDP protocol in your kernel.  Did you check this?

Dejan