Subject: Setting up Linux as a print server

From: Lorenzo Thurman <[email-masked]>
Date: Tue, 20 Jun 2000 22:48:06 -0500

I have been trying to setup my Linux box (2.2.16) as a print server. I have
gotten to the point where  I can print using, pap -P filename.eps, but it
fails when using lpr -P. There are no errors in my log file and no spool
documents are created in the spool folder, and I get an error message on the
console:"Cannot access LW 630". I have gone through the How-To, found a
couple of archived messages at linuxppc and netatalk but nothing has helped,
so I'm turning to the list. My printcap file is:
lp|venerable LaserWriter|"LW 630":\
       :sd=/usr/spool/LW 630:\
       :lp=/dev/null:\
       :pl#63:pw#85:\
       :mx#0:\
       :sh:sf:\
       :lf=/var/log/lpd-errs:\
       :pd=/usr/spool/LW630.ppd:   #Unix file format
       :if=/usr/spool/LW 630/ifpap:

My papd.conf, looks like this:
LW 630:\
       :pr=lp:op=lorenzo:\
       :pd=/var/spool/LW630.ppd:
I have created a .paprc file and placed it in the LW 630 spool directory
with the contents:
LW 630:LaserWriter@*

Note: I do not need to print from linux, only Mac and Windows clients. If
anyone has any ideas, I would really appreciate it.
TIA

---

From: andrew morgan <[email-masked]>
Date: Tue, 20 Jun 2000 23:05:58 -0700 (PDT)

> anyone has any ideas, I would really appreciate it.

Anything in /var/log/messages (syslog stuff)?  Does the print job
disappear, or is it stuck in the queue?

	Andy