Subject: Re: AppleVolumes.system need to be updated?

From: Steve Freitas <[email-masked]>
Date: Wed, 2 Aug 2000 15:53:46 -0700

>on this same topic, how does one update this file?  I have a vague
>memory of reading a msg a long time ago where a method of dumping this
>information off a mac was detailed.  Can that happen?

I don't know, good question. Anybody know the answer to this?

Steve

---

From: Cliff Crawford <[email-masked]>
Date: Wed, 2 Aug 2000 21:34:42 -0400

There was a perl script posted to the list which could read the info
from Internet Preferences.  I've included it below.

> I don't know, good question. Anybody know the answer to this?

-----
#!perl
#
# ICDumpMap
#     ---  Dump suffix mappings from your Internet Config extension.
#
# iNOUE Koich! <[email-masked]>
#

use Mac::InternetConfig;

open MAP, ">AppleVolumes";
printf MAP "%-9s \"%4s\"  \"%4s\"      %-30s %-25s %-15s\n\n",
".", "TEXT", "ttxt", "ASCII Text", "SimpleText", "text/plain";
print MAP "\# The following lines are extracted from Internet Config
Preference.\n\n";
for my $entry (keys %InternetConfigMap) {
    next unless $entry->extension =~ /^\./;
    $_ = sprintf "%-9s \"%4s\"  \"%4s\"      %-30s %-25s %-15s",
        $entry->extension, $entry->file_type, $entry->file_creator,
        $entry->entry_name, $entry->creator_app_name,
        $entry->MIME_type;
    s/\s*$/\n/;
    print MAP;
}
close MAP;

-- 
cliff crawford    -><-    http://www.people.cornell.edu/pages/cjc26/
                         "But why is it TILED?!?"      icq 68165166