Subject: Trouble Starting Netatalk - Invalid Arguments to 'socket'??

From: Basil Hussain <[email-masked]>
Date: Tue, 21 Nov 2000 12:13:13 +0000

Hi all,

I've just tried installing the latest (8th Nov) RPM of Netatalk from
Sourceforge on a stock RedHat 6.2 machine. I'm having a bit of trouble
getting Netatalk to start. Upon starting, I get these errors:

# /etc/rc.d/init.d/atalk start
Starting AppleTalk services: socket: Invalid argument
socket: Invalid argument
atalkd: can't get interfaces, exiting.
                                                           [  OK  ]

And I also get this in the system log:

Nov 21 11:52:07 vic20 atalkd: socket: Invalid argument
Nov 21 11:52:07 vic20 atalkd: socket: Invalid argument
Nov 21 11:52:07 vic20 atalkd: atalkd: can't get interfaces, exiting.
Nov 21 11:52:07 vic20 atalk: atalkd startup failed
Nov 21 11:52:07 vic20 atalk: timelord startup succeeded
Nov 21 11:52:07 vic20 timelord[617]: main: atp_open: Invalid argument

Why wouldn't atalkd be able to get a socket? What is providing invalid
arguments, whatever it may be?

I can't think what it could be that's stopping it working - I installed the
same RPM onto a virtually identical machine (they only differ in the model
of Intel network card) with RH 6.2 only the other day, which works
absolutely fine.

I'm thinking it might possibly be something to do with my config, but I have
nothing strange there. In my netatalk.conf file I have these directives:

AFPD_MAX_CLIENTS=20
ATALK_NAME=`echo ${HOSTNAME}`
AFPD_GUEST=nobody
ATALKD_RUN=yes
PAPD_RUN=no
AFPD_RUN=yes
ATALK_BGROUND=no

In my afpd.conf file I have:

- -transall -uamlist uams_dhx.so -nosavepassword

And I have a couple of entries in the AppleVolumes.default file:

~
/home/httpd/html "Discussions Web Root" casefold:tolower

Can anyone assist here?

Regards,

------------------------------------------------
Basil Hussain ([email-masked])

---

From: "Daniel E. Lautenschleger" <[email-masked]>
Date: Tue, 21 Nov 2000 07:17:46 -0600 (CST)

Sounds like you need to add the infamous "alias net-pf-5 appletalk" line
to your /etc/conf.modules file :-)

-Dan

-- 

Daniel E. Lautenschleger
University of Wisconsin
R.M. Bock Laboratories
Network Administrator and Computer Support
[email-masked]
http://resumes.dice.com/pooba53

---

From: Dick Visser <[email-masked]>
Date: Tue, 21 Nov 2000 14:17:52 +0100 (CET)

> atalkd: can't get interfaces, exiting.

Before you start netatalk, load the appletalk module into the kernel.
insmod /lib/modules/linux-blabla/misc/appletalk.o
then try again

-- 

Dick Visser