Subject: Re: Problem: Appletalk with TCP/IP only

From: "S.Ecker" <[email-masked]>
Date: Mon, 15 May 2000 09:13:28 -0700 (PDT)

Look where you have 127.0.0.1 in your log file.  That
indicates that you have the default redhat loopback ip
in your /etc/hosts file.  Change it from 127.0.0.1 to
your actual network IP address.  That should fix the
problem with not being able to double click on the
server.

-Scott

--- Bill Tihen -- TECHNOLOGY <[email-masked]>
wrote:
> Hello,
> 
> I am using RH6.1 and I have installed: 
> 	netatalk-1.4b2+asun2.1.3-7.i386.rpm
> 
> I see the server in the mac's chooser menu, but
> clicking
> on this says no response from the server.  However,
> if I
> type in the IP address -- that works just fine.  I
> think
> I have seen this issue raised before, but I don't
> remember seeing the answer.
> 
> In anycase, I tried to locate the problem, but I
> don't
> see anything wrong.  Here is what I checked.  Sorry
> about the length, I have included lots of files
> including /etc/services -- I didn't edit them incase
> I
> am over looking something obvious.
> ________________________
> 
> I configured: /etc/atalk/config as (I didn't
> configure
> the other files at all papd.conf and atalk.conf):
> 
> 
> # Appletalk configuration
>    # Change this to increase the maximum number of
> clients that can connect:
>    AFPD_MAX_CLIENTS=50
>    # Change this to set the machine's atalk name:
>    ATALK_NAME=`echo ${HOSTNAME}|cut -d. -f1`
>    # Set which daemons to run:
>    # printer daemon
>    PAPD_RUN=no
>    # apple file system daemon
>    AFPD_RUN=yes
>    # Control whether the daemons are started in the
> background
>    ATALK_BGROUND=yes
> 
> __________________
> 
> To see if netatalk is running I did
> ps -ax, which gives:
> 
>   PID TTY      STAT   TIME COMMAND
>        1 ?        S      0:04 init [3]
>        2 ?        SW     0:00 [kflushd]
>        3 ?        SW     0:00 [kupdate]
>        4 ?        SW     0:00 [kpiod]
>        5 ?        SW     0:02 [kswapd]
>        6 ?        SW<    0:00 [mdrecoveryd]
>      302 ?        S      0:00 portmap
>      355 ?        S      0:00 syslogd -m 0
>      366 ?        S      0:00 klogd
>      382 ?        S      0:00 /usr/sbin/atd
>      398 ?        S      0:00 crond
>      414 ?        S      0:00 inetd
>      461 ?        S      0:00 httpd
>      464 ?        S      0:00 httpd
>      465 ?        S      0:00 httpd
>      466 ?        S      0:00 httpd
>      467 ?        S      0:00 httpd
>      468 ?        S      0:00 httpd
>      469 ?        S      0:00 httpd
>      470 ?        S      0:00 httpd
>      471 ?        S      0:00 httpd
>      472 ?        S      0:00 httpd
>      473 ?        S      0:00 httpd
>      507 ?        S      0:00 atalkd
>      508 ?        S      0:00 smbd -D
>      519 ?        S      0:00 nmbd -D
>      531 ?        S      0:00 /usr/sbin/dhcpd eth0
>      548 tty2     S      0:00 /sbin/mingetty tty2
>      549 tty3     S      0:00 /sbin/mingetty tty3
>      550 tty4     S      0:00 /sbin/mingetty tty4
>      551 tty5     S      0:00 /sbin/mingetty tty5
>      552 tty6     S      0:00 /sbin/mingetty tty6
>      567 ?        S      0:00 afpd -c 50 -n students
>      569 tty1     S      0:00 login -- root    
>      570 tty1     S      0:00 -bash
>      603 tty1     R      0:00 ps -ax
> 
> This seems reasonable.
> ____________________
> 
> So I checked the boot up messages.  Which give:
> 
> May 15 14:43:15 localhost syslogd 1.3-3: restart.
>    May 15 14:43:15 localhost syslog: syslogd startup
> succeeded
>    May 15 14:43:15 localhost syslog: klogd startup
> succeeded
>    May 15 14:43:15 localhost kernel: klogd 1.3-3,
> log
> source = /proc/kmsg started.
>    May 15 14:43:15 localhost kernel: Inspecting
> /boot/System.map-2.2.12-20
>    May 15 14:43:15 localhost kernel: Loaded 6865
> symbols
> from
>    /boot/System.map-2.2.12-20.
>    May 15 14:43:15 localhost kernel: Symbols match
> kernel version 2.2.12.
>    May 15 14:43:15 localhost kernel: No module
> symbols
> loaded.
>    May 15 14:43:15 localhost kernel: 3c59x.c:v0.99H
> 11/17/98 Donald Becker
>   
>
http://cesdis.gsfc.nasa.gov/linux/drivers/vortex.html
> 
>    May 15 14:43:15 localhost kernel: eth0: 3Com
> 3c905B
> Cyclone 100baseTx at 0xb000, 
>    00:50:04:34:de:d6, IRQ 10 
>    May 15 14:43:15 localhost kernel:   8K byte-wide
> RAM
> 5:3 Rx:Tx split,
>    autoselect/Autonegotiate interface. 
>    May 15 14:43:15 localhost kernel:   MII
> transceiver
> found at address 24, status 782d.
> 
>    May 15 14:43:15 localhost kernel:   Enabling
> bus-master transmits and whole-frame
>    receives. 
>    May 15 14:43:15 localhost atd: atd startup
> succeeded
>    May 15 14:43:16 localhost crond: crond startup
> succeeded
>    May 15 14:43:16 localhost inet: inetd startup
> succeeded
>    May 15 14:43:16 localhost dhcpd: Internet
> Software
> Consortium DHCP Server 2.0
>    May 15 14:43:16 localhost dhcpd: Copyright 1995,
> 1996, 1997, 1998, 1999 The Internet
>    Software Consortium.
>    May 15 14:43:16 localhost dhcpd: All rights
> reserved.
>    May 15 14:43:16 localhost dhcpd: 
>    May 15 14:43:16 localhost dhcpd: Please
> contribute if
> you find this software useful.
>    May 15 14:43:16 localhost dhcpd: For info, please
> visit
>    http://www.isc.org/dhcp-contrib.html
>    May 15 14:43:16 localhost dhcpd: 
>    May 15 14:43:16 localhost dhcpd: Internet
> Software
> Consortium DHCP Server 2.0
>    May 15 14:43:16 localhost dhcpd: Copyright 1995,
> 1996, 1997, 1998, 1999 The Internet
>    Software Consortium.
>    May 15 14:43:16 localhost dhcpd: All rights
> reserved.
>    May 15 14:43:16 localhost dhcpd: 
>    May 15 14:43:16 localhost dhcpd: Please
> contribute if
> you find this software useful.
>    May 15 14:43:16 localhost dhcpd: For info, please
> visit
>    http://www.isc.org/dhcp-contrib.html
>    May 15 14:43:16 localhost dhcpd: 
>    May 15 14:43:16 localhost dhcpd: Listening on
> LPF/eth0/00:50:04:34:de:d6/192.168.1.0
>    May 15 14:43:16 localhost dhcpd: Listening on
> LPF/eth0/00:50:04:34:de:d6/192.168.1.0
>    May 15 14:43:16 localhost dhcpd: Sending on  
> LPF/eth0/00:50:04:34:de:d6/192.168.1.0
>    May 15 14:43:16 localhost dhcpd: Sending on  
> Socket/fallback/fallback-net
>    May 15 14:43:17 localhost dhcpd: Sending on  
> LPF/eth0/00:50:04:34:de:d6/192.168.1.0
>    May 15 14:43:17 localhost dhcpd: Sending on  
> Socket/fallback/fallback-net
>    May 15 14:43:17 localhost dhcpd: dhcpd startup
> succeeded
>    May 15 14:43:17 localhost keytable: Loading
> keymap: 
>    May 15 14:43:17 localhost keytable: Loading
>    /usr/lib/kbd/keymaps/i386/qwerty/us.kmap.gz
>    May 15 14:43:17 localhost keytable: Loading
> system
> font: 
>    May 15 14:43:17 localhost rc: Starting keytable
> succeeded
>    May 15 14:43:18 localhost httpd: httpd startup
> succeeded
>    May 15 14:43:18 localhost kernel: NET4: AppleTalk
> 0.18 for Linux NET4.0 
>    May 15 14:43:18 localhost atalkd[507]: restart
> (1.4b2+asun2.1.3)
>    May 15 14:43:19 localhost smb: smbd startup
> succeeded
>    May 15 14:43:19 localhost smb: nmbd startup
> succeeded
>    May 15 14:43:19 localhost linuxconf-setup:
> Linuxconf
> final setup
>    May 15 14:43:19 localhost atalkd[507]:
> zip_getnetinfo
> for eth0
>    May 15 14:43:20 localhost dhcpd: Internet
> Software
> Consortium DHCP Server 2.0
>    May 15 14:43:20 localhost dhcpd: Copyright 1995,
> 1996, 1997, 1998, 1999 The Internet
>    Software Consortium.
>    May 15 14:43:20 localhost dhcpd: All rights
> reserved.
>    May 15 14:43:20 localhost dhcpd: 
>    May 15 14:43:20 localhost dhcpd: Please
> contribute if
> you find this software useful.
>    May 15 14:43:20 localhost dhcpd: For info, please
> visit
>    http://www.isc.org/dhcp-contrib.html
>    May 15 14:43:20 localhost dhcpd: 
>    May 15 14:43:20 localhost dhcpd: Listening on
> LPF/eth0/00:50:04:34:de:d6/192.168.1.0
>    May 15 14:43:20 localhost dhcpd: Sending on  
> LPF/eth0/00:50:04:34:de:d6/192.168.1.0
>    May 15 14:43:20 localhost dhcpd: Sending on  
> Socket/fallback/fallback-net
>    May 15 14:43:20 localhost linuxconf-setup:    
> Executing: /sbin/route add -net
>    255.255.255.255 netmask 255.255.255.255 dev eth0
>    May 15 14:43:20 localhost linuxconf-setup:    
> Killing /usr/sbin/dhcpd with signal 15
>    return 0
>    May 15 14:43:20 localhost linuxconf-setup:    
> Executing: /usr/sbin/dhcpd eth0 2>&1
>    May 15 14:43:20 localhost linuxconf-setup:       
>  >
> Internet Software Consortium
>    DHCP Server 2.0
>    May 15 14:43:20 localhost linuxconf-setup:       
>  >
> Copyright 1995, 1996, 1997,
>    1998, 1999 The Internet Software Consortium.
>    May 15 14:43:20 localhost linuxconf-setup:       
>  >
> All rights reserved.
>    May 15 14:43:20 localhost linuxconf-setup:       
>  > 
>    May 15 14:43:20 localhost linuxconf-setup:       
>  >
> Please contribute if you find
>    this software useful.
>    May 15 14:43:20 localhost linuxconf-setup:       
>  >
> For info, please visit
>    http://www.isc.org/dhcp-contrib.html
>    May 15 14:43:20 localhost linuxconf-setup:       
>  > 
>    May 15 14:43:20 localhost linuxconf-setup:       
>  >
> Listening on
>    LPF/eth0/00:50:04:34:de:d6/192.168.1.0
>    May 15 14:43:20 localhost linuxconf-setup:       
>  >
> Sending on  
>    LPF/eth0/00:50:04:34:de:d6/192.168.1.0
>    May 15 14:43:20 localhost linuxconf-setup:       
>  >
> Sending on  
>    Socket/fallback/fallback-net
>    May 15 14:43:20 localhost rc: Starting
> linuxconf-setup succeeded
>    May 15 14:43:28 localhost atalkd[507]:
> zip_getnetinfo
> for eth0
>    May 15 14:43:38 localhost atalkd[507]:
> zip_getnetinfo
> for eth0
>    May 15 14:43:48 localhost atalkd[507]: config for
> no
> router
>    May 15 14:43:49 localhost atalkd[507]: ready
> 0/0/0
>    May 15 14:43:49 localhost atalk: atalkd startup
> succeeded
>    May 15 14:44:01 localhost atalk: afpd startup
> succeeded
>    May 15 14:44:02 localhost PAM_pwdb[547]:
> authentication failure; LOGIN(uid=0) -> root
>    for login service
>    May 15 14:44:03 localhost login[547]: FAILED
> LOGIN 1
> FROM (null) FOR root,
>    Authentication failure
>    May 15 14:44:03 localhost login[547]: FAILED
> LOGIN 2
> FROM (null) FOR , User not known
>    to the underlying authentication module
>    May 15 14:44:08 localhost afpd[567]:
> students:AFPServer@* started on 65280.217:128
>    (1.4b2+asun2.1.3)
>    May 15 14:44:08 localhost afpd[567]: ASIP started
> on
> 127.0.0.1:548(1)
>    (1.4b2+asun2.1.3) 
>    May 15 14:47:09 localhost PAM_pwdb[569]: (login)
> session opened for user root by
>    LOGIN(uid=0)
> 
> __________________________
> more /etc/services gives:
> 
> # /etc/services:
>    # $Id: services,v 1.4 1997/05/20 19:41:21 tobias
> Exp
> $
>    #
>    # Network services, Internet style
>    #
>    # Note that it is presently the policy of IANA to
> assign a single well-known
>    # port number for both TCP and UDP; hence, most
> entries here have two entries
>    # even if the protocol doesn't support UDP
> operations.
>    # Updated from RFC 1700, ``Assigned Numbers''
> (October 1994).  Not all ports
>    # are included, only the more common ones.
> 
>    tcpmux          1/tcp                           #
> TCP
> port service multiplexer
>    echo            7/tcp
>    echo            7/udp
>    discard         9/tcp           sink null
>    discard         9/udp           sink null
>    systat          11/tcp          users
>    daytime         13/tcp
>    daytime         13/udp
>    netstat         15/tcp
>    qotd            17/tcp          quote
>    msp             18/tcp                          #
> message send protocol
>    msp             18/udp                          #
> message send protocol
>    chargen         19/tcp          ttytst source
>    chargen         19/udp          ttytst source
>    ftp-data        20/tcp
>    ftp             21/tcp
>    fsp             21/udp          fspd
>    ssh             22/tcp                          #
> SSH
> Remote Login Protocol
>    ssh             22/udp                          #
> SSH
> Remote Login Protocol
>    telnet          23/tcp
>    # 24 - private
>    smtp            25/tcp          mail
>    # 26 - unassigned
>    time            37/tcp          timserver
>    time            37/udp          timserver
>    rlp             39/udp          resource        #
> resource location
>    nameserver      42/tcp          name            #
> IEN
> 116
>    whois           43/tcp          nicname
>    re-mail-ck      50/tcp                          #
> Remote Mail Checking Protocol
>    re-mail-ck      50/udp                          #
> Remote Mail Checking Protocol
>    domain          53/tcp          nameserver      #
> name-domain server
>    domain          53/udp          nameserver
>    mtp             57/tcp                          #
> deprecated
>    bootps          67/tcp                          #
> BOOTP server
>    bootps          67/udp
>    bootpc          68/tcp                          #
> BOOTP client
>    bootpc          68/udp
>    tftp            69/udp
>    gopher          70/tcp                          #
> Internet Gopher
>    gopher          70/udp
>    rje             77/tcp          netrjs
>    finger          79/tcp
>    www             80/tcp          http            #
> WorldWideWeb HTTP
>    www             80/udp                          #
> HyperText Transfer Protocol
>    link            87/tcp          ttylink
>    kerberos        88/tcp          kerberos5 krb5  #
> Kerberos v5
>    kerberos        88/udp          kerberos5 krb5  #
> Kerberos v5
>    supdup          95/tcp
>    # 100 - reserved
>    hostnames       101/tcp         hostname        #
> usually from sri-nic
>    iso-tsap        102/tcp         tsap            #
> part of ISODE.
>    csnet-ns        105/tcp         cso-ns          #
> also used by CSO name server
>    csnet-ns        105/udp         cso-ns
>    # unfortunately the poppassd (Eudora) uses a port
> which has already
>    # been assigned to a different service. We list
> the
> poppassd as an
>    # alias here. This should work for programs
> asking
> for this service.
>    # (due to a bug in inetd the 3com-tsmux line is
> disabled)
>    #3com-tsmux     106/tcp         poppassd
>    #3com-tsmux     106/udp         poppassd
>    rtelnet         107/tcp                         #
> Remote Telnet
>    rtelnet         107/udp
>    pop-2           109/tcp         postoffice      #
> POP
> version 2
>    pop-2           109/udp
>    pop-3           110/tcp                         #
> POP
> version 3
>    pop-3           110/udp
>    sunrpc          111/tcp         portmapper      #
> RPC
> 4.0 portmapper TCP
>    sunrpc          111/udp         portmapper      #
> RPC
> 4.0 portmapper UDP
>    auth            113/tcp         authentication
> tap
> ident
>    sftp            115/tcp
>    uucp-path       117/tcp
>    nntp            119/tcp         readnews untp   #
> USENET News Transfer Protocol
>    ntp             123/tcp
>    ntp             123/udp                         #
> Network Time Protocol
>    netbios-ns      137/tcp                         #
> NETBIOS Name Service
>    netbios-ns      137/udp
>    netbios-dgm     138/tcp                         #
> NETBIOS Datagram Service
>    netbios-dgm     138/udp
>    netbios-ssn     139/tcp                         #
> NETBIOS session service
>    netbios-ssn     139/udp
>    imap2           143/tcp         imap            #
> Interim Mail Access Proto v2
>    imap2           143/udp         imap
>    snmp            161/udp                         #
> Simple Net Mgmt Proto
>    snmp-trap       162/udp         snmptrap        #
> Traps for SNMP
>    cmip-man        163/tcp                         #
> ISO
> mgmt over IP (CMOT)
>    cmip-man        163/udp
>    cmip-agent      164/tcp
>    cmip-agent      164/udp
>    xdmcp           177/tcp                         #
> X
> Display Mgr. Control Proto
>    xdmcp           177/udp
>    nextstep        178/tcp         NeXTStep
> NextStep       # NeXTStep window
>    nextstep        178/udp         NeXTStep
> NextStep       # server
>    bgp             179/tcp                         #
> Border Gateway Proto.
>    bgp             179/udp
>    prospero        191/tcp                         #
> Cliff Neuman's Prospero
>    prospero        191/udp
>    irc             194/tcp                         #
> Internet Relay Chat
>    irc             194/udp
>    smux            199/tcp                         #
> SNMP Unix Multiplexer
>    smux            199/udp
>    at-rtmp         201/tcp                         #
> AppleTalk routing
>    at-rtmp         201/udp
>    at-nbp          202/tcp                         #
> AppleTalk name binding
>    at-nbp          202/udp
>    at-echo         204/tcp                         #
> AppleTalk echo
>    at-echo         204/udp
>    at-zis          206/tcp                         #
> AppleTalk zone information
>    at-zis          206/udp
>    qmtp            209/tcp                         #
> The
> Quick Mail Transfer Protocol
>    qmtp            209/udp                         #
> The
> Quick Mail Transfer Protocol
>    z3950           210/tcp         wais            #
> NISO Z39.50 database
>    z3950           210/udp         wais
>    ipx             213/tcp                         #
> IPX
>    ipx             213/udp
>    imap3           220/tcp                         #
> Interactive Mail Access
>    imap3           220/udp                         #
> Protocol v3
>    rpc2portmap     369/tcp
>    rpc2portmap     369/udp                         #
> Coda portmapper
>    codaauth2       370/tcp
>    codaauth2       370/udp                         #
> Coda authentication server
>    ulistserv       372/tcp                         #
> UNIX Listserv
>    ulistserv       372/udp
>    https           443/tcp                         #
> MCom
>    https           443/udp                         #
> MCom
>    snpp            444/tcp                         #
> Simple Network Paging Protocol
>    snpp            444/udp                         #
> Simple Network Paging Protocol
>    saft            487/tcp                         #
> Simple Asynchronous File Transfer
>    saft            487/udp                         #
> Simple Asynchronous File Transfer
>    npmp-local      610/tcp         dqs313_qmaster  #
> npmp-local / DQS
>    npmp-local      610/udp         dqs313_qmaster  #
> npmp-local / DQS
>    npmp-gui        611/tcp         dqs313_execd    #
> npmp-gui / DQS
>    npmp-gui        611/udp         dqs313_execd    #
> npmp-gui / DQS
>    hmmp-ind        612/tcp         dqs313_intercell#
> HMMP Indication / DQS
>    hmmp-ind        612/udp         dqs313_intercell#
> HMMP Indication / DQS
>    #
>    # UNIX specific services
>    #
>    exec            512/tcp
>    biff            512/udp         comsat
>    login           513/tcp
>    who             513/udp         whod
>    shell           514/tcp         cmd             #
> no
> passwords used
>    syslog          514/udp
>    printer         515/tcp         spooler         #
> line printer spooler
>    talk            517/udp
>    ntalk           518/udp
>    route           520/udp         router routed   #
> RIP
>    timed           525/udp         timeserver
>    tempo           526/tcp         newdate
>    courier         530/tcp         rpc
>    conference      531/tcp         chat
>    netnews         532/tcp         readnews
>    netwall         533/udp                         #
> -for emergency broadcasts
>    uucp            540/tcp         uucpd           #
> uucp daemon
>    afpovertcp      548/tcp                         #
> AFP
> over TCP
>    afpovertcp      548/udp                         #
> AFP
> over TCP
>    remotefs        556/tcp         rfs_server rfs  #
> Brunhoff remote filesystem
>    klogin          543/tcp                         #
> Kerberized `rlogin' (v5)
>    kshell          544/tcp         krcmd           #
> Kerberized `rsh' (v5)
>    kerberos-adm    749/tcp                         #
> Kerberos `kadmin' (v5)
>    #
>    webster         765/tcp                         #
> Network dictionary
>    webster         765/udp
>    #
>    # From ``Assigned Numbers'':
>    #
>    #> The Registered Ports are not controlled by the
> IANA and on most systems
>    #> can be used by ordinary user processes or
> programs
> executed by ordinary
>    #> users.
>    #
>    #> Ports are used in the TCP [45,106] to name the
> ends of logical
>    #> connections which carry long term
> conversations. 
> For the purpose of
>    #> providing services to unknown callers, a
> service
> contact port is
>    #> defined.  This list specifies the port used by
> the
> server process as its
>    #> contact port.  While the IANA can not control
> uses
> of these ports it
>    #> does register or list uses of these ports as a
> convienence to the
>    #> community.
>    #
>    ingreslock      1524/tcp
>    ingreslock      1524/udp
>    prospero-np     1525/tcp                        #
> Prospero non-privileged
>    prospero-np     1525/udp
>    datametrics     1645/tcp        old-radius      #
> datametrics / old radius entry
>    datametrics     1645/udp        old-radius      #
> datametrics / old radius entry
>    sa-msg-port     1646/tcp        old-radacct     #
> sa-msg-port / old radacct entry
>    sa-msg-port     1646/udp        old-radacct     #
> sa-msg-port / old radacct entry
>    radius          1812/tcp                        #
> Radius
>    radius          1812/udp                        #
> Radius
>    radacct         1813/tcp                        #
> Radius Accounting
>    radacct         1813/udp                        #
> Radius Accounting
>    cvspserver      2401/tcp                        #
> CVS
> client/server operations
>    cvspserver      2401/udp                        #
> CVS
> client/server operations
>    venus           2430/tcp                        #
> codacon port
>    venus           2430/udp                        #
> Venus callback/wbc interface
>    venus-se        2431/tcp                        #
> tcp
> side effects
>    venus-se        2431/udp                        #
> udp
> sftp side effect
>    codasrv         2432/tcp                        #
> not
> used
>    codasrv         2432/udp                        #
> server port
>    codasrv-se      2433/tcp                        #
> tcp
> side effects
>    codasrv-se      2433/udp                        #
> udp
> sftp side effect
>    mysql           3306/tcp                        #
> MySQL
>    mysql           3306/udp                        #
> MySQL
>    rfe             5002/tcp                        #
> Radio Free Ethernet
>    rfe             5002/udp                        #
> Actually uses UDP only
>    cfengine        5308/tcp                        #
> CFengine
>    cfengine        5308/udp                        #
> CFengine
>    bbs             7000/tcp                        #
> BBS
> service
>    #
>    #
>    # Kerberos (Project Athena/MIT) services
>    # Note that these are for Kerberos v4, and are
> unofficial.  Sites running
>    # v4 should uncomment these and comment out the
> v5
> entries above.
>    #
>    kerberos4       750/udp         kerberos-iv kdc #
> Kerberos (server) udp
>    kerberos4       750/tcp         kerberos-iv kdc #
> Kerberos (server) tcp
>    kerberos_master 751/udp                         #
> Kerberos authentication
>    kerberos_master 751/tcp                         #
> Kerberos authentication
>    passwd_server   752/udp                         #
> Kerberos passwd server
>    krb_prop        754/tcp                         #
> Kerberos slave propagation
>    krbupdate       760/tcp         kreg            #
> Kerberos registration
>    kpasswd         761/tcp         kpwd            #
> Kerberos "passwd"
>    kpop            1109/tcp                        #
> Pop
> with Kerberos
>    knetd           2053/tcp                        #
> Kerberos de-multiplexor
>    zephyr-srv      2102/udp                        #
> Zephyr server
>    zephyr-clt      2103/udp                        #
> Zephyr serv-hm connection
>    zephyr-hm       2104/udp                        #
> Zephyr hostmanager
>    eklogin         2105/tcp                        #
> Kerberos encrypted rlogin
>    #
>    # Unofficial but necessary (for NetBSD) services
>    #
>    supfilesrv      871/tcp                         #
> SUP
> server
>    supfiledbg      1127/tcp                        #
> SUP
> debugging
>    #
>    # Datagram Delivery Protocol services
>    #
>    rtmp            1/ddp                           #
> Routing Table Maintenance Protocol
>    nbp             2/ddp                           #
> Name Binding Protocol
>    echo            4/ddp                           #
> AppleTalk Echo Protocol
>    zip             6/ddp                           #
> Zone Information Protocol
>    #
>    # Services added for the Debian GNU/Linux
> distribution
>    poppassd        106/tcp                         #
> Eudora
>    poppassd        106/udp                         #
> Eudora
>    mailq           174/tcp                         #
> Mailer transport queue for Zmailer
>    mailq           174/tcp                         #
> Mailer transport queue for Zmailer
>    ssmtp           465/tcp                         #
> SMTP over SSL
>    gdomap          538/tcp                         #
> GNUstep distributed objects
>    gdomap          538/udp                         #
> GNUstep distributed objects
>    snews           563/tcp                         #
> NNTP over SSL
>    ssl-ldap        636/tcp                         #
> LDAP over SSL
>    omirr           808/tcp         omirrd          #
> online mirror
>    omirr           808/udp         omirrd          #
> online mirror
>    rsync           873/tcp                         #
> rsync
>    rsync           873/udp                         #
> rsync
>    simap           993/tcp                         #
> IMAP over SSL
>    spop3           995/tcp                         #
> POP-3 over SSL
>    socks           1080/tcp                        #
> socks proxy server
>    socks           1080/udp                        #
> socks proxy server
>    rmtcfg          1236/tcp                        #
> Gracilis Packeten remote config server
>    xtel            1313/tcp                        #
> french minitel
>    support         1529/tcp                        #
> GNATS
>    cfinger         2003/tcp                        #
> GNU
> Finger
>    ninstall        2150/tcp                        #
> ninstall service
>    ninstall        2150/udp                        #
> ninstall service
>    afbackup        2988/tcp                        #
> Afbackup system
>    afbackup        2988/udp                        #
> Afbackup system
>    icp             3130/tcp                        #
> Internet Cache Protocol (Squid)
>    icp             3130/udp                        #
> Internet Cache Protocol (Squid)
>    postgres        5432/tcp                        #
> POSTGRES
>    postgres        5432/udp                        #
> POSTGRES
>    fax             4557/tcp                        #
> FAX
> transmission service        (old)
>    hylafax         4559/tcp                        #
> HylaFAX client-server protocol  (new)
>    noclog          5354/tcp                        #
> noclogd with TCP (nocol)
>    noclog          5354/udp                        #
> noclogd with UDP (nocol)
>    hostmon         5355/tcp                        #
> hostmon uses TCP (nocol)
>    hostmon         5355/udp                        #
> hostmon uses TCP (nocol)
>    ircd            6667/tcp                        #
> Internet Relay Chat
>    ircd            6667/udp                        #
> Internet Relay Chat
>    webcache        8080/tcp                        #
> WWW
> caching service
>    webcache        8080/udp                        #
> WWW
> caching service
>    tproxy          8081/tcp                        #
> Transparent Proxy
>    tproxy          8081/udp                        #
> Transparent Proxy
>    mandelspawn     9359/udp        mandelbrot      #
> network mandelbrot
>    amanda          10080/udp                       #
> amanda backup services
>    kamanda         10081/tcp                       #
> amanda backup services (Kerberos)
>    kamanda         10081/udp                       #
> amanda backup services (Kerberos)
>    amandaidx       10082/tcp                       #
> amanda backup services
>    amidxtape       10083/tcp                       #
> amanda backup services
>    isdnlog         20011/tcp                       #
> isdn logging system
>    isdnlog         20011/udp                       #
> isdn logging system
>    vboxd           20012/tcp                       #
> voice box system
>    vboxd           20012/udp                       #
> voice box system
>    binkp           24554/tcp                       #
> Binkley
>    binkp           24554/udp                       #
> Binkley
>    asp             27374/tcp                       #
> Address Search Protocol
>    asp             27374/udp                       #
> Address Search Protocol
>    tfido           60177/tcp                       #
> Ifmail
>    tfido           60177/udp                       #
> Ifmail
>    fido            60179/tcp                       #
> Ifmail
>    fido            60179/udp                       #
> Ifmail
> 
>    # Local services
> 
>    linuxconf 98/tcp
>    swat              901/tcp                        
> #
> Add swat service used via inetd
> 
> ________________________________________
> 
> This also looked okay, so I looked for the ddp
> module,
> to see if RH still has this.   and I found the
> following:
> 
> /usr/doc/rhl-rg-6.1en/figs/gnorpm/gnoaddpkg.gif
>    /usr/man/man4/ddp.4
>    /usr/man/man7/ddp.7
>   
>
/usr/src/linux-2.2.12/include/linux/modules-BOOT/ddp.stamp
/usr/src/linux-2.2.12/include/linux/modules-BOOT/ddp.ver
/usr/src/linux-2.2.12/include/linux/modules-smp/ddp.stamp
/usr/src/linux-2.2.12/include/linux/modules-smp/ddp.ver
/usr/src/linux-2.2.12/include/linux/modules-up/ddp.stamp
/usr/src/linux-2.2.12/include/linux/modules-up/ddp.ver
/usr/src/linux-2.2.12/Documentation/networking/ipddp.txt
>    /usr/src/linux-2.2.12/drivers/net/ipddp.c
>    /usr/src/linux-2.2.12/drivers/net/ipddp.h
>    /usr/src/linux-2.2.12/net/appletalk/ddp.c
>    /lib/modules/2.2.12-20/net/ipddp.o
> 
> Which looks like it is there, but I guess I can't be
> sure it is loading. 
> 
> What do I try next?
> 
> Thanks.
> __________________________________________
> TASIS (The American School In Switzerland)
> Lugano-Montagnola, Switzerland
> <http://www.tasis.ch/>
> 

__________________________________________________
Do You Yahoo!?
Send instant messages & get email alerts with Yahoo! Messenger.
http://im.yahoo.com/

---

From: "S.Ecker" <[email-masked]>
Date: Mon, 15 May 2000 09:59:49 -0700 (PDT)

-Scott