Subject: RE: [netatalk-admins] newbie question about shared dirs

From: "James Fraser" <[email-masked]>
Date: Tue, 5 Oct 1999 15:14:25 -0700

In this particular case my account owns the dir and all files in the /mp3
directory. I am logging in from the Mac as my account also. But thanks for
the hint.

Jamie

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, October 05, 1999 3:13 PM
> To: James Fraser
> Subject: Re: [netatalk-admins] newbie question about shared dirs
>
>
>
>
> One thing to remember is that unix/linux is a multi-user env.
> That means that if
> you put a file in a dir and and your buddy logs in and tries to
> get the file he
> will not be able to because it is owned by you. What I have done
> in the past is
> when I made a user (foobar) I made him id 400 (just for example)
> then if I want
> to also give (feebar) access to the same files I also give him id
> 400. That
> means that 2 users share ids but have different logins. You could
> also make it
> so the default create permissions for the group are rwx and make
> both users the
> same group.
>
> If there are some other ways I would like to hear them just for future
> reference.......
>
> Johua
>
>
>
>
>
> "James Fraser" <[email-masked]> on 10/05/99 05:53:55 PM
>
> To:   [email-masked]
> cc:    (bcc: Josh Curtis/COMPEPHR/EPHRATA/MPG)
> Subject:  [netatalk-admins] newbie question about shared dirs
>
>
>
>      Please excuse my ignorance of netatalk. I'm new to netatalk and this
> mailing list.
>
>      I'm running Slackware 2.2.6 on my Intel box and I've just installed
> netatalk. Almost everything is working great. From a Mac on the network I
> can see my server in the Appleshares and select it. I am able to
> log in with
> my username and password. I see my home directory properly and can access
> it. The problem is that I have been trying to set up a common area that is
> accessible from multiple accounts. I've added the lines:
> #volumes
> ~       Home
> /mp3 "MP3 Files"
>
> to my /usr/local/atalk/etc/Applevolumes.default . Permissions are set to
> rwxr--r-- root root on both the Applevolumes.default and the
> Applevolumes.system. The dir /mp3 exists and has permissions set
> rwxr-xr-x .
> But I still can't see the /mp3 directory. Could sombody please point me in
> the right direction? I'm not sure what else to check.
>
> Thanks
>
> Jamie
>>

---

From: "Harry Zink/Netatalk List" <[email-masked]>
Date: Tue, 05 Oct 1999 22:15:59 -0700

> The dir /mp3 exists and has permissions set rwxr-xr-x .

Is /mp3 in your root directory, or in your paths?

Harry

--
Beauty, brains, availability, personality  - pick any two.