Subject: Re: [netatalk-admins] installation question: Solaris 7

From: John Browning <[email-masked]>
Date: Fri, 19 Mar 1999 12:39:43 +0000

On 18.3.99 at 16:32, David S. <[email-masked]> wrote:

> Well I can report that 'pre-asun2.1.4-2.tar.gz' compiled with the demo
> version of Sun's WorkShop 5.0 C compiler works fine under a 64 bit
> Solaris 7 kernel on a Sun Ultra 5.

Looks like there's a compiler problem, because pre-asun2.1.4-4.tar.gz doesn't attach on the same OS/kernel/machine when compiled with gcc 2.8.1. Which leaves a quandry. While I reckon I could compile with the demo, I hate to install something that I can no longer maintain after 30 days -- and unless Sun starts giving away free compilers for a fairly liberal version of "non-commercial use" the odds of us getting a real Sun compiler are close to NULL. So either

* try to use CAP until gcc does better 64-bit code or

* see if somebody with a Sun compiler wants to distribute binaries on a continuing basis

* switch to a 32-bit kernel

The first option looks best to me now, I must admit -- even though netatalk seems like the technological right thing. And it has such a wonderfully helpful mailing list. Many thanks again to everybody that responded so quickly and intelligently to my query...

John Browning   |||   71 Richmond Ave   |||   London N1 0LX
t + 44 171 700 1230      |||      f + 44 171 700 5255

---

From: "Andrew Snell" <[email-masked]>
Date: Fri, 19 Mar 1999 11:30:45 -0500

At 12:39 PM +0000 3/19/99, John Browning wrote:
>Looks like there's a compiler problem, because pre-asun2.1.4-4.tar.gz
>doesn't attach on the same OS/kernel/machine when compiled with gcc 2.8.1.
>Which leaves a quandry. While I reckon I could compile with the demo, I
>hate to install something that I can no longer maintain after 30 days --
>and unless Sun starts giving away free compilers for a fairly liberal
>version of "non-commercial use" the odds of us getting a real Sun compiler
>are close to NULL. So either
>
	One option I'll toss out would be to go to egcs (roughly = gcc
2.9.x). I have had many odd problems related (as far as I can tell)
directly to gcc 2.8.x, most of which have been solved by using egcs 1.1.1.
	I'm not sure it would solve this particular issue, but I'd say it
would be worth a try.
	The egcs project homepage is http://egcs.cygnus.com/.  I see that
as of 3/15, egcs 1.1.2 has been released, FYI.

- Andrew

Andrew Snell
Systems Administrator
UNC Student Stores
[email-masked]
(919) 843-9844
http://www.store.unc.edu/