Subject: [netatalk-admins] "too many files open"

From: Chris Colburn <[email-masked]>
Date: Tue, 14 Dec 1999 13:59:17 -0600 (CST)

When copying a large number of files (~2500 under a nest of folders) from
a Sun Ultra 10 (Solaris 7) box running pre-asun-2.1.4-35 to a G4 running
8.6, things start to gack after copying about 45 files with a "An error
occurred in copying "myfile" (too many files open)".  Have I missed a
configuration option somewhere, or did this get fixed in pre36a?  If
anyone has any ideas, please let me know.

Chris Colburn
Web Systems Associate
North Central Regional Educational Laboratory (NCREL)
e: [email-masked]

---

From: Will Lowe <[email-masked]>
Date: Tue, 14 Dec 1999 15:04:07 -0500 (EST)

> a Sun Ultra 10 (Solaris 7) box running pre-asun-2.1.4-35 to a G4 running

Aha!  Do you know the magic incarnations to get netatalk to compile under
Solaris 7 (sparc)?

                     					Will

--------------------------------------------------------------------------
|   [email-masked] [email-masked] [email-masked] [email-masked]  |
|			http://www.cis.udel.edu/~lowe/		         |
|    PGP Public Key:  http://www.cis.udel.edu/~lowe/index.html#pgpkey    |
--------------------------------------------------------------------------

---

From: [email-masked]
Date: Tue, 14 Dec 1999 12:19:26 -0800 (PST)

>From the Solaris FAQ:

3.45) How can I increase the number of file descriptors per process? 

In 2.3 in earlier this requires poking the kernel. In Solaris 2.4+, this can be accomplished by adding the following lines to
/etc/system: 

        * set hard limit on file descriptors
        set rlim_fd_max = 4096
        * set soft limit on file descriptors
        set rlim_fd_cur = 1024

Raising the soft limit past 256 may confuse certain applications, especially BCP applications. Raising the limit past 1024
may confuse applications that use select(). Select() cannot use more than 1024 file descriptors at this time prior to Solaris
7. In Solaris 2.6, the RPC code was rewritten to use poll(), which does work with many more fds than select(). Prior to 2.6,
all RPC servers will likely crash and burn if you increase the fd soft limit past 1024. 

Solaris 7 allows upto 65536 fds passed to select; this does require recompiling with a larger value for FD_SETSIZE. 

Programs using stdio or even library calls that use stdio may break when they have more than 256 files open as that is the
stdio limit. Programs using many filedescriptors should try and reserve a number of low numbered file descriptors for use
by stdio. 

The stdio limit is removed for 64 bit applications in Solaris 7; if you really need more than 256 FILE * in and you can't use
Solaris 7+ or need to run in 32 bits, you can use SFIO from AT&T. 

> North Central Regional Educational Laboratory (NCREL)

David S.
[email-masked]

---

From: clyde jones <[email-masked]>
Date: Tue, 14 Dec 1999 15:24:09 -0500

I don't think this is a netatalk error.
You can get an error -45 with sys 8.6  if you have too many font files (go
figure).  I had the same problem and it was solved by consolidating 
font files in the system folder.
I am running netatalk on a Linux RedHat 6.1 box.

>North Central Regional Educational Laboratory (NCREL)

--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==
Pray to God, But Hammer Away
     - Spanish Proverb
           Clyde Jones

Clyde Jones
Http://www.geocities.com/clyde-jones
mailto:[email-masked]
Cell 443.226.6054
--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==

__________________________________________________
Do You Yahoo!?
Thousands of Stores.  Millions of Products.  All in one place.
Yahoo! Shopping: http://shopping.yahoo.com

---

From: sat <[email-masked]>
Date: Tue, 14 Dec 1999 15:33:31 -0500

Try MacOS 9.   The number of allowed open files has increased dramatically.