Subject: [netatalk-admins] afpd[nnn]: dsi_tcp_open: sigaction: Invalid argument

From: 藤原 誠 Makoto Fujiwara <[email-masked]>
Date: Thu, 13 May 1999 22:33:33 +0900

>                                   Thu May 13 22:32:23 1999
>                                                [email-masked]
>                                                 Chiba Japan          

Hi, 
I am some problem on TCP/IP and NetBSD/sparc combination.

The related version is:
netatalk-1.4b2+asun2.1.3.tar.gz
NetBSD-1.4_BETA/sparc
  ( + option NETATALK kernel)
egcs-1.1.1

and I have following problem when accessing from MacOS 8.0.
(after selecting the file server name on chooser),
-----------------
May 12 18:02:40 hostname afpd[717]: ASIP session:548(1) from 220.4.101.130:2101(2)
May 12 18:02:40 hostname afpd[530]: server_child[1] 717 done
May 12 18:02:50 hostname afpd[718]: dsi_tcp_open: sigaction: Invalid argument
May 12 18:02:50 hostname afpd[530]: server_child[1] 718 exited 1
-----------------
On Mac dialog (in Japanese)
The connection is suddenly disconnected.

If accessing from MacOS 7.5, it is OK to work good.
(say, AppleTalk part is working fine)

>From Unix machine, by telneting hostname 548 resulted
immediately disconnected.

  But sometimes get connected and typing some char resulted Invalid
header ( this is probably due to manually typing so I don't care).

I have another similar machine running SunOS 4.1.4 + netatak +asun,
which responds at least always get connected by telnetting 548.

  I am not totally sure for /etc/services. The local /etc/services are
definitely having services.atalk entry, but NIS service is flaky at
the moment ( only because my setup is not firm yet), that's why I am
rather saying not sure. But I have checked with ypbind working and
without, resulting the same symptom.

Does anybody know where and how to check ?
Also is there any easy way to disable AFP over TCP temporarily ?

Or is this the problem of MacOS 8.0 ?
---
(Makoto Fujiwara)

---

From: a sun <[email-masked]>
Date: Thu, 13 May 1999 11:16:11 -0700 (PDT)

May 12 18:02:50 hostname afpd[718]: dsi_tcp_open: sigaction:
   Invalid argument

actually, someone else just pointed this out to me. go to
libatalk/dsi/dsi_tcp.c and do the following before action gets its
assignments:
	memset(&action, 0, sizeof(action));

-a