Subject: [netatalk-admins] redhat 6

From: John Barnett <[email-masked]>
Date: Wed, 23 Jun 1999 19:44:57 -0400

I've seen (and posted) some messages about strangeness involving
netatalk in redhat 6.  Someone posted a message suggesting that
the problem is glibc 2.1; I have a couple of follow up questions
to that.

- if the problem is glibc 2.1, would a version compiled on an earlier
glibc work?  I wasn't able to run my earlier version on rh 6.

- if that is the problem, how would I get around it?  I imagine that
if I tried to use an earlier glibc, that might break other things;
any thoughts as to how to proceed?

I'd especially like to hear from those who *are* running netatalk
successfully on redhat 6; perhaps you could guide me through what you
had to do to get things running.

Thanks for any help.

-John Barnett

---

From: Dan Horth <[email-masked]>
Date: Thu, 24 Jun 1999 09:48:39 +1000

Hiya - we're running netatalk-1.4b2+asun2.1.3-2 on redhat 6 (kernel 2.2.5) fine here - but did not compile netatalk here - rather relied on a rpm from http://rufus.w3.org/

but I think this version has been replaced by:

http://rufus.w3.org/linux/RPM/contrib/libc6/i386/netatalk-1.4b2+asun2.1.3-4.i386.html

anyway - however iNOUE Koichi compiled & set up their distribution is working great for us here... 

cheers, dan.

>had to do to get things running.
-----
	Nitro - 3D Visualisation, Graphics & Animation
		Ph (+61 2) 9810 5177 - Fx (+61 2) 9810 0199
			http://www.nitro.com.au/

---

From: Albert Max Lai <[email-masked]>
Date: Wed, 23 Jun 1999 20:48:52 -0400 (EDT)

> the problem is glibc 2.1; I have a couple of follow up questions

All I know is that DHX broke when I compiled it on redhat
6. Everything else seemed to work fine. When I compiled netatalk on
5.2, everything else worked. (Very strange problem... the password was
received and then got lost I believe. Should not have occured under
any circumstances.) Now seems to run successfully.

-- 
Albert Lai <[email-masked]>
http://www.columbia.edu/~aml61

---

From: John Barnett <[email-masked]>
Date: Thu, 24 Jun 1999 12:36:57 -0400

I tried Inoue Koichi's netatalk rpm, but I still get the same results:

AppleTalk not up! Child exited with 1.
bind: Cannot assign requested address
bind: Cannot assign requested address

I've tried loading & unloading the appletalk module, recompiling it,
but I always get the same error message.  Any suggestions?

Thanks,
John

---

From: Dan Horth <[email-masked]>
Date: Fri, 25 Jun 1999 10:06:47 +1000

John - it would be helpful if you could send in log file clippings showing
what's actually happening as netatalk starts up - I've found from my
experiences that problems can be sorted out quite readily by checking log
files.

also I would suggest joining the Appletalk on linux mail list as this seems
to carry more "how do I fix this netatalk problem" type questions rather
than the development related issues that pop up here...

http://www.lsoft.com/scripts/wl.exe?SL1=LINUX-ATALK&H=NETSPACE.ORG

there's also a handy archive search facility there...

Cheers, dan.

ps. feel free to mail me log clippings if you need help deciphering what's
going on...

-----