Subject: [netatalk-admins] linuxppc 2.2/ glibc 2.0 compile fail. for netatalk-1.4b2+asun2.14-2

From: satadru pramanik <[email-masked]>
Date: Mon, 15 Mar 1999 17:06:17 +0000 (Local time zone must be set--see zic manual page)

Any thoughts on this?   Do I need new include files, or is this a problem
in the netatalk source?

thanks.

Making all for linux...
make[1]: Entering directory
`/mnt/ibm/sin/src/netatalk-1.4b2+asun2.1.4/sys/linux
'
make[1]: *** Warning: File `../../libatalk' has modification time in the
future
(921526923 > 921517337)
cd ../../libatalk; make -w CC="gcc " \
    ADDLIBS="" DEFS="-DSENDFILE_FLAVOR_LINUX -DUSE_PAM" OPTOPTS="-O2
-fomit-fram
e-pointer -fsigned-char -Wunused -Wuninitialized" \
    SBINDIR="/usr/local/atalk/etc" BINDIR="/usr/local/atalk/bin"
RESDIR="/usr/lo
cal/atalk/etc" \
    ETCDIR="/usr/local/atalk/etc" LIBDIR="/usr/local/atalk/lib"
INCDIR="/usr/loc
al/atalk/include" \
    DESTDIR="/usr/local/atalk" AFSDIR="" KRBDIR="" \
    AFPLIBS="-lrpcsvc -lpam -ldl" all
make[2]: Entering directory
`/mnt/ibm/sin/src/netatalk-1.4b2+asun2.1.4/libatalk'
make[2]: *** Warning: File `asp' has modification time in the future
(921529281
> 921517337)
cd asp; make -w CC="gcc " DEFS="-DSENDFILE_FLAVOR_LINUX -DUSE_PAM" \
    OPTOPTS="-O2 -fomit-frame-pointer -fsigned-char -Wunused
-Wuninitialized" TC
PWRAPDIR="/usr" DB2DIR=""
make[3]: Entering directory
`/mnt/ibm/sin/src/netatalk-1.4b2+asun2.1.4/libatalk/
asp'
gcc  -p -DSENDFILE_FLAVOR_LINUX -DUSE_PAM -O2 -fomit-frame-pointer
-fsigned-char
 -Wunused -Wuninitialized -I../../include -c asp_attn.c
In file included from /usr/include/sys/socket.h:37,
                 from ../../include/netatalk/at.h:11,
                 from ../../include/atalk/atp.h:29,
                 from asp_attn.c:12:
/usr/include/bits/sockunion.h:39: field `sat' has incomplete type
make[3]: *** [asp_attn.o] Error 1
make[3]: Leaving directory
`/mnt/ibm/sin/src/netatalk-1.4b2+asun2.1.4/libatalk/a
sp'
make[2]: *** [asp] Error 2
make[2]: Leaving directory
`/mnt/ibm/sin/src/netatalk-1.4b2+asun2.1.4/libatalk'
make[1]: *** [../../libatalk] Error 2
make[1]: Leaving directory
`/mnt/ibm/sin/src/netatalk-1.4b2+asun2.1.4/sys/linux'
make: *** [all] Error 2

----
satadru pramanik [email-masked]'
"Put your hand on a hot stove for a minute, and it seems like an hour. Sit
with a pretty girl for an hour, and it seems like a minute. THAT'S
relativity." 
-Albert Einstein
---

---

From: "Tim O'Shea [ tmo ]" <[email-masked]>
Date: Wed, 17 Mar 1999 10:22:20 -0500 (EST)

> make[1]: *** Warning: File `../../libatalk' has modification time in the

Seeing as how your mail header had timezone problems, and your are getting
modification time errors, I would make sure your clock is set properly.

man hwclock
man clock
man date

Should get you on the right track.  Once that is done, 'touch' the files
in your netatalk source directories.

man touch

for help on that one.

Tim O'Shea [tmo]

Director of Research Technology
The Living SchoolBook Project
Syracuse University				315.443.5273	phone
Syracuse, NY					315.443.2258	fax