Subject: [netatalk-admins] Why does "getzones" time out?

From: Heinz Nabielek <[email-masked]>
Date: Thu, 08 Apr 1999 14:59:47 +0200

Netatalk is largely working fine
(see below), but why do I always get
a time out message from getzones?

Heinz

Here, two Macs are Ethernet-connected:
iev014 is running linuxppc R4
iev140 is running MacOS7.6.1

[root@iev014 /root]# nbplkup 
                        server3:AFPServer
65280.148:130
                        server2:AFPServer
65280.148:129
                        server1:AFPServer
65280.148:128
                         iev014:netatalk                           65280.148:4
                         iev014:Workstation                        65280.148:4
                         iev140:MacPing* 3.0.3                     65280.85:2
                        Mac7100:AFPServer
65280.85:250
                        Mac7100:PPCToolBox
65280.85:251
                        Mac7100:  Power Macintosh
65280.85:252
                        Mac7100:Workstation                        65280.85:4
                 microLaser Pro:LaserWriter
65280.233:128
[root@iev014 /root]# aecho 65280.148
14 bytes from 65280.148: aep_seq=0. time=0. ms
14 bytes from 65280.148: aep_seq=1. time=0. ms
14 bytes from 65280.148: aep_seq=2. time=0. ms
14 bytes from 65280.148: aep_seq=3. time=0. ms

----65280.148 AEP Statistics----
4 packets sent, 4 packets received, 0% packet loss
round-trip (ms)  min/avg/max = 0/0/0
[root@iev014 /root]# aecho 65280.85
14 bytes from 65280.85: aep_seq=0. time=1. ms
14 bytes from 65280.85: aep_seq=1. time=1. ms
14 bytes from 65280.85: aep_seq=2. time=1. ms
14 bytes from 65280.85: aep_seq=3. time=1. ms
14 bytes from 65280.85: aep_seq=4. time=1. ms
14 bytes from 65280.85: aep_seq=5. time=1. ms

----65280.85 AEP Statistics----
6 packets sent, 6 packets received, 0% packet loss
round-trip (ms)  min/avg/max = 1/1/1
[root@iev014 /root]# aecho 65280.233
14 bytes from 65280.233: aep_seq=0. time=67. ms
14 bytes from 65280.233: aep_seq=1. time=61. ms
14 bytes from 65280.233: aep_seq=2. time=57. ms
14 bytes from 65280.233: aep_seq=3. time=52. ms
14 bytes from 65280.233: aep_seq=4. time=48. ms
14 bytes from 65280.233: aep_seq=5. time=44. ms

----65280.233 AEP Statistics----
6 packets sent, 6 packets received, 0% packet loss
round-trip (ms)  min/avg/max = 44/54/67

[root@iev014 /root]# getzones
atp_rresp: Connection timed out
[root@iev014 /root]# getzones 65280.85
atp_rresp: Connection timed out

and in /var/log/messages:

X kernel: NET4: AppleTalk 0.18 for Linux NET4.0
X atalkd[331]: restart (1.4b2+asun2.0a18.2)
X atalkd[331]: zip_getnetinfo for eth0
X last message repeated 2 times
X atalkd[331]: config for no router
X atalkd[331]: ready 0/0/0
X papd[342]: restart (1.4b2+asun2.0a18.2)
X afpd[351]: server1:AFPServer@* started on 65280.148:128 (1.4b2+asun2.0a18.2)
X afpd[351]: ASIP started on 134.94.116.15:12000(4) (1.4b2+asun2.0a18.2) 
X afpd[351]: server2:AFPServer@* started on 65280.148:129 (1.4b2+asun2.0a18.2)
X afpd[351]: ASIP started on 134.94.116.15:12001(6) (1.4b2+asun2.0a18.2) 
X afpd[351]: server3:AFPServer@* started on 65280.148:130 (1.4b2+asun2.0a18.2)
X afpd[351]: ASIP started on 134.94.116.15:12002(8) (1.4b2+asun2.0a18.2) 

because of /etc/atalk/afpd.conf
server1 -port 12000
server2 -port 12001
server3 -port 12002

and printing looks like this in /var/log/messages:

X ifpap[579]: starting for root
X ifpap[579]: sending to pap[580]
X ifpap[579]: straight text
X ifpap[579]: 580 done
X ifpap[579]: done
X ifpap[584]: starting for iev014
X ifpap[584]: sending to pap[585]
X ifpap[584]: PostScript
X ifpap[584]: 585 done
X ifpap[584]: done

---

From: Yuji Shinozaki <[email-masked]>
Date: Thu, 8 Apr 1999 09:19:06 -0400 (EDT)

> X atalkd[331]: config for no router
                 ^^^^^^^^^^^^^^^^^^^^

Looks like you cannot see an appletalk router and probably do not have a
seed router (an appletalk router that establishes zones). No seed router
=> no zones and nothing to return zone info. Do you see zones in the Mac
Chooser? 

You can set up netatalk as a seed router to create zones, but not knowing
your network topology I hesitate to explain how. 

yuji
----
Yuji Shinozaki		        Systems Administrator
[email-masked]	        Dept of Physics and Astronomy
http://www.physics.unc.edu      Univ. of North Carolina - CH
(919)962-7214 (voice)           CB 3255 Philips Hall
(919)962-0480 (fax)	        Chapel Hill, NC  27599