Subject: [netatalk-admins] netatalk on Solaris 7

From: "validgh.com firewall administrator" <[email-masked]>
Date: Tue, 17 Aug 1999 07:05:47 -0700 (PDT)

I compiled netatalk-1.4b2+asun2.1.3.tar.gz with gcc
on a SPARCstation running Solaris 2.6 and it ran OK.   

I upgraded the SPARCstation to Solaris 7, and booted the 64-bit Solaris 7
kernel, and netatalk didn't work.    I then booted the 32-bit Solaris 7
kernel and netatalk worked again, all without recompiling.

I just wanted to inquire to make sure that's the expected behavior.
Is there a satisfactory route to getting netatalk to work with 64-bit
Solaris 7?

I was gratified that my samba binaries
worked in 64-bit mode with no effort whatever on my part.
I originally converted from totalnet to samba and netatalk because
I couldn't upgrade the operating system to Solaris 7 without buying new
licenses for a new version of totalnet.

David Hough
[email-masked]

---

From: "Chris G. Sellers" <[email-masked]>
Date: Mon, 23 Aug 1999 22:53:16 -0500 (EDT)

David,
	I also noted some issues with Solaris7 and 64bit.  I was able to
get it to work but had to use some talored code.  I'll see if I can find
that for you and arrange for an area to get it ftp.

> licenses for a new version of totalnet.

<(************************************************************)>

   CHRIS G. SELLERS		
   Scientific Programmer Analyst 	
    Information & Instructional Technology 
	(formerly Computer & Information Services)
    101  Kresge Library		 		  
    Oakland University - Rochester, Michigan 48309-4401	
    Phone: (248) 370.2016    FAX: (248) 370.4251

---

From: "Tony Canning" <[email-masked]>
Date: Tue, 24 Aug 1999 11:28:26 +0100

On Aug 23, 10:53pm, Chris G. Sellers wrote:
> Subject: Re: [netatalk-admins] netatalk on Solaris 7
> David,
>-- End of excerpt from Chris G. Sellers

Dear Chris, I am also hoping to install netatalk on Solaris 7 (on a SPARC E450)
and would be grateful for any tips - I couldn't find any references
to solaris 7 on the mail archive.

Tony Canning
Technical & Support Manager
Friends of the Earth England, Wales & N. Ireland
[email-masked]
http://www.foe.org.uk

---

From: Tim Carlson <[email-masked]>
Date: Tue, 24 Aug 1999 07:51:02 -0600 (MDT)

> to solaris 7 on the mail archive.

Solaris 7 needs 64bit kernel modules. To do this you need to compile with
Sun's Workshop 5.0 compilers. Best to use asun's latest snapshots. GCC
2.95.x does not support 64bit compilation on UltraSparc. I can supply you
with Solaris binaries (less the DES enscription) for 64bit machines. 

Tim

---

From: Russell E Glaue <[email-masked]>
Date: Tue, 24 Aug 1999 17:33:51 -0500 (CDT)

What's the word for Netatalk on Intel Sun Solaris 7 ?
Anyone know?
						-----russ-----

> with Solaris binaries (less the DES enscription) for 64bit machines. 

+--------------------------------------------------------------+
 Russell E Glaue, Technologies Engineer   [email-masked]
 Center for the Application of Information Technologies
 101 Horrabin Hall, 1 University Circle, Macomb, Illinois 61455
 http://www.cait.org  http://cait.wiu.edu