Subject: Re: [netatalk-admins] Netatalk problem, too many routes/iface? (more information)

From: "Harry Zink/Netatalk List" <[email-masked]>
Date: Tue, 13 Jul 1999 00:50:33 -0700

> This results in Appleshare over Appletalk not working.  Appleshare/TCP 
> works fine.  I checked all the archives, but couldn't find any reference
> to this problem.  Can someone tell me what the problem is?

I have the similar problem.

My atalkd.conf contains:

eth0 -seed -phase 2 ; this is the internal network
eth1 -phase 2 ; this is the WAN/DSL connection

This turns into:

eth0 -seed -phase 2 -net 65280-65534 -addr 65280.148
eth1 -seed -phase 2 -net 65280-65534 -addr 65280.74

Here's what my log shows:

Jul 13 00:42:20 hzink kernel: NET4: AppleTalk 0.18 for Linux NET4.0
Jul 13 00:42:20 hzink atalkd[12263]: restart (1.4b2+asun2.1.3)
Jul 13 00:42:21 hzink atalkd[12263]: zip_getnetinfo for eth0
Jul 13 00:42:40 hzink last message repeated 2 times
Jul 13 00:42:50 hzink atalkd[12263]: as_timer configured eth0 phase 2 from
seed
Jul 13 00:42:51 hzink atalkd[12263]: zip_getnetinfo for eth1
Jul 13 00:43:00 hzink last message repeated 2 times
Jul 13 00:43:10 hzink atalkd[12263]: as_timer configured eth1 phase 2 from
seed
Jul 13 00:43:10 hzink atalkd[12263]: ready 0/0/0
Jul 13 00:43:10 hzink atalk: atalkd startup succeeded
Jul 13 00:43:23 hzink atalk: afpd startup succeeded
Jul 13 00:43:29 hzink afpd[12291]: Gateway:AFPServer@* started on
65280.74:128 (1.4b2+asun2.1.3)
Jul 13 00:43:29 hzink afpd[12291]: ASIP started on 192.168.100.103:548(2)
(1.4b2+asun2.1.3)

Yet, the server doesn't show up in the chooser at all, yet I can access it
via TCP.

If I don't enter ANYTHING in atalkd.conf, I get this upon restart:

nbp_rgstr: Connection timed out
Can't register hzink:Workstation@*
nbp_rgstr: Connection timed out
Can't register hzink:netatalk@*

and my log shows:

Jul 13 00:48:33 hzink atalkd[12338]: as_timer multiple interfaces, no seed
Jul 13 00:48:33 hzink atalkd[12338]: as_timer can't configure eth0
Jul 13 00:48:33 hzink atalkd[12338]: as_timer waiting for router
Jul 13 00:48:33 hzink atalkd[12338]: ready 0/0/0
Jul 13 00:48:33 hzink atalk: atalkd startup succeeded
Jul 13 00:48:49 hzink atalk: papd startup succeeded
Jul 13 00:48:49 hzink papd[12353]: restart (1.4b2+asun2.1.3)
Jul 13 00:48:49 hzink atalk: afpd startup succeeded
Jul 13 00:48:59 hzink afpd[12363]: Can't register Gateway:AFPServer@*
Jul 13 00:48:59 hzink afpd[12363]: ASIP started on 192.168.100.103:548(1)
(1.4b2+asun2.1.3)

Yet, now "Gateway" shows up in the chooser, but is still not accessible (TCP
works, though).

This is frustrating. Any help is appreciated.

Harry

---

From: a sun <[email-masked]>
Date: Tue, 13 Jul 1999 11:09:04 -0700 (PDT)

instead of the above, just stick the following in atalkd.conf and
atalkd will figure itself out:
eth0

-a

---

From: Patrik Schindler <[email-masked]>
Date: Tue, 13 Jul 1999 19:49:49 +0200

>eth1 -seed -phase 2 -net 65280-65534 -addr 65280.74

Your Network Range overlaps.

>Jul 13 00:48:33 hzink atalkd[12338]: ready 0/0/0

If you have more than one interface and no router on (one) of them, you MUST use -seed (on the one which doesn't have the router) and set the network information by hand that the ranges are relatively small (one number per Mac is a good start) and DO NOT OVERLAP!
What you do with the zone information is upon you (different or the same). 

>This is frustrating. Any help is appreciated.

Learn the two most important things of networking and routing (for what ever protocol you are using):

- Different NICs have to get different network numbers [1]
- All NICs together on one "cable" must have different adresses [1]

[1] there are rare and special cases in which this is not always true

:wq! PoC