Subject: RE: [netatalk-admins] Confiuration - apple to linux working

From: "Tom Tilmant" <[email-masked]>
Date: Sun, 29 Aug 1999 19:41:08 -0700

Nicole,

Tried your suggestion, but still no luck.  The message file show everything
but afpd starting up.  Does yours look this way?

Aug 30 02:23:02 ns atalkd[536]: config for no router
Aug 30 02:23:03 ns atalkd[536]: ready 0/0/0
Aug 29 19:23:03 ns atalk.init: atalkd startup succeeded
Aug 29 19:23:16 ns atalk.init: papd startup succeeded
Aug 30 02:23:16 ns papd[549]: restart (1.4b2+asun2.1.0)
Aug 29 19:23:16 ns atalk.init: afpd startup failed

If anyone knows what I am doing wrong, please let me know.  My wife will not
let me sacrifice a chicken or child :-) to get this running.

As for going the other direction, I have no need, so I haven't looked into
it.

Tom Tilmant

-----Original Message-----
From: Nicole Lallande [mailto:[email-masked]]
Sent: Sunday, August 29, 1999 10:21 AM
To: [email-masked]
Subject: Re: [netatalk-admins] Confiuration - apple to linux working

Tom -

I got my apple to see my linux:

Go to /etc/atalk and edit your AppleVolumes.default file.  You will see
that the last line is a '"' (quote).  Here is where you would add the
directories you want your appletalk to load from the chooser so eg. :

/tmp  Scratch
/home/ftp/pub  "Public Areas"

This information came from a linux other network technologies howto
http://metalab.unc.edu/LDP/HOWTO/NET-3-HOWTO-8.html#ss8.2

I want it going in the other direction - ie, load apple filesystems on the
linux.  Any clues?

Good luck

***********************************
Nicole Lallande
VOX:  760.753.6766
FAX:  760.753.6768
[email-masked]
[email-masked]
______________________________ "Advice to worms:  Sleep late"
www.mipana.com
www.high-techmarketing.com
***********************************

---

From: "Tom Tilmant" <[email-masked]>
Date: Mon, 30 Aug 1999 21:32:19 -0700

OK guys, I finally got it working.  I removed the
netatalk-1.4b2+asun2.1.0-5.rpm and installed the
netatalk-1.4b2+asun2.1.3-6.rpm which worked right out of the box.  both
appletalk and appleshare IP and running.  Hey Rick Zeman, I did not even
have to sacrifice the wife <grin>, but I did come close.  Thanks Nicole
Lallande and the rest of you for your help.  Now for the next step, can you
have Netatalk use the smbuser/smbpasswd files?

Tom Tilmant

---

From: Benjamin Lee <[email-masked]>
Date: Tue, 31 Aug 1999 21:14:38 +1000 (EST)

hi,

i was wondering if this was on redhat 6.0..??  as i'm having a few
troubles with the same .rpm. on redhat 6.0, it worked fine for 5.2

i'll post more error information if it was 6.0. ;-)

ben

__________________________________________________________________

Perfection is reached, not when there is no longer anything to add, but
when there is no longer anything to take away.
                -- Antoine de Saint-Exupery

---

From: "Tom Tilmant" <[email-masked]>
Date: Tue, 31 Aug 1999 15:04:46 -0700

It was Red Hat 6.0.  Which RPM were you using?
netatalk-1.4b2+asun2.1.0-5.rpm or netatalk-1.4b2+asun2.1.3-6.rpm.

Tom Tilmant

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of
Benjamin Lee
Sent: Tuesday, August 31, 1999 4:15 AM
To: Tom Tilmant
Cc: [email-masked]
Subject: RE: [netatalk-admins] Confiuration

hi,

ben

---

From: Benjamin Lee <[email-masked]>
Date: Wed, 1 Sep 1999 11:47:12 +1000 (EST)

What does not destroy me, makes me stronger.
                -- Nietzsche

> netatalk-1.4b2+asun2.1.0-5.rpm or netatalk-1.4b2+asun2.1.3-6.rpm.

i am using netatalk-1.4b2+asun2.1.3-6.rpm.

what i just found is that it does work.... BUT only ONCE.

if i turn off atalkd in ntsysv then
if i manually run:

/etc/rc.d/init.d/atalk start

it seems to work fine...

however AS SOON as i do a /etc/rc.d/init.d/atalk restart

i get things like this...

Sep  1 11:41:02 chaos atalkd[1578]: restart (1.4b2+asun2.1.3)
Sep  1 11:41:13 chaos atalkd[1578]: ready 0/0/0
Sep  1 11:41:13 chaos atalk: atalkd startup succeeded
Sep  1 11:41:13 chaos atalkd[1578]: setifaddr: eth0: Address already in
use
Sep  1 11:41:13 chaos atalk: papd startup succeeded
Sep  1 11:41:13 chaos papd[1591]: restart (1.4b2+asun2.1.3)
Sep  1 11:41:14 chaos papd[1591]: atp_open: Cannot assign requested
address

and on the console

bind: Cannot assign requested address
bind: Cannot assign requested address

my setup is simple...

my linux box has two network cards (RJ45) each card is connected via
direct crossover cable to a single mac.

as i mentioned earlier it's worked fine for me in 5.2

i think it has something to do with how the 'stop' is defined in
init.d/atalk

what do you think?

ben