Subject: [netatalk-admins] Jukeboxing with netatalk

From: Lars <[email-masked]>
Date: Tue, 01 Jun 1999 11:49:08 +0200

I am thinking about building a cheaper "jukebox" for my users:

1. external SCSI CDROM tower with real old and cheap SCSI CDROMS.
2. interface (for ejecting / mounting /unmounting CD's) controlled/supplied
per Apache/PHP3 over webbrowser

But what really bugs me ist that i.e. with,

mount -thfs -o uid=501 -o gid=100 -o umask=000 /dev/scd0 /macfs/cdrom

I can mount a CDROM and it is served per netatalk BUT:
when I mount a multimedia CDROM (i.e. PromoCD's) I can not execute
anything. It just looks like a regular, boring iso9660 filesystem, which
can be browsed but nothing more.

<clueless value=full cellpading=rubber>
Am I missing something?
</clueless>

Thanks for the help in advance,
Lars

-secure mail prefered-
true affection: http://unix.oreilly.com/news/unix_love_0299.html

---

From: [email-masked] (William P. McGonigle)
Date: 02 Jun 99 09:34:53 EDT

--- Lars wrote:
--- end of quote ---

Perhaps you're just mounting the first session of a multi-session CD-ROM?  I
don't know the mount syntax you need, but it must be possible.  

The tricky part is probably going to be reliably getting the mac session on all
of the disks, in each drive, since it's probably not always going to be session
n.

To make things worse, I think you can also just have a mac names session, which
points to the ISO9660 session for file data.

-Bill