Subject: [netatalk-admins] Netatalk now working .....

From: Heinz Nabielek <[email-masked]>
Date: Fri, 19 Mar 1999 14:51:22 +0100

Netatalk is now working in MkLinuxDR3:

I used
netatalk-1.4b2+asun2.0a18.2-oa1a
instead of 
netatalk-1.4b2+asun2.1.1-2
-->     What does the oa1a mean?
Whatever, it did the trick for me.

Now I get:
nbplkup 
                         iev140:AFPServer
65280.143:128
                         iev140:netatalk                           65280.143:4
                         iev140:Workstation                        65280.143:4
                         iev013:AFPServer                          65280.5:249
                         iev013:ARA - Client-Only                  65280.5:2
                         iev013:PPCToolBox                         65280.5:251
                         iev013:  Power Macintosh                  65280.5:252
                         iev013:Workstation                        65280.5:4
                 microLaser Pro:LaserWriter
65280.233:128
As Mac, the Performa is "iev013", as
linuxPPC box the Performa is "iev014".

With
/etc/printcap
lp|microLaser Pro:\
	:sd=/var/spool/lp:\
	:lp=/dev/atalk/lp:\
	:lf=/var/log/lpd-errs:\
	:if=/usr/lib/atalk/filters/ifpap:\
	:mx#0:sh:sf:
I can print onto the TI microLaser at the neighbouring Mac.

Before, I had to re-establish all the broken links in
/usr/lib/atalk/filters/* to /usr/sbin/psf.

To my great surprise, even ASCII printing
works with only some 22 characters falling
off the left-hand-side of the page (Any
help here ?)

On the  linuxPPC box, things are more difficult.
In addition, I have to 
insmod /lib/modules/2.2.1/misc/appletalk.o
atalkd

There is still a lot of fine tuning to do.

Why does my MkLinux AppleTalk server have
the number 65280.143, i.e. $FF00/8F ?
I never gave it a number !

Further hints still welcome.

Greetings
Heinz

>Date: Mon, 15 Mar 1999 12:41:14 +0100
>From: Heinz Nabielek <[email-masked]>
>Subject: I cannot get netatalk working. Please, help.

>Two Macs connected via Ethernet,
>but not to the outside world.
>
>iev140 is a 7100/66AV running
> MacOS7.6.1 or MkLinux DR3 GENERIC #6
> 
>iev014 is a Performa 6400/200 running
> MacOS8.5.1 or linuxPPC R4
> 
>Both boxes see each other in the usual
>way under MacOS (Appletalk) and Linux,
>but I cannot get netatalk working.
>
>iev140 with MkLinux -- iev014 running MacOS8.5.1
>[root@iev140 /root]# /etc/rc.d/init.d/atalk start
>Starting AppleTalk services: (backgrounded)
>[root@iev140 /root]# AppleTalk not up! Child died.
>bind: Cannot assign requested address
>bind: Cannot assign requested address
>....however, the other Mac is up with appletalk running ....
>
>from: /var/log/messages
>Mar 14 12:34:23 iev140 papd[347]: restart (1.4b2+asun2.1.1)
>Mar 14 12:34:25 iev140 afpd[360]: main: atp_open:
>	Cannot assign requested address
>Mar 14 12:34:25 iev140 afpd[360]: 
>	ASIP started on [TCP/IPaddress]:548(0) (1.4b2+asun2.1.1)
>	
>
>iev014 with linuxppc - iev140 running MacOS7.6.1
>[root@iev014 log]# /etc/rc.d/init.d/atalk start
>Starting AppleTalk services: (backgrounded)
>[root@iev014 log]# socket: Invalid argument
>socket: Invalid argument
>atalkd: can't get interfaces, exiting.
> 
>from: /var/log/messages
>Mar 14 09:36:21 iev014 papd[359]: restart (1.4b2+asun2.1.1)
>Mar 14 09:36:21 iev014 afpd[369]: main: atp_open: Invalid argument
>Mar 14 09:36:22 iev014 afpd[369]:
>	ASIP started on [TCP/IPaddress]:548(0) (1.4b2+asun2.1.1) 
>
>
>afp is doing fine, i.e. I can go via the chooser
>into a Linux user account on the other machine.
>However, the Linux box does not appear in the
>Mac chooser field, I have to type in the
>numerical TCP/IP address.

---

From: Albert Max Lai <[email-masked]>
Date: Fri, 19 Mar 1999 09:26:59 -0500 (EST)

> -->     What does the oa1a mean?
The oa stands for Osma Ahvenlampi <[email-masked]>. I'm assuming that the 1a
is a version number.

> I never gave it a number !

It is optional to give a number (look in atalkd's man page).

--
Albert Lai <[email-masked]>           1018D East Campus
Residential Computer Consultant           411 W. 116th St.
Columbia University                       New York, NY 10027
http://www.columbia.edu/~aml61            (212)853-4854