Subject: [netatalk-admins] AppleTalk multi-homing

From: [email-masked] (Chris Ferebee, Ferebee)
Date: Fri, 07 May 1999 21:19:51 +0200

Adrian,

you wrote:

>in other news, i keep meaning to add the fews bits needed to get
>atalkd to do multi-homing with multiple interfaces, but no one's
>really been hankering for that. so, i've never bothered.

I'm not quite sure I understand what you mean, but it sounds like you mean something we would love to have, namely the ability to have afpd talk to multiple Ethernet cards WITHOUT routing between the independent networks. At least that is what Apple means by multi-homing with multiple interfaces, as supported by AppleShare IP.

This would be a VERY NICE addition to netatalk, if it is possible. We have a number of installations where different companies have networks connected by Linux routers over IP, and it would be very convenient if they could transfer files from one network to another via an AFP server using AppleTalk. However, AppleTalk routing is exactly what they don't want, as the nets are supposed to be kept as separate as possible.

I can't believe I'm the only one who would be very pleased with this feature!

Sincerely,
Chris Ferebee

---

From: a sun <[email-masked]>
Date: Fri, 7 May 1999 13:31:55 -0700 (PDT)

I'm not quite sure I understand what you mean, but it sounds like you mean =
   something we would love to have, namely the ability to have afpd talk to =
   multiple Ethernet cards WITHOUT routing between the independent networks. =
   At least that is what Apple means by multi-homing with multiple =
   interfaces, as supported by AppleShare IP.

i take it that you mean that you want the appletalk stuff to work, but
you don't want to route appletalk between interfaces. ya sure, you
betcha. i just added the few necessary bits in. it'll be available via
the -dontroute flag. basically, it acts like the reverse of the
-router flag. i haven't really tested it, but it should be set up so
that you can turn off routing for a subset of interfaces if
desired. i'll let people know when the next snapshot is available for
testing.

-a
[email-masked]