Subject: [netatalk-admins] Where papd advertises the printers

From: "J. A. Landamore" <[email-masked]>
Date: Thu, 11 Nov 1999 09:24:07 +0000 (GMT)

On Tuesday 9th Nov. I asked the list about how to get papd to advertise printers 
in a zone other than the default zone.  I have been deafened by the silence.  
Does this mean that no-one knows how to do this, or is it so simple that is 
obvious to a 2 year old (it certainly isn't obvious to me)?  If it is so obvious 
could someone take the time to guide me in the correct direction please.

TIA for any help

John Landamore

------------- Begin Forwarded Message -------------

We have a problem.  Our site has dozens of zones.  I can get afpd to display in 
our zone, but papd insists on displaying in the default zone.  How can I force 
papd to display in our zone?

thanks

John Landamore			| Please re-install Universe |
Sys. Admin.			| and reboot                 |
				|                            |
e-mail:				|     Hogfather              |
[email-masked]	|   Terry Pratchett          |

Phone: 	+44 (0)116 2523410
Fax: 	+44 (0)116 2523604

------------- End Forwarded Message -------------

---

From: "Andy Daws" <[email-masked]>
Date: Thu, 11 Nov 1999 11:04:49 -0000

>in a zone other than the default zone.

The man info pages for papd don't give away much but looking at the source code it appears that you have to name your printer in papd.conf as something like name:LaserWriter@zone replacing name and zone with what ever you need.  Havn't actually tried this as my development kernal has broken appletalk but nobody else answered so I gave it a shot.

---

From: Jeremy Kemp <[email-masked]>
Date: Thu, 11 Nov 1999 07:12:49 -0600 (CST)

I have found this to be the easiest way to set the zone of my afpd server,
and althought I don't have a printer running off it, I'm pretty sure this
should work for papd as well.

On Thu, 11 Nov 1999, Andy Daws wrote:

> The man info pages for papd don't give away much but looking at the
> source code it appears that you have to name your printer in papd.conf
> as something like name:LaserWriter@zone replacing name and zone with
> what ever you need.  Havn't actually tried this as my development
> kernal has broken appletalk but nobody else answered so I gave it a
> shot.

Jeremy Kemp
<[email-masked]>

One of the main causes of the fall of the Roman
Empire was that, lacking zero, they had no way
to indicate successful termination of their C programs. 
-- Robert Firth