Subject: [netatalk-admins] permissions

From: "Jon Doyle" <[email-masked]>
Date: Sat, 27 Nov 1999 17:01:10 -0800

I have had some long nights trying to figure out the permissions in SAMBA. I had a situation where I want to have this one large RAID partition accessible to users on PC's and MAC's. I found that users could do whatever they wanted to files once I copied them over and CHMOD on them for rwx in their group. What I found was that new files they created or copied over were not able to be erased by other users of the same group. Obviously a UMASK problem.

Being new to Linux; but trying hard, I searched and found that there are some entries in Samba regarding the creation of files and directories. Are there similar settlings for Atalk?

Jon

Jon R. Doyle 
Systems Administrator
Document Solutions, Inc.
1611 Telegraph Avenue Ste. 1010
Oakland, Ca. 94612
510-986-0250

---

From: "P T Withington" <[email-masked]>
Date: Mon, 29 Nov 1999 10:16:23 -0500

This can all be done with Unix permissions.

If you give each user a private group, then they can run with umask 002 and files they create will still be private.

For the shared directory, 'chmod g+s' will cause all files created in that directory to have the same group as the directory (rather than the user's 'home' group), hence all users in that group will have read/write access.

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of
> Jon Doyle
> Sent: Saturday, November 27, 1999 8:01 PM
> To: [email-masked]
> Subject: [netatalk-admins] permissions
> 
> 
> I have had some long nights trying to figure out the permissions 
> in SAMBA. I had a situation where I want to have this one large 
> RAID partition accessible to users on PC's and MAC's. I found 
> that users could do whatever they wanted to files once I copied 
> them over and CHMOD on them for rwx in their group. What I found 
> was that new files they created or copied over were not able to 
> be erased by other users of the same group. Obviously a UMASK problem.
> 
> Being new to Linux; but trying hard, I searched and found that 
> there are some entries in Samba regarding the creation of files 
> and directories. Are there similar settlings for Atalk?
> 
> Jon
> 
> Jon R. Doyle 
> Systems Administrator
> Document Solutions, Inc.