Subject: Re: [netatalk-admins] Can't register ...

From: Claudiu Ivanescu <[email-masked]>
Date: Fri, 8 Jan 1999 10:47:10 +0000 ( )

On Tue, 6 Jan 1998, chris thoen wrote:

> I installed netatalk on a linux system (Dell optiplex GXpro 180 MHZ).  I
> used version 1.4b2, and 1 patch : afpd-macos8.diff (dncing icons)
> 
> When I start up my system, I get the message :
>  atalkd  nbp_rgstr:  Connection timed out
> Can't register chris-pc: Workstation@*
> nbp_rgstr: Connection timed out
> Can't register chris-pc: netatalk@*
> 
> The kernel is compiled on the right way, and /etc/services is modified.

Hi, i have just tried to use netatalk and i have the same problem, i was
browsing the archive and i saw you got the same problem.

Can u help me please. Thank you in advance

---

From: "Stefan Arbes" <[email-masked]>
Date: Sun, 10 Jan 1999 15:18:59 +0100 (CET)

>> The kernel is compiled on the right way, and /etc/services is modified.

I got the same problem on my linux system (kernel 2.0.36) and the solution (or the workaround, I don't 
know for shure;-)) was quite simple: in the startup script (on my system, atalk in the rc.d) the atalkd 
had been started using startproc; I removed the startproc:

        /usr/sbin/atalkd || return=$rc_failed
        /usr/bin/nbprgstr -p 4 `hostname|sed 's/\..*$//'`:Workstation
[...]
and now it works (there is a little delay between the start of atalkd and the nbp_rgstr on startup).
It seems to me, that the startup of the atalkd using startproc isn't completed when the nbp_rgstr tries 
to register.
I hope, I could help.

Stefan