Subject: [netatalk-admins] papd baling out with msg lp_init: lock: No such file...

From: Martin Stenzel <[email-masked]>
Date: Wed, 17 Feb 1999 08:16:35 +0100

Hello,

I am trying for several days now, still I am not succeeding:

An iMac is linked to my Linux box with attached printer  (Canon BJ
200e)at lp1 and I tried to make it execute print orders made from the
iMac.

I am using the following:

Kernel 2.0.36
netatalk 1.4.2b
ghostscript 3.33
MacOS 8.1

Since my printer is not a PostScript printer I tried to set it up with
help of the information given by Mike Pearson:
<http://artoo.hitchcock.org/~flowerpt/projects/linux-netatalk/ghostscript.html>

This is what I receive:

Feb  9 06:15:48 plum xntpd[398]: kernel pll status change 89
Feb  9 06:15:48 plum syslog: ROOT LOGIN ON tty1
Feb  9 06:16:19 plum papd[478]: child 619 done
Feb  9 06:16:40 plum papd[478]: child 633 for "gs10e" from 41201.173
Feb  9 06:16:41 plum papd[633]: lp_init: lock: No such file or directory

Feb  9 06:16:41 plum papd[633]: lp_open failed
Feb  9 06:16:42 plum papd[478]: child 633 done
Feb  9 06:17:30 plum afpd[617]: done
Feb  9 06:17:30 plum afpd[480]: asp_chld 617 done

My Mac tells me that the document could not be printed due to a
PostScript error (I like those "precise" error msgs!)
This is all of the information I receive.

I have to say that printing directly from Linux is possible.

My papd.conf should be set up properly.

#
# Attributes are:
#
# Name Type Default Description
# pd str ".ppd" Pathname to ppd file.
# pr str "lp" LPD printer name.
# op str "operator" Operator name, for LPD spooling.
#
gs10e:\
:pr=lpr -Plp:op=apple:pd=/usr/local/atalk/etc/PPD/APLWNTR1.PPD:

(I set it to pr=lp and pr=ps, too, the user I created is 'apple')

My paths.h starts with:

/*
 * papd paths
 */
#define _PATH_PAPDPRINTCAP      "/etc/printcap"
#ifdef ultrix
#define _PATH_PAPDSPOOLDIR      "/usr/spool/lpd"
#else ultrix
#define _PATH_PAPDSPOOLDIR      "/var/spool/lpd"
#endif ultrix
#ifdef BSD4_4
#define _PATH_DEVPRINTER        "/var/run/printer"
#else BSD4_4
#define _PATH_DEVPRINTER        "/dev/lp1"
#endif BSD4_4

I already found some more information in formerly posted messages,
means:
1.Instead of using e.g. 'lp' directly I tried to pipe it with 'lpr -Plp'

in papd.conf
2. I tried to install the LaserWriter driver version 8.4.1 instead of
8.5.1 but unfortunately my system hangs when trying this, so I had to
reinstall ver 8.5.1

Is netatalk ver 1.42b compatible with MacOS 8.1?

Any help would be greatly appreciated!

Thanks in advance, Martin.

################################################
# Computers are what you make of them...UNIX/Linux. #
################################################

--
+++++++++++++++++++++++++++++++++++++
+    M A R T I N   S T E N Z E L    +
+++++++++++++++++++++++++++++++++++++
+ D-13156 Berlin-Niederschoenhausen +
+++++++++++++++++++++++++++++++++++++
+ e-mail:  [email-masked] +
+++++++++++++++++++++++++++++++++++++

---

From: Peter Whaite <[email-masked]>
Date: Thu, 18 Feb 1999 10:56:59 -0500

Martin Stenzel said:
> 
> An iMac is linked to my Linux box with attached printer (Canon BJ 200e)at
> lp1 and I tried to make it execute print orders made from the iMac.
> 

I have had similar experience with imac running macos 8.5.1 (french version),
and Aladdin gs-5.02 (and also gs-5.50).

> My Mac tells me that the document could not be printed due to a PostScript
> error (I like those "precise" error msgs!)  This is all of the information I
> receive.

I found that gs could not digest the imac postscript.  It crashes in the true
type font definitions (e.g. Geneva).  Documents containing only the standard
postscript fonts (e.g. helvetica) work.  Maybe that is your problem here too.
To check:

1. There is a printer option to print postscript error reports. Turn it on.
   If there is a postscript error the printer will produce a page showing
   where the error occurred.

2. Use the printer driver to save the postscript as an EPS file, then transfer
   the file to linux system via ftp.  It should not matter what mode is used
   for the transfer (binary/ascii), but try both just in case.  Try to display
   the transferred file using gs. 

If this is your problem I have no solution to offer.  Maybe there is some
magic ppd that induces the macos driver to produce digestible postscript, but I
didnt look that hard. Aladdin might have a patch for ghostscript.

In the end we bought a postscript printer (HP2100M) and installed it on linux.
No more problems.