Subject: [netatalk-admins] Q4.04-autosave with asun 2.1.29

From: [email-masked]
Date: Wed, 30 Jun 1999 20:02:47 +0200 (CEST)

kernel 2.2.10 on intel-hw
netatalk pre-asun2.1.4-29

clients: MacOS 8.1, Q-XPress 4.04

afpd.conf:
"
NetATalk -tcp
"

atalkd.conf:
"
eth0   -seed -phase 2 -net 49321 -addr 49321.100 -zone "our zone"
eth1   -seed -phase 2 -net 49320 -addr 49320.100 -zone "our zone"
eth2   -seed -phase 2 -net 49324 -addr 49324.100 -zone "our zone"
eth3   -seed -phase 2 -net 49325 -addr 49325.100 -zone "our zone"
"

(the net and zone stuff for some obsolete reasons but thats not important)

for traffic reasons the linux/.../ddp.c ist patched to don't route
therefore the 4 seeds:

"
shuttle:/usr/src/linux/net/appletalk# diff ddp.c ddp.c.ORG
1504,1505c1504
< /*    if (skb->pkt_type != PACKET_HOST || ddp->deh_dnet == 0) */
< if (1)
---
>               if (skb->pkt_type != PACKET_HOST || ddp->deh_dnet == 0)
"

Now something NEW happens, if the users ask there Q to don't autosave but
hold up to 5 or 10 Version in a folder on their local desktop they are no
more able to write on their NetATalk-Volumes.

What seems to happen is that Q puts an *.AutoSave Dokument in the shared
folder, if afterwars someone wants to save the replies are:
"write protected [-54]" or
"already open for writing [-49]"

this is new, in the former versions this never happened ...

Ok I have to blame me, i did the upgrade from kernel 2.0.36 to 2.2.10
and installing the pre-asun2.1.4-29 in the same night, maybe that
complicates the trouble-shooting a bit.

Any help would be appreciated, for i now only stopped that
"autosave"-behaviour and have no idea how to fix.

Thank You in advance,
Thomas

---

From: a sun <[email-masked]>
Date: Wed, 30 Jun 1999 12:14:14 -0700 (PDT)

strangeness. i've just sent a query to see who is really at fault
here. anyways, my next snapshot will change the reply codes to make
quark happy.

-a

---

From: Patrik Schindler <[email-masked]>
Date: Wed, 30 Jun 1999 21:13:49 +0200

>"already open for writing [-49]"

We discovered something similar with XPress 3 and EtherShare/Solaris 7.
XPress auto-saves documents with something like a serial number. If the XP-files have long names, there seems to be some sort of conflict.

I do not have exact information handy at the moment, but if you are interested, I will dig in to the thing again.

:wq! PoC