Subject: [netatalk-admins] File Associations

From: Jeremy Kemp <[email-masked]>
Date: Tue, 26 Oct 1999 08:23:46 -0500 (CDT)

Hi All,

I have my NetATalk shares setup, and I can access them from my OS 8.6 and
8.5.1 Macs, but I have one major problem: Every file comes up as a
SimpleText document. How do I fix it so that files have the correct
type/creator codes in the Finder? Thanks!

Jeremy Kemp
<[email-masked]>

---

From: Harry Zink/Netatalk List <[email-masked]>
Date: Tue, 26 Oct 1999 08:40:45 -0700

on 10/26/1999 6:23 AM, Jeremy Kemp at [email-masked] wrote:

> How do I fix it so that files have the correct

You need to have your Applevolumes.system file in the proper location.
netatalk needs to know what files to associate with what icons.

The basic disttribution does not install any Applevolumes.default or
Applevolumes.system files (might be a good idea to include them in an
install, as the 2.1.3 RPM installs them).

Harry
--

---

From: "Anthony L. Sollars" <[email-masked]>
Date: Tue, 26 Oct 1999 09:01:53 -0700

Dear Jeremy,

	Check out the AppleVolumes.system file, should be in /etc. It contains
the file mapping translations. Their could be an error in yours or
something. If atalkd doesn't recognize a file and the text flag is
active in this file it will view it as a text file. I will insert a copy
of my AppleVoumes.system file in this email to give you something to
look against.

 Sincerely,

--------------------------------------------------------------
Anthony L. Sollars
Technology Coordinator
Star of the Sea School
1411 Grand Ave.
Astoria, Or 97103
(503) 325-3771
[email-masked]
--------------------------------------------------------------

#
# This file is read before (after if -u is specified) the user's
# AppleVolume file.  Add extension mappings and volumes here.
#

# default translation -- note that CR <-> LF translation is done on all
# files of type TEXT.  The first line turns off translation for files of
# unknown type, the second turns this translation on.
.       BINA    UNIX
# .       TEXT    UNIX

# sounds
.mod    STrk    STrk
.mid    Midi    ttxt
.aiff   AIFF    SNdm
.wav    WAVE    SNdm
.au     ULAW    SNdm

# video
.moov   MooV    mMPG
.mov    MooV    mMPG
.mpg    MPEG    mMPG
.mpeg   MPEG    mMPG

# formatted text
.html   TEXT    MOS!
.rtf    TEXT    MSWD
.doc    WDBN    MSWD

# compressed archives
.bin    BINA    MB2P
.zip    ZIP     ZIP
.tar    TARF    TAR!
.gz     Gzip    Gzip
.Z      ZIVM    LZIV
.sea    ????    SITx
.cpt    PACT    CPCT
.sit    SIT!    SIT!
.hqx    TEXT    SITx

# graphics
.tiff   TIFF    JVWR
.tif    TIFF    JVWR
.bmp    BMPp    JVWR
.pct    PICT    ttxt
.pict   PICT    ttxt
.jpeg   JPEG    JVWR
.jpg    JPEG    JVWR
.gif    GIFf    JVWR

# If uncommented, this line would export the /tmp directory as
"Temporary".
#/tmp Temporary

---

From: Thierry Michalowski <[email-masked]>
Date: Tue, 26 Oct 1999 18:53:00 +0200

Of course, you _did_ note that the file names _must_ have the appropriate
extension for the mapping to work... :-)
Regards
Thierry Michalowski

--
Thierry Michalowski                                     /
Edipresse Publications S.A                 \\\' ,      / //
Informatique de Production                  \\\//    _/ //'
33,av. de la gare                            \_-//' /  //'
1001 LAUSANNE SUISSE                           \ ///  //'
phone: +41 21 349 46 26                        /  >>   \\\`
mailto:[email-masked]       /,)-^>>  _\`
                                              (/   \\ / \\\
"Unix is user-friendly...                           //  //\\\
It is just selective about who its friends are"    ((`