Subject: [netatalk-admins] Folder alias workaround

From: Michael May <[email-masked]>
Date: Wed, 30 Jun 1999 08:33:07 -0700

I figured out what appears to be a nice workaround for aliases to netatalk
volume folders. Typically, aliases to folders break after the first
session, usually pointing to another folder randomly. Aliases to files do
not seem to have the problem (I can only vouch for OS 8.5.1 &
netatalk-1.4b2+asun2.1.2).

So, here's the workaround: create an alias of your netatalk folder, keep it
on your netatalk volume (inside the original folder is tidy). Make an alias
to the alias, place that on your desktop (or wherever locally).

This seems to keep the alias from breaking. YMMV.

Mike

----------------------------
Michael May
San Francisco Estuary Institute
1325 S. 46th Street #180
Richmond, CA 94804
(510) 231-9539
(510) 231-9414 fax
www.sfei.org

---

From: Michael May <[email-masked]>
Date: Thu, 1 Jul 1999 19:21:47 -0700

At 8:33 AM -0700 6/30/99, Michael May wrote:
>Typically, aliases to folders break after the first

My apologies for any confusion, asun2.1.2 never existed. Checking as to the
actual version we're running...

---

From: "Andrew J. Hutton" <[email-masked]>
Date: Fri, 2 Jul 1999 11:22:55 -0400 (EDT)

netatalk-1.4b2+asun2.1.3

when users connect they only get offered their home directory,
AppleVolumes.default contains,

# Also see the AppleVolumes.system file
~	HOME
/home1/ftp	PUBLICFTP
/home1/httpd	=WEBSITE
/home2/s+padministration 	=ADMINISTRATION
#/home2/s+parchives	=ARCHIVES
/home3/s+parchives	=ARCHIVES1
#/home4/s+parchives2	=ARCHIVES2
/home2/s+pcommon 	=COMMON	
/home2/s+presources	=RESOURCES

Which worked before.

I'm in a real pinch on this and taking some serious heat over the
'upgrade' not working as well as the old one.

--
Achilles - Linux Support, Pre-Installed Workstations & Servers
Sponsor & Host of the Ottawa Linux Symposium, July 22-24th, 1999
http://www.ottawalinuxsymposium.org/ for more information.

---

From: "Chris G. Sellers" <[email-masked]>
Date: Fri, 2 Jul 1999 12:22:47 -0500 (EDT)

What happens when you make new entries like below in the
AppleVolumes.default where there is normally just  ~  which stand for
homedir?

Sellers

> 'upgrade' not working as well as the old one.

<(************************************************************)>

   CHRIS G. SELLERS		
   Scientific Programmer Analyst 	
    Information & Instructional Technology 
	(formerly Computer & Information Services)
    101  Kresge Library		 		  
    Oakland University - Rochester, Michigan 48309-4401	
    Phone: (248) 370.2016    FAX: (248) 370.4251

---

From: a sun <[email-masked]>
Date: Fri, 2 Jul 1999 10:47:44 -0700 (PDT)

/home1/httpd	=WEBSITE

asun2.1.3 mistakenly used = as an option delimiter. i've changed that
to : for asun2.1.4. so, for now, just don't use ='s.

-a

---

From: Michael May <[email-masked]>
Date: Wed, 7 Jul 1999 17:47:08 -0700

>actual version we're running...

OK, my wires are now uncrossed. We were running netatalk 1.4b2+asun2.1.1.

asun2.1.3 appears to fix the alias issue completely (thank you Adrian)...

Sorry for decreasing the signal to noise ratio...

Mike