Subject: [netatalk-admins] afpd: incorrect appledouble header

From: Robert Sweet <[email-masked]>
Date: Sat, 6 Feb 1999 20:19:30 -0800

Feb  6 20:15:34 robs afpd[622]: warning: incorrect appledouble header. run 
'adv1tov2 -v1compat' when you upgrade to asun2.2.0.

I have looked high and low for this, can someone point me to where to download 
this file or how to fix the incompatability? Or to I just delete all the 
.AppleDouble dirs?

tia
                     .........
Robert Sweet           `:::'                  .......  ......
[email-masked]       :::  *                  `::.    ::'
Gardner Lithograph      ::: .::  .:.::.  .:: .::  `::. :'
                        :::  ::   ::  ::  ::  ::    .::.
                        ::: .::. .::  ::.  `::::. .:'  ::.
                     ...:::.....................::'   .::::..
                                      The choice of a GNU generation
UNIX is user friendly. It's just selective about who its friends are.

---

From: "Steven N. Hirsch" <[email-masked]>
Date: Sun, 7 Feb 1999 18:09:21 -0500 (EST)

> this file or how to fix the incompatability? Or to I just delete all the 

For the second time, I'm posting a Perl script which I've used here to fix
an entire tree:

------------------- Cut Here ---------------------------
:	# -*-perl-*-
eval 'exec perl -w -S $0 ${1+"$@"}'
    if 0;

use strict;
use POSIX qw(fcntl_h);
use IO::File;
use File::Find;
use Cwd;

# Traverse desired filesystems

my $magic = pack "C4", 0x00, 0x05, 0x16, 0x07; 
my $adVersion = pack "C4", 0x00, 0x01, 0x00, 0x00;

sub fixADFiles {
  my $curdir = cwd();
  chdir('.AppleDouble');
  foreach ( glob '*' ) {
    my $fh = new IO::File;
    print "$_\n";
    $fh->open($_, O_WRONLY) || die "Can't open $File::Find::name: $!\n";
    $fh->print($magic);
    $fh->print($adVersion);
    $fh->close;
  }
  chdir($curdir);
}

sub wanted {
  my $globalSave = $_;

    (my ($dev,$ino,$mode,$nlink,$uid,$gid) = lstat($_)) &&
    -d _ &&
    /^\.AppleDouble$/ &&
    fixADFiles();

  $_ = $globalSave;
}

@ARGV == 1 || die "Usage: fixad <dir>\n";

my $dir = shift;

find(\&wanted, $dir);

exit;
-------------------Cut Here ----------------------------

---

From: Brian Reid <[email-masked]>
Date: Sun, 07 Feb 99 15:57:02 -0800

I'm so embarassed. In my attempts to protect myself against spam, I set
up an incoming mail filter that was resulting in my not seing messages
that had CC: netatalk-admins; only if it was TO: netatalk-admins did
the message make it past my silly filter.

I'm the big loser here, of course: I didn't see Steven Hirsch's kind
Perl program in time to use it to solve my big problem. I think I need
to re-work my spam strategy entirely, starting with turning it off.