Subject: [netatalk-admins] netatalk questions

From: admin <[email-masked]>
Date: Tue, 14 Dec 1999 09:49:08 -0600 (CST)

Hey all-

  I am new to netatalk usage, and I have a few questions.  First, is there
a troubleshooting guide/FAQ available that we can reference for
problematic issues other then the one at umich.edu (espically MacOS 8.x
probs)? Second, is the project still being actively developed?  Third, is
there a technical document(s) available that describes this seemingly
illogical method of sharing files (just what the heck are are these
.Appledoubles all over the !@##!% place!).  I still can't get over the
one-button mouse thing.

Regards,

Richard N. Fogle
Sysadmin
The IDF
www.theidf.com

---

From: ian reinhart geiser <[email-masked]>
Date: Tue, 14 Dec 1999 11:03:43 -0600 (CST)

I have  very bad feeling i know what the answer
is to this question but i am going to ask anyway.

Is there any way to get MacOS 9s Multiuser login
to interface with netatalk.  We have a new lab of
G4 systems and an exsisting Netatalk server. We
have always used MacLogin but it will not support
logins over Appleshare IP.  

Any Ideas?

thanks in advance

	-ian reinhart geiser

-------------------------------------------------
Ian Reinhart Geiser <[email-masked]>
DEC Unix Systems Adimistrator and
	Computer Engineering Student
http://www.msoe.edu/~geiseri/finger.phtml

---

From: admin <[email-masked]>
Date: Tue, 14 Dec 1999 14:01:46 -0600 (CST)

Thanks!  One of the probs I'm having is Mac users not being able to
see/use files that were copied/created by unix stations - we have one big
filesystem that is used by NFS for Linux/Solaris boxes, netatalk for the
Macs, and samba for like two win32 boxes.  The file server is linux.
  Will the Macs see/use the shares that don't have an .Appledouble in the
directory?  Also, we have problems with files disappearing (already
checked for Macuser probs), alias probs, and sometimes when the MacOS
8.x/9 users delete a file, the entire directory gets thrown in the
'Network Trash Folder' but doesn't physically disappear from the
filesystem (i.e., I can still see the files from a unix shell).  
  I'll check out the link below.. I'm surprised this isn't a bigger
'thing' in the unix community - these iMacs are like a plague of
translucent gumdrops in the corporate world and this package is great for
global filesharing.  

Rich

On Tue, 14 Dec 1999, Andrew Morgan wrote:

> 
> 
> On Tue, 14 Dec 1999, admin wrote:
> 
> A good web site for Netatalk help, links, and more is at:
> http://www.thehamptons.com/anders/netatalk/
> 
> Netatalk is still being developed.  Adrian Sun is working on v2.1.4 of his
> patches, and a few others (myself included) are working on papd.
> 
> Mac files have a data fork and a resource fork.  The data fork holds the
> usual file data while the resource fork contains Mac specific settings
> such as the icon, file creator settings, etc.  Netatalk uses the
> .AppleDouble directories to hold the resource forks for each file.
> Anytime you create a file on the Netatalk server from a mac, an
> .AppleDouble directory will be created.
> 
> 	Andy
> 
>

---

From: Andrew Morgan <[email-masked]>
Date: Tue, 14 Dec 1999 09:30:30 -0800 (PST)

Andy

---

From: Brian Bergstrand <[email-masked]>
Date: Wed, 15 Dec 1999 09:32:05 -0600 (CST)

> logins over Appleshare IP.  

Right now, there is not much you can do. But Apple is supposed to
be releasing an SDK Real Soon Now(tm) that will allow you
to develop authentication plug-ins for Mac OS 9's multi-user
support. When/if this happens you could write a plug-in to
authenticate to any AppleShare server, including netatalk.

-- 
Brian Bergstrand
Systems Programmer Northern Illinois University
Use the Source, Luke.