Subject: [netatalk-admins] Configuring a print server]

From: David Goodman <[email-masked]>
Date: Mon, 08 Nov 1999 20:32:03 -0600

Thanks to all who replied.  My problem was indeed an improper kernel config,
exacerbated by FreeBSD's lack of feedback via dmesg.

I have now rebuilt my kernel with NETATALK turned on.  After I rebooted, I
was able to start atalkd, and it was even nice enough to reconfigure my
atalkd.conf file with correct numbering.  After that, my print server could
see the zone I had specified.  However, the iMac could not, and it could not
see the print server either.  Any idea how to make the iMac see my zone?

Also, I seem to have a bigger problem.  I tried to start atalkd in my
rc.local, but I get this error message when my machine starts up:

Nov  8 20:11:08 FreeBSD atalkd[1809]: bind 41201.6:6: Address already in use
Nov  8 20:11:08 FreeBSD atalkd[1809]: bind 41201.6:6: Address already in use
AppleTalk not up! Child exited with 1.

Thanks,
- Dave

--
David Goodman
Sr. Applications Developer
Citadel Investment Group, LLC
(312) 696-2069
[email-masked]

-----Original Message-----
From: Yann Ramin [mailto:[email-masked]]
Sent: Thursday, November 04, 1999 7:22 PM
To: Goodman, David
Cc: [email-masked]
Subject: Re: [netatalk-admins] Configuring a print server

-----BEGIN PGP SIGNED MESSAGE-----

FreeBSD 3.2 does include support in the kernel.  You will have to go and
recompile it though.  Add the following line in your kernel config file:

options NETATALK

Just as a note, dmesg | grep AppleTalk won't work under FreeBSD.  The driver
(like IPX/NS/IP and almost any non-hardware probing code) doesn't confirm it
is
installed.

Yann

On Thu, 04 Nov 1999, you wrote:
>
> Hello,
>
> I'm trying to use an Intel NetportExpress PRO/100 print server to share my
> Epson printer between Windows and Macintosh machines.  The print server
> wants there to be at least one zone defined before it will enable
AppleTalk,
> so I started looking for AppleTalk routers, and found netatalk.  I have a
> 486 that is Running FreeBSD 3.2, and have installed the netatalk port.
>
> When I attempt to start atalkd, I get the following message:
>       socket: Protocol not supported
>
> I'm pretty sure that my version of FreeBSD comes with kernel support for
> DDP, but I can't seem to verify one way or the other if that is the
protocol
> atalkd is complaining about.
>
> Any suggestions?
>
> Thanks,
> - Dave
>
> --
> David Goodman
> Sr. Applications Developer
> Citadel Investment Group, LLC
> (312) 696-2069
> [email-masked]
>
>

--

--------------------------------------------------------------------
Yann Ramin                      [email-masked]
Atrus Trivalie Productions      www.redshift.com/~yramin
                                irm.it.montereyhigh.com
Monterey High IT                www.montereyhigh.com
ICQ                             46805627
Marina, CA

One of the main causes of the fall of the Roman
Empire was that, lacking zero, they had no way
to indicate successful termination of their C programs.
-- Robert Firth

--------------------------------------------------------------------

---

From: Brian Bergstrand <[email-masked]>
Date: Tue, 9 Nov 1999 08:54:35 -0600

> see the print server either.  Any idea how to make the iMac see my  
zone?
Are you connected to a switch that has the Spanning Tree protocol  
turned on?
If so, any Mac running 8.5 or above will have major problems with  
AppleTalk, and I have
even heard they have problems with IP. Check out   
http://til.info.apple.com/techinfo.nsf/artnum/n30922 for more info.

> AppleTalk not up! Child exited with 1.
Try 'nbplkup' to see if you can list the AppleTalk devices on your  
network. This could
also be related to the Spanning Tree problem, or your netatalk  
server might be getting
crap back from your router.

--
Brian Bergstrand
Systems Programmer, Northern Illinois University