Subject: Re: Re: [netatalk-admins] Netatalk and Samba?

From: Andreas Lehmann <[email-masked]>
Date: Tue, 14 Sep 1999 16:29:54 +0200

Tony Grant wrote:

> Now I am "losing" files - create a file on the Mac, save to shared
> directory, file is invisible to Dreamweaver on Win NT Workstation...
> Shared directory has .Appledouble etc

What kind of "loss" do you encounter? Is it a real loss on the server?
We just had a kind of such thing on our samba/netatalk server (with
shared shares) and could not point the reason. The files seem _really_
to be lost on the server, the free disk space increased within some
hours ... .

Regards

	-andreas

-- 
[email-masked]
Projektleiter IT
Private Fachhochschule Göttingen
tel: 0551.54700-135   mobil: 0177.5957157

---

From: Tony Grant <[email-masked]>
Date: Tue, 14 Sep 1999 19:50:46 +0200

> to be lost on the server, the free disk space increased within some

No real loss, the files are in the folder but only the Mac can see them.

Cheers

Tony Grant

---

From: Andreas Lehmann <[email-masked]>
Date: Wed, 15 Sep 1999 07:49:29 +0200

> No real loss, the files are in the folder but only the Mac can see them.

What about the free disk space seen by the windows clients? Do they see
the disk usage of the Mac files?

Andreas Lehmann

---

From: Hauke Fath <[email-masked]>
Date: Wed, 15 Sep 1999 09:52:44 +0200

>No real loss, the files are in the folder but only the Mac can see them.

 From my experience, this sounds like a filename "codepage" issue. I have 
been relatively successful in mapping both netatalk and samba filenames to 
ISO8859-1. This creates file names that can be reasonably dealt with in all 
NetBSD, MacOS and NT/W9x, although some chars unique to the MacOS cannot be 
used.

- ---------------------------------------------------------------------------- 
- -----

netatalk:  /usr/local/etc/AppleVolumes.default
- ---------

/local/atalk/Foo "Foo" codepage=maccode.iso8859-1 access=@foogrp

samba:  /etc/samba/smb.conf
- ------

#Global parameters

         character set = ISO8859-1
         client code page = 437

[Foo]

         create mask = 0770
         directory mask = 0770
         veto files = /.AppleDouble/.AppleDesktop/Network Trash 
Folder/DesktopFolderDB/resource.frk/
         mangled names = No

- ---------------------------------------------------------------------------- 
- -----

         hauke

- --
Hauke Fath                              Saphir Software GmbH
                                         D-69115 Heidelberg
[email-masked]                          Ruf +49-6221-13866-35, Fax -21