Subject: [netatalk-admins] Authentication with NIS

From: eirvine <[email-masked]>
Date: Mon, 22 Nov 1999 21:03:30 +1100

Howdy

I'm wondering if there is any reason why netatalk won't
authenticate on some NIS passwords.

I'm running as an NIS slave, on a new server, with the 
+::::: stuff at the bottom of my master.passwd and group file. 
I can telnet or samba into the machine fine, but when I try 
to connect with the apple chooser the password is rejected.

I can log in with netatalk to the NIS server machine. On that machine 
the account info is native to the master.passwd file.

Accounts local to the machine can log in fine. Curiously,
some other NIS accounts seem to work OK - these seem to be ones
with short passwords.
 
Any ideas? BTW I'm running FreeBSD 3.3 STABLE.
 
Eddie.

---

From: Brian Bergstrand <[email-masked]>
Date: Mon, 22 Nov 1999 10:39:14 -0600

> Any ideas? BTW I'm running FreeBSD 3.3 STABLE.

You mentioned long passwords. AppleShare is limited to 8 character  
passwords. Netatalk will not try to match just the first 8  
characters, so you must make sure all of your passwords are 8  
characters or less.

--
Brian Bergstrand
Systems Programmer, Northern Illinois University

---

From: eirvine <[email-masked]>
Date: Thu, 25 Nov 1999 18:28:54 +1100

Tim Carlson wrote:
> 
> On Mon, 22 Nov 1999, eirvine wrote:
> 
> what does /etc/shells look like on the slave

Bingo. The slave did not have /usr/bin/local/bash in /etc/shells

Thanks 
Eddie.