Subject: RE: [netatalk-admins] PPD files on server

From: Peter Gutowski <[email-masked]>
Date: 26 Mar 99 08:19:54 -0500

Reply to:   RE: [netatalk-admins] PPD files on server
System Administrator wrote:
> Hi, I have a question about the PPD files kept on the netatalk server.
> My papd.conf looks like:
> > [edv] Tek Phaser 560@Uni-Med-Neurophysiologie:\
> 	:pr=|/usr/local/bin/lpr -lPtek560 -Jpapd -Unetatalk:\
> 	:op=netatalk:\
> 	:pd=/usr/local/share/PPD/TKP560P1.PPD:
> > [edv] HP 4000@Uni-Med-Neurophysiologie:\
> 	:pr=|/usr/local/bin/lpr -lPhp4000 -Jpapd -Unetatalk:\
> 	:op=netatalk:\
> 	:pd=/usr/local/share/PPD/HP LaserJet 4000 Series:
> > This works, but I don't understand the duplicity of PPD files on the server
> and on the client.  I have the same PPD files on the client and on the
> server.  Is this necessary?
> > What I want is a way to set the values for extra features in the printers
> (like extra memory, what trays available, what media) at ONE place and
> have all the client Macs see this.  I have done this
> in the PPD files on the server, but the clients don't get the values.
> > What does netatalk actually do with the PPD files on the server?  It seems
> repetitious.
> > Thanks,
> > ..Howard
> In my understanding of this, the purpose of PPD files on the sending computer
is to avoid unnecessary postscript queries where the answer can be
determined from a local resource. For those situtions where netatalk is dealing
with a client that doesn't have that info, it needs to have its own resource to
be able to answer the question correctly on behalf of the printer for which it's acting as the spooler.

Conversly, if the [mac] clients believe that they have the correct answer to
a possible postscript query, they probably won't ask the question, which may
be why your clients "don't get the values."

Peter Gutowski

Power-Vue Graphics
[email-masked]
http://www.powervue.com/~peterg  << NEWLY UPDATED Jan 6, 1999 !!

---

From: "Jeremy J. Reichman" <[email-masked]>
Date: Fri, 26 Mar 1999 11:49:37 -0500

Some of this may depend on how your Mac clients are reaching the print queues.

If they are configured via AppleTalk ... some print servers will
communicate with the LaserWriter client so that the local computer gets
the right PPD and setup info automatically, no extra steps required. I
have seen different results, for example, with Windows NT 4 Servers vs.
Apple AppleShare IP servers. (Some print servers make a server print
queue look like a printer, others seem to tell the LaserWriter software
that it's a queue.)

If the clients are configured via LPR (for TCP/IP printing with
LaserWriter 8.5.1 or later), then you must use the Finder's Printing
menu to configure the available options for each desktop printer icon.
That, or create a new PPD (or modify an existing one) and put it on each
local computer's hard disk!

If you haven't set up an LPR print queue for a Mac, I have some
instructions that have proven useful on the official AppleShare IP
mailing list.

-- 
Jeremy J. Reichman
Interim HelpDesk Manager of Operations
ISC HelpDesk
Information and Technology Services
Rochester Institute of Technology
Rochester, New York, USA

Voice                       (716) 475-HELP (4357)
TTY                         (716) 475-2810
Fax                         (716) 475-5306
World Wide Web              <http://www.rit.edu/~jjracc/>
Electronic mail             <mailto:[email-masked]>

For computer-related questions at RIT, make the ISC HelpDesk your first
point of contact; it's available by:
-   voice at (716) 475-HELP (4357)
-   TTY at (716) 475-2810
-   electronic mail to "[email-masked]"
-   World Wide Web at <http://www.rit.edu/isc/>
-   walk-up in the Frank E. Gannett Bldg
    (Room 1113, right off the main lobby).