Subject: [netatalk-admins] Problems with papd providing ppd info to the mac

From: Alvise Nobile <[email-masked]>
Date: Sun, 4 Jul 1999 21:00:26 +0200 (CEST)

I have netatalk on Linux, to act as a print-server for some macs.
The mac's are supposed to see the printers as generic laserwriters, and
get some details about them from the ppd provided by the server.
It does not seem to work. Has anyone seen something like that and knows a
workaround?. Here is my bug report:

============================================================
Subject:
============================================================
Faulty communication of PPD contents from papd to MAC

============================================================
Environment:
============================================================

netatalk 1.4b2 on both Linux Red Hat 5.1 and 6.0

	netatalk 1.4b2+asun2.1.3-4 as distributed from RedHat contrib 
		archive

	Linux kernel 2.2.5-15 (For RedHat 6.0 : Plain RedHat 6.0)
	Linux kernel 2.0.34   (For Redhat 5.1)

Mac GS/3 with MacOS 8.5.1

Printers: 
	HP 4000N  (ppd from HP)
	HP 2000C  (Windows PPD from HP)
	Epson StylosPro 8500 (with Birmy PowerRip Postscript  stuff)
============================================================
Description:
============================================================
All the printers are controlled by a Linux box. 
	I want the Linux box to inform the Mac's about 
	the characteristics of the printer (colour; 
	double-sided; Postscript level; memory). (I realize 
	Double-sided is not supported, by now...)
papd configured to advertize them to Mac clients: papd configuration file
contains path of ppd files, ppd files downloaded from manufacturers.
Printers are visible to the chooser, with their UNIX names, as configured 
in papd.
One clicks 'setup' from the chooser, and then 'Autosetup' 
and then one arrives to the 'ppd selection' window. Selecting 'Generic'
apparently everything goes well. >>>>BUT then, looking at the Printer Info,
one gets: 
1) For the Epson, Product name, Postscript Version and Postscript Revision ,
   and Color Supported are right; Postscript Level is wrong (1 instead of 2), 
   all the other parameters are empty(while resolution and memory should be not)
2) For the HP printers, more or less all the parameters are nonsense
   (Product Name is 22000000, which in the ppd is *FreeVM; some other numbers
   like resolution etc are non recognizable)

The PPD for HP 4000 are the ones HP distributes the MAC. 
There are no recognizable difference
in style between PPD's for Epson and HP. 
Using the Epson ppd file with values changed to reflect HP values works 
to the same extent as the Epson (Product OK, colour OK, not the rest)
================================================================
Repeat-By
================================================================
Any attempt to configure the printer as advertized by papd from the chooser

Alvise Nobile,		    Scientific Computing Section
The Abdus Salam International Centre for Theoretical Physics
Address: str. Costiera 11, I-34100 Trieste, Italy
Tel: +39-040-2240-391       Fax: +39-040-224163/224559

---

From: "Espen H. Koht" <[email-masked]>
Date: Mon, 5 Jul 1999 19:07:12 +0100 (BST)

> workaround?. Here is my bug report:

This is an indirect answer to your question, but I've found that moving
printing to PPR has simplified my life tremendously. It takes advantage of
some of netatalks features for getting in touch with AppleTalk printers,
but seems to have its own PAP server which is far easier to set up. Take a
look at:  http://tarzan.trincoll.edu/printing/pprfaq.html

Espen

---

From: Eddie Irvine <[email-masked]>
Date: Tue, 06 Jul 1999 09:50:53 +1000

Hi,

Did you use the Mac software that came with your HP4000 to *make* the
ppd?

-- 
 
Eddie

http://www1.tpgi.com.au/users/eirvine/index.html
________________________________________________