Subject: [netatalk-admins] nbp_rgstr: Connection timed out

From: Simon Buchanan <[email-masked]>
Date: Thu, 03 Jun 1999 09:51:53 +1200

Hi.. 

Trying to run netatalk-1.4b2+asun2.1.3-4 on RH5.2/i386

Installed via rpm (contrib.redhat.com), and edited the
AppleVolumes.default etc.

start atalk via :/etc/rc.d/init.d/atalk start

It spits ":Starting AppleTalk services (backgrounded)" back at me... so
far so good.

Waits a while.. then:

nbp_rgstr: Connection timed out
Can't register narcotic:Workstation@*
npb_rgstr: Connection timed out
Can't register narcotic:netatalk@*

and stops.

Anyone know what to do?

-- 
Simon Buchanan
Systems Administrator
New Media Communications
===================================================
[email-masked]           www.newmedia.net.nz

---

From: Rob Cascella <[email-masked]>
Date: Thu, 3 Jun 1999 10:34:13 -0400 (EDT)

< Waits a while.. then:
< 
< nbp_rgstr: Connection timed out
< Can't register narcotic:Workstation@*
< npb_rgstr: Connection timed out
< Can't register narcotic:netatalk@*
< 
< and stops.
< 
< Anyone know what to do?
< 

Looks like you don't have Appletalk support.  You should be able
to access the box via Appleshare over TCP/IP.  Try that and see.

If that works, the problem is that your kernel isn't able to
support the Appletalk protocol.  Recompile or get the module for
your particular kernel.

-rob.
-- 
Rob Cascella, Manager of IT Services
Della Femina/Jeary and Partners
[email-masked]

---

From: Simon Buchanan <[email-masked]>
Date: Fri, 04 Jun 1999 08:24:22 +1200

> to access the box via Appleshare over TCP/IP.  Try that and see.

Yes, this works.

> support the Appletalk protocol.  Recompile or get the module for

But it was working a while ago... but i dont know what i did.

Some strange messages thou:

this:

Jun  3 14:02:26 narcotic atalkd[444]: restart (1.4b2+asun2.1.3)
Jun  3 14:02:27 narcotic atalkd[444]: zip_getnetinfo for eth0
Jun  3 14:02:36 narcotic atalkd[444]: zip_getnetinfo for eth0
Jun  3 14:02:46 narcotic atalkd[444]: zip_getnetinfo for eth0
Jun  3 14:02:56 narcotic atalkd[444]: as_timer multiple interfaces, no
seed
Jun  3 14:02:56 narcotic atalkd[444]: as_timer can't configure eth0
Jun  3 14:02:56 narcotic atalkd[444]: as_timer waiting for router
Jun  3 14:02:56 narcotic atalkd[444]: ready 0/0/0
Jun  3 14:02:57 narcotic papd[504]: restart (1.4b2+asun2.1.3)
Jun  3 14:03:07 narcotic afpd[513]: Can't register narcotic:AFPServer@*
Jun  3 14:03:07 narcotic afpd[513]: ASIP started on 202.27.193.34:548(0)
(1.4b2+asun2.1.3)

and this all the time:

Jun  3 16:35:00 narcotic atalkd[444]: nbp lkup sendto 41201.78: Network
is unreachable

---

From: Patrik Schindler <[email-masked]>
Date: Fri, 4 Jun 1999 18:39:00 +0200

>Can't register narcotic:netatalk@*

Yes, tell us what you see in the syslog.

:wq! PoC

---

From: Patrik Schindler <[email-masked]>
Date: Fri, 4 Jun 1999 18:51:14 +0200

>Jun  3 14:02:56 narcotic atalkd[444]: as_timer multiple interfaces, no

You've more than one network card but not configured netatalk to do seeding (tell the network it's configuration).

>Jun  3 14:02:56 narcotic atalkd[444]: as_timer waiting for router

So there's no other seeding router found on the net connected to eth0. atalkd can't guess what configuration you want on eth0 and on eth1, so you'll have to tell it:

- to use only one network interface (in atalkd.conf you must have only one line with eth0, the rest is filled out by atalkd automatically)
- to seed and thus to configure the network itself. Example see below.

So I've two NIC in my server and told to seed:

eth0 -seed -phase 2 -net 11 -addr 11.2 -zone "Ether"
eth1 -seed -phase 2 -net 13 -addr 13.1 -zone "Ether"

If you have many Macs and/or printers, you may even give a range: -net 13-20.

>Jun  3 16:35:00 narcotic atalkd[444]: nbp lkup sendto 41201.78: Network

Of course, because without router no packets could be forwarded.

:wq! PoC