Subject: [netatalk-admins] File Permissions.

From: Nitin Mule <[email-masked]>
Date: Mon, 17 May 1999 12:03:23 -0300

Hi all,

I've netatalk 1.4.b2 running on a redhat 5.2 linux box. When I create files
from Mac, the files 
are created with rw-rw-r-- permissions on linux. How do I configure these
default settings? Is there any option to force netatalk to create files
with a desired owner, group, and mode? Is there something simnilar to force
user, force group, force create mode, and force directory mode options of
Samba? 

TIA,
Nitin.

---

From: Peter Gutowski <[email-masked]>
Date: 17 May 99 12:36:26 -0400

Reply to:   RE: [netatalk-admins] File Permissions.
I asked this question a while ago and don't recollect seeing a response. But what I did finally remember and it seems to be born out by my experience: new files are created with a combination of permissions 666, [umask settings (I think) ] and permissions of the current directory.

If the file was being created in a directory with permissions 770 (i.e. no guest access, but full group permissions) then the file should show up with permissions of 660 (note: guest permissions stripped away). I'm not sure how or whether umask settings have any effect.

Peter Gutowski

Power-Vue Graphics
[email-masked]
http://www.powervue.com/~peterg

Nitin Mule wrote:
> from Mac, the files > are created with rw-rw-r-- permissions on linux. How do I configure these
> Samba? > > TIA,
> > RFC822 header
> -----------------------------------
> >  Return-Path: <[email-masked]>
>  Received: from terminator.rs.itd.umich.edu ([email-masked] > [141.211.164.2])
>  	by powervue.com (8.8.8/8.8.8) with ESMTP id LAA27850
>  	for <[email-masked]>; Mon, 17 May 1999 11:14:18 -0400
>  Received: from localhost (daemon@localhost)
>  	by terminator.rs.itd.umich.edu (8.8.8/2.5) with SMTP id MAA10399; Mon, 17 > May 1999 12:00:03 -0400 (EDT)
>  Received: by terminator.rs.itd.umich.edu (bulk_mailer v1.5+); Mon, 17 May > 1999 11:59:38 -0400
>  Received: (from majordom@localhost)
>  	by terminator.rs.itd.umich.edu (8.8.8/2.5) id LAA10344
>  	for netatalk-admins-list; Mon, 17 May 1999 11:59:37 -0400 (EDT)
>  Received: from redheat.rs.itd.umich.edu (redheat.rs.itd.umich.edu > [141.211.83.36])
>  	by terminator.rs.itd.umich.edu (8.8.8/2.5) with ESMTP id LAA10331
>  	for <[email-masked]>; Mon, 17 May 1999 > 11:59:28 -0400 (EDT)
>  Received: (from root@localhost)
>  	by redheat.rs.itd.umich.edu (8.8.5/2.5) with X.500 id LAA28099
>  	for [email-masked]; Mon, 17 May 1999 > 11:59:26 -0400 (EDT)
>  Received: (from root@localhost)
>  	by redheat.rs.itd.umich.edu (8.8.5/2.5) with X.500 id LAA28092
>  	for [email-masked]; Mon, 17 May 1999 11:59:26 > -0400 (EDT)
>  Received: from mail01.cable.com (mail01.cable.com [204.92.64.7])
>  	by redheat.rs.itd.umich.edu (8.8.5/2.5) with ESMTP id LAA28072
>  	for <[email-masked]>; Mon, 17 May 1999 11:59:24 -0400 (EDT)
>  Received: from tarkin (user66.pulsus.com [205.210.249.66])
>  	by mail01.cable.com (8.9.1/8.9.1) with SMTP id NAA14669
>  	for <[email-masked]>; Mon, 17 May 1999 13:22:39 -0400 (EDT)
>  Message-Id: <[email-masked]>
>  X-Sender: [email-masked]
>  X-Mailer: Windows Eudora Pro Version 3.0.1 (32)
>  Date: Mon, 17 May 1999 12:03:23 -0300
>  To: [email-masked]
>  From: Nitin Mule <[email-masked]>
>  Subject: [netatalk-admins] File Permissions.
>  Mime-Version: 1.0
>  Content-Type: text/plain; charset="us-ascii"
>  Sender: [email-masked]
>  Status:   >