Subject: [netatalk-admins] problems compiling afpd

From: [email-masked] (Roland Wong)
Date: Wed, 10 Feb 1999 11:08:34 -0500

MkLinux on stock 7300/200, 2.0.33 kernel, and I'm using the PTF
distribution (think it's based on redhat).

everything else seems to be compiling properly, except afpd.  I've
attached diffs of the modified makefiles vs the defaults.  I've
downloaded the des libs (the make exited without errors on that one) and
put des.h and libdes.a in the expected places (but I don't think that's
the problem).

any help would be super appreciated.
--
Jordan McGrath Case & Partners
212/463-1235
25c25
< CC=	gcc
---
> CC=	cc
3c3
< #DESTDIR=/usr/local/atalk
---
> DESTDIR=/usr/local/atalk
6c6
< #SBINDIR=$(DESTDIR)/etc
---
> SBINDIR=$(DESTDIR)/etc
8c8
< #BINDIR=$(DESTDIR)/bin
---
> BINDIR=$(DESTDIR)/bin
10c10
< #LIBDIR=$(DESTDIR)/lib
---
> LIBDIR=$(DESTDIR)/lib
12c12
< #RESDIR=$(DESTDIR)/etc
---
> RESDIR=$(DESTDIR)/etc
14c14
< #ETCDIR=$(DESTDIR)/etc
---
> ETCDIR=$(DESTDIR)/etc
16c16
< #INCDIR=$(DESTDIR)/include
---
> INCDIR=$(DESTDIR)/include
19c19
< #MANDIR=$(DESTDIR)/man
---
> MANDIR=$(DESTDIR)/man
21,27c21,27
< SBINDIR=/usr/sbin
< BINDIR=/usr/bin
< LIBDIR=/usr/lib
< RESDIR=/usr/lib/atalk
< ETCDIR=/etc
< INCDIR=/usr/include
< MANDIR=/usr/man
---
> #SBINDIR=/usr/sbin
> #BINDIR=/usr/bin
> #LIBDIR=/usr/lib
> #RESDIR=/usr/lib/atalk
> #ETCDIR=/etc
> #INCDIR=/usr/include
> #MANDIR=/usr/man
41c41
< #PAMDIR=/usr
---
> PAMDIR=/usr
9,10c9
< #AFPLIBS=-lrpcsvc  # this here is the original line
< AFPLIBS=
---
> AFPLIBS=-lrpcsvc
nfsquota.o: In function `getnfsquota':
nfsquota.o(.text+0x206): undefined reference to `xdr_getquota_args'
nfsquota.o(.text+0x20a): undefined reference to `xdr_getquota_rslt'
nfsquota.o(.text+0x21a): undefined reference to `xdr_getquota_args'
nfsquota.o(.text+0x21e): undefined reference to `xdr_getquota_rslt'
collect2: ld returned 1 exit status
make[4]: *** [afpd] Error 1
make[4]: Leaving directory `/usr/local/src/netatalk-1.4b2+asun2.1.1/etc/afpd'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/usr/local/src/netatalk-1.4b2+asun2.1.1/etc/afpd'
make[2]: *** [afpd] Error 2
make[2]: Leaving directory `/usr/local/src/netatalk-1.4b2+asun2.1.1/etc'
make[1]: *** [../../etc] Error 2
make[1]: Leaving directory `/usr/local/src/netatalk-1.4b2+asun2.1.1/sys/linux'
make: *** [all] Error 2 dd

---

From: Stephen Boulet <[email-masked]>
Date: Sun, 14 Feb 1999 01:10:07 -0600

Can someone help me solve this error?  :

gcc    -O2 -fsigned-char -I../../include   -DAPPLCNAME -DCRLF    -c
afs.c -o afs.o
gcc    -O2 -fsigned-char -I../../include   -DAPPLCNAME -DCRLF    -c
kuam.c -o kuam.o
gcc    -O2 -fsigned-char -I../../include   -DAPPLCNAME -DCRLF    -c
send_to_kdc.c -o send_to_kdc.o
gcc    -O2 -fsigned-char -I../../include   -DAPPLCNAME -DCRLF    -c
lifetime.c -o lifetime.o
gcc    -O2 -fsigned-char -I../../include   -DAPPLCNAME -DCRLF    -c
ofork.c -o ofork.o
gcc    -O2 -fsigned-char -I../../include   -DAPPLCNAME -DCRLF  \
    -D_PATH_AFPDDEFVOL=\"/usr/local/atalk/etc/AppleVolumes.default\" \
    -D_PATH_AFPDSYSVOL=\"/usr/local/atalk/etc/AppleVolumes.system\" \
    -DVERSION=\"`cat ../../VERSION`\" \
     -c main.c
main.c: In function `main':
main.c:255: `TIOCNOTTY' undeclared (first use this function)
main.c:255: (Each undeclared identifier is reported only once
main.c:255: for each function it appears in.)
make[4]: *** [main.o] Error 

Thanks.

-- 

Stephen

Grayslake, IL, USA
spboulet at enteract dot com

---

From: Bernard Paris <[email-masked]>
Date: Thu, 25 Feb 1999 09:16:51 +0200

I did the following:  insert this line in source main.c of afpd directory:
include <asm/ioctls.h>.
(you can find in this file: #define TIOCNOTTY      0x5422).

Watch out:
I deed a mistake in a previous message while indicating "include
<asm/ioctl.h>" instead of "include <asm/ioctls.h>" (ending 's').

Bernard.