Subject: [netatalk-admins] Login problems

From: "Michael Mercier" <[email-masked]>
Date: Fri, 06 Aug 1999 13:43:35 -0600

I am having a problem with users logging on to netatalk.  I am running
pre-asun2.1.4-35 on a Solaris 7 x86 box.  This is how I have my
afpd.conf configured.
- -uamlist uams_clrtxt.so -nosavepassword

Whenever a user tries to login they get a password not correct error.
If I change afpd.conf to be
-
I can successfully log the guest account in but not users.
I previously have pre-asun2.1.4-34 (I think) compiled and running
properly with the same afpd.conf configuration..
I compiled pre-asun2.1.4-35 with gcc2.95
Has anyone else experienced this problem or have any solutions?

Mike

---
Michael Mercier
System Support
Student Computer Labs
University of Lethbridge

---

From: Roman Czyborra <[email-masked]>
Date: Mon, 9 Aug 1999 11:43:21 +0200 (MEST)

> I am having a problem with users logging on to netatalk.  I am
> running pre-asun2.1.4-35 on a Solaris 7 x86 box.  I can
> successfully log the guest account in but not users.  Has anyone
> else experienced this problem or have any solutions?

You might have to add the user's login shell to /etc/shells - the
standard Solaris 7 /etc/syslog.conf discards the hint
syslog(LOG_INFO,"illegal shell %s for %s",...) from etc/afpd/auth.c.

---

From: "Michael Mercier" <[email-masked]>
Date: Mon, 09 Aug 1999 14:42:11 -0600

Roman,

Thanks, this has fixed the problem.  I did not need the /etc/shells with
the previous version I downloaded but I was using ksh for all users.
With the new build, all users have bash as their login shell.  This
seems to be what has caused the problem.

Mike

---
Michael Mercier
System Support
Student Computer Labs
University of Lethbridge