Subject: [netatalk-admins] TCP wrapper

From: Robert G Palmer Jr <[email-masked]>
Date: Tue, 27 Apr 1999 10:11:28 -0400

In the Makefile, I can only get the binaries to build if
I comment out the TCPWRAPPER line.  The comment says that
it is highly recommended to have TCP wrapper support.

OK, first, what is TCP Wrapper support?  Second, when would
I or wouldn't I need it?  Third, where do I find the 
libraries and the header files?

<<-------------------------------------------------------------->>
Robert G. Palmer, Jr.             1009 Commerce Park Drive
[email-masked]                  Oak Ridge, TN 37830
Development Engineer              Voice: (423)-482-3000
Interactive Pictures Corp.        FAX:   (423)-482-5447
http://www.ipix.com              
               -------------------------------------
Any opinions stated herein are solely mine.  In no way, shape,
or form should they be construed as opinions of my employer.
<<-------------------------------------------------------------->>

---

From: "James S. White" <[email-masked]>
Date: Tue, 27 Apr 1999 09:41:14 -0500 (CDT)

TCP Wrappers is a program written by Wietse Venema. It adds MUCH security
and control to inetd. 

ftp://ftp.porcupine.org/pub/security/index.html

You don't have to use it. I just know I sleep better having it running. :)

 ---------------------------------------------------------------------------- 
| James S. White                              www.vetmed.auburn.edu/~whitej4 |
| Sys/Net Administrator                            [email-masked] |
| Auburn University College of Veterinary Medicine             (334)844-3705 |
 ---------------------------------------------------------------------------- 
The complete lack of evidence is the surest sign that the conspiracy is working.

---

From: Joergen Persson <[email-masked]>
Date: Tue, 27 Apr 1999 19:42:20 +0200

>TCP Wrappers is a program written by Wietse Venema. It adds MUCH security

What to do if you don't want to use the ordinary TCP Wrapper or inetd?

I'm running TCPserver myself (http://pobox.com/~djb/ucspi-tcp.html, tools
for building TCP client-server applications with the ability to act as an
tcpwrapper. I consider it to be more safe and efficient compared to inetd).
Does anyone have any experience or general ideas?

---
Joergen Persson
Sysadmin TLTH