Subject: [netatalk-admins] Where papd advertises the printers

From: "J. A. Landamore" <[email-masked]>
Date: Tue, 9 Nov 1999 12:29:00 +0000 (GMT)

We have a problem.  Our site has dozens of zones.  I can get afpd to display in 
our zone, but papd insists on displaying in the default zone.  How can I force 
papd to display in our zone?

thanks

John Landamore			| Please re-install Universe |
Sys. Admin.			| and reboot                 |
				|                            |
e-mail:				|     Hogfather              |
[email-masked]	|   Terry Pratchett          |

Phone: 	+44 (0)116 2523410
Fax: 	+44 (0)116 2523604

---

From: Howard Schultens <[email-masked]>
Date: Thu, 11 Nov 1999 20:03:42 +0100

"J. A. Landamore" wrote:
> 
> On Tuesday 9th Nov. I asked the list about how to get papd to advertise printers
> in a zone other than the default zone.  I have been deafened by the silence.
> Does this mean that no-one knows how to do this, or is it so simple that is
> obvious to a 2 year old (it certainly isn't obvious to me)?  If it is so obvious
> could someone take the time to guide me in the correct direction please.
>

The netatalk documentation is minimal, to put it mildly.

What works for me is to include the name of the zone in the
printer definition in papd.conf.  For example:

HP 4000@Uni-Med-Neurophysiologie:\
        :pr=|/usr/local/bin/lpr -lPhp4000 -Jpapd -Unetatalk:\
        :op=netatalk:\
        :pd=/usr/local/share/PPD/HP LaserJet 4000 Series:

will advertise a  printer with the name "HP 4000" in the zone
"Uni-Med-Neurophysiologie" rather than the default zone (which is
called "Uni-Med-Physiologie" here).

-- 
--------------------------------------------------------------------
Dipl.-Phys. H.Schultens     Tel: +49 551 39-5914
Zentrum Physiologie         FAX: +49 551 39-5923
Humboldtallee 23
37073 Goettingen       mailto:[email-masked]
Germany               http://www.neuro-physiol.med.uni-goettingen.de
--------------------------------------------------------------------