Subject: [netatalk-admins] Accentued letter printing problem

From: "Guillaume Menguy" <[email-masked]>
Date: Tue, 9 Nov 1999 17:22:25 +0100

Hi,

I have a linux box running redhat6.1 + pre-asun2.1.4-36 and samba.
When I try to print from a PC, the output is okay.
When I print from a Mac, the accentuated characters are replaced by spaces.
When on a mac I chose "always download fonts to the printer", it sometimes work, sometimes not. I think it depends on the fonts installed on the mac.
And when the macs print throught an NT server, it always rocks.
Perhaps the NT server automatically send the fonts to the printer ? How can I force the Linux Box to act the same way?
Any Idea ?

Thanks.

G. Menguy

---

From: Thierry Michalowski <[email-masked]>
Date: Tue, 09 Nov 1999 18:02:21 +0100

Your problem sounds like a TrueType fonts related one. This is not
necessarily related to the Linux or NT server: I have the same problem
when printing _directly_ (no spooler, no server) to an HP 4MV printer
from a Mac. I had to select "prefer TrueType" font and so on in the
printing configuration dialog box for it to print everything ok. So,
I assume you can deal with this problem with your Mac's configuration.

Hope this helps
Thierry Michalowski

Guillaume Menguy wrote:

> Hi, I have a linux box running redhat6.1 + pre-asun2.1.4-36 and
> samba.When I try to print from a PC, the output is okay.When I print
> from a Mac, the accentuated characters are replaced by spaces.When on
> a mac I chose "always download fonts to the printer", it sometimes
> work, sometimes not. I think it depends on the fonts installed on the
> mac.And when the macs print throught an NT server, it always
> rocks.Perhaps the NT server automatically send the fonts to the
> printer ? How can I force the Linux Box to act the same way?Any Idea ?
> Thanks. G. Menguy

--
Thierry Michalowski                                     /
Edipresse Publications S.A                 \\\' ,      / //
Informatique de Production                  \\\//    _/ //'
33,av. de la gare                            \_-//' /  //'
1001 LAUSANNE SUISSE                           \ ///  //'
phone: +41 21 349 46 26                        /  >>   \\\`
mailto:[email-masked]       /,)-^>>  _\`
                                              (/   \\ / \\\
"Unix is user-friendly...                           //  //\\\
It is just selective about who its friends are"    ((`
============================================================================
This message has been checked with GRIMEsweeper which has detected a virus
embedded in this plain text message. You should now delete your entire hard
drive and rinse your eyes with soapy water to ensure it doesn't spread.

---

From: "P T Withington" <[email-masked]>
Date: Tue, 9 Nov 1999 14:29:51 -0500

The root of the problem is that the character encodings are different for the Mac and PC.  Is your Mac set up to use the correct PPD for the printer?  I believe you can put the .ppd file in the spool directory for your printer and netatalk will pass this back to the mac when you do Setup in the Chooser.

---

From: Harry Zink/Netatalk List <[email-masked]>
Date: Tue, 09 Nov 1999 16:49:48 -0800

on 11/9/1999 11:29 AM, P T Withington at [email-masked] wrote:

> I believe you can put the .ppd file in the spool directory for your printer
> and netatalk will pass this back to the mac when you do Setup in the Chooser.

PLEASE - if someone has figured out how to properly use and install ppd
files on the linux side of the netatalk equation, so that the Mac can
properly see the printer's capabilities in the chooser, I'd be ecstatic...

Include proper permissions for the files to boot, and you'd be God.

Harry

---

From: "Guillaume Menguy" <[email-masked]>
Date: Wed, 10 Nov 1999 11:20:12 +0100

That's done. But I found later that upgrading the local fonts on the mac
solve the problem.
Thanks everybody.
G.Menguy

----- Original Message -----
From: P T Withington <[email-masked]>
To: Thierry Michalowski <Thierry.Michalowski>; Guillaume Menguy <gmenguy>
Cc: netatalk mailing list <netatalk-admins>
Sent: Tuesday, November 09, 1999 8:29 PM
Subject: RE: [netatalk-admins] Accentued letter printing problem

The root of the problem is that the character encodings are different for
the Mac and PC.  Is your Mac set up to use the correct PPD for the printer?
I believe you can put the .ppd file in the spool directory for your printer
and netatalk will pass this back to the mac when you do Setup in the
Chooser.

---

From: "P T Withington" <[email-masked]>
Date: Wed, 10 Nov 1999 08:30:07 -0500

Gee, I have this working.  I didn't know it was a big mystery.

AFAIK all I did was 'man papd'.  Here is my /etc/papd.conf

Iridium Spooler:\
 :pd=/usr/spool/lpd/iridium/aplwsel.ppd:\
 :pr=Iridium:

Presumably you can put the ppd anywhere, but you know the printer daemon has access to it's spool dir, so that seemed a good choice.  My permissions:

drwxrwxr-x   2 root     lp           2048 Nov  8 12:25 /var/spool/lpd/iridium/

-rw-rw-r--   1 root     root        21723 Sep  5  1998 /var/spool/lpd/iridium/aplwsel.ppd

PPD's can be gotten from the printer manufacturer, but I think I just opened the PPD that was on a Mac in BBEdit and saved it as a text file.  I used the '*PCFileName' from the PPD as the file name just for consistency -- I don't think it is important.

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of
> Harry Zink/Netatalk List
> Sent: Tuesday, November 09, 1999 7:50 PM
> To: P T Withington; Thierry Michalowski; Guillaume Menguy
> Cc: netatalk mailing list
> Subject: Re: [netatalk-admins] Accentued letter printing problem
> 
>