Subject: [netatalk-admins] atalkd won't start: too many routes/iface

From: [email-masked] (Markus Boie)
Date: Mon, 28 Jun 1999 21:27:05 +0200

Hello,

I just installed the latest netatalk version on a RedHat 6.0 system with kernel version 2.2.10. Everything compiles well and the binaries work.

The machines has two network interface cards connecting to the same network, ip-forwarding is disabled.

atalkd.conf says nothng but

	eth1

When I try to start atalkd i get a message

	kernel: too many routes/iface

Looking at the log file I see that atalkd managed to get an AppleTalk address from the network.

Has anyone else encountered this problem?

Thanks for your time
Markus

---

From: "Chris G. Sellers" <[email-masked]>
Date: Tue, 29 Jun 1999 08:09:35 -0500 (EDT)

There should be an RPM for Netatalk in the RH distribution.  You may have 
luck with that unless your looking to be on the cutting edge! :)

> Has anyone else encountered this problem?

<(************************************************************)>

   CHRIS G. SELLERS		
   Scientific Programmer Analyst 	
    Information & Instructional Technology 
	(formerly Computer & Information Services)
    101  Kresge Library		 		  
    Oakland University - Rochester, Michigan 48309-4401	
    Phone: (248) 370.2016    FAX: (248) 370.4251

---

From: "Andrew J. Hutton" <[email-masked]>
Date: Tue, 29 Jun 1999 09:14:12 -0400 (EDT)

There is no rpm in redhat 6.0 and this may be the root of my problems as
well.  

--
Achilles - Linux Support, Pre-Installed Workstations & Servers
Sponsor & Host of the Ottawa Linux Symposium, July 22-24th, 1999
http://www.ottawalinuxsymposium.org/ for more information.

---

From: Konstantin Reznitsky <[email-masked]>
Date: Tue, 29 Jun 1999 10:05:29 -0400 (EWT)

I'm not sure that you can connect both cards to the same network segment,
atalkd will get confused. Try one at a time and put in the atalkd.conf
just this:
eth0 -phase 2 (or whatever phase you are using)
eth1 -phase 2 (the same here)
In this case atalkd will try to get the addresses from the network for
connected interface. If you have both cards on the same wire the
network addresses will have to be the same. Atalkd is a router, it has to
route between different networks (but you will have only one). This seems
to be the problem. To use both interfaces you need to have two network
segments.

Konstantin.

---

From: [email-masked] (Markus Boie)
Date: Tue, 29 Jun 1999 16:38:24 +0200

>I saw this problem once upon a time ... on Solaris.  The root
>cause was that we had an appletalk network with two zones with
>very different network numbers (say 10 and 800).  atalkd tries to
>define a route for every network between the lowest and highest
>appletalk networks it can find on the interface.  This caused
>atalkd to hit the maximum number of supported routes per
>interface (256 IIRC). 
>
>The solution is to set up the appletalk router for the network
>to seed zone network numbers with a smaller spread (lets say 10 and
>11) and then reboot every Mac in the building.  I did manage to hack
>the ddp driver to allow a larger number of routes but I don't
>think I have the hacked version around.

Thanks for your answer.

I don't want atalkd to route anything. That's why I specified only one of the networks in atalkd.conf. Is this setting ignored?

Markus

---

From: Patrik Schindler <[email-masked]>
Date: Tue, 29 Jun 1999 18:46:45 +0200

>The machines has two network interface cards connecting to the same network, ip-forwarding is disabled.

Why two cards? I think, this is the problem.
You won't get more throughput this way.

:wq! PoC