Subject: [netatalk-admins] setting exec permission from Mac

From: Darie Duclos <[email-masked]>
Date: Thu, 16 Sep 1999 11:11:02 +0200

Hi netatalk enthusiasts,

Is there a way to set an execute permission on a file created
on a Mac and stored on a Unix partition via Netatalk? 

We have a secretary who creates html files with includes (like
to include the standard header). In order for the include to
be carried out by the server, the execute bit has to be on.
But Macs don't know about execute permissions, and I can't
see her having to telnet to a Sun in order to chmod files..

The last resort will be a crontab which chmods her files once
a day, but I would have liked to avoid this.

Please copy me on your mail as I'm not receiving this list.
Thanks!

===============================================================
Darie Duclos
Systems Manager                      "All my life I've wanted
Institut d'Informatique               to be somebody, it's
Universite de Fribourg                only now I see I should
[email-masked]                 have been more specific."
tel: +41 26 300 83 42
fax: +41 26 300 96 42                           -- Lily Tomlin
===============================================================

---

From: Russell E Glaue <[email-masked]>
Date: Thu, 16 Sep 1999 08:36:09 -0500 (CDT)

Yes. I too would be interested in an answer to this.

+--------------------------------------------------------------+
 Russell E Glaue, Technologies Engineer   [email-masked]
 Center for the Application of Information Technologies
 101 Horrabin Hall, 1 University Circle, Macomb, Illinois 61455
 http://www.cait.org  http://cait.wiu.edu

---

From: Rick Zeman <[email-masked]>
Date: Thu, 16 Sep 1999 21:27:15 -0400

On 9/16/99 at 11:11 AM, Darie Duclos <[email-masked]> wrote:

|Is there a way to set an execute permission on a file created
|on a Mac and stored on a Unix partition via Netatalk? 
|
|We have a secretary who creates html files with includes (like
|to include the standard header). In order for the include to
|be carried out by the server, the execute bit has to be on.
|But Macs don't know about execute permissions, and I can't
|see her having to telnet to a Sun in order to chmod files..

You could have a graphical ftp client (like NetFinder) set up to change the
permissions.  She could have it open to that directory and badda bing, x.
_______________________________________________________________________
Rick Zeman                           In our secret world, we will collide
mailto:[email-masked]            In all of the places we were hiding love
Will Rogers never met Bill Clinton       What was it we were thinking of?

---

From: Rich Lafferty <[email-masked]>
Date: Thu, 16 Sep 1999 22:46:51 -0400

> permissions.  She could have it open to that directory and badda bing, x.

You could also configure the Web server to use something more modern
for determining server-parsed handler types than XBitHack, which 
is really trying hard to die a nice, peaceful death.

  -Rich

-- 
------------------------------ Rich Lafferty ---------------------------
 Sysadmin/Programmer, Information and Instructional Technology Services
   Concordia University, Montreal, QC                 (514) 848-7625
------------------------- [email-masked] ----------------------