Subject: [netatalk-admins] SuSE Linux 6.1

From: Jan CSERNOCH <[email-masked]>
Date: Thu, 13 May 1999 16:44:53 +0200

Dear List members!

I subscribed to this list as I didn't find any other source for my
problem. I previously have setup a netatalk-1.4b2 on a RedHat Linux 5.1
system. I still have the system running without problem. Now I tried to
install SuSE Linux 6.1 with netatalk-1.4b2+asun2.0a18.2-47 and I get
strange results.

Right after installing , when I start the daemon it gives an error
message:
socket: Invalid argument
atalkd: can't get interfaces, exiting.

I didn't change any of the configuration files and can reproduce the
same error any time. Please help me to find out what could be wrong.

Thanks
Jan Csernoch

---

From: Randy Newman <[email-masked]>
Date: Thu, 13 May 1999 10:54:59 -0500

You're really best getting the new sources and compiling it yourself.
Use /usr/local/atalk and the rc script below. 
Ran

#! /bin/sh

. /etc/rc.config

test "$START_ATALK" = "yes" || exit 0

case "$1" in
    start)
	echo "Starting netatalk."
	/usr/local/atalk/etc/atalkd
	/usr/local/atalk/bin/nbprgstr -p 4 `hostname|sed
's/\..*$//'`:Workstation
	/usr/local/atalk/bin/nbprgstr -p 4 `hostname|sed 's/\..*$//'`:netatalk
	# /usr/local/atalk/etc/papd
	/usr/local/atalk/etc/afpd
	echo
	;;
    stop)
	echo -n "Shutting down netatalk:"
	# killproc -TERM /usr/local/atalk/etc/papd
	killproc -TERM /usr/local/atalk/etc/afpd
	killproc -TERM /usr/local/atalk/etc/atalkd
	# killproc -TERM /usr/local/atalk/etc/papd
	echo
	;;
    *)
	echo "Usage: $0 {start|stop}"
	exit 1
esac

---

From: Jan CSERNOCH <[email-masked]>
Date: Thu, 13 May 1999 19:29:42 +0200

Hi!

I have the module Appletalk DDP compiled in the kernel.

Thanks for the replies.

Janos