Subject: [netatalk-admins] Configuring a print server

From: "Goodman, David" <[email-masked]>
Date: Thu, 4 Nov 1999 07:37:15 -0600

Hello,

I'm trying to use an Intel NetportExpress PRO/100 print server to share my
Epson printer between Windows and Macintosh machines.  The print server
wants there to be at least one zone defined before it will enable AppleTalk,
so I started looking for AppleTalk routers, and found netatalk.  I have a
486 that is Running FreeBSD 3.2, and have installed the netatalk port.

When I attempt to start atalkd, I get the following message:
	socket: Protocol not supported

I'm pretty sure that my version of FreeBSD comes with kernel support for
DDP, but I can't seem to verify one way or the other if that is the protocol
atalkd is complaining about.

Any suggestions?

Thanks,
- Dave

--
David Goodman
Sr. Applications Developer
Citadel Investment Group, LLC
(312) 696-2069
[email-masked]

---

From: "Andy Daws" <[email-masked]>
Date: Thu, 4 Nov 1999 14:55:45 -0000

Hi David,

The line

dmesg | grep AppleTalk

should confirm if you have AppleTalk compiled into the kernel, next after this you will need to update your services and the protocols file should have the ddp protocol as per the readme.  Examples of what should be in the services file are contained in the distribution

>I'm pretty sure that my version of FreeBSD comes with kernel support for DDP

---

From: Yann Ramin <[email-masked]>
Date: Thu, 4 Nov 1999 17:21:38 -0800

-----BEGIN PGP SIGNED MESSAGE-----

FreeBSD 3.2 does include support in the kernel.  You will have to go and
recompile it though.  Add the following line in your kernel config file:

options NETATALK

Just as a note, dmesg | grep AppleTalk won't work under FreeBSD.  The driver
(like IPX/NS/IP and almost any non-hardware probing code) doesn't confirm it is
installed.

Yann

--

--------------------------------------------------------------------
Yann Ramin			[email-masked]
Atrus Trivalie Productions	www.redshift.com/~yramin
				irm.it.montereyhigh.com
Monterey High IT		www.montereyhigh.com
ICQ 				46805627
Marina, CA

One of the main causes of the fall of the Roman
Empire was that, lacking zero, they had no way
to indicate successful termination of their C programs.
-- Robert Firth

--------------------------------------------------------------------