Subject: Re: [netatalk-admins] Q: Printing via netatalk to parallel prt on SS10

From: Henrik Andre Wyss Johansen <[email-masked]>
Date: Wed, 11 Feb 98 22:40:13 +0100

Hi Lucas

I did have the same problem, i solved the problem by setting pr to the name of my printer in the linux printer def. file (printcap i am using RH 4.2).

This is my printcap

LaserJet_6L|ljet|lp|local0|LPT1:\
	:sd=/var/spool/lpd/ljet4:\
	:mx#0:\
	:sh:\
	:lp=/dev/lp1:\
	:if=/var/spool/lpd/ljet4/filter:

This is my papd.conf.

LaserJet_6L:\
          :pr=LaserJet_6L:op=root:\
          :pd=/usr/share/lib/ppd/LaserJet_4.PPD:

So i think that you shuld set pr to QMS-PS410 and not lpr. Try "pr=QMS-PS410" or "pr=/usr/ucb/QMS-PS410"

>Printing is set up:
>
>QMS-PS410:\
>        :bsdaddr=sokrates,QMS-PS410,Solaris:\
>        :description=QMS-PS410:
>_default:\
>        :use=QMS-PS410:
>

>I configured papd as follows: (as was statet in the FAQ @
>http://www.cec.mtu.edu/Doc/FAQ/netatalk.html
>
>QMS-PS410:\
>        :pr=|/usr/ucb/lpr:\
Why          ^ ?

>	:op=daemon:\
>        :pd=/opt/atalk/ppd/QMS-PS410
>
>the printer shows up in the chooser on my mac. I can mount Volumes.

Venlig hilsen
Henrik André Wyss Johansen

---

From: Edan Idzerda <[email-masked]>
Date: Wed, 11 Feb 1998 19:53:54 -0500 (EST)

On Wed, 11 Feb 1998, Henrik Andre Wyss Johansen wrote:
> I did have the same problem, i solved the problem by setting pr to the name of
> my printer in the linux printer def. file (printcap i am using RH 4.2).
 [ snip ]
> So i think that you shuld set pr to QMS-PS410 and not lpr. Try "pr=QMS-PS410" or "pr=/usr/ucb/QMS-PS410"

Bzzt.  

You're lucky that papd printing works out of the box for you with Linux.
Under Solaris 2's lp system, or the LPRng lpr replacement, you can't use the
built-in spool-directory-twiddling routines.

> Why          ^ ?

Because the | means "start up /usr/ucb/lpr and pipe the file to be printed
to that program."

I would recommend using 'pr=/path/to/lpr -Pprintername' as its the only
way that's worked for me.  That's why its on the web page.  But I've only
been skimming this list lately so I may have missed some other detail.

- edan

--
Edan Idzerda	<[email-masked]>
System Administrator --  Michigan Technological University, Houghton MI USA