Subject: [netatalk-admins] atalkd

From: Ravi S <[email-masked]>
Date: Thu, 9 Apr 1998 17:38:48 +0530

On SunOS, should atalkd be run as root? The rc.atalk has
the following lines:
######################
echo -n 'loading netatalk: '
if [ -f /user/ravi/atalk/etc/netatalk.o ]; then
        /usr/etc/modload -sym /user/ravi/atalk/etc/netatalk.o;
fi
 
echo -n 'starting appletalk daemons:'
if [ -f /user/ravi/atalk/etc/atalkd ]; then
        /user/ravi/atalk/etc/atalkd;            echo -n ' atalkd'
fi
 
if [ -f /user/ravi/atalk/bin/nbprgstr ]; then
        /user/ravi/atalk/bin/nbprgstr -p 4 `hostname|sed 's/\..*$//'`:Workstatio
n
        /user/ravi/atalk/bin/nbprgstr -p 4 `hostname|sed 's/\..*$//'`:netatalk
                                        echo -n ' nbprgstr'
fi
 
if [ -f /user/ravi/atalk/etc/papd ]; then
        /user/ravi/atalk/etc/papd;              echo -n ' papd'
fi
 
if [ -f /user/ravi/atalk/etc/afpd ]; then
        /user/ravi/atalk/etc/afpd;              echo -n ' afpd'
fi
 
if [ -f /user/ravi/atalk/etc/timelord ]; then
        /user/ravi/atalk/etc/timelord;          echo -n ' timelord'
fi
 
                                        echo '.'
######################

Can  I have only the following lines in this file (rc.atalk)

echo -n 'loading netatalk: '
if [ -f /user/ravi/atalk/etc/netatalk.o ]; then
        /usr/etc/modload -sym /user/ravi/atalk/etc/netatalk.o;
fi

and start the daemons as a normal user? 

Thanks and Best Regards, Ravi

---

From: Isaac Finnegan <[email-masked]>
Date: Thu, 9 Apr 1998 08:23:08 -0700

I cannot get the recently compiled netatalk-1.4b2+asun2.0a18 to accept
logins.  It is denying the password. rand2num is the authentication method
and the des libs are setup correctly.
The error being reported to the log file is:

afpd[502]: Insecure permissions found for /home/isaac/.passwd

I have tried all sorts of different permissions for this file.  None seem
to work. What exactly are they supposed to be?

Isaac Finnegan
[email-masked]