Subject: Re: [netatalk-admins] netatalk on RedHat 5.1

From: Bob Atkins <[email-masked]>
Date: Wed, 14 Oct 1998 00:04:17 -0700 (PDT)

I too have tried using the netatalk-1.4b2+asun2.1.0 on Solaris x86
(2.6) and sparc (Solaris 2.5.1) platforms. It doesn't work properly on
either one. netatalk-1.4b2+asun2.1.0 includes the 971027 driver.

Wes, I emailed you directly the results of my testing which show that
the ddp streams driver is not handling the setsocketopt processing
properly. I will reiterate my offer for you to use my system to
troubleshoot the problem. The problem is critical enough for me that I
am more than willing to compensate (pay) you for your time should you
wish to look into this.

Sincerely,
Bob Atkins

> 
> > From:    "Mike Reiling" <[email-masked]>
> 
> > I have been having this problem with Solaris 2.6 running and an intel
> > platform.  I have tried every version of Netatalk that I could find,
> > but none compile.  Do I have something wrong with my compiler (gcc
> > 2.8.1) or is it something else.  Any input would be greatly
> > appreciated.
> 
> First, there is no version of netatalk that's been tested on Solaris
> x86.  Second, 1.4b2 is not compatible with Solaris 2.6.  There have
> been several snap-shots since 1.4b2, but no other releases (from
> Michigan).  The latest snap-shot that I'd suggest anyone use is
> ftp://terminator.rs.itd.umich.edu/pub/n-971027.tar.gz.  There are later
> snap-shots, since we put various snap-shots there when we're testing
> cross-platform builds of netatalk.  971027 has the nice characteristic
> of being used in production at Michigan, and hence works pretty well,
> especially on Solaris.
> 
> If you want to work on a Solaris x86 port of netatalk, there are other
> interested parties on the net.
> 
> :wes
>

---

From: Bob Atkins <[email-masked]>
Date: Wed, 14 Oct 1998 00:46:36 -0700 (PDT)

Mike,

I figured this compile problem out a while back and someone asked if
I would post the diffs. Sorry it took me so long but here they are:

--- Begin Included File (netatalk-1.4b2+asun2.1.0-sol26.patch) ---

--- README.SOLARIS
34c34
< c/o Wes Craig				+1-313-764-2278
---
> c/o Wes Craig				+1-734-764-2278
--- include/netatalk/endian.h
50a51
> #ifndef SOL26
52a54
> #endif
121a124
> #ifndef SOL26
123a127
> #endif
--- libatalk/compat/strcasecmp.c
22c22
< # if defined( ibm032 ) || ( defined( sun ) && defined( i386 ))
---
> # if defined( ibm032 ) || ( defined( sun ) && defined( i386 ) && !defined( SOL26 ))
--- sys/netatalk/endian.h
50a51
> #ifndef SOL26
52a54
> #endif
121a124
> #ifndef SOL26
123a127
> #endif
--- sys/solaris/Makefile
6,7c6,7
< KCFLAGS=	-D_KERNEL -Wall -Wstrict-prototypes \
< 		-mno-app-regs -munaligned-doubles -fpcc-struct-return
---
> KCFLAGS=	-D_KERNEL -Wall -Wstrict-prototypes -fpcc-struct-return
> #		-mno-app-regs -munaligned-doubles -fpcc-struct-return
15c15
< DEFS=	-D__svr4__ -DSOLARIS -I../../sys/solaris
---
> DEFS=	-D__svr4__ -DSOLARIS -DSOL26 -I../../sys/solaris

--- End Included File ---

Simple cut'n paste the above patches into a file and save it in the top
level of your netatalk-1.4b2+asun2.1.0 tree. Then run patch to apply the
patches. Then it should compile just fine. Let me know if it works for you.
I still haven't gotten either PHASE1 or PHASE2 networking to work properly
on my Solaris x86 (2.6) systems.

I'm hoping that Wes might be able to look at the problem I found.

---
Bob Atkins

> 
> I have been having this problem with Solaris 2.6 running and an intel platform.
> I have tried every version of Netatalk that I could find, but none compile.  Do
> I have something wrong with my compiler (gcc 2.8.1) or is it something else.
> Any input would be greatly appreciated.
> 
> Thanks in advance,
> Mike
> 
> Making all for solaris...
> gcc -D_KERNEL  -fpcc-struct-return -I../../sys/solaris -D__svr4__ -DSOLARIS -O
> -I../../include -I../netatalk  -c  aarp.c
> gcc -D_KERNEL  -fpcc-struct-return -I../../sys/solaris -D__svr4__ -DSOLARIS -O
> -I../../include -I../netatalk  -c  ddp.c
> gcc -D_KERNEL  -fpcc-struct-return -I../../sys/solaris -D__svr4__ -DSOLARIS -O
> -I../../include -I../netatalk  -c  ddptp_rdq.c
> gcc -D_KERNEL  -fpcc-struct-return -I../../sys/solaris -D__svr4__ -DSOLARIS -O
> -I../../include -I../netatalk  -c  ddptp_utls.c
> In file included from ddptp_utls.c:39:
> ../netatalk/endian.h:51: warning: redefinition of `int32_t'
> /usr/include/sys/int_types.h:69: warning: `int32_t' previously declared here
> ../netatalk/endian.h:123: conflicting types for `ntohl'
> /usr/include/sys/byteorder.h:66: previous declaration of `ntohl'
> ../netatalk/endian.h:123: conflicting types for `htonl'
> /usr/include/sys/byteorder.h:64: previous declaration of `htonl'
> ddptp_utls.c: In function `ddptp_verify_msg':
> ddptp_utls.c:110: structure has no member named `dub_len'
> *** Error code 1
> make: Fatal error: Command failed for target `ddptp_utls.o'
> Current working directory /export/miker/netatalk-1.4b2+asun2.0a18.2/sys/solaris
> *** Error code 1
> make: Fatal error: Command failed for target `all'
> 
>