Subject: [netatalk-admins] netatalk MacOS 7.6 problems

From: Paul Pomerleau <[email-masked]>
Date: Thu, 29 Jan 1998 14:20:53 -0600 (CST)

Hi!

	I find that my MacOS 8 clients connect fine to my netatalk afpd,
but 7.6 machines don't -- I get "no response from server".  I'm using
netatalk-1.4b2+asun2.0a18.2. On RedHat-5.0 on a PPro.

	I see that other people have had the same problem, and a very
intriguing answer came from Jochen Haeberle <[email-masked]>:

>> I get the same message from time to time. I'm running netatalk 1.4b2 on
>> Debian/GNU Linux which shares printers and volumes between macos (7.5.x,
>> 7.6.{0,1}) and PC (win 3.1, 95, nt) users.
>>
>> After a few days/weeks running successfully, the linux box is still in
>> their choosers but users cannot log in ("No response from server"). In
>
>I had this problem a while ago and found that it only happend when other
>atalk-routers went down. Defining the exact zone-addresses in the netatalk
>config solved the problem for me. ... cheers ... Jochen

	The problem is that I'm not sure what Jochen means.

	I used to have an empty atalkd.conf.  I've added (hoping this is
what he meant) one line:

eth0 -phase 2 -addr 852.118 -zone "Psych"

	But this hasn't solved the problem. I've also tried

eth0 -phase 2 -net 852-854 -addr 852.118 -zone "Psych"

	and 

eth0 -seed -phase 2 -net 852-854 -addr 852.118 -zone "Psych"

	But again, no dice.  In the first case, nothing changes, and in the
second, the machine doesn't show up in the chooser at all.

	Is there some file I don't know about which talks about zones?

	Thanks!

-------------------------------------------------------------
Paul Pomerleau				Green 217
Director of Computing			(773) 702-4830
Center for Computational Psychology	[email-masked]
University of Chicago

---

From: Richard Mann <[email-masked]>
Date: Thu, 29 Jan 1998 14:37:16 -0600 (CST)

Here's mine:

	eth0 -phase 2 -net 7 -addr 7.160 -zone "EtherTalk"

Hence I would deduct yours would be

	eth0 -phase 2 -net 852 -addr 852.118 -zone "Psych"

Just guessing, purely on what's in my atalk.conf file...

     //\     --rich
    //  \    
   // /  \   Richard Mann -- Network Administrator
  // / /  \  P u b l i c a t i o n  S e r v i c e s,  I n c. 
  \\  / / /  Champaign, Illinois, USA 61821 (217) 398-2060 x22
   \\  / /   
    \\  /    
     \\/