Subject: [netatalk-admins] printing problem

From: Paul Wolstenholme <[email-masked]>
Date: Mon, 5 Oct 1998 19:56:52 -0700 (PDT)

Greetings,

I'm new to netalk and have just finished switching over from CAP.  We are
runnig version 1.4b2 on FreeBSD 2.2.7. We have a Lexmark Optra Rn+ which
the BSD boxes connects remotely. 

The essential services are all working great except for papd (at least
that is what I believe the problem is). When I go to print, the job just
sits in the queue.  During setup, the Mac client seems to communicate with
the printer without any errors. If I reboot the Mac client, it appears to
be printing but nothing arrives at the printer. I have tried running papd
with and without a config file. Does anyone have any suggestions?

/Paul

The papd.conf file looks like:

CPROST Printer Spooler:\
                  :pr=lp:pd=/usr/local/atalk/ppd/lexmark.ppd: 
 
printcap:

lp|CPROST Lexmark:\
        :rp=pslaser_cr:lp=/dev/lp:mx#0:rm=192.75.242.134:\
        :sd=/var/spool/output/lpd:lf=/var/log/lpd-errs: 

Some of the errors in printer log file:

Oct 5 19:11:47 oscar papd[29741]: register CPROST Printer Spooler:LaserWriter@* 
Oct 5 19:12:56 oscar papd[29741]: child 29746 for"CPROST Printer Spooler" from
Oct 5 19:17:11 oscar papd[29746]:  connection timed out 
Oct 5 19:17:11 oscar papd[29741]: child 29746 exited with 1 
Oct 5 19:19:47 oscar papd[29741]: child 29751 for "CPROST Printer Spooler" from
Oct 5 19:20:09 oscar papd[29741]: child 29755 for "CPROST Printer Spooler" from 
Oct 5 19:21:04 oscar papd[29741]: child 29756 for "CPROST Printer Spooler" from 

Oct 5 19:24:02 oscar papd[29751]: connection timed out 
Oct 5 19:24:02 oscar papd[29741]: child 29751 exited with 1 
Oct 5 19:26:12 oscar papd[29756]: connection timed out 
Oct 5 19:26:12 oscar papd[29741]: child 29756 exited with 1 
Oct 5 19:26:24 oscar papd[29755]: connection timed out 
Oct 5 19:26:24 oscar papd[29741]: child 29755 exited with 1 
Oct 5 19:33:43 oscar papd[29741]: child 29820 for "CPROST Printer Spooler" from 
Oct 5 19:37:57 oscar papd[29820]: connection timed out
Oct  5 19:37:57 oscar papd[29741]: child 29820 exited with 1

---

From: Brian Aker <[email-masked]>
Date: Tue, 06 Oct 1998 14:30:30 -0500

Been trying to track down the problem I have been getting
using netatalk-1.4b2+asun2.1.0 and the solaris kernel
driver that comes with it (netatalk-971027).  I do know it is
getting far enough to authenticate since it only dies if a correct
password is given to the chooser. The message that is showing
up in syslog is:

Oct  6 13:58:34 editorial afpd[204]: dsi_getsess: Interrupted system call

Now the message is coming from file libatalk/dsi/dsi_getsess.c where 
the lines are:
 
  switch (pid = dsi->proto_open(dsi)) {
  case -1:
    /* if we fail, just return. it might work later */
    syslog(LOG_ERR, "dsi_getsess: %m");
    return dsi;

  case 0: /* child. mostly handled below. */
    dsi->child = 1;
    break;

Getzones is working so I know that the kernel driver must
be working a bit. Even if afpd dies, getzones will continue
to work. Afpd can restarted but it will die just as soon as anyone
logs in with the right password.
I am using Solaris 2.6 BTW.

	thanks,
		-Brian

---

From: Michael M Han <[email-masked]>
Date: Tue, 06 Oct 1998 13:21:04 -0700

Previously...
>Oct  6 13:58:34 editorial afpd[204]: dsi_getsess: Interrupted system call

Ah, it took me a while to jog my memory here, but did you by any
chance compile with TCP wrappers? And is your client Mac reverse
DNS'ing correctly? For example, can your target netatalk server
`nslookup` the IP of your Mac in a way that gibes? This is a feature
of TCP wrappers, since it doesn't make any sense to allow/deny hosts
if someone's just going to spoof you.
_________
mike ([email-masked])
I will return the seeing-eye dog
 - The collected wisdom of Bart Simpson