Subject: [netatalk-admins] netatalk on SUNOS

From: Ravi S <[email-masked]>
Date: Fri, 17 Apr 1998 12:14:09 +0530

I'm trying to install netatalk on a SUN machine running SUNOS and I'm facing
some problems. This is what I did to install:

%uname -a 
SunOS cvp12 4.1.3_U1 1 sun4m
%cd /usr/share/sys/sun4m/conf
%cp GENERIC GENERIC.ATALK
%echo "options VDDRV" >>GENERIC.ATALK
%/etc/config GENERIC.ATALK
%cd ../GENERIC.ATALK
%make                             #make the new kernel
%mv /vmunix /vmunix.org           #save the old kernel
%mv ./vmunix /                    #new kernel
%cd /etc
%cat >> services                #Update the services database
rtmp            1/ddp           # Routing Table Maintenance Protocol
nbp             2/ddp           # Name Binding Protocol
echo            4/ddp           # AppleTalk Echo Protocol
zip             6/ddp           # Zone Information Protocol

%echo "sh ~ravi/atalk/etc/rc.atalk" >>/etc/rc.local
%reboot

All of the above steps were executed as a superuser.

When the system is rebooted, I get the following messages:

Cannot write into "/user/ravi/atalkd/etc/l<somefilenamehere>. I have
changed the permissions of /user/ravi/atalkd/etc/ to 777. This error message
is printer when trying to execute the statement:

if [ -f /user/ravi/atalk/etc/netatalk.o ]; then
        /usr/etc/modload -sym /user/ravi/atalk/etc/netatalk.o;

When 

if [ -f /user/ravi/atalk/etc/atalkd ]; then
        /user/ravi/atalk/etc/atalkd;            echo -n ' atalkd'
is executed, the following error message is printed:

config file is (null)
socket: Protocol not supported

Can I get some help here? Have I missed any steps here?

Thanks and Best Regards, Ravi

+--------------------------------------------------------------------+
| Ravi Subramanian                |         Email: [email-masked] |
| Texas Instruments Incorporated                                     |
+--------------------------------------------------------------------+

---

From: "Paul J. Schinder" <[email-masked]>
Date: Fri, 17 Apr 1998 09:50:10 -0400

At 12:14 PM +0530 4/17/98, Ravi S wrote:

}
} When the system is rebooted, I get the following messages:
}
} Cannot write into "/user/ravi/atalkd/etc/l<somefilenamehere>. I have
} changed the permissions of /user/ravi/atalkd/etc/ to 777. This error message
} is printer when trying to execute the statement:
}
} if [ -f /user/ravi/atalk/etc/netatalk.o ]; then
}         /usr/etc/modload -sym /user/ravi/atalk/etc/netatalk.o;

Is the disk that /user/ravi is on NFS mounted, by any chance, or is it a
disk local to the machine you're running netatalk on?

}
} When
}
} if [ -f /user/ravi/atalk/etc/atalkd ]; then
}         /user/ravi/atalk/etc/atalkd;            echo -n ' atalkd'
} is executed, the following error message is printed:

What does modstat show?

}
} config file is (null)
} socket: Protocol not supported
}
} Can I get some help here? Have I missed any steps here?
}
} Thanks and Best Regards, Ravi
}
} +--------------------------------------------------------------------+
} | Ravi Subramanian                |         Email: [email-masked] |
} | Texas Instruments Incorporated                                     |
} +--------------------------------------------------------------------+

---
Paul J. Schinder
NASA Goddard Space Flight Center
Code 693, Greenbelt, MD 20771
[email-masked]