Subject: Re: [netatalk-admins] Installation problem: netatalk 1.4b2 on solaris 2.5.1

From: "Yasmine Arafa" <[email-masked]>
Date: Tue, 27 Oct 1998 15:22:32 -0000

Yes I do have /etc/rc2.d and /etc/rc0.d directories but not the file. I
have tried cleaning and reinstalling but still can't find rc.atalkd. The
instructions say they should be included in the /etc/rc file.
Are the files in these directories sufficient or do I need rc.atalkd?

Thanx
Yasmine.

------
> From: Mitch McNeel <[email-masked]>
> To: Yasmine Arafa <[email-masked]>
> Cc: netatalk-admins <[email-masked]>
> Subject: Re: [netatalk-admins] Installation problem: netatalk 1.4b2 on
solaris 2.5.1
> Date: 27 October 1998 15:12
> 
> Well for one thing, the rc.atalk file should have been created on the
> install...  look in your /etc/rc2.d and /etc/rc0.d directories, there
should
> be a soft link to the file atalk in /etc/init.d directory.
> 
> Hope this helps
> Mitch
> 
> 
> 
> Yasmine Arafa wrote:
> 
> > I  have almost been able to successfully complete compilation of
netatalk
> > 1.4b2 on solaris 2.5.1
> >
> > I am at the last step of the instructions, which is to add the rc.atalk
> > file  to /etc/rc
> > I can't find this file anywhere? The instructions say it should be
> > installed in the in the ETCDIR (which in my case is
/usr/local/atalk/etc),
> > but I can't find it!
> > Does this mean that there could be a problem with the installation? or
can
> > I just cp this file from somewhere? if I can cp it where can I get this
> > file from?
> >
> > Thanx,
> > Yasmine.

---

From: Yuji Shinozaki <[email-masked]>
Date: Tue, 27 Oct 1998 11:56:57 -0500 (EST)

The rc files are installed when you do a "make kinstall" (to install the
kernel drivers et al). 

What it installs and where varies according to OS.  On Solaris is should
install /etc/init.d/atalk and two symlinks at /etc/rc2.d/S79atalk and
/etc/rc0.d/K79atalk.

Hope this helps.

yuji
----

> > > I just cp this file from somewhere? if I can cp it where can I get this

Yuji Shinozaki		        Systems Administrator
[email-masked]	        Dept of Physics and Astronomy
http://www.physics.unc.edu      Univ. of North Carolina - CH
(919)962-7214 (voice)           CB 3255 Philips Hall
(919)962-0480 (fax)	        Chapel Hill, NC  27599