Subject: [netatalk-admins] Unix Level Renaming/Deleting Problem

From: "Frank Morton" <[email-masked]>
Date: Sat, 28 Nov 1998 16:47:31 -0500

I need an explanation from someone in the know.

I have a software package that at times will rename a directory
from a mixture of upper/lower case to all lower-case as is
required for good reason. Or, in other circumstances, it might
need to delete the directory.

The renaming causes very strange things to happen I can not
yet put my finger on, but deleting is more obvious. Upon deleting
a directory, netatalk begins to report "The folder xxxxx could not
be opened, because it cannot be found" even though it displays
in the finder. Closing the finder window and reopening sometimes
causes the directory to disappear, but at times, instead of the
deleted directory disappearing, not only does the deleted directory
show in the list, but also previously deleted directories reappear!

I assume the desktop file or something else knows about the
directories in the root directory for the volume. The same thing
does not occur further layers in the directory structure.

Any help? Is there any special way to delete/rename the files so
as to not confuse netatalk?

I am running asun2.0a18.2 on linux with a 2.0 35 kernel. Thanks.

-----Original Message-----
From: Harry Zink <[email-masked]>
To: a sun <[email-masked]>; Osma Ahvenlampi <[email-masked]>
Cc: [email-masked] <[email-masked]>
Date: Saturday, November 28, 1998 2:25 AM
Subject: [netatalk-admins] ethernet card information

>>      1) ethernet card, driver version, and os
>
>multiple generic DEC tulip 10/100 base-T cards. They all work flawlessly,
>and quite well with 2.10 version of netatalk+asun.
>
>On the Macs, Asante 10/100 base-T cards (also the DEC tulip chipset),
>with Asanté 3.1 driver.
>
>On portable Macs - built-in ethernet.
>
>>      2) whether or not atalkd causes your computer to crash or not.
>
>works fine. No crashes. Mac OS 8.5 on all.
>
>>      3) whether or not you can see nbp info (via nbplkup).
>
>Yep, works finer on both Linux boxes. Red Hat 5.2 on both.
>
>>      4) any workarounds you might have.
>
>none needed.
>
>P.S Thanks for the great work on netatalk you are doing, andreas.
>
>Harry

---

From: Wagner One <[email-masked]>
Date: Mon, 30 Nov 1998 07:30:28 -0500

>need to delete the directory.

I'm assuming you're talking about doing this on the unix side to the 
netatalk directories.

>as to not confuse netatalk?

The most simple solution is probably to do the same thing on the macos 
client side. There are several shareware utilities that do all sorts of 
renaming, case changing, etc. functions. "Manipulator" and "Guillotine" 
come to mind.

Mike

--
Mike Wagner - A bad Dead show is better than a good day at work...
[email-masked], [email-masked], [email-masked]