Subject: [netatalk-admins] purpose of PAM, crypt, and DES

From: patrick finerty <[email-masked]>
Date: Wed, 11 Feb 1998 01:01:42 -0700

hi,

would someone be really kind and tell me exactly how PAM, DES, and/or 
crypt are used by afpd or any other part of netatalk?

thanks,

-patrick
-- 
       "There is only one aim in life and that is to live it."
 Karl Shapiro,(1959) from an essay on Henry Miller's Tropic of Cancer
	  finger [email-masked] for PGP key
		    http://zifi.genetics.utah.edu

---

From: Jonathan Peterson <[email-masked]>
Date: Wed, 11 Feb 1998 11:35:51 +0000

Hi,

I spend many happy hours trying to get my Win95 and MacOS8.0 people sharing
a linux drive. I'm largely succesful, but Win95 machines just will not
delete the 'Icon\r' files that get created by Macs. The \r in the file name
is just how my bash shell displays what I presume is a carriage return
character. In windows the file is called Icon followed by a thick black
vertical bar.

Anyway, I thought maybe there was a way (albeit a source code hack) to get
Netatalk (I use 1.4b3) to call these Icon files something different. Any
ideas?

--------
Jon Peterson		
[email-masked]	
+44 (0)171 613 5300	

'Never never never never never'
			-- Shakespeare

---

From: Jonathan Peterson <[email-masked]>
Date: Wed, 11 Feb 1998 17:40:24 +0000

At 09:23 AM 2/11/98 -0800, Marc Matteo wrote:
>On Wed, 11 Feb 1998, Jonathan Peterson wrote:
>
>> delete the 'Icon\r' files that get created by Macs.
>
>If you are using Samba to serve the Win folk then a like in your Samba
>config file like:
>
>veto files = /.Apple*/Trash Can*/Temporary Items/Icon*/
>
>Will clear out all the Netatalk stuff.

Ah, if only. What I find is that this prevents the PC's from deleting any
of these files, which is great until they want to delete the whole
directory. At that point samba tells them that the directory is not empty,
which is slightly confusing for the PC users, since the directory _looks_
empty. Using:

hide files = /.Apple*/Trash Can*/Temporary Items/Icon*/

is better, but I still get trouble from the Icon\r file.

--------
Jon Peterson		
[email-masked]	
+44 (0)171 613 5300

---

From: Julian Elischer <[email-masked]>
Date: Wed, 11 Feb 1998 10:25:29 -0800

> is better, but I still get trouble from the Icon\r file.
the PC user CAN't look inthe directory if veto is used..

there is an option in samba to allow veto'd directories to be deleted
if they would otherwise appear empty to the user.

---

From: Marc Matteo <[email-masked]>
Date: Wed, 11 Feb 1998 09:23:25 -0800 (PST)

Marc

Marc Matteo
Web Engineer, The Sacramento Bee
http://www.sacbee.com

---

From: m* <[email-masked]>
Date: Wed, 11 Feb 1998 20:09:46 -0600

> veto files = /.Apple*/Trash Can*/Temporary Items/Icon*/

i guess this service parm will hold true for copies too? that is,
your copy on Windoze won't crash because of that pesky Icon file?

thx,

m*