Subject: [netatalk-admins] Solaris 2.6 on Ultra ....cont

From: "Andreas M. Kogelnik" <[email-masked]>
Date: Sun, 18 Jan 1998 12:10:53 -0500 (EST)

Ok, so I got the patched version from U.Washington (I think I'd been using
the older U Mich version), which took care of the initial compilation
problem, gets further now with minor warnings along the way, but hangs on
looking for tcp.h.

gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include
-DTCPWRAP -c dsi_tcp.c
dsi_tcp.c:27: tcpd.h: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `dsi_tcp.o'
Current working directory
/usr/local/build/netatalk-1.4b2+asun2.0a18.1/libatalk/dsi
*** Error code 1
make: Fatal error: Command failed for target `all'
Current working directory
/usr/local/build/netatalk-1.4b2+asun2.0a18.1/libatalk/dsi
*** Error code 1
make: Fatal error: Command failed for target `dsi'
Current working directory
/usr/local/build/netatalk-1.4b2+asun2.0a18.1/libatalk
*** Error code 1
make: Fatal error: Command failed for target `../../libatalk'
Current working directory
/usr/local/build/netatalk-1.4b2+asun2.0a18.1/sys/solaris
*** Error code 1
make: Fatal error: Command failed for target `all'
# find / -name tcpd.h -print
# 

tcpd.h doesn't seem to be on this system. Anyone have any thoughts?

Any thoughts on the second workaround from my previous message are still
welcome.

Thanks
Andy

---

From: Edan Idzerda <[email-masked]>
Date: Sun, 18 Jan 1998 12:51:41 -0500 (EST)

> dsi_tcp.c:27: tcpd.h: No such file or directory

I assume you should take out the -DTCPWRAP as you are missing the 
the tcp wrappers header files.

> Any thoughts on the second workaround from my previous message are still

I started a web page for Netatalk on Solaris 2--I swear I've seen one 
before, but I don't have the energy to go looking.

    http://www.cec.mtu.edu/Doc/FAQ/netatalk.html

It ain't much.

- edan

---

From: Mike Holling <[email-masked]>
Date: Sun, 18 Jan 1998 10:23:43 -0800 (PST)

> tcpd.h doesn't seem to be on this system. Anyone have any thoughts?

You need to either install the "TCP Wrappers" package, or comment out the
TCP wrapper section in the Makefile.

- Mike