Subject: Re: [netatalk-admins] unknown printer

From: [email-masked] (Abel Deuring)
Date: Thu, 01 Oct 1998 00:00:00 +0000

[email-masked] wrote

> The printcap entry looks like this:
> apple:\
>  :sd=/usr/spool/apple:\
>  :lp=/dev/null:\
>  :of=/usr/local/atalk/etc/filters/ofpap:\
>  :sh:sf:
>
> Of course, /usr/spool/apple exists and ofpap and psf are where they are
> supposed to be.
> When I try "lpr -Papple testfile", I get the message
> "lpr: apple: unknown printer".
>
> What did I wrong?

Perhaps you have immediately before the line "apple:\" a line  
ending with a backslash in your printcap file? (Some months ago I  
had the same phenomenon - it tooks me days to find the error just  
described...)

Abel

---

From: Patrick Herzog <[email-masked]>
Date: Fri, 02 Oct 1998 13:14:38 +0000

Yeah, this is it: Thanks to Abel I was able to get things to work:

> had the same phenomenon - it tooks me days to find the error just

I had a line commented out right before the "apple..." entry with a backslash at
the end. When I removed the "\", suddenly the printer was known. :-) So my
suggestion is:
never comment out a line within or befor a printer entry in printcap. Remove it
or move it far away.

Andras' and Scott's comment to restart lpd have also been helpful ("lpc restart
all") though I had done this.

Perhaps someone may be interesting fin how I created an additional null-device
in the printer spool directory (this works :-)):
cd /usr/spool/apple
mknod null c 1 3
chmod 666 null
chgrp sys null

Thanks to all for their comments!

Patrick

--
Dr.-Ing. Patrick Herzog
-- Oberingenieur --
RWTH Aachen
Institut für Technische Elektronik
Sommerfeldstraße 24
D-52056 Aachen, Germany
http://www.ite.rwth-aachen.de