Subject: Re: [netatalk-admins] Files starting with .

From: Thomas Tornblom <[email-masked]>
Date: Sun, 25 Oct 1998 10:02:45 +0100 (MET)

> >Received: from terminator.rs.itd.umich.edu (terminator.rs.itd.umich.edu 
[141.211.164.2]) by hellfire.englund.nu (8.8.8+Sun/8.8.8) with ESMTP id IAA02433 
for <[email-masked]>; Sun, 25 Oct 1998 08:14:06 +0100 (MET)
> Subject: Re: [netatalk-admins] Files starting with .
> From: Harry Zink <[email-masked]>
> To: "David Casti" <[email-masked]>, <[email-masked]>
> Mime-Version: 1.0
> 
> >How do I get files starting with . to show up when I mount a volume on my 
> 
> You should *NOT* have files starting with the period character.
> 
> This is bad under any UNIX file system, this is also bad under the 
> Macintosh file system.
> 
> This will be just as bad under Mac OS X, which is UNIX based, and you 
> won't be able to patch.
> 
> Avoid it. 

Care to enlighten us as to why this is bad?

A unix filename can contain any character with the exception of "/" and <null> 
and the OS couldn't care less.

There are filenames that are harder so use than others with some tools, i.e. 
name globbing, filenames starting with "-", filenames containing " ", but there 
is nothing inherently bad about them.

Files starting with "." is common if you don't want them to clutter up "ls" 
listings.

> 
> Norton even alerts you that you have files starting with he period, as 
> being bad.
> 
> There is absolutely *NO* reason to have files starting with the period.

I beg to differ, at least from a unix perspective.

> Period.
> Harry

Real life:      Thomas Törnblom             Email:  [email-masked]
Snail mail:     HB Hax                      Phone:    +46  18 290 290
                Banvallsvägen 14            Fax:      +46  18 290 291
                S - 754 40 Uppsala, Sweden  Cellular: +46  73 986 6318

---

From: Tony & <[email-masked]>
Date: Sun, 25 Oct 1998 10:16:25 -0600

> Care to enlighten us as to why this is bad?

	Under MacOS, files starting with a . are a hint that the file is a
device driver.
	Under Unix, they are supposed to be invisible to normal user
interaction.

> and the OS couldn't care less.

	Correct.  The problem isn't technical, it's social.
-- 
Anthony J. Stuckey                              [email-masked]
"When I was young, the sky was filled with stars.
 I watched them burn out one by one."  -Warren Zevon