Subject: [netatalk-admins] NT4 destroy atalkd?!

From: "kazunori miura" <[email-masked]>
Date: 31 Mar 98 22:10:52 +0000

Hello! ALL
Thank you for answer to my question "netatalk over IP-masqurade".
Now , I can mount remote volume over IP-masurade via PPP:-).

BUT, another problem is arriving.
There is NT4 server inside of IP-masqurade.
NT4 and Linux-Box (IP-masqurading) serve files for Mac on same zone.
netatalk is seed zone "Yea Parking" and NT4 routing AppleTalk.
Problem is NT4 destroying atalkd.
When NT4 is routing AppleTalk ,atalkd goes down.
(I made certain of this affair, disconnect NT4 from network)

message file
Mar 31 16:10:30 ns atalkd[566]: zone_bcast Yes Parking^?^Q exists           
   Mar 31 16:10:30 ns atalkd[566]: zip_packet: zone_bcast                   
       
Mar 31 16:10:30 ns atalkd[566]: ap->ap_packet: Unknown error 

netatalk-1.4b2+asun2.0a17 RedHat 4.2 kernel 2.0.31
NT4 Server SP1

Is this known problem ?
-----------------------------
     kazunori miura zao-net 
       yamagata prefecture
-----------------------------

---

From: Andras Kadinger <[email-masked]>
Date: Tue, 31 Mar 1998 14:40:09 +0200

> When NT4 is routing AppleTalk ,atalkd goes down.
[...]
> Is this known problem ?

When a seed router tries to come up, it checks, if it's configuration
agrees with the other routers on the network. If it finds conflicts, it
shuts down (it has to, as per appletalk requirements).

Make sure, that the configuration (zone names, network ranges, etc.)
agrees between atalkd and the NT.

The 'unknown error' is interesting though.

Sincerely,
Andras Kadinger
[email-masked]