Subject: [netatalk-admins] Can't apply 8.0 patch to 1.4b2 src

From: Matt Covey <[email-masked]>
Date: Sat, 28 Feb 1998 13:44:14 -0800

This may be a dumb question, but I just tried to apply the "MacOS8 compatibility issues/"dancing icons" & read-only file troubles" patch, located at http://www.umich.edu/~rsug/netatalk/patches/1.4b2/afpd-macos8.diff
to my Netatalk 1.4b2 (Linux x86) source using the command:

	patch -p0 < patchfile

in the top-level netatalk src directory (/usr/local/src/netatalk-1.4b2). 

I get this response:

Hmm...  Looks like a new-style context diff to me...
The text leading up to this was:
--------------------------
|*** etc/afpd/file.c-    1997/08/17 00:01:46
|--- etc/afpd/file.c     1997/08/20 22:39:08
--------------------------
Patching file etc/afpd/file.c using Plan A...
Hunk #1 failed at 125.
1 out of 1 hunks failed--saving rejects to etc/afpd/file.c.rej
Hmm...  The next patch looks like a new-style context diff to me...
The text leading up to this was:
--------------------------
|*** etc/afpd/fork.c-    1997/08/17 00:01:46
|--- etc/afpd/fork.c     1997/08/26 03:50:24
--------------------------
Patching file etc/afpd/fork.c using Plan A...
Hunk #1 failed at 95.
Hunk #2 failed at 173.
Hunk #3 failed at 323.
Hunk #4 failed at 556.
Hunk #5 failed at 650.
Hunk #6 failed at 718.
6 out of 6 hunks failed--saving rejects to etc/afpd/fork.c.rej
Hmm...  Ignoring the trailing garbage.
done

Any hints on what I'm doing wrong?

Thanks in advance,

++matt

---

From: "Stefan Bethke" <[email-masked]>
Date: Mon, 02 Mar 1998 12:43:08 +0100

--On Sam, 28. Feb 1998 13:44 Uhr -0800 "Matt Covey" <[email-masked]>
wrote: 

> This may be a dumb question, but I just tried to apply the "MacOS8
compatibility issues/"dancing icons" & read-only file troubles" patch,
located at
http://www.umich.edu/~rsug/netatalk/patches/1.4b2/afpd-macos8.diff
> to my Netatalk 1.4b2 (Linux x86) source using the command:

Make sure to download it "binary". I. e. in Navigator, use "Save Link as"
from the pop-up menu (or Shift-click the link).

Then, do
$ cd netatalk-1.4b2
$ patch <patchfile

This should do the trick.

Hope this helps,
Stefan

--
Stefan Bethke
Promo Datentechnik      |  Tel. +49-40-851744-18
+ Systemberatung GmbH   |  Fax. +49-40-851744-44
Eduardstrasse 46-48     |  e-mail: [email-masked]
D-20257 Hamburg         |  http://www.Promo.DE/