Subject: Re: [netatalk-admins] Urgent help needed (netatalk on Solaris2.6)

From: "David S." <[email-masked]>
Date: Sun, 22 Nov 1998 13:53:14 -0800 (PST)

> Hi Guys,
> 
> I finally got the Netatalk to compile and installed it successfully (no
> error message), but I can't get my Mac client to connect.
> 
> The error I get from the Mac client is "The connection to this server has
> been unexpectedly broken."  What did I do wrong?
> 
> The Netatalk version is 1.4b2+asun2.1.0.
> 
> I need to get the Netatalk up and running TODAY.  My users are screaming.
> So any suggestion and help are greatly appreciated.
> 

Make sure that you've

	1) added the flag "-DSHADOWPW" to the 'CFLAGS' definition in 			
	'etc/afpd/Makefile'
	
	2) commented out the 'PAMDIR=' line in the top-level 'Makefile' 		
	('netatalk's PAM support is broken on Solaris, or vice-versa)
	
	3) listed all of your users' shells in the server's '/etc/shells' file

David S.
[email-masked]

> Thanks.
> Kao Wang

---

From: Kao Wang <[email-masked]>
Date: Sun, 22 Nov 1998 16:20:03 -0600

Hi David,

Thanks for the quick help.

I have added the -DSHADOWPW option and removed the PAM support, recompiled
and reinstalled.  However, I don't understand what you mean by "list users'
shells in /etc/shells file."  I don't have a /etc/shells file.

In any case I am still getting the same error message from Mac client
(System 8.1), "The connection to this server has been unexpectedly broken."

Just to clarify on where I am, the lines in /etc/services and
/etc/netconfig were added already as described in the README.  Atalk.conf
was also set.  One uncertainty is the /etc/rc file.  Can you tell me if it
is correct?  The single line in the /etc/rc file is as follows:

sh /usr/local/atalk/etc/rc.atalk

Thanks again for your help.

Kao

---

From: Marc Matteo <[email-masked]>
Date: Sun, 22 Nov 1998 17:56:52 -0800

>         1) added the flag "-DSHADOWPW" to the 'CFLAGS' definition in

Really?  I didn't do this and my Solaris netatalk works great.

>         3) listed all of your users' shells in the server's '/etc/shells' file

Also make sure you've followed README.SOLARIS, i.e.:

*Added the right lines to /etc/netconfig
*Done the 'make kinstall'
*Manually created your atalk.conf file
etc.

Marc
-- 
Marc Matteo
Web Engineer, The Sacramento Bee
http://www.sacbee.com
"We're a newspaper, we don't actually own any bees."

---

From: Bill Studenmund <[email-masked]>
Date: Mon, 23 Nov 1998 15:41:34 -0800 (PST)

On Sun, 22 Nov 1998, Kao Wang wrote:

>         .  However, I don't understand what you mean by "list users'

That might be a problem. Add one.

All it needs to do is list, one per line, all the valid shells of your
users.

So if you use sh, csh, tcsh, and bash, it should be something like:

/bin/sh
/bin/csh
/bin/tcsh
/bin/bash

The idea is that anyone whose shell is NOT listed here will not be
permitted to log in via appletalk. So that you can make someone's shell
/usr/local/bin/we_locked_your_account_because_you_were_stealing_message
(which would print out a message explaining why a user was loged out) and
they couldn't use appleshare to get in.

Take care,

Bill