Subject: [netatalk-admins] Help! Occassional File Corruption Problem

From: "Frank Morton" <[email-masked]>
Date: Thu, 16 Jul 1998 14:29:52 -0500

We are  using netatalk-1.4b2+asun2.0a18.2 and are experiencing
occassional corruption on file transfers. It happens on various flavors
of the MacOS and on different Macs, pointing me to the server.

I'm using Red Hat 5.0, so the kernel is 2.0.31. It is a Dell Pentium II.

Here are some message showing in the logs. I would appreciate
any help interpreting them and if it could relate to this problem in
any way.

Thanks.
----------------------------------------------
Jul 15 08:31:20 what afpd[22856]: byte lock: 1162A NY CE Flyer: 0
Jul 15 08:31:21 what last message repeated 33 times
Jul 15 08:31:21 what afpd[22856]: byte lock: 1162A NY CE Flyer: 1
Jul 15 08:31:21 what afpd[22856]: byte lock: 1162A NY CE Flyer: 0
Jul 15 08:31:21 what afpd[22856]: byte lock: 1162A NY CE Flyer: 1
Jul 15 08:31:21 what afpd[22856]: byte lock: 1162A NY CE Flyer: 0
Jul 15 08:31:21 what afpd[22856]: byte lock: 1162A NY CE Flyer: 1
Jul 15 08:31:21 what afpd[22856]: byte lock: 1162A NY CE Flyer: 0
Jul 15 08:31:21 what afpd[22856]: byte lock: 1162A NY CE Flyer: 1
Jul 15 08:31:21 what afpd[22856]: byte lock: 1162A NY CE Flyer: 0

Jul 15 17:14:13 what afpd[24017]: session from 16.134:246 on 16.109:134
Jul 15 17:14:13 what afpd[24017]: login kdarby (uid 2100, gid 2000)
Jul 15 17:14:38 what afpd[315]: asp_alrm: 23724 timed out
Jul 15 17:14:48 what afpd[23724]: atp_rresp: Connection timed out
Jul 15 17:14:58 what afpd[23724]: afp_die: asp_shutdown: Connection timed
out
Jul 15 17:14:58 what afpd[315]: server_child[0] 23724 done
Jul 15 17:26:05 what afpd[24017]: main: asp_getrequest: -2
Jul 15 17:26:41 what afpd[24017]: main: asp_getrequest: -2
Jul 15 17:26:45 what afpd[24017]: main: asp_getrequest: -2
Jul 15 17:27:08 what afpd[24017]: main: asp_getrequest: -2
Jul 15 17:27:25 what afpd[24017]: main: asp_getrequest: -2
Jul 15 17:27:38 what afpd[24017]: afp_addicon: Input/output error
Jul 15 17:27:42 what last message repeated 14 times
Jul 15 18:01:00 what PAM_pwdb[24022]: (su) session opened for user news by
(uid=9)

---

From: Patrik Schindler <[email-masked]>
Date: Thu, 16 Jul 1998 22:38:25 +0200

>Jul 15 08:31:21 what afpd[22856]: byte lock: 1162A NY CE Flyer: 0

This happens when whe Program on the Mac "locks" a file. I get this messages while working with Excel 3.0, too. Not harmful.

>Jul 15 17:14:13 what afpd[24017]: login kdarby (uid 2100, gid 2000)

Normal user login. Not harmful.

>Jul 15 17:14:58 what afpd[315]: server_child[0] 23724 done

This is usually when a Mac crashed or network connectivity to this particular Mac is lost. Harmless for the Unix box. Maybe for the Mac not ;-)

>Jul 15 17:27:25 what afpd[24017]: main: asp_getrequest: -2

I get this when copying many Files. Harmless, I think.

>Jul 15 17:27:42 what last message repeated 14 times

After copying a file with BNDL-Resource and Icons (usually applications), afpd could not update the desktop database. IMO harmless.

>Jul 15 18:01:00 what PAM_pwdb[24022]: (su) session opened for user news by

Dunno. What's this?

I think your problems are related to CRFL-Translations...

When you copy a file from Mac to netatalk, netatalk knows it's type and switches properly between ascii and binary mode.
When you create a file on your netatalk box from unix side, it's default filetype is TEXT. As such, when copied it's considered as TEXT and all LF will be replaced by CR, as the Mac likes it.
The safest way to get around this is, recompile afpd after disabling -DCRLF in etc/afpd/Makefile.

:wq! PoC

---

From: Jonathan Benson <[email-masked]>
Date: Fri, 17 Jul 1998 16:22:04 +1000

If you are also getting messages to do with a flush or fork, or something to
do with invalid file descriptors then you are most likely getting the same
problems I've had with a user and her Excel 5.0 files.

The only way I got around this was to get the pre release of Andrews next
patch:
 ftp://ftp.u.washington.edu/pub/user-supported/asun/pre-asun2.1.0-3.tar.gz

He has changed the way bytelocks work (or disabled them or something) in this
version and everything seems to work fine with it for me, admiteddly I have
been using a slightly older version not the v3 release, but from reading the
Changelog this version sounds like it will be more reliable if anything.

If you need help compiling it then let me know, but it's fairly simple and you
should be fine.

---

From: [email-masked]
Date: Sun, 19 Jul 1998 10:47:54 -0400

> From:    Patrik Schindler <[email-masked]>
> To:      <[email-masked]>

> >Jul 15 17:26:05 what afpd[24017]: main: asp_getrequest: -2

This is an ASP retransmit.  Harmless, except that packet loss on an
AppleTalk network is generally pretty costly.

:wes

---

From: Patrik Schindler <[email-masked]>
Date: Sun, 19 Jul 1998 22:23:17 +0200

>AppleTalk network is generally pretty costly.

Ah! Thank you!

:wq! PoC