Subject: [netatalk-admins] Problems installing netatalk on Solaris

From: [email-masked] (Carl R Daudt)
Date: Wed, 13 May 1998 08:51:56 -0500

I am trying to install netatalk (version 1.4b2) on a Sparc 1000
(Solaris 2.5).  I was able to successfully do
a 'make', 'make kinstall' (as root), and 'make install' .
However, I am unable to start atalkd.  The error message is
simply:

"AppleTalk not up! Child exited with 1."

I was logged in as root when I tried to start atalkd.

-->Can you give me some suggestions in troubleshooting?

The following might or might not be important:

1) I used gcc as my compiler

2) I changed the following line in the sys/solaris/Makefile:
KCFLAGS=	-D_KERNEL -mno-app-regs -munaligned-doubles -fpcc-struct-return
to:
KCFLAGS=	-D_KERNEL -munaligned-doubles -fpcc-struct-return
(our compiler did not know about the -mno-app-regs option).

3) I added the following line near the top of sys/solaris/ddp.h:
#include "../netatalk/endian.h"

I do not know if the changes in 2) and 3) were appropriate, but they
were the only way I was able to get make to work.

The /etc/atalkd.conf file consists of a single line with:
le0
which is appropriate for our machine.

Any assistance you can give me would be greatly appreciated.

--Carl R Daudt
  Center For Earthquake Research and Information
  The University of Memphis
  3904 Central Avenue
  Memphis, TN  38152-6590
  901-678-4855   fax: 901-678-4734   email: [email-masked]

---

From: Johan Claesson <[email-masked]>
Date: Wed, 13 May 1998 18:30:49 +0200

> "AppleTalk not up! Child exited with 1."

This sounds like you forgotten to add the appropriate lines to
/etc/services and /dev/netconfig as mentioned in the README.Solaris file

Add the 4 lines below to /etc/services:
rtmp            1/ddp           # Routing Table Maintenance Protocol
nbp             2/ddp           # Name Binding Protocol
echo            4/ddp           # AppleTalk Echo Protocol
zip             6/ddp           # Zone Information Protocol

Add the line below to /etc/netconfig:
ddp        tpi_clts      -    appletalk ddp   /dev/ddp        -

Regards Johan
-- 
Johan Claesson                [email-masked]
Ericsson Utvecklings AB
Box 1505                      Phone: +46 8 727 30 95
S-125 25 ÄLVSJÖ, Sweden       Fax:   +46 647 82 76