Subject: [netatalk-admins] please help getting netatalk to work!

From: System Administrator <[email-masked]>
Date: Tue, 27 Jan 1998 15:17:25 -0500 (EST)

Hi,

I'm trying desperatly to get netatalk to work so a mac workstation can
access our linux webserver (cygnus.intergrafix.net) files. However, it is
being very difficult. I have tried both the .rpm and .tar.gz versions of
netatalk with the same results on bootup. I'll try to give you as much
detail as possible.

If i let atalkd make my atalkd.conf, on bootup I get:
starting appletalk daemons:Net (0) not in net-range (65280-65534)
 atalkdbind: Cannot assign requested address
bind: Cannot assign requested address

 And in /var/log/messages:
 papd[648]: restart (1.4b2)
 afpd[650]: main: atp_open: Cannot assign requested address

If I put nothing in the atalkd.conf, on bootup I get:
starting appletalk daemons: atalkd, 
nbp_rgstr: Connection timed out
Can't register cygnus:Workstation@*
nbp_rgstr: Connection timed out
Can't register cygnus:netatalk@*
 nbprgstr papd afpd

 And in /var/log/messages:
 atalkd[660]: restart (1.4b2)
 atalkd[660]: zip_getnetinfo for eth0
 last message repeated 2 times
 atalkd[660]: as_timer multiple interfaces, no seed
 atalkd[660]: as_timer can't configure eth0
 atalkd[660]: as_timer waiting for router
 atalkd[660]: ready 0/0/0
 papd[672]: restart (1.4b2)
 afpd[674]: Can't register cygnus:AFPServer@*

Then my ethernet card (onboard Intel EtherExpress Pro 100) goes nuts with
 eth0: Tx timeout: Transmit timed out
 eth0: Trying to restart the transmitter...

My ethernet is on eth0 and i'm using ip aliasing for virtual domains, so i
have eth0:1 eth0:2 eth0:3, etc..

'ifconfig eth0' reports
eth0 Link encap: 10Mbps Ethernet  HWaddr 00:A0:C9:60:50:0A
     inet addr: 206.245.154.68 Bcast:206.245.154.127 Mask:255.255.255.192
     EtherTalk Phase 2 addr:65280/160
     UP BROADCAST RUNNING MULTICAST  MTU: 1500  Metric: 1

     RX packets: etc, etc..
     TX packets: etc, etc..
     Interrupt: etc, etc..

PLEASE help if possible. Thanx.

-Cygnus
---------------------------------------------------------------------------
Anthony J. Biacco                           Network Administrator/Engineer
.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-.
         "The only way to predict the future, is to invent it."
.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-.
[email-masked]                                [email-masked]
                      http://cygnus.ncohafmuta.com/
---------------------------------------------------------------------------

---

From: Alistair Riddell <[email-masked]>
Date: Tue, 27 Jan 1998 21:26:36 +0000 (GMT)

Are there any other AppleTalk routers on your network?
If so what network ranges do they seed.
If not try the following:
shut down every mac on the network
set seed information in atalkd.conf (choose a suitable zone name and a
network range of something like 10-20)
start netatalk.
now start up the macs.

--
Alistair Riddell - BOFH
IT Support Department, George Watson's College, Edinburgh
Tel: +44 131 447 7931 Ext 176       Fax: +44 131 452 8594

---

From: a sun <[email-masked]>
Date: Tue, 27 Jan 1998 13:43:07 -0800 (PST)

this should be a FAQ. atalkd treats aliased interfaces as real
ones. as a result, you either need to setup your atalkd.conf to treat
your linux box as a router between the different interfaces or make
sure that it doesn't try to query the aliased interfaces. to do the
latter, just stick something like the following as the only line in
atalkd.conf:

	eth0 -phase 2 -net 0-65534 -addr <some number>.<number>

-a

---

From: System Administrator <[email-masked]>
Date: Tue, 27 Jan 1998 17:29:20 -0500 (EST)

> Are there any other AppleTalk routers on your network?

  any OTHER? if you consider the linux box a router, then no, no others.
  our cisco 2501 router doesn't have any appletalk on it. (both the linux
  server and mac plug into the ethernet switch, so the cisco is out of the
  picture)

> shut down every mac on the network

  there's only 1 mac btw.

> network range of something like 10-20)

  where do i get a zone name?? do i have to make one somewhere? if so,
where?

-Cygnus

---

From: Alistair Riddell <[email-masked]>
Date: Wed, 28 Jan 1998 10:18:30 +0000 (GMT)

Shut down the mac, then do (as root)

ifconfig eth0 -allmulti

then put this in your atalkd.conf file:

eth0 -phase 2 -net 10-20 -addr 10.5 -zone "Twilight Zone"

After putting that in your atalkd.conf file, start netatalk, and see if
you get any different results.

---

From: System Administrator <[email-masked]>
Date: Wed, 28 Jan 1998 11:41:54 -0500 (EST)

> you get any different results. 

Now i get in my syslog:

atalkd[640]: restart (1.4b2)
atalkd[640]: zip_getnetinfo for eth0
last messages repeated 2 times
atalkd[640]: config for no router
atalkd[640]: ready 0/0/0
kernel: eth0: Transmit timed out
kernel: eth0: TX timed out
papd[651]: restart (1.4b2)
afpd[653]: cygnus:AFPServer@# started on 11:34:00 (1.4b2)

that stupid eth0 keeps timing out, therefore can't get any data in or out
on the network. Stupid kernel net driver. And i can't change the network
card because it's on-board.

-Cygnus
.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-.._.-._.-._.-._.-._.-._.-._.-._.-.

---

From: Ignacio REGUERO <[email-masked]>
Date: Thu, 29 Jan 1998 17:34:38 +0100 (MET)

Hello,
 I believe that you have the same problem with Multicast on the
EtherExpress Pro 100B that I had. Here follows a description of the
problem and my solution.

                   cheers  ...Ignacio...

On Mon, 26 Jan 1998, Ignacio REGUERO wrote:
> 
> Date: Mon, 26 Jan 1998 10:58:53 +0100 (MET)
> From: Ignacio REGUERO <[email-masked]>
> To: [email-masked]
> Cc: [email-masked], [email-masked]
> Subject: Re: Interface restarts
> 
> Hello,
>  The timeouts in my case seem to be produced by delays introduced by the
> calculation of the multicast filter so I have done a little modification 
> to the eepro100 driver like the following
> 
> ---------------------------------------------------------
> set_rx_mode(struct device *dev)
> {
>         struct speedo_private *sp = (struct speedo_private *)dev->priv;
>         int ioaddr = dev->base_addr;
>         char new_rx_mode;
>         unsigned long flags;
>         int entry, i;
>  
>         if (dev->flags & IFF_PROMISC) {                 /* Set
> promiscuous. */
>                 new_rx_mode = 3;
>         } else if (dev->flags & IFF_ALLMULTI) {
>                 new_rx_mode = 1;
>         } else {
>         /*      new_rx_mode = 0; */
>                 new_rx_mode = 1;  /* Too many to filter perfectly --
> accept all multicasts. */
>         }
> ---------------------------------------------------------
> 
> This sort of modification was suggested in a related case for Tulip boards
> by Donald Becker (original mail follows).
> 
> This is working fine for me but I wonder if there is a cleaner solution
> for this multicast with Netatalk problem... 
>                  
>                    Best Regards 
> 
> Ignacio Reguero:  [email-masked]
> CERN,  European Laboratory for Particle Physics,
> IT Division, CH-1211 Geneva 23. Switzerland.   
> 
> -----------------------------------------------------------------------
> Return-Path: <[email-masked]>
> Received: from www2.w3-design.com (www2.w3-design.com [206.83.161.164])
>         by argonaut.w3-design.com (8.8.5/8.8.5) with ESMTP id OAA00419
>         for <[email-masked]>; Mon, 3 Nov 1997 14:04:53 -0800
> Received: from cesdis (new.gsfc.nasa.gov [128.183.38.51]) by
> www2.w3-design.com
> (8.7.5/8.6.9) with SMTP id OAA13742 for <[email-masked]>; Mon, 3 Nov
> 1997 14
> :05:36 -0800 (PST)
> Received: by cesdis (4.1/SMI-4.1)
>         id AA08204; Mon, 3 Nov 97 14:32:01 EST
> Received: from beowulf.gsfc.nasa.gov by cesdis (4.1/SMI-4.1)
>         id AA08197; Mon, 3 Nov 97 14:31:48 EST
> Received: by beowulf.gsfc.nasa.gov (4.1/SMI-4.1)
>         id AA07101; Mon, 3 Nov 97 14:37:32 EST
> Date: Mon, 3 Nov 1997 14:37:30 -0500 (EST)
> From: Donald Becker <[email-masked]>
> X-Sender: becker@beowulf
> To: Jeff Wiegley <[email-masked]>
> Cc: [email-masked]
> Subject: Re: tulip multicast and netatalk?
> In-Reply-To: <[email-masked]>
> Message-Id: <Pine.SUN.3.91.971103142917.6958H-100000@beowulf>
> Mime-Version: 1.0
> Content-Type: TEXT/PLAIN; charset=US-ASCII
> Sender: [email-masked]
> Precedence: bulk
>  
> On Mon, 3 Nov 1997, Jeff Wiegley wrote:
>  
> > Subject: tulip multicast and netatalk?
> >
> > Just having a little prroblem with netatalk and the netatalk people
> > indicate that it is a tulip driver problem.
>  
> Every single Linux driver that uses a multicast filter (as opposed to
> Rx-all-multicast when any multicast packets are desired) seems to be
> having
> a problem with netatalk.
>  
> Since they all use different multicast filter schemes, I'm starting to
> think
> it's a problem with netatalk, not a problem with my drivers.
>  
> > I asked the question on the netatalk mailing list about why this is
> > so and received this reply...
> >
> > > The caveat (for the DEC tulip based cards) is that the driver has
> > > difficulties with multicast. Upgrade to a newer kernel, and/or upgrade
> > > the tulip driver explicitly. Or you could force the card into
> promiscuous
> > > mode (not ideal or recommended, but it works). It's not that bad.
>  
> Ask them about the EEPro100 driver then... it seems to have problems with
> multicast as well.  And it computes the multicast filter internally, so
> the
> driver could only pass a corrupt multicast address list.
>  
> > Is this true? how do I fix it?  I am using the
> >
> >      "tulip.c:v0.83 10/19/97 [email-masked]"
> >
> > driver version with kernel version 2.0.29+ISS patch.
> >
> > Other than that I can't quite figure out how to get promiscuous mode
> > enabled and I can't figure out why this would be good/bad.
>  
> A patch is to always turn on the Rx-all-multicast flag:
>  
> In set_multicast_list():
>  
>         printk(KERN_INFO "%s: Promiscuous mode enabled.\n", dev->name);
>                 tp->csr6 |= 0xC0;
> -       } else if ((dev->mc_count > 1000)  ||  (dev->flags &
> IFF_ALLMULTI)) {
> +       } else if ((dev->mc_count > 0)  ||  (dev->flags & IFF_ALLMULTI)) {
>                 /* Too many to filter perfectly -- accept all multicasts.
> */
>                 outl(csr6 | 0x0080, ioaddr + CSR6);
>  
> This is evil, and wastes the *excellent* multicast filter of the Tulip,
> but..
>  
> Donald Becker
> [email-masked]
> USRA-CESDIS, Center of Excellence in Space Data and Information Sciences.
> Code 930.5, Goddard Space Flight Center,  Greenbelt, MD.  20771
> 301-286-0882
> http://cesdis.gsfc.nasa.gov/pub/people/becker/whoiam.html
> ----------------------------------------------------------------------- 
> 
> On Thu, 22 Jan 1998, Ignacio REGUERO wrote:
> 
> > Hello,
> > I am running RedHat 5.0 (Linux 2.0.32) which seems to include the latest
> > version of the Intel EtherExpress Pro 100 driver (v0.36) and since I
> > installed the Netatalk Appletalk support package I get restarts of the
> > ethernet interface as follows:
> >  
> >  
> > Jan 22 17:05:28 pcdisir atalkd[1877]: as_timer gateway 41088.28 down
> > Jan 22 17:10:28 pcdisir atalkd[1877]: as_timer gateway 41088.28 down
> > Jan 22 17:10:34 pcdisir kernel: eth0: Transmit timed out: status 0050
> > command 0000.
> > Jan 22 17:10:34 pcdisir kernel: eth0:  Tx timeout  fill index 8419
> > scavenge index 8404.
> > Jan 22 17:10:34 pcdisir kernel:     Tx queue  0000a000 0000a000 400ca000
> > 0000a000 00000000 0000a000 0000a000 0000a000 0000a000 0000a000 0000a000
> > 0000a000 0000a000 0000a000 0000a000 0000a000.
> > Jan 22 17:10:34 pcdisir kernel:     Rx ring  00000003 c0000003 00000003
> > 00000003 00000003 00000003 00000003 00000003 00000003 00000003 00000003
> > 00000003 00000003 00000003 00000003 00000003.
> > Jan 22 17:10:34 pcdisir kernel: eth0: Trying to restart the transmitter...
> >  
> > 
> > It seems that the Appletalk traffic is creating some problem...
> > 
> > Any idea? 
> > 
> > 
> >                     Thank you & Best Regards
> > 
> > 
> > 
> > Ignacio Reguero:  [email-masked]
> > CERN,  European Laboratory for Particle Physics,
> > IT Division, CH-1211 Geneva 23. Switzerland.
> > 
> > 
> 
> 

Ignacio Reguero:  [email-masked]
CERN,  European Laboratory for Particle Physics,
IT Division, CH-1211 Geneva 23. Switzerland.