Subject: [netatalk-admins] problem with translations

From: Chip Mefford <[email-masked]>
Date: Tue, 30 Jun 1998 07:36:04 -0400 (EDT)

Is probably a cr/lf problem, but
I am clueless;

Situation, Netatalk 1.4b2, linux
OS RHL 5.0,
Problem, in a nutshell, we use a file type
recognized by DOS as .dxf or the Autocad 
Digital eXchange Format. This file is 
spec'd to be a somewhat universal way to 
exchange CAD drawing or plotting information across
many different cad programs. When viewed from
anything not macintosh, these files are essentially
text,  vector information. 

I can generate a .dxf file from Minicad on the
macintosh, and then later use that file to 
import date into a new file, HOWEVER, whenever
I copy a raw .dxf file from a CD library onto my
netatalk file server, when importing to a Minicad
document, I recieve an error to the effect of
"Error, unexpected EOF" and of course, I get
nothing. When viewed with 'less or something, the
files look just fine, EOF appears right where it is
supposed to, right after the comment telling us that
it is going to, and all in all its driving me NUTZ!

The CAD folks are pressing me to dump Linux in favor
of NT (which I belive has even more problems) or 
a new Apple file server (which I am also led to 
belive has its own share of buggies) 

Can someone please point me to a CR/LF document
so I can understand what is going on? 

I am a principally Macintosh shop, with some linux
and some MS. 

Copstalk also crashes hard when trying to mount a
netatalk shared volume, any insights here would be a great
help

thanx so much

chipper

---

From: Vivek <[email-masked]>
Date: Tue, 30 Jun 1998 15:26:14 +0100 (BST)

> Is probably a cr/lf problem, but

[deletia] 

> it is going to, and all in all its driving me NUTZ!

First things first, set the default type creator to be 

BINA/UNIX in your AppleVolumes.system file, so that translation only
occurs if something has been specifically set to TEXT/<blah> by a Mac. If
its a CR/LF problem, that should deal with it. [ I personally reckon this 
should be the default, given the amount of grief CRLF seems to cause some 
people ] Then see what the type/creator set by Minicad is.

You can do this with something like resedit, or by looking at the contents
of a resource fork on the netatalk server:

for file:

/some/dir/foo.dxf

less /some/dir/.AppleDouble/foo.dxf

The type/creator string will be there, towards the end of the resource
fork, usually [ 557 bytes in, to be exact, 4 chars for the type, 4 for
the creator] 

Add an entry for .dxf in your AppleVolumes.system file.

If this doesn't fix things, then CRLF probably isn't your problem.

HTH
-- 
I dunno about the Big Bang. The Big Kludge I can believe in.

---

From: "Amarendranath (Amar) Vadlamudi" <[email-masked]>
Date: Thu, 23 Jul 1998 09:51:17 -0400 (EDT)

I have been using the UMich netatalk-971027 and the UMich AuthMan with
great success at our site which also uses AFS and Kerberos. Netatalk works
great and reports all AFS volume sizes accurately as far as I can tell. 

However, users report incredibly slow speeds. Essentially, it takes more
than a few seconds for the contents of a folder (in AFS) to display
completely. So the user can never be sure if he is seeing all the contents
of the folder or not. 

I have tried to use Adrian Sun's version (asun2.0a18.2) with the new
Solaris streams drivers from UMich in conjunction with AFS. This was in
the hope that AppleShareIP will prove to be significantly faster and solve
the speed problem. However, the AFS volume sizes reported are all
inaccurate and it just does not appear to function right. 

Is anybody successfully using Adrian Sun's IP netatalk with AFS ? If so,
do you have any tips for me.

Thanks in advance
--Amar 

--
####################################################################
Amarendranath Vadlamudi				Phone: 301-405-6597
Institute for Systems Research			FAX:   301-314-9920
University of Maryland				Email: [email-masked]