Subject: [netatalk-admins] No printer with RH5

From: pierre arnaud <[email-masked]>
Date: Thu, 11 Jun 1998 23:43:58 +0200

I have a problem with netatalk on red hat 5

I installed a netatalk rpm package called "netatalk-lorax" which differs quite
of bit from the tar.gz I had on my red hat 4.2 system. This pacakge came with
the red hat distribution. For some reason, I am unable to print from my Mac to
the hplj 6ML on my Linux box. No matter how I configure papd.conf, I see no
printer in the MAc selector when I select the laserwriter icon. On my rh 4.2
setup, it worked fine. Does anybody know this netatalk-lorax package? I have
only one printer, conncected to my linux box, it's crucial to get the mac to
work with it. Right now, I have to maintain a red hat 4.2 partition, solely for
that prupose !

Pierre Arnaud
[email-masked]

---

From: pierre arnaud <[email-masked]>
Date: Sat, 13 Jun 1998 00:13:36 +0200

On Fri, 12 Jun 1998, you wrote:
>Hello Pierre,

>- is the papd process running?

>- are there any messages when papd starts up (on the console or in the

>logs)?

>If You can not see the printer in the chooser, two things might be the

>reason:

>- papd is not running, and so it did not register the printer (You

>should see the server in this case, just the printer is missing)

>- papd is running, but it could not register the printer, because

>something happened to atalkd (in this case, You would not see the server

>at all)

papd, afpd and atalkd all run. I can mount shared linux volumes on the mac. I
see my linux machine in the chooser when I select appleshare. But I cannot see
t
he printer !

 >Hope, this helps,

>Sincerely,

>Andras Kadinger

>[email-masked]

---

From: pierre arnaud <[email-masked]>
Date: Sat, 13 Jun 1998 23:27:04 +0200

Andras,

Thanks so much for taking the time to reply. 

On Sat, 13 Jun 1998, you wrote:
>pierre arnaud wrote:

>> the printer !

>Have You created a papd.conf with the necessary entries? Don't forget to

>configure printcap as well.

Well I have created just one entry with the name of the printer in papd.conf. 

myprinter:\

It worked this way on redhat 4, seemingly because papd;conf used printcap (that
is, if I understand well the netatalk info). My printcap is as follows :

##PRINTTOOL3## LOCAL ljet4 600x600 a4 {} LaserJet4 Default 1
lp:\
	:sd=/var/spool/lpd/lp:\
	:mx#0:\
	:sh:\
	:lp=/dev/lp1:\
	:if=/var/spool/lpd/lp/filter:

I use an Hp laserjet 6L. It's a pcl printer, but on red hat 4.2 it did show in
the chooser when I selected the laserwriter icon.

While I'm at it, let me give you the other config files. There's one file called
"config, that's specific to netaltalk "lorax". it resides in /etc/atalk, along
with AppleVolumes.default, atalk.conf, and papd.conf.

config :
# Appletalk configuration
# Change this to increase the maximum number of clients that can connect:
AFPD_MAX_CLIENTS=5
# Change this to set the machine's atalk name:
ATALK_NAME="linux"
# Comment out this line to enable normal (clear text) logins:
#AFPD_NOCLR=-C
# Comment out this line to enable AFS login: (not yet supported)
#AFPD_NOAFS=-A
# Comment out this line to enable kerberos login: (not yet supported)
#AFPD_NOKRB=-K
# Comment out this line to enable guest logins:
#AFPD_NOGUEST=-G
# Change this to set the id of the guest user
AFPD_GUEST=nobody
# Set which daemons to run:
PAPD_RUN=yes
AFPD_RUN=yes
# Control whether the daemons are started in the background
ATALK_BGROUND=yes

Then there is /etc/rc.d/init.d/atalk.init:

#!/bin/sh

# Source function library.
.. /etc/rc.d/init.d/functions

# Source networking configuration.
.. /etc/sysconfig/network

# Source Appletalk configuration
.. /etc/atalk/config

# Check that networking is up.
[ ${NETWORKING} = "no" ] && exit 0

# See how we were called.
case "$1" in
  start)
	echo -n "Starting AppleTalk services: "
	if [ ${ATALK_BGROUND} = yes ] ; then
	    echo -n "(backgrounded)"
	    {
		daemon atalkd
		nbprgstr -p 4 "${ATALK_NAME}:Workstation"
		nbprgstr -p 4 "${ATALK_NAME}:netatalk"
		if [ ${PAPD_RUN} = yes ] ; then
		    daemon papd
		fi
		if [ ${AFPD_RUN} = yes ] ; then
		    daemon afpd ${AFPD_NOCLR} ${AFPD_NOAFS} ${AFPD_NOKRB} \
			${AFPD_NOGUEST} -g ${AFPD_GUEST} \
			-c ${AFPD_MAX_CLIENTS} -n ${ATALK_NAME}
		fi
	    } >/dev/null &
	else
	    daemon atalkd
	    nbprgstr -p 4 "${ATALK_NAME}:Workstation"
	    nbprgstr -p 4 "${ATALK_NAME}:netatalk"
	    if [ ${PAPD_RUN} = yes ] ; then
		daemon papd
	    fi
	    if [ ${AFPD_RUN} = yes ] ; then
		daemon afpd ${AFPD_NOCLR} ${AFPD_NOAFS} ${AFPD_NOKRB} \
		    ${AFPD_NOGUEST} -g ${AFPD_GUEST} \
		    -c ${AFPD_MAX_CLIENTS} -n ${ATALK_NAME}
	    fi
	fi
	echo
	touch /var/lock/subsys/atalk
	;;
  stop)
	echo -n "Shutting down AppleTalk services: "
	killall afpd
	killall papd
	nbpunrgstr "${ATALK_NAME}:Workstation@*"
	nbpunrgstr "${ATALK_NAME}:netatalk@*"
	killall atalkd
	# Attempt to zap the module, so that we can restart the
	# Appletalk daemons cleanly
	if [ -e /proc/modules ] && [ -x /sbin/modprobe ] ; then
	    modprobe -r appletalk
	fi
	rm -f /var/lock/subsys/atalk
	echo ""
	;;
  *)
	echo "Usage: atalk {start|stop}"
	exit 1
esac

Thanks again

Pierre Arnaud
[email-masked]

PS: what does .hu stand for in your address ? Hungary ?