Subject: [netatalk-admins] Printing Config Problem

From: Doug Littlefield <[email-masked]>
Date: Mon, 23 Feb 1998 12:31:39 -0800

Trying to print to appletalk LaserWriter on ethernet via Linux box. Read
All the docs, how tos I can
find. Lurked on this for months, searched the archives.

It's time to yell for help.  (I saw the articles on how great the Linux
community is on "customer support") -:)
============================================

Running Redhat 4.2, netatalk 1.4b2   rpm

I can get aecho and can print directly via pap a postscript test.ps
file.
Printing goes to the spool directly just fine.
Can't get any thing out of the printer.
lpc, status says it's printing.

===========================================

.paprc

#PRINTTOOL3## REMOTE POSTSCRIPT 600x600 letter {} PostScript Default {}
lp0|LaserWriter Pro 630|LaserWriter:\
        :pr=lp0:\

==============================================

# /etc/printcap

(The first printer, lp, the laserjet works fine)

##PRINTTOOL3## LOCAL laserjet 300x300 letter {} LaserJet Default 1
lp:\
        :sd=/var/spool/lpd/lp:\
        :mx#0:\
        :sh:\
        :pl:\
        :60:\
        :sf:\
        :ff=:\
        :lp=/dev/lp1:\
        :if=/var/spool/lpd/lp/filter:

##PRINTTOOL3## REMOTE POSTSCRIPT 600x600 letter {} PostScript Default {}

lp0|"LaserWriter Pro 630"|LaserWriter:\
        :sd=/var/spool/lpd/lp0:\
        :lp0=/var/spool/lpd/lp0/dev/null:\
        :pl#63:\
        :pw#85:\
        :mx#0:\
        :sh:\
        :sf:\
        :lf=/var/log/lpd-errs:\
        :if=/usr/local/atalk/etc/filters/ifpap:\
        :of=/usr/local/atalk/etc/filters/ofpap:

=====================================
papd.conf

(I tried this with just first 2 lines, but papd didn't see it )

##PRINTTOOL3## REMOTE POSTSCRIPT 600x600 letter {} PostScript Default {}

lp0|"LaserWriter Pro 630"|LaserWriter:\
        :sd=/var/spool/lpd/lp0:\
        :lp0=/var/spool/lpd/lp0/dev/null:\
        :pl#63:\
        :pw#85:\
        :mx#0:\
        :sh:\
        :sf:\
        :lf=/var/log/lpd-errs:\
        :if=/usr/local/atalk/etc/filters/ifpap:\
        :of=/usr/local/atalk/etc/filters/ofpap:

======================================

/var/log/lpd-errs

lp0:LaserWriter@*: NBP Lookup failed
lp0:LaserWriter@*: NBP Lookup failed
lp0:LaserWriter@*: NBP Lookup failed

=========================================

Got this automatic email

Subject: printer job
   Date:  Mon, 23 Feb 1998 15:18:08 -0800
  From:  bin <[email-masked]>
    To:     [email-masked]

Your printer job (Mac Job)
was not unlinked: permission denied

==============================

Thanks for the help.

Doug Littlefield

---

From: Peter Gutowski <[email-masked]>
Date: Tue, 24 Feb 1998 06:44:16 -0500 (EST)

Doug,

Having recently worked a number of bugs with a similar setup (RH
5.0/Pentium/Laserwriter via Ethernet & HPDeskJet 870 attached to lp1)
Here's my voodoo:

> lpc, status says it's printing.

observation: my .paprc file only has the appletalk name of the printer in
its spool folder (this for my Laserwriter, of course the DeskJet doesn't
have a paprc file 'cause it prints via parallel port)

The man page for papd says that the contents of a papd.conf file should 
ONLY contain 3 entires: "pr", "op" and "pd". Yeah, it says it's
"formatted" like a printcap file, but that's where it ends. Here's a
portion of my papd.conf:

DeskJet 870 Faster Text:\
        :pr=lp:op=daemon:\

This is probably coming from your erroneous .paprc file: it's looking
for a Laserwriter called lp0!

Also, when logged in as a "normal" user (not root) I had trouble printing
when I said "cat <file> | lpr", until I change perms of lpr as follows:

-r-sr-sr-x   1 root     lp          15244 Oct 30 10:39 /usr/bin/lpr