Subject: [netatalk-admins] Printing problems

From: William Knox <[email-masked]>
Date: Tue, 10 Mar 1998 19:01:09 -0500

I am attempting to print to a HP LaserJet 4 that I have set up with pap 
on my Linux box.  It is normally working fine, but when I try to print 
from a Windows 95 machine (which is being served the printer with samba), 
I get (at least from some of the Windows machines - others work fine) the 
following message in my system console:

status: Permission denied
unprintable character (0x1b)!
status: Permission denied

The printer's light flashes, pauses, and then it gives up silently.
I am running netatalk 1.4b2 with the asun patches, Linux 2.0.32, and (for 
what it's worth) samba 1.9.17p4.  

					Bill Knox ([email-masked])
					Harvard University Herbaria
					(617) 496-3023

---

From: Richard Mann <[email-masked]>
Date: Wed, 11 Mar 1998 09:27:10 -0600 (CST)

Some of the printer drivers on the Windows 95
	disk are crap. I have switched over to
	Adobe's PostScript driver for Win95 (and 3.11),
	which you can get from
	
http://www.adobe.com/supportservice/custsupport/download.html

	You can also get the latest PPD for that printer
	from the same site. (When the install utility
	asks you to select your printer, you point it
	to the directory containing that PPD file.)

	I haven't had any trouble printing to my
	HP LaserJet 4/4M Plus since.

     //\     --rich
    //  \    
   // /  \   Richard Mann -- Network Administrator
  // / /  \  P u b l i c a t i o n  S e r v i c e s,  I n c. 
  \\  / / /  Champaign, Illinois, USA 61821 (217) 398-2060 x22
   \\  / /   
    \\  /    
     \\/