Subject: [netatalk-admins] problems installing on Solaris 2.6

From: "Maurizio Davini" <[email-masked]>
Date: Fri, 23 Oct 1998 09:54:30 +0200

I have the following problem....

Making kinstall for solaris...
make[1]: Entering directory
`/export/home/mau/solaris-freeware/netatalk-1.4b2+as
un2.1.0/sys/solaris'
rem_drv ddp
sync;sync;sync
/usr/ucb/install -c ddp /usr/kernel/drv/ddp
ln /usr/kernel/drv/ddp /usr/kernel/strmod/ddp
/usr/ucb/install -c ddp.conf /usr/kernel/drv/ddp.conf
add_drv -m '* 0666 root sys' ddp
drvconfig: '/etc/path_to_inst' - No such file or directory
drvconfig: Warning: '/etc/path_to_inst' was updated.
drvconfig: Warning: failed to update '/etc/path_to_inst'
Warning: Driver (ddp) successfully added to system but failed to attach

make[1]:
*** [kinstall] Error 1
make[1]: Leaving directory
`/export/home/mau/solaris-freeware/netatalk-1.4b2+asu
n2.1.0/sys/solaris'
make: *** [kinstall] Error 2
                                                            Can someone help
?
                                                                Maurizio

---

From: Dejan Ilic <[email-masked]>
Date: Fri, 23 Oct 1998 17:22:31 +0200 (MET DST)

No problems for me in Sparc Solaris 2.6

Dejan

> make: *** [kinstall] Error 2

=====================================================================
Dejan Ilic, Tech Univ. of Linkoping, Sweden    Phone:+46-13-473 01 06
Email: [email-masked]   Web: http://www.lysator.liu.se/~svedja
=====================================================================
[finger -l [email-masked] for public PGP key]

---

From: Michael M Han <[email-masked]>
Date: Fri, 23 Oct 1998 09:14:29 -0700

Well, not much idea *why* this happens, but try 'man add_drv', 'man
drvconfig' and 'man path_to_inst'. Basically, make can't install your
kernel modules correctly. Are you by any chance doing the diskless
thing?

Previously...
>make: *** [kinstall] Error 2
_________
mike ([email-masked])
I do not have power of attorney over first graders
 - The collected wisdom of Bart Simpson