Subject: [netatalk-admins] Can't get shares to show!

From: [email-masked]
Date: Thu, 16 Apr 98 20:30:40 CDT

All you Linux-heads out there...

Just decided this afternoon to run Appletalk on my Linux box at work.  Had it up and running a couple of hours no problem.  It's sweet.  I do have one problem though.  I can't seem to share out any volumes on the Linux box other than those in the /home directory (which is by default).  I've checked and triple-checked (notice that he went from the "single check" right for the "triple check" skipping the "double check") the AppleVolumes.default and .system files in the ../atalk/etc area, and even though I have volumes spec. to share out, I don't see them.  Guest gets nothing.  I checked file permissions on these files to make sure they had at least w+r, but still nothing works.  Anyone had any experience running AT on Linux and had this problem?  Before I compiled atalk with no shadow passwords, I could get whatever volumes I specified in guest but couldn't log in as a regular user (no shadow password support, remember?).  After I recompiled afpd w/shadow password support, I g!
 et this weird inflexibility...  I 
used the AppleVolumes.default and .system files that were provided in the 1.4.2 beta distribution (in the ../config area) but added only two lines for additional shares to both the *.system and *.default files:

/home "People"
/usr "Usr Area"

Doesn't work!

Otherwise, I would highly recommend this product to anyone.  It's killer...

Chris

---

From: Andras Kadinger <[email-masked]>
Date: Fri, 17 Apr 1998 04:29:48 +0200

Chris,

[email-masked] wrote:
> the AppleVolumes.default and .system files in the ../atalk/etc area,

Before everything else, try to use /etc/* instead of any
'../atalk/etc/*', and see if that works. I hope it does. Don't listen to
the docs if they say something else.

Also, I recommend using Adrian Sun's patch set, which is available at:

ftp://ftp.u.washington.edu:/public/asun/

Hope this helps,

Sincerely,
Andras Kadinger
[email-masked]

---

From: [email-masked]
Date: Fri, 17 Apr 1998 08:46:35 -0000 (???)

Hi!

The AppleVolumes.default and AppleVolumes.system must be readable for the world 
(644). 

Regards
Helmut

On 17-Apr-98 [email-masked] wrote:
> Just decided this afternoon to run Appletalk on my Linux box at work.  Had it
> up and running a couple of hours no problem.  It's sweet.  I do have one
> problem though.  I can't seem to share out any volumes on the Linux box other
> than those in the /home directory (which is by default).  I've checked and
> triple-checked (notice that he went from the "single check" right for the
> "triple check" skipping the "double check") the AppleVolumes.default and
> .system files in the ../atalk/etc area, and even though I have
>  volumes spec. to share out, I don't see them.  Guest gets nothing.  I
> checked file permissions on these files to make sure they had at least w+r,
> but still nothing works.  Anyone had any experience running AT on Linux and
> had this problem?  Before I compiled atalk with no shadow passwords, I could
> get whatever volumes I specified in guest but couldn't log in as a regular
> user (no shadow password support, remember?).  After I recompiled afpd
> w/shadow password support, I g!
> used the AppleVolumes.default and .system files that were provided in the
> 1.4.2 beta distribution (in the ../config area) but added only two lines for
> additional shares to both the *.system and *.default files:
> 
> /home "People"
> /usr "Usr Area"
> 
> Doesn't work!
> 

MfG
Helmut Franzke

---------------------------------------------------------------------
RP-Online Verlagsgesellschft mbH        http://rp-online.de
E-Mail: [email-masked]
Date: 17-Apr-98
Time: 08:41:40

This message was sent by LINUX-XFMail
---------------------------------------------------------------------