Subject: [netatalk-admins] Compile error, and question about limiting printing.

From: [email-masked] (Mr M S Aitchison)
Date: Fri, 27 Nov 1998 18:41:32 +1300

1. I get the following error when trying to make netatalk on a linux 2.0.34
   system. I guess I'm doing something stupid - any ideas what?  This happens
   1.4b2 (I get "asp_getsess.c:178: incompatible types in assignment" in 1.3.3)...

main.c: In function `main':
main.c:255: `TIOCNOTTY' undeclared (first use this function)
main.c:255: (Each undeclared identifier is reported only once
main.c:255: for each function it appears in.)
make[4]: *** [main.o] Error 1
make[4]: Leaving directory `/usr/local/netatalk-1.4b2/etc/afpd'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/usr/local/netatalk-1.4b2/etc/afpd'
make[2]: *** [afpd] Error 2
make[2]: Leaving directory `/usr/local/netatalk-1.4b2/etc'
make[1]: *** [../../etc] Error 2
make[1]: Leaving directory `/usr/local/netatalk-1.4b2/sys/linux'
make: *** [all] Error 2

2. Can I require a password somehow before allowing printing from Macs?

Thanks,
---------------------------------------------------------------------------
Mark Aitchison,               \_  Phone: +64 3 364-2947 home 337-1225
Dept of Physics & Astronomy,  <|    Fax: +64 3 364-2469  or  364-2999
University of Canterbury,    /)     Web: www.phys.canterbury.ac.nz/~physmsa
Christchurch, NEW ZEALAND.  (/'  E-mail: [email-masked]

---

From: Richard Hyde <[email-masked]>
Date: Fri, 27 Nov 1998 15:40:42 -0800

> make[1]: Leaving directory `/usr/local/netatalk-1.4b2/sys/linux'

That's what it looked like for me when I tried to compile netatlk-1.4b2 on my RedHat 5.1 system.  The pre-patched 1.4b2-asun source dist did the trick.

Richard Hyde
Sysadmin ScienceVIEW
[email-masked]