Subject: [netatalk-admins] Using Netatalk as a Router

From: Tony Moran <[email-masked]>
Date: Tue, 28 Apr 1998 10:59:56 +0100

Hi, this doesnt seem to be documented anywhere,
but I believe it's possible.  So how do I use a Netatalk Server
as a router on a Ethernet/Appletalk/TCP/IP network ?

Can I use it to define and name Zones ?
Do I need to install a second Network Card ?
I know I can define Zones in atalkd.conf, but how do I add extra ones ?

This, from Eddie Irvine on Wed, 1 Apr 1998,  is what I'd like to do :

> Use a netatalk box as a router to break your appletalk network
> into zones, and then use Appleshare in multi-homing mode.

Basically I'm clueless on this side of things and any help on how to
achieve this would be much appreciated.  I'll write anything up I get
from the list for posterity.

Many thanks,  Tony

__________________________________________________
Tony Moran		Scope Communications.
IT Manager		http://www.infolive.ie
Ph:   (+353-1)-8303455	http://www.jobfinder.ie
Fax: (+353-1)-8300888	Ireland's Jobs and IT resources Web Site
__________________________________________________
How to complain about Spam: http://weber.ucsd.edu/~pagre/spam.html
-=-=-=-=-=-=--=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

      "'Tis true; there's magic in the web of it;" Othello, Act 3 Scene 4

                                          ->>!<<-

---

From: "Eddie Irvine" <[email-masked]>
Date: Thu, 30 Apr 1998 20:12:32 +1000

>So how do I use a Netatalk Server

Ok. First you have to have two ethernet networks not
connected together. Let us call them "Room1" and
"Room2".

The ip addresses in Room1 are in a different ip subnet
to Room2. Let us say Room1 is 192.168.1.1/24 and
Room2 is 192.168.2.1/24.

Your unix box has two network cards - one for each room.
Let us call these network cards "ed0" and "ed1".
I must assume, as I don't know your system, that
ed0 and ed1 are already configured with the right ip
addresses.
 
Let us say:
ed0 = 192.168.1.1 and ed1 = 192.168.2.1
 
All the computers in room 1 have the "gateway"
address set to 192.168.1.1
 
All the computers in room 2 have the "gateway"
address set to 192.168.2.1
 
Get this far, and on most systems a computer in Room1
can ping (IP ping) a computer in room 2. Unix will do
the routing automatically (at least with FreeBSD).
 
Now for netatalk. I can't get this exactly right 'cause
I'm not at work - but here is an attempt:
 
edit your atalkd.conf file so it looks like so:

ed0 -seed -somethingtodowithaddresses -zone Room1
ed1 -seed -somethingtodowithaddresses -zone Room2
 
man atalkd to get it right.
 
Note that somethingtodowithaddresses
refers to Appletalk address ranges not
IP addresses or card addresses.
 
Turn every appletalk device off in both rooms, and
restart netatalk.
 
And Voila! When you restart your Macs, they should now
show zones on the chooser, and macping will now
ping a mac in another room with Appletalk as well
as TC/IP.
 
If atalkd didn't like your configuration file, however,
it will rewrite the whole thing.
 
>I know I can define Zones in atalkd.conf, but how do I add extra ones ?

You can't have two zones unless you have two ethernet or
appletalk networks. It is probably not worth splitting up
an existing network unless you have more than 20 or so Macs.
 
Phew! I should write a howto on this!

Check out http://thehamptons.com/anders/netatalk/atalkd.conf.html 
as well.