Subject: [netatalk-admins] problem when starting the daemon

From: Vincent Katz <[email-masked]>
Date: Fri, 10 Jul 1998 16:59:48 +0200

Hello,

i have installed netatalk 1.4b2. But when i boot linux (version 2.0.30)
and i start the atalkd i have the msg :

starting appletalk daemons:eth0: Setting Rx mode to 2 addresses.
eth0: Setting Rx mode to 3 addresses.
Too many routes/iface.
AppleTalk not up! Child exited with 1.
 atalkdnbp_rgstr: Connection timed out
Can't register Toto:Workstation@*
nbp_rgstr: Connection timed out
Can't register Toto:netatalk@*
 nbprgstr papd afpd.

i dont understand what is the problem. It s the first time that i have
this problem.
the daemon seems to have some difficults to differentiate the local
route on eth0 and the gateway route on eth0 ?

my route :
Kernel IP routing table
Destination     Gateway               Genmask             Flags Metric
Ref    Use Iface
localnet            *                            255.255.255.128
U            0        0       47 eth0
loopback           *                           255.0.0.0
U            0         0        2 lo
default               xxx.xxx.xxx.xxx  0.0.0.0               UG
1         0       74 eth0

who can help me please?
thanks.

Vincent Katz
[email-masked]

---

From: Pat Trainor <[email-masked]>
Date: Fri, 10 Jul 1998 11:54:21 -0400 (EDT)

> Can't register Toto:netatalk@*

hmm.. in linux 2.* do a:

frank:~# netstat -rn
Kernel IP routing table
Destination Gateway    Genmask       Flags MSS  Window  irtt   Iface
192.1.23.0  0.0.0.0    255.255.255.0 U     1500 0       0      eth0
127.0.0.0   0.0.0.0    255.0.0.0     U     3584 0       0      lo
0.0.0.0     192.1.23.1 0.0.0.0       UG    1500 0       0      eth0

	From what I saw, you are in fact missing a default route.. The
above are behind a firewall, so I don't mind giving you realistic values.
My router is the .1, and 192.1.23 is my class C..
	It looks like your interface doesn't mind having multiple
addresses bound to it, which is a kernel compile option. /etdc/services is
correct, right:

frank:~# cat /etc/services | grep ddp
rtmp            1/ddp           # Routing Table Maintenance Protocol
nbp             2/ddp           # Name Binding Protocol
echo            4/ddp           # AppleTalk Echo Protocol
zip             6/ddp           # Zone Information Protocol

	That's where I'd start, along with your
/usr/local/atalk/etc/atalkd.conf starting off with a line:

eth0

(the system will fill in the rest when it starts..)

	Just a few ideas..

pat 	
:)

Pat Trainor
System Administration - BBN Technologies
[email-masked] - key: www.title14.com/pgp/pat.key
..will program for boat