Subject: [netatalk-admins] Routing between LocalTalk and EtherTalk: news

From: Patrik Schindler <[email-masked]>
Date: Thu, 16 Jul 1998 16:18:06 +0200

Hi,

I sniffed around a bit in /proc/net/atalk_route. I thought that might help isolating the routing-issue I discovered:

I've two linux-boxes, tycho with three interfaces and leela with two. Leela's eth0 and tycho's eth0 are connected together. The respective atalkd.conf's look as follows:

[tycho]
ltalk0 -seed -phase 1 -net 125 -addr 125.1 -zone "Local"
eth0 -seed -phase 2 -net 100-120 -addr 100.1 -zone "Ether"
eth1 -seed -phase 2 -net 130-140 -addr 130.1 -zone "Ether"

[leela]
eth0 -seed -phase 2 -net 100-120 -addr 101.1 -zone "Ether"
eth1 -seed -phase 2 -net 150-160 -addr 150.1 -zone "Ether"

I found the following data (consolidated and decoded from hex by myself) in tycho's /proc/net/atalk_route:

Target          Router  Flags   Dev
130.1           0.0     5       lo
150-160         101.1   3       eth0
130-140         130.1   1       eth1
100.1           0.0     5       lo
100-120         100.1   1       eth0
125.1           0.0     5       lo
125             125.1   1       ltalk0
0.0             0.0     5       lo

In leela respective:

Target          Router  Flags   Dev
130-140         100.1   3       eth0
150.1           0.0     5       lo
150-160         150.1   1       eth1
101.1           0.0     5       lo
100-120         101.1   1       eth0
0.0             0.0     5       lo

Type 3 (remote?) routes only appear for EtherTalk but NOT for LocalTalk in leela. I think, tycho won't broadcast its ltalk0-route (net 125) with RTMP.
Is there anyone who can help track this down in source? Adrian? Alan?

:wq! PoC

---

From: Patrik Schindler <[email-masked]>
Date: Thu, 16 Jul 1998 19:26:17 +0200

Me again, ;-)

I've changed the configuration for a one-number range:

[tycho]
ltalk0 -seed -phase 1 -net 10 -addr 10.1 -zone "Local"
eth0 -seed -phase 2 -net 11 -addr 11.1 -zone "Ether"
eth1 -seed -phase 2 -net 12 -addr 12.1 -zone "Ether"

[leela]
eth0 -seed -phase 2 -net 11 -addr 11.2 -zone "Ether"
eth1 -seed -phase 2 -net 13 -addr 13.1 -zone "Ether"

>Type 3 (remote?) routes only appear for EtherTalk but NOT for LocalTalk in leela. I think, tycho won't broadcast its ltalk0-route (net 125) with RTMP.

Okay, the route to 10 is now showing up in leela's /proc/net/atalk_route -> no ranges allowed in the entire net? Why? Is netatalk not 100% Phase-2 compliant?

But aecho-requests won't even now come back from LocalTalk devices to anything in the net except tycho.

More interesting facts:
- A Mac within net 12 can see devices on localtalk (but cannot send any data to them). Because this net is directly connected?
- A Mac in net 10 cannot see anything but devices in net 10 (and an running AFPServer on tycho).
- A Mac in net 12 cannot see any devices in net 13.
- A Mac in net 13 cannot see any devices in net 12.

I remember someone complaining about the last 2 facts in this list a while ago.

It seems that routing further than 1 hop simply doesn't work.

Something else, I missed to state clear: Aechoing the local LocalTalk interface address from anywhere succeeds.

Any tips?

:wq! PoC