Subject: [netatalk-admins] ANOTHER Problem compiling 1.4B2

From: "Jamie Orzechowski" <[email-masked]>
Date: Fri, 19 Jun 1998 17:45:33 -0400

i made it past my first error by including ioctls.h but now I get a crypt
error ... I included crypt.h but fdidn't work .. any ideas??

here is a compile output

make[3]: Entering directory `/tmp/netatalk-1.4b2/etc/afpd'
if [ x"" != x ]; then \
    KRBLIBS="-lkrb -ldes"; \
    KRBLIBDIRS="-L/lib"; \
    KRBINCPATH="-I/include"; \
    KRBDEFS="-DKRB"; \
fi; \
if [ x"" != x ]; then \
    AFSLIBS="-lkauth -lprot -lubik -lauth -lsys -lrxkad -lrx -laudit \
        -llwp -lcmd -lcom_err /lib/afs/util.a -ldes"; \
    AFSLIBDIRS="-L/lib -L/lib/afs"; \
    AFSINCPATH="-I/include"; \
    AFSDEFS="-DAFS"; \
fi; \
make -w CC="gcc" ADDLIBS="" DEFS="" \
    OPTOPTS="-O2 -fsigned-char" DESTDIR="/usr/local/atalk" \
    SBINDIR="/usr/local/atalk/etc" BINDIR="/usr/local/atalk/bin"
RESDIR="/usr/lo
cal/atalk/etc" \
    ETCDIR="/usr/local/atalk/etc" LIBDIR="/usr/local/atalk/lib"
INCDIR="/usr/loc
al/atalk/include" \
    KRBLIBS="${KRBLIBS}" KRBLIBDIRS="${KRBLIBDIRS}" \
    KRBINCPATH="${KRBINCPATH}" KRBDEFS="${KRBDEFS}" \
    AFSLIBS="${AFSLIBS}" AFSLIBDIRS="${AFSLIBDIRS}" \
    AFSINCPATH="${AFSINCPATH}" AFSDEFS="${AFSDEFS}" \
    afpd
make[4]: Entering directory `/tmp/netatalk-1.4b2/etc/afpd'
gcc    -O2 -fsigned-char -I../../include   -DAPPLCNAME -DCRLF   -o afpd
unix.o a
fs.o kuam.o send_to_kdc.o lifetime.o ofork.o main.o switch.o auth.o volume.o
dir
ectory.o file.o enumerate.o desktop.o filedir.o fork.o appl.o gettok.o
bprint.o
-L../../libatalk   -latalk
unix.o: In function `setdeskmode':
unix.o(.text+0x18b): the `getwd' function is dangerous and should not be
used.
auth.o: In function `clrtxt_login':
auth.o(.text+0x541): undefined reference to `crypt'
make[4]: *** [afpd] Error 1
make[4]: Leaving directory `/tmp/netatalk-1.4b2/etc/afpd'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/tmp/netatalk-1.4b2/etc/afpd'
make[2]: *** [afpd] Error 2
make[2]: Leaving directory `/tmp/netatalk-1.4b2/etc'
make[1]: *** [../../etc] Error 2
make[1]: Leaving directory `/tmp/netatalk-1.4b2/sys/linux'
make: *** [all] Error 2
[root@zima netatalk-1.4b2]#

---

From: [email-masked]
Date: Fri, 19 Jun 98 15:33:31 PST

Original message sent on Fri, Jun 19  13:45 by [email-masked] (Jamie

> error ... I included crypt.h but fdidn't work .. any ideas??

There is a patch for 1.4b2 which fixes the compile problems under RH5, you can
find it at:

<http://www.thehamptons.com/anders/netatalk>

It is just a matter of a few different #includes, -lcrypt when linking, a few
other misc. bits, and everything will compile just fine.

Bob

---

From: [email-masked]
Date: Fri, 19 Jun 98 15:33:31 PST

Bob