Subject: [netatalk-admins] Error with Freehand

From: "Norbert Neumeier" <[email-masked]>
Date: Thu, 10 Dec 1998 10:33:20 +0100

Hello

I have a Linux Server with Netatalk and it seems to be fine.

Saving a Feehand-File on the Server works, but opening the
same file later chauses an error:
"Your request could not be executed.
An error has happened..." ( form german ).

Saving the file on the Mac, copy to the Server, and open is OK.
But when I'm saving the file on the Server this file doesn't work
anywhere.

I've saved the file on the Mac, and the same on the Server, then I put
the File from the Mac on the Server. The two files seemed to be
identical, but only the file from the mac could be opened.

In the File-Open-Box is the preview of the bad file and the good file
available.

With other programs (e.g. Photoshop) the saving and opening is no
problem.

My version of Linux Suse 5.3 (Kernel 2.0.35), Netatalk 1.4b2+asun.

I hope anyone can help me to solve this problem.

bye
Norbert Neumeier
[email-masked]

---

From: Patrick Herzog <[email-masked]>
Date: Fri, 11 Dec 1998 14:50:00 +0100

> An error has happened..." ( form german ).

This is a known problem. Freehand generates the file as TEXT file, then saves
the data and changes the Type to whatever (FH..). Netatalk has builtin cr-lf
conversion for TEXT files which means that your files get corrupted if they
contain '13'-data (what they usually do).
You should compile Netatalk with crlf conversion disabled. Then anything works.

Patrick
--
Dr.-Ing. Patrick Herzog
-- Oberingenieur --
RWTH Aachen
Institut für Technische Elektronik
Sommerfeldstraße 24
D-52056 Aachen, Germany
http://www.ite.rwth-aachen.de

--
Dr.-Ing. Patrick Herzog
-- Oberingenieur --
RWTH Aachen
Institut für Technische Elektronik
Sommerfeldstraße 24
D-52056 Aachen, Germany
http://www.ite.rwth-aachen.de