Subject: Re: [netatalk-admins] can log in only as guest (no shadowpasswd!)

From: Rob Clark <[email-masked]>
Date: Fri, 23 Oct 1998 12:55:40 -0700

David S. wrote:
> 
> >
> > Hi, I have just installed netatalk, and I am having the "can log in as
> > guest, but not as user" problem, but with a twist:  I am not using
> > shadow passwords.  The symptoms are:  (1) if I try and login w/ bogus
> > username/passwd I get a "Sorry, your password is incorrect.  Please
> > reenter it." dialog.  (2)  If I try and login with a real username, but
> > bogus or real passwd, I get a "The connection to this server has been
> > unexpectedly broken" dialog.
> >
> 
> This question is addressed in the 'netatalk' FAQ.  You need to make sure that
> your shell, and all of your users' shells, are listed in '/etc/shells' on your
> 'netatalk' server.

The shell that I use, /usr/bash, is in /etc/shells.  (I did check the
faq before turning to the mailing list for help.)

Other info:

  I am running this on a RedHat v5.1 system (ie w/glibc).

  I installed netatalk from .rpm (netatalk-1.4b2+asun2.1.0-5.i386.rpm),
so I would have thought that it would have returned an error when I
installed if there was any missing libraries, etc.

Where does netatalk log errors too?  If I could see some error messages
from the linux side, it might make it easier to figure out what is going
on.

Thanks

> > If it matters, I am using cleartext password exchange.

-- 
----------------------
Rob Clark
Dot Wireless, Inc.
(619)678-0889 x2028
[email-masked]
----------------------

---

From: "frank scholten Linde" <[email-masked]>
Date: Mon, 26 Oct 1998 13:34:35 +0200 (CET)

> installed if there was any missing libraries, etc.

Rob,

I've had exactly the same problem with that version you're running, i went one
version down to netatalk-1.4b2+asun2.0a18.2-oa1.i386.rpm (don't have the url
where to get it atm) and the problem was solved.

Hope that helps

Frank

----------------------------------
E-Mail: [email-masked]
Date: 26-Oct-98
Time: 13:31:50
XFMail *** RedHat 5.1-2.0.35
----------------------------------

---

From: "Achim Gosse" <[email-masked]>
Date: Mon, 26 Oct 1998 14:03:14 +0100

> Betreff: Re: [netatalk-admins] can log in only as guest (no
> shadowpasswd!

Try this

Add -DSHADOWPW to the etc/afpd/Makefile like so: 

  CFLAGS= ${DEFS} ${AFSDEFS} ${KRBDEFS} ${DESDEFS} ${OPTOPTS} ${INCPATH} \
    ${PAMDEFS} -DAPPLCNAME -DCRLF -DSHADOWPW # -DDOWNCASE

Achim

---

From: Rob Clark <[email-masked]>
Date: Mon, 26 Oct 1998 15:09:34 -0800

Thanks to everyone who responded.  I built the latest version
(netatalk-1.4b2+asun2.1.0.tar.gz) from source, and the problem went
away.

I guess it must have been some problem with the .rpm that I originally
installed from.  Thanks!

-- 
----------------------
Rob Clark
Dot Wireless, Inc.
(619)678-0889 x2028
[email-masked]
----------------------