Subject: [netatalk-admins] Unix command support for AppleDouble files

From: [email-masked]
Date: Wed, 25 Mar 98 18:39:29 PST

I have a minor problem with some users who like to work in their Unix
directories with things like "mv" and "cp", while also using those same
directories through netatalk afpd.  This is leading to "broken" files because
they forget to also change the .AppleDouble header files when working from the
Unix side.

So, I'm thinking about writing a set of scripts to run in place of "mv", "cp",
and "rm" that will automatically take care of this.  I don't think it will be
terribly difficult, but before re-inventing the wheel I thought I'd see if
anyone out there has already done this and is willing to share.

Thanks in advance to anyone who can help!

Bob Smith
Hammett & Edison
[email-masked]

---

From: Alistair Riddell <[email-masked]>
Date: Thu, 26 Mar 1998 12:00:07 +0000 (GMT)

I'm not sure about rm, cp and mv replacements, but there are scripts which
will check for .Appledouble files which no longer have a data fork
associated with them because it has been delted or move elsewhere. These
files can then be safely removed.

--
Alistair Riddell - BOFH
IT Support Department, George Watson's College, Edinburgh
Tel: +44 131 447 7931 Ext 176       Fax: +44 131 452 8594

---

From: David Foster <[email-masked]>
Date: Thu, 26 Mar 1998 23:52:42 -0500

At 07:00 AM 3/26/98 , Alistair Riddell wrote:
>associated with them because it has been delted or move elsewhere. 

A bunch of which got posted here at one point, and I foolishly didn't save
them.  Anyone have a URL for any of these (straightforward enough to write,
I suppose, but why re-invent the wheel).

---

From: Alistair Riddell <[email-masked]>
Date: Fri, 27 Mar 1998 13:13:21 +0000 (GMT)

I have put one such script at
http://frank.watsons.edin.sch.uk/~ali/AppleDouble.pl
I don't know who wrote it but I'd be happy to acknowledge them if they let
me know who they are.

---

From: Edan Idzerda <[email-masked]>
Date: Fri, 27 Mar 1998 14:52:27 -0500 (EST)

>associated with them because it has been delted or move elsewhere. 

Does netatalk create files in .Appledouble when they just have
creator/type info automatically created from them by the extension
mapping?  If .Appledouble files only exist for files that *had*
information assigned to them, how does it help anyone if you 
mv that file and then delete it's .Appledouble?

If you have users which do a lot of Mac and unix work, it might
make sense to make wrappers for the above, so that:
	
	mv would move the file and it's friends
	cp would copy the file and it's friends
	rm would remove the file and it's friends

Then you wouldn't even have to worry about running some death
script to check for orphan .Appledouble files.  Writing
these wrappers is left as an exercise for the reader.  :)

- edan

---

From: Richard Mann <[email-masked]>
Date: Fri, 27 Mar 1998 14:26:47 -0600 (CST)

> ...
> script to check for orphan .Appledouble files.  

	Is there any kind of issue with orphan .AppleDouble 
	files, besides general housekeeping?

	Usually for us the issue is a file not being able to be
	opened by its application on a Mac, as a result of the
	resource fork not being there, or it having the wrong
	permissions.

	For this I agree it could be handy to have some utilities
	on the unix side to make things simpler.

	But does it cause system problems of any sort, when
	a .AppleDouble file sits out there with no match in
	its parent directory?

     //\     --rich
    //  \    
   // /  \   Richard Mann -- Network Administrator
  // / /  \  P u b l i c a t i o n  S e r v i c e s,  I n c. 
  \\  / / /  Champaign, Illinois, USA 61821 (217) 398-2060 x22
   \\  / /   
    \\  /    
     \\/