Subject: [netatalk-admins] socket: Invalid argument

From: Jochen Haeberle <[email-masked]>
Date: Wed, 25 Mar 1998 15:07:08 +0000

Subject: socket: Invalid argument
From: Jochen Haeberle <[email-masked]>
To: "[email-masked]" <[email-masked]>
Date: Tue, 24 Mar 1998 16:47:25 +0000

Hi,

I am trying to transfer my (rather) working netatalk installation from one
linux box to another. So I tried transferring the sources over
(netatlk-1.4b2+asun2.0a18.2) and compile those. This worked. But when running
those binaries from the new machine, I get the following errors from atalkd:

socket: Invalid argument
socket: Invalid argument
atalkd: can't get interfaces, exiting.

What could this be???

Thanks for your help!

Jochen

---

From: Jochen Haeberle <[email-masked]>
Date: Wed, 25 Mar 1998 19:05:54 +0000

Hi Chris,

I thought this too, but no. The Modules are compiled and installed, but I even
can't "find" them in the running kernel. When I do lsmod, I get nothing...

Jochen

chris thoen wrote:
> 
> I think you forgot to compile appletalk in the kernel of your new system.
> 
> Chris
> 
> Jochen Haeberle wrote:
> 
> --
> Chris THOEN
> Systeembeheerder Net it be
> Posthoflei 3
> 2600  BERCHEM
> tel     :       03/286.04.34
> fax     :       03/286.04.70
> email   :       [email-masked]
> url     :       www.netit.be