Subject: [netatalk-admins] Disabling Routing in Netatalk

From: Nate Carlson <[email-masked]>
Date: Mon, 19 Jan 1998 13:40:15 -0600 (CST)

I need to get a netatalk server which does not do appletalk routing, but
still allows people to connect from any of the three ethernet cards in the
machines. I have applied the patch to disable routing, and it does, but
afpd only binds to one address, so only people on that network card can
attach. Somebody told me to modify etc/afpd/main.c:main() so that afpd
only binds to one address, but (being fairly new at c), I have not been
able to figure out how to do this. Does someone have a patch that does
this already? (It looks like asun2 allows you to bind it to a certain
address, but that is only for TCP/IP, right?) Or, could someone give me a
few pointers on how to modify the source? Thanks!

-Nate Carlson
 The Infinite Loop
 [email-masked]

---

From: Helge Münnich <[email-masked]>
Date: Tue, 20 Jan 1998 12:35:39 +0100

>  [email-masked]
I have a patch for the ddp - part of the LINUXkernel(2.0.29-31). It
stops the routing to the ethercards, but not the "internal routing" :
all ethernets can connect to the afpd, without seeing each other.
The patch is not so clever, but it works fine for me. 
B.d. Helge
-- 
					ID-Online
Tel.: +49 761 290035			Schauinslandstr. 26c 
Fax : +49 761 290034			D-79100 Freiburg
--- ddp.c.orig	Fri May 31 12:46:27 1996
+++ ddp.c	Fri Mar 28 16:32:51 1997
@@ -1489,10 +1489,16 @@
 		{
 			kfree_skb(skb, FREE_READ);
 			return(0);
 		}
 #endif
+
+#if 1                          /* Don't do appletalk routing */
+       kfree_skb(skb, FREE_READ);
+       return 0;
+#endif
+
 		ta.s_net=ddp->deh_dnet;
 		ta.s_node=ddp->deh_dnode;
 
 		/* Route the packet */
 		rt=atrtr_find(&ta);