Subject: [netatalk-admins] Utility for TYPE/CREATOR

From: "Frank Morton" <[email-masked]>
Date: Thu, 27 Aug 1998 10:23:57 -0500

Is there a command line utility anywhere that, given
a filename, returns the macintosh type/creator?

---

From: Chip Mefford <[email-masked]>
Date: Fri, 28 Aug 1998 06:47:39 -0400 (EDT)

Umm, I don't mean to be thick, but I use
"less" on the resource fork in the .AppleDouble directory

---

From: Mike Mansell <[email-masked]>
Date: Fri, 28 Aug 1998 10:01:24 -0400 (EDT)

My sophiticated 'thick' method is to use:

cat filename | grep -v "^@"

which gives you the same thing as less/more/cat, but without the filler:

user@sparc>>> cat LanTest.Logfile.0.0 | grep -v "^@"
MVU     - LanTest.Logfile.0.05MQ5HFTEXTttxt

I suppose you could write an awk script and just display the filename and
type/creator.  I have no clue if the rest of the filler ('MVU'?) has any
significance.

--
    /\     Michael G. Mansell, BSc. (SCS)  Office:  (905) 761-6171  x228
   /\ \    Engineering Support             Fax:     (905) 761-7358
  /\ \ \   DataVation Inc.    
 /  \ \ \  WWW.DataVation.COM              Email:   [email-masked]

---

From: Hannu Krosing <[email-masked]>
Date: Fri, 28 Aug 1998 11:36:04 +0300

> a filename, returns the macintosh type/creator?

the file attached here claims to do it

I don't know where I got it from so I just post it (2.8Kb)

------------------
Hannu Krosing

---

From: "Gerry.Tomlinson" <[email-masked]>
Date: Tue, 1 Sep 1998 10:31:10 +0100 (BST)

> a filename, returns the macintosh type/creator?

My utility afile will display type/creator info.

It's available from

ftp://ftp.ncl.ac.uk/pub/users/ngmt/netatalk/afile.tgz

	Gerry.

---
[email-masked]
Computing Officer
Department of Computing Science, University of Newcastle, Tel: +44 191 222 8139
Newcastle upon Tyne, NE1 7RU, United Kingdom.             Fax: +44 191 222 8232