Subject: RE: [netatalk-admins] netatalk-1.4b2+asun2.0a18.2 - IP works, eth ertalk doesn't?

From: Sean Page <[email-masked]>
Date: Tue, 26 May 1998 13:20:06 -0600

Right you are.
So, I'm still wondering why it is that the Mac that is on the same
physical hub as the server (on the inside interface) cannot see the
server via standard EtherTalk. Is there something I haven't done in
order to make the server advertise via ethertalk on the inside
interface?

> ----------
> From: 	Hannu Krosing
> Sent: 	Tuesday, May 26, 1998 9:47 AM
> To: 	Sean Page
> Cc: 	'Andras Kadinger'; 'netatalk list'
> Subject: 	Re: [netatalk-admins] netatalk-1.4b2+asun2.0a18.2 - IP
> works, eth	ertalk doesn't?
> 
> <<File: smime.p7s>>
> Sean Page wrote:
> > 
> > Hi, Andras,
> > 
> > No, there are no other routers, it is a very small test network
> > consisting of only the FreeBSD server (sitting between the Appletalk
> > network on ethernet and the Internet) and one mac workstation
> running OS
> > 8. Both of them are on the same hub on the inside network. It's very
> > strange. Even when I use the -seed option, the Mac can't see the
> server
> > in the chooser.
> > 
> > Tried making the atalkd.conf file read only (great suggestion by the
> > way!), but that didn't work either. I also tried manually changing
> the
> > net address on the mac to be the same as the server (different node,
> of
> > course) and that also didn't help. I'm starting to think there is
> > something more fundamentally wrong. Any more suggestions?
> 
> AFAIK there is no protocol for server advertizing that works over IP,
> so
> you can see only these machines in the chooser that advertize using 
> ethertalk, not IP.
> 
> To use ethertalk, you must have appletalk support in your OS.
> 
> I'm not sure that this is the case for FreeBSD, at least not default
> 
> Hannu
>

---

From: Sean Page <[email-masked]>
Date: Tue, 26 May 1998 13:25:39 -0600

Hmmm, well, maybe I'll try a different card.
I'm going to upgrade from 2.2.5 (with the netatalk patch) to 2.2.6 right
away, I'll see if that changes anything. If not, I'll replace the NIC
and cross my fingers. I'll let you know how I make out!

Sean.

> ----------
> From: 	Casey Bisson
> Reply To: 	[email-masked]
> Sent: 	Tuesday, May 26, 1998 9:33 AM
> To: 	Sean Page
> My first experience with Netatalk was with a Dell 486 and DEC
> EtherWorks III
> ethernet card under FreeBSD. I experienced the same unfathomable
> problems (can
> connect via IP, cannot connect via appletalk), and tried(and failed
> with) the same
> solutions. It was all particularly annoying because MacOS and WinNT
> machines could
> serve AppleShare fine from the same subnet. We read through pages of
> sniff logs
> and forwarded them to our router manufacturer for help, and we
> couldn't identify
> any reasonable cause for the problem.
> 
> In the end, I tried a different machine (Dell pnetium 166) a different
> ethernet
> card (3com 10/100) and newer install of FreeBSD (2.2.5.? to 2.2.6.?)
> and it worked
> fine with Netatalk 2.4b3 + asun18 (or 17). Nothing else changed, and
> it worked.
> 
> If you ever do identify why it doesn't work, I'd like to know.
> 
> Casey Bisson
> Information Technology
> Plymouth State College
> 
> 
> 
> Sean Page wrote:
> 
> > Hi, Andras,
> >
> > Sean.
> > > From:         Andras Kadinger
> > > Sent:         Thursday, May 21, 1998 5:13 PM
> > > To:   Sean Page
> > > works, ethertalk doesn't?
> > >
> > > Hello Sean,
> > >
> > > Sean Page wrote:
> > > >
> > > > I have installed netatalk-1.4b2+asun2.0a18.2 on FreeBSD 2.2.5
> (with
> > > > netatalk kernel patches) and I'm at my wits end. I can connect
> to
> > > the
> > > > server via IP no problem at all, works great, but can not see it
> on
> > > the
> > > > local network via the chooser no matter what I do.
> > > >
> > > > My atalkd.conf auto configures to:
> > > >
> > > > ed0 -phase 2 -net 65280-65534 -addr 65280.198
> > > > ed1 -phase 2 -net 65280-65534 -addr 0.0
> > > > And I tried to reconfigure it to:
> > > >
> > > > ed0 -phase 2 -net 65280-65534 -addr 65280.198
> > > > ed1 -phase 2 -net 100-200 -addr 100.1
> > > > to no avail. ed0 is the interface to the outside world, ed1 is
> the
> > > > internal network. I am also running NAT, if that makes a
> > > difference...
> > > >
> > > > Any advise on what I can try would be greatly appreciated!
> > >
> > > Are there other routers on Your network?
> > >
> > > Although I am on Linux, I could force atald to use my settings in
> some
> > > cases by making atalkd.conf read-only. Try it, it might help.
> > >
> > > What do Macs show in their AppleTalk control panel in
> Administrator
> > > mode?
> > >
> > > Sincerely,
> > > Andras Kadinger
> > > [email-masked]
> > >
> 
> 
>