Subject: re: Re: [netatalk-admins] Can't get shares to show!

From: [email-masked]
Date: Fri, 17 Apr 98 18:01:03 EDT

[email-masked] wrote:

>Before everything else, try to use /etc/* instead of any
>'../atalk/etc/*', and see if that works. I hope it does. Don't listen to
>the docs if they say something else.

Well, I tried that, and that didn't work either.  Note the following:

pit-svr0:/etc# ls -l AppleVolumes.*
-rw-r--r--   1 root     root          177 Apr 17 16:24 AppleVolumes.default
-rw-r--r--   1 root     root          925 Apr 17 16:24 AppleVolumes.system

pit-svr0:/etc# head -n25 AppleVolumes.default
# This file looks empty when viewed with "vi".  In fact, there is one
# '~', so users with no AppleVolumes file in their home directory get
# their home directory by default.
~~

pit-svr0:/etc# head -n25 AppleVolumes.system
#
# This file is read before (after if -u is specified) the user's
# AppleVolume file.  Add extension mappings and volumes here.
#

/home "eg People"
/dosc "Gate's Land"

# default translation -- note that CR <-> LF translation is done on all
# files of type TEXT.  The first line turns off translation for files of
# unknown type, the second turns this translation on.
.       BINA    UNIX
# .       TEXT    UNIX

# sounds
.mod    STrk    STrk
.mid    Midi    ttxt
.aiff   AIFF    SNdm
.wav    WAVE    SNdm
.au     ULAW    SNdm

# video
.moov   MooV    mMPG
.mov    MooV    mMPG
.mpg    MPEG    mMPG

pit-svr0:/etc# cd /usr/local/atalk/etc
pit-svr0:/usr/local/atalk/etc# ls -l AppleVolumes.*
-rw-r--r--   1 root     root          177 Apr 14 16:39 AppleVolumes.default
-rw-r--r--   1 root     root          925 Apr 14 16:41 AppleVolumes.system

Can anyone make heads or tails of this?  Again, I am running the Netatalk 1.4.2 beta release.  Previous to 
recompilation for shadow password support, I got the volumes spec. when logging in as Guest on the Mac.

>Also, I recommend using Adrian Sun's patch set, which is available at:

What does this do?  I'm running this on an Intel 486/66 box.  Does that make a difference?

Chris
----
Chris Olive
Exhibitgroup/Giltspur Pittsburgh
[email-masked]

---

From: [email-masked]
Date: Fri, 17 Apr 98 14:54:34 PST

> ...but added only two lines for additional shares to both the *.system and 
> *.default files:
>
> /home "People"
> /usr "Usr Area"

You need to lose the "" and the spaces in the volume names; the code that parses
these files is pretty dumb.  Also there is no reason to put these entries in
both AppleVolumes.system and .default, one or the other is enough.  The rules
are, entries in .system are always visible to everyone, but the .default file
will be used only if the user doesn't have an AppleVolumes or .AppleVolumes file
in their home directory.

Hope this helps!

Bob Smith
Hammett & Edison, Inc.
[email-masked]

---

From: Andras Kadinger <[email-masked]>
Date: Sat, 18 Apr 1998 01:40:56 +0200

> What does this do?  I'm running this on an Intel 486/66 box.  Does that make a difference?

It has a couple of bug fixes and feature enhancements (e.g. AppleShare
over TCP/IP) from 1.4b2. It works on Intel.

Sincerely,
Andras Kadinger
[email-masked]