Subject: [netatalk-admins] 8.5 and asun hanging

From: [email-masked] (Lee Blevins)
Date: Fri, 6 Nov 1998 07:14:18 -0500

I can confirm the hanging at my location.

sending a 39.1 meg tif from a variety of macs, the mac hangs.

I look at the activity lights on my bridge and the network shows no
activity. It's like one machine asked a question, and it's just sitting
there waiting for an answer.

If I send a small file (250k) it goes. If I send both the small file and
the large file it goes. If I send the large file by itself, it hangs.
The hang is intermittent.

I have removed 8.5 because I see no speedup with any netatalk+asun and I
get the hangs.

I don't see any speed difference with 8.5 when it does work.

---

From: Sean Anker <[email-masked]>
Date: Fri, 6 Nov 1998 11:38:04 -0500

>The hang is intermittent.
I have seen similar things here... running LinuxPPC R4 w/ the default
netatalk (1.4b2+asun2.0a18.2). When I first installed 8.5, my copies would
'rest' for about 20 seconds, and then run for about 20 seconds -- I didn't
actually time it. I rebuilt the Linux machine (for various reasons), and
the copy problems went away for a few days. Yesterday, I had total hangs
trying to copy files, that had been placed on the linux box only minutes
before by another machine.

I have also noticed that I cannot login to the linux box using the Network
Browser -- it can see the machine fine, but won't authenticate.
   --------------
 /   sean.anker    \
|  Chief Engineer   |
|  Innovative Edit  |
 \ p.(317)686-6086 /
   --------------

---

From: Neil McAllister <[email-masked]>
Date: Fri, 6 Nov 1998 09:53:45 -0800

>Browser -- it can see the machine fine, but won't authenticate.

Have you tried punching in a URL of the format:

afp://username:[email-masked]

Some of what I've read leads me to believe the latter is successful where a
standard login doesn't work.

--
Neil McAllister, Systems Administrator
Primo Angeli Inc., San Francisco, CA, USA
http://www.primo.com  mailto:[email-masked]

---

From: Marc Matteo <[email-masked]>
Date: Fri, 06 Nov 1998 11:26:42 -0800

> Browser -- it can see the machine fine, but won't authenticate.

This was fixed in asun2.1.0

Marc
-- 
Marc Matteo
Web Engineer, The Sacramento Bee
http://www.sacbee.com
"We're a newspaper, we don't actually own any bees."

---

From: Sean Anker <[email-masked]>
Date: Fri, 6 Nov 1998 13:21:00 -0500

>standard login doesn't work.

This works wonderfully.... except for typing in clear-text password...

---

From: a sun <[email-masked]>
Date: Fri, 6 Nov 1998 10:23:25 -0800 (PST)

okay,

i want to clear some of these problems up as it looks like people are
trying different versions with OS 8.5.

  1) anybody having problems please grab pre-asun2.1.0a-4.tar.gz from
     ftp.u.washington.edu:/public/asun. asun2.0a18.2 will NOT work
     with the network browser.

  2) if you're experiencing hangs, go to afp_dsi.c and add
     syslog(LOG_INFO, "command (req=%d): %d %d",
     ntohs(dsi->header.dsi_requestID), cmd, dsi->commands[0]); to
     right after the while (cmd = dsi_receive(dsi)) line and
     syslog(LOG_INFO, "command done"); to right before the breaks in
     the DSIFUNC_WRITE and DSIFUNC_CMD bits. 

     also, go to alarm_handler() and add a syslog(LOG_INFO, "dsi
     tickle: %d", child.tickle); in there.

  3) give me the tail end of the resulting syslogs that hang. 

also, tell me your system/networking setup is. the one log that i've
gotten so far suggests that the client has stopped sending tickles to
the afpd process.

-a

---

From: Michael May <[email-masked]>
Date: Mon, 9 Nov 1998 14:06:23 -0800

I am experiencing the following problem under netatalk 1.4b2+asun2.1.0a and
Mac OS 8.5, while using Sherlock (the revamped "Find File" for OS 8.5):

Trying to select a file in the results window of Sherlock displays the
following error message:

"The selected item cannot be found. The item may have been deleted. The
item will be dimmed in the list."

This occurs only if the item you are selecting resides on a netatalk volume.

Can anyone duplicate this behavior?

----------------------------
Michael May
San Francisco Estuary Institute
(510) 231-9539

---

From: a sun <[email-masked]>
Date: Mon, 9 Nov 1998 14:33:13 -0800 (PST)

fyi, i've been trying to track this one down. i think find's
expectations changed a little. from a trace of the traffic, it doesn't
look like afpd is doing anything wrong. i'll go peak at the technote a
little to see if something bizarre has changed.

-a

---

From: Chip Mefford <[email-masked]>
Date: Tue, 10 Nov 1998 12:10:31 -0500 (EST)

Is anyone out there currently running an ASIP 6.1, MacOS
8.5 and asun 2.x envoirnment? This is where I am 
hoping to move in the next few weeks. I am set up
to do this. It seems that ASIP 6.1 and MacOS 8.5 
actually have real networking now as opposed to
the horrible kludges of the past.

I am hoping that this will actually work, that
I can finally share files over IP without the
horrors of the past, achive some usable network
speed and so forth.

Anyone?

---

From: Walt Bigelow <[email-masked]>
Date: Sat, 14 Nov 1998 16:42:55 -0800 (PST)

Asun:

I am experiencing these damn lockups.  I am using pre-asun2.1.0-5 and I
added the syslog modifications.  Below is the syslog file.

Nov 14 16:27:02 jaque afpd[959]: command (req=5597): 2 27
Nov 14 16:27:02 jaque afpd[959]: command done
Nov 14 16:27:02 jaque afpd[959]: command (req=5598): 2 27
Nov 14 16:27:02 jaque afpd[959]: command done
Nov 14 16:27:02 jaque afpd[959]: command (req=5599): 2 27
Nov 14 16:27:03 jaque afpd[959]: command done
Nov 14 16:27:03 jaque afpd[959]: command (req=5600): 2 27
Nov 14 16:27:03 jaque afpd[959]: command done
Nov 14 16:27:03 jaque afpd[959]: command (req=5601): 2 27
Nov 14 16:27:03 jaque afpd[959]: command done
Nov 14 16:27:03 jaque afpd[959]: command (req=5602): 2 27
Nov 14 16:27:03 jaque afpd[959]: command done
Nov 14 16:27:04 jaque afpd[959]: command (req=5603): 2 27
Nov 14 16:27:55 jaque afpd[957]: command (req=317): 5 9
Nov 14 16:28:55 jaque afpd[957]: command (req=318): 5 9
Nov 14 16:29:55 jaque afpd[957]: command (req=319): 5 9
Nov 14 16:29:59 jaque afpd[954]: server_child[1] 959 killed
Nov 14 16:30:55 jaque afpd[957]: command (req=320): 5 9
Nov 14 16:31:55 jaque afpd[957]: command (req=321): 5 9

Basically I was copying files from the server to a local Hard drive.  It
seems to stop at random spots.   The mac client just frezes up for a bit
then does the unexpectedly quit message, then the connection is gone.

If there is anything else I can do, let me know.

Thanks,
Walt

---

From: Sean Anker <[email-masked]>
Date: Tue, 17 Nov 1998 09:14:53 -0500

At 10:23 -0800 11/6/98, a sun wrote:

>     [more snipped]

Server:
  LinuxPPC R4, kernel 2.1.24
  netatalk pre-asun2.1.0a-4.tar.gz distribution
  UMAX C500e 32MB RAM/8GB total disk space

Client:
  PowerBook 3400c/180
  MacOS 8.5 fairly standard install

Sysop:
  Newbie   :)

Conditions:
  single connection, no other applications running on client
  10baseT network w/ light traffic at the time
  copy 1.5 MB file from server to client desktop

08:55:30 -- began copy. Copy progress bar immediately stops at left edge.
	No log activity or computer activity until
08:57:31 -- file shoots over and copy is complete.

This *seems* to happen more often with things that have custom icons...
although I can't say that for sure.

# tail -n 36 /var/log/messages

Nov 17 08:55:29 newton afpd[619]: command done
Nov 17 08:55:29 newton afpd[619]: command (req=314): 2 58
Nov 17 08:55:29 newton afpd[619]: command done
Nov 17 08:55:30 newton afpd[619]: command (req=315): 2 34
Nov 17 08:55:30 newton afpd[619]: command done
Nov 17 08:55:30 newton afpd[619]: command (req=316): 2 58
Nov 17 08:55:30 newton afpd[619]: command done
Nov 17 08:55:30 newton afpd[619]: command (req=317): 2 26
Nov 17 08:55:30 newton afpd[619]: command done
Nov 17 08:55:30 newton afpd[619]: command (req=318): 2 26
Nov 17 08:55:30 newton afpd[619]: command done
Nov 17 08:55:30 newton afpd[619]: command (req=319): 2 27
Nov 17 08:55:30 newton afpd[619]: command done
Nov 17 08:55:30 newton afpd[619]: command (req=320): 2 27
Nov 17 08:57:31 newton afpd[619]: command done
Nov 17 08:57:31 newton afpd[619]: command (req=321): 5 27
Nov 17 08:57:31 newton afpd[619]: command (req=322): 5 27
Nov 17 08:57:31 newton afpd[619]: command (req=323): 2 27
Nov 17 08:57:32 newton afpd[619]: command done
Nov 17 08:57:33 newton afpd[619]: command (req=324): 2 4
Nov 17 08:57:33 newton afpd[619]: command done
Nov 17 08:57:33 newton afpd[619]: command (req=325): 2 27
Nov 17 08:57:33 newton afpd[619]: command done
Nov 17 08:57:33 newton afpd[619]: command (req=326): 2 4
Nov 17 08:57:33 newton afpd[619]: command done
Nov 17 08:58:03 newton afpd[619]: dsi tickle: 1
Nov 17 08:58:09 newton afpd[619]: command (req=327): 5 4
Nov 17 08:58:33 newton afpd[619]: dsi tickle: 1
Nov 17 08:59:03 newton afpd[619]: dsi tickle: 2
Nov 17 08:59:09 newton afpd[619]: command (req=328): 5 4
Nov 17 08:59:20 newton afpd[619]: command (req=329): 2 34
Nov 17 08:59:20 newton afpd[619]: command done
Nov 17 08:59:22 newton afpd[619]: command (req=330): 2 2
Nov 17 08:59:22 newton afpd[619]: command done
Nov 17 08:59:22 newton afpd[619]: command (req=331): 2 20
Nov 17 08:59:22 newton afpd[619]: logout
Nov 17 08:59:22 newton afpd[619]: 11.52KB read, 31848.16KB written
Nov 17 08:59:22 newton afpd[262]: server_child[1] 619 done

---

From: "Mike Reiling" <[email-masked]>
Date: Wed, 18 Nov 1998 08:45:09 -0800

Same thing with me.  I begin a copy and the progress bar never moves.  I have
not bothered to wait for a long time, since I am the impatiant type.  I
compiled and installed the newest version last night with no success.  I will
re_compile it with the syslog code in it.

Mike

---

From: "Mike Reiling" <[email-masked]>
Date: Wed, 18 Nov 1998 23:59:28 -0800

Hi everyone.

    Here is an update with my problem.  After playing around for a couple of
hours, I finally got Netatalk working.  My problem (start a copy and it
would just sit there) is gone!!!  The culprit was my virus software.
Although that was the first thing I disabled, it seems that Virex does not
play nice, and in fact, I had to remove the Virex control panel.  Just
selecting "Off" in the control panel does not seem to do it.

I appreciate everyones help.  Please keep me updated with your problems with
8.5.  Maybe I can help.

Mike