Subject: RE: [netatalk-admins] netatalk over tcp

From: Marc Matteo <[email-masked]>
Date: Mon, 14 Dec 1998 09:27:36 -0800

You need to use the asun patches to get AFP/TCP.

ftp://ftp.u.washington.edu:/public/asun/

> ----------
> From: 	Yann Bizeul
> Reply To: 	[email-masked]
> Sent: 	Monday, December 14, 1998 8:19 AM
> To: 	[email-masked]
> Subject: 	[netatalk-admins] netatalk over tcp
> 
> Hello
> 
> I set up appletalk on my Linux box so that I can see it in chooser, and
> connect
> to it, but with the "IP address of server" button, it tells me that the
> server
> doesn't respond...
> I can't establish a telnet session on my linux box on port 548 :
> connection
> refused... Any idea ?
>

---

From: Yann Bizeul <[email-masked]>
Date: Tue, 15 Dec 1998 13:20:13 +0100

>You need to use the asun patches to get AFP/TCP.
The problem is that I installed netatalk+asun... do I have to reinstall it ?
the version I installed is 1.4b2+asun 2.1.1

any idea ?

 >> I set up appletalk on my Linux
box so that I can see it in chooser, and >> connect

---

From: Mark Donnelly <[email-masked]>
Date: Tue, 15 Dec 1998 09:16:55 -0600

> the version I installed is 1.4b2+asun 2.1.1

OK, run a netstat on your box.  (I assume you know what that does already)
If that has an line for port 548 (or afpovertcp if you put the line in
/etc/services), then your problem is with tcpwrappers, as Bill McGonigle
said.  If there isn't an entry for it in netstat, then I'd be curious to
see both any logs you have and also how you compiled it...

---

From: a sun <[email-masked]>
Date: Tue, 15 Dec 1998 09:14:30 -0800 (PST)

> You need to use the asun patches to get AFP/TCP.  The problem is
   > that I installed netatalk+asun... do I have to reinstall it ?

another possible failure point is forgetting to correctly specify your
host ip address in /etc/hosts. look at your syslog.

-a