Subject: [netatalk-admins] socket: Invalid argument

From: Jochen Haeberle <[email-masked]>
Date: Tue, 24 Mar 1998 16:47:25 +0000

Hi,

I am trying to transfer my (rather) working netatalk installation from one
linux box to another. So I tried transferring the sources over
(netatlk-1.4b2+asun2.0a18.2) and compile those. This worked. But when running
those binaries from the new machine, I get the following errors from atalkd:

socket: Invalid argument
socket: Invalid argument
atalkd: can't get interfaces, exiting.

What could this be???

Thanks for your help!

Jochen

---

From: Vivek <[email-masked]>
Date: Tue, 24 Mar 1998 16:17:34 +0000 (GMT)

> atalkd: can't get interfaces, exiting.

Has the second box got the right stuff compiled in to its kernel
or modules?
--
fsck -f -b 8193 /dev/cortex

---

From: Jochen Haeberle <[email-masked]>
Date: Wed, 25 Mar 1998 19:09:25 +0000

Hi Vivek,

> Has the second box got the right stuff compiled in to its kernel

The atalk-stuff is compiled as module. But when I do lsmod, I do get nothing.
This should not be the case either...

Jochen

---

From: Alistair Riddell <[email-masked]>
Date: Wed, 25 Mar 1998 23:11:53 +0000 (GMT)

> This should not be the case either...

Well, have you tried insmod appletalk?
If you have no kerneld support or kerneld is not running then you will
need to do this.

--
Alistair Riddell - BOFH
IT Support Department, George Watson's College, Edinburgh
Tel: +44 131 447 7931 Ext 176       Fax: +44 131 452 8594