Subject: RE: [netatalk-admins] netatalk on RedHat 5.1

From: Marc Matteo <[email-masked]>
Date: Tue, 13 Oct 1998 08:50:58 -0700

Yes, on two RedHat 5.1 boxes I have Netatalk1.4b2+asun2.0a18.2 (that is with
version 2.0a18.2 of asun's patch) running like a charm.

There are RPMS available out there but some of those are buggy too.  There's
an RPM of asun's "development" 2.1.0 series that people have been having
luck with.

Marc
> ----------
> From: 	Osma Ahvenlampi
> Sent: 	Tuesday, October 13, 1998 12:41 AM
> To: 	[email-masked]
> Subject: 	Re: [netatalk-admins] netatalk on RedHat 5.1
> 
> Douglas Melniker <[email-masked]> writes:
> > ok, my problem is now this: when i try to log on to my machine form a
> mac,
> > it gives me the dialog box and let's me type a user and password. then
> it
> > IMMEDIATELY says that the connection has been unexpectedly broken.
> 
> Netatalk 1.4b2 is broken, busted, buggy, and so on. Patch it massively
> or move to the Andrew Sun sourcetree (netatalk-1.4b2-asun)
> 
> -- 
> Sevareid`s Law: The chief cause of problems is solutions.
> Osma Ahvenlampi <[email-masked]>
>

---

From: "Mike Reiling" <[email-masked]>
Date: Tue, 13 Oct 1998 17:57:59 -0700

I have been having this problem with Solaris 2.6 running and an intel platform.
I have tried every version of Netatalk that I could find, but none compile.  Do
I have something wrong with my compiler (gcc 2.8.1) or is it something else.
Any input would be greatly appreciated.

Thanks in advance,
Mike

Making all for solaris...
gcc -D_KERNEL  -fpcc-struct-return -I../../sys/solaris -D__svr4__ -DSOLARIS -O
-I../../include -I../netatalk  -c  aarp.c
gcc -D_KERNEL  -fpcc-struct-return -I../../sys/solaris -D__svr4__ -DSOLARIS -O
-I../../include -I../netatalk  -c  ddp.c
gcc -D_KERNEL  -fpcc-struct-return -I../../sys/solaris -D__svr4__ -DSOLARIS -O
-I../../include -I../netatalk  -c  ddptp_rdq.c
gcc -D_KERNEL  -fpcc-struct-return -I../../sys/solaris -D__svr4__ -DSOLARIS -O
-I../../include -I../netatalk  -c  ddptp_utls.c
In file included from ddptp_utls.c:39:
../netatalk/endian.h:51: warning: redefinition of `int32_t'
/usr/include/sys/int_types.h:69: warning: `int32_t' previously declared here
../netatalk/endian.h:123: conflicting types for `ntohl'
/usr/include/sys/byteorder.h:66: previous declaration of `ntohl'
../netatalk/endian.h:123: conflicting types for `htonl'
/usr/include/sys/byteorder.h:64: previous declaration of `htonl'
ddptp_utls.c: In function `ddptp_verify_msg':
ddptp_utls.c:110: structure has no member named `dub_len'
*** Error code 1
make: Fatal error: Command failed for target `ddptp_utls.o'
Current working directory /export/miker/netatalk-1.4b2+asun2.0a18.2/sys/solaris
*** Error code 1
make: Fatal error: Command failed for target `all'

---

From: [email-masked]
Date: Wed, 14 Oct 1998 00:22:47 -0400

> From:    "Mike Reiling" <[email-masked]>

> I have been having this problem with Solaris 2.6 running and an intel
> platform.  I have tried every version of Netatalk that I could find,
> but none compile.  Do I have something wrong with my compiler (gcc
> 2.8.1) or is it something else.  Any input would be greatly
> appreciated.

First, there is no version of netatalk that's been tested on Solaris
x86.  Second, 1.4b2 is not compatible with Solaris 2.6.  There have
been several snap-shots since 1.4b2, but no other releases (from
Michigan).  The latest snap-shot that I'd suggest anyone use is
ftp://terminator.rs.itd.umich.edu/pub/n-971027.tar.gz.  There are later
snap-shots, since we put various snap-shots there when we're testing
cross-platform builds of netatalk.  971027 has the nice characteristic
of being used in production at Michigan, and hence works pretty well,
especially on Solaris.

If you want to work on a Solaris x86 port of netatalk, there are other
interested parties on the net.

:wes