Subject: [netatalk-admins] modifications on AppleVolumes.system and reboot

From: chris thoen <[email-masked]>
Date: Mon, 19 Jan 1998 15:58:18 +0100

Hello,

I'm using netatalk 1.4b2 on Linux 2.33.  Everytime I do some changes on
my AppleVolumes.system file, I have to reboot.
I read somewhere that compiling the ipx protocol as a module was a
solution.  So I did, inserted the ipx-protocol by the command
"insmod ipx", and launched my appletalk software. This works fine, but
even after deleting the appletalk processes, deleting and
reloading the appletalk module, I get the errors:

"
starting appletalk daemons: atalkdnbp_rgstr: Connection timed out
Can't register chris-pc:Workstation@*
nbp_rgstr: Connection timed out
Can't register chris-pc:netatalk@*
"

 and have to reboot. What I'm I doing wrong?

Thanks,

Chris

--
Chris THOEN
Systeembeheerder Net it be
Posthoflei 3
2600  BERCHEM
tel     :       03/286.04.34
fax     :       03/286.04.70
email   :       [email-masked]
url     :       www.netit.be

---

From: Jeff Wiegley <[email-masked]>
Date: Mon, 19 Jan 1998 15:37:58 +0000

I'm not a PAM wizard but this crops up in the /var/log/messages file
when a netatalk login attempt fails...

Jan 19 07:28:19 server afpd[457]: ASIP session:548(2) from 209.85.7.12:2050(4)
Jan 19 07:28:19 server pam[457]: unable to dlopen(/lib/security/pam_unix_auth.so)
Jan 19 07:28:19 server pam[457]: [dlerror: /lib/security/pam_unix_auth.so: undefined symbol: crypt]
Jan 19 07:28:19 server pam[457]: adding faulty module: /lib/security/pam_unix_auth.so
Jan 19 07:28:19 server afpd[362]: server_child[1] 457 done

Does this help anybody figure out what I did wrong?

- Jeff

---

From: Jeff Wiegley <[email-masked]>
Date: Mon, 19 Jan 1998 15:48:43 +0000

Contrary to what the Makefile in sys/linux/Makefile says...

# if you aren't using pam and are using glibc, you'll need to add -lcrypt
AFPLIBS= -lcrypt
ADDLIBS=

well, I thought RedHet 5.0 does use glibc *and* PAM so I shouldn't
need -lcrypt according to the above comment. But appearantly I really
did need -lcrypt since that fixed my netatalk login problems.

- Jeff

---

From: a sun <[email-masked]>
Date: Mon, 19 Jan 1998 12:17:02 -0800 (PST)

actually, it's redhat 5.0 that is wrong here. applications shouldn't
need to link against -lcrypt as specific pam modules which need it
should do so themselves. for example, this is what i get when i do an
ldd against /lib/security/pam_auth_unix.so:
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x40004000)
        libc.so.6 => /lib/libc.so.6 (0x40031000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x2aaaa000)

it looks like redhat 5.0 didn't build the pam modules correctly.

-a