Subject: [netatalk-admins] nbp_rgstr times out.

From: Aaron Benner <[email-masked]>
Date: Fri, 09 Jan 1998 10:29:55 -0700

I've got netatalk 1.4b2 running on a FreeBSD 2.2.5-RELEASE kernel
and when nbprgstr tries to register services (afpd) with atalkd
it times out.

The error reported is below.

Script started on Fri Jan  9 10:24:51 1998
# . /usr/local/atalk/etc/rc.atalk
starting appletalk daemons: atalkdnbp_rgstr: Operation timed out
Can't register ghengis:Workstation@*
nbp_rgstr: Operation timed out
Can't register ghengis:netatalk@*
 nbprgstr papd afpd.
#
Script done on Fri Jan  9 10:26:05 1998

The network is a simple appletalk network with 1 PowerMac 1 Netatalk
workstaion (other then the one I'm trying to get running) and 1 printer
Shared off the Netatalk box that's running.  There are no routers.

Any suggestions?

Thanks,
Aaron

---

From: "J. Stenberg" <[email-masked]>
Date: Fri, 9 Jan 1998 12:16:05 -0600 (CST)

Regarding the panic problems on my Solaris2.5.1.

Okay, I looked through the archives and found many questions that looked
exactly the same but I only found one solution.  

SOmebody suggested that moving the afpd.conf file would do the trick.  It
can't be that simple.  I suppose it could but a panic is pretty extreme.
So the Solaris Kernel is flakey to the point where misconfigurations make
it extra volatile?

Argh!

Thanks for any help sent my way,
-jarrod

--                                   --
Jarrod P. Stenberg                   [email-masked]
612.646.6427                         www.visi.com/~jarrod
612.901.6650                         www.denizen.net

"What the hell are you doing in my canoe!?" - Dubliner bar

---

From: Julian Elischer <[email-masked]>
Date: Fri, 09 Jan 1998 10:56:23 -0800

> Shared off the Netatalk box that's running.  There are no routers.

2.2.5 requires a patch.
see the freebsd ftp site
for the 'errata' (or erratum) file in the 2.2.5 release..
you should check this file every now and then anyhow.