Subject: Re: [netatalk-admins] Solaris 2.6

From: Paul Krohn <[email-masked]>
Date: Mon, 5 Oct 98 11:58:43 -0700

Try adding the lines you tried to /etc/pamd/netatalk, instead of 
pam.conf. That's how it works on my Solaris 2.6 setup.

>Hi, I need to move our mac file server over to a  Sun 450.
>I compiled and installed Netatalk-1.4b2+asun2.1.0. It compiled,
>the file server appears in the chooser but the following is what
>happens when someone tries to login:
>Oct  5 13:28:52 editorial afpd[299]: illegal pam.conf entry: netatalk
>session requiredi       /usr/lib/security/pam_pwdb.so.1
>Oct  5 13:28:52 editorial afpd[299]:    invalid flag: requiredi
>Oct  5 13:29:17 editorial afpd[295]: dsi_getsess: Interrupted system call
>
>You can type in the name and password but it just fails, then afpd dies.
>I currently have netatalk compiled with PAM but I was getting a similar
>error before I compiled in PAM.
>
>I currently have in /etc/pam.conf :
># Stuff for netalk
>netatalk        auth    required        /usr/lib/security/pam_unix.so.1 
>netatalk        account required        /usr/lib/security/pam_pwdb.so.1
>netatalk        session requiredi       /usr/lib/security/pam_pwdb.so.1
>
>I also tried exchanging the netatalk keyword in pam.conf with afpd.
>
>Any ideas? 
>
>	-Brian
>

------------
Paul Krohn
San Francisco Examiner Systems Department
110 Fifth Street
San Francisco, CA  94103
415-777-7884
[email-masked] - www.examiner.com

---

From: Brian Aker <[email-masked]>
Date: Mon, 05 Oct 1998 14:25:58 -0500

>pam.conf. That's how it works on my Solaris 2.6 setup.
Strange, that you can create a directory there is not 
documented in any of the man pages... figures.

Now though it dies with a:
Oct  5 14:18:32 editorial afpd[182]: dsi_getsess: Interrupted system call

	-Brian