Subject: Re: [netatalk-admins] Installation problem: netatalk 1.4b2 on solaris 2.5.1

From: "Yasmine Arafa" <[email-masked]>
Date: Tue, 27 Oct 1998 17:23:42 -0000

The following is the instruction in the README file:

5.  The file rc.atalk is installed in ETCDIR.  It should be called
    from your /etc/rc file, e.g. "sh ETCDIR/rc.atalk".  For more
    information on what this script does, read the man pages for the
    appropriate commands.

I include the above command in the etc/rc file.
But rc.atalk does not exist! I do though have etc/init.d/atalk and two
symlinks at /etc/rc2.d/S79atalk and /etc/rc0.d/K79atalk.

Is there still something missing?

Yasmine.
Thanx

----------
> From: Yuji Shinozaki <[email-masked]>
> To: Yasmine Arafa <[email-masked]>
> Cc: Mitch McNeel <[email-masked]>; netatalk-admins
<[email-masked]>
> Subject: Re: [netatalk-admins] Installation problem: netatalk 1.4b2 on
solaris 2.5.1
> Date: 27 October 1998 16:56
> 
> 
> The rc files are installed when you do a "make kinstall" (to install the
> kernel drivers et al). 
> 
> What it installs and where varies according to OS.  On Solaris is should
> install /etc/init.d/atalk and two symlinks at /etc/rc2.d/S79atalk and
> /etc/rc0.d/K79atalk.
> 
> Hope this helps.
> 
> yuji
> ----
> 
> 
> 
> On Tue, 27 Oct 1998, Yasmine Arafa wrote:
> 
> > Yes I do have /etc/rc2.d and /etc/rc0.d directories but not the file. I
> > have tried cleaning and reinstalling but still can't find rc.atalkd.
The
> > instructions say they should be included in the /etc/rc file.
> > Are the files in these directories sufficient or do I need rc.atalkd?
> > 
> > Thanx
> > Yasmine.
> > 
> > ------
> > > From: Mitch McNeel <[email-masked]>
> > > To: Yasmine Arafa <[email-masked]>
> > > Cc: netatalk-admins <[email-masked]>
> > > Subject: Re: [netatalk-admins] Installation problem: netatalk 1.4b2
on
> > solaris 2.5.1
> > > Date: 27 October 1998 15:12
> > > 
> > > Well for one thing, the rc.atalk file should have been created on the
> > > install...  look in your /etc/rc2.d and /etc/rc0.d directories, there
> > should
> > > be a soft link to the file atalk in /etc/init.d directory.
> > > 
> > > Hope this helps
> > > Mitch
> > > 
> > > 
> > > 
> > > Yasmine Arafa wrote:
> > > 
> > > > I  have almost been able to successfully complete compilation of
> > netatalk
> > > > 1.4b2 on solaris 2.5.1
> > > >
> > > > I am at the last step of the instructions, which is to add the
rc.atalk
> > > > file  to /etc/rc
> > > > I can't find this file anywhere? The instructions say it should be
> > > > installed in the in the ETCDIR (which in my case is
> > /usr/local/atalk/etc),
> > > > but I can't find it!
> > > > Does this mean that there could be a problem with the installation?
or
> > can
> > > > I just cp this file from somewhere? if I can cp it where can I get
this
> > > > file from?
> > > >
> > > > Thanx,
> > > > Yasmine.
> > 
> 
> Yuji Shinozaki		        Systems Administrator
> [email-masked]	        Dept of Physics and Astronomy
> http://www.physics.unc.edu      Univ. of North Carolina - CH
> (919)962-7214 (voice)           CB 3255 Philips Hall
> (919)962-0480 (fax)	        Chapel Hill, NC  27599

---

From: Yuji Shinozaki <[email-masked]>
Date: Tue, 27 Oct 1998 12:44:05 -0500 (EST)

> Is there still something missing?

What is missing is better instructions!  This is innaccurate (or at least
misleading). 

What you should do from the point you are now is follow the instructions
in README.SOLARIS.  Even those instructions are a bit cloudy, but
basically follow steps 2,3 and 5.  (what happened to 4?). 

Step 3 will install the rc scripts in the correct locations.  In a
nutshell, the rc.atalk.sysv file is edited and copied to /etc/init.d/atalk
and symlinks are installed in /etc/rc0.d and /etc/rc2.d.  When the system
boots (and also when it is shutdown), the rc scripts in these directories
are executed, thus starting up (or shutting down) the netatalk services.

yuji
----