Subject: [netatalk-admins] AppleTalk not up! Child exited with 1.

From: David Sweet <[email-masked]>
Date: Wed, 16 Dec 1998 22:44:54 -0800

I can compile and use the out of the box netatalk-1.4b2.
I need netatalk with asun's patches (netatalk-1.4b2+asun2.1.1) to get
appleshare
  ip to work.
When I run atalkd I get the infamous:
  AppleTalk not up! Child exited with 1.
I am compiling and running it under Solaris 2.5.1 with PAM, DES, TCPWRAP

  turned off (I don't have the necessary includes).
Here is the truss out put from where the child is forked off:
--
1990:   fork()                                          = 1991
1991:   fork()          (returning as child ...)        = 1990
1991:   getrlimit(RLIMIT_NOFILE, 0xEFFFFC58)            = 0
1991:   open("/dev/tty", O_RDWR)                        = 3
1991:   ioctl(3, TIOCNOTTY, 0x00000000)                 Err#22 EINVAL
1991:   close(3)                                        = 0
1991:   getpid()                                        = 1991 [1990]
1991:   setpgid(0, 1991)                                = 0
1991:   open("/dev/conslog", O_WRONLY)                  = 3
1991:   fcntl(3, F_SETFD, 0x00000001)                   = 0
1991:   fstat(3, 0xEFFFF128)                            = 0
1991:   fstat(3, 0xEFFFFB78)                            = 0
1991:   time()                                          = 913874851
1991:   open("/usr/share/lib/zoneinfo/US/Eastern", O_RDONLY) = 4
1991:   read(4, "\0\0\0\0\0\0\0\0\0\0\0\0".., 8192)     = 817
1991:   close(4)                                        = 0
1991:   getpid()                                        = 1991 [1990]
1991:   putmsg(3, 0xEFFFF230, 0xEFFFF224, 0)            = 0
1991:   fstat(-1, 0xEFFFF0E0)                           Err#9 EBADF
1991:   open("/etc/syslog.pid", O_RDONLY)               = 4
1991:   fstat(4, 0xEFFFF0E0)                            = 0
1991:   fcntl(4, F_SETFD, 0x00000001)                   = 0
1991:   lseek(4, 0, SEEK_SET)                           = 0
1991:   read(4, " 1 5 0\n\0\n\0", 11)                   = 7
1991:   getpid()                                        = 1991 [1990]
1991:   fcntl(4, F_SETLK, 0xEFFFF18C)                   Err#11 EAGAIN
1991:   open("/dev/hme", O_RDWR)                        = 5
1991:   ioctl(5, I_PUSH, "ddp")                         = 0
1991:   sigfillset(0xEF616854)                          = 0
1991:   ioctl(5, 0x80047336, 0xEFFFF840)                Err#22 EINVAL
1991:   fstat(3, 0xEFFFF6F8)                            = 0
1991:   time()                                          = 913874851
1991:   getpid()                                        = 1991 [1990]
1991:   putmsg(3, 0xEFFFEDB0, 0xEFFFEDA4, 0)            = 0
1991:   fstat(4, 0xEFFFEC60)                            = 0
1991:   lseek(4, 0, SEEK_SET)                           = 0
1991:   read(4, " 1 5 0\n\0\n\0", 11)                   = 7
1991:   getpid()                                        = 1991 [1990]
1991:   fcntl(4, F_SETLK, 0xEFFFED0C)                   Err#11 EAGAIN
1991:   lseek(0, 0, SEEK_CUR)                           = 5875
1991:   _exit(1)
1990:       Received signal #18, SIGCLD [default]
1990:         siginfo: SIGCLD CLD_EXITED pid=1991 status=0x0001
1990:   times(0xEFFFFBD0)                               = 386957
1990:   waitid(P_ALL, 0, 0xEFFFFBE0, WEXITED|WTRAPPED|WSTOPPED) = 0
AppleTalk not up!1990:  write(2, " A p p l e T a l k   n o".., 17)
= 17
 Child exited with 1990:        write(2, "   C h i l d   e x i t e"..,
19)
= 19
1.
1990:   write(2, " 1 .\n", 3)                           = 3
1990:   lseek(0, 0, SEEK_CUR)                           = 6322
1990:   _exit(1)
--

Thanks in advance for any recommendations

--
That is all.

---

From: Michael M Han <[email-masked]>
Date: Wed, 16 Dec 1998 23:18:01 -0800

Previously...
>  turned off (I don't have the necessary includes).

Let's see, is your kernel module installed and configured? I.e. did
you 'make kinstall', configure /etc/services and /etc/netconfig?
Sometimes a restart's required to get these to kick in... especially
after the first installation... Also, does your atalkd.conf contain a
newline-separated list of interfaces for afpd to bind? A quick and
dirty approach would alternatively be to specify -noddp in afpd.conf,
which will probably work around the missing ddp kernel module. This of
course means going without any AppleTalk support. Just to verify,
you've examined the contents of README, README.ASUN and
README.SOLARIS, right?
_________
mike ([email-masked])
I will not show off
 - The collected wisdom of Bart Simpson