Subject: [netatalk-admins] Solaris 2.6 install

From: "Mitch McNeel" <[email-masked]>
Date: Thu, 26 Mar 1998 11:06:34 -0800

I was not successful installing netatalk on a Solaris 2.6 sun box, but I
was successful with the 2.5.* version.  Is there anything in the works
for a 2.6 version install?

Also, is the any possible way to connect to my Sun box using a TCP/IP
connection form the MAC client?

Thanks
Mitch

---

From: Michael M Han <[email-masked]>
Date: Thu, 26 Mar 1998 11:18:32 -0800

Previously...
>for a 2.6 version install?

I installed 1.4b2+asun2.0a18.2 w/o incident on a Solaris 2.6
(Sparcstation2) box. I *did* have trouble installing the patched up
kernel module from Umich, but that's a different story.

>connection form the MAC client?

Once again, 1.4b2+asun2.0a18.2 is very nice. Supports AFP2.2 TCP/IP
transport for AppleShare.

For more info about the 1.4b2+asun, start at the netatalk site
( http://www.umich.edu/~rsug/netatalk/ ) and look for it among the
patches. Grab the whole package and read the readmes. Lots of
important info in the readmes.
_________
mike ([email-masked])
I will not conduct my own fire drills
 - The collected wisdom of Bart Simpson

---

From: "Mitch McNeel" <[email-masked]>
Date: Thu, 26 Mar 1998 14:07:41 -0800

Attached you will find a screen print copy of my efforts to install
netatalk-1.4b2+asun2.0a18.2 on my Solaris 2.6 Sun (Sparcstation 4) box.  I'm
still encountering errors with my install.  Is there anything you can see
from the attached file, that you think I might be doing wrong?  and thanks
for pointing me in the right direction!

I've notice that there is a few changes to the Makefile from the Umich ver
1.4b2. to include DES, tcp wrapper and PAM support.  Do you know where I can
find all the library and include files for those above??

Thanks for the help
Mitch

>  - The collected wisdom of Bart Simpson

# Root of installation. Subdirectories will be ${DESTDIR}/etc,
# ${DESTDIR}/bin, and ${DESTDIR}/lib.
# Root of installation. Subdirectories will be ${DESTDIR}/etc,
# ${DESTDIR}/bin, and ${DESTDIR}/lib.
# Root of installation. Subdirectories will be ${DESTDIR}/etc,
# ${DESTDIR}/bin, and ${DESTDIR}/lib.
DESTDIR=/opt/netatalk-1.4b2+

# for system-level binaries
SBINDIR=$(DESTDIR)/etc
# for user-level binaries
BINDIR=$(DESTDIR)/bin
# for program libraries (*.a)
LIBDIR=$(DESTDIR)/lib
# for machine-independent resources (pagecount.ps, etc.)
RESDIR=$(DESTDIR)/etc
# for configuration files (AppleVolumes.system, etc.)
ETCDIR=$(DESTDIR)/etc
# for include files
INCDIR=$(DESTDIR)/include
# Root of man pages.  Subdirectories will be
# ${MANDIR}/man1, ${MANDIR}/man4, and ${MANDIR}/man8.
MANDIR=$(DESTDIR)/man

#SBINDIR=/usr/sbin
#BINDIR=/usr/bin
#LIBDIR=/usr/lib
#RESDIR=/usr/lib/atalk
#ETCDIR=/etc
#INCDIR=/usr/include
#MANDIR=/usr/man

# Location of the DES library and include files. Comment this out if you
# don't want Randnum Exchange and 2-Way Randnum Exchange as allowable UAMs
# for afpd. We expect libdes.a in $DESDIR/lib and des.h in $DESDIR/include.
DESDIR=/usr/local

# Location of the tcp wrapper library and include files. Comment this out
# if you don't want tcp wrapper support. having tcp wrapper support is
# highly recommended.
TCPWRAPDIR=/usr

# Location of PAM support library and include files. Comment this out
# if you don't want to enable PAM support
#PAMDIR=/usr

# Location of the AFS and Kerberos libraries and include files.  Uncomment
# and edit these if you want to include AFS or Kerberos support in afpd
# or Kerberos support in papd.
#AFSDIR=/usr/local/afs
#KRBDIR=/usr/local/kerberos

##########################################################################

all install depend clean tags kernel kinstall kpatch:   FRC
        @case `uname -rs` in \
"Makefile" 95 lines, 2770 characters 
SUPERUSER@venus:/opt/tmp/netatalk-1.4b2+asun2.0a18.2> make
Making all for solaris...
gcc -D_KERNEL -mno-app-regs -munaligned-doubles -fpcc-struct-return -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -I../netatalk  -c  aarp.c
gcc -D_KERNEL -mno-app-regs -munaligned-doubles -fpcc-struct-return -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -I../netatalk  -c  ddp.c
gcc -D_KERNEL -mno-app-regs -munaligned-doubles -fpcc-struct-return -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -I../netatalk  -c  ddptp_rdq.c
gcc -D_KERNEL -mno-app-regs -munaligned-doubles -fpcc-struct-return -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -I../netatalk  -c  ddptp_utls.c
In file included from ddptp_utls.c:39:
../netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
gcc -D_KERNEL -mno-app-regs -munaligned-doubles -fpcc-struct-return -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -I../netatalk  -c  dlpi.c
gcc -D_KERNEL -mno-app-regs -munaligned-doubles -fpcc-struct-return -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -I../netatalk  -c  tpi.c
gcc -D_KERNEL -mno-app-regs -munaligned-doubles -fpcc-struct-return -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -I../netatalk  -c  utils.c
ld -r -o ddp aarp.o ddp.o ddptp_rdq.o ddptp_utls.o dlpi.o tpi.o utils.o
cd ../../libatalk; make  CC="gcc" \
    ADDLIBS="-lsocket -lnsl" DEFS="-I../../sys/solaris -D__svr4__ -DSOLARIS" OPTOPTS="-O" \
    SBINDIR="/opt/netatalk-1.4b2+/etc" BINDIR="/opt/netatalk-1.4b2+/bin" RESDIR="/opt/netatalk-1.4b2+/etc" \
    ETCDIR="/opt/netatalk-1.4b2+/etc" LIBDIR="/opt/netatalk-1.4b2+/lib" INCDIR="/opt/netatalk-1.4b2+/include" \
    DESTDIR="/opt/netatalk-1.4b2+" AFSDIR="" KRBDIR="" all
cd asp; make  CC="gcc" DEFS="-I../../sys/solaris -D__svr4__ -DSOLARIS" \
    OPTOPTS="-O" TCPWRAPDIR="/usr"
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c asp_attn.c
In file included from ../../include/atalk/asp.h:29,
                 from asp_attn.c:13:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o asp_attn.o- asp_attn.o
mv asp_attn.o- profiled/asp_attn.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c asp_attn.c
In file included from ../../include/atalk/asp.h:29,
                 from asp_attn.c:13:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o asp_attn.o- asp_attn.o
mv asp_attn.o- asp_attn.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c asp_close.c
In file included from ../../include/atalk/asp.h:29,
                 from asp_close.c:30:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o asp_close.o- asp_close.o
mv asp_close.o- profiled/asp_close.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c asp_close.c
In file included from ../../include/atalk/asp.h:29,
                 from asp_close.c:30:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o asp_close.o- asp_close.o
mv asp_close.o- asp_close.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c asp_cmdreply.c
In file included from ../../include/atalk/asp.h:29,
                 from asp_cmdreply.c:28:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o asp_cmdreply.o- asp_cmdreply.o
mv asp_cmdreply.o- profiled/asp_cmdreply.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c asp_cmdreply.c
In file included from ../../include/atalk/asp.h:29,
                 from asp_cmdreply.c:28:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o asp_cmdreply.o- asp_cmdreply.o
mv asp_cmdreply.o- asp_cmdreply.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c asp_getreq.c
In file included from asp_getreq.c:29:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o asp_getreq.o- asp_getreq.o
mv asp_getreq.o- profiled/asp_getreq.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c asp_getreq.c
In file included from asp_getreq.c:29:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o asp_getreq.o- asp_getreq.o
mv asp_getreq.o- asp_getreq.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c asp_getsess.c
In file included from ../../include/atalk/asp.h:29,
                 from asp_getsess.c:20:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
asp_getsess.c: In function `asp_getsession':
asp_getsess.c:118: warning: passing arg 2 of `setitimer' discards `const' from pointer target type
ld -r -o asp_getsess.o- asp_getsess.o
mv asp_getsess.o- profiled/asp_getsess.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c asp_getsess.c
In file included from ../../include/atalk/asp.h:29,
                 from asp_getsess.c:20:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
asp_getsess.c: In function `asp_getsession':
asp_getsess.c:118: warning: passing arg 2 of `setitimer' discards `const' from pointer target type
ld -r -o asp_getsess.o- asp_getsess.o
mv asp_getsess.o- asp_getsess.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c asp_init.c
In file included from ../../include/atalk/asp.h:29,
                 from asp_init.c:31:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o asp_init.o- asp_init.o
mv asp_init.o- profiled/asp_init.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c asp_init.c
In file included from ../../include/atalk/asp.h:29,
                 from asp_init.c:31:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here

ld -r -o asp_init.o- asp_init.o
mv asp_init.o- asp_init.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c asp_write.c
In file included from asp_write.c:26:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o asp_write.o- asp_write.o
mv asp_write.o- profiled/asp_write.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c asp_write.c
In file included from asp_write.c:26:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o asp_write.o- asp_write.o
mv asp_write.o- asp_write.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c asp_shutdown.c
In file included from asp_shutdown.c:9:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o asp_shutdown.o- asp_shutdown.o
mv asp_shutdown.o- profiled/asp_shutdown.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c asp_shutdown.c
In file included from asp_shutdown.c:9:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o asp_shutdown.o- asp_shutdown.o
mv asp_shutdown.o- asp_shutdown.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c asp_tickle.c
In file included from ../../include/atalk/asp.h:29,
                 from asp_tickle.c:3:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o asp_tickle.o- asp_tickle.o
mv asp_tickle.o- profiled/asp_tickle.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c asp_tickle.c
In file included from ../../include/atalk/asp.h:29,
                 from asp_tickle.c:3:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o asp_tickle.o- asp_tickle.o
mv asp_tickle.o- asp_tickle.o
building profiled asplib
building normal asplib
cd atp; make  CC="gcc" DEFS="-I../../sys/solaris -D__svr4__ -DSOLARIS" \
    OPTOPTS="-O" TCPWRAPDIR="/usr"
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c atp_bprint.c
ld -r -o atp_bprint.o- atp_bprint.o
mv atp_bprint.o- profiled/atp_bprint.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c atp_bprint.c
ld -r -o atp_bprint.o- atp_bprint.o
mv atp_bprint.o- atp_bprint.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c atp_bufs.c
ld -r -o atp_bufs.o- atp_bufs.o
mv atp_bufs.o- profiled/atp_bufs.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c atp_bufs.c
ld -r -o atp_bufs.o- atp_bufs.o
mv atp_bufs.o- atp_bufs.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c atp_close.c
ld -r -o atp_close.o- atp_close.o
mv atp_close.o- profiled/atp_close.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c atp_close.c
ld -r -o atp_close.o- atp_close.o
mv atp_close.o- atp_close.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c atp_open.c
ld -r -o atp_open.o- atp_open.o
mv atp_open.o- profiled/atp_open.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c atp_open.c
ld -r -o atp_open.o- atp_open.o
mv atp_open.o- atp_open.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c atp_packet.c
ld -r -o atp_packet.o- atp_packet.o
mv atp_packet.o- profiled/atp_packet.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c atp_packet.c
ld -r -o atp_packet.o- atp_packet.o
mv atp_packet.o- atp_packet.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c atp_rreq.c
ld -r -o atp_rreq.o- atp_rreq.o
mv atp_rreq.o- profiled/atp_rreq.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c atp_rreq.c
ld -r -o atp_rreq.o- atp_rreq.o
mv atp_rreq.o- atp_rreq.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c atp_rresp.c
ld -r -o atp_rresp.o- atp_rresp.o
mv atp_rresp.o- profiled/atp_rresp.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c atp_rresp.c
ld -r -o atp_rresp.o- atp_rresp.o
mv atp_rresp.o- atp_rresp.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c atp_rsel.c
In file included from atp_rsel.c:31:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o atp_rsel.o- atp_rsel.o
mv atp_rsel.o- profiled/atp_rsel.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c atp_rsel.c
In file included from atp_rsel.c:31:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o atp_rsel.o- atp_rsel.o
mv atp_rsel.o- atp_rsel.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c atp_sreq.c
ld -r -o atp_sreq.o- atp_sreq.o
mv atp_sreq.o- profiled/atp_sreq.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c atp_sreq.c
ld -r -o atp_sreq.o- atp_sreq.o
mv atp_sreq.o- atp_sreq.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c atp_sresp.c
ld -r -o atp_sresp.o- atp_sresp.o
mv atp_sresp.o- profiled/atp_sresp.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c atp_sresp.c
ld -r -o atp_sresp.o- atp_sresp.o
mv atp_sresp.o- atp_sresp.o
building profiled atplib
building normal atplib
cd nbp; make  CC="gcc" DEFS="-I../../sys/solaris -D__svr4__ -DSOLARIS" \
    OPTOPTS="-O" TCPWRAPDIR="/usr"
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c nbp_util.c
In file included from nbp_util.c:29:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o nbp_util.o- nbp_util.o
mv nbp_util.o- profiled/nbp_util.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c nbp_util.c
In file included from nbp_util.c:29:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o nbp_util.o- nbp_util.o
mv nbp_util.o- nbp_util.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c nbp_lkup.c
In file included from nbp_lkup.c:30:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o nbp_lkup.o- nbp_lkup.o
mv nbp_lkup.o- profiled/nbp_lkup.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c nbp_lkup.c
In file included from nbp_lkup.c:30:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o nbp_lkup.o- nbp_lkup.o
mv nbp_lkup.o- nbp_lkup.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c nbp_rgstr.c
In file included from nbp_rgstr.c:14:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o nbp_rgstr.o- nbp_rgstr.o
mv nbp_rgstr.o- profiled/nbp_rgstr.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c nbp_rgstr.c
In file included from nbp_rgstr.c:14:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o nbp_rgstr.o- nbp_rgstr.o
mv nbp_rgstr.o- nbp_rgstr.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c nbp_unrgstr.c
In file included from nbp_unrgstr.c:31:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o nbp_unrgstr.o- nbp_unrgstr.o
mv nbp_unrgstr.o- profiled/nbp_unrgstr.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c nbp_unrgstr.c
In file included from nbp_unrgstr.c:31:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o nbp_unrgstr.o- nbp_unrgstr.o
mv nbp_unrgstr.o- nbp_unrgstr.o
building profiled nbplib
building normal nbplib
cd adouble; make  CC="gcc" DEFS="-I../../sys/solaris -D__svr4__ -DSOLARIS" \
    OPTOPTS="-O" TCPWRAPDIR="/usr"
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c ad_open.c
In file included from ad_open.c:28:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o ad_open.o- ad_open.o
mv ad_open.o- profiled/ad_open.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c ad_open.c
In file included from ad_open.c:28:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o ad_open.o- ad_open.o
mv ad_open.o- ad_open.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c ad_flush.c
In file included from ad_flush.c:25:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o ad_flush.o- ad_flush.o
mv ad_flush.o- profiled/ad_flush.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c ad_flush.c
In file included from ad_flush.c:25:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o ad_flush.o- ad_flush.o
mv ad_flush.o- ad_flush.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c ad_read.c
In file included from ../../include/atalk/adouble.h:31,
                 from ad_read.c:26:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o ad_read.o- ad_read.o
mv ad_read.o- profiled/ad_read.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c ad_read.c
In file included from ../../include/atalk/adouble.h:31,
                 from ad_read.c:26:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o ad_read.o- ad_read.o
mv ad_read.o- ad_read.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c ad_write.c
In file included from ../../include/atalk/adouble.h:31,
                 from ad_write.c:12:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o ad_write.o- ad_write.o
mv ad_write.o- profiled/ad_write.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c ad_write.c
In file included from ../../include/atalk/adouble.h:31,
                 from ad_write.c:12:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o ad_write.o- ad_write.o
mv ad_write.o- ad_write.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c ad_size.c
In file included from ../../include/atalk/adouble.h:31,
                 from ad_size.c:11:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o ad_size.o- ad_size.o
mv ad_size.o- profiled/ad_size.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c ad_size.c
In file included from ../../include/atalk/adouble.h:31,
                 from ad_size.c:11:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o ad_size.o- ad_size.o
mv ad_size.o- ad_size.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c ad_mmap.c
In file included from ../../include/atalk/adouble.h:31,
                 from ad_mmap.c:14:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o ad_mmap.o- ad_mmap.o
mv ad_mmap.o- profiled/ad_mmap.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c ad_mmap.c
In file included from ../../include/atalk/adouble.h:31,
                 from ad_mmap.c:14:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o ad_mmap.o- ad_mmap.o
mv ad_mmap.o- ad_mmap.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c ad_lock.c
In file included from ../../include/atalk/adouble.h:31,
                 from ad_lock.c:6:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o ad_lock.o- ad_lock.o
mv ad_lock.o- profiled/ad_lock.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include -c ad_lock.c
In file included from ../../include/atalk/adouble.h:31,
                 from ad_lock.c:6:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o ad_lock.o- ad_lock.o
mv ad_lock.o- ad_lock.o
building profiled adoublelib
building normal adoublelib
cd dsi; make  CC="gcc" DEFS="-I../../sys/solaris -D__svr4__ -DSOLARIS" \
    OPTOPTS="-O" TCPWRAPDIR="/usr"
if [ x"/usr" != x ]; then \
  TCPWRAPDEFS="-DTCPWRAP"; \
  if [ "/usr" != "/usr" ]; then \
    TCPWRAPINCPATH="-I/usr/include"; \
  fi; \
fi; \
make  CC="gcc" DEFS="-I../../sys/solaris -D__svr4__ -DSOLARIS" \
OPTOPTS="-O" \
TCPWRAPINCPATH="${TCPWRAPINCPATH}" TCPWRAPDEFS="${TCPWRAPDEFS}" \
dsilib
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include  -DTCPWRAP -c dsi_attn.c
In file included from ../../include/atalk/afp.h:28,
                 from ../../include/atalk/dsi.h:17,
                 from dsi_attn.c:11:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o dsi_attn.o- dsi_attn.o
mv dsi_attn.o- profiled/dsi_attn.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include  -DTCPWRAP -c dsi_attn.c
In file included from ../../include/atalk/afp.h:28,
                 from ../../include/atalk/dsi.h:17,
                 from dsi_attn.c:11:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o dsi_attn.o- dsi_attn.o
mv dsi_attn.o- dsi_attn.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include  -DTCPWRAP -c dsi_close.c
In file included from ../../include/atalk/afp.h:28,
                 from ../../include/atalk/dsi.h:17,
                 from dsi_close.c:8:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o dsi_close.o- dsi_close.o
mv dsi_close.o- profiled/dsi_close.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include  -DTCPWRAP -c dsi_close.c
In file included from ../../include/atalk/afp.h:28,
                 from ../../include/atalk/dsi.h:17,
                 from dsi_close.c:8:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o dsi_close.o- dsi_close.o
mv dsi_close.o- dsi_close.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include  -DTCPWRAP -c dsi_cmdreply.c
In file included from ../../include/atalk/afp.h:28,
                 from ../../include/atalk/dsi.h:17,
                 from dsi_cmdreply.c:7:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o dsi_cmdreply.o- dsi_cmdreply.o
mv dsi_cmdreply.o- profiled/dsi_cmdreply.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include  -DTCPWRAP -c dsi_cmdreply.c
In file included from ../../include/atalk/afp.h:28,
                 from ../../include/atalk/dsi.h:17,
                 from dsi_cmdreply.c:7:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o dsi_cmdreply.o- dsi_cmdreply.o
mv dsi_cmdreply.o- dsi_cmdreply.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include  -DTCPWRAP -c dsi_getsess.c
In file included from ../../include/atalk/afp.h:28,
                 from ../../include/atalk/dsi.h:17,
                 from dsi_getsess.c:14:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o dsi_getsess.o- dsi_getsess.o
mv dsi_getsess.o- profiled/dsi_getsess.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include  -DTCPWRAP -c dsi_getsess.c
In file included from ../../include/atalk/afp.h:28,
                 from ../../include/atalk/dsi.h:17,
                 from dsi_getsess.c:14:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o dsi_getsess.o- dsi_getsess.o
mv dsi_getsess.o- dsi_getsess.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include  -DTCPWRAP -c dsi_getstat.c
In file included from ../../include/atalk/afp.h:28,
                 from ../../include/atalk/dsi.h:17,
                 from dsi_getstat.c:9:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o dsi_getstat.o- dsi_getstat.o
mv dsi_getstat.o- profiled/dsi_getstat.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include  -DTCPWRAP -c dsi_getstat.c
In file included from ../../include/atalk/afp.h:28,
                 from ../../include/atalk/dsi.h:17,
                 from dsi_getstat.c:9:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o dsi_getstat.o- dsi_getstat.o
mv dsi_getstat.o- dsi_getstat.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include  -DTCPWRAP -c dsi_init.c
In file included from ../../include/atalk/afp.h:28,
                 from ../../include/atalk/dsi.h:17,
                 from dsi_init.c:9:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o dsi_init.o- dsi_init.o
mv dsi_init.o- profiled/dsi_init.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include  -DTCPWRAP -c dsi_init.c
In file included from ../../include/atalk/afp.h:28,
                 from ../../include/atalk/dsi.h:17,
                 from dsi_init.c:9:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o dsi_init.o- dsi_init.o
mv dsi_init.o- dsi_init.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include  -DTCPWRAP -c dsi_opensess.c
In file included from ../../include/atalk/afp.h:28,
                 from ../../include/atalk/dsi.h:17,
                 from dsi_opensess.c:10:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o dsi_opensess.o- dsi_opensess.o
mv dsi_opensess.o- profiled/dsi_opensess.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include  -DTCPWRAP -c dsi_opensess.c
In file included from ../../include/atalk/afp.h:28,
                 from ../../include/atalk/dsi.h:17,
                 from dsi_opensess.c:10:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o dsi_opensess.o- dsi_opensess.o
mv dsi_opensess.o- dsi_opensess.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include  -DTCPWRAP -c dsi_read.c
In file included from ../../include/atalk/afp.h:28,
                 from ../../include/atalk/dsi.h:17,
                 from dsi_read.c:12:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o dsi_read.o- dsi_read.o
mv dsi_read.o- profiled/dsi_read.o
gcc -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include  -DTCPWRAP -c dsi_read.c
In file included from ../../include/atalk/afp.h:28,
                 from ../../include/atalk/dsi.h:17,
                 from dsi_read.c:12:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/opt/GCC2723/lib/gcc-lib/sparc-sun-solaris2.6/2.7.2.3/include/sys/int_types.h:69: warning: `int32_t' previously declared here
ld -r -o dsi_read.o- dsi_read.o
mv dsi_read.o- dsi_read.o
gcc -p -I../../sys/solaris -D__svr4__ -DSOLARIS -O -I../../include  -DTCPWRAP -c dsi_tcp.c
dsi_tcp.c:27: tcpd.h: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `dsi_tcp.o'
Current working directory /opt/tmp/netatalk-1.4b2+asun2.0a18.2/libatalk/dsi
*** Error code 1
make: Fatal error: Command failed for target `all'
Current working directory /opt/tmp/netatalk-1.4b2+asun2.0a18.2/libatalk/dsi
*** Error code 1
make: Fatal error: Command failed for target `dsi'
Current working directory /opt/tmp/netatalk-1.4b2+asun2.0a18.2/libatalk
*** Error code 1
make: Fatal error: Command failed for target `../../libatalk'
Current working directory /opt/tmp/netatalk-1.4b2+asun2.0a18.2/sys/solaris
*** Error code 1
make: Fatal error: Command failed for target `all'
SUPERUSER@venus:/opt/tmp/netatalk-1.4b2+asun2.0a18.2>