Subject: RE: [netatalk-admins] netatalk-1.4b2+asun2.0a18.2 - IP works, eth ertalk doesn't?

From: Sean Page <[email-masked]>
Date: Tue, 26 May 1998 08:55:35 -0600

Hi, Andras,

No, there are no other routers, it is a very small test network
consisting of only the FreeBSD server (sitting between the Appletalk
network on ethernet and the Internet) and one mac workstation running OS
8. Both of them are on the same hub on the inside network. It's very
strange. Even when I use the -seed option, the Mac can't see the server
in the chooser.

Tried making the atalkd.conf file read only (great suggestion by the
way!), but that didn't work either. I also tried manually changing the
net address on the mac to be the same as the server (different node, of
course) and that also didn't help. I'm starting to think there is
something more fundamentally wrong. Any more suggestions?

Sean.

> ----------
> From: 	Andras Kadinger
> Sent: 	Thursday, May 21, 1998 5:13 PM
> To: 	Sean Page
> Subject: 	Re: [netatalk-admins] netatalk-1.4b2+asun2.0a18.2 - IP
> works, ethertalk doesn't?
> 
> Hello Sean,
> 
> Sean Page wrote:
> > 
> > I have installed netatalk-1.4b2+asun2.0a18.2 on FreeBSD 2.2.5 (with
> > netatalk kernel patches) and I'm at my wits end. I can connect to
> the
> > server via IP no problem at all, works great, but can not see it on
> the
> > local network via the chooser no matter what I do.
> > 
> > My atalkd.conf auto configures to:
> > 
> > ed0 -phase 2 -net 65280-65534 -addr 65280.198
> > ed1 -phase 2 -net 65280-65534 -addr 0.0
> > And I tried to reconfigure it to:
> > 
> > ed0 -phase 2 -net 65280-65534 -addr 65280.198
> > ed1 -phase 2 -net 100-200 -addr 100.1
> > to no avail. ed0 is the interface to the outside world, ed1 is the
> > internal network. I am also running NAT, if that makes a
> difference...
> > 
> > Any advise on what I can try would be greatly appreciated!
> 
> Are there other routers on Your network?
> 
> Although I am on Linux, I could force atald to use my settings in some
> cases by making atalkd.conf read-only. Try it, it might help.
> 
> What do Macs show in their AppleTalk control panel in Administrator
> mode?
> 
> Sincerely,
> Andras Kadinger
> [email-masked]
>

---

From: Casey Bisson <[email-masked]>
Date: Tue, 26 May 1998 11:33:18 -0400

My first experience with Netatalk was with a Dell 486 and DEC EtherWorks III
ethernet card under FreeBSD. I experienced the same unfathomable problems (can
connect via IP, cannot connect via appletalk), and tried(and failed with) the same
solutions. It was all particularly annoying because MacOS and WinNT machines could
serve AppleShare fine from the same subnet. We read through pages of sniff logs
and forwarded them to our router manufacturer for help, and we couldn't identify
any reasonable cause for the problem.

In the end, I tried a different machine (Dell pnetium 166) a different ethernet
card (3com 10/100) and newer install of FreeBSD (2.2.5.? to 2.2.6.?) and it worked
fine with Netatalk 2.4b3 + asun18 (or 17). Nothing else changed, and it worked.

If you ever do identify why it doesn't work, I'd like to know.

Casey Bisson
Information Technology
Plymouth State College

---

From: Jon Torrez <[email-masked]>
Date: Tue, 26 May 1998 10:50:31 -0500 (CDT)

On Tue, 26 May 1998, Sean Page wrote:

	Sean: 

		I am having the exact same problem, but mine goes a little
		more indepth, there has been a few folks that have tried
		to help but no go :(

		Here is an pathetic ascii drawing of my network :)

(resrv-net 192.168.0.0/255)       eth1 (192.168.0.1)
(Mac /Windoze ) -----------<eth1>------ (Linux box)-----<eth0>-----(internet)
						eth0(207.239.128.197

_and_ I have ny atalkd.conf like this:
__BOF__
eth1 -phase 2 -net 0-65534 -addr 65280.97
__EOF__ this file is read-only

This is what it looks like when ASIP starts up:
May 26 10:35:17 wwwebservers atalkd[8523]: restart (1.4b2+asun2.0a18.2)
May 26 10:35:18 wwwebservers atalkd[8523]: zip_getnetinfo for eth1
^A1^A1May 26 10:35:37 wwwebservers last message repeated 2 times
May 26 10:35:47 wwwebservers atalkd[8523]: config for no router
May 26 10:35:48 wwwebservers atalkd[8523]: ready 0/0/0
May 26 10:36:06 wwwebservers afpd[8535]: wwwebservers:AFPServer@* started
on 65280.97:128 (1.4b2+asun2.0a18.2)
May 26 10:36:06 wwwebservers afpd[8535]: ASIP started on 207.239.128.197:548(2)
(1.4b2+asun2.0a18.2)

	should it not start on 192.168.0.1?? that is going out on the 'net

May 26 10:37:38 wwwebservers afpd[8535]: server_child[1] 8538 done
May 26 10:37:48 wwwebservers afpd[8539]: ASIP session:548(2) from
                                                192.168.0.2:2145(4)
May 26 10:37:48 wwwebservers afpd[8535]: server_child[1] 8539 killed

	This is what happens when a user tries to login, yes
etc/afpd/Makefile does have -DSHADOWPW in it.

afpd also creates a core file, is anyone interested in it?? :)

would anyone know the answer to my problem?

Sysinfo:
	p120, 32megs EDO RAM
	libc 5.4.44
	gcc: 2.7.2.3
	Linux 2.0.34pre16

+--------
| Jon Torrez
| Systems Administrator - WWWebServers, Inc. 
| http://www.wwwebservers.com / [email-masked]
+----------------------------------------------------------------------

---

From: Hannu Krosing <[email-masked]>
Date: Tue, 26 May 1998 18:47:41 +0300

> something more fundamentally wrong. Any more suggestions?

AFAIK there is no protocol for server advertizing that works over IP, so
you can see only these machines in the chooser that advertize using 
ethertalk, not IP.

To use ethertalk, you must have appletalk support in your OS.

I'm not sure that this is the case for FreeBSD, at least not default

Hannu