Subject: [netatalk-admins] papd and RedHat 5.0

From: "Richard H. Fifarek" <[email-masked]>
Date: Mon, 12 Jan 1998 10:51:48 -0600 (CST)

I recently upgraded to RedHat 5.0, and upgraded to netatalk 1.4b2
+ asun2.0a18.  This fixed all but one problem (seemingly).  papd refuses
to print.  papd registers the printer fine, and the Macs are able to send
print jobs to it without any complaints, but I receive no print out.  My
syslog looks like this:

Jan 12 10:32:06 elmo papd[1015]: lp_print queued
Jan 12 10:32:06 elmo papd[947]: child 1015 done
Jan 12 10:32:06 elmo kernel: lp1 at 0x0378, (polling)

which would appear to be correct.  lpd appears to be working fine as well.
I can print locally and remotely.

Any suggestions?

Thanks, Rich

_____________________________________________________
Richard H. Fifarek	SIU School of Medicine
[email-masked]	Information Systems Center
_____________________________________________________

---

From: Michael Zuelsdorff <[email-masked]>
Date: Wed, 14 Jan 1998 01:22:50 +0100 (MET)

Hi,

On 12-Jan-98 Richard H. Fifarek wrote:
>.....

I don't know Redhat but I ran into similiar problem after upgrading to SuSE 5.1.
The "old" lpr has been replaced by lprng which behaves different. Fortunately I
remembered the following posting from July 97:

--------------------------------------------------------------------------
Date: Wed, 2 Jul 1997 11:22:50 -0400 (EDT)
X-Sender: [email-masked]
In-Reply-To: <[email-masked]>
Message-ID: <[email-masked]>
MIME-Version: 1.0
Content-Type: TEXT/PLAIN; charset=US-ASCII
XFMstatus: 0000
Sender: [email-masked]
From: Edan Idzerda <[email-masked]>
To: "Jonathan I. Kamens" <[email-masked]>
Subject: Re: papd and LPRng ... not working ...
Cc: [email-masked], [email-masked]

On Tue, 1 Jul 1997, Jonathan I. Kamens wrote:
> LPRng doesn't queue the same was BSD LPR does.  I modified netatalk to
> use support LPRng by using "lpr" to queue jobs rather than trying to
> insert them directly into the queue directory.  I submitted my patches

Err, I didn't look closely at your code to see if it would work 
better, but you can already do

        :pr=|lpr:

To get papd to use lpr instead of queueing directly.  This appears
to be the The One Truth I Know About Netatalk Printing.

- edan
----------------------------------------------------------------------------

After changing the entry in papd.conf this way, printing works again without
problems.I hope this helps with Redhat, too.

Good luck.

Michael

  _~_  (?)
 (o o)°
-- V -^ -----------------------------------------------------------------------
   .  N  .                             (!)              Michael   Zuelsdorff
    \ i /           I don't like LINUX -  ° ^ ^         Gruene  Riede  5    
  °. \u/ .°              I love it         (o o)        31311  Dollbergen   
    °>X<°                                  / v \        +49 517-792-2113
--- " L " --------------------------------//8°8\\------ [email-masked] --