Subject: [netatalk-admins] pap does not disconnect from Apple LaserWriter

From: Johannes Martin <[email-masked]>
Date: Tue, 27 Oct 1998 17:41:33 -0800 (PST)

Hi,

I just installed netatalk (tried both 1.3.3 and 1.4b2) on a ix86 Linux
2.0.35 machine. I did this in order to print to an Apple LaserWriter Pro
630 printer.

Printing using pap works fine - except that pap does not disconnect from
the printer when the print job is finished. It just sits there and waits:
Trying 35195.225:128 ...
status: idle
Connected to rigi:[email-masked].
<it now prints, then nothing else happens>

A call to papstatus prints:
status: waiting; source: EtherTalk

There are only two ways to get 'solve' this:
- turn off the printer
- restart atalkd (killing pap does not help)

Do you have any hints on how to solve this? 

Thanks
	Johannes

---

From: [email-masked]
Date: Wed, 28 Oct 1998 09:24:09 -0500

> From:    Johannes Martin <[email-masked]>
> To:      [email-masked]

> - restart atalkd (killing pap does not help)

If you kill pap, you have to wait (on most printers) two minutes for
the printer to time the connection out.  Try using the -E option.
Also, are you having this problem when using pap with psf and lpr?  If
so, disable accounting.

:wes