Subject: [netatalk-admins] Managing netatalk

From: Jochen Haeberle <[email-masked]>
Date: Thu, 12 Mar 1998 11:23:19 +0000

Hi,

I am installing netatalk in a rather busy environment. I have problems
shutting down the services and getting it up again. I do have a script atalk
in a Sys V way that I can call as "atalk start", but I cannot restart it after
some changes to the config files with "atalk start" I get errors
  nbp_rgstr: Connection timed out
  Can't register Linux-FTP-Server:Workstation@*
  nbp_rgstr: Connection timed out
  Can't register Linux-FTP-Server:netatalk@*

Is there a way to restart the netatalk services without rebooting the machine?

BTW: Is there a way to know which and how many users are using the shared
volumes on my Linux box?

I am using Linux 2.0.32 on Intel as the netatalk 1.4b2 server and Mac OS 8 and
8.1 clients.

Thanks for your help

Jochen

---

From: Vivek <[email-masked]>
Date: Thu, 12 Mar 1998 11:26:13 +0000 (GMT)

> Is there a way to restart the netatalk services without rebooting the machine?

1] Compile the ddp stuff in as a module, then:
   Kill the daemon,
   rmmod the ddp stuff, [and insmod it again if you don't have kerneld up]
   Start the daemon.

Or:

2] Go to kernel 2.0.33 which should fix the atalkd stop/start problem...

> BTW: Is there a way to know which and how many users are using the shared

The afpd processes will run as the connected users - one per user, plus
one master running as root. 

Hope this helps...
--
fsck -f -b 8193 /dev/cortex

---

From: Wes Brown <[email-masked]>
Date: Thu, 12 Mar 1998 08:36:16 -0500 (EST)

> On Thu, 12 Mar 1998, Jochen Haeberle wrote:
[snip]
> one master running as root. 

There is a perl script called nu that I saw at
http://thehamptons.com/anders/netatalk/

The text just above the first full horizontal line on that page:
Want to know who's logged on a netatalk server? Try nu. 

#!/usr/bin/perl
# nu - by Anders Brownworth   [email-masked]
#
# shows netatalk users logged on
#
# usage: nu
#
# I'm sure I'll get some options in there at some point!

@users = `ps aucx | grep afpd`;

print "Netatalk users:\n---------------\n";
foreach $user (@users)
{
  $user =~ /(\S+)/;
  $n = `grep $1 /etc/passwd`;
  ($a, $b, $c, $d, $name) = split (/:/, $n);
  print "$name\n" unless ($name eq "root");
}

Wes
--- 
Wes Brown
[email-masked]		[email-masked]
http://prozac.cwru.edu/wes/About.me.html
KB8TGR