Subject: [netatalk-admins] Rdhat 5.1 compile probs

From: "Jamie Orzechowski" <[email-masked]>
Date: Mon, 22 Jun 1998 10:00:43 -0400

I made it past my first error by including ioctls.h but now I get a crypt
error ... I included crypt.h but fdidn't work .. any ideas??

here is a compile output

make[3]: Entering directory `/tmp/netatalk-1.4b2/etc/afpd'
if [ x"" != x ]; then \
    KRBLIBS="-lkrb -ldes"; \
    KRBLIBDIRS="-L/lib"; \
    KRBINCPATH="-I/include"; \
    KRBDEFS="-DKRB"; \
fi; \
if [ x"" != x ]; then \
    AFSLIBS="-lkauth -lprot -lubik -lauth -lsys -lrxkad -lrx -laudit \
        -llwp -lcmd -lcom_err /lib/afs/util.a -ldes"; \
    AFSLIBDIRS="-L/lib -L/lib/afs"; \
    AFSINCPATH="-I/include"; \
    AFSDEFS="-DAFS"; \
fi; \
make -w CC="gcc" ADDLIBS="" DEFS="" \
    OPTOPTS="-O2 -fsigned-char" DESTDIR="/usr/local/atalk" \
    SBINDIR="/usr/local/atalk/etc" BINDIR="/usr/local/atalk/bin"
RESDIR="/usr/lo
cal/atalk/etc" \
    ETCDIR="/usr/local/atalk/etc" LIBDIR="/usr/local/atalk/lib"
INCDIR="/usr/loc
al/atalk/include" \
    KRBLIBS="${KRBLIBS}" KRBLIBDIRS="${KRBLIBDIRS}" \
    KRBINCPATH="${KRBINCPATH}" KRBDEFS="${KRBDEFS}" \
    AFSLIBS="${AFSLIBS}" AFSLIBDIRS="${AFSLIBDIRS}" \
    AFSINCPATH="${AFSINCPATH}" AFSDEFS="${AFSDEFS}" \
    afpd
make[4]: Entering directory `/tmp/netatalk-1.4b2/etc/afpd'
gcc    -O2 -fsigned-char -I../../include   -DAPPLCNAME -DCRLF   -o afpd
unix.o a
fs.o kuam.o send_to_kdc.o lifetime.o ofork.o main.o switch.o auth.o volume.o
dir
ectory.o file.o enumerate.o desktop.o filedir.o fork.o appl.o gettok.o
bprint.o
-L../../libatalk   -latalk
unix.o: In function `setdeskmode':
unix.o(.text+0x18b): the `getwd' function is dangerous and should not be
used.
auth.o: In function `clrtxt_login':
auth.o(.text+0x541): undefined reference to `crypt'
make[4]: *** [afpd] Error 1
make[4]: Leaving directory `/tmp/netatalk-1.4b2/etc/afpd'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/tmp/netatalk-1.4b2/etc/afpd'
make[2]: *** [afpd] Error 2
make[2]: Leaving directory `/tmp/netatalk-1.4b2/etc'
make[1]: *** [../../etc] Error 2
make[1]: Leaving directory `/tmp/netatalk-1.4b2/sys/linux'
make: *** [all] Error 2
[root@zima netatalk-1.4b2]#

---

From: Edward Birdsall <[email-masked]>
Date: Mon, 22 Jun 1998 14:01:50 -0400

Hi,

The is a listing of patch for netatalk 1.4b2 for RedHat5.0 and I believe
5.1 to handle the change in C compilor locations with the new
RedHat5.0(5.1).  It is at:  http://thehamptons.com/anders/netatalk/#other
It has downloadable files and loads of information that I used for my
installation to find the diffderences between RedHat 4.2 and Redhat 5.0&5.1.

Yours,
ed

"Jamie Orzechowski" <[email-masked]> tales continues-------
>[root@zima netatalk-1.4b2]#

------------------------------------------------------------------------
Edward Birdsall            Engineer II
[email-masked]            Nuclear Engineering and Radiological Sciences
Phone: (313)764-8262       College of Engineering
Fax:   (313)763-4540       University of Michigan,   48109-2104
------------------------------------------------------------------------

---

From: Magnus Hoglund <[email-masked]>
Date: Tue, 23 Jun 1998 02:13:51 +0200 (MET DST)

Hi,

I'm running netatalk with the latest asun-patches on a Solaris 2.6-box
with two ethernet-interfaces and have a question.... I would like to
disable Appletalk-routing between the interfaces. How do I do that?

Regards. Magnus Hoglund
         Dalarna University
         SWEDEN

---

From: thomas <[email-masked]>
Date: Tue, 23 Jun 1998 11:52:12 +0200 (CEST)

Well I don't know, what the clean way is, but on a 2.0.32 Linux,
we wanted the same and did it "cruel and dirty":

-START-------------------------.../linux/net/appletalk/ddp...-----------

--- ddp.c.orig  Fri May 31 12:46:27 1996
+++ ddp.c   Fri Mar 28 16:32:51 1997
@@ -1489,10 +1489,16 @@
        {
            kfree_skb(skb, FREE_READ);
            return(0);
        }
 #endif
+
+#if 1                          /* Don't do appletalk routing */
+       kfree_skb(skb, FREE_READ);
+       return 0;
+#endif
+
        ta.s_net=ddp->deh_dnet;
        ta.s_node=ddp->deh_dnode;

        /* Route the packet */
        rt=atrtr_find(&ta);

--- END ----------------------------------------------------------------
If there is a better solution (there must be) tell me where ...

Thomas Riewe