Subject: [netatalk-admins] NetATalk & Samba on Intel Linux

From: Jean-Christophe Praud <[email-masked]>
Date: Fri, 23 Jan 1998 13:48:48 +0100

Hello,

I've installed NetATalk and Samba on a RedHat 5.0 Linux box. PC and Mac
users have to share HTML and image files.

When a PC write image files to the linux and read them. It works well
When a Mac does the same, it works too.

The trouble is : when a mac tries to read an image file created by a PC,
the file is corrupted. 
On some linear format such as TIFF, the image is valid up to a certain
offset in the file.
I suspect a CR/LF conversion. But I couldn't find out where.

For the mac, text files and image files appear with the same icon.

Any idea about that ?

-- 
Jean-Christophe PRAUD - LUDEXPRESS
Game  Web: http://www.chronos.org
Perso Web: http://www.brutaltruth.com
Ph'nglui mglw'nafh Cthulhu n'gah Bill R'lyeh Wgah'nagl fhtagn.

---

From: Vivek <[email-masked]>
Date: Fri, 23 Jan 1998 14:20:11 +0000 (GMT)

> For the mac, text files and image files appear with the same icon.

It certainly sounds like CR/LF conversion: make sure your
AppleVolumes.system file has appropriate type/creator entries for the
various types of file you want to share: Setting your default translation
to BINA/ttxt or similar might help to - this will mean that CR/LF
translation will only occur for file types you specifically set to
type TEXT. I hope.

--
fsck -f -b 8193 /dev/cortex

---

From: Kramer <[email-masked]>
Date: Fri, 23 Jan 1998 13:00:16 -0500

>translation will only occur for file types you specifically set to

Hey!

Thought you might find this helpful.  I use the following
AppleVolumes.system file.  It takes care of most everything.

Good luck.
Philip

_____cut here_______
/usr/sharevol "Share Me"
/usr/install "Install"
.       TEXT    ttxt      ASCII Text file
.a        TEXT  MPS       Assembly Source
.aif      AIFF  SNDM      AIFF Sound
.aiff     AIFF  SNDM      AIFF Sound
.aifc     AIFF  SNDM      AIFF Sound
.arc      BINA  arc©      PC ARChive
.asc      TEXT  ttxt      ASCII Text
.ascii    TEXT  ttxt      ASCII Text
.au       ULAW  SNDM      Sun Sound
.avi      BINA  AVIC      VI Movie
.backup   FASL  Fra5      FrameMaker Backup file
.bat      TEXT  ttxt      MS-DOS Batch File
.bar      BARF  S6+1      Unix BAR Archive
.bin      BINA  SITx      MacBinary
.bmp      BMPp  JVWR      Windows Bitmap
.bok      FBok  Fra5      FrameMaker Book file
.book     FBok  Fra5      FrameMaker Book file
.c        TEXT  MMCC      C Source
.com      PCFA  PCXT      MS-DOS Binary
.cp       TEXT  MMCC      C Source
.cpp      TEXT  MMCC      C Source
.cpt      PACT  CPCT      Compact Pro Archive
.dbf      COMP  FOX       DBase Document
.dl       DL    AnVw      DL Animation
.dll      PCFL  PCXT      Windows DLL
.doc      WDBN  MSWD      Word Document
.dvi      ODVI  OTEX      TeX DVI Document
.eps      EPSF  vgrd      PostScript
.epsf     EPSF  vgrd      PostScript
.etx      TEXT  R*ch      SEText
.evy      ENYD  ENVY      Envoy Document
.exe      PCFA  PCXT      MS-DOS Binary
.faq      TEXT  ttxt      ASCII Text
.fli      FLI   AnVw      FLI Animation
.fm       FMPR  FMPR      FileMaker Pro Database
.fm5      FASL  Fra5      FrameMaker Document
.gif      GIFf  JVWR      GIF Picture
.gl       BINA  AnVw      GL Animation
.gz       Gzip  Gzip      Gnu ZIP Archive
.h        TEXT  MMCC      C Include File
.hp       TEXT  MMCC      C Include File
.hpp      TEXT  MMCC      C Include File
.hqx      TEXT  SITx      BinHex4
.htm      TEXT  MOSS      HyperText Markup Language (HTML)
.html     TEXT  MOSS      HyperText Markup Language (HTML)
.ief      IEF   GKON      IEF Image
.java     TEXT  ALFA      Java Source
.jpg      JPEG  JVWR      JPEG Picture
.jpe      JPEG  JVWR      JPEG Picture
.jpeg     JPEG  JVWR      JPEG Picture
.latex    TEXT  OTEX      TeX Document
.lha      LHA   LARC      LHArc Archive
.lzh      LHA   LARC      LHArc Archive
.med      STrk  STrk      MOD Music
.mid      Midi  ttxt      MIDI Sound
.mif      TEXT  Fram MIF Fra5    FrameMaker MIF
.mod      STrk  STrk      MOD Sound
.moov     MooV  ttxt      QuickTime Movie
.mov      MooV  ttxt      QuickTime Movie
.mpe      MPEG  mMPG      MPEG Movie
.mpg      MPEG  mMPG      MPEG Movie
.mpeg     MPEG  mMPG      MPEG Movie
.mswd     WDBN  MSWD      Microsoft Word document
.mw       WORD  MWII      MacWrite Document
.mwii     WORD  MWII      MacWrite Document
.obj      PCFL  PCXT      Object (DOS/Windows)
.oda      ODIF  ODA       ODA Document
.ovl      PCFL  PCXT      Overlay (DOS/Windows)
.p        TEXT  MWPS      Pascal Source
.pas      TEXT  MWPS      Pascal Source
.pbm      PPGM  GKON      Portable Bitmap
.ps       TEXT  vgrd      PostScript
.pct      PICT  ttxt      PICT Picture
# this should be corrected:
#.pdf      TEXT  caro      Portable Display Format (Adobe Acrobat)
.pdf      PDF   CARO      Portable Display Format (Adobe Acrobat)
.pgm      PPGM  GKON      Portable Graymap
.pict     PICT  ttxt      PICT Picture
.pit      PIT   SITx      PackIt Archive
.pkg      HBSF  GEOL      AppleLink Package
.pl       TEXT  McPL      Perl Source
.pm4      ALB4  ALD4      PageMaker Document
.ppm      PPGM  GKON      Portable Pixmap
.ppd      SLD3  PPT3      Power Point
.psd      8BPS  8BIM      Photoshop
.qt       MooV  ttxt      QuickTime Movie
.readme   TEXT  R*ch      Text Readme
.rle      RLE   GKON      RLE Image
.rpl      FRL!  REP!      Replica Document
.rtf      TEXT  MSWD      Rich Text Format
.rtx      TEXT  R*ch      Rich Text
.sea      APPL  ????      Self-Extracting Archive
.sit      SITD  SIT!      StuffIt Archive
.sithqx   TEXT  SITx      BinHexed StuffIt Archive
.svx      SVXB  Snd       WAV Sound
.sylk     TEXT  XCEL      SYLK Spreadsheet
.syk      TEXT  XCEL      SYLK Spreadsheet
.tar    TARF    TAR!      Unix Tape ARchive
#.tar      TARF  S6+1      Unix Tape ARchive
.taz      ZIVM  SITx      Compressed Tape ARchive
.tex      TEXT  OTEX      TeX Document
.texi     TEXT  OTEX      TeX Document
.texinfo  TEXT  OTEX      TeX Document
.tgz      Gzip  SITx      Gnu ZIPed Tape ARchive
.tif      TIFF  JVWR      TIFF Picture
.tiff     TIFF  JVWR      TIFF Picture
.tsv      TEXT  R*ch      Tab Separated Values
.txt      TEXT  MSWD      ASCII Text
.txt      TEXT  MSWD      ASCII Text
.url      AURL  Arch      Anarchie URL Bookmark
.uu       TEXT  uuUN      UUEncode
.uue      TEXT  uuUN      UUEncode
.voc      ovc   BSnd      VOC Sound
.wav      WAVE  SCPL      Windows Sound
.wk1      TEXT  XCEL      Lotus Spreadsheet
.wks      TEXT  XCEL      Lotus Spreadsheet
.w51      WPPC  WPC2      WordPerfect Document
.wp5      WPPC  WPC2      WordPerfect Document
.wp       WPPC  WPC2      WordPerfect Document
.xbm      XBM   GKON      X Windows Picture
.xl       XLS4  XCEL      Excel Spreadsheet
.xlc      XLC4  XCEL      Excel Chart
.xlm      XLM4  XCEL      Excel Macro
.xls      XLS4  XCEL      Excel Spreadsheet
.zip      ZIP   ZIP       PC ZIP Archive
.Z        ZIVM  LZIV      Unix Compress Archive

---

From: Jean-Christophe Praud <[email-masked]>
Date: Sun, 25 Jan 1998 19:00:39 +0100

OK, I've tuned my AppleVolume.system file, and it works.

Tanks you all