Subject: [netatalk-admins] Error in "make" on Solaris 2.6 box

From: "Robert J. Marinchick" <[email-masked]>
Date: Tue, 6 Jan 1998 10:24:03 -0500 (EST)

Hi,

I'm currently trying to make netatalk on a solaris 2.6 box,
an am running into a problem "/usr/include/sys/model.h:32 
                              #error "No DATAMODEL_NATIVE
specified"

*** Error code 1
make: Fatal error: Command failed for target 'aarp.o'.

I'd appreciate any suggestions.

Thanks,
Bob Marinchick
[email-masked]

---

From: Mark Juric <[email-masked]>
Date: Tue, 6 Jan 1998 09:51:30 -0600 (CST)

Robert,
  You will need to recompile GCC to run correctly under 2.6.  The DATAMODEL
directive is a new addition to Solaris 2.6 and it will be defined in
/<gcc-lib_install_dir>/include/sys/sunddi.h 

-Mark

--                                 
Mark Juric  [email-masked]      `||||'      (630) 620-5000 x1653
Team Leader, Production Systems       ||       PLATINUM Technology