Subject: [netatalk-admins] Woah! crash, Bad Trap!

From: "Brad G. Parks" <[email-masked]>
Date: Tue, 1 Sep 98 16:06:22 -0500

Yikes.  Anybody seen the "afpd: trap type = 0x31" before?
Maybe the problem has something to do with the network changes...
I don't know.  Anybody have any ideas/suggestions?
Environment is an Ultra-5 running 2.6.

Sep  1 15:09:26 host unix: dump on /dev/dsk/c1t0d0s1 size 263040K
Sep  1 15:09:26 host unix: BAD TRAP: cpu=0 type=0x31 rp=0x30315340 addr=0x4c 
mmu_fsr=0x0
Sep  1 15:09:26 host unix: afpd: trap type = 0x31
Sep  1 15:09:26 host unix: addr=0x4c
Sep  1 15:09:26 host unix: pid=10530, pc=0x100631e0, sp=0x303153d0, tstate=0x
9980001e02, context=0xceb
Sep  1 15:09:26 host unix: g1-g7: 10433400, 53ed0f4, 10040580, f20, 0, 0, 607
585a0
Sep  1 15:09:26 host unix: Begin traceback... sp = 303153d0
Sep  1 15:09:26 host unix: Called from 606b4128, fp=30315430, args=605373fc 6
0612800 60612798 60a340e0 2 60537dfc
Sep  1 15:09:26 host unix: Called from 606b2144, fp=303154a0, args=600b7b30 6

-brad
bparks at bethel dot edu

---

From: "Brad G. Parks" <[email-masked]>
Date: Thu, 3 Sep 98 09:06:32 -0500

Galen wrote:
> Get the latest tcp/ip and kernel patches for that Ultra-5, install
> them and try again.

Yes, well, I thought I was pretty up to date, but I guess not.
The file ftp://sunsolve.sun.com/pub/patches/Solaris2.6.PatchReport
has the following entry relating to hme:
     Patch-ID# 105795-05
     Synopsis: SunOS 5.6: /kernel/drv/hme patch
     BugId's fixed with this patch: [...]
     Changes incorporated in this version: 4149861 4151457 4152994
     Date: Aug/11/98
and my system's showrev -p lists Patch: 105795-03, so I would
definitely like to get the latest and greatest...  But I am unable
to find 105795-05 in ftp://sunsolve.sun.com/pub/patches...  Any
suggestions on where I could get this rather important patch?

-brad