Subject: [netatalk-admins] Installation problem: netatalk 1.4b2 on solaris 2.5.1

From: "Yasmine Arafa" <[email-masked]>
Date: Thu, 22 Oct 1998 16:56:23 +0100

I am now getting the following error msg when I am building netatalk:
Making all for solaris...
cd ../../libatalk; make  CC="gcc" \
    ADDLIBS="-lsocket -lnsl" DEFS="-D__svr4__ -DSOLARIS" OPTOPTS="-O" \
    SBINDIR="/usr/local/atalk/etc" BINDIR="/usr/local/atalk/bin"
RESDIR="/usr/local/atalk/etc" \
    ETCDIR="/usr/local/atalk/etc" LIBDIR="/usr/local/atalk/lib"
INCDIR="/usr/local/atalk/include" \
    DESTDIR="/usr/local/atalk" AFSDIR="/usr/local/afs"
KRBDIR="/usr/local/kerberos" all
cd asp; make  CC="gcc" DEFS="-D__svr4__ -DSOLARIS" \
    OPTOPTS="-O"
gcc -p -D__svr4__ -DSOLARIS -O -I../../include -c asp_getsess.c
asp_getsess.c: In function `asp_getsession':
asp_getsess.c:138: storage size of `asv' isn't known
asp_getsess.c:138: storage size of `oasv' isn't known
asp_getsess.c:138: storage size of `csv' isn't known
asp_getsess.c:138: storage size of `ocsv' isn't known
asp_getsess.c:159: `SA_RESTART' undeclared (first use this function)
asp_getsess.c:159: (Each undeclared identifier is reported only once
asp_getsess.c:159: for each function it appears in.)
*** Error code 1
make: Fatal error: Command failed for target `asp_getsess.o'
Current working directory
/disk2/apps/netatalk_1_4b2/netatalk-981013/libatalk/asp
*** Error code 1
make: Fatal error: Command failed for target `asp'
Current working directory
/disk2/apps/netatalk_1_4b2/netatalk-981013/libatalk
*** Error code 1
make: Fatal error: Command failed for target `../../libatalk'
Current working directory
/disk2/apps/netatalk_1_4b2/netatalk-981013/sys/solaris
*** Error code 1
make: Fatal error: Command failed for target `all'

does anyone have any ideas on how to resolve this error?

Yasmine

---

From: Paul Krohn <[email-masked]>
Date: Thu, 22 Oct 98 09:20:41 -0700

>Making all for solaris...

A couple of important points here:

What version of Solaris?

What version of netatalk?

------------
Paul Krohn
San Francisco Examiner Systems Department
110 Fifth Street
San Francisco, CA  94103
415-777-7884
[email-masked] - www.examiner.com

---

From: Wenchi Liao <[email-masked]>
Date: Thu, 22 Oct 1998 11:59:12 -0500

>gcc -p -D__svr4__ -DSOLARIS -O -I../../include -c asp_getsess.c

Ignoring that the version of netatalk and OS is unknown, it probably
needs a line like "-I../../sys/<OS>".

>asp_getsess.c:159: `SA_RESTART' undeclared (first use this function)

In include/atalk/compat.h (for asun-2.1.0b13), there's a comment that
SA_RESTART is not defined for SunOS 4. So, should SOLARIS be defined?

WL

---

From: "Yasmine Arafa" <[email-masked]>
Date: Tue, 27 Oct 1998 15:26:36 -0000

If I try to run atalkd i first get the following msg:
"atalkd: can't get interfaces, exiting."

but if I run it a second time then is runs OK.

Should this happen? Should I recompile and reinstall?

Yasmine.
----------
> From: Yasmine Arafa <[email-masked]>
> To: Mitch McNeel <[email-masked]>
> Cc: netatalk-admins <[email-masked]>
> Subject: Re: [netatalk-admins] Installation problem: netatalk 1.4b2 on
solaris 2.5.1
> Date: 27 October 1998 15:22
> 
> Yes I do have /etc/rc2.d and /etc/rc0.d directories but not the file. I
> have tried cleaning and reinstalling but still can't find rc.atalkd. The
> instructions say they should be included in the /etc/rc file.
> Are the files in these directories sufficient or do I need rc.atalkd?
> 
> Thanx
> Yasmine.
> 
> ------
> > From: Mitch McNeel <[email-masked]>
> > To: Yasmine Arafa <[email-masked]>
> > Cc: netatalk-admins <[email-masked]>
> > Subject: Re: [netatalk-admins] Installation problem: netatalk 1.4b2 on
> solaris 2.5.1
> > Date: 27 October 1998 15:12
> > 
> > Well for one thing, the rc.atalk file should have been created on the
> > install...  look in your /etc/rc2.d and /etc/rc0.d directories, there
> should
> > be a soft link to the file atalk in /etc/init.d directory.
> > 
> > Hope this helps
> > Mitch
> >

---

From: "Yasmine Arafa" <[email-masked]>
Date: Tue, 27 Oct 1998 17:16:45 -0000

This is the msg I get after doing "make install"

"Install is done.  Don't forget to add lines from
services.atalk to /etc/services and to call rc.atalk
in /etc/rc.  See README and README.SOLARIS for more
information."

So what does it mean to " call rc.atalk in /etc/rc"?
I assumed this meant to run rc.atalk?!!
Is this not correct?

Thanx,
Yasmine

----------
> From: Yuji Shinozaki <[email-masked]>
> Cc: Mitch McNeel <[email-masked]>; netatalk-admins
<[email-masked]>
solaris 2.5.1
> Date: 27 October 1998 16:56
> 
> 
> The rc files are installed when you do a "make kinstall" (to install the
> kernel drivers et al). 
> 
> What it installs and where varies according to OS.  On Solaris is should
> install /etc/init.d/atalk and two symlinks at /etc/rc2.d/S79atalk and
> /etc/rc0.d/K79atalk.
> 
> Hope this helps.
> 
> yuji
> ----
> 
> 
> 
> On Tue, 27 Oct 1998, Yasmine Arafa wrote:
> 
> > > Yasmine Arafa wrote:
> > > > I  have almost been able to successfully complete compilation of
> > netatalk
> > > > 1.4b2 on solaris 2.5.1
> > > >
> > > > I am at the last step of the instructions, which is to add the
rc.atalk
> > > > file  to /etc/rc
> > > > I can't find this file anywhere? The instructions say it should be
> > > > installed in the in the ETCDIR (which in my case is
> > /usr/local/atalk/etc),
> > > > but I can't find it!
> > > > Does this mean that there could be a problem with the installation?
or
> > can
> > > > I just cp this file from somewhere? if I can cp it where can I get
this
> > > > file from?
> > > >
> > > > Thanx,
> > > > Yasmine.
> > 
> 
> Yuji Shinozaki		        Systems Administrator
> [email-masked]	        Dept of Physics and Astronomy
> http://www.physics.unc.edu      Univ. of North Carolina - CH
> (919)962-7214 (voice)           CB 3255 Philips Hall
> (919)962-0480 (fax)	        Chapel Hill, NC  27599

---

From: "Yasmine Arafa" <[email-masked]>
Date: Wed, 28 Oct 1998 11:11:56 -0000

Hi there,

How do I add the appletlk services to the NIS master machine's maps and
push them?

thanx,
Yasmine

----------
> To: Marc Matteo <[email-masked]>
> Cc: 'Yuji Shinozaki' <[email-masked]>; [email-masked]'
solaris 2.5.1 
> Date: 28 October 1998 10:55
> 
> Thanx very much to all how have replied. This has been a big help.
> 
> I am actually using the original 1.4b2 code. I did however download the
> 1.4b2+asun2.1.0 version but I got the following error:
> "tcpd.h file not found" so I switched back.
> Any suggestions on how to overcome this?
> I will try this version again and see from there.
> 
> Thanx,
> Yasmine
> 
> ----------
> > From: Marc Matteo <[email-masked]>
> > To: 'Yasmine Arafa' <[email-masked]>
> > Cc: 'Yuji Shinozaki' <[email-masked]>;
[email-masked]'
> > Subject: RE: [netatalk-admins] Installation problem: netatalk 1.4b2 on
> solaris 2.5.1 
> > Date: 27 October 1998 18:35
> > 
> > First off get the asun version from
> > "ftp://ftp.u.washington.edu/public/asun/" (1.4b2+asun2.1.0 is the
latest
> as
> > of this writing)
> > 
> > The original 1.4b2 code has lots of problems especially for Solaris. 
The
> > 'make install' part does what it's supposed to and the docs are much
> > clearer.
> > 
> > Marc
> > 
> > > ----------
> > > From: 	Yasmine Arafa
> > > Sent: 	Tuesday, October 27, 1998 5:34 AM
> > > To: 	[email-masked]
> > > Subject: 	Re: [netatalk-admins] Installation problem: netatalk 1.4b2
> > > on solaris 2.5.1 
> > > 
rc.atalk
or
this