Subject: RE: [netatalk-admins] problems installing on Solaris 2.6

From: Marc Matteo <[email-masked]>
Date: Fri, 23 Oct 1998 08:38:59 -0700

What the heck is this:

>drvconfig: '/etc/path_to_inst' - No such file or directory

Did you specify a path of "/etc/path_to_inst" somewhere?

> ----------
> From: 	Maurizio Davini
> Sent: 	Friday, October 23, 1998 12:54 AM
> To: 	[email-masked]
> Subject: 	[netatalk-admins] problems installing on Solaris 2.6
> 
> I have the following problem....
> 
> 
> Making kinstall for solaris...
> make[1]: Entering directory
> `/export/home/mau/solaris-freeware/netatalk-1.4b2+as
> un2.1.0/sys/solaris'
> rem_drv ddp
> sync;sync;sync
> /usr/ucb/install -c ddp /usr/kernel/drv/ddp
> ln /usr/kernel/drv/ddp /usr/kernel/strmod/ddp
> /usr/ucb/install -c ddp.conf /usr/kernel/drv/ddp.conf
> add_drv -m '* 0666 root sys' ddp
> drvconfig: '/etc/path_to_inst' - No such file or directory
> drvconfig: Warning: '/etc/path_to_inst' was updated.
> drvconfig: Warning: failed to update '/etc/path_to_inst'
> Warning: Driver (ddp) successfully added to system but failed to attach
> 
> make[1]:
> *** [kinstall] Error 1
> make[1]: Leaving directory
> `/export/home/mau/solaris-freeware/netatalk-1.4b2+asu
> n2.1.0/sys/solaris'
> make: *** [kinstall] Error 2
>                                                             Can someone
> help
> ?
>                                                                 Maurizio
>

---

From: Edan Idzerda <[email-masked]>
Date: Fri, 23 Oct 1998 12:11:55 -0400 (EDT)

> Did you specify a path of "/etc/path_to_inst" somewhere?

More importantly, does /etc/path_to_inst really not exist?  That smells
like trouble to me, pilgrim.

- edan 

--
Netatalk on Solaris 2 FAQ is at http://www.mtusysadm.mtu.edu/mtudocs/netatalk

---

From: [email-masked]
Date: Fri, 23 Oct 1998 12:46:29 -0400

> From:    Edan Idzerda <[email-masked]>
> To:      Marc Matteo <[email-masked]>

> like trouble to me, pilgrim.

Talk about trouble....  From the path_to_inst man page:

    WARNINGS
	 If the file is removed the system may not be bootable (as it
	 may rely on information found in this file to find the root,
	 usr or swap device). If it does successfully boot,  it  will
	 regenerate  the file, but after rebooting devices may end up
	 having different minor numbers than  they  did  before,  and
	 special  files  created via mknod(1M) may refer to different
	 devices than expected.

	 For the same reasons, changes should not  be  made  to  this
	 file without careful consideration.

:wes

---

From: Tim Carlson <[email-masked]>
Date: Fri, 23 Oct 1998 11:00:10 -0600 (MDT)

> Talk about trouble....  From the path_to_inst man page:

or from the file itself...

#
#       Caution! This file contains critical kernel state
#

If you are lucky, there is sometimes a /etc/path_to_inst.old