Subject: [netatalk-admins] "Making netatalk on a Solaris 2.6 box"

From: "Robert J. Marinchick" <[email-masked]>
Date: Wed, 7 Jan 1998 10:57:00 -0500 (EST)

Hi,
First, I want to thank Mark Juric for his suggestion to recompile
"gcc". I got past the DATAMODEL problem.

However, I encountered another with conflicting types for
"msgdsize" and "allocb" while compliing "ddptp_utls.c".
It looks as if they differ wrt those in
/usr/include/sys/stream.h.
I'm not heavy into "C" programming, so I'm a little confused.

How can I resolve this, and will I experience more of this
type error as I continue?

Any help is greatly appreciated.

Thanks,
Bob Marinchick
[email-masked]

---

From: Mark Juric <[email-masked]>
Date: Wed, 7 Jan 1998 12:13:11 -0600 (CST)

Robert,
  Just comment out those two definitions.  They are already defined in stream.h
and don't need to be redefined here.  As for other problems... I've run into
one I can't seem to solve yet - "__inline__" doesn't seem to be defined and the
only way I can get compilation is to force including /usr/include, but then
this breaks some stuff in nbp_parse.

-Mark

--                                 
Mark Juric  [email-masked]      `||||'      (630) 620-5000 x1653
Team Leader, Production Systems       ||       PLATINUM Technology