Subject: Re: [netatalk-admins] Netatalk and volume size calculations...

From: Webmaster <[email-masked]>
Date: Tue, 10 Mar 1998 07:38:28 -0500

Before I decide to roll my sleeves up, has anyone patched the FreeBSD patched
version
of 1.4b2 with the asun patch successfully??

[email-masked] wrote:

> Aha, sorry, my goof.  You are using 1.4b2, I'm using 1.4b2+asun2.0a18.2 (on a
> Linux system, but I don't think that's an issue here).  I had forgotten that
> large volume support was one of the things asun added during all his marvelous
> work on TCP/IP support.  I saw the 1.9GB "truncate" problem on 7.5.5 clients
> when I first set up my server, but in my case since I have netatalk patched for
> large volumes, upgrading the AppleShare client fixed the problem.  You are quite
> correct concluding that the base 1.4b2 afpd can't handle volumes >2GB regardless
> of AppleShare client or MacOS version.
>
> You could try to move to the asun version, or try applying his patches to what
> you have, look at <ftp://ftp.u.washington.edu/public/asun> for details.  I also
> recall there is a large-volume patch for base 1.4b2 on the netatalk home page,
> that might be a better choice if you don't need all the other stuff in the asun
> version.  But I don't know how any of this might interact with the BSD 2.2.5
> patches, so proceed with care!
>
> Hope this is helpful.
>
> Bob Smith
> Hammett & Edison, Inc.
> [email-masked]
>
> ______________________________________________
> Original message sent on Mon, Mar 9  5:44 PM by [email-masked] (Webmaster) :
>
> To: bsmith
> Re: [netatalk-admins] Netatalk and volume size calculations...
> Why do I only see 1.9 gigs of a 5.3 gig Netatalk volume mounted on a Mac running
> System 8???
> There's about 500 megs used on the volume.
> I'm running Netatalk 1.4b2 patched for FreeBSD 2.2.5 if it helps. Also, from the
> Mac, in the window
> for the mounted volume the 'bytes in disk' label is always zero k. It never
> grows
> no matter how many
> files of varying sizes you copy into it.
>
> I'll try updating one of my 7.5.3 Mac clients to see if there's any difference.
>
> Thanks
>
> [email-masked] wrote:
>
> > Systems after 7.5.3 can handle volumes up to 4GB, but AppleShare volumes
> bigger
> > than 2GB require a newer version of the AppleShare client to work properly,
> the
> > AppleShare client 3.6.x that came with Systems 7.5.3 and 7.5.5 won't cut it.
> > There is an upgrade to AppleShare client 3.7.2 somewhere on the Apple web
> pages
> > (sorry, don't remember the exact URL) and using this allows 4GB volumes on
> > Systems 7.5.3 and later.  Volumes >4GB still require System 7.6 or later.  The
> > AppleShare 3.7.2 client also does ASIP, so if you're using the asun patched
> > netatalk you get the advantage of TCP/IP connections (they seem faster than
> DDP
> > connections, but I might just be imagining this).
> >
> > Bob Smith
> > Hammett & Edison, Inc.
> > [email-masked]
> >

---

From: Bill Studenmund <[email-masked]>
Date: Tue, 10 Mar 1998 17:04:50 -0800 (PST)

> of 1.4b2 with the asun patch successfully??

What patches are in the "FreeBSD patched version"? 1.4b2 supported FreeBSD
out of the box.

If you're refering to the patches in the FreeBSD netatalk port, I think
it'd be easier to apply those patches to Adrian's source. And it looks
like most of these patches are only needed if you're running
freebsd-current. At least as far as I could tell from the patches I just
downloaded. :-)

Take care,

Bill

---

From: Webmaster <[email-masked]>
Date: Tue, 10 Mar 1998 21:50:18 -0500

Today I started from scratch with Netatalk and decided to apply the asun patch that

does AFP using TCP. Since support for larger volume sizes was added in this patch
I figured it would be worth a try. I applied the patch, made a few simple
adjustments
in the Makefile and recompiled the Netatalk source without any problems. I had to
edit my netatalk.sh file to include the paths to the new binaries which this
version puts
in a separate dir (/usr/local/atalk/bin). This was a good thing because I wanted to
maintain
the previous Netatalk tree in case this incarnation didn't work.

Anyway, what followed after a full reboot was rather interesting. From a Mac
running system 8
I was able to enter the IP of my Netatalk server and mount it's volume over IP very
easily.
I was *also* able to mount another Netatalk volume using AppleShare from the same
Mac! Cool.
Both mounted volumes didn't show the total volume size available. However, after
copying large files to both I discovered what this notion of quotas is all about;
something I gleaned from looking at some of
the Netatalk source and something that isn't at all documented.

Before copying these files I had 1.2gigs of space out of 5.3gigs available on the
Netatalk volume. As the writing of the
data to this volume progressed I noticed that the available size increased
automatically whenever the
first *quota* was about to be used up. When I saw this I went back to study the
source to see if this is
supposed to happen. Sure enough, it turns our that Netatalk has a notion of a
'soft' quota. It will expand
the volume as needed until it hits the hard limit of the physical volume. I may not
be entirely right about
this but it sure seems this way...

It would be nice to be able to define a min and max for the quota. Oh well, it
works, that's the
main thing.