Subject: [netatalk-admins] Problem compiling 1.4b2+asun2.1 on Solaris 2.6

From: Kao Wang <[email-masked]>
Date: Wed, 28 Oct 1998 06:46:17 -0600

Hi guys,

I have been trying to compile Netatalk 1.4b2+asun2.0a18.2 and 1.4b2+2.1.0
with no success.

Both compilation failed at the similar location.  By the way, I am using
gcc for the compilation.

The error looks like this:

In file included from ../../include/atalk/afp.h:28,
                 from switch.c:26:
../../include/netatalk/endian.h:51: warning: redefinition of `int32_t'
/usr/include/sys/int_types.h:69: warning: `int32_t' previously declared here
gcc -D__svr4__ -DSOLARIS -I../../sys/solaris   -DUAM_RNDNUM -O
-I../../include   -I/usr/local/include    -DUSE_PAM -DAPPLCNAME -DCRLF  -c
auth.c
auth.c:145: des.h: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `auth.o'
Current working directory /space/local/netatalk/net+asun21/etc/afpd
*** Error code 1
make: Fatal error: Command failed for target `all'
Current working directory /space/local/netatalk/net+asun21/etc/afpd
*** Error code 1
make: Fatal error: Command failed for target `afpd'
Current working directory /space/local/netatalk/net+asun21/etc
*** Error code 1
make: Fatal error: Command failed for target `../../etc'
Current working directory /space/local/netatalk/net+asun21/sys/solaris
*** Error code 1
make: Fatal error: Command failed for target `all'

Anyone has any idea on what might be wrong?

Thanks for your help.

Kao

---

From: Marc Matteo <[email-masked]>
Date: Wed, 28 Oct 1998 09:24:24 -0800

> Anyone has any idea on what might be wrong?

Check the top level makefile and set your options accordingly...
 
Marc
-- 
Marc Matteo
Web Engineer, The Sacramento Bee
http://www.sacbee.com
"We're a newspaper, we don't actually own any bees."