Subject: [netatalk-admins] Netatalk under Solaris 2.6

From: Reiner Keller <[email-masked]>
Date: Tue, 29 Sep 1998 01:09:18 +0200 (MET DST)

Hello,

I searched your FAQ and Mailinglist, but didn't find the solution to my
problem. I could compile netatalk-971027, netatalk-980819 and
netatalk-1.4b2+asun2.0a18.2 and could install them correctly.

If I want to start the daemon, it says:

#/etc/rc0.d/K79atalk start
starting appletalk daemons: le0: Invalid argument
 atalkdbind: Cannot assign requested address
bind: Cannot assign requested address
 nbprgstr papd afpd.

machine: SunOS weyl 5.6 Generic_105181-04 sun4u sparc SUNW,Ultra-1
Thanx.

Reiner
-- 
----------------------------------------------------------- _________   __
Reiner Keller                  e-mail:                     /______  /  / /
Tutor fuer Rechnerbetreuung    [email-masked]      / / / /__/ /
----------------------------------------------------------- /_/ /______/

---

From: Marc Matteo <[email-masked]>
Date: Mon, 28 Sep 1998 17:59:15 -0700

Shot in the dark:  Did you manually create a atalkd.conf file?  Solaris
can't create on automatically.

Marc

> ----------
> From: 	Reiner Keller
> Sent: 	Monday, September 28, 1998 4:09 PM
> To: 	[email-masked]
> Subject: 	[netatalk-admins] Netatalk under Solaris 2.6
> 
> Hello,
>

---

From: Paul Krohn <[email-masked]>
Date: Mon, 28 Sep 98 21:22:52 -0700

I get a similar problem, i gleaned the following from /var/adm/messages:

Sep 28 17:34:13 <server name> afpd[21392]: main: atp_open: Protocol not 
supported
Sep 28 17:34:13 <server name> afpd[21392]: main: atp_open: Protocol not 
supported

in addition to:

# ./S79atalk start
starting appletalk daemons: hme0: Protocol not supported
Can't configure multicast.
can't establish STREAMS plumbing, exiting.
 atalkd nbprgstr papd afpd.

>bind: Cannot assign requested address

odd that you would start it from the 'kill' location ...

Paul Krohn
San Francisco Examiner - Systems Department
110 Fifth Street
San Francisco, CA 94103
415-777-7884 [email-masked]