Subject: Re: [netatalk-admins] Installation problem: netatalk 1.4b2 on solaris 2.5.1

From: "Yasmine Arafa" <[email-masked]>
Date: Wed, 28 Oct 1998 10:55:43 -0000

Thanx very much to all how have replied. This has been a big help.

I am actually using the original 1.4b2 code. I did however download the
1.4b2+asun2.1.0 version but I got the following error:
"tcpd.h file not found" so I switched back.
Any suggestions on how to overcome this?
I will try this version again and see from there.

Thanx,
Yasmine

----------
> From: Marc Matteo <[email-masked]>
> To: 'Yasmine Arafa' <[email-masked]>
> Cc: 'Yuji Shinozaki' <[email-masked]>; [email-masked]'
> Subject: RE: [netatalk-admins] Installation problem: netatalk 1.4b2 on
solaris 2.5.1 
> Date: 27 October 1998 18:35
> 
> First off get the asun version from
> "ftp://ftp.u.washington.edu/public/asun/" (1.4b2+asun2.1.0 is the latest
as
> of this writing)
> 
> The original 1.4b2 code has lots of problems especially for Solaris.  The
> 'make install' part does what it's supposed to and the docs are much
> clearer.
> 
> Marc
> 
> > ----------
> > From: 	Yasmine Arafa
> > Sent: 	Tuesday, October 27, 1998 5:34 AM
> > To: 	[email-masked]
> > Subject: 	Re: [netatalk-admins] Installation problem: netatalk 1.4b2
> > on solaris 2.5.1 
> > 
> > I  have almost been able to successfully complete compilation of
netatalk
> > 1.4b2 on solaris 2.5.1 
> > 
> > I am at the last step of the instructions, which is to add the rc.atalk
> > file  to /etc/rc
> > I can't find this file anywhere? The instructions say it should be
> > installed in the in the ETCDIR (which in my case is
/usr/local/atalk/etc),
> > but I can't find it!
> > Does this mean that there could be a problem with the installation? or
can
> > I just cp this file from somewhere? if I can cp it where can I get this
> > file from?
> > 
> > 
> > Thanx,
> > Yasmine.
> >

---

From: PayPC System Mail Subscriber <[email-masked]>
Date: Wed, 28 Oct 1998 21:26:24 +1000

Yasmine Arafa said in Re: [netatalk-admins] Installation problem: netatalk 
1.4b2 on solaris 2.5.1  at 28/Oct/1998 (Wed) 20:55:43.
> I will try this version again and see from there.

-and-

Jann Wegner said in [netatalk-admins] Problems compiling asun2.1.0 at 
28/Oct/1998 (Wed) 17:23:47.

> I can't succeed in installing the latest asun2.1.0 version.
> (Kernel is 2.0.35-suse)

Sounds like you folks either don't have TCP Wrappers (headers as well as tcpd 
libs) or you've not setup the path to them properly in the root makefile.

If you don't have TCP Wrappers, you should be able to disable it by #'ing out 
the path (read the Makefile for clarification).  I would recommend getting 
and using TCP Wrappers if you don't have them, though... Appleshare IP means 
your file server can be hit/mounted through your modem/isdn/router -- the 
"protection" you used to have by most routers not routing Appletalk is gone 
with as-ip (same goes for samba).

TCP wrappers are available on almost any unix software site in the world. 
It's very mature software.
=Robert=

---

From: Dejan Ilic <[email-masked]>
Date: Wed, 28 Oct 1998 14:33:13 +0100 (MET)

> I will try this version again and see from there.

"tcpd.h" is part of the TCP_Wrappers package (much recommended as it
has stopped a lot of potential attackers on my site) that can help you
limit access to your server, especialy the TCP-access that can go
across routers, all over internet. Appletalk is usualy limited within
the vissible appletalk-zones (like you office, university whatever the
size of the site is).

Edit the makefile and comment out the line that tells where
tcpwrappers should be and you will be able to compile the asun
package without problems. Remember that on Solaris you have to do
"make kinstall" also.

Dejan
=====================================================================
Dejan Ilic, Tech Univ. of Linkoping, Sweden    Phone:+46-13-473 01 06
Email: [email-masked]   Web: http://www.lysator.liu.se/~svedja
=====================================================================
[finger -l [email-masked] for public PGP key]