Subject: [netatalk-admins] Problems compiling asun2.1.0

From: [email-masked] (Jann Wegner)
Date: Wed, 28 Oct 1998 08:23:47 +0100

Hi there,

I can't succeed in installing the latest asun2.1.0 version.
(Kernel is 2.0.35-suse)

"make" always results in the following:

make[4]: Entering directory `/usr/local/netatalk-1.4b2+asun2.1.0/etc/afpd'
gcc  -DNEED_QUOTACTL_WRAPPER    -O2 -fomit-frame-pointer -fsigned-char -Wunused
-Wuninitialized -I../../include      -DAPPLCNAME -DCRLF   -o afpd unix.o
afs.o k
uam.o send_to_kdc.o lifetime.o ofork.o main.o switch.o auth.o volume.o
directory
.o file.o enumerate.o desktop.o filedir.o fork.o appl.o gettok.o bprint.o
status
.o afp_options.o afp_asp.o afp_dsi.o messages.o config.o nfsquota.o
-L../../liba
talk      -latalk
../../libatalk/libatalk.a(dsi_tcp.o): In function `dsi_tcp_open':
dsi_tcp.o(.text+0x36d): undefined reference to `request_init'
dsi_tcp.o(.text+0x376): undefined reference to `sock_host'
dsi_tcp.o(.text+0x37c): undefined reference to `hosts_access'
dsi_tcp.o(.text+0x389): undefined reference to `eval_client'
make[4]: *** [afpd] Error 1
make[4]: Leaving directory `/usr/local/netatalk-1.4b2+asun2.1.0/etc/afpd'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/usr/local/netatalk-1.4b2+asun2.1.0/etc/afpd'
make[2]: *** [afpd] Error 2
make[2]: Leaving directory `/usr/local/netatalk-1.4b2+asun2.1.0/etc'
make[1]: *** [../../etc] Error 2
make[1]: Leaving directory `/usr/local/netatalk-1.4b2+asun2.1.0/sys/linux'
make: *** [all] Error 2

I already had to remove "-lrpcsvc" in sys/linux/Makefile.

Any hints?

********************************
*
* Jann Wegner
* INSTITUT FUER DEMOSKOPIE ALLENSBACH
* EDV-Abteilung
* Radolfzeller Strasse 8
* D-78476 Allensbach
* Germany
*
* Phone: +49 7533 805-233
* Fax: +49 7533 3048
* eMail: [email-masked]
*
********************************

---

From: Jens Brambring <[email-masked]>
Date: Wed, 28 Oct 1998 16:21:36 +0200

Hello Jann,
change to etc/afpd
vi Makefile
delete nfsquota.o

vi unix.c
delete line 326
(return vol->v_nfs ? getnfsquota(vol, uuid, bsize, dq):)

There after everything should be ok.
Next weekend you will find this version at
http://www.brambring.de/linux

Sorry, this page is german only at the moment

Ciao, Jens Brambring