Subject: Re: netatalk performance

From: Andrew Norman <[email-masked]>
Date: Thu, 01 Feb 1996 01:03:54 GMT

On Wed, 31 Jan 1996 16:31:44 -0600 (CST), Bradley Carlson
<[email-masked]> wrote:

>Tests today done on almost-idle network, PM6100/60 as client.
>
>Copying a large Netscape Cache folder (average file size 7.1 Kbytes):
>  to Netatalk server:   4.6 Kbytes/second
>  to Mac            :   5.8 Kbytes/second
>
>Copying a single large tar file (18,680 Kbytes):
>  to Netatalk server: 242.6 Kbytes/second
>  to Mac            : 233.5 Kbytes/second
>

It appears that netatalk's weakness (or is it AppleTalk's weakness) is
in opening and closing files then.

It would be interesting to see some figues comparing copying
Mac->Netatalk and Mac->Mac...
-- 
Andy Norman  Home: [email-masked]
             Home: +44 (1)181 521 1468
             Work: +44 (1)171 316 0001
Datamonitor Group IT Co-ordinator

Any views expressed above are entirely personal and do not
represent those of Datamonitor Publications Ltd.

---

From: "Gerry.Tomlinson" <[email-masked]>
Date: Thu, 1 Feb 1996 10:37:47 +0000 (GMT)

what is the best way to measure netatalk performance?
 
i've  used LanTest at various times - which is free and very useful but
runs on the mac whereas it would be nice to be able to get the sort of
figures that nfstat and nfswatch provide on the server.

gerry,

---
[email-masked]
Computing Officer
Department of Computing Science, University of Newcastle, Tel: +44 191 222 8139
Newcastle upon Tyne, NE1 7RU, United Kingdom.             Fax: +44 191 222 8232

---

From: Joe Smith <[email-masked]>
Date: Thu, 1 Feb 1996 10:59:34 -0500

From: Andrew Norman <[email-masked]>
   Date: Thu, 01 Feb 1996 01:03:54 GMT
   ...
   It appears that netatalk's weakness (or is it AppleTalk's weakness) is
   in opening and closing files then.
   ...

Well, right off the bat there's a big hit because you've got two Unix
files to open for every Mac file.

There is a native hfs for Linux.  Last I heard it was able to mount
Apple harddisks read-only.  Seems like hfs r/w capability and netatalk
would be 'perfect together', although I don't know how the
resource/data forks look to Unix processes.

<Joe
-- 
 Joe Smith
 University of Pennsylvania                   [email-masked]
 Department of Physiology
 Philadelphia, PA 19104