Subject: Re: Problems w/ 1.3.3b2 & Linux 1.2.11

From: [email-masked] (Joe Block)
Date: Wed, 19 Jul 1995 23:06:02 -0400

>I've installed netatalk 1.3.3b2 on my Linux 1.2.11 system, and keep getting
>the following messages when I try to start it up:

I just (a week or so ago, anyway) installed 1.3.3b2 with 1.2.8 without any
problems.  Did you remember to compile your kernel with atalk and IPX
defined?

My server runs just fine, but I have one minor problem - when I run
PowerTalk (7.5.1), it won't add the netatalk drives to the keychain.  I can
access them normally, the system just won't remember the passwords for me.

Joe Block <[email-masked]>

No man's life, liberty or property are safe while the legislature is in session.

---

From: Ken Gieselman <[email-masked]>
Date: Thu, 20 Jul 1995 11:28:02 -0700

>No man's life, liberty or property are safe while the legislature is in sessio

Yeah - thanks for all the help - I managed to get it working by running
it only on startup.  I guess all the problems I was having were from
trying to start services *after* the boot process.

Thanks again,
Ken Gieselman
UCI GSM Technical Services
============================================================================
		"You countermanded me on *whose* authority?"
				- Pope John
Ken Gieselman                                      [email-masked]
============================================================================

---

From: [email-masked] (Toens Bueker)
Date: Fri, 21 Jul 1995 19:41:55 +0200 (MET DST)

> trying to start services *after* the boot process.
Nice to see your problem solved. But I have another one :-)

A certain period of time after boot-time everything looks
quite pretty and the Linux-Server appears in the chooser
menu of the different Macs in our network.

I don't know exactly when, but after some time the Linux-Server
isn't available any longer in the chooser menus. On the
Server there is no difference. 'nbplkup' and all the other
utils seem to work quite perfect.

Maybe somebody could explain these lines out of
/usr/adm/messages (if they have anything to do with this
phenomenon). And maybe somebody already has a solution for
this.

Jul 21 10:16:51 bidnix atalkd[58]: zip_getnetinfo for eth0
Jul 21 10:17:11 bidnix atalkd[58]: zip_packet configured eth0 from 200.207
Jul 21 10:17:16 bidnix atalkd[58]: rtmp_packet gateway 200.108 up
Jul 21 10:17:18 bidnix atalkd[58]: rtmp_packet gateway 200.207 up
Jul 21 10:17:20 bidnix atalkd[58]: zip skip reply 200-200 from 200.108 (no query)
Jul 21 10:17:40 bidnix atalkd[58]: ready 0/0/0
Jul 21 12:27:20 bidnix atalkd[58]: as_timer gateway 200.207 down
Jul 21 12:27:30 bidnix atalkd[58]: as_timer gateway 200.108 down
Jul 21 12:27:50 bidnix atalkd[58]: as_timer gateway 200.207 down
Jul 21 12:28:00 bidnix atalkd[58]: as_timer gateway 200.108 down
Jul 21 12:28:00 bidnix atalkd[58]: as_timer last gateway down

Thx and by

T"ons

---

From: [email-masked]
Date: Fri, 04 Aug 1995 10:27:50 -0400

> From:    [email-masked] (Toens Bueker)
> To:      [email-masked] (Ken Gieselman)

> Jul 21 12:28:00 bidnix atalkd[58]: as_timer last gateway down

A fairly easy fix.  The distributed version of sys/linux/ddp.c
doesn't pay attention to what's passed to it from atalkd.  The
attached patch fixes this problem.

:wes
*** sys/linux/ddp.c-	1995/06/30 18:00:45
--- sys/linux/ddp.c	1995/07/18 19:53:52
***************
*** 313,318 ****
--- 313,319 ----
  	int ct;
  	int netrange=ntohs(atif->nets.nr_lastnet)-ntohs(atif->nets.nr_firstnet)+1;
  	int probe_net=ntohs(atif->address.s_net);
+ 	int probe_node=atif->address.s_node;
  	int netct;
  	int nodect;
  	
***************
*** 328,335 ****
  		else
  			probe_net=ntohs(atif->nets.nr_firstnet) + (jiffies%netrange);
  	}
! 	
! 	
  	/*
  	 *	Scan the networks.
  	 */
--- 329,339 ----
  		else
  			probe_net=ntohs(atif->nets.nr_firstnet) + (jiffies%netrange);
  	}
! 
! 	if ( probe_node == ATADDR_ANYNODE ) {
! 	    probe_node = jiffies&255;
! 	}
! 
  	/*
  	 *	Scan the networks.
  	 */
***************
*** 337,350 ****
  	for(netct=0;netct<=netrange;netct++)
  	{
  		/*
! 		 *	Sweep the available nodes from a random start.
  		 */
- 		int nodeoff=jiffies&255;
- 		
  		atif->address.s_net=htons(probe_net);
  		for(nodect=0;nodect<256;nodect++)
  		{
! 			atif->address.s_node=((nodect+nodeoff)&0xFF);
  			if(atif->address.s_node>0&&atif->address.s_node<254)
  			{
  				/*
--- 341,352 ----
  	for(netct=0;netct<=netrange;netct++)
  	{
  		/*
! 		 *	Sweep the available nodes from a given start.
  		 */
  		atif->address.s_net=htons(probe_net);
  		for(nodect=0;nodect<256;nodect++)
  		{
! 			atif->address.s_node=((nodect+probe_node)&0xFF);
  			if(atif->address.s_node>0&&atif->address.s_node<254)
  			{
  				/*