Subject: Disappearing from chooser ...

From: [email-masked] (T\vns B\|ker)
Date: Fri, 6 Oct 1995 16:40:40 +0100 (MET)

Hi *,

yesterday evening I startet another attempt to compile a 
netatalk-binary which does not disappear from the chooser
of the client-macs.
Therefore I fetched another patch from the
'linux+netatalk-Hompage' and compiled with it.

That's the result:

Oct  5 00:43:53 bidnix atalkd[84]: restart
Oct  5 00:43:55 bidnix atalkd[84]: zip_getnetinfo for eth0
Oct  5 00:43:56 bidnix atalkd[84]: zip_packet configured eth0 from 200.9
Oct  5 00:43:58 bidnix atalkd[84]: rtmp_packet gateway 200.108 up
Oct  5 00:44:01 bidnix atalkd[84]: rtmp_packet gateway 200.207 up
Oct  5 00:44:03 bidnix atalkd[84]: zip skip reply 200-200 from 200.108 (no query)
Oct  5 00:44:03 bidnix atalkd[84]: rtmp_packet gateway 200.9 up
Oct  5 00:44:23 bidnix atalkd[84]: ready 0/0/0
Oct  5 00:48:33 bidnix atalkd[84]: as_timer gateway 200.9 down
Oct  5 00:48:33 bidnix atalkd[84]: as_timer gateway 200.207 down
Oct  5 00:48:33 bidnix atalkd[84]: as_timer gateway 200.108 down
Oct  5 00:49:03 bidnix atalkd[84]: as_timer gateway 200.9 down
Oct  5 00:49:03 bidnix atalkd[84]: as_timer gateway 200.207 down
Oct  5 00:49:03 bidnix atalkd[84]: as_timer gateway 200.108 down
Oct  5 00:49:03 bidnix atalkd[84]: as_timer last gateway down

And it still disappears from the chooser.

Netatalk 1.3.3b2 and Linux 1.2.10

Is there a fix? Please ...

By
T"ons

---

From: [email-masked]
Date: Tue, 10 Oct 1995 14:41:56 -0400

> From:    [email-masked] (T\vns B\|ker)
> To:      [email-masked]

> Netatalk 1.3.3b2 and Linux 1.2.10

I'm not aware of a linux+netatalk-Homepage.  If you tell me where it's
at, I'll add a link in the netatalk homepage.  However, I've attached
the fix I have for this problem.

:wes
*** sys/linux/ddp.c-	1995/06/30 18:00:45
--- sys/linux/ddp.c	1995/07/18 19:53:52
***************
*** 313,318 ****
--- 313,319 ----
  	int ct;
  	int netrange=ntohs(atif->nets.nr_lastnet)-ntohs(atif->nets.nr_firstnet)+1;
  	int probe_net=ntohs(atif->address.s_net);
+ 	int probe_node=atif->address.s_node;
  	int netct;
  	int nodect;
  	
***************
*** 328,335 ****
  		else
  			probe_net=ntohs(atif->nets.nr_firstnet) + (jiffies%netrange);
  	}
! 	
! 	
  	/*
  	 *	Scan the networks.
  	 */
--- 329,339 ----
  		else
  			probe_net=ntohs(atif->nets.nr_firstnet) + (jiffies%netrange);
  	}
! 
! 	if ( probe_node == ATADDR_ANYNODE ) {
! 	    probe_node = jiffies&255;
! 	}
! 
  	/*
  	 *	Scan the networks.
  	 */
***************
*** 337,350 ****
  	for(netct=0;netct<=netrange;netct++)
  	{
  		/*
! 		 *	Sweep the available nodes from a random start.
  		 */
- 		int nodeoff=jiffies&255;
- 		
  		atif->address.s_net=htons(probe_net);
  		for(nodect=0;nodect<256;nodect++)
  		{
! 			atif->address.s_node=((nodect+nodeoff)&0xFF);
  			if(atif->address.s_node>0&&atif->address.s_node<254)
  			{
  				/*
--- 341,352 ----
  	for(netct=0;netct<=netrange;netct++)
  	{
  		/*
! 		 *	Sweep the available nodes from a given start.
  		 */
  		atif->address.s_net=htons(probe_net);
  		for(nodect=0;nodect<256;nodect++)
  		{
! 			atif->address.s_node=((nodect+probe_node)&0xFF);
  			if(atif->address.s_node>0&&atif->address.s_node<254)
  			{
  				/*

---

From: "Jin S. Choi" <[email-masked]>
Date: Tue, 10 Oct 1995 15:39:25 -0400

How often do these updates get merged in with the main linux
development sources? The ddp.c in the 1.3.32 kernel has many changes
from the ddp.c in the 1.3.3b2 source.

---

From: [email-masked]
Date: Tue, 10 Oct 1995 15:57:34 -0400

> From:    "Jin S. Choi" <[email-masked]>
> To:      [email-masked]

> from the ddp.c in the 1.3.3b2 source.

Well, the next release of netatalk, presumably netatalk 1.3.3 final,
won't have any linux kernel code in it.  This is because as of linux
1.3.something it's all distributed with linux.  So, rather than have
constant version skew between netatalk's linux code and linux's
AppleTalk code, there will only be the code in linux.

BTW, as far as I know, all of the bug fixes, etc, that I've made to
linux's AppleTalk code are integrated in whatever's currently being
distributed.

:wes