Subject: adding magic support to afpd

From: [email-masked] (Dwight Kelly)
Date: Wed, 26 Jan 94 09:06:02 EST

I am interested in adding /etc/magic support to afpd.
Basically afpd would consult an extended /etc/magic file
to determine the file type and creator of an unknown file.
If afpd could determine the file type, say TIFF, then
it could create a .AppleDouble entry telling the Mac what
the file type is really.

Has anyone done this yet?

-- 
Dwight Kelly
Essential Technical Services, Inc.
3375 Summit Trail Cumming, GA 30131
(404) 889-2848  (404) 889-2624 fax
Internet: [email-masked]

---

From: [email-masked]
Date: Thu, 27 Jan 1994 14:36:51 -0500

> From:    [email-masked] (Dwight Kelly)
> To:      [email-masked]

> it could create a .AppleDouble entry telling the Mac what

We've discussed adding a mapping between file name extensions and
type/creators.  We haven't really considered added true /etc/magic
support, since that would require that we read the first few bytes of
each file.  We're already reading the first 500 or so bytes of the
.AppleDouble file, and it is the cause of most of the enumerate
overhead.  Adding a feature that requires reading even more files for
simple operations seems like the wrong direction, to me.

:wes

---

From: [email-masked]
Date: Thu, 27 Jan 1994 14:36:51 -0500

:wes

---

From: [email-masked]
Date: Thu, 27 Jan 1994 14:36:51 -0500

:wes

---

From: [email-masked]
Date: Thu, 27 Jan 1994 14:36:51 -0500

:wes