Subject: papd bug

From: Dung Nguyen <[email-masked]>
Date: Tue, 20 Dec 1994 15:08:05 +0100

I found a bug in papd that shows up with the LaserWriter 8 driver:
papd creates empty print jobs because it fails to detect STARTJOB doc.

*** processjob.c.orig   Wed Sep  8 16:34:52 1993
--- processjob.c        Tue Dec 20 14:57:29 1994
***************
*** 303,309 ****
                                && !isspace( *keyword )) {
                            ++keyword;  /* skip rest of first word */
                        }
!                       while ( isspace ( *keyword )) {
                            ++keyword;  /* skip white space */
                        }
                        if ( *keyword == EOL || *keyword == NEWLINE ) {
--- 303,310 ----
                                && !isspace( *keyword )) {
                            ++keyword;  /* skip rest of first word */
                        }
!                       while ( *keyword != EOL && *keyword != NEWLINE
!                               && isspace ( *keyword )) {
                            ++keyword;  /* skip white space */
                        }
                        if ( *keyword == EOL || *keyword == NEWLINE ) {

---

From: Mark Smith <[email-masked]>
Date: Tue, 20 Dec 1994 09:57:44 -0500

>From:     Dung Nguyen <[email-masked]>
>  To:     [email-masked]
>
> ... [ patch to etc/papd/papd/processjob.c deleted ]

Indeed, this looks like a bug.  There is a new implementation of papd in
the works here, with much improved parsing code.  It should not have this
problem.  Thanks for reporting the bug.  Can you tell me how to duplicate
this (that is, what does one need to do on the Mac to generate an empty
print job)?

-Mark