Subject: panic: getblk: size too big

From: [email-masked] (Jacques Beigbeder)
Date: Wed, 6 Apr 1994 23:09:48 +0200 (MET DST)

Hello,

I send this mail to 2 lists, you'll see why.

Hardware: SUN 4/370 (arch = sun4)
Software: SunOS 4.1.3		(so sun-managers appears)
	  Netatalk 1.3.1	(so netatalk-admins appears)
File systems are clean, I just checked with fsck in single-user.

Problems SEEMED to start when I replaced netatalk-1.3 with netatalk-1.3.1.
The host oseille now panics about once a day with the following messages:

Apr  6 20:51:20 oseille vmunix: panic: getblk: size too big
Apr  6 20:51:20 oseille vmunix: syncing file systems... done
Apr  6 20:51:20 oseille vmunix: 00234 low-memory static kernel pages
etc.etc.

The message <<getblk: size too big>> appears in /sys/sun4/OBJ/vfs_bio.o.
No patch is installed for this file.

Is there a known bug in netatalk or in the kernel?
We have 2 other hosts using netatalk-1.3.1, they work well
but they have 2 differences:
- the host which panics has the heaviest load of the 3;
- the 2 others hosts are sun4m (SunOS 4.1.3 too).

Thanks in advance,

Jacques Beigbeder                    | Internet: [email-masked]
Service de Prestations Informatiques |
Ecole Normale Superieure             |
45 rue d'Ulm                         |     Tel : (33-1) 44-32-37-96
F75230 Paris Cedex 05                |     Fax : (33-1) 44-32-20-80

---

From: [email-masked]
Date: Thu, 07 Apr 1994 12:00:13 -0400

> From:    [email-masked] (Jacques Beigbeder)
> To:      [email-masked], [email-masked]

> Is there a known bug in netatalk or in the kernel?

There are currently no known netatalk panics (particularly not in the
kernel's file system code).  Not that it isn't possible.

:wes