Subject: HPLJIII takes forever to print a file from Mac

From: [email-masked] (Xiaoguang Zhang)
Date: Tue, 19 Apr 1994 10:27:19 -0500 (EDT)

I have papd running on a DEC 3100 with Ultrix 4.1. It takes *FOREVER* to
print a simple one page text from a Mac. One time when I tried to print
a graph it never came out and lpq showed "printer stalled, no progress for
15 hours". Is this normal? How can I fix it?
Below is my rc.atalk on the DEC. I'm running netatalk-1.3
#
# AppleTalk daemons. Make sure not to start atalkd in the background:
# its data structures must have time to stablize before running the
# other processes.
#

ATALKDIR="/"

#
# SUNOS: UNCOMMENT THESE LINES TO LOAD THE KERNEL MODULE.
#
##echo -n 'loading netatalk: '
##if [ -f ${ATALKDIR}/etc/netatalk.o ]; then
##	/usr/etc/modload -sym ${ATALKDIR}/etc/netatalk.o;
##fi

echo -n 'starting appletalk daemons:'
if [ -f ${ATALKDIR}/etc/atalkd ]; then
	${ATALKDIR}/etc/atalkd;		echo -n ' atalkd'
fi

if [ -f ${ATALKDIR}/bin/nbprgstr ]; then
	${ATALKDIR}/bin/nbprgstr -p 4 `hostname|sed 's/\..*$//'`:Workstation
					echo -n ' nbprgstr'
fi

if [ -f ${ATALKDIR}/etc/papd ]; then
	${ATALKDIR}/etc/papd -a;	echo -n ' papd'
fi

if [ -f ${ATALKDIR}/etc/afpd ]; then
	${ATALKDIR}/etc/afpd;		echo -n ' afpd'
fi

if [ -f ${ATALKDIR}/etc/timelord ]; then
	${ATALKDIR}/etc/timelord;	echo -n ' timelord'
fi

					echo '.'

---

From: Mark Smith <[email-masked]>
Date: Thu, 21 Apr 1994 12:16:37 -0400

>From:     [email-masked] (Xiaoguang Zhang)
>  To:     [email-masked] (netatalk netatalk)
>
> Below is my rc.atalk on the DEC. I'm running netatalk-1.3...

Is the long wait between the Mac and DEC or between the DEC and the printer?
In other words, does it take a long time to spool the job or does it take
a long time to send the job to the printer?  How is the printer attached
to the DEC (serial or AppleTalk)?  I would say a 15 hour or more wait is
not normal; my guess is that there is a communication problem between
netatalk and the printer.  What kind of printer is it?

-Mark