Subject: helping installing netatalk

From: [email-masked] (studarus)
Date: Thu, 18 Nov 93 15:28:56 PST

Hi, I need a little help installing netatalk.  I'm
using SunOS 4.1.2
	When I run getzones it only returns the one zone that I
have listed in atalkd.conf.  And nbplkup doesn't return any info
other than the one computer netatalk is running on.
	
	Here's my atalkd.conf file:

ifconfig ni0 121.0
ifconfig lo0 0.0
ni0 "SIOADM"
route ni0 lo0
zone SIOADM

	Another quirk:  Before I run atalkd ifconfig -a returns:

ni0: flags=63<UP,BROADCAST,NOTRAILERS,RUNNING>
        inet 132.239.123.152 netmask ffffffc0 broadcast 132.239.123.128
        ether 0:0:83:1d:0:8a 
lo0: flags=49<UP,LOOPBACK,RUNNING>
        inet 127.0.0.1 netmask ff000000 

	But afterwards I get:

ni0: flags=63<UP,BROADCAST,NOTRAILERS,RUNNING>
        inet 132.239.123.152 netmask ffffffc0 broadcast 132.239.123.128
        ether 0:0:83:1d:0:8a 
ni0: flags=63<UP,BROADCAST,NOTRAILERS,RUNNING>
        inet 132.239.123.152 netmask ffffffc0 broadcast 132.239.123.128
        ether 0:0:83:1d:0:8a 
lo0: flags=49<UP,LOOPBACK,RUNNING>
        inet 127.0.0.1 netmask ff000000 
lo0: flags=49<UP,LOOPBACK,RUNNING>
        inet 127.0.0.1 netmask ff000000 

	Is this normal?

	Thanks,

		-John
		[email-masked]

---

From: Charlie Clark <[email-masked]>
Date: Thu, 18 Nov 1993 18:36:05 -0500 (EST)

> 	Here's my atalkd.conf file:

Try using an atalkd.conf file that is as follows:
ni0

And that is it (this is assuming you are using netatalk 1.3bsomething, 
not netatalk 1.2.1).  If you are using 1.3something the rest of your 
network needs to be running AppleTalk Phase 2, and if you are using 1.2.1 
the rest of your network needs to be running Phase 1, or you won't see 
anything.

>         inet 127.0.0.1 netmask ff000000 

Yes.