Subject: problems using netatalk

From: [email-masked]
Date: Tue, 11 May 1993 15:56:31 +0100

Hi,

I installed netatalk (1.3a) the first time on my SUN IPX (OS 4.1.3).

netatlk.o is loaded without problems.
atalkd, nbprgstr, papd, and afpd started without problems, but they
doesn't work like expected.

I can't see my SUN from my Mac (also connected to Ethernet).
I can see my Mac (and other Macs in other zones) from my SUN (via nbplkup).
I can't see my SUN from my SUN.
I can't get a list zones (via getzones). 
  I get a "atp_rresp: Connection timed out". We have 30 zones, so should I
  increase a timeout?

Anyone any ideas?
  Thanx in advance,
     --cla

P.S.: My atalkd.conf looks like:
      le0 -phase 2 -net 129 -zone BackboneET
      # Why do I have to specify "-net 129" ?
      # Shouldn't netatalk be able to determine this by itself?

**********************************************************
German National Research Center for Computer Science (GMD)
Claus Riemann (I3.MMK)           Phone: (+49 2241) 14-2865
Postfach 1316                       [email-masked]
5205 Sankt Augustin 1              Don't dream it - Be it!

---

From: [email-masked]
Date: Wed, 12 May 1993 22:40:01 -0400

> From:    [email-masked]
> To:      [email-masked]

> I can't see my SUN from my Mac (also connected to Ethernet).

This is interesting.  Did you look in zones other than BackboneET?
1.3a is not real deterministic about what zone names appear in.

> I can't see my SUN from my SUN.

This doesn't work in 1.3a.

> I get a "atp_rresp: Connection timed out". We have 30 zones, so should I

See the README.  The code to support this in atalkd is just missing.
getzones does take an address as argument, if you're interested in
finding out what other routers think the zone list looks like.

> # Shouldn't netatalk be able to determine this by itself?

You don't have to specify -net.  atalkd will determine the network, the
range, and a zone list.

:wes