Subject: RS6K: pap replies No Such Printer

From: [email-masked] (John R. Cary)
Date: Tue, 3 Nov 92 8:45:23 MST

I am trying to get netatalk working on an RS6K/32H running AIX3.1.
I have afpd working, and now I am trying to get pap working.  I
used the LaserWriter Utility to name my printer "LaserWriter".  I then
do:

apas.root$ /usr/local/atalk/etc/pap -p LaserWriter test.text
LaserWriter[10112]: No Such Printer
/usr/local/atalk/etc/pap[10112]: send file failed

I tried to use nbplkup to see if any of my machines are in the NBP database.
They are not.  Must I register these first manually?

John Cary

-- 
--------------------------
John R. Cary                                  [email-masked]
Department of Astrophysical, Planetary and Atmospheric Sciences
University of Colorado, Boulder, CO 80309-0391
ph. (303) 492-1489                                   fax (303) 492-0642

---

From: Gordon Good <[email-masked]>
Date: Tue, 03 Nov 92 11:28:09 -0500

>/usr/local/atalk/etc/pap[10112]: send file failed

It sounds to me like the Apple LaserWriter Utility padded the
11-character name "LaserWriter" with a space at the end, so the printer
is really named "LaserWriter ".  Try:

/usr/local/atalk/etc/pap -p "LaserWriter " test.text

and see if that works.  I think it should, although your next statement

>They are not.  Must I register these first manually?

Do you mean you can't see the NBP name of the workstation running netatalk,
or that you can't see anything at all?  You might want to send the contents
of your atalkd configuration files to this mailing list if the above
fix doesn't work.

-Gordon

---

From: [email-masked] (John R. Cary)
Date: Tue, 3 Nov 92 10:01:55 MST

>/usr/local/atalk/etc/pap -p "LaserWriter " test.text

I tried this with no luck:
apas.cary$ /usr/local/atalk/etc/pap -p "LaserWriter " atalkd.conf
LaserWriter [5294]: No Such Printer
/usr/local/atalk/etc/pap[5294]: send file failed

>of your atalkd configuration files to this mailing list if the above

I see the workstation:
apas.cary$ nbplkup =:=@*
                           apas:AFPServer                          0.2:128
                           apas:Workstation                        0.2:4

but I was wondering if any of the netatalk utilities allow me to see the
other devices by name.  I have used aecho to see that there are
devices at 0.0,0.1,0.2,0.3,0.12.  I have six devices but one of these
is a NeXT with a flakey appletalk interface.  I do not know how to
tell which address goes with which device.  My atalkd.conf file is:

ifconfig en0 0.0
ifconfig lo0 0.0
en0 apas
route en0 lo0
zone apas

I presume the name, apas, which I want eventually in phase-2, means nothing
now.  I use this name for both the workstation name and the appletalk
zone name.

Hints?....Thx....John Cary

---

From: [email-masked]
Date: Thu, 05 Nov 92 12:56:03 -0500

> From:    [email-masked] (John R. Cary)
> To:      [email-masked] (Gordon Good)

> other devices by name.

> zone apas

There is a bug in the atalkd from netatalk-1.2.1, exercised by setting the
ethernet interface address to 0.0.  Here's the patch:

*** etc/atalkd/nbp.c-	1992/01/22 23:13:52
--- etc/atalkd/nbp.c	1992/03/31 05:25:25
***************
*** 138,144 ****
  	}
  
  	for ( rt = rtmptab; rt; rt = rt->rt_next ) {
! 	    if ( rt->rt_net != ATADDR_ANYNET && rt->rt_zt &&
  		    nbp_streq( rt->rt_zt->zt_zonelen, rt->rt_zt->zt_zone,
  			       zlen, zone )) {
  		sat.sat_addr.s_net = rt->rt_net;
--- 138,144 ----
  	}
  
  	for ( rt = rtmptab; rt; rt = rt->rt_next ) {
! 	    if ( rt->rt_zt &&
  		    nbp_streq( rt->rt_zt->zt_zonelen, rt->rt_zt->zt_zone,
  			       zlen, zone )) {
  		sat.sat_addr.s_net = rt->rt_net;

wes