Subject: Re: MMAXOFF not defined

From: Marcus D. Watts <[email-masked]>
Date: Sat, 26 Sep 92 21:38:04 EDT

I am looking into porting netatalk to AIX3.2 sometime "soon", can't
guarantee when yet (depends on other time constraints, and would actually
like to delay it a bit, so that I can use wes's new 1.3 atalkd daemon,
if feasible.)

I should introduce myself.  I'm part of the Umich Systems Group,
and one of our jobs is "IFS Deployment".  One of the key parts
of IFS is translating file protocols, and we use a slightly
modified version of netatalk for this purpose.  I'm the (lucky?)
guy who gets to deploy and debug netatalk, so I get to discover
all those deep dark moldy secrets nobody else wanted to deal with.
When I started, we were running netatalk 1.1 on RT's.  Since
coming here, I've brought up 1.1 on AIX3.1 / RS6K's, then 1.2 phase 1,
with a series of evolutionary enhancements to increase reliability,
and then, "mostly" 1.2 on "mostly" phase 2 but still AIX3.1 -- this
is what we're running right now.  (I say "mostly" because it's
actually 1.1 updated to 1.2 (not my doing) but including many of those
evolutionary improvments, but the phase 2 appletalk support
is still somewhat deficient.  In short, pure mutt.)  I should
mention that there is a 3rd element here in the triangle involving
development work of netatalk and RS/6K's here at the U -- CITI,
which did the initial port of netatalk to RS/6K's, and more recently
implemented appletalk phase 2 support in netatalk.  You can send
mail to "[email-masked]" if you want more information on CITI.
Wes and CITI are, variously, really more interested in off-campus
use of netatalk than am I.  I admit my interest in you is
largely selfish -- can you find all the problems in porting
netatalk to aix3.2 before I have to?

The messages you got regarding MMAXOFF point precisely to the
part of aix3.2 that is quite different--networking; it
indeed uses 4.3bsd-reno style networking, and as a first step,
you should definitely try defining BSD4_4 because the piece of
code it enables in aarp.c looks exactly like what you need for AIX3.2.

I'm not sure what other complications you'll face.  One of the nuisances
I know of, is that in AIX3.1, there was a lot of weirdness about
splx.  Some things were run with kproc's, others at
interrupt level, so selecting between splx (which actually
just serialized access to data structures shared
with the kproc), and i_enable (which actually played
with the process interrupt mask) was a bit strange.
Another issue in 3.1, is that aarpinput actually has 3
parameters -- the third is an mbuf that, if not freed,
causes an mbuf leak that, when production here at the UM,
would cause the machine to hang about once a week.

The result is definitely somewhat overblown, and I suspect,
part of the reason that RS/6K's were just not quite as good
at network processing as one might expect.  Still, with
changes for 3.1 to account for various weirdnesses, I've
been able to get a machine that seems to be pretty steady,
under constant use, for months at a time.  This is
distinctly more reliable than our network, or
for that matter the IFS file servers, so I can
hardly complain.  The last reboot, in fact, was
due to the air conditioning failing in the machine
room, and even then, more out of paranoia (94 F?!)
than any real need.

It looks like, in AIX3.2, you can forget much of this,
for which you ought to be properly thankful.
splx & friends now just call i_disable/i_enable,
so a lot of the former complication goes away.  I think.
The stuff about device writes ist still true, though,
so that could still be an issue.  The extra 3rd
parameter to arpinput is also still there, but now
it's a simple pointer not an mbuf, and whatever
created it worries about freeing it elsewhere, so
I think you can pretend it doesn't exist.  All in all,
it looks like 3.2 might be very straight forward -- just
pretend it's berkeley 4.3bsd-reno, only not quite -- a
lot of the problems I had to deal with in AIX3.1 just
aren't there anymore.  Of course, who knows what
*new* dark moldy secrets are lying in wait...

I'd certainly be very interested in your luck getting
things to run under AIX 3.1.

				-Marcus Watts
				UM ITD RS Umich Systems Group

---

From: peter honeyman <[email-masked]>
Date: Mon, 28 Sep 92 09:42:23 -0400

for information about the center for information technology integration, 
send mail to [email-masked] instead of the address given by mdw.

	peter