Subject: installation problem

From: [email-masked] (Felicia Cheng)
Date: Fri, 4 Sep 1992 09:58:27 EDT

Hi, 

I have installed netatalk version 1.2.1, however, when 
I rebooted the system, I show the following error message,
I have already added etc.services on the server machine,
and did a make of the YP ( the machines are running Sun OS 4.1.2).
on inis4, ypcat services can see those services. 

what have I missed ?

Sep  3 19:05:27 inis4 papd[145]: pap_slinit
Sep  3 19:05:27 inis4 papd[145]: initialize: Protocol not supported (exiting)

the papd.conf file 
-------------------

# This file consists of a keyword and value colon separated pair,
# one per line. Everything after the colon is significant, so
# don't insert white space unless you want the values to contain
# them. Papd also doesn't like blank lines.
#
# File containing list of fonts resident in printer we spool to
fontfile:/var/spool/atalk/LWPlusFonts
#
# Location of printcap
printcap:/etc/printcap
#
# Directory to store Macintosh procedure sets in.
#procsetdir:/var/spool/lpd/papd-procsets
printer:r4111
#
# Name to appear in the Macintosh chooser
choosername:Unix Spooler

thanx
felicia

---

From: peter honeyman <[email-masked]>
Date: Fri, 04 Sep 92 12:10:14 -0400

is atalkd running?

	peter

---

From: [email-masked]
Date: Fri, 04 Sep 92 12:35:08 -0400

> From:    [email-masked] (Felicia Cheng)
> To:      [email-masked]

> Sep  3 19:05:27 inis4 papd[145]: initialize: Protocol not supported (exiting)

This message generally indicates that the netatalk loadable module has
not been stuffed into the kernel. There is some mention of adding
something like

	modload -sym -entry at_entry netatalk.o

to your /etc/rc, in the README.SUN file. This is the code which
allows your sun to have AF_APPLETALK sockets.

Peter also mentioned that you may not be running atalkd. atalkd is the
process which is responsible for maintianing routing tables and doing
NBP. You'll need to start it in /etc/rc also.

wes